处理已放置的元件
概览
- 了解元件的来源、部件和多部件元件的处理方式,以及将它们放置到原理图上的主要方法。
- 了解如何更高效地搜索元件,以及如何在放置过程中或放置后快速进行图形编辑。
- 理解原理图元件与 PCB 元件之间的对应关系,以及放置后可以查看或编辑的核心属性。
库中的元件代表放置在实际印制电路板上的物理器件。在原理图图纸上,元件由其原理图符号模型表示。每个元件可以包含一个或多个部件。
部件
概述
部件是一种电气设计图元,是表示电阻、开关、运算放大器、稳压器等电子器件的原理图符号。部件存储在原理图元件库的元件中。请注意,每个元件可以包含一个或多个部件。除了元件的符号表示外,部件还包含指向 PCB 封装等模型的链接,以及用于记录元件参数、供应商信息等详细资料的参数。向部件添加模型链接和参数的方式取决于所使用的库存储类型。
可用性
在原理图编辑器和原理图库编辑器中均可放置部件。
- 在原理图编辑器中,单击 Place » Part。
- 在设计空间中右键单击,然后从右键菜单中选择 Place » Part。
- 在 元件面板中,右键单击某个元件并选择 Place <ComponentName>。
- 在 Components 面板中,选择一个通用元件作为占位符。
- 从 Components 面板中拖放元件。
- 选择 Components 面板的 Details 窗格中的 Place 按钮,或使用 Enter 快捷键。
- 在原理图库编辑器中,从 SCH Library 面板选择一个元件,然后单击 Place。
从元件面板放置
在原理图编辑器中,可以通过 Components 面板选择和放置部件。
- 面板显示当前所选库的内容。使用库名称旁的 下拉列表可选择其他库。
- 使用当前所选库字段下方的筛选字段 筛选列表以加快搜索, 也可以滚动列表并选择所需的部件。
- 单击 Place、双击元件,或单击并拖动,即可将所选元件放置到当前原理图图纸上。当部件悬浮在光标上时,可以在放置前将其旋转(按 Spacebar)、沿某个轴镜像(按 X 或 Y)或进行编辑(按 Tab)。
- 当前所选库的元件列表中显示的列可以重新排列(单击并拖动),也可以重新配置(右键单击,然后选择 Select Columns)。
-
单击通用元件磁贴中的
按钮,即可将元件附着到光标上,以便放置到当前原理图文档中。选择磁贴本身则会在 Components 面板中打开该元件类型的类别。
搜索元件
非工作区库的菜单选项可用于设置首选项、执行搜索,以及迁移数据库库和基于文件的库的内容。要访问这些选项,请选择 Components 面板右上角的库菜单
按钮。
选择 File-based Libraries Preferences 可打开 可用的基于文件的库对话框,其中提供了用于添加或删除库、安装库以及指定库搜索路径的控件。
在 Components 面板的 Search 字段中输入搜索短语,即可筛选当前列出的数据库库和基于文件的库中的元件。要使用更高级的元件库搜索功能,请从面板右上角的
菜单中选择 File-based Libraries Search 选项,打开基于文件的库搜索对话框。此对话框提供灵活的搜索选项,包括基于查询的筛选条件,并支持搜索所有可用的数据库库和基于文件的库,或指定路径中的库。
- 默认搜索 Scope 是在 Available File-based Libraries 中搜索 Components。
- 此外,此对话框还支持搜索存储在驱动器文件夹中的 Libraries on path。 为此,请启用 Libraries on path 选项, 然后根据需要配置 Path 选项。
- Filters 使用“AND”逻辑, 因此, 最好先使用简单的 筛选条件;如果结果较多, 再使用 Refine last search 模式在结果中搜索。
- 选择 Helper 后,查询搜索结果将显示在 File-based Libraries Search 对话框中。
从原理图库编辑器放置
也可以通过 SCH 库面板, 直接从原理图库编辑器中打开的库放置部件。 请注意:
- 单击面板中的 Place 按钮,会将所选部件(元件)放置到上次激活的原理图图纸中。
- 当部件悬浮在光标上时,可以在放置前将其旋转(按 Spacebar)、沿某个轴镜像(按 X 或 Y)或进行编辑(按 Tab)。拖动对象时也可以执行这些操作。每次旋转的角度为 90°。
-
如果直接从库中放置部件,则无需事先在可用的基于文件的库对话框中添加该库。
图形化编辑
部件的图形化编辑仅限于移动、旋转和镜像。在设计空间中选中部件后,其周围会显示一个虚线选择框。要以图形方式操作所选元件:
- 按 Delete 可从设计中删除所选部件。
- 单击并按住鼠标可移动所选部件。光标将跳转到最近的电气热点(最近引脚的接线端)。
- 按 Spacebar 可逆时针旋转圆弧,按 Shift+Spacebar 可顺时针旋转。拖动对象时也可以执行此操作。每次旋转的角度为 90°。
- 当部件随光标移动时,按 X 或 Y 键可沿相应轴将其镜像。
在原理图元件与 PCB 元件之间协同操作
软件提供了一些工具,便于在原理图元件与 PCB 上的同一元件之间协同操作。这些工具包括交叉探查、交叉选择以及从原理图选择 PCB 元件。
交叉探查
顾名思义,交叉探查允许您在一个编辑器中单击某个元件,然后跳转到另一个编辑器中的同一元件。要执行交叉探查:
- 单击原理图或 PCB 编辑器的 Tools 菜单中的 Cross Probe。
- 在原理图编辑器中单击元件后,PCB 编辑器会将该元件居中显示并缩放。缩放级别可在 Preferences 对话框的 系统 – 导航页面上设置。
- 默认情况下,您会留在当前编辑器中,以便继续交叉探查其他元件。若要在交叉探查时切换到另一个编辑器,请按住 Ctrl 键。
交叉选择模式
交叉选择模式会在另一个编辑器中选中同一元件。请注意,此模式不会缩放或居中显示元件。交叉选择只有开启和关闭两种状态。单击 Tools » Cross Select Mode 可开启或关闭此模式。按住 Shift 键并依次单击,可选择多个元件。
选择 PCB 元件
此功能允许您按特定顺序选择多个原理图元件,然后在 PCB 编辑器中按相同顺序放置这些元件。要使用此功能:
- 逐个选择原理图上的元件(按住 Shift 并单击可选择多个元件)。
- 切换到 PCB 编辑器,然后按 I, C 快捷键启动 Reposition Selected Components 命令。按 I 快捷键后,也可以在右键菜单中找到 Reposition Selected Components 命令。
部件属性
常规选项卡
常规
-
Reuse Block – 当元件属于某个复用块时,此字段显示其父复用块的名称。单击 Reuse Block 超链接可查看此复用块的属性。
-
Designator – 输入位号。单击眼睛图标可显示或隐藏位号。使用锁定图标可锁定或解锁位号。了解有关位号的更多信息。
-
Comment – 输入名称或注释。单击眼睛图标可显示或隐藏名称。使用锁定图标可锁定或解锁名称。Comment 字段也可用于显示用户定义参数或系统参数的值。了解有关注释的更多信息。
-
Part <x> of Parts – 显示所选部件的编号和部件总数。单击
可锁定或解锁这些字段,然后使用下拉列表选择相应部件的编号。
-
Description – 元件/部件的描述。
-
Type – 在此为元件封装选择以下元件类型之一。可用类型包括:
-
Standard– 具有标准电气属性的元件,始终在原理图与 PCB 之间保持同步(封装、引脚/焊盘及网络分配必须全部匹配),并包含在 BOM 中。例如电阻等标准电气元件。 -
Mechanical– 不具有电气属性的元件,不进行同步(必须在两个编辑器中分别手动放置),并包含在 BOM 中。例如散热器。 -
Graphical– 不具有电气属性的元件,不进行同步(必须在两个编辑器中分别手动放置),并且not包含在 BOM 中。例如公司徽标。 -
Net Tie (In BOM)– 用于将两个或多个不同网络短接在一起的元件,始终在原理图与 PCB 之间保持同步(封装、引脚/焊盘及网络分配必须全部匹配),并包含在 BOM 中。与标准元件不同,此类元件不会检查封装内部铜箔形成的连接;正是这些铜箔实现了网络短接。注意:请在 设计规则检查器对话框中启用 Verify Shorting Copper 选项,以验证元件内部是否存在未连接的铜箔。 -
Net Tie (No BOM)– 用于将两个或多个不同网络短接在一起的元件,始终在原理图与 PCB 之间保持同步(封装、引脚/焊盘及网络分配必须全部匹配),并且not 包含在 BOM 中。与标准元件不同,此类元件不会检查封装内部铜箔形成的连接;正是这些铜箔实现了网络短接。注意:请在 设计规则检查器对话框中启用 Verify Shorting Copper 选项,以验证元件内部是否存在未连接的铜箔。 -
Standard (No BOM)– 具有标准电气属性的元件,始终在原理图与 PCB 之间保持同步(封装、引脚/焊盘及网络分配必须全部匹配),并且not包含在 BOM 中。例如您希望从 BOM 中排除的测试点元件。 -
Jumper– 用于在 PCB 设计中添加跳线的元件,例如用于无法在单层上完成全部布线的单面 PCB。对于此元件类型,元件封装和引脚会在原理图与 PCB 之间同步,但网络分配不会同步,且该元件包含在 BOM 中。除了在元件级别选择此选项外,还必须将元件中两个焊盘的 JumperID 设置为相同的非零值。跳线类型元件不需要在原理图上接线;只有需要将其包含在 BOM 中时,才需要将其添加到原理图中。如果不需要将其包含在 BOM 中,则可以直接将其放置在 PCB 上,在其中设置 Component Type 和 JumperIDs,并为焊盘手动分配 Nets。
-
-
Design Item ID – 此字段列出所选元件的名称(对于工作区元件),以及在 Field Settings中定义的所选关键字段 区域(对于数据库库元件),或为元件符号定义的 Design Item ID 参数(对于基于文件的库元件)。单击
可打开替换元件对话框。通过此对话框,您可以访问所选元件的完整详细信息(参数、模型、备选器件、供应商数据等)、比较元件,以及将当前元件替换为其他元件等。如果选择其他元件进行替换, 此字段随后将显示新选定元件的完整 Design Item ID。单击 Validate 按钮(
)可显示元件的存储位置信息。如果元件不在工作区中,则会显示其在计算机上的保存路径。如果元件位于工作区中,则仅会提示已找到该元件。
-
Source – 显示元件源库的名称。单击
可搜索并选择所需的库。
-
Revision status – 如果所选元件修订版处于适用状态(允许在设计中使用),此项将指示该修订版是否为最新版本(
Up to date表示是,Out of date表示否)。如果修订版处于不适用状态(不允许在设计中使用),此项将显示Not applicable。单击
按钮可将元件更新为最新修订版。
-
Component issues(仅限 Properties 面板)– 如果所选元件来自当前连接的 Altium 365 工作区,且存在任何健康问题,则会显示
(表示错误)或
(表示致命错误)图标。图标右侧的数字表示发现的问题数量。单击数字右侧的向下箭头可查看问题的简要描述。

发现库健康问题的示例。 -
Supply Chain Data(仅限 Properties 面板)– 显示相关备选器件的供应链 信息:
- 单位价格中位数。如果没有价格或价格为 0,此项将显示为红色。
- 库存。此项显示为工作区的 Altium Parts Provider 来源启用的所有供应商的可用库存总量。
-
制造商生命周期状态条。将鼠标悬停在状态条上可查看提示信息。此状态条可呈现以下四种状态之一:
- 白色/灰色 = 默认、未知或无信息
- 绿色 = 新产品或量产状态
- 橙色 = 不推荐用于新设计
- 红色 = 已停产或生命周期结束(EOL)
位置
-
(X/Y)
- X (第一个字段)– 对象参考点相对于当前设计空间原点的当前 X(水平)坐标。编辑此值可更改对象的 X 位置。该值可以使用公制或英制单位输入;如果输入值的单位不是当前默认单位,请同时注明单位。
- Y (第二个字段)– 对象参考点相对于当前原点的当前 Y(垂直)坐标。编辑此值可更改对象的 Y 位置。该值可以使用公制或英制单位输入;如果输入值的单位不是当前默认单位,请同时注明单位。
-
Rotation – 使用下拉列表选择旋转角度。可选项为
0 Degrees、90 Degrees、180 Degrees和270 Degrees。
参数
-
Grid – 列出与当前所选元件关联的参数的 Name 和 Value。使用
锁定/解锁列出的参数,防止其 被更新。参数值可以手动输入,也可以从下拉列表中选择,该列表提供此类型所有可用元件的参数值。您可以切换眼睛图标以显示/隐藏参数。
-
Favorites – 标记为收藏的参数将显示在参数列表中,未标记的参数则会隐藏。将鼠标悬停在参数筛选器名称的右侧,然后单击
图标,将该筛选器设为收藏。 要取消收藏某个参数,请再次单击该图标。
要查看所有隐藏的参数,请单击列表底部的 Show More 控件。单击 Show Less 控件可仅查看收藏的参数。
-
Font – 单击显示的字体可更改字体样式。
-
Other – 单击可打开下拉菜单,更改其他选项:
- Show Parameter Name – 启用以显示参数名称。
- Allow Synchronization with Database – 启用以与数据库同步。此选项用于控制注释是否可以更新。默认情况下,这些选项处于启用状态, 以始终允许与源库/数据库同步。您可以禁用此选项,防止该注释被纳入更新过程。
- (X/Y) – 输入 X 和 Y 坐标。
-
Rotation – 使用下拉菜单选择旋转角度。可选值为:
0°、90°、180°和270°。 - Autoposition – 勾选以启用自动定位,这意味着每次旋转关联元件时, 参数 都会自动定位。禁用此选项可在旋转关联元件时,保持参数相对于元件的位置不变。
-
Add – 单击 可添加参数,例如封装、模型或规则等。单击
可从表格中删除所选条目。单击
可通过参数对应的对话框编辑该参数。
图形
-
Mode – 使用下拉菜单选择所需模式。如果除 Normal 之外没有其他可用模式,此下拉菜单将呈灰色显示。
- Mirrored – 启用以镜像部件。
- Local Colors – 启用局部颜色选项后,原理图元件的填充、线条和引脚颜色将分别被 Fill、 Lines 和 Pins 颜色框中的颜色覆盖。禁用此选项可使用库中预定义的颜色。
器件选型
此区域提供分配给所选元件的器件选型和供应商链接信息。 有关本区域各条目所提供信息的更多说明,请参阅为元件添加供应链信息 页面。
引脚选项卡
-
Grid – 此区域列出所选元件所有引脚的 Pins 和 Names。使用眼睛图标 可显示/隐藏引脚。使用锁定图标 可锁定/解锁引脚。
对于多功能引脚(即在属性面板的引脚模式下的 Functions 字段中指定了功能的引脚),请单击该引脚在 Name 列中的单元格,然后在出现的下拉菜单中选择引脚功能。所选功能将作为引脚名称显示在原理图图纸上。
- Show Full/Show Short - 在 Show Full 模式下,显示所有列出引脚的完整扩展引脚名称;在 Show Short模式下,显示当前引脚名称。
-
– 启用此按钮时(闭合的锁图标),无法在原理图编辑器中编辑元件引脚(但可以在原理图库编辑器中编辑)。禁用此选项可在原理图图纸上编辑元件引脚。
-
– 单击可显示所有隐藏引脚及引脚属性(名称和编号),包括在元件引脚编辑器中禁用了 Show 属性的引脚。请注意,如果您正在原理图库编辑器中工作,还必须启用 View » Show Hidden Pins 选项,才能在库编辑器中显示隐藏引脚。
-
– 单击可向元件添加引脚。在 Properties 面板中配置引脚,然后单击并拖动以将其定位。
-
– 单击可从元件中删除选定的引脚。
-
– 单击可打开元件引脚编辑器对话框。通过此对话框,可以方便地查看和编辑原理图库编辑器中当前打开的元件的所有引脚,或原理图编辑器中所选元件(或其部分单元)的所有引脚。
通用元件属性
通用元件
当 Altium Designer 连接到工作区时,可从 Components 面板访问可用的通用元件。在 Categories 窗格中选择 All 选项后,即可显示这些元件;当面板处于紧凑模式时,也可从顶部下拉菜单中访问。单击通用元件磁贴中的
按钮,可将元件附着到光标上,以便放置在当前原理图中。选择磁贴本身将在 Components 面板中打开相应的元件类型类别。
通用元件属性
常规
- Designator – 输入位号。切换眼睛图标以显示或隐藏位号。单击锁图标 可锁定或解锁位号。
- Comment – 输入名称。切换眼睛图标以显示或隐藏名称。
-
Description – 通用元件/单元的描述。
- Replace – 当设计进展到可以使用特定实体元件替换通用元件的阶段时,选择 Replace 按钮,通过 替换元件对话框进行替换。
位置
-
(X/Y)
- X(第一个字段)– 对象参考点相对于当前设计空间原点的当前 X(水平)坐标。编辑此值可更改对象的 X 位置。可以使用公制或英制单位输入数值;如果输入值的单位不是当前默认单位,请在输入时注明单位。
- Y(第二个字段)– 对象参考点相对于当前原点的当前 Y(垂直)坐标。编辑此值可更改对象的 Y 位置。可以使用公制或英制单位输入数值;如果输入值的单位不是当前默认单位,请在输入时注明单位。
- Rotation – 使用下拉菜单选择旋转角度。
参数
- Grid – 列出与当前所选元件关联的参数的 Name 和 Value。使用锁图标 可锁定或解锁列出的参数。参数值可以手动输入,也可以从下拉菜单列表中选择,列表中的值来自该类型的所有可用元件。您可以使用眼睛图标显示或隐藏参数。
- Font – 单击显示的字体可更改字体样式。
-
Other – 单击可打开下拉菜单,以更改其他选项:
- Show Parameter Name – 启用可显示参数名称。
- Allow Synchronization with Database – 启用可与数据库同步。此选项用于控制注释是否可以更新。默认情况下,这些选项处于启用状态,始终允许与源库/数据库同步。您可以禁用此选项,以防止该注释在更新过程中被更新。
- (X/Y) – 输入 X 和 Y 坐标。
- Rotation – 使用下拉菜单选择旋转角度。
- Autoposition – 勾选可启用自动定位,即每次旋转关联元件时,都会自动定位参数。禁用此选项可在关联元件旋转时保持参数相对于该元件的位置。
位号
位号用于唯一标识设计中的每个元件。
概述
位号字段是原理图元件(单元)的子参数对象。它用于唯一标识每个已放置的单元,以便将其与项目中所有原理图图纸上放置的其他单元区分开来。
可用性与放置
放置父级元件单元对象时,会自动放置位号。 它不是可以直接放置的设计对象。
图形化编辑
位号字符串可以通过称为in-place编辑的方式进行图形化编辑。要就地编辑位号字符串,请拖动光标框选位号,然后按 Enter 键。

就地编辑示例
编辑完成后,按 Enter 或单击字符串以外的位置,即可退出就地编辑模式。
非图形化编辑
编辑位号时需要考虑两个方面:编辑位号值,以及编辑位号的显示属性。
位号(及注释)字符串可以显示在原理图库编辑器中,双击即可编辑其属性。Properties 面板中与该字段关联的
图标用于显示或隐藏位号。
在原理图编辑器中编辑位号值
在 Properties panel中,可以在放置元件时或将元件放置到原理图图纸上之后,在原理图编辑器中定义位号。
-
要在放置元件时编辑位号,请在元件悬浮于光标上时按 Tab 键。随后将打开 Properties 面板;输入所需的位号字符串。 单击设计空间中的暂停按钮浮层(
)以继续放置。
- 继续放置元件, 或按 Esc 结束放置。
- 按 Spacebar 可逆时针旋转圆弧,按 Shift+Spacebar 可顺时针旋转。拖动对象时也可以执行此操作。每次旋转的增量为 90°。
- 要在放置后编辑位号,请双击已放置的元件,打开 属性 面板,然后在其中编辑位号。
编辑位号显示属性
位号字符串的外观(包括字体、字号和颜色)可以在 Preferences 对话框的 原理图 - 默认值 页面上配置。 除非原理图库编辑器中元件符号所定义的设置覆盖了这些设置,否则将应用这些设置。
固定位号字符串的位置
位号的默认行为是在放置过程中随元件旋转而自动调整位置。如果不需要此行为,可以在创建符号时或将元件放置到原理图图纸上之后,关闭 Preferences 对话框中的 Autoposition 选项(参见上图)。请注意,这样会将此参数归类为 manual parameter(即手动定位的参数)。手动定位参数的选择框左下角会显示一个圆点,以便识别。
注意事项
-
原理图编辑器提供了简单的位号自动递增功能,可在放置同一器件的多个实例时使用。要使用此功能,请在第一个元件悬浮于光标上时按 Tab,然后输入合适的位号,例如
R1。后续元件的位号将依次为R2、R3等。请注意,切换为放置其他类型的元件时,必须再次按 Tab 并输入合适的位号前缀。 -
放置多子部件元件时,如果按照上述方式指定了初始位号,系统会自动分配子部件后缀,例如
U3A、U3B等。 如果未指定初始位号,所有子部件都将具有相同的后缀。可以使用原理图编辑器的 Annotation 命令解决此问题。子部件后缀可以是字母或数字。使用 Preferences 对话框中 原理图 - 常规 页面上的 Alpha Numeric Suffix 选项进行配置。
位号属性
位置
-
(X/Y)
- X (第一个字段)- 对象参考点相对于当前工作区原点的当前 X(水平)坐标。编辑此值可更改对象的 X 位置。可以输入公制或英制值;如果输入值的单位不是当前默认单位,则需同时输入单位。
- Y (第二个字段)- 对象参考点相对于当前原点的当前 Y(垂直)坐标。编辑此值可更改对象的 Y 位置。可以输入公制或英制值;如果输入值的单位不是当前默认单位,则需同时输入单位。
- Rotation - 使用下拉列表选择旋转角度。
属性
- Object - 显示关联的对象。
-
名称 - 单击可见性图标(
)启用此字段,可在位号值本身前添加“Designator:”前缀。这样可以在原理图文档中直观地区分并确认该文本值为位号。
-
Value - 显示位号名称本身。 切换眼睛图标
可显示/隐藏该值。
- 自动定位 - 勾选以启用自动定位,这意味着当元件移动和旋转时,文本将保持在所选位置。
- 锁定参数 - 勾选以锁定参数,防止从 Properties 面板或原理图文档中编辑其值。
- 允许与数据库同步 - 启用后可与数据库同步。此选项用于控制是否可以更新注释。默认情况下,这些选项处于启用状态, 以始终允许与源库/数据库同步。您可以禁用此选项,防止该注释包含在更新过程中。
- 字体 - 使用这些控件选择字体、字号和字体颜色,并根据需要为字体添加特殊样式,例如粗体、斜体和下划线。
- 对齐方式 - 单击箭头可配置文本的对齐方式,单击圆圈可将其居中。
- Override Library Primitive(仅限 Preferences 对话框)- 勾选此复选框,可覆盖库中为位号对象定义的图元设置。因此,放置元件时,将采用您在“首选项”对话框中定义的图元设置,而不是库中为该元件定义的设置。
注释
注释可用于显示元件的附加信息。
概述
注释字段是原理图元件(器件)的子参数对象,用于显示有关元件的附加信息。
可用性与放置
注释在放置其父元件器件对象时进行配置。 它不是可以直接放置的设计对象。
图形化编辑
可以通过所谓的 in-place 编辑,以图形方式编辑注释(Comment)。要就地编辑注释,请单击将其选中,稍停一秒,然后再次单击以进入编辑模式。
编辑完成后,按 Enter 或单击字符串以外的位置,即可退出就地编辑模式。
非图形编辑
编辑注释时,需要考虑两个方面:编辑注释的值和编辑注释的显示属性。
在原理图编辑器中编辑注释
在原理图编辑器中,可以在放置元件期间,或将元件放置到原理图图纸上之后,通过 Properties 面板的 Comment 字段定义注释。
-
要在放置元件期间编辑注释,请在元件悬浮于光标上时按 Tab 键。此时将打开 Properties 面板;输入所需的注释。 单击设计空间中的暂停按钮浮层(
),即可继续放置元件。
- 继续放置元件,或按 Esc 结束放置。
- 要在放置后编辑注释,请双击已放置的元件以打开 属性 面板,然后在其中编辑注释。
编辑注释显示属性
可以在 Preferences 对话框的 原理图 - 默认值 页面上配置注释的外观,包括字体、字号和颜色。
固定注释的位置
默认情况下,在放置期间旋转元件时,注释会自动定位。如果不需要此行为,可在创建符号期间,或将元件放置到原理图图纸上之后,禁用 Preferences 对话框中的 Autoposition 选项(请参阅上一张图片)。请注意,这样会将此参数归类为 manual parameter(即手动定位的参数)。手动参数的选择框左下角带有一个圆点标记。
注释属性
位置
-
(X/Y)
- X (第一个字段)- 对象参考点相对于当前设计空间原点的当前 X(水平)坐标。编辑此值可更改对象的 X 位置。可以使用公制或英制输入数值;如果输入值的单位与当前默认单位不同,请同时输入单位。
- Y (第二个字段)- 对象参考点相对于当前原点的当前 Y(垂直)坐标。编辑此值可更改对象的 Y 位置。可以使用公制或英制输入数值;如果输入值的单位与当前默认单位不同,请同时输入单位。
- Rotation - 使用下拉列表选择旋转角度。可选项为: 0 Degrees、 90 Degrees、 180 Degrees 和 270 Degrees。
属性
- 元件 - 显示关联元件的名称。单击 Component 链接可打开 部件属性面板,在其中可以编辑元件选项,以及在该面板的 Comment 字段中定义的 注释本身。
-
名称 - 单击可见性图标(
)启用此字段,即可在注释值前添加“Comment:”前缀。这样便能从视觉上区分并确认该文本值是原理图文档中的注释。
-
值 - 显示注释名称本身。切换(
)可显示/隐藏该值。
- 自动定位 - 勾选可启用自动定位,这意味着当元件移动和旋转时,文本将保持在所选位置。
- 锁定参数 - 勾选可锁定参数,防止从 Properties 面板或原理图文档中编辑该值。
- 允许与数据库同步 - 启用后可与数据库同步。此选项用于控制是否可以更新注释。默认情况下,此选项处于启用状态,始终允许与源库/数据库同步。可以禁用此选项,防止在更新过程中包含该注释。
- 字体 - 使用这些控件选择字体、字号和字体颜色,并为字体添加所需的特殊样式,例如粗体、斜体和下划线。
- 对齐方式 - 单击箭头配置文本的对齐方式,或单击圆圈使其居中。
- Override Library Primitive(仅限 Preferences 对话框)- 启用此复选框可覆盖库中为注释对象定义的图元设置。因此,放置元件时,将采用您在 Preferences 对话框中定义的图元设置,而不是库中为该元件定义的设置。
从库更新和替换元件
将元件初次放置到电路板设计的原理图图纸上之后,就需要一种方法,根据相应工作区中所链接源元件的任何更改,更新这些元件实例。换言之,需要一种方法,使设计与其使用的工作区实体保持同步。
例如,某个元件可能已重新保存到工作区,其中可能包含对子模型的更改。这会生成该元件的新修订版。此时,该元件的已放置实例仍在使用旧修订版,您可能希望将其更新为最新修订版。或者,您可能决定改用完全不同的元件,只需将设计中的现有元件替换为另一个元件。
将元件初次放置到设计中后,可以通过多种方式对其进行管理。
更改单个元件实例
每个已放置的元件都链接到工作区中的相应元件修订版。查看所选元件的属性时,可以在 Properties 面板中找到此信息。
在这一最基本的单个元件级别,可以对已放置的实例执行以下操作:
-
单击
按钮,将现有元件更新为最新修订版。
将同一元件更新为最新修订版的示例——将鼠标悬停在图像上可查看结果。
-
单击 Design Item ID 字段右侧的
按钮,将其替换为另一个工作区元件(替代元件)的最新修订版,或基于文件的库元件。Replace Component 对话框随即打开,显示已连接工作区中的元件以及可用的基于文件的库中的元件。当前元件显示在列表顶部。搜索所需的替代元件,将其选中,然后单击 OK。
Replace Component 对话框可直接访问所有可用的工作区库元件和基于文件的库元件。 该对话框提供所选元件的完整详细信息(参数、模型、器件选型、供应商数据等)以及元件比较功能;对于 工作区库元件,还提供基于筛选器的参数化搜索功能,用于指定目标元件参数。
替换元件对话框的选项和控件
- Search - 使用搜索文本框手动搜索特定元件。
-
- 单击以展开或折叠 Categories 窗格,从而显示特定类型的元件或所有可用元件。使用 Categories 窗格下方的搜索栏,可手动搜索特定元件类别或可用的基于文件的元件库。
-
- 单击以访问菜单并选择以下选项:
- File-based Libraries Preferences - 单击以打开 可用的基于文件的库对话框,以添加或移除库。
- File-based Libraries Search - 单击以打开 基于文件的库搜索对话框,以搜索库。
- Refresh - 单击以刷新对话框。
-
- 单击以打开/关闭对话框的 Details 区域 (如下所述)。
筛选器
选择工作区元件类别后,单击 Filters 图标(
)可打开 Filters 区域,在此可进一步筛选 Components 列表中选定的类别。可以根据需要自定义面板的 Filters 选项,将特定参数类型设为 Favorites,这些参数类型随后会移至当前元件类别列表的顶部。将鼠标悬停在参数筛选器名称的右侧,然后单击(
)图标,可将该筛选器设为收藏项。收藏筛选器设置会应用于各个元件 Categories,并分别保存。
元件
- Name - 元件的名称。
- Description - 每个元件的描述。
- Footprint - 元件的封装。
- Results - 列出搜索中找到/列出的元件总数。
详细信息
- Component Revision ID - 列出给定元件的修订版 ID 和价格。单击修订版 ID 可打开 Explorer 面板,以获取有关元件的更多信息。
- References - 单击以在 Web 浏览器中打开元件的参考信息。使用下拉菜单可访问 Manufacturer URL 或 Datasheet。
- Place - 单击以将所选元件放置到原理图文档中。
- Component information - 列出元件的相关信息,包括制造商、发布日期和描述信息。单击 Show More 链接可查看所有信息;单击 Show Less 可折叠这些信息。
- Models - 展开以查看提供的模型。使用可用链接可显示单个模型的不同部分。
- References - 展开以访问 Manufacturer URL、Datasheet 和 Package Specification。
- Part Choices - 展开以查看器件选型。其中提供名称、价格和描述,还会列出元件的数据手册。
- Where Used - 展开以查看使用该元件的项目。
右键菜单
- Find Similar Components - 单击以打开 查找相似元件对话框,在其中可以搜索具有相似特征的其他元件。
- Place <component> - 单击以将元件放置到相应的文档中。
- Edit - 单击以打开所选元件的元件库文档。
- Navigate to <revision> - 单击以在 Explorer 面板中打开所选元件。
- Operations - 将鼠标悬停于此,可访问 Submit Request、Create、Download、Clone、Change Component Type、Create / Edit PCL 和 Full Item History 功能。
- Refresh- 单击以刷新,查看最近的更新或编辑。也可以使用 F5 快捷键进行刷新。
- Library Report - 在 Categories 窗格中选中基于文件的库后,单击以访问 库报告设置对话框,在其中可以使用提供的控件配置库报告。
批量更改元件——Item Manager
Related page: 使用 Item Manager 管理内容
逐个更改元件固然方便,但当元件数量较多时,这种方式很快就会变得繁琐。此时,您需要一个统一、集中的位置,以批量方式执行多项更改。这正是 Item Manager(Tools » Item Manager)的用武之地。
Item Manager 是一个“指挥中心”,用于将放置在原理图图纸上的 Workspace 设计实体与其在 Workspace 中链接的源内容进行同步。它会自动检测并列出所有元件,标明它们是否为 Workspace 实体,然后将原理图上每个 Workspace 元件的条目修订版与 Workspace 中该元件的可用修订版进行比较。对于每个实体,都会提供当前链接条目的相关信息,包括修订版、生命周期状态以及所在的源 Workspace。
您可以完全控制要更新哪些 Workspace 实体以及如何更新。例如:
- 选择单个条目,将其更新为使用所链接条目的最新修订版,或选择使用另一个完全不同条目的最新修订版。
- 选择一组使用相同链接条目的条目,将它们更新为该条目的最新修订版,或选择使用另一个完全不同条目的最新修订版。
所有拟议更改都会显示在管理器中。
按需设置好更改后,生成工程变更单(ECO),并查看为实施这些更改将执行的操作。如有需要,可以禁用任何操作——一切始终由您掌控!准备就绪后,执行 ECO,即可应用更改。快速高效,轻松管理已放置的 Workspace 内容。
以下示例演示了 Item Manager 的使用方法:
- 更新多个元件,使其使用现有 Workspace 元件的最新修订版。
- 将几个元件更换为另一个 Workspace 元件的最新修订版,该元件通过 替换元件对话框选择。
Item Manager 不仅可用于使设计中的元件与所连接 Workspace 中源内容的更改保持同步,还可作为强大的工具,帮助您将现有电路板设计从使用本地设计条目迁移为使用 Workspace 设计内容。将设计元件以及所用的原理图图纸(器件图纸)迁移到 Workspace 后,您可以使用 Item Manager,将现有元件和图纸符号“替换”为其新迁移的 Workspace 版本。换言之,从设计角度来看,元件保持不变,但这些元件的来源发生了变化。
从 BomDoc 更换元件
在检查 BomDoc 并准备订购零件时,发现元件存在问题的情况并不少见。例如,设计人员可能忘记最终确定某个元件的选型,或者某个元件已停产(EOL),设计人员希望了解潜在替代元件的价格和供货情况。虽然您可以返回原理图编辑元件,选择合适的零件,然后刷新 BomDoc 来解决此问题,但 ActiveBOM 支持直接在 BomDoc 中执行此操作,然后通过工程变更单将更改推送回原理图。
在 BomDoc 中,右键单击所选元件,然后选择 Operations » Change <ComponentName> 命令。此时将打开 替换元件对话框,您可以在其中搜索替代元件。找到所需的替代元件后,选中它,然后单击 OK。随后将打开 Engineering Change Order 对话框,详细列出使原理图与 BomDoc 保持同步所需的更改。
替换通用元件
当设计进展到可以将通用元件替换为具体实物元件的阶段时,可选择 Properties 面板中的
按钮,打开 替换元件对话框。请注意,也可以通过 条目管理器或项目的 ActiveBOM 文档执行此操作。
已应用于通用元件的参数值(此处为功率和电阻值)会自动用作 Replace Generic Component 对话框中的搜索条件,使您能够从筛选结果中选择合适的替代元件——在此示例中,有两个元件条目符合搜索条件。
|
通过 Properties 面板替换通用元件。 通过 Properties 面板替换通用元件。 |
管理整个设计中的封装
Altium Designer 的原理图编辑器包含功能强大的 Footprint Manager。从原理图编辑器的“工具”菜单(Tools » Footprint Manager)启动 Footprint Manager 后,您可以查看整个项目中每个元件关联的所有封装。借助多选功能,您可以轻松编辑多个元件的封装分配、更改封装的链接方式,或为已分配多个封装的元件更改当前封装分配。 Footprint Manager 便于查看并发现整个设计中的封装分配问题,在处理旧设计或来自其他组织的设计时尤其有用。设计更改通过 ECO 系统应用,并在需要时同时更新原理图和 PCB。
Footprint Manager 对话框会列出当前活动项目中所有源设计原理图上的全部元件。使用对话框右侧的控件,可管理设计元件可用的封装以及当前使用的封装。功能包括:
- 为一个或多个选定元件添加、编辑和移除封装模型。
- 在元件之间复制封装。
- 更改当前封装分配(从元件可能具有的多个可用封装中,指定当前用于在 PCB 中表示该元件的封装)。
- 封装验证——确保封装模型确实可用,尤其是被设为当前模型的封装。
按要求完成所有封装模型分配更改后,即可通过标准的工程变更单 (ECO) 实施这些更改。只需单击 Footprint Manager 对话框右下角的 Accept Changes (Create ECO) 按钮即可。
封装管理器对话框的选项和控件
元件列表
此处列出当前处于焦点的 PCB 设计项目中所有原理图图纸上的元件。信息包括:
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
查看和编辑封装
此处列出 Component List 中所选元件关联的封装。使用该区域底部的控件或右键菜单命令,可对列表中的封装进行操作。
右键菜单
-
Add - 单击可打开 PCB 模型对话框,为高亮显示的原理图元件选择要添加的新封装模型。选中受管元件时不可用。
-
Remove - 单击可移除选定封装。选中受管元件时不可用。
-
Edit Footprint - 单击可打开 PCB 模型对话框。PCB Model 对话框用于定义与原理图元件关联的封装模型,以及原理图编辑器可以在哪些库中查找该封装。选中受管元件时不可用。
-
Validate Footprint Paths - 单击可确认能否在允许的位置找到高亮显示的封装。如果找不到封装,Found In 字段中会显示 Not Validated 。如果封装通过验证,则会显示该封装的完整路径。
-
Change PCB Library - 单击可打开 Edit PCB Library 对话框,以更改选定封装所在的 PCB 库。此对话框是 PCB Model 对话框的简化版本,可通过其中的 PCB Library 选项定义软件查找封装模型的位置。

Edit PCB Library 对话框- Any - 在所有可用库中搜索匹配的模型。
- Library name - 仅在具有此名称的可用库中搜索匹配的模型。
- Library path - 仅在此位置具有此名称的库中搜索匹配的模型。可手动输入路径和库名称,或单击 Choose 按钮打开 Windows Open 对话框,然后浏览到所需的库。
- Use footprint from source integrated library, database library, or server - 仅在放置该元件时所用的集成库/数据库库/服务器中搜索模型。集成库或数据库库必须可用;如果使用服务器,则必须连接到该服务器。
-
Copy - 单击可复制当前选定封装的详细信息。
-
Paste - 单击可将复制的封装详细信息粘贴(添加)到当前选定的原理图元件。
-
Select All - 单击可选择 View and Edit Footprints 列表中当前可见的所有封装。
-
Set As Current - 单击可将选定封装设为当前封装(在 Current 列中以
表示)。
-
Add to All Parts - 单击可将选定封装添加到同一原理图元件中的所有其他子部件(仅当选定元件为多部件元件,且其中一个或多个子部件尚未指定此封装时,此命令才可用)。
其他控件
-
Menu - 单击可查看一个菜单,其中包含与上述右键菜单相同的控件。
-
Add, Remove, Edit, Validate - 这些按钮的功能与上述菜单项相同。
-
Accept Changes (Create ECO) - 单击可接受对原理图元件及其关联封装模型的更改,并打开 Engineering Change Order 对话框。在 ECO 对话框中,您可以先检查对相应原理图元件的封装值所做的修改,再验证并执行这些更改。




















