Altium Designer Documentation

View Configurations - View Options tab

Created: July 7, 2017 | Updated: July 7, 2017

The View Options tab of the View Configurations dialog.

Summary

This tab of the View Configurations dialog allows the designer to configure various additional display options with respect to the PCB design workspace.

Access

This is one of four tabs available for a 2D view configuration – accessed from within the View Configurations dialog. This dialog can be accessed from both the PCB Editor and the PCB Library Editor, in the following ways:

  • In 2D Layout Mode, choose the Design » Board Layers & Colors command (PCB Editor), or choose the Tools » Layers & Colors command (PCB Library Editor).
  • Press the L key.
To access 2D view-related tabs, either ensure the workspace is in 2D Layout Mode prior to accessing the dialog, or select a 2D configuration in the Select PCB View Configuration region, once the dialog is accessed.

Options/Controls

Display Options

  • Convert Special Strings - enable this option to display special strings converted to their literal value. Special strings act as place holders for various system data, e.g. layer names, hole counts and drawing legends. Normally, special strings are interpreted to their literal values only during printing or plotting, but with this option some of those special strings can be displayed on-screen.

Single Layer Mode

This field shows the current Single Layer Mode, if any, chosen for the view configuration. Click to choose from one of the following available options:

  • Gray Scale Other Layers - displays the current layer, all primitives on other layers are displayed in gray. The shade of gray is based on a layer's color scheme.
  • Monochrome Other Layers - displays the current layer, all primitives on other layers are displayed in the same shade of gray.
  • Hide Other Layers - displays the current layer, all primitives on other layers are not displayed.
  • Not In Single Layer Mode - displays all visible layers as normal.

Other Options

  • Net Names on Tracks Display - this field shows the current display mode for identifying net names on tracks. Click to choose one of the following display modes:
    • Do Not Display - no net names will be shown.
    • Single and Centered - the net name will be shown once at the center of each track segment.
    • Repeated - the net name is shown repeatedly along each track segment.
Only track segments that are long enough will display the net name. Net names will only become visible if you are zoomed in close enough.
  • Plane Drawing - this field shows how any internal split planes are displayed. Click to choose one of the following drawing modes:
    • Outlined Layer Colored - the internal split plane will be shown as an outline only, color-dependent on the associated layer color.
    • Solid Net Colored - the internal split plane will be shown with outline and fill, color-dependent on the associated net color.
The relevant internal plane layer must be visible for this option to work in the 2D workspace. Ensure that the layer's Show attribute is enabled on the Board Layers And Colors tab of the View Configurations dialog. Plane layers are always visible in the 3D workspace.

Solder Masks

  • Show Top Positive - enable this option to display the top solder mask in positive (all masked areas colored).
  • Show Bottom Positive - enable this option to display the bottom solder mask in positive (all masked areas colored).
  • Opacity - use this slide control, associated to each of the above options, to alter the opacity of the mask. The greater the opacity, the less 'light' passes through the surface. Move the slide bar to the right for greater opacity.
The Top Solder and Bottom Solder mask layers must be visible, respectively, for these options to work. Ensure that each layer's Show attribute is enabled on the Board Layers And Colors tab of the View Configurations dialog.

Show

  • Test Points - enable this option to show any test points on the PCB.
  • Status Info - enable this option to have summary information, such as coordinate position and layer, displayed in the status bar when an object is selected.
  • Origin Marker - enable this option to display the coordinate origin marker (bottom left corner). All objects in the PCB design are positioned relative to the origin marker. Click the color swatch to the right, to change the color of the origin marker through the standard Choose Color dialog.
  • Component Reference Point - enable this option to display reference point markers for components. Component reference points can be especially helpful when placing and positioning components. Click the color swatch to the right, to change the color of component reference markers through the standard Choose Color dialog.
  • Show Pad Nets - enable this option to display the associated net name on a pad. Note that net names will only become visible if you are zoomed in close enough.
  • Show Pad Numbers - enable this option to display pad numbers. Note that pad numbers will only become visible if you are zoomed in close enough.
  • Show Via Nets - enable this option to display the relevant net name on a via. Note that net names will only become visible if you are zoomed in close enough.
  • Show All Connections In Single Layer Mode - enable this option to always display all of the connection lines when in Single Layer Mode. With this option disabled, all connection lines that do not start or end on the current layer are also hidden, when switching to Single Layer Mode, as it is assumed that they are not relevant.
  • Use Layer Colors For Connection Drawing - enable this option to display the connection lines using the colors of the start and end layers that the connection line travels between. The connection lines are displayed as dashed lines, alternating the colors of both the start and end layers. This feature is ideal when you are routing a multi-layer board, as you can easily tell the target layer that the connection being routed must get to.
Note that this dashed color override is only applied to nets that travel from one layer to another, if the connection starts and ends on the same layer it retains its defined net color.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。