操作原理图库

 

上级页面:使用基于文件的元器件库

在设计输入阶段,我们使用原理图符号来表示电路板上实际安装的元器件;在电路板设计阶段,我们则使用PCB封装来表示这些元器件。Altium Designer元器件可以:

  • 在本地库中创建并从本地库放置;或
  • 直接从连接的Workspace(所有设计团队成员均可访问)放置。
本文档概述了原理图库(*.SchLib)的创建和管理。如需了解关于创建元器件符号的更多信息,请参考Creating a Schematic Symbol页面。

您可以将符号从原理图编辑器复制到原理图库,在原理图库之间复制符号,或者使用Schematic Symbol Generation Tool或绘图工具直接创建符号。

新建原理图库

如需新建原理图库,请从主菜单中选择File » New » Library命令,然后从New Library对话框的File区域中选择Schematic Library选项。

单击Create后,软件将创建并在Projects面板中显示一个名为Schlib1.SchLib的新原理图库文档,并且屏幕上将显示一个名为Component_1的空元器件图纸。

库的内容将显示在SCH Library面板中。

您现在可以使用原理图符号编辑器命令在新原理图库中添加、删除或编辑原理图元器件。

从原理图文档创建原理图库

您还可以通过单击Design » Make Schematic Library来创建一个包含活动项目原理图源文档中所使用的所有元器件的原理图库。该方法可以有效帮助您为已完成设计创建精确的工作库或档案。如果存在引用相同库但内部结构不同的元器件,则Component Grouping对话框将打开;您可以使用该对话框指定用于元器件分组的参数。

指定参数后,活动项目的所有原理图源文档将打开(如果尚未打开),并且软件将自动创建一个库文档(<ProjectName>.SchLib)并将其添加到项目中。该文档将在原理图符号编辑器中作为活动文档打开。该库将包含设计中使用的所有元器件。创建的文件将作为Libraries\Schematic Library Documents子文件夹下项目的一部分出现在Projects面板中,但其最初并不会被保存到硬盘。

从原理图创建原理图库

您可以从活动原理图图纸创建一个新的原理图元器件符号(该图纸上的端口将成为元器件的管脚)。如需这样做,请从主菜单中选择Design » Create Component From Sheet命令,或在主设计区内(远离设计对象的位置)右键单击并从上下文菜单中选择Sheet Actions » Create Component From Sheet命令。

启动命令后,Symbol Options对话框将打开。使用此对话框定义与源图纸上的端口相关的符号高度和宽度、其管脚长度以及其管脚样式。

Symbol Options对话框
Symbol Options对话框

在对话框中单击OK后,软件将在新的Schematic Library文档(Schlib1.SchLib)中创建新的元器件,并以原理图文档名称为其命名。该库将作为活动文档打开,并且新元器件将作为该库中的活动元器件显示。

若源原理图图纸不包含端口,则软件仍会新建元器件,但不带任何符号图形。

新建原理图元器件

您可以在原理图库中创建任意数量的元器件符号。如需在现有库中新建原理图元器件,请从主菜单或设计区的右键菜单中选择Tools » New Component,或单击SCH Library面板Design Item ID区域下的Add按钮。

启动命令后,New Component对话框将打开。使用此对话框的Design Item ID字段为元器件指定一个合适的名称。

New Component对话框
New Component对话框

单击OK后,软件将在库中创建一个具有此名称的新元器件,并在设计区中打开一个空元器件图纸并使其成为活动图纸。

由于新库总是包含一个空元器件,因此您还可以通过重命名Component_1以开始创建元器件。如需这样做,请从SCH Library面板Design Item ID列表中选择Component_1,然后单击面板中的Edit按钮或双击Component_1,以在Component模式下打开Properties面板。之后,在Design Item ID字段中输入作为其唯一标识的新元器件名称并按Enter。

如需从活动库中删除当前元器件,请从主菜单中选择Tools » Remove Component,或在设计区中右键单击,然后从上下文菜单中选择Tools » Remove Component。您也可以直接从SCH Library面板中删除元器件。如需这样做,请在Design Item ID列表中选择所需元器件,然后单击列表下方的Delete按钮,或者右键单击然后从上下文菜单中选择Delete命令。若使用面板删除元器件,则您可以一次性删除多个元器件。

将模型添加到原理图元器件

您可以将任意数量的PCB封装模型添加到原理图元器件,以及用于电路仿真和信号完整性分析的模型文件。若一个元器件有多个模型(例如,多个封装),则您可以在将元器件放置到原理图上时,从Properties面板中选择合适的模型。在获取模型方面,您可以创建自己的模型文件,也可以从网上下载供应商的模型文件。PCB库可以包含任意数量的PCB封装。

三维模型被放置在PCB封装中,而非直接链接到元器件符号。这是因为三维模型必须相对于封装进行正确旋转、对齐和定位;因此,明智的做法是在封装编辑器中执行上述操作。如需了解关于使用三维模型和在封装中放置三维模型的更多信息,请参考Creating the PCB Footprint

您可以通过以下方式将模型添加到当前元器件:

  • 从设计区底部的Model区域添加(如下图所示,单击设计区右下角的向下箭头/插入符号)。

    单击高亮显示的插入符号以访问设计区的Model区域。
    单击高亮显示的插入符号以访问设计区的Model区域。

  • 使用Component模式下的Properties面板Parameters区域中的Add下拉列表,然后选择模型。

  • 通过原理图符号编辑器的Model Manager对话框(Tools » Model Manager,或右键单击SCH Library面板中的元器件,然后从上下文菜单中选择Model Manager),您可以查看和组织活动原理图库中所有元器件的元器件模型。例如,您可以将同一模型添加到多个选定元器件。

    Model Manager对话框
    Model Manager对话框

将模型映射到符号

作为模型链接过程的一个环节,必须将关于元器件的信息从原理图映射到目标模型。

特定域信息存在于预定义格式模型文件中(例如,IBIS、MDL和CKT文件)。在访问特定域信息时,系统还需要使用其他信息(例如,原理图符号和特定域模型之间的管脚映射和网表)。特定域信息在特定域模型编辑器中定义(该编辑器将在添加或编辑模型时打开)。除了引用模型文件外,它还将包括该模型类型所需的所有管脚映射或网表信息。

这些是SPICE内置的多个预定义模拟器件模型。对于这些元器件类型,不需要使用单独的模型文件。其建模所需的所有信息均在SIM Model编辑器中配置。

搜索模型文件位置

当您在原理图符号编辑器中将模型添加到元器件时,模型将与元器件链接;但是,模型数据不会复制或存储在原理图元器件中。这意味着,当您创建库以及在原理图图纸上放置元器件时,必须确保链接模型可用。当您在库编辑器中工作时,软件将使用以下有效搜索位置解析从元器件到模型信息的链接:

  • 首先,搜索包含在当前库包项目中的库。
  • 其次,搜索当前Installed Libraries列表中可用的PCB库(而非集成库)。请注意:您可以订购库列表。
  • 最后,搜索位于项目搜索路径上的所有模型库。搜索路径在Project Options对话框(Project » Project Options)的Search Paths选项卡上定义。请注意:您无法通过浏览搜索路径上的库来定位模型,但编译器在搜索模型时会包含这些库。

有关如何在原理图符号编辑器和原理图编辑器中搜索模型的更多信息,请参考Searching for Components in File-based & Database Libraries页面的Managing Available Database and File-based Libraries部分。

将封装添加到原理图元器件

如需将封装添加到当前原理图元器件,请如上所述,在选择模型添加选项时选择Footprint。此时,PCB Model对话框将打开。

PCB Model对话框

PCB Model对话框顶部的Name字段必须包含封装名称。您可以直接输入名称,或者在Browse Libraries对话框中,使用Browse按钮在可用封装库中查找封装名称。您可以通过Libraries下拉列表访问可用库列表。单击该按钮可打开Available File-based Libraries对话框;您可以在该对话框中添加或删除库。如果所需封装在当前库中不可用,则您需要使用Find按钮打开File-based Libraries Search对话框,以对其进行搜索。

PCB Model对话框底部有一个显示模型所在位置的文本字符串。

定义模型查找位置的设置会影响软件查找模型的能力。该设置位于模型名称的正下方,涵盖了从Any(表示在所有可用库中搜索此模型)到Integrated Library或Server(表示仅可使用来自指定集成库或Workspace的模型)的一系列选项。

PCB Model对话框包括以下选项:

库选项 行为 对话框设置
Any 在所有可用库中搜索匹配模型。 Library option Any
Library name 仅在具有此名称的可用库中搜索匹配模型。 Library Option Library name
Library path 仅在位于此位置且具有此名称的可用库中搜索匹配模型。 Library Option Library path
Integrated library 仅在放置元器件的集成库中搜索模型。集成库必须可用。 Library Option Integrated Library
Server 仅在放置此元器件的Workspace中搜索模型。软件必须连接到该Workspace。 Search for model in the server

如需为链接封装配置管脚映射,请单击PCB Model对话框中的Pin Map,以打开Model Map对话框并根据需要对Pin-Pad对进行编辑。Component Pin Designator列列出了所有元器件管脚(该字段不可编辑);Model Pin Designator列则列出了模型管脚编号(可编辑该字段以匹配元器件管脚)。

如需将一个元器件管脚映射到多个模型管脚,请在Model Pin Designator列的相关单元格中输入模型管脚编号列表(用逗号分隔)。

将仿真模型添加到原理图元器件

创建新元器件时,您通常会从器件供应商网站获取SPICE模型。如需将仿真模型添加到当前原理图元器件,请如上所述,在选择模型添加选项时选择Simulation。此时,Sim Model对话框将打开。您可以在此对话框中选择模型并进行原理图符号管脚到模型管脚的映射。

您还可以使用SPICE Model Wizard(Tools » XSpice Model Wizard)创建特定SPICE模型类型,以添加元器件:了解更多

在原理图阶段添加模型

在原理图阶段,设计是逻辑连接元器件的集合。为了测试或实现设计(例如,电路仿真、PCB布局、信号完整性分析等),您需要将设计转移到另一个设计域中。为实现这一点,您必须针对目标域,为每个元器件建立一个合适的模型。

  • 您可以通过将封装添加到Properties面板的Parameters区域,将封装链接到原理图元器件。如需配置封装,请单击Add下拉列表,然后选择Footprint,以打开PCB Model对话框。

  • 您可以通过将模型添加到Properties面板的Parameters区域,将模型链接到原理图元器件。请单击Add下拉列表,然后选择Simulation或Ibis Model,以打开各个对话框。

使用参数为元器件添加详细信息

元器件参数是定义与元器件有关的附加信息的一种方式。通过参数,您可以定义有关元器件的附加文本信息,其中可包括电气规格(即,瓦数或公差)、采购或库存详细信息、设计师说明、对元器件数据表的引用等——基本上涵盖您所选择的任何目的:贵公司所需的BOM数据、制造商数据、对元器件数据表的引用,或设计说明信息(例如,设计规则或PCB类分配等)。

您可以在创建元器件期间,使用Properties面板在原理图库编辑器中定义参数。

为元器件添加参数

对于单个元器件,参数将被添加到Component模式下的Properties面板的Parameters区域中。如前所述,您可以在库中完成该操作,亦可通过将元器件放置到原理图图纸上来完成该操作。

使用以下步骤将参数添加到原理图元器件:

  1. 双击SCH Library面板中的元器件名称,以在Component模式下打开Properties面板
  2. 在Parameters区域中,从Add下拉列表中选择Parameter。
  3. 输入所需的参数名称和值。
  4. 若您希望在将元器件放置到原理图图纸上时显示参数的名称和值,请确保Parameter的可见性选项已启用( )。
  5. 单击Parameters区域底部的Font Link and Other,访问其他选项以配置参数。

您也可以在设计区中选择参数,在Parameter模式下打开Properties面板以配置参数。

将参数添加到多个元器件

参数是每个元器件的关键元素,并且多个元器件共用多项参数的情况并不罕见。除了将参数单独添加到每个元器件外,您还可以使用Parameter Manager命令(Tools » Parameter Manager)将它们添加到多个元器件。除了添加和删除参数外,您还可以为多个元器件编辑参数值。

Parameter Table Editor对话框可用于编辑所有元器件的所有参数。
Parameter Table Editor对话框可用于编辑所有元器件的所有参数。

关于编辑多个参数的说明:

  • 您可以使用相同步骤为库中的多个元器件或原理图设计中使用的多个元器件编辑参数。请在原理图或原理图库编辑器中选择Tools » Parameter Manager,以开始编辑。
  • 由于可以将参数添加到各种不同的对象,因此您需要首先在Parameter Editor Options对话框中选择要编辑的参数的对象类型。
  • 参数编辑将在Parameter Table Editor对话框中执行。由于可通过不同方式访问该对话框,因此对话框标题可以更改。但是,您所选用的对话框访问方式并不会影响您在对话框中进行的操作:使用标准Windows选择按键选择要编辑的单元格,然后右键单击并选择编辑操作。
  • 更改不会立即执行;它们将通过Engineering Change Order (ECO)来完成。
  • 每个正在被更改的单元格均带有一个彩色小图标。有关每个图标的描述,请参考Parameter Table Editor对话框页面。

将参数映射到元器件的评论字段

原理图上显示的默认元器件参数是Designator和Comment。在将设计从原理图编辑器转移到PCB编辑器时,仅需简单操作,即可将Designator和Comment字符串作为默认字符串显示在电路板上。

如需在原理图和PCB上显示任何元器件参数的值(例如,显示Capacitance参数的值),您可以使用字符串间接技术将任意元器件参数映射到该元器件的Comment字段中。

这种映射是通过以=ParameterName形式输入参数名称来实现的。例如,如需将元器件参数Capacitance的值映射到元器件的Comment字段,请如下所示,在Properties面板的Comment字段中输入字符串=Capacitance。使用语法‘=ParameterName’定义的字符串被称为特殊字符串。

特殊字符串会自动转换以实现在屏显示。在映射为特殊字符串的参数没有值的情况下,若在Preferences对话框Schematic - Graphical Editing页面上启用了Display Names of Special Strings that have No Value Defined选项,则参数名称将显示为灰色;若禁用该选项,则不显示任何内容。

使用特殊字符串功能将任意参数值映射到元器件的Comment。
使用特殊字符串功能将任意参数值映射到元器件的Comment。

使用特殊字符串,即可将任意参数映射到任意字符串(字符串可以是元器件字符串、原理图图纸上放置的离散字符串或原理图模板中放置的字符串;参数可以是元器件参数、文档参数或项目参数)。请参考 Special Strings,了解更多信息。

定义参考信息的可点击链接

您可以在Component模式下的Properties面板的Parameters区域中,通过单击Add下拉列表并选择Link来添加链接。例如,您可以使用该功能添加指向数据表或制造商网站的链接。软件支持为一个元器件定义任意数量的链接。

链接应配置如下:

  • Name - 用于定义出现在菜单中的入口:
  • Url - 用于定义目标文档。以下示例是有效入口:
    • C:\Design_Projects\Schematics\Modifications.txt
    • C:\Design_Projects\Schematics\MyDataSheet.pdf
    • https://www.altium.com
    • www.altium.com/documentation

面板中显示的链接是实时的,因此当您单击链接文本时,该URL将加载到您的首选浏览器中。如需编辑现有链接,请单击单元格中远离链接文本的任意位置,然后单击编辑按钮。

仅需右键单击放置的原理图元器件,即可通过上下文菜单访问链接。虽然您可以定义任意数量的指定链接,但Schematic编辑器的右键References上下文菜单仅提供前9个链接。其他指定链接将不会出现在Schematic编辑器的参考菜单中,但它们会包含在生成的PDF中,并且当您在PDF文档中单击元器件时,这些链接将作为PDF中的实时链接发挥作用(参见下文)。

右键单击图纸上的一个元器件,以访问该元器件链接。   
右键单击图纸上的一个元器件,以访问该元器件链接。

启动命令后,指定目标文档将打开。基于网络的URL目标页面将直接打开(若可用)。对于PDF或文本文档,请按如下方式搜索文档:

  • 如果指定了路径,则首先搜索该位置;
  • 如果在该位置找不到文档,或者没有指定路径,则搜索Altium Designer安装的\Help文件夹。

您亦可通过Smart PDF功能或者从OutputJob文件生成的PDF,将链接包含到从原理图生成的PDF中。下图显示了元器件参数列表在PDF中的显示方式。您可以单击任何URL类型参数,从PDF浏览至该参数所在位置。您亦可通过启用Smart PDF Wizard中的Include Component Parameters选项或者OutputJob选项生成设置,将元器件参数包含到生成的PDF中。

可以通过Smart PDF Wizard从原理图生成PDF,亦可从OutputJob直接生成PDF。如下所示,单击PDF中的一个元器件,即可显示参数。

单击PDF中的一个元器件,显示参数;然后单击链接类型参数,打开目标。
单击PDF中的一个元器件,显示参数;然后单击链接类型参数,打开目标。

早期版本的Altium Designer软件支持一种名为HelpURL的特殊参数。如果元器件包含该参数,则当您将光标悬停在原理图元器件上方并按F1键时,或者当您从元器件右键菜单中选择References » Help命令时,HelpURL参数中定义的链接或文档将被传送至Windows,然后Windows将打开引用的URL或文件。当前版本的Altium Designer软件已不再支持此项功能。如果一个元器件有HelpURL参数,则应如上所述用元器件链接替代该参数。

检查元器件和生成报告

您可以通过生成多份报告来检查是否已正确新建元器件。请务必在生成报告之前保存库文件。

库列表

Library List将列出每个元器件及其详细信息(来自活动库文档)。

  1. 选择Reports » Library List.
  2. 软件将生成并打开(作为活动文档)一个ASCII文本文件(<LibraryName>.rep)。该文件记录了库中元器件的总数,并列出元器件名称和每个元器件的描述(如有)。

    软件还将创建并打开第二个文件(<LibraryName>.csv),并在.rep文件中引用该文件。该文件是一个逗号分隔值文件,包含库中每个元器件的详细信息(从各元器件属性中提取)。

库报告

您可以从活动库文档生成报告(其中包含有关存储在该库中的元器件的信息)。该报告经过配置,可以包含参数、管脚和模型信息,以及元器件/模型预览(彩色预览或黑白预览)。该报告可以生成为Microsoft Word文档(*.doc)或标准HTML文档(*.html)。

  1. 选择Reports » Library Report打开Library Report Settings对话框。使用该对话框配置报告的内容和样式,以及报告生成位置(以及名称)。在默认情况下,报告将以原理图库命名,并与原理图库存储在相同位置。

  2. 配置报告设置,然后单击OK。如果您选择在生成后打开报告,则您必须事先安装Microsoft Word(如果生成Doc样式报告)或默认浏览器(如果生成HTML样式报告)才能实现。

    如果您选择在生成后将生成的报告添加到项目中,则该报告将出现在Generated\Documents子文件夹(针对HTML样式报告)或Generated\Text Documents子文件夹(针对Doc样式报告)下的Projects面板中。

元器件规则检查器

Component Rule Checker可检测错误(例如,管脚重复和管脚缺失)。

  1. 选择Reports » Component Rule Check(快捷键R、R)打开Library Component Rule Check对话框。设置您想要检查的属性,然后单击OK。

  2. 设计区中将显示标题为<libraryname.ERR>的报告,该报告将列出所有违反规则检查的元器件。

  3. 对库进行必要调整,然后重新运行报告。
  4. 保存原理图库。关闭报告以返回原理图编辑器设计区。
  • 元器件规则检查器不检查从元器件管脚到模型的链接。但是,当将库包编译成集成库时,检查器将检查该层级的链接。即使您不打算使用已编译的集成库,通过库包创建和管理您的库仍然对您的设计大有益处。
  • 该报告存储在与库文档相同的位置,并且作为Documentation\Text Documents子文件夹下的离散文档添加到Projects面板。
  • 检查管脚重复时,检查器将仅报告每个元器件的首个实例。若存在多个重复管脚,检查器将不会单独对每个重复管脚进行报告。
可以为活动原理图符号生成Component Report——了解更多

从其他源复制元器件

从其他库移动和复制元器件

您还可以将元器件从其他打开的原理图库复制到您的原理图库,然后根据需要编辑它们的属性。如果该元器件位于集成库中,则您必须打开.IntLib文件并选择Yes以提取源库。然后,您需要从Projects面板打开生成的源库(*.SchLib)。

  1. SCH Library面板的Design Item ID列表中选择要移动或复制的元器件,以便在设计窗口中显示该元器件。

  2. 选择Tools » Move Component或Tools » Copy Component以打开Destination Library对话框;该对话框中将列出当前打开的所有原理图库文档。所有打开的库均将列在对话框中(无论其是离散文档还是当前或其他任何打开项目的一部分)。

  3. 选择要将元器件移动/复制到的文档,然后单击OK。元器件或其副本将放置在目标库中,您可以在必要时对其进行编辑。

    复制元器件时,您可以选择当前库作为目标库。将元器件复制到同一个库能够有效帮助您创建图形表示与现有元器件图形表示相似(仅需细微修改)的新元器件。

从原理图复制元器件

您还可以将元器件从原理图图纸复制到原理图库,然后根据需要编辑它们的属性。在原理图图纸上选择要复制的元器件,然后使用所选元器件右键菜单中的Copy命令(快捷键:Ctrl+C)进行复制。然后,打开目标原理图库,右键单击SCH Library面板的元器件列表区域并选择Paste(快捷键:Ctrl+V)。

请注意,如果将元器件从连接的Workspace或Manufacturer Part Search面板放置到原理图图纸上,则指向源Workspace的链接将被保留。这些元器件将通过SCH Library面板中的图标进行区分。您可以通过从主菜单中选择Tools » Clear Server Links命令,将打开的库中的所有元器件的Workspace链接全部清除。启动命令后,Confirm Clear Vault Links对话框将打开。单击Yes,可清除对话框中指定的Workspace链接并保存库;单击No,可直接退出对话框。

Confirm Clear Vault Links对话框
Confirm Clear Vault Links对话框

复制多个元器件

您还可以使用SCH Library面板复制多个元器件。如需这样做,请使用标准Ctrl+Click或Shift+Click功能在面板中选择元器件,然后右键单击其中一个选定元器件并从弹出菜单中选择Copy。接着,在列表中右键单击并:

  • 将元器件粘贴回同一个库中。
  • 将元器件粘贴到另一个打开的库中。
  • 使用相同的方法将元器件从原理图复制并粘贴到打开的库中。
在将元器件粘贴到同一个库中,或将复制的元器件的多个实例粘贴到不同的库中时,元器件将被复制,但每个副本均会自带一个后缀,而非使用相同的名称。例如,如果原始元器件的名称是CAP,则第一个副本将称为CAP_1,第二个将称为 CAP_2,以此类推。

将设计从一个位置移动到另一个位置

当您将一个元器件从库放置到设计中时,该元器件将缓存在设计文件中,以便您能够在任意位置打开文档,而无需使用或加载其源库。该功能为您省去了移动库的烦恼,能够有效帮助您将设计从一个位置移动到另一个位置。请注意,原始源库名称和模型名称亦将存储在所放置的元器件的属性中。

SCH库面板

通过SCH Library面板,您能够查看和更改存储在活动原理图库文档中的元器件。此外,该面板还提供将对库中元器件所做的任何更改直接传递到原理图设计文档,以及为元器件定义模型链接的功能。

交互式地浏览、查看和编辑原理图库元器件及其管脚。

If you find an issue, select the text/image and pressCtrl + Enterto send us your feedback.

软件的功能取决于您购买的Altium产品级别。您可以比较Altium Designer软件订阅的各个级别中包含的功能,以及通过Altium 365平台提供的应用程序所能实现的功能。

如果您在软件中找不到某个讨论过的功能,请联系Altium销售团队以获取更多信息。

Content