Biegelinien definieren – Standardmodus

Auf einen Blick

Dieser Artikel erläutert, wie Sie in Altium Designer im Standard-Starrflex-Modus Biegelinien für flexible Bereiche definieren, platzieren, verschieben, entfernen und konfigurieren. Außerdem erfahren Sie, wie sich der Standard-Starrflex-Modus vom erweiterten Starrflex-Modus unterscheidet, wie Sie den für Ihre Leiterplatte verwendeten Modus überprüfen und welche Editoransichten und Panels zur präzisen Verwaltung von Biegungen dienen. Wenn Sie eine praxisnahe Anleitung zum Einstellen von Biegeposition, Winkel, Radius, Breite des betroffenen Bereichs und Faltreihenfolge im richtigen Modus suchen, hilft Ihnen dieser Leitfaden, sicherer zu arbeiten. Lesen Sie weiter und setzen Sie diese Schritte bei Ihrem nächsten Design um.

- Erfahren Sie, wann Biegelinien im Standard-Starrflex-Modus verwendet werden können und wie sich dieser Modus bei der Definition von Leiterplattenbereichen vom erweiterten Starrflex-Modus unterscheidet.
- Lernen Sie die genauen Schritte kennen, um Biegelinien im Leiterplattenplanungsmodus zu platzieren, neu zu positionieren, zu löschen und präzise auszurichten.
- Erfahren Sie, welche Eigenschaften von Biegelinien konfiguriert werden können, darunter Biegewinkel, Radius, Breite des betroffenen Bereichs und Faltreihenfolge für die Überprüfung der Faltung in 3D.
Mit KI tiefer einsteigen:

In der PCB-Designsoftware von Altium stehen zwei Starrflex-Designmodi zur Verfügung. Der ursprüngliche Modus bzw. Standardmodus, der als Rigid-Flex bezeichnet wird, unterstützt einfache Starrflex-Designs. Wenn Ihr Design komplexere Starrflex-Anforderungen aufweist, beispielsweise überlappende Flexbereiche, benötigen Sie den Modus Advanced Rigid-Flex (auch als Rigid-Flex 2.0 bekannt). Der Modus wird im Menü Tools im Lagenaufbau-Manager ausgewählt.

Der grundlegende Unterschied zwischen den Modi besteht darin, dass im ursprünglichen Modus die Leiterplattenkontur durch Platzieren einer Trennlinie in separate Leiterplattenbereiche unterteilt wird. Diese Trennlinie bleibt als Objekt bestehen und definiert, wo ein Leiterplattenbereich endet und ein anderer beginnt. Im erweiterten Modus wird jeder Leiterplattenbereich separat platziert. Wird ein größerer Bereich geteilt, entstehen daraus zwei separate Bereichsobjekte. Im erweiterten Modus definieren die Kanten benachbarter Leiterplattenbereiche, wo diese beiden Bereiche aufeinandertreffen – nicht das Vorhandensein einer Trennlinie. Aufgrund dieses Unterschieds gibt es im Modus Advanced Rigid-Flex kein Trennlinienobjekt.

► Erfahren Sie mehr über das Entwerfen einer Starrflex-Leiterplatte

Das Menü View bietet drei Arbeitsmodi für den PCB-Editor mit leicht zu merkenden Tastenkombinationen, mit denen Sie schnell zwischen folgenden Modi wechseln können:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Beim Wechsel zwischen dem 2D- und dem 3D-Ansichtsmodus werden standardmäßig für jeden Ansichtsmodus separate Zoom- und Ausrichtungseinstellungen beibehalten. Wenn Sie beim Wechsel denselben Ausschnitt und dieselbe Ausrichtung der Leiterplatte sehen möchten, drücken Sie Ctrl+Alt+2 oder Ctrl+Alt+3 anstelle von 2 oder 3.

Sie haben gerade eine Leiterplatte geöffnet und fragen sich, ob sie den Standard-Starrflex-Modus oder den erweiterten Starrflex-Modus verwendet?

Sie können dies im Lagenaufbau-Manager überprüfen. Alternativ können Sie in den Leiterplattenplanungsmodus wechseln (Tastenkombination 1) und einen Blick auf die Active Bar werfen:

Standard-Starrflex-Modus
Erweiterter Starrflex-Modus

Um festzulegen, wie eine flexible Leiterplatte gebogen werden soll, platzieren Sie eine oder mehrere Biegelinien. Die Biegelinie definiert, an welcher Stelle auf der Oberfläche des Flexbereichs die Biegung erfolgen soll. Außerdem definiert sie den Winkel und den Radius der Biegung sowie die Breite des Streifens der Leiterplattenoberfläche, der gebogen wird. Biegelinien werden im PCB-Editor in Board Planning Mode platziert und bearbeitet (View » Board Planning Mode oder drücken Sie die Tastenkombination 1).

Eine Biegelinie kann nur auf einem Bereich platziert werden, der im Layer Stack Manager als Flex-Bereich konfiguriert ist.


Eine Biegelinie wird über dem flexiblen Bereich platziert und so konfiguriert, dass die Leiterplatte um 180 Grad gefaltet werden kann. Dieses Video zeigt das Platzieren einer Biegelinie im Standard-Starrflex-Modus.

Platzieren einer Biegelinie

So platzieren Sie eine Biegelinie:

  1. Wählen Sie View » Board Planning Mode aus oder drücken Sie die Tastenkombination 1, um in Board Planning Mode zu wechseln.

  2. Biegelinien werden auf Multi-Layer platziert. Wenn die Registerkarte Mutli-Layer am unteren Rand des Bearbeitungsbereichs nicht sichtbar ist, aktivieren Sie die Lage im Panel View Configuration (Tastenkombination L zum Einblenden des Panels).

  3. Wählen Sie den Befehl Design » Define Bending Line aus.

  4. Klicken Sie in den Leiterplattenbereich, in dem die Biegelinie platziert werden soll. Ein Ende der Linie wird an der Kante des Bereichs fixiert, die der Klickposition am nächsten liegt; das andere Ende wird an den Cursor angehängt.

  5. Positionieren Sie das zweite Ende an der gewünschten Stelle und klicken Sie einmal, um es zu platzieren.

  6. Sie bleiben im Platzierungsmodus für Biegelinien und können bei Bedarf eine weitere Biegelinie platzieren. Andernfalls klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um den Platzierungsmodus für Biegelinien zu verlassen.

Das Panel PCB zeigt im Modus Layer Stack Regions die Daten zu Bending Lines an. Doppelklicken Sie auf einen Eintrag, um den Dialog „Biegelinie“ zu öffnen. 

Auf diesem flexiblen Leiterplattenbereich wurden drei Biegelinien platziert. Die Breite des orangefarbenen Streifens entspricht der Breite des betroffenen Bereichs.
Auf diesem flexiblen Leiterplattenbereich wurden drei Biegelinien platziert. Die Breite des orangefarbenen Streifens entspricht der Breite des betroffenen Bereichs.

Wenn für einen Leiterplattenbereich ein flexibler Lagenaufbau festgelegt wird, wird automatisch eine vertikale Biegelinie durch seinen geometrischen Mittelpunkt hinzugefügt. Entfernen Sie diese Biegelinie bei Bedarf oder positionieren und konfigurieren Sie sie neu.

Verschieben einer Biegelinie

So ändern Sie die Position einer vorhandenen Biegelinie:

  1. Wählen Sie View » Board Planning Mode  aus (oder drücken Sie die Tastenkombination  1), um in Board Planning Mode zu wechseln.
  2. Klicken Sie einmal, um den Leiterplattenbereich auszuwählen, der die Biegelinie enthält. Die Anfasspunkte aller Biegelinien innerhalb dieses Bereichs werden angezeigt.
  3. Um das Ende einer Linie zu verschieben, klicken Sie auf den Knoten, halten Sie die Maustaste gedrückt und ziehen Sie ihn an die gewünschte Position auf dem Umriss des Leiterplattenbereichs. Der Cursor wird dabei am aktuellen Fangraster und/oder an vorhandenen Designobjekten gefangen.
  4. Die Biegeposition wird durch die neue Position der Biegelinie neu definiert.

Wählen Sie einen Endknoten einer Biegelinie aus und ziehen Sie ihn, um die Position der Biegung auf der Leiterplatte zu ändern.
Wählen Sie einen Endknoten einer Biegelinie aus und ziehen Sie ihn, um die Position der Biegung auf der Leiterplatte zu ändern.

Exaktes Positionieren einer Biegelinie

Beim Verschieben einer Biegelinie rastet der Anfasspunkt an Positionen des aktuellen Fangrasters ein. Während des Verschiebens kann er auch an vorhandenen Designobjekten gefangen werden, beispielsweise an Linien auf einer mechanischen Lage. Das Bild unten zeigt, wie ein Anfasspunkt einer Biegelinie am Ende einer Linie auf der Lage Mechanical 2 positioniert wird (durch die Zahl 1 hervorgehoben). Beachten Sie, dass die mechanische Lage die aktive Designlage sein muss, damit die Fangfunktion greift.

Die Zahl 1 kennzeichnet einen Anfasspunkt einer Biegelinie, der an einer Linie auf Mechanical 2 gefangen wird. Beachten Sie, dass diese Lage die aktive Lage ist.
Die Zahl 1 kennzeichnet einen Anfasspunkt einer Biegelinie, der an einer Linie auf Mechanical 2 gefangen wird. Beachten Sie, dass diese Lage die aktive Lage ist.

Um den oben beschriebenen Vorgang genauer zu veranschaulichen, zeigen die folgenden Bilder die Hilfslinien, die in 2D Layout Mode auf Mechanical 2 platziert wurden. Sie definieren präzise obere und untere Referenzpunkte, mit denen eine Biegelinie im Winkel von 45 Grad platziert werden kann.

Die Leiterplatte im 2D-Layoutmodus mit Hilfslinien zum präzisen Platzieren der diagonalen Biegelinien.Die Leiterplatte im 2D-Layoutmodus mit Hilfslinien zum präzisen Platzieren der diagonalen Biegelinien.

Die Leiterplatte im Leiterplattenplanungsmodus mit den diagonalen Biegelinien, die an den Hilfslinien auf Mechanical 2 gefangen wurden.Die Leiterplatte im Leiterplattenplanungsmodus mit den diagonalen Biegelinien, die an den Hilfslinien auf Mechanical 2 gefangen wurden.

Entfernen einer Biegelinie

So entfernen Sie eine Biegelinie:

  1. Wählen Sie View » Board Planning Mode aus (oder drücken Sie die Tastenkombination 1), um in Board Planning Mode zu wechseln.
  2. Klicken Sie auf einen ihrer Endpunkte und halten Sie die Maustaste gedrückt. Drücken Sie dann die Taste Delete. Alternativ können Sie im Bereich Bending Lines des PCB-Panels einen Biegelinieneintrag auswählen und löschen.

Wenn für einen Leiterplattenbereich ein flexibler Lagenaufbau festgelegt wird, wird automatisch eine vertikale Biegelinie durch seinen geometrischen Mittelpunkt hinzugefügt. Entfernen Sie diese Biegelinie bei Bedarf oder positionieren und konfigurieren Sie sie neu.

Konfigurieren der Biegelinieneigenschaften

Leiterplattenbereiche, Trennlinien und Biegelinien werden in Board Planning Mode geprüft und bearbeitet (drücken Sie 1). Biegelinien können interaktiv im Designbereich oder über PCB bearbeitet werden. Panel, wenn es auf den Modus Layer Stack Regions eingestellt ist. Um das Panel anzuzeigen, klicken Sie unten rechts in Altium Designer auf die Schaltfläche Panels und wählen Sie dann PCB aus dem Menü. Wählen Sie im Panel oben im Dropdown-Menü Layer Stack Regions aus. In diesem Modus zeigt das Panel Folgendes an:

  • Die verfügbaren Leiterplatten-Lagenaufbauten im Bereich Layer Stacks.
  • Die diesen Lagenaufbauten zugewiesenen Regionen im Bereich Stackup Regions.
  • Die in der ausgewählten Region definierten Biegelinien im Bereich Bending Lines.

Beim Wechsel zu Board Planning Mode wird das Panel PCB automatisch auf den Modus Layer Stack Regions eingestellt.

So bearbeiten Sie die Eigenschaften einer Biegelinie im Panel PCB:

  1. Biegelinien können entweder in 2D Layout Mode (drücken Sie 2) oder in Board Planning Mode (drücken Sie 1) bearbeitet werden.
  2. Aktivieren Sie das Kontrollkästchen Select oben im Panel.
  3. Wählen Sie im Bereich Stackup Regions des Panels PCB die Leiterplattenregion aus, die die Biegelinie enthält.
  4. Wählen Sie die Biegelinie aus der Liste im Bereich Bending Lines des Panels aus. Die Biegelinie wird auf der Leiterplatte hervorgehoben (ausgewählt), wenn die Option Select des Panels PCB aktiviert ist. Ein Biegelinieneintrag kann auch aus dem Bereich Bending Lines gelöscht werden.
  5. Doppelklicken Sie auf den Biegelinieneintrag im Bereich Bending Lines, um den Dialog Bending Line zu öffnen, wie in der folgenden Abbildung gezeigt.

  6. Bearbeiten Sie im Dialog Bending Line zwei der ersten drei Eigenschaften, beispielsweise Radius (den Abstand des Biegemittelpunkts von der Biegefläche) und Bending Angle (den Winkel, um den die Oberfläche der flexiblen Region gebogen werden soll). Die dritte Eigenschaft – Affected area width (die Breite der Fläche, die bei den angegebenen Werten für Radius und Bending Angle gebogen wird) – wird automatisch berechnet (mehr dazu weiter unten). Beachten Sie, dass Affected area width jeder Biegelinie als orange schattierter Bereich dargestellt wird.
  7. Stellen Sie im Dialog Bending Line den Wert für Fold Index nach Bedarf ein, um die Reihenfolge festzulegen, in der die Biegungen ausgeführt werden, wenn der Schieberegler Fold State im PCB-Panel oder der Befehl View » Fold/Unfold verwendet wird. Beide dienen dazu, die Leiterplatte im 3D-Modus zu falten. Die Biegung mit dem niedrigsten Wert wird zuerst ausgeführt, gefolgt von den weiteren Biegungen bis zum höchsten Wert.

Für eine Leiterplattenregion muss im Dialog Board Region das Kontrollkästchen 3D Locked aktiviert sein, um die physische Bezugsebene für den 3D-Anzeigemodus festzulegen (bei Z = 0). Andernfalls wird Affected area width für die einzelnen definierten Biegelinien nicht angezeigt.

Der Dialog Bending Line kann auch geöffnet werden, indem Sie beim Platzieren oder Verschieben eines Biegelinien-Griffpunkts Tab drücken oder auf einen Biegelinien-Griffpunkt doppelklicken.

Zusammenfassung zum Definieren von Biegungen

Eine Biegelinie ist ein lineares Objekt, das über eine Region hinweg platziert wird, um Position, Radius und Winkel der Biegung zu definieren, die auf diese flexible Region der Leiterplatte angewendet werden soll.

Definieren einer Biegelinie:

  • Biegelinien werden im Leiterplattenplanungsmodus platziert (Tastenkombination 1).
  • Um eine Biegelinie zu platzieren, führen Sie den Befehl Design » Define Bending Line aus.
  • Platzieren Sie die Biegelinie über die flexible Leiterplattenregion hinweg. Anfang und Ende der Biegelinie müssen die jeweiligen Ränder der Region nicht exakt berühren. Die Software verlängert die Linie automatisch, wenn sie zu kurz ist, oder verkürzt sie, wenn sie zu lang ist. Mindestens ein Ende der Biegelinie muss den Rand der Region berühren oder über ihn hinausreichen.
  • Um die Eigenschaften einer Biegelinie zu bearbeiten, klicken Sie auf eine beliebige Stelle innerhalb der Region, um die Eckpunkte aller Biegelinien in dieser Region anzuzeigen. Gehen Sie anschließend wie folgt vor:
    • Doppelklicken Sie auf den Eckpunkt einer Biegelinie, um den Dialog „Biegelinie“ zu öffnen, oder
    • blenden Sie das Panel PCB ein und stellen Sie es auf den Modus Layer Stack Regions ein. Dort können Sie die Regionen und Biegelinien prüfen und bearbeiten.
    • Stellen Sie Bending Angle und Radius der Biegung nach Bedarf ein.
    • Biegungen werden in der Reihenfolge ihres Werts für Fold Index ausgeführt. Nutzen Sie diese Funktion, wenn die Faltreihenfolge überprüft werden muss.
  • Um eine Biegelinie zu verschieben, klicken Sie auf die einzelnen Eckpunkte und ziehen Sie diese an die gewünschte Position.
  • Eine Biegelinie kann entfernt werden, indem Sie auf einen der Eckpunkte klicken, die Maustaste gedrückt halten und anschließend Delete auf der Tastatur drücken.
  • Biegelinien können nicht auf den Rand eines Leiterplattenausschnitts angewendet werden. Falls dies für Ihre Leiterplatte erforderlich ist, wechseln Sie in den Modus „Rigid-Flex Advanced“.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents