Bauteilplatzierung
Altium Essentials: PCB Component Placement
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Sie erfahren, was ein Bauteil-Footprint auf einer Leiterplatte umfasst – von Pads und Bestückungsdruckelementen bis hin zu optionalen 3D-Körpern.
- Sie lernen, welche Bauteileigenschaften in Altium Designer die Platzierung, Ausrichtung, Lagenzuordnung und Identifikation beeinflussen.
- Sie sehen, wie verschiedene Bauteiltypen und Flächendefinitionen im PCB-Editor gehandhabt werden.
Es heißt, dass das Leiterplattendesign zu 90 % aus Platzierung und zu 10 % aus Routing besteht. Über die genauen Anteile lässt sich zwar streiten, doch es ist allgemein anerkannt, dass eine gute Bauteilplatzierung entscheidend für ein gutes Leiterplattendesign ist. Denken Sie daran, dass Sie die Platzierung möglicherweise auch während des Routings anpassen müssen.
Der Bauteil-Footprint definiert den Platzbedarf und die Anschlusspunkte, die für die Montage des physischen Bauteils auf der Leiterplatte erforderlich sind. Er ist ein Gruppenobjekt, das aus einer Sammlung einfacher Grundobjekte besteht, darunter Pads, Linien und Bögen sowie weitere Designobjekte.

Der Bauteil-Footprint definiert die Montage und die Anschlüsse des Bauteils auf der Leiterplatte und kann auch 3D-Körperobjekte enthalten, die das tatsächliche Bauteil beschreiben.
Die Pads dienen als Montage- und Anschlusspunkte für die Bauteilpins. Zusätzliche Design-Grundobjekte wie Linien und Bögen werden häufig verwendet, um den Umriss des Bauteils auf der Bestückungsdrucklage (Siebdrucklage) darzustellen.
Der Bauteil-Footprint kann auch optionale 3D-Körperobjekte enthalten, die den physischen Raumbedarf bzw. die Hüllkontur des tatsächlichen, auf der Leiterplatte montierten Bauteils definieren. Wenn das physische Bauteil mithilfe von 3D-Körperobjekten oder importierten STEP-Modellen definiert wurde, kann eine dreidimensionale Prüfung der Bauteilabstände durchgeführt werden.
Bauteil-Footprints werden im PCB-Footprint-Editor erstellt, indem geeignete Designobjekte so platziert werden, dass sie die für die Montage und den Anschluss des Bauteils erforderliche Form bilden. Der Referenzpunkt des Bauteils ist der Ursprung des Arbeitsbereichs im PCB-Footprint-Editor. Er kann im Editor auf Pin 1, den geometrischen Mittelpunkt oder eine benutzerdefinierte Position am Bauteil gesetzt werden. Weitere Informationen zum Erstellen von Footprints finden Sie auf der Seite Erstellen eines PCB-Footprints.
Bauteileigenschaften

Der Modus Component des Panels Properties.
Registerkarte „Allgemein“
Position
-
(X/Y)
-
X (erstes Feld) – die aktuelle X-Koordinate (horizontal) des Referenzpunkts des Bauteils relativ zum aktuellen Ursprung des Arbeitsbereichs. Bearbeiten Sie diesen Wert, um die X-Position des Bauteils zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht. Der Referenzpunkt eines Bauteil-Footprints wird im Bibliothekseditor festgelegt.
-
Y (zweites Feld) – die aktuelle Y-Koordinate (vertikal) des Referenzpunkts des Bauteils relativ zum aktuellen Ursprung. Bearbeiten Sie diesen Wert, um die Y-Position des Bauteils zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht. Der Referenzpunkt eines Bauteil-Footprints wird im Bibliothekseditor festgelegt.
-
-
Rotation – der Drehwinkel des Bauteils (in Grad), gegen den Uhrzeigersinn ausgehend von null (der 3 o'clock Horizontalen) gemessen. Bearbeiten Sie diesen Wert, um die Drehung des Bauteils zu ändern. Die minimale Winkelauflösung beträgt 0,001°.
Eigenschaften
-
Layer – legt die Lage fest, auf der das Bauteil platziert wird. Bauteile können der oberen oder unteren Lage zugewiesen werden. Wählen Sie über die Dropdown-Liste eine andere Lage aus. Beim Ändern der Lage werden alle Grundobjekte des Bauteils auf die jeweils gegenüberliegende Lage verschoben. Wird beispielsweise ein Bauteil von der oberen auf die untere Lage verschoben, werden einlagige Pads von der oberen auf die untere Lage verschoben, Grundobjekte auf der oberen Bestückungsdrucklage werden der unteren Bestückungsdrucklage zugewiesen, und Grundobjekte auf einer gepaarten mechanischen Lage werden auf die andere mechanische Lage dieses Paars verschoben. Die Ausrichtung des Bauteils wird an der X-Achse gespiegelt, und der Text auf der Bestückungsdrucklage ist von unten lesbar.
-
Reuse Block – wenn das Bauteil Teil eines Wiederverwendungsblocks ist, zeigt dieses Feld den Namen des übergeordneten Wiederverwendungsblocks an. Klicken Sie auf den Hyperlink Reuse Block, um die Eigenschaften dieses Wiederverwendungsblocks anzuzeigen.
-
Designator – der Bezeichner des Bauteils ist eine alphanumerische Zeichenfolge mit bis zu 255 Zeichen. Jedes Bauteil muss einen eindeutigen Bezeichner haben. Wechseln Sie zwischen
und
, um den Bezeichner ein- bzw. auszublenden. Klicken Sie auf den Hyperlink Designator, um die Eigenschaften des Bauteilbezeichners zu öffnen.
-
Comment – der Kommentar des Bauteils ist eine alphanumerische Zeichenfolge mit bis zu 255 Zeichen. Wechseln Sie zwischen
und
, um den Kommentar ein- bzw. auszublenden. Klicken Sie auf den Hyperlink Comment, um die Eigenschaften des Bauteilkommentars zu öffnen.
-
Area – die Fläche des platzierten Bauteils, angezeigt in den aktuellen Leiterplatteneinheiten. Die Fläche kann benutzerdefiniert festgelegt werden. Andernfalls wird sie automatisch anhand des Auswahlbereichs des Bauteils berechnet:
-
Um die Bauteilfläche zu definieren, bearbeiten Sie Area im Panel „Properties“ für den Footprint im PCB-Footprint-Editor. Um einen aktualisierten Footprint auf eine geöffnete Leiterplatte zu übertragen, klicken Sie im Panel PCB Library mit der rechten Maustaste auf den Footprint-Namen und wählen Sie anschließend Update PCB With <ComponentName> aus dem Kontextmenü.
-
Sie können die Fläche eines bereits auf einer Leiterplatte platzierten Bauteils auch benutzerdefiniert festlegen, indem Sie das Bauteil auswählen und anschließend den Wert in dieses Feld eingeben.
-
Um bei einem auf einer Leiterplatte platzierten Bauteil von einer benutzerdefinierten zu einer berechneten Fläche zu wechseln, löschen Sie den Wert in diesem Feld. Das Feld wird automatisch wieder mit dem berechneten Wert gefüllt.
-
Die automatisch berechnete Fläche ist die Fläche, die hervorgehoben wird, wenn Sie das Bauteil durch Anklicken auswählen. Die Auswahlfläche wird anhand der Geometrien auf dem Courtyard-Layer bestimmt. Ist dieser Layer nicht vorhanden, wird die Kombination der Geometrien auf dem Bestückungsdruck, der 3D-Körperobjekte und der Kupferlagen herangezogen (Zeichenfolgen sind ausgenommen). Die oberen Abbildungen unten zeigen die Bauteilfläche, wenn auf dem Courtyard-Layer eine Kontur definiert ist; die untere Abbildung zeigt die Fläche, wenn sie aus den Geometrien auf dem Bestückungsdruck, den 3D-Körperobjekten und den Kupferlagen berechnet wird.
► Erfahren Sie mehr darüber, wie die Auswahlfläche berechnet wird, und über die weiteren verfügbaren Modi zur Bestimmung der Auswahlfläche.
► Erfahren Sie mehr über das Arbeiten mit mechanischen Lagen.
-
-
Description – Beschreibung dieses Bauteils auf Bauteilebene. Üblicherweise wird die Beschreibung beim Erstellen des Bauteils festgelegt. Sie kann jedoch auch am Bauteil im Schaltplan bearbeitet oder hinzugefügt werden. Diese Beschreibung wird im Panel „Components“ angezeigt.
-
Type – wählen Sie hier einen der folgenden Bauteiltypen für den Bauteil-Footprint aus. Folgende Typen sind verfügbar:
-
Standard– diese Bauteile besitzen standardmäßige elektrische Eigenschaften, werden stets zwischen Schaltplan und Leiterplatte synchronisiert (Footprint, Pins/Pads und Netzzuweisungen müssen übereinstimmen) und sind in der Stückliste enthalten. Ein Beispiel ist ein elektrisches Standardbauteil wie ein Widerstand. -
Mechanical– diese Bauteile besitzen keine elektrischen Eigenschaften, werden nicht synchronisiert (Sie müssen sie in beiden Editoren manuell platzieren) und sind in der Stückliste enthalten. Ein Beispiel ist ein Kühlkörper. -
Graphical– diese Bauteile besitzen keine elektrischen Eigenschaften, werden nicht synchronisiert (Sie müssen sie in beiden Editoren manuell platzieren) und sind not in der Stückliste enthalten. Ein Beispiel ist ein Firmenlogo. -
Net Tie (in BOM)– diese Bauteile dienen dazu, zwei oder mehr unterschiedliche Netze kurzzuschließen. Sie werden stets zwischen Schaltplan und Leiterplatte synchronisiert (Footprint, Pins/Pads und Netzzuweisungen müssen übereinstimmen) und sind in der Stückliste enthalten. Sie unterscheiden sich von einem Standardbauteil dadurch, dass die durch Kupfer innerhalb des Footprints hergestellte Konnektivität nicht geprüft wird – dieses Kupfer ermöglicht das Kurzschließen der Netze. Hinweis: Aktivieren Sie die Option Verify Shorting Copper im Dialog Design Rule Checker, um zu prüfen, dass sich kein unverbundenes Kupfer innerhalb des Bauteils befindet. -
Net Tie– diese Bauteile dienen dazu, zwei oder mehr unterschiedliche Netze kurzzuschließen. Sie werden stets zwischen Schaltplan und Leiterplatte synchronisiert (Footprint, Pins/Pads und Netzzuweisungen müssen übereinstimmen) und sind not in der Stückliste enthalten. Sie unterscheiden sich von einem Standardbauteil dadurch, dass die durch Kupfer innerhalb des Footprints hergestellte Konnektivität nicht geprüft wird – dieses Kupfer ermöglicht das Kurzschließen der Netze. Hinweis: Aktivieren Sie die Option Verify Shorting Copper im Dialog Design Rule Checker, um zu prüfen, dass sich kein unverbundenes Kupfer im Bauteil befindet. -
Standard (No BOM)– diese Bauteile besitzen standardmäßige elektrische Eigenschaften, werden stets zwischen Schaltplan und Leiterplatte synchronisiert (Footprint, Pins/Pads und Netzzuweisungen müssen übereinstimmen) und sind not in der Stückliste enthalten. Ein Beispiel ist ein Testpunkt-Bauteil, das Sie aus der Stückliste ausschließen möchten. -
Jumper– diese Bauteile dienen dazu, Drahtbrücken in ein Leiterplattendesign aufzunehmen, beispielsweise auf einer einseitigen Leiterplatte, die sich nicht vollständig auf einer Lage routen lässt. Bei diesem Bauteiltyp werden der Bauteil-Footprint und die Pins zwischen Schaltplan und Leiterplatte synchronisiert, die Netzzuweisungen jedoch nicht. Das Bauteil ist in der Stückliste enthalten. Zusätzlich zur Auswahl dieser Option auf Bauteilebene muss für beide Pads des Bauteils dieselbe JumperID ungleich null eingestellt sein. Bauteile des Typs „Jumper“ müssen im Schaltplan nicht verdrahtet werden; sie müssen nur dann im Schaltplan enthalten sein, wenn sie in der Stückliste benötigt werden. Werden sie nicht in der Stückliste benötigt, können sie direkt auf der Leiterplatte platziert werden, wo Component Type festgelegt, JumperIDs eingestellt und Nets für die Pads manuell zugewiesen werden.
-
-
Design Item ID – zeigt die Design Item ID des ausgewählten Bauteils an. Dieses Feld kann nicht bearbeitet werden.
-
Source – zeigt das Quelldokument des Bauteils an. Klicken Sie auf
, um einen Dialog zum Suchen und Auswählen eines anderen Quelldokuments zu öffnen.
-
Revision State – zeigt den Zustand der Revision des Workspace-Bibliotheksbauteils hinsichtlich ihres Lebenszyklusstatus sowie ihres Revisionsstatus an, d. h., ob es sich um die neueste freigegebene Revision dieses Bauteils (
Up to date) oder um eine frühere Revision (Out of date) handelt. -
Height – ein Höhenfeld für das Bauteil. Dieses Feld definierte vor der Einführung des 3D-Körperobjekts die Höhe des Leiterplattenbauteils. Das 3D-Modell bietet jedoch eine bessere Methode zur Definition der Bauteilhöhe für Aufgaben wie die 3D-Kollisionserkennung. Beachten Sie, dass Altium MCAD CoDesigner den in diesem Feld „Height“ definierten Wert verwendet und nicht die Höhe des 3D-Modells (mehr erfahren).
-
3D Body Opacity – geben Sie die gewünschte Deckkraft in Prozent ein oder verwenden Sie den Schieberegler.
-
Primitives – klicken Sie zum Sperren/Entsperren auf das zugehörige Schlosssymbol.
– alle Primitive des Bauteils sperren, sodass es als einzelnes Objekt behandelt werden kann.
– entsperren, um die einzelnen Primitive zu bearbeiten, aus denen das Bauteil besteht. Nach der Bearbeitung sollten die Bauteilprimitive wieder gesperrt werden.
-
Strings – klicken Sie auf das zugehörige Schlosssymbol, um zu sperren/entsperren.
– alle Zeichenfolgen des Bauteils sperren.
– entsperren, um die Zeichenfolgen des Bauteils zu bearbeiten.
Footprint
- Footprint Name – zeigt den Namen des Footprints an, der dem ausgewählten Bauteil entspricht.
- Design Item ID – die Kennung des ausgewählten Bauteils.
- Source – Name des Workspace, in dem das ausgewählte Bauteil platziert wurde.
- Description – Beschreibung des Bauteil-Footprints, die im PCB-Footprint-Editor definiert wurde.
Tauschoptionen
- Enable Pin Swapping – aktivieren, um den Pintausch zu ermöglichen.
- Enable Part Swapping – aktivieren, um den Tausch von Teilbauteilen zu ermöglichen (z. B. vier Teilbauteile eines ICs der 74er-Serie).
Schaltplan-Referenzinformationen
- Designator – das Referenzkennzeichen des Schaltplanbauteils, dem dieses PCB-Bauteil zugeordnet wurde.
- Hierarchical Path – zeigt an, wo dieses Bauteil in der hierarchischen Struktur des Schaltplans zu finden ist.
- Channel Offset – wenn ein Design erstmals vom Schaltplan auf die Leiterplatte übertragen wird, erhält jedes Bauteil auf jedem Schaltplanblatt einen eindeutigen Kanal-Offset.
Registerkarte „Parameter“
- Table – zeigt Name, Value und Source jedes aufgeführten Parameters an.
Referenzkennzeichen und Kommentare von Bauteilen
Die Felder für Referenzkennzeichen und Kommentar sind untergeordnete Parameterobjekte eines PCB-Bauteils. Das Referenzkennzeichen dient dazu, jedes platzierte Bauteil eindeutig zu identifizieren und von allen anderen Bauteilen zu unterscheiden, die in sämtlichen PCB-Dokumenten des Projekts platziert sind. Der Kommentar dient dazu, einem platzierten Objekt zusätzliche Informationen hinzuzufügen. Sowohl Kommentar als auch Referenzkennzeichen werden konfiguriert, nachdem das übergeordnete Bauteilobjekt platziert wurde. Es handelt sich nicht um Designobjekte, die Sie direkt platzieren können.

Ein platziertes Referenzkennzeichenobjekt

Ein platziertes Kommentarobjekt
Die Referenzkennzeichen von PCB-2D/3D-Bauteilen werden während der Platzierung automatisch um eins erhöht, wenn das Referenzkennzeichen des ersten Bauteils mit einer Ziffer endet. Ändern Sie das Referenzkennzeichen des ersten Bauteils vor der Platzierung im Panel Eigenschaften.
Um alphabetische oder numerische Schrittweiten ungleich 1 für Referenzkennzeichen zu verwenden, nutzen Sie die Funktion Paste Array. Die Bedienelemente für diese Funktion finden Sie im Dialog „Einfügearray einrichten“, den Sie durch Klicken auf die Schaltfläche Paste Array im Dialog Paste Special (Edit » Paste Special) öffnen.
Bei der grafischen Bearbeitung können Sie ein platziertes Referenzkennzeichen- oder Kommentarobjekt direkt im Designbereich auswählen und seine Position, Drehung, Ausrichtung und Größe ändern.
Wenn ein Referenzkennzeichen- oder Kommentarobjekt ausgewählt ist, stehen folgende Bearbeitungsgriffe zur Verfügung:

Ein ausgewähltes Referenzkennzeichen
- Klicken und ziehen Sie B, um das Referenzkennzeichen/den Kommentar um seinen Bezugspunkt A zu drehen (gekennzeichnet durch das kleine x).
- Klicken und ziehen Sie C, um die Größe des Begrenzungsrahmens des Referenzkennzeichens/Kommentars gleichzeitig in vertikaler und horizontaler Richtung zu ändern.
- Klicken und ziehen Sie D, um die Größe des Begrenzungsrahmens des Referenzkennzeichens/Kommentars in vertikaler und horizontaler Richtung getrennt zu ändern.
-
Klicken Sie auf eine beliebige Stelle des Referenzkennzeichens/Kommentars außerhalb der Bearbeitungsgriffe und ziehen Sie es, um es neu zu positionieren. Während des Ziehens kann der Kommentar gedreht oder gespiegelt werden:
- Drücken Sie Spacebar, um das Referenzkennzeichen/den Kommentar gegen den Uhrzeigersinn zu drehen, oder Shift+Spacebar, um es im Uhrzeigersinn zu drehen. Die Drehung erfolgt entsprechend dem Wert für Rotation Step, der auf der Seite „PCB-Editor – Allgemein“ des Dialogs Preferences festgelegt ist.
- Drücken Sie die Tasten X oder Y, um das Referenzkennzeichen/den Kommentar entlang der X-Achse bzw. Y-Achse zu spiegeln.
Die Eigenschaften eines Referenzkennzeichen- oder Kommentarobjekts können im Modus Parameter des Panels Properties geändert werden.
Parametereigenschaften

Der Modus Parameter des Panels Properties.
Position
-
(X/Y)
-
X (erstes Feld) – die aktuelle X-Koordinate (horizontal) des Bezugspunkts des Referenzkennzeichens relativ zum aktuellen Ursprung des Arbeitsbereichs. Bearbeiten Sie diesen Wert, um die X-Position des Referenzkennzeichens zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie nicht der aktuellen Standardeinheit entspricht.
-
Y (zweites Feld) – die aktuelle Y-Koordinate (vertikal) des Bezugspunkts des Referenzkennzeichens relativ zum aktuellen Ursprung. Bearbeiten Sie diesen Wert, um die Y-Position des Referenzkennzeichens zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie nicht der aktuellen Standardeinheit entspricht.
-
- Rotation – der Drehwinkel des Referenzkennzeichens (in Grad), gegen den Uhrzeigersinn von null aus gemessen (der 3 o'clock Horizontalen). Bearbeiten Sie diesen Wert, um die Drehung des Referenzkennzeichens zu ändern. Die minimale Winkelauflösung beträgt 0,001°.
Eigenschaften
-
Parameter type – zeigt den Parametertyp (Bauteil, Blattsymbol usw.) und den Parameternamen an.
-
Name – der Name des Referenzkennzeichens.
-
Value – geben Sie in diesem Feld den gewünschten Wert des Referenzkennzeichens ein. Klicken Sie auf das Augensymbol, um die Sichtbarkeit des Werts im Designbereich ein- oder auszuschalten.
-
Layer - wählen Sie über die Dropdown-Liste die gewünschte Lage aus. Aktivieren Sie bei Bedarf Mirror .
-
Autoposition - wählen Sie über die Dropdown-Liste die gewünschte automatische Position relativ zum zugehörigen Objekt aus.
-
Text Height - geben Sie in diesem Feld die gewünschte Texthöhe ein.
-
Font Type
-
TrueType - wählen Sie diese Option, um die auf Ihrem PC verfügbaren Schriftarten (im Ordner \Windows\Fonts ) zu verwenden. TrueType-Schriftarten bieten vollständige Unicode-Unterstützung. Standardmäßig verknüpft die Software eine verwendete TrueType-Schriftart lediglich (sie wird nicht in der PCB-Datei gespeichert). Daher muss dieselbe Schriftart auf jedem PC vorhanden sein, auf den das Design übertragen wird. Alternativ können Sie verwendete TrueType-Schriftarten mit den Optionen auf der Seite PCB-Editor – TrueType-Schriftarten des Dialogs Preferences in die PCB-Datei einbetten. Dort können Sie auch eine Substitution Font auswählen, die verwendet wird, wenn eine nicht eingebettete Schriftart nicht verfügbar ist.
-
Justification - legen Sie hiermit die Position des Bezeichners innerhalb des Begrenzungsrechtecks fest.
- Left - klicken Sie auf die linke Schaltfläche, um den Text horizontal linksbündig auszurichten.
- Center - klicken Sie auf die mittlere Schaltfläche, um den Text horizontal zentriert auszurichten.
- Right - klicken Sie auf die linke Schaltfläche, um den Text horizontal rechtsbündig auszurichten.
- Above - klicken Sie auf die obere Schaltfläche, um den Text vertikal oben auszurichten.
- Middle - klicken Sie auf die mittlere Schaltfläche, um den Text vertikal mittig auszurichten.
- Below - klicken Sie auf die untere Schaltfläche, um den Text vertikal unten auszurichten.
-
Font - wählen Sie über die Dropdown-Liste die gewünschte TrueType-Schriftart aus. Verwenden Sie die Optionen B (bold) und/oder I (italic), um den Text nach Bedarf hervorzuheben.
-
Inverted - verwenden Sie , um den Text invertiert darzustellen und die Größe des Rahmens um den Text festzulegen. Mit den folgenden Optionen können Sie den Text weiter konfigurieren:
-
Size (Width/Height) -
- Width - die Breite des Begrenzungsrechtecks.
- Height - die Höhe des Begrenzungsrechtecks.
-
Size (Width/Height) -
-
Inverted - verwenden Sie , um den Text invertiert darzustellen und die Größe des Rahmens um den Text festzulegen. Mit den folgenden Optionen können Sie den Text weiter konfigurieren:
-
-
Stroke
-
Justification - legen Sie hiermit die Position des Bezeichners innerhalb des Begrenzungsrechtecks fest.
- Left - klicken Sie auf die linke Schaltfläche, um den Text horizontal linksbündig auszurichten.
- Center - klicken Sie auf die mittlere Schaltfläche, um den Text horizontal zentriert auszurichten.
- Right - klicken Sie auf die linke Schaltfläche, um den Text horizontal rechtsbündig auszurichten.
- Above - klicken Sie auf die obere Schaltfläche, um den Text vertikal oben auszurichten.
- Middle - klicken Sie auf die mittlere Schaltfläche, um den Text vertikal mittig auszurichten.
- Below - klicken Sie auf die untere Schaltfläche, um den Text vertikal unten auszurichten.
-
Font - wählen Sie über die Dropdown-Liste die gewünschte Strichschrift aus. Zur Auswahl stehen:
-
Default- eine einfache Vektorschrift, die für Stiftplotter und Vektorfotoplotter entwickelt wurde. -
Sans Serif- eine komplexe Schriftart, die die Erzeugung von Vektorausgaben, beispielsweise Gerber, verlangsamt. -
Serif- eine komplexe Schriftart, die die Erzeugung von Vektorausgaben, beispielsweise Gerber, verlangsamt.
-
- Stroke Width - zeigt die Strichbreite an.
-
Justification - legen Sie hiermit die Position des Bezeichners innerhalb des Begrenzungsrechtecks fest.
-
TrueType - wählen Sie diese Option, um die auf Ihrem PC verfügbaren Schriftarten (im Ordner \Windows\Fonts ) zu verwenden. TrueType-Schriftarten bieten vollständige Unicode-Unterstützung. Standardmäßig verknüpft die Software eine verwendete TrueType-Schriftart lediglich (sie wird nicht in der PCB-Datei gespeichert). Daher muss dieselbe Schriftart auf jedem PC vorhanden sein, auf den das Design übertragen wird. Alternativ können Sie verwendete TrueType-Schriftarten mit den Optionen auf der Seite PCB-Editor – TrueType-Schriftarten des Dialogs Preferences in die PCB-Datei einbetten. Dort können Sie auch eine Substitution Font auswählen, die verwendet wird, wenn eine nicht eingebettete Schriftart nicht verfügbar ist.
-
Border Mode
-
Margin - klicken Sie auf diese Schaltfläche, um die Bearbeitung der Option „Margin Border“ zu aktivieren.
- Text Offset - der Abstand, um den der Bezeichner von der Kante/Ecke zurückgesetzt wird, an der er ausgerichtet ist. Diese Option hat keine Auswirkung, wenn der Ausrichtungsmodus Center gewählt ist. Diese Option ist für Margin nicht verfügbar.
-
Offset - klicken Sie auf diese Schaltfläche, um die Bearbeitung der Option „Text Offset“ zu aktivieren.
- Margin Border - legen Sie hiermit die Größe des Randbereichs um den Bezeichner fest. Diese Option ist für Offset nicht verfügbar.
-
Margin - klicken Sie auf diese Schaltfläche, um die Bearbeitung der Option „Margin Border“ zu aktivieren.
Verfügbarkeit von Bauteilen auf der Leiterplatte
Wenn das Design vom Schaltplaneditor in den PCB-Editor übertragen wird, werden die PCB-Bauteil-Footprints automatisch aus den verfügbaren Bibliotheken platziert. Dies wird als Designsynchronisierung bezeichnet. Dabei werden Unterschiede zwischen Schaltplan und Leiterplatte erkannt und behoben.
Altium Designer unterstützt eine Reihe von Werkzeugen, die das Platzieren des benötigten Bauteil-Footprints im PCB-Designbereich erleichtern. Auf den folgenden Seiten erfahren Sie mehr über diese Werkzeuge:
Platzierte Bauteile durchsuchen
Im Modus des PCB-Panels Components ändern sich dessen drei Hauptbereiche, um die Bauteilhierarchie des aktuellen PCB-Designs widerzuspiegeln (von oben nach unten):
- Component Classes
- Components innerhalb einer Klasse
- Component Primitives

Die Bereiche des Panels PCB ermöglichen eine kumulative Filterauswahl von Bauteilklassen über einzelne Bauteile bis hin zu Bauteil-Primitiven.
Klicken Sie mit der rechten Maustaste auf den Eintrag eines Bauteils oder Bauteil-Primitivs und wählen Sie den Befehl Properties (oder doppelklicken Sie direkt auf den Eintrag), um das Panel Properties zu öffnen. Dort können Sie die Eigenschaften des Bauteils/Primitivs nach Bedarf anzeigen und ändern.
Klicken Sie mit der rechten Maustaste auf einen Bauteilklasseneintrag und wählen Sie Properties (oder doppelklicken Sie direkt auf den Eintrag), um den Dialog Bauteilklasse bearbeiten für diese Klasse zu öffnen. In diesem Dialog können Sie die zur Klasse gehörenden Bauteile anzeigen und ändern, die Klasse umbenennen oder weitere Klassen hinzufügen.

Bearbeiten einer ausgewählten Bauteilklasse.
Die Anzeige bzw. Einbeziehung der einzelnen Bauteil-Primitivtypen im Bereich Component Primitives des Panels hängt davon ab, ob die jeweilige Option im Kontextmenü aktiviert ist. Dieses Menü können Sie in den Bereichen Components oder Component Primitives aufrufen.

Klicken Sie mit der rechten Maustaste auf den Eintrag eines Bauteils oder Bauteil-Primitivs, um die einzubeziehenden Elemente auszuwählen.
Beim Durchsuchen können Bauteile einfach gesperrt oder entsperrt werden, indem Sie auf das Kästchen rechts neben der Spalte Footprint im Bereich Components doppelklicken.

Durch das Sperren/Entsperren im Panel PCB müssen Sie nicht durch das Panel Properties navigieren.
Begrenzungsrahmen der Bauteilauswahl
Wenn Sie auf ein Bauteil klicken und es auswählen, wird der Auswahlbegrenzungsrahmen angezeigt. Welche Layer zur Definition dieses Rahmens verwendet werden, lässt sich mit der Option PCB.ComponentSelection im Dialog Erweiterte Einstellungen festlegen. Die Option unterstützt drei Modi (geben Sie den Wert 0, 1 oder 2 ein; der Standardmodus ist 2):
-
0 - legacy mode– Dieser Modus kombiniert die Geometrien aller Layer mit Ausnahme der Zeichenfolgen für Bauteilbezeichnung und Kommentar auf dem Bestückungsdruck. -
1 - by layer mode– Verwendet die Geometrien des ersten der unten aufgeführten Layer, der Objekte enthält, mit folgender Priorität:-
Layer vom Typ Courtyard
-
3D-Körper-Layer (STEP-Modelle werden in einem 3D-Körperobjekt gespeichert, dessen Größe dem kleinsten rechteckigen Quader entspricht, der das Modell umschließt. Für die Bauteilauswahl wird dieser 3D-Körper verwendet, nicht die Form des STEP-Modells)
-
Bestückungsdruck-Layer und Kupferlagen
-
Kupferlagen
-
-
2 - by graphic mode– Dieser Modus kombiniert die Geometrien, die auf Layern vom Typ Courtyard, dem Bestückungsdruck, in 3D-Körperobjekten und auf Kupferlagen erkannt werden. Zeichenfolgen werden ausgeschlossen.
Primitive zu einem Bauteil hinzufügen
Ausgewählte Primitive können einem Bauteil hinzugefügt werden, indem Sie den Befehl Tools » Convert » Add Selected Primitives to Component aus den Hauptmenüs wählen. Wählen Sie nach dem Aufrufen des Befehls das Bauteil aus, dem Sie die ausgewählten Primitive hinzufügen möchten. Nach der Bestätigung werden die neuen Primitive als Teil des einzelnen Bauteilobjekts erkannt und können zusammen mit den ursprünglichen Primitiven des Bauteils verwendet werden.
Die Primitive des Zielbauteils müssen entsperrt sein, um diesen Vorgang auszuführen. Verwenden Sie das Schlosssymbol Primitives in den Bauteileigenschaften, um die Bauteilprimitive zu entsperren.
Ein Bauteil in Primitive zerlegen
Ein Bauteil kann mit dem Befehl Tools » Convert » Explode Component to Free Primitives aus den Hauptmenüs in seine einzelnen primitiven Objekte umgewandelt werden. Alternativ klicken Sie mit der rechten Maustaste auf ein platziertes Bauteil (ausgewählt oder nicht) und wählen anschließend den Befehl Component Actions » Explode Component To Free Primitives (oder Explode Selected Components To Free Primitives) aus dem Kontextmenü. Ein zerlegtes Bauteil ist kein Bauteil mehr. Daher werden Bauteilbezeichnung und Kommentar entfernt, und das Bauteil wird wieder in die verschiedenen Primitive aufgelöst, aus denen es bestand.
Das Zerlegen hat keine Auswirkungen auf das Footprint-Modell, das in der zugehörigen Quellbibliothek gespeichert ist, sondern nur auf die umgewandelten Instanzen der im PCB-Dokument platzierten Bauteile.
Klickbare Links zu Referenzinformationen aufrufen
Wenn dem Bauteil benannte Dokumentlinks hinzugefügt wurden, kann die angegebene Dokument-/Seiten-URL für das ausgewählte Bauteil oder das Bauteil unter dem Mauszeiger geöffnet werden. Diese URL wird über einen definierten, zugrunde liegenden URL-Linkparameter angegeben. Mit dieser Funktion können benannte Dokumentlinks, die von Schaltplanbauteilen übertragen wurden, als benannte PCB-Bauteillinks zu PDFs, Textdateien oder HTML-Seiten bereitgestellt werden. Dies geschieht, wenn die benannten Dokumentlinks für das Bauteil vom Schaltplan auf die Leiterplatte übertragen wurden (Design » Update PCB Document). Während dieses Aktualisierungsvorgangs (über einen ECO) werden die benannten Dokumentlinks aus dem Schaltplan in ComponentLink-Parameterpaare (ComponentLinknDescription/ComponentLinknURL) für das entsprechende PCB-Bauteil umgewandelt. Zum Beispiel:
| Parameter des Schaltplanbauteils | Parameter des PCB-Bauteils | |||
|---|---|---|---|---|
| Name | Url |
⇒ |
Name | Value |
STM32 Family Web Page |
http://www.st.com/stm32 |
ComponentLink1Description |
STM32 Family Web Page |
|
ComponentLink1URL |
http://www.st.com/stm32 |
|||
Die in den Bauteilparametern verwendete Link-Indexnummer (n) legt die Position des entsprechenden PCB-Bauteillinks in der Reihenfolge im Untermenü References fest. Wenn ein Bauteil auf der Leiterplatte ausgewählt ist, werden die definierten ComponentLink-Parameterpaare im Abschnitt Parameters des Panels „Eigenschaften“ angezeigt.
Nach dem Aufrufen des Befehls wird die webbasierte URL-Zielseite oder das angegebene Dokument direkt geöffnet (sofern verfügbar).

).