High-Speed-Design
Auf einen Blick
- Erfahren Sie, welche wesentlichen Faktoren beim High-Speed-Design Sie mit Altium Designer berücksichtigen können – von Terminierung und Rückstrompfaden bis hin zu Durchkontaktierungen, differenziellen Paaren und Längenkontrolle.
- Erfahren Sie, wie Sie mithilfe der Signalintegritätsanalyse vor und nach dem Layout potenzielle Reflexionsprobleme erkennen und die Wahl der Terminierung optimieren können.
- Lernen Sie, wie Sie mit xSignals, Impedanzprofilen im Lagenaufbau und Routing-Designregeln kritische High-Speed-Signalpfade definieren, vermessen und kontrollieren.
High-Speed-Design in Altium Designer
Beim High-Speed-Leiterplattendesign werden die Anforderungen an das Schaltungsdesign, die Bauteiltechnologien sowie die Fertigungsmaterialien und -verfahren aufeinander abgestimmt, um eine Leiterplatte zu entwickeln, die Signale zwischen den Bauteilen unter Wahrung der Signalintegrität übertragen kann.
Zu berücksichtigende Aspekte
Beim Routing einer Leiterplatte mit High-Speed-Signalen müssen Sie folgende Aspekte berücksichtigen:
-
Gegebenenfalls erforderliche Terminierungsbauteile
-
Die Definition der Signale, auf die High-Speed-Designregeln angewendet werden müssen
-
Die geometrischen Abmessungen der Leiterbahnen für impedanzkontrolliertes Routing
-
Die Eigenschaften und Abmessungen der Leiterplattenmaterialien
-
Die Anzahl und Anordnung der Lagen im Lagenaufbau
-
Den Rückstrompfad jedes High-Speed-Signals
-
Die Auswirkungen und Konfiguration von Vias
-
Die Konfiguration und das Routing differenzieller Paare
-
Die Konfiguration und Kontrolle der Leiterbahnlängen
Signalintegritätsanalyse vor und nach dem Layout
Bereits in einer frühen Phase des Designprozesses ist es wichtig, Signale zu identifizieren, die möglicherweise eine Impedanzanpassung erfordern, damit zusätzliche Terminierungsbauteile noch vor Abschluss der Bauteilplatzierung berücksichtigt werden können. Da Ausgangspins in der Regel niederohmig und Eingangspins in der Regel hochohmig sind, müssen dem Design gegebenenfalls Terminierungsbauteile hinzugefügt werden, um eine Impedanzanpassung zu erreichen.
Altium Designer enthält einen Signalintegritätssimulator, der sowohl während der Schaltplanerfassung als auch während des Leiterplattenlayouts verfügbar ist. Dadurch lässt sich die Signalintegrität sowohl vor als auch nach dem Layout analysieren (Tools » Signal Integrity). Der Signalintegritätssimulator modelliert das Verhalten der gerouteten Leiterplatte anhand der berechneten charakteristischen Impedanz der Leiterbahnen in Kombination mit Makromodelldaten der E/A-Puffer, die als Eingabedaten für die Simulationen dienen. Der Simulator basiert auf einem schnellen Reflexions- und Übersprechsimulator, der mithilfe industriell bewährter Algorithmen sehr genaue Simulationen liefert.
Da sowohl die Schaltplanerfassung als auch das Leiterplattendesign ein integriertes Bauteilsystem verwenden, das Schaltplansymbole mit den zugehörigen Leiterplatten-Footprints, SPICE-Simulationsmodellen und Signalintegritäts-Makromodellen verknüpft, kann die Signalintegritätsanalyse bereits während der Schaltplanerfassung und vor der Erstellung des Leiterplattendesigns durchgeführt werden. Wenn noch kein Leiterplattendesign vorhanden ist, können Sie die physikalischen Eigenschaften des Designs, beispielsweise die gewünschte charakteristische Leiterbahnimpedanz, direkt im Signalintegritätssimulator festlegen. In dieser Phase vor dem Layout kann der Signalintegritätssimulator die tatsächliche Länge einzelner Verbindungen noch nicht ermitteln. Daher verwendet er für seine Übertragungsleitungsberechnungen eine benutzerdefinierbare durchschnittliche Verbindungslänge. Wenn Sie diesen Standardwert sorgfältig so wählen, dass er die Abmessungen der geplanten Leiterplatte widerspiegelt, erhalten Sie ein recht genaues Bild der voraussichtlichen Signalintegrität des Designs.
Netze mit potenziellen Reflexionsproblemen lassen sich identifizieren und gegebenenfalls erforderliche zusätzliche Terminierungsbauteile können dem Schaltplan hinzugefügt werden, bevor Sie mit dem Leiterplattenlayout fortfahren. Die Werte dieser Bauteile können nach der Signalintegritätsanalyse im Anschluss an das Layout weiter optimiert werden.

Die Signalintegritätsanalyse hilft dabei, Netze mit potenziellen Reflexionsproblemen zu identifizieren. Beachten Sie, dass Messwerte direkt aus den Signalverläufen abgelesen werden können.
► Erfahren Sie mehr über die Impedanzanpassung der Bauteile
High-Speed-Signale definieren
Main page: High-Speed-Signalpfade mit xSignals definieren
High-Speed-Design ist die Kunst, den Energiefluss von einem Punkt auf einer Leiterplatte zu einem anderen zu steuern. Als Entwickler müssen Sie sich auf ein Signal konzentrieren können, das von einem bestimmten Punkt auf der Leiterplatte zu einem anderen verläuft, und die Designvorgaben gezielt darauf anwenden können. Dieses Signal entspricht jedoch nicht zwangsläufig einem einzelnen Leiterplattennetz. Es könnte sich beispielsweise um einen Zweig von A0 in einem Design handeln, das Sie in einer T-Verzweigungstopologie routen möchten. Der andere Zweig von A0 ist dann ein weiteres Signal, das Sie ebenfalls betrachten und dessen Leiterbahnlänge Sie mit der des ersten Signals vergleichen müssen. Oder der Signalpfad enthält ein Serienterminierungsbauteil, das der Leiterplatteneditor als ein Bauteil und zwei Leiterplattennetze betrachtet. Gehört dieses Signal zu einem differenziellen Paar, muss seine Länge mit der des anderen Signals in diesem Paar verglichen werden.
Diese Anforderungen lassen sich mit der Funktion xSignals verwalten. Ein xSignal ist im Wesentlichen ein benutzerdefinierter Signalpfad. Sie wählen das Quellpad und das Zielpad aus – im Arbeitsbereich oder im Panel PCB – und klicken anschließend mit der rechten Maustaste auf eines der beiden Pads, um diesen Signalpfad als xSignal zu definieren. Neben der interaktiven Definition eines xSignals über sein Start- und Endpad können Sie auch den intelligenten xSignals-Assistenten ausführen. Dessen Heuristiken helfen Ihnen, schnell eine große Anzahl von xSignals zwischen den ausgewählten Bauteilen einzurichten. Mit diesen xSignals können Sie anschließend Designregeln gezielt auf Ihre High-Speed-Signale anwenden. Die Software erkennt die Struktur dieser xSignals und berechnet beispielsweise die Gesamtlänge mehrerer Netze, die über ein Terminierungsbauteil verbunden sind, einschließlich der Strecke durch dieses Bauteil.
Das Panel PCB bietet einen xSignal-Modus, mit dem Sie xSignals untersuchen und verwalten können. Das Panel gibt außerdem Rückmeldung zur Signallänge und hebt xSignals hervor, die nahe an den Grenzwerten der geltenden Designvorgaben liegen (gelb) oder diese nicht erfüllen (rot). In der folgenden Abbildung unterscheiden sich die xSignal-Längen des differenziellen Paars CLK1 stärker, als es die geltende Designregel für den Längenabgleich zulässt. Das Panel enthält die Angabe Signal Length, die eine genaue Punkt-zu-Punkt-Länge darstellt. Typische Ungenauigkeiten bei der Längenberechnung, etwa durch Leiterbahnen innerhalb von Pads und übereinanderliegende Leiterbahnsegmente, werden korrigiert. Zudem werden zur Berechnung der Signallänge die tatsächlichen Strecken durch die Vias verwendet.

Verwenden Sie den xSignals-Modus des Panels PCB , um Ihre xSignals zu verwalten und zu untersuchen. Beachten Sie die dünne Linie: Sie kennzeichnet den Signalpfad durch ein Serienbauteil. (Bild mit freundlicher Genehmigung von FEDEVEL Open Source, www.fedevel.com)
Routing-Eigenschaften definieren
Main page: Impedanzkontrolliertes Routing
Traditionell legten Leiterplattendesigner die Breite und Dicke der Leiterbahnen fest, indem sie einen Wert für die Breite eingaben und eine Kupferdicke für die jeweilige Lage auswählten. Dies war in der Regel ausreichend, da lediglich sichergestellt werden musste, dass die Leiterbahnen den Strom führen konnten und die erforderlichen spannungsabhängigen Isolationsabstände eingehalten wurden. Für die High-Speed-Signale in Ihrem Design reicht dieser Ansatz jedoch nicht aus. Bei diesen müssen Sie die Impedanz der Leiterbahnen kontrollieren.
Beim impedanzkontrollierten Routing werden die Abmessungen der Leiterbahnen und die Eigenschaften der Leiterplattenmaterialien so aufeinander abgestimmt, dass eine bestimmte Impedanz erreicht wird. Dazu definieren Sie ein geeignetes Impedanzprofil und weisen dieses anschließend in den Routing-Designregeln den kritischen High-Speed-Netzen zu.
Definieren des Impedanzprofils
Main page: Konfigurieren des Lagenaufbaus für impedanzkontrolliertes Routing
Impedanzprofile werden im Layer Stack Manager des PCB-Editors definiert (Design » Layer Stack Manager). Der Layer Stack Manager wird wie ein Schaltplanblatt, die Leiterplatte und andere Dokumenttypen in einem Dokumenteditor geöffnet.
Nachdem Sie die Lageneigenschaften konfiguriert haben, wechseln Sie zur Registerkarte Layer Stack Manager's Impedance, um Impedanzprofile für Einzelleitungen oder differenzielle Paare hinzuzufügen oder zu bearbeiten.
Ein 50-Ω-Impedanzprofil für einzelne Netze, die auf der obersten Lage geroutet werden. Bewegen Sie den Mauszeiger über das Bild, um die Einstellungen desselben Profils für Lage L3 anzuzeigen.
Konfigurieren der Designregeln
Die Impedanz einer Leiterbahn wird durch ihre Breite und Dicke sowie die Eigenschaften der umgebenden dielektrischen Materialien bestimmt. Auf Grundlage der im Layer Stack Manager definierten Materialeigenschaften werden beim Erstellen jedes Impedanzprofils die erforderlichen Leiterbahnbreiten berechnet. Je nach Materialeigenschaften kann sich die erforderliche Breite beim Wechsel der Routing-Lage ändern. Diese notwendige Anpassung der Breite beim Lagenwechsel wird automatisch durch die entsprechende Routing-Designregel verwaltet, die im Editor für Leiterplattenregeln und -beschränkungen (Design » Rules) konfiguriert ist.
Bei den meisten Leiterplattendesigns gibt es eine bestimmte Gruppe von Netzen, die impedanzkontrolliert geroutet werden müssen. Ein gängiger Ansatz besteht darin, eine Netzklasse oder eine Klasse differenzieller Paare zu erstellen, die diese Netze enthält, und anschließend eine Routing-Regel für diese Klasse anzulegen, wie in den folgenden Abbildungen gezeigt.
Normalerweise legen Sie die minimale, maximale und bevorzugte Breite manuell fest: entweder in den oberen Einstellungen für die Randbedingungen, um sie auf alle Lagen anzuwenden, oder einzeln für jede Lage in der Lagentabelle. Für impedanzkontrolliertes Routing aktivieren Sie stattdessen die Option Use Impedance Profile und wählen dann das gewünschte Impedanzprofil aus der Dropdown-Liste aus. Daraufhin ändert sich der Bereich Constraints der Regel. Als Erstes werden Sie feststellen, dass im Bereich der verfügbaren Lagen der Designregel nicht mehr alle Signallagen der Leiterplatte angezeigt werden, sondern nur noch die Lagen, die im ausgewählten Impedanzprofil aktiviert sind. Die Werte für die bevorzugte Breite und den Abstand differenzieller Paare werden entsprechend den für jede Lage berechneten Breiten und Abständen aktualisiert. Diese bevorzugten Werte können nicht bearbeitet werden, die minimalen und maximalen Werte hingegen schon. Stellen Sie diese auf geeignete kleinere bzw. größere Werte ein.
Designregel für die Leiterbahnbreite
Bei unsymmetrischen Netzen wird die Leiterbahnbreite durch die Designregel Leiterbahnbreite festgelegt.
Wenn Sie die Verwendung eines Impedanzprofils auswählen, werden die verfügbaren Lagen und die bevorzugten Breiten durch das ausgewählte Profil vorgegeben.
Designregel für das Routing differenzieller Paare
Das Routing differenzieller Paare wird durch die Designregel Routing differenzieller Paare gesteuert.
Bei einem differenziellen Paar werden die verfügbaren Lagen, die bevorzugte Breite und der bevorzugte Abstand durch das ausgewählte Profil vorgegeben.
► Erfahren Sie mehr über das Routing differenzieller Paare
Auswählen der Impedanz
Woher wissen Sie also, welche Zielimpedanz Sie wählen sollten? Diese richtet sich normalerweise nach der charakteristischen Quellimpedanz der verwendeten Logikfamilie oder Technologie. Beispielsweise hat ECL-Logik eine charakteristische Impedanz von 50Ω, während die Quellimpedanz von TTL im Bereich von 70Ω bis 100Ω liegt. 50Ω bis 60Ω ist eine gängige Zielimpedanz in vielen Designs. Bei differenziellen Paaren sind differenzielle Impedanzen von 90Ω oder 100 Ω üblich. Denken Sie daran: Je niedriger die Impedanz, desto höher die Stromaufnahme. Je höher die Impedanz, desto größer die Wahrscheinlichkeit elektromagnetischer Störaussendungen und desto anfälliger ist das Signal für Übersprechen.
Ein differenzielles Paar mit 100Ω lässt sich auch als zwei gleich lange, unsymmetrische Leiterbahnen mit jeweils 50Ω betrachten. Aufgrund der Kopplung zwischen den beiden Leiterbahnen ist dies jedoch nicht ganz korrekt. Die Kopplung wird mit abnehmendem Abstand stärker und verringert die differenzielle Impedanz des Paars. Um eine differenzielle Impedanz von 100Ω beizubehalten, kann die Breite jeder Leiterbahn reduziert werden. Dadurch erhöht sich die charakteristische Impedanz jeder Leiterbahn des Paars geringfügig um einige Ohm.
Definieren der Leiterplatteneigenschaften
Main page: Verwaltung des Lagenaufbaus
Die Materialien der Leiterplattenlagen, ihre Abmessungen sowie die Anzahl und Reihenfolge der Lagen werden im Lagenaufbau-Manager definiert. Hier konfigurieren Sie die verschiedenen Lagen, die zur Herstellung der fertigen Leiterplatte benötigt werden, einschließlich der kupfernen Signal- und Flächenlagen, der die Kupferlagen trennenden dielektrischen Schichten, der Deckschichten und des Bestückungsdrucks.

Alle zu fertigenden Lagen werden auf der Registerkarte „Lagenaufbau“ des Lagenaufbau-Managers definiert.
Konfigurieren der Durchkontaktierungen
Main page: Definieren der Durchkontaktierungstypen
Wie im Übersichtsabschnitt dieser Seite erwähnt, beeinflussen Vias die Impedanz der Signalführung und sind ein wichtiger Aspekt beim High-Speed-Design. Neben der Länge, dem Bohrungsdurchmesser und der Anschlussfläche des Vias, die die vom Signal wahrgenommene Impedanz beeinflussen, kann jeder ungenutzte Abschnitt der Via-Hülse als Stichleitung wirken und Signalreflexionen verursachen. Um dies zu vermeiden, können verschiedene Via-Typen für Verbindungen zwischen Lagen gefertigt werden, darunter Blind Vias, Buried Vias, µVias und Skip Vias. Alle diese Via-Typen werden in Altium Designer unterstützt.
Vias werden als Teil des Lagenaufbaus auf der Registerkarte Layer Stack Manager's Via Types definiert. Auch das Rückbohren ungenutzter Via-Hülsen wird unterstützt; die entsprechenden Einstellungen werden auf der Registerkarte Layer Stack Manager's Back Drills festgelegt (erfahren Sie mehr über die Konfiguration der Leiterplatte für das Rückbohren).
Alle fertigbaren Via-Typen können auf der Registerkarte „Via Types“ des Layer Stack Manager definiert werden.
Um die Auswirkungen von Vias zu verstehen, wurden quantitative Untersuchungen durchgeführt, beispielsweise in der Altera Application Note AN529 Techniken zur Via-Optimierung für High-Speed-Kanaldesigns.
Aus dieser Untersuchung und weiteren Quellen lassen sich die folgenden Richtlinien ableiten, um die Auswirkungen von Vias zu minimieren:
- Verkleinern Sie den Restring des Vias an der Stelle, an der die Signalleiterbahn an das Via angeschlossen ist. Die Application Note empfiehlt für mechanisch gebohrte Vias einen Via-Durchmesser/Bohrungsdurchmesser von 20/10 mil (0,5/0,25 mm).
- Entfernen Sie ungenutzte Restringe (auch als NFPs oder Non-Functioning Pads bezeichnet) auf Lagen, mit denen das Via nicht verbunden ist. Verwenden Sie dazu den Befehl Tools » Remove Unused Pad Shapes.
- Vergrößern Sie den Abstand zwischen der Via-Hülse und benachbarten Versorgungslagen. Dieser wird durch die Designregel „Power Plane Clearance“ gesteuert. Die Application Note empfiehlt 40 bis 50 mil (1,0 bis 1,25 mm). Beachten Sie, dass dadurch die Aussparungen in diesen Versorgungslagen größer werden.
- Platzieren Sie Stitching-Vias neben Signal-Vias, wenn ein Lagenwechsel der Signalleiterbahn dazu führt, dass der Rückstrompfad auf eine andere Lage wechselt. Wenn die neue Referenzlage dasselbe Potenzial wie die ursprüngliche Referenzlage hat, sollten diese Lagen durch ein Via miteinander verbunden werden, das höchstens 35 mil (0,9 mm) vom Signal-Via entfernt ist (Mitte zu Mitte).
- Wenn die Signalleiterbahn die Lage wechselt und die neue Referenzlage ein anderes Potenzial hat, platzieren Sie Entkopplungskondensatoren neben dem Signal-Via. Ein solcher Kondensator entkoppelt direkt zwischen den beiden Lagen, unabhängig von deren Potenzialen. Beachten Sie, dass diese Lösung dazu führen kann, dass Störungen von einer Lage auf die andere eingekoppelt werden. Sie sollte daher nur als letztes Mittel eingesetzt werden, um die Schleifenfläche des Rückstrompfads zu verringern.
- Entfernen Sie Via-Stubs (zusätzliche Via-Länge jenseits der Lage, auf der die Signalleiterbahn an das Via angeschlossen ist). Dies erfolgt durch die Verwendung geeigneter Blind Vias und Buried Vias oder durch Rückbohren der Vias während der Fertigung.
Rückstrompfade für High-Speed-Signale verwalten
Ein guter Rückstrompfad ist für jedes High-Speed-Signal im Design unerlässlich. Immer wenn der Rückstrompfad abweicht und nicht unter der Signalleiterbahn verläuft, entsteht eine Schleife. Diese Schleife verursacht elektromagnetische Störungen (EMI), deren Stärke direkt von der Schleifenfläche abhängt.
Versorgungsflächen erstellen
- Eine Versorgungsfläche kann entweder aus einer Versorgungslage oder aus einer Signallage erstellt werden, die mit einem oder mehreren Polygonen bedeckt ist.
-
Eine Versorgungsfläche mit einer Versorgungslage erstellen:
- Versorgungslagen werden im Layer Stack Manager hinzugefügt. Klicken Sie mit der rechten Maustaste auf eine vorhandene Lage und wählen Sie Insert layer above oder Insert layer below, um eine neue Versorgungslage hinzuzufügen.
- Wählen Sie die Versorgungslage als aktive Lage aus und doppelklicken Sie auf eine beliebige Stelle innerhalb der Fläche, um den Dialog „Split Plane“ zu öffnen. Dort können Sie das Netz zuweisen.
- Die Software zieht den Rand der Fläche automatisch um den Wert vom Leiterplattenrand zurück, der für diese Lage in der Spalte Pullback Distance im Layer Stack Manager angegeben ist. Wenn diese Spalte nicht sichtbar ist, klicken Sie mit der rechten Maustaste auf eine vorhandene Spaltenüberschrift, um auf den Befehl Select Columns zuzugreifen.
- Eine Versorgungslage kann durch das Platzieren von Linien (Place » Line) in separate Bereiche aufgeteilt werden. Drücken Sie Tab, nachdem Sie mit dem Platzieren des ersten Liniensegments begonnen haben, um die Breite der Trennlinie festzulegen. Platzieren Sie die Liniensegmente von einem Leiterplattenrand zum anderen oder erstellen Sie eine geschlossene Kontur für eine Insel. Die Software erkennt die durch die Trennlinien erzeugten separaten Flächen automatisch. Doppelklicken Sie auf jede Fläche, um ihr ein Netz zuzuweisen.
-
Eine Versorgungsfläche mit Polygonen auf einer Signallage erstellen:
- Signallagen werden im Layer Stack Manager hinzugefügt. Klicken Sie mit der rechten Maustaste auf eine vorhandene Lage und wählen Sie Insert layer above oder Insert layer below, um eine neue Signallage hinzuzufügen.
- Wenn separate Versorgungsbereiche benötigt werden, kann es einfacher sein, die gesamte Lage mit einem Polygon zu bedecken und dieses anschließend aufzuteilen (Place » Slice Polygon Pour). Drücken Sie Tab, nachdem Sie mit dem Platzieren der Schnittlinie begonnen haben, um den Dialog „Line Constraints“ zu öffnen. Dort können Sie die Schnittbreite festlegen. Diese Breite bestimmt den Abstand zwischen den beiden Polygonen, die durch das Aufteilen entstehen. Die Schnittlinie muss außerhalb des Polygons beginnen und außerhalb des Polygons enden.
- Um ein Polygon neu zu füllen, klicken Sie mit der rechten Maustaste und wählen Sie Polygon Actions » Repour Selected im Kontextmenü.
- Polygone können auch vorübergehend ausgeblendet werden. Klicken Sie dazu mit der rechten Maustaste und wählen Sie den entsprechenden Befehl im Polygon Actions Untermenü. Verwenden Sie diese Funktion, wenn Sie Bauteile und Leiterbahnen verschieben müssen.
- Es kann hilfreich sein, die verschiedenen Netze in unterschiedlichen Farben darzustellen, wie in den folgenden Abbildungen gezeigt. Dies ist im Schaltplan oder auf der Leiterplatte möglich. Erfahren Sie mehr über das Zuweisen von Farben zu Netzen.
Die erste Abbildung zeigt eine Versorgungslage, die in 3v3- und 5v0-Bereiche aufgeteilt ist; die zweite Abbildung zeigt eine Signallage mit einem 3v3-Polygon und einem 5v0-Polygon. Den Netzen wurden Farben zugewiesen und die Hervorhebung wurde aktiviert.
Die Fläche als Signalrückstrompfad
Ein guter Rückstrompfad zeichnet sich dadurch aus, dass:
- in der als Rückstrompfad dienenden Fläche (der dem betreffenden Signal nächstgelegenen Fläche) unterhalb der Signalleiterbahn keine Unterbrechungen, Aufteilungen oder Aussparungen (durch ein Via oder einen bedrahteten Anschluss erzeugte Löcher in der Fläche) vorhanden sind.
- Die Breite des Rückstrompfads beträgt idealerweise das Dreifache der Breite der Signalleiterbahn oder das Dreifache des Abstands zwischen Leiterbahn und Fläche, je nachdem, welcher Wert kleiner ist. Die höchste Stromdichte liegt zwar direkt unter der Signalleiterbahn, der Strom breitet sich jedoch auch zu beiden Seiten der Leiterbahn in der Fläche aus, wobei etwa 95 % innerhalb der dreifachen Leiterbahnbreite fließen. Unterbrechungen der Fläche in diesem Bereich erhöhen die Impedanz des Rückstrompfads, und jede Abweichung des Rückstrompfads erzeugt eine Schleife. Hinsichtlich der Signalintegrität beeinträchtigt diese erhöhte Impedanz des Rückstrompfads die Signalqualität ebenso stark wie eine Erhöhung der Impedanz des Signalpfads.
- Die Schleifenfläche wurde minimiert. Im Allgemeinen ist es wichtiger, die Schleifenfläche zu verringern, als die Länge der verlegten Signalleiterbahn zu minimieren. Trifft der Rückstrompfad auf eine Aussparung, sollten Sie erwägen, die Signalleiterbahn so neu zu verlegen, dass sie einem verfügbaren Rückstrompfad folgt.
- Wenn eine Versorgungsfläche den Rückstrompfad bereitstellt, gelangt die Rückstromenergie letztlich über einen Entkopplungskondensator zur Masse. Wählen Sie die Position der Entkopplungskondensatoren in der Nähe des Quellpins des Signals sorgfältig, um die Fläche entstehender Schleifen zu minimieren.
Umgang mit geteilten und mehreren Versorgungs- und Masseflächen
Es besteht allgemeine Einigkeit darüber, dass eine Massefläche nur dann geteilt werden sollte, wenn eine konkrete Anforderung dafür besteht und Sie wissen, wie eine solche Teilung zu definieren und zu handhaben ist. Stattdessen sollten die Bauteile so angeordnet werden, dass störungsreiche und störungsarme Bauteile voneinander getrennt bleiben. Außerdem sollten Bauteile nach der jeweils verwendeten Versorgungsschiene gruppiert werden.
Weitere Punkte, die bei Versorgungs- und Masseflächen zu beachten sind:
- Wenn das Design eine teilweise geteilte Massefläche erfordert, sollten Signale, die diese Bereiche durchqueren, über die Brücke geführt werden, also über den Bereich, unter dem die Fläche nicht geteilt ist.
- Wenn Sie Störungen in der Schaltung minimieren möchten, ist es besser, zusätzliche Masseflächen zu verwenden, als eine Fläche zu teilen. Sehen Sie nach Möglichkeit für jede geregelte Stromversorgung sowohl für die Versorgungs- als auch für die Masseschiene eigene Flächenlagen vor.
- Wenn das Design mehrere Versorgungsschienen umfasst, die jeweils über eine eigene Fläche verteilt werden, stellen Sie sicher, dass jede Versorgungsfläche nur ihre eigene Massefläche als Referenz verwendet. Eine Versorgungsfläche darf die Massefläche einer anderen Versorgungsschiene nicht überlappen und damit als Referenz verwenden. Dadurch entsteht eine kapazitive Kopplung, über die Störungen von einer Versorgung auf eine andere übertragen werden können.
- Wenn die benachbarte Fläche eine Versorgungsfläche ist, die in Bereiche unterschiedlicher Spannung aufgeteilt werden muss, kann eine direkte Entkopplung zwischen den beiden Spannungsbereichen erforderlich sein, um einen geeigneten Rückstrompfad bereitzustellen.
Geteilte Flächen visualisieren
Zur visuellen Prüfung der Rückstrompfade können Sie die Anzeige so konfigurieren, dass sich der Rückstrompfad unter kritischen Leiterbahnverläufen leichter untersuchen lässt.

Prüfung, ob Signale beim Durchqueren unterschiedlicher Spannungsbereiche auf der Fläche eine Trennlinie überqueren. Die vier hervorgehobenen Netze überqueren eine Teilung in der VCC-Versorgungsfläche, wodurch der Rückstrompfad dieser Signale unterbrochen wird.
Gehen Sie dazu wie folgt vor:
- Weisen Sie jedem Versorgungsnetz eine Farbe zu. Weitere Informationen finden Sie unter Netzen Farben zuweisen.
- Beschränken Sie die angezeigten Lagen auf die relevanten Signal- und Flächenlagen. Diese Zusammenstellung von Lagen kann als Lagensatz gespeichert werden. Weitere Informationen finden Sie unter Einen Lagensatz erstellen.
- Wechseln Sie zur Signallage und verwenden Sie Ctrl+Click auf dem gewünschten Netz, um es hervorzuheben (halten Sie beim Klicken zusätzlich Shift gedrückt, um mehrere Netze hervorzuheben). Der Vorteil des Hervorhebens gegenüber dem Auswählen besteht darin, dass die Hervorhebung erhalten bleibt, auch wenn Sie an eine andere Stelle klicken. Drücken Sie Shift+C , um die aktuelle Hervorhebung aufzuheben.
- Die Hervorhebung erfolgt durch Abblenden der übrigen Objekte im Designbereich. Die Dimmed Objects-Stufe wird im Abschnitt Maskierungs- und Abblendeinstellungen des Panels View Configuration festgelegt.
- Machen Sie die Flächenlage zur aktiven Lage.
Ihre Netze heben sich nun deutlich ab, und Teilungen oder Unterbrechungen im Rückstrompfad, etwa Trennlinien oder durch Durchsteckpads und Vias erzeugte Aussparungen, sind leichter zu erkennen.
Unterbrechungen im Rückstrompfad erkennen
Unterbrechungen oder Engstellen im Rückstrompfad lassen sich mit der Designregel „Return Path“ erkennen. Die Designregel „Return Path“ prüft, ob auf den festgelegten Referenzlagen oberhalb oder unterhalb der von der Regel erfassten Signale ein durchgehender Signalrückstrompfad vorhanden ist. Der Rückstrompfad kann aus Füllflächen, Regionen und Polygonflächen auf der als Referenz dienenden Signallage bestehen oder durch eine Flächenlage gebildet werden.
Die Rückstrompfadlagen sind die Referenzlagen, die im in der Designregel „Return Path“ ausgewählten Impedance Profile definiert sind. Diese Lagen werden darauf geprüft, ob die angegebene Minimum Gap (Breite über die Signalkante hinaus) entlang des Signalpfads vorhanden ist. Fügen Sie in der Regelkategorie High Speed eine neue Designregel „Return Path“ hinzu.

Die Rückstrompfadlagen werden im ausgewählten Impedance Profile definiert; die Pfadbreite (über die Signalkante hinaus) wird durch Minimum Gap festgelegt.
Das folgende Bild zeigt Rückstrompfadfehler, die für das Signal NetX mit einer Minimum Gap-Einstellung von 0.1mm erkannt wurden. Rückstrompfadfehler lassen sich leichter lokalisieren, wenn Sie DRC Violation Display Style im Dialog „Preferences“ so konfigurieren, dass Verletzungsdetails, jedoch keine Verletzungsüberlagerung angezeigt werden – Bild anzeigen. Dadurch werden genau die Stellen hervorgehoben, an denen die Regel verletzt wurde, statt der gesamten betroffenen Objekte.
Via-Prüfung des Rückstrompfads
Wenn ein High-Speed-Signal von einer Referenzebene zu einer anderen wechselt, sollten auch Rückstrom-Vias vorhanden sein, um die Rückströme zwischen den Ebenen zu führen. Um zu prüfen, ob ein solches Via innerhalb eines bestimmten Abstands zu einem Signal-Via vorhanden ist, legen Sie mithilfe der Option Max Stitch Via Distance in der entsprechenden Designregel Return Path fest, ob innerhalb eines vorgegebenen Abstands zu einem Via des Signals im Geltungsbereich ein Rückstrom-Via vorhanden sein muss. Das Rückstrom-Via sollte eine Verbindung zu der Referenzlage herstellen, die in Layer Stack Manager für das entsprechende Impedanzprofil definiert ist.
Wenn Max Stitch Via Distance in der Regel definiert ist, wird im Rahmen der Batch-DRC geprüft, ob innerhalb des angegebenen Abstands ein Rückstrom-Via vorhanden ist.

Ein Beispiel für eine Verletzung der Vorgabe für den maximalen Stitching-Via-Abstand. Hier befindet sich innerhalb des angegebenen Abstands zu einem Via des Netzes DQS4R_N kein Rückstrom-Via.
Differenzpaare konfigurieren und routen
Main pages: Routing von Differenzpaaren, Routing mit kontrollierter Impedanz
Differenzpaare können während der Schaltplanerstellung oder nach der Übertragung des Designs in das Leiterplattenlayout definiert werden. Eine grundlegende Voraussetzung für die Definition eines Paares im Schaltplan ist, dass der Netzname jedes betreffenden Netzes mit _P oder _N endet. Differenzpaare werden im Schaltplan gekennzeichnet, indem auf jedem Netz ein Differential Pair directive platziert wird oder indem eines auf einem Blanket directive platziert wird, wobei die Blanket-Direktive eine Gruppe eingeschlossener Netzbezeichnungen im Differenzpaarformat überdeckt, wie in der Abbildung unten gezeigt.
Mit einem Blanket können mehrere Netze als Mitglieder von Differenzpaaren konfiguriert werden.
Arbeiten mit Differenzpaaren:
- Im PCB-Editor können Differenzpaare im Modus Differential Pair Editor des Panels PCB definiert werden. Um die Definition von Designregeln für die Differenzpaare zu vereinfachen, können diese entweder Netzklassen oder Differenzpaarklassen zugewiesen werden. Beide werden im Object Class Explorer definiert.
- Um ein Differenzpaar mit kontrollierter Impedanz zu routen, erstellen Sie ein Impedanzprofil im Layer Stack Manager. Erfahren Sie mehr über das Routing mit kontrollierter Impedanz.
- Die Eigenschaften des Differenzpaar-Routings werden durch die Designregel Differential Pair Routing festgelegt.
-
Verwenden Sie zum Routen eines Differenzpaars den Routing-Befehl Interactive Differential Pair. Klicken Sie entweder auf das
_P- oder das_N-Pad, um das Routing zu beginnen, und verwenden Sie anschließend Spacebar, um die verfügbaren Austrittsformen der Leiterbahnen zu durchlaufen. Das Routing-Verhalten entspricht dem beim Routen einzelner Netze. Drücken Sie Shift+F1, um eine Liste der Tastenkombinationen für das interaktive Routing anzuzeigen. Wenn Sie sich den Ziel-Pads nähern, drücken Sie Ctrl+Click, um das Routing bis zu den Pads abzuschließen.
Faustregeln für Differenzpaare:
-
Der Längenabgleich ist entscheidend für die Wirksamkeit von Differenzpaaren. Halten Sie die Längenabweichungen innerhalb einer für die Signalübertragungstechnik geeigneten Toleranz. Gleichen Sie beispielsweise USB-3.x-Paare auf eine Abweichung von 5 bis 10 mil ab. Eine weitere Faustregel lautet, die Längen so abzugleichen, dass die Laufzeitdifferenz höchstens 20 % der Signalanstiegszeit beträgt. Die differenzielle Signalübertragung funktioniert, weil die Rückstromenergie über den anderen Leiter des Paares zurückfließt. Je größer die Längenabweichung ist, desto mehr Energie fließt stattdessen über die nächstgelegene Flächenlage zurück.
-
Unterbrechungen der Kopplung, etwa wenn die Leiter eines Paares auf unterschiedlichen Seiten um ein Hindernis herumgeführt werden, erhöhen die Impedanz. Es kann besser sein, das gesamte Paar mit schwächerer Kopplung zu routen (beispielsweise mit einem Abstand vom Zweifachen der Signalleiterbahnbreite), um Impedanzänderungen durch Kopplungsunterbrechungen zu verringern.
-
Halten Sie störende Leiterbahnen fern, insbesondere auf Außenlagen. Streben Sie zu potenziell störenden Netzen einen Abstand vom Dreifachen der Signalleiterbahnbreite an.
-
Als allgemeine Regel sollten Sie zwischen einem Paar und anderen Signalen einen Abstand vom Zweifachen der Signalleiterbahnbreite anstreben.
-
Halten Sie zu Massepolygonen auf derselben Lage einen Abstand von mindestens dem Dreifachen der Signalleiterbahnbreite ein.
-
Reflexionen, die durch Vias und Kopplungsdiskontinuitäten entstehen, werden durch Routing mit kontrollierter Impedanz beherrscht. Dafür ist eine durchgehende Referenzfläche unterhalb des Signalpfads erforderlich.
-
Verringern Sie den Abstand zwischen Signallage und Referenzfläche, um die Störfestigkeit gegenüber Übersprechen zu verbessern.
Kontrolle und Abstimmung der Leiterbahnlängen
Main pages: Längenabstimmung, Designregel für die Länge, Designregel für den Längenabgleich
Eine wesentliche Voraussetzung für den Umgang mit High-Speed-Signalen auf einer Leiterplatte ist die Kontrolle und Abstimmung ihrer Leiterbahnlängen.
- Die absoluten Längen können mit der Designregel für die Länge und die relativen Leiterbahnlängen mit der Designregel für den Längenabgleich überwacht werden.
- Die aktuellen Längen einer Gruppe von Netzen und die Einhaltung der geltenden Designregeln lassen sich im Panel PCB im Modus Nets überprüfen (siehe unten).
- Wenn eine Regel für die Länge und/oder den Längenabgleich definiert ist, können Sie die Länge während des interaktiven Routings oder der Längenabstimmung überwachen, indem Sie die Längenabstimmungsanzeige einblenden (Shift+G).
- Die durch die Pin-Länge innerhalb des Bauteilgehäuses verursachte Verzögerung wird berücksichtigt. Weitere Informationen finden Sie unter Pin-Verzögerung im Gehäuse.
- Netze, deren Signalpfad in Reihe geschaltete Bauteile enthält, werden durch die Definition von xSignals verwaltet.
Designregeln
- Managing the Overall Route Lengths – Die gesamte Leiterbahnlänge eines Netzes oder einer Gruppe von Netzen kann mit einer Designregel für die Länge überwacht werden. Diese Designregel legt eine zulässige Mindest- und Höchstlänge fest. Ist die Signallänge kleiner als das zulässige Minimum, wird sie im Panel PCB (im Modus Nets) gelb hervorgehoben. Eine Signallänge oberhalb des zulässigen Maximums wird rot hervorgehoben.
- Managing the Relative Route Lengths – Die relativen Leiterbahnlängen einer Gruppe von Netzen können mit einer Designregel für den Längenabgleich überwacht werden. Diese Designregel legt eine Toleranz fest und verwendet die längste Leiterbahn der betreffenden Netze als Referenzlänge. Eine gelbe Hervorhebung der Signallänge im Panel zeigt an, dass die Länge dieses Signals kleiner ist als die längste Leiterbahnlänge abzüglich der Toleranz. Eine rote Hervorhebung zeigt an, dass die Länge dieses Signals größer ist als die längste Leiterbahnlänge.
Wie die Einstellungen dieser beiden Regeln zusammenwirken, wenn beide in einem Design vorhanden sind, erfahren Sie auf der Seite Längenabstimmung.
Überwachen der Leiterbahnlänge
Die aktuellen Leiterbahnlängen werden im Modus Netze des Panels PCB angezeigt und während des Routings aktualisiert. Der Längenwert Routed wird gelb, wenn Sie sich der Ziellänge nähern, und rot, wenn Sie diese überschreiten.
Wenn eine Regel für die Länge und/oder den Längenabgleich definiert ist, können Sie die Länge während des interaktiven Routings oder der Längenabstimmung überwachen, indem Sie die Längenabstimmungsanzeige einblenden. Während des Routings können Sie die Anzeige mit dem Tastenkürzel Shift+G ein- und ausblenden.
Die Anzeige stellt die aktuell geroutete Länge als Zahlenwert über dem Schieberegler dar, während der Schieberegler die geschätzte Länge anzeigt. Während der Längenabstimmung gilt Estimated Length = Current Routed Length; wenn Sie die Anzeige beim interaktiven Routing verwenden, gilt Estimated Length = Routed Length + distance to target (length of connection line).
Die Einstellungen der Anzeige werden aus den Vorgaben der geltenden Regeln berechnet.
-
Das Minimum der Anzeige (linker Rand) beträgt 45 (niedrigster Wert von
MinLimit). -
Das Maximum der Anzeige (rechter Rand) beträgt 48 (höchster Wert von
MaxLimit). -
Der linke gelbe Balken (höchster Wert von
MinLimit) liegt bei 46,58. -
Der rechte gelbe Balken (niedrigster Wert von
MaxLimit) liegt bei 47,58 (in der Abbildung oben vom grünen Balken verdeckt). -
Der grüne Balken (
TargetLength) liegt bei 47,58 (Leiterbahnlänge des längsten Netzes der Gruppe, entsprichtMaxLimit). - Der grüne Schieberegler und der darüber angezeigte Zahlenwert (aktuelle Leiterbahnlänge) liegen bei 47,197.
Abstimmen der Leiterbahnlängen
Nach Abschluss des Routings können die Leiterbahnlängen mit dem Befehl Interactive Length Tuning oder dem Befehl Interactive Diff Pair Length Tuning (Menü Route) abgestimmt werden. Diese Befehle fügen mäanderförmige Abschnitte in die Leiterbahnführung ein, wobei drei Formen zur Auswahl stehen.
Wenn sowohl eine Regel für die Länge als auch eine Regel für den Längenabgleich gilt, berücksichtigt das Werkzeug zur Längenabstimmung beide Regeln und ermittelt daraus die strengsten Vorgaben. Ist also die durch die Längenregel festgelegte Maximallänge kürzer als die längste von der Längenabgleichsregel angestrebte Länge, hat die Längenregel Vorrang und ihre Länge wird bei der Abstimmung verwendet.
Um zu sehen, welche Regeln angewendet werden, oder um die Mäandereigenschaften während der Längenabstimmung zu ändern, drücken Sie Tab. Dadurch wird der Modus Interactive Length Tuning des Panels Properties geöffnet, wie unten gezeigt. Beachten Sie Target Length: Dies ist Max Limit der strengsten geltenden Regeleinstellungen.

Drücken Sie während der Längenabstimmung Tab, um das Panel im Modus Interactive Length Tuning zu öffnen. Dort können Sie den Ziellängenmodus auswählen und die Mäanderparameter anpassen.
Um die Länge eines Netzes abzustimmen, führen Sie den Befehl aus und klicken Sie dann auf eine beliebige Stelle entlang des Netzes. Bewegen Sie den Cursor entlang des Leiterbahnverlaufs. Dabei werden Mäanderabschnitte zur Längenabstimmung eingefügt. Es werden so lange weitere Abschnitte hinzugefügt, bis die Längenanforderungen der geltenden Designregeln erfüllt sind. Wenn sich der Cursor außerhalb der Grenzen der Abstimmungsmäander befindet, verschwinden die Mäanderformen. Sobald der Cursor wieder innerhalb dieser Grenzen liegt, werden sie erneut angezeigt.
Weitere Informationen finden Sie unter Längenabstimmung.
Fazit
Es lässt sich zwar kein universeller Regelsatz ableiten, der für jedes High-Speed-Design gilt, doch bewährte Designpraktiken helfen Ihnen, Ihr High-Speed-Design erfolgreich umzusetzen. Verschiedene Branchenexperten bieten praxisnahe und beliebte Schulungen zum High-Speed-Design an. Über die folgenden Links erhalten Sie weitere Informationen und können sich über spezielle Schulungsangebote informieren.
Referenzen
Der Autor würdigt dankend die Arbeit der folgenden Branchenexperten. Diese Seite ist ein Versuch, ihr gebündeltes Wissen zusammenzufassen.
- Signallaufzeiten auf Microstrip-Leitungen
- Aufteilen von Flächen für Geschwindigkeit und Leistung
- Skin-Effekt
- Designregeln für differenzielle Leiterbahnen – Wahrheit und Fiktion
Artikel von Dr. Howard Johnson
- Via-Induktivität
- 10-Lagen-Aufbau
Bücher und Artikel von Lee W. Ritchey
- Gleich beim ersten Mal richtig
- Eine Betrachtung der differenziellen Signalübertragung und ihrer Designanforderungen
- Leiterplattenlaminate beeinflussen High-Speed-Datenraten, Teil 1, Teil 2
Artikel von In-Circuit Design – Barry Olney
- Routing differenzieller Paare
- Die ungeschönte Wahrheit über Referenzflächenbrücken
- Kritische Bauteilplatzierung
- Planung des Lagenaufbaus (Teile 1, 2 & 3)
- Der perfekte Lagenaufbau
Bewährte Verfahren beim Leiterplattendesign - Tim Jarvis RadioCAD Limited
Leiterplattenlayout - Learn-EMC-Website
Artikel von Keith Armstrong, EMC Information Centre (kostenlose Registrierung erforderlich)
Handbuch der Elektronikaufbautechnik - Glenn R. Blackwell
Handbuch der Leiterplattentechnik - Clyde Coombs und Happy Holden
Das HDI-Handbuch - Happy Holden und andere
Techniken zur Via-Optimierung für Hochgeschwindigkeitskanäle - Altera-Applikationsschrift AN529
Überlegungen zum High-Speed-Leiterplattendesign - Lattice-Semiconductor-Applikationsschrift TN 1033
Messung der Signallaufzeit - Chris Grachanen, EDN
Die Zukunft von HDI-Via-Strukturen, Stromversorgung und Wärmemanagement in Leiterplatten der nächsten Generation - Tom Buck TTM Technologies