Enrutamiento de impedancia controlada
De un vistazo
- Aprende qué son los problemas de integridad de la señal, como las reflexiones y las oscilaciones, y cómo el aumento de las velocidades de conmutación hace que el enrutamiento con impedancia controlada sea más importante.
- Descubre cómo evaluar si tu diseño puede requerir atención a la impedancia controlada, incluida la regla práctica que se utiliza para estimar cuándo la longitud de las pistas empieza a ser un problema.
- Comprende cómo Altium Designer facilita la adaptación de impedancias de los componentes y el análisis de redes mediante sus herramientas de integridad de la señal antes de pasar a las decisiones de enrutamiento.
Con el aumento de las velocidades de conmutación de los dispositivos, el enrutamiento con impedancia controlada se ha convertido en un tema de gran interés para los diseñadores digitales. Esta página presenta cómo utilizar el motor de análisis de integridad de señal para adaptar las impedancias de los componentes y las funciones de enrutamiento con impedancia controlada del editor de PCB.
Hay un dicho en los círculos de ingeniería: solo hay dos tipos de ingenieros electrónicos que trabajan en diseño digital: los que han tenido problemas de integridad de señal y los que los tendrán. No hace tantos años, la integridad de señal era un concepto reservado a los especialistas, y solo había que ocuparse de ella en los diseños de alta velocidad. Sin embargo, las velocidades de conmutación de los dispositivos de aquellos diseños de alta velocidad ya no son excepcionales; se están convirtiendo rápidamente en la norma. A medida que los avances en la tecnología de circuitos integrados reducen el tamaño de los transistores, aumentan las velocidades a las que pueden conmutar. Es esta velocidad de conmutación la que afecta a la integridad de las señales digitales.
Afortunadamente, muchos posibles problemas de integridad de señal pueden evitarse siguiendo buenas prácticas de diseño e implementando el diseño como una placa de impedancia controlada. Para lograrlo, se necesitan funciones específicas en las herramientas de diseño: herramientas de análisis que detecten redes con posibles problemas de oscilaciones y reflexiones, y herramientas de diseño de placas que permitan conseguir las impedancias de enrutamiento correctas. El editor de PCB de Altium Designer dispone de estas funciones.
Esta página le ayudará a comprender qué causa los problemas de integridad de señal y si es probable que su placa los sufra. También explicará los dos enfoques de diseño que debe emplear para minimizar los posibles problemas de integridad de señal: la adaptación de impedancias de los componentes y el enrutamiento con impedancia controlada.
Cuando el enrutamiento pasa a formar parte del circuito
A medida que aumentan las velocidades de conmutación de los dispositivos, también aumentan las exigencias para el diseñador de la placa de circuito impreso y el fabricante. Cuando la longitud del flanco de conmutación de la señal es menor que la longitud de la pista de PCB que la transporta, la pista debe tratarse como parte del circuito. Esa pista tiene una impedancia, que se denomina characteristic impedance (Zo).
La mejor manera de gestionar el efecto de estos elementos adicionales del circuito es diseñar el enrutamiento de las pistas de modo que la impedancia característica sea constante a lo largo de su longitud, una técnica denominada controlled impedance routing.
La impedancia del enrutamiento de las pistas viene definida por:
- Cross-sectional area of the trace - se determina a partir de la anchura, la altura (espesor del cobre) y la pendiente de los bordes de la pista creados durante el proceso de grabado.
- Distance from the trace to the reference plane(s) - la trayectoria de retorno de la energía de la señal es tan importante como la trayectoria de la propia señal. Esta trayectoria de retorno sigue la trayectoria de la señal en los planos de referencia adyacentes.
- Properties of the surrounding materials - la energía de la señal no está contenida únicamente en el cobre de la pista; debido al efecto pelicular, también se propaga por el material dieléctrico que rodea la pista. La permitividad del material dieléctrico mide cuánto influye este en el flujo de esa energía.

La calculadora de impedancia Simbeor calcula las anchuras necesarias para obtener la impedancia especificada.
¿Necesito enrutamiento con impedancia controlada?
Quizá se pregunte: ¿realmente necesito preocuparme por el enrutamiento con impedancia controlada?
En una situación ideal, toda la energía que sale de un pin de salida de un componente se acoplaría a la pista conectada en la PCB, fluiría por el enrutamiento de la PCB hasta el pin de entrada de la carga en el otro extremo y sería absorbida por dicha carga. Si la carga no absorbe toda la energía, la energía restante puede reflejarse de vuelta al enrutamiento de la PCB y fluir hacia el pin de salida de la fuente. Esta energía reflejada puede interactuar con la señal original, sumándose a ella o restándose de ella (según la polaridad de la energía), lo que genera oscilaciones. Si estas oscilaciones son lo suficientemente grandes, afectarán a la integridad de la señal y darán lugar a un comportamiento impredecible y erróneo del circuito.
Entonces, ¿cómo puede saber si esto podría ocurrir? Si el pin de la fuente puede completar la transición de su flanco antes de que la señal llegue al pin de la carga, se dan las condiciones para que la energía reflejada afecte a su diseño. Una regla práctica habitual para determinar si es probable que haya problemas de integridad de señal es la regla de «1/3 del tiempo de subida». Esta regla establece que, si el tiempo de propagación por la pista supera 1/3 del tiempo de subida, pueden producirse reflexiones (oscilaciones). Si el pin de la fuente tiene un tiempo de subida de 1 ns, una ruta con un tiempo de propagación superior a 0,33 ns (aproximadamente 2 pulgadas en FR4) debe considerarse una línea de transmisión, susceptible de presentar problemas de integridad de señal. Si sus dispositivos tienen tiempos de subida de este orden y sabe que habrá rutas de estas longitudes, podría acabar teniendo problemas de integridad de señal en la PCB.
¿Cómo controlo las impedancias?
¿Cómo se evita que la energía se refleje de un lado a otro entre la fuente y la carga? Mediante la adaptación de impedancias. La adaptación de impedancias garantiza que toda la energía se acople de la fuente al enrutamiento y, después, del enrutamiento a la carga. Enrutar la placa teniendo en cuenta la impedancia se denomina enrutamiento con impedancia controlada; dicho de otro modo, una placa en la que se han gestionado las impedancias se denomina PCB de impedancia controlada.
La adaptación de impedancias consta de dos aspectos distintos: el primero es adaptar las impedancias de los componentes; el segundo es enrutar la placa para obtener la impedancia necesaria.
Adaptación de impedancias de los componentes
No se puede conseguir una PCB de impedancia controlada únicamente mediante el enrutamiento. Primero debe comprobar y, si es necesario, adaptar las impedancias de los componentes.
Lo ideal es detectar las redes que podrían presentar problemas de integridad de señal durante la fase de captura del diseño para poder incluir los componentes de terminación adicionales antes de que comience el proceso de diseño de la placa. Dado que los pines de salida tienen baja impedancia y los pines de entrada tienen alta impedancia, es probable que tenga que añadir componentes de terminación al diseño para lograr la adaptación de impedancias.
Puede realizar un análisis de integridad de señal de su diseño durante la etapa de captura de esquemas. Al ejecutar el comando Tools » Signal Integrity, suele aparecer el cuadro de diálogo Errors or Warnings, que indica que no todos los componentes tienen asignados modelos de integridad de señal. El motor de análisis de integridad de señal seleccionará automáticamente modelos predeterminados en función de los designadores de los componentes; haga clic en Continue para utilizar los valores predeterminados o en Model Assignments para examinar y cambiar los modelos. Puede acceder al cuadro de diálogo Signal Integrity Model Assignments en cualquier momento mediante el botón Model Assignments del panel Signal Integrity.
Análisis del diseño
Al ejecutar el comando Tools » Signal Integrity, se analiza el diseño y se identifican las redes potencialmente problemáticas en el panel Signal Integrity, como se muestra a continuación.
Comprobación del diseño para detectar posibles problemas de integridad de señal durante la captura del diseño.
Desde el panel, puede realizar un análisis de reflexiones en una o varias redes seleccionadas. A la izquierda se muestran los resultados del análisis de todas las redes del diseño. Seleccione una red y haga clic en el botón
(o haga doble clic en el nombre de una red) para transferirla al campo Net, situado a la derecha del panel, donde puede realizar un análisis detallado de esa red, que incluye:
- Examinar los pines de esa red: con un solo clic puede localizar el pin correspondiente en el esquema mediante sondeo cruzado, y con un doble clic puede comprobar y configurar el modelo asignado a ese pin.
- Activar una o varias opciones de terminación teóricas para esa red.
- Realizar un análisis de reflexiones en la red para generar un conjunto de formas de onda que muestren el comportamiento en cada pin de la red.
El panel permite experimentar con posibles configuraciones y valores de terminación. Tenga en cuenta que la región Termination del panel Signal Integrity que se muestra en la imagen anterior tiene activada la opción Serial Res. La sección del panel que aparece a continuación muestra una resistencia de terminación en serie. Aquí se definen los valores mínimo y máximo de resistencia de terminación en serie teórica que se utilizarán para el análisis de reflexiones (desmarque la casilla Suggest para introducir sus propios valores).
Exploración de los resultados
Al hacer clic en el botón Reflection Waveforms, se realiza un análisis preciso de reflexiones en esa red y los resultados se presentan en una nueva ventana de formas de onda (*.SDF).
La ventana de formas de onda incluirá:
- Un gráfico para cada red analizada; haga clic en las pestañas de la parte inferior de la ventana para cambiar entre gráficos.
- Cada gráfico incluirá un trazado para cada pin de esa red, que muestra el comportamiento de la señal en ese pin.
Las imágenes siguientes muestran dos gráficos de los resultados en el pin de entrada de la red seleccionada en la imagen anterior del panel. El primer gráfico muestra el pin de entrada de la red sin terminación; el segundo gráfico muestra seis barridos: uno para la red original sin terminación y otros cinco con la resistencia de terminación en serie teórica incluida en el pin de origen.
Se realizaron cinco pasadas del análisis de reflexiones (valor de la opción Sweep Steps = 5), variando la resistencia de terminación teórica por pasos desde Min = 20 ohmios hasta Max = 60 ohmios. Las cinco pasadas (la primera a 20 ohmios y la última a 60 ohmios) se enumeran en el lado derecho del gráfico. Al hacer clic en cada etiqueta, se resalta el resultado correspondiente y se muestra el valor de la resistencia de terminación teórica en la parte inferior derecha. Para esta red, una resistencia de terminación en serie de 40 ohmios produciría el gráfico seleccionado en la imagen de la derecha.
El gráfico de la izquierda muestra el análisis de reflexiones de una red con posibles problemas de integridad de señal; el gráfico de la derecha corresponde a la misma red con una resistencia de terminación en serie teórica de aproximadamente 40 ohmios añadida.
¿Qué determina la impedancia del enrutado?
La segunda parte del proceso para obtener una PCB de impedancia controlada consiste en enrutar la placa de modo que las pistas tengan una impedancia definida. Hay varios factores que influyen en la impedancia del enrutado de las señales, entre ellos las dimensiones de las pistas y las propiedades de los materiales utilizados para fabricar la PCB.
El editor de PCB incluye el motor electromagnético de integridad de señal Simbeor® de Simberian. La precisión de los modelos de Simbeor se valida mediante algoritmos avanzados de análisis de onda completa en 3D, pruebas comparativas y validación experimental. El motor Simbeor admite todas las estructuras y materiales de placas modernos.
Versión de Simbeor
Simbeor SFS
Las impedancias se calculan mediante Simbeor SFS, un solucionador de campos cuasiestático. Simbeor SFS es un avanzado solucionador de campos 2D cuasiestático basado en el método de los momentos, validado mediante pruebas de convergencia, comparaciones y mediciones. El solucionador genera una malla de los límites de los dieléctricos y los conductores y resuelve las ecuaciones correspondientes para construir matrices RLGC dependientes de la frecuencia para las ecuaciones del telegrafista.
Simbeor SFS no es un solucionador de onda completa, ya que esto no es necesario para evaluar la impedancia, el retardo o la atenuación en las interconexiones de PCB debido a la naturaleza cuasi-TEM de las ondas que se propagan por ellas. Estas ondas pueden simularse con precisión mediante parámetros RLGC extraídos con un solucionador de campos 2D cuasiestático.
Una característica exclusiva del solucionador Simbeor SFS es que admite modelos de rugosidad de los conductores. Tenga en cuenta que no admite un modelo de conductor multicapa (recubrimiento metálico) y que la rugosidad es común para todos los conductores. El solucionador es cuasiestático porque la solución no incluye la dispersión de alta frecuencia que se produce en las líneas microstrip (mayor concentración de campos en un dieléctrico con una constante dieléctrica más alta a altas frecuencias).
► Más información sobre la tecnología electromagnética de integridad de señal de Simberian
Estructuras de PCB compatibles
Se pueden calcular las impedancias de las siguientes estructuras de PCB:
- Microstrip
- Stripline simétrica
- Stripline asimétrica
- Estructuras coplanares de señal única y diferenciales
- Varias capas dieléctricas adyacentes con distintas propiedades dieléctricas.
Configuración de la PCB para el enrutamiento con impedancia controlada
El enrutamiento con impedancia controlada consiste en configurar las dimensiones de las pistas y las propiedades de los materiales de la placa para obtener una impedancia específica. Esto se realiza en el Layer Stack Manager del editor de PCB. Para abrir el Layer Stack Manager,, seleccione Design » Layer Stack Manager en los menús principales. El Layer Stack Manager se abre en un editor de documentos, del mismo modo que una hoja de esquemático, la PCB y otros tipos de documentos.
El ancho de pista necesario para obtener una impedancia específica se calcula como parte del perfil de impedancia, que se configura en la pestaña Impedance del Layer Stack Manager.
A partir de:
- Los valores de Target Impedance, Target Tolerance y Roughness que configure en la pestaña Impedance, y
-
los ajustes de los materiales definidos en la pestaña Stackup, incluidos:
- el espesor de la capa de señal,
- el espesor de las capas dieléctricas circundantes (las distancias a los planos de referencia), y
- las propiedades del material dieléctrico (permitividad Dk y factor de disipación Df).
Cuando estos parámetros están correctamente configurados, la calculadora de impedancia dispone de información suficiente para calcular lo siguiente:
- Ancho de pista
- Impedancia calculada (Z)
- Impedancia en modo común (Zcomm)
- Desviación de impedancia (desviación de Z)
- Retardo de propagación (Tp)
- Inductancia por unidad de longitud (p.u.l.)
- Capacitancia por unidad de longitud (p.u.l.)
Los valores calculados se muestran en la sección Transmission Line del panel Properties cuando se selecciona la pestaña Impedance en el Layer Stack Manager, como se muestra a continuación.
Un perfil de impedancia de 50Ω definido para redes individuales enrutadas en la capa superior. Pase el cursor sobre la imagen para ver los ajustes del mismo perfil para la capa L3 (imagen cortesía de FEDEVEL Open Source, www.fedevel.com).
Configuración del apilado de capas
Main page: Definición del apilado de capas
Las capas de fabricación de cobre y dieléctrico se configuran en la pestaña Stackup del Layer Stack Manager.
- En esta pestaña se añaden, eliminan y configuran las capas. En un diseño rígido-flexible, las capas también se habilitan y deshabilitan en esta pestaña.
-
Las propiedades de la capa seleccionada actualmente se pueden editar directamente en la cuadrícula o en el panel Properties. Haga clic en el botón
situado en la parte inferior del espacio de diseño para habilitar el panel.
- Haga clic con el botón derecho en la cuadrícula de capas o utilice los comandos Edit » Add Layer para añadir una capa. Al añadir una capa de cobre, también se añadirá una capa dieléctrica si una de las capas adyacentes existentes también es de cobre.
- Si la opción Stack Symmetry está habilitada en la sección Board del panel Properties, las capas se añaden en pares simétricos respecto a la capa dieléctrica central.
- El material de la capa se puede introducir en la celda Material seleccionada o elegir en el cuadro de diálogo Select Material; haga clic en el botón de puntos suspensivos para abrirlo.
- Se puede añadir un acabado superficial a una capa de cobre. Utilice el submenú Add Layer para añadir una capa Surface Finish a la capa de cobre seleccionada actualmente y, a continuación, haga clic en el botón de puntos suspensivos de la nueva capa de acabado superficial para seleccionar el tipo de acabado.
- La capa seleccionada se puede mover hacia arriba o hacia abajo entre las capas del mismo tipo mediante el menú contextual o los menús Edit.
- La región Board del panel Properties incluye opciones para imponer Stack Symmetry y Library Compliance. Estos aspectos se explican más adelante.
- La región Board del panel Properties muestra un resumen del apilado seleccionado actualmente (o del subapilado, en un diseño rígido-flexible con varios apilados).
Consideraciones sobre el apilado de capas
Un requisito fundamental para controlar la impedancia es incluir una trayectoria de retorno de señal debajo de cada trayectoria de señal. El motor Simbeor SI admite tanto capas de plano como capas de señal cubiertas por un polígono. Estas capas de retorno deben distribuirse por todo el apilado de la placa. Lo ideal es disponerlas de modo que al menos una capa de retorno sea adyacente a cada capa de señal que contenga enrutamiento con impedancia controlada. La capa de retorno adyacente proporciona la trayectoria de retorno de la señal y, por motivos que no se tratarán aquí, lo hace independientemente de la tensión de CC distribuida por ese plano.
La corriente de retorno que circula por el plano intentará seguir la misma trayectoria física que la pista de la capa de señal, por lo que es importante evitar la introducción de discontinuidades, como una división o un recorte en la capa de retorno situada debajo de cualquier enrutamiento de señal crítico.
Además de seleccionar un orden adecuado para las capas de señal y de plano, también debe definir las propiedades de los materiales de cada capa, entre ellas:
- Espesor del cobre
- Espesor del dieléctrico
- Constante dieléctrica
Estos valores, junto con el ancho de las pistas, contribuyen a la impedancia final. Por tanto, conseguir la impedancia requerida se convierte en un proceso de ajuste de todos estos valores. Recuerde que los valores posibles del espesor del cobre y del dieléctrico también pueden estar limitados por los materiales disponibles de su fabricante de PCB.
► Más información sobre los posibles apilados de capas
Definición de los perfiles de impedancia
El motor Simbeor está integrado en el Layer Stack Manager (Design » Layer Stack Manager) del editor de PCB. Para configurar el apilado de capas para el enrutamiento con impedancia controlada, cambie a la pestaña Layer Stack Manager's Impedance, donde podrá añadir y configurar un perfil de impedancia.
Un perfil de impedancia de 50 Ω definido para redes individuales enrutadas en la capa superior. Pase el cursor sobre la imagen para ver los ajustes del mismo perfil para la capa L3.
Notas sobre la creación y configuración de un perfil de impedancia:
- En el Layer Stack Manager, cambie a la pestaña Impedance, como se muestra arriba.
-
Haga clic en el botón
(o en el botón
si ya hay un perfil definido) para añadir un nuevo perfil.
- Defina los valores requeridos de Type, Target Impedance y Target Tolerance de la impedancia en el panel Properties. El Description es opcional y se mostrará dondequiera que aparezca el nombre del perfil de impedancia.
-
La cuadrícula de capas se divide en 2 regiones: a la izquierda se muestran las capas del apilado y, por cada capa de señal del apilado, se muestra una capa en la región del perfil de impedancia de la derecha. Utilice la casilla de verificación de la capa en la región del perfil para habilitar el cálculo de impedancia de esa capa. Tomando como ejemplo la imagen anterior y teniendo en cuenta el número de capa que aparece en la columna situada más a la izquierda, las capas
L1,L3,L10yL12tienen marcada su casilla de verificación, lo que las habilita para los cálculos de impedancia. - Al hacer clic en una capa habilitada en la región Perfil, todas las capas de la pila se atenuarán, excepto las que se utilizan para calcular la impedancia de la capa de señal seleccionada (como se muestra en la imagen anterior). Edite las capas de referencia de esa capa en las columnas Ref. superior y Ref. inferior de la región Perfil de impedancia . Tenga en cuenta que las capas de referencia pueden tener una capa Type de tipo
Planeo Signal. Por ejemplo, en la imagen anterior, la capaL10del apilado está habilitada para los cálculos de impedancia, con Top Ref establecido en9-L9, que es una capaPlane, y Bottom Ref establecido en11-L11, que es una capa Signal . El software supone que, si se utiliza una capa de señal como plano de referencia, esta contiene un plano continuo de cobre conectado a una red de alimentación o de tierra. - Marque la casilla Impedance Profile de cada una de las demás capas que contendrán pistas con esta impedancia y configure los planos de referencia. Sitúe el cursor sobre la imagen anterior para mostrar el perfil de impedancia S50 de la capa L3.
- Si la anchura de pista calculada es un valor que no se puede fabricar bajo pedido, puede ajustar los valores de anchura y separación.
Ajuste de los valores de anchura y separación
El software calcula la anchura de pista a partir de la impedancia objetivo y la tolerancia. Es habitual que la anchura de pista calculada sea un valor que no se pueda fabricar bajo pedido, por ejemplo, 0,0683 mm. El fabricante le indicará qué espesores de material están disponibles y qué precisión puede alcanzar en las anchuras de pista. A partir de ahí, el proceso consiste en partir de los valores deseados y comprobar cómo se ven afectados los valores de impedancia calculados al ajustar las dimensiones a las opciones disponibles.
Para facilitar este proceso de prueba y ajuste de los parámetros, las calculadoras de impedancia permiten realizar cálculos directos e inversos. El modo predeterminado es el directo (se introduce la impedancia y el software calcula la anchura). El icono
indica la variable calculada.
Una impedancia objetivo de 50Ω da como resultado una anchura (W1) de 94,6 µm mediante cálculo directo. La imagen de la derecha muestra el cálculo inverso cuando la anchura (W1) se establece en 95 µm.
Para invertir el cálculo y explorar distintas anchuras de pista para la capa seleccionada, escriba el nuevo valor de Width (W1) y pulse Intro en el teclado. Los valores calculados se actualizarán para reflejar el efecto del cambio a esa anchura. Haga clic en el botón
para volver a poner la calculadora en modo de cálculo directo. Al introducir un nuevo valor en Width (W2), cambiará el valor de Etch.
Para explorar los resultados de la línea de transmisión de par diferencial, seleccione la variable calculada, ya sea Trace Width o Trace Gap, haciendo clic en el botón
correspondiente. Edite la otra variable para cambiar Target Impedance o, como alternativa, cambie Target Impedance para explorar su efecto sobre la otra variable.
Factor de grabado
Las pistas de señal de una PCB se fabrican eliminando el cobre no deseado mediante grabado químico. Dado que el agente de grabado comienza a eliminar el cobre por la superficie, este cobre pasa más tiempo en contacto con dicho agente. Como resultado, los bordes de la pista terminada presentan una pendiente que reduce su área transversal, como se muestra en la siguiente imagen.
El área de cobre de los bordes de la pista que se pierde (en ambos bordes) durante el grabado = X * Y
El grado de inclinación se denomina factor de grabado, donde:
Etch Factor = Y/X
Si Y = X, entonces Etch Factor = 1
Tomando como referencia la imagen que se muestra en el panel Properties:
Sitúe el cursor sobre el signo ? para mostrar la fórmula.
La definición estándar del factor de grabado lo expresa como la relación trace thickness / amount of over-etching. De ello se obtiene la siguiente fórmula:
Etch Factor = T/[0.5(W1-W2)]
El inconveniente de este enfoque es que, para especificar que no hay sobregrabado (es decir, que los bordes de la pista son verticales), habría que introducir un valor de inf (infinito) para el factor de grabado. Para simplificar la especificación del grado de grabado, se ha invertido la fórmula, de modo que se pueda introducir un valor de 0 (cero) para indicar que no hay sobregrabado.
Etch = [0.5(W1-W2)]/T
Orientación del cobre
Otro detalle de fabricación que contribuye al factor de grabado es la orientación del cobre. Las pistas de la PCB se forman eliminando mediante grabado químico el cobre no deseado de una lámina continua de cobre laminada sobre un sustrato dieléctrico. La orientación del cobre define la dirección en la que el cobre sobresale de ese sustrato. También puede entenderse como la dirección desde la que se graba el cobre, desde arriba o desde abajo.
Haga clic en la casilla Pista invertida para cambiar la orientación del cobre de Arriba a Abajo.
Rugosidad superficial del conductor
La superficie de cada capa de cobre de una placa de circuito impreso presenta cierto grado de rugosidad. Durante la fabricación de la PCB, la superficie de las capas de cobre se trata para aumentar su rugosidad y mejorar la adhesión entre el cobre y las capas dieléctricas. Esta rugosidad superficial contribuye de forma significativa a la impedancia del conductor a velocidades de conmutación superiores a 10 GB/s. Tras una investigación y un análisis exhaustivos, los expertos del sector han concluido que la rugosidad superficial se puede modelar mediante un coeficiente de corrección de rugosidad derivado de los valores de Surface Roughness y Roughness Factor.
Roughness Los ajustes están disponibles en el modo Layer Stack Manager del panel Properties . Estos parámetros solo se utilizan para las capas conductoras.
La rugosidad superficial se incluye en el cálculo de la impedancia característica.
Rugosidad:
-
Model Type - modelo preferido para calcular el efecto de la rugosidad superficial (consulte los artículos siguientes para obtener más información sobre los distintos modelos). Se aplica a todas las capas de cobre del subapilado.
-
Surface Roughness - valor de la rugosidad superficial (puede obtenerlo de su fabricante). Introduzca un valor entre 0 y 10 µm; el valor predeterminado es 0,1 µm.
-
Roughness Factor - caracteriza el aumento máximo previsto de las pérdidas en el conductor debido al efecto de la rugosidad. Introduzca un valor entre 1 y 100; el valor predeterminado es 2.
Lecturas complementarias
- Metodología práctica para analizar el efecto de la rugosidad de los conductores en las pérdidas de señal y la dispersión en las interconexiones: Y. Shlepnev, C. Nwachukwu, DesignCon2012.
- Enfoque unificado para el modelado de la rugosidad superficial de los conductores de interconexión: Y. Shlepnev, 26.ª Conferencia del IEEE sobre el rendimiento eléctrico de encapsulados y sistemas electrónicos de 2017 (EPEPS2017)
Compatibilidad con estructuras de líneas de transmisión coplanares
La calculadora de impedancia de Layer Stack Manager admite estructuras coplanares de una sola línea y diferenciales. Cree un nuevo perfil de impedancia y, a continuación, seleccione Single-Coplanar o Differential-Coplanar en la lista desplegable Type del perfil de impedancia.
Trabajo con estructuras coplanares:
- Al igual que con las impedancias estándar de una sola línea y diferenciales, los valores de cada variable se calculan automáticamente a partir de Target Impedance y Target Tolerance definidos por el usuario y de las propiedades físicas de las capas de la placa. Estos valores calculados automáticamente se pueden ajustar introduciendo nuevos valores en los cuadros de edición del modo Layer Stack Manager del panel Properties.
- Para especificar las redes de señal que desea enrutar con una estructura coplanar, configure una regla de diseño de Ancho de enrutamiento (o de Enrutamiento de pares diferenciales) con la opción Use Impedance Profile habilitada y el perfil de impedancia coplanar requerido seleccionado.
- Las estructuras coplanares requieren un plano de referencia a ambos lados del trazado de señal; este se puede crear mediante un polígono que coloque o, si se añaden vías de cosido, mediante el comando Add Shielding to Net (más información a continuación). Si coloca un polígono, la separación entre este y el trazado de señal viene definida por el valor Clearance (S) determinado por la calculadora de impedancia Simbeor (que se muestra en el panel Properties, en las imágenes anteriores y posteriores). Configure una regla de diseño de separación para controlar la separación entre el polígono de referencia y el trazado de señal (mostrar imagen).
-
Es habitual incluir una barrera de vías a cada lado de la pista de señal cuando la estructura coplanar está conectada a tierra. Para ello, utilice el comando Tools » Via Stitching/Shielding » Add Shielding to Net en el editor de PCB. Además de colocar vías, al habilitar la opción Add shielding copper, este comando también puede colocar un polígono alrededor del enrutamiento de señal que cubra la barrera de vías, como se muestra en la imagen inferior derecha.
► Más información sobre el blindaje con vías
La calculadora de impedancia determina las propiedades de la señal y las separaciones (primera imagen); utilice esa separación en el ajuste Distancia del blindaje con vías.
Selección del material de las capas
En un diseño de impedancia controlada, la selección de los materiales utilizados en el apilado de capas es muy importante.
Por ejemplo, el material más común para fabricar PCB es la resina epoxi reforzada con fibra de vidrio, con una lámina de cobre adherida a cada lado. La densidad del tejido de fibra de vidrio afecta al valor y a la uniformidad de la constante dieléctrica Dk (permitividad) y de la tangente de pérdidas Df. El tejido de fibra de vidrio está rodeado de resina; el porcentaje de resina utilizado también es importante para el rendimiento del material.
Existe una amplia variedad de tejidos de fibra de vidrio. Para ayudar a garantizar la previsibilidad y el rendimiento de los materiales basados en fibra de vidrio utilizados en la fabricación de PCB, el IPC dispone de una norma para los tejidos:
IPC standard IPC-4412B: Specification for Finished Fabric Woven from "E" Glass for Printed Boards
La biblioteca de materiales
Como diseñador, puede editar las propiedades de los materiales directamente en Layer Stack Manager o seleccionar materiales de Altium Material Library.
La biblioteca completa se puede consultar (y ampliar) en el cuadro de diálogo Biblioteca de materiales de Altium (Tools » Material Library).
Los materiales se organizan en categorías de uso, a las que se accede mediante una estructura de árbol situada a la izquierda del cuadro de diálogo. Por debajo de este nivel, cada categoría de uso se divide en categorías funcionales, como Conductive layer material, Dielectric layer material, y Surface Layer Material i en la categoría PCB layer material.
Adición, guardado y carga de materiales
Se pueden añadir nuevos materiales a la biblioteca al seleccionar una categoría de materiales específica en el árbol. Se pueden cargar materiales definidos en una biblioteca de materiales externa (botón Load), y los materiales definidos por el usuario que se hayan añadido en el cuadro de diálogo Altium Material Library también se pueden guardar en una biblioteca de usuario (botón Save). Solo se guardan los materiales definidos por el usuario.
Adición de propiedades personalizadas a los materiales
Se pueden añadir propiedades personalizadas a los materiales incluidos en la biblioteca (tanto a los predeterminados como a los definidos por el usuario). Para añadir una propiedad personalizada, seleccione primero el nodo adecuado en el árbol de la izquierda para definir los materiales a los que se añadirá y, a continuación, haga clic en el botón
para abrir el cuadro de diálogo Material Library Settings.
A continuación, se puede añadir el valor requerido al material seleccionado en el cuadro de diálogo Altium Material Library; seleccione la fila y haga clic en el botón Edit.
Panel Propiedades
Cuando la pestaña Impedance del documento de apilado de capas está activa, el panel Properties permite configurar los requisitos del perfil de impedancia. A continuación, el perfil de impedancia requerido se puede seleccionar en las reglas de diseño de Ancho de enrutamiento o Enrutamiento de pares diferenciales.
-
Impedance Profile
- Description – introduzca una descripción significativa. Este campo es opcional y se mostrará dondequiera que se muestre el nombre del perfil de impedancia.
- Type – utilice la lista desplegable para elegir el tipo de impedancia. Las opciones son Single, Differential, Single-Coplanar y Differential-Coplanar.
- Target Impedance – introduzca la impedancia que desea obtener.
- Target Tolerance – introduzca la tolerancia que desea alcanzar. Consulte con el fabricante para determinar un valor de tolerancia realista que pueda garantizar.
-
Transmission Line
- Trace inverted – active esta opción para invertir la pista, tal como se muestra en el panel Properties. Esta opción es la misma que la opción Copper Orientation que aparece cuando la pestaña Stackup está activa y define la dirección en la que se lamina el cobre sobre el núcleo. La orientación del cobre define la dirección en la que el cobre se proyecta desde ese sustrato. También puede interpretarse como la dirección desde la que se realiza el grabado del cobre, desde arriba o desde abajo.
-
Etch – el factor de grabado es
= T/[(W1-W2)/2], lo que reduce el área total de la sección transversal de la pista en una cantidad igual al cuadrado del espesor del cobre. Consulte con el fabricante de la placa para obtener información sobre el Etch generado por sus procesos.
-
Width (W1) / (W2) – W1 es el ancho de la pista que enruta; W2 es el ancho de la superficie superior de esa pista una vez grabada, con el factor Etch aplicado. Hay una función de cálculo directo/inverso disponible para el ancho de pista. De forma predeterminada, el ancho se calcula a partir del Target Impedance introducido (cálculo directo). Ese ancho puede ser un valor que el fabricante no pueda conseguir, como 5,978, por lo que necesitará un valor más práctico, como 6,0. Puede introducir 6,0 en el campo Width y pulsar Enter en el teclado para recalcular los valores calculados (Impedance, Deviation, etc.). El botón
se vuelve gris (queda inactivo) y se pasa al modo de cálculo inverso. Si hace clic en el botón para activarlo, volverá al modo directo y el Width (W1) volverá al valor calculado. Esta función le permite explorar opciones de ancho que sean viables para la fabricación. Si introduce manualmente un valor para W2, se actualizará el factor de grabado en consecuencia.
- Impedance – el software calcula la impedancia a partir de las propiedades de los materiales utilizados para fabricar la placa (cobre, núcleo y preimpregnado) y del área de la sección transversal de la pista (determinada por el ancho, el espesor y el factor de grabado de la pista).
- Deviation – es una medida de la diferencia entre lo que se buscaba (impedancia objetivo) y lo que se ha obtenido (impedancia calculada). El software calcula la desviación de impedancia (lo que realmente se obtendrá a partir del material y las dimensiones introducidos) basándose en las propiedades de los materiales utilizados para fabricar la placa (cobre, núcleo y preimpregnado) y en el área de la sección transversal de la pista (determinada por el ancho, el espesor y el factor de grabado de la pista).
- Delay – es el tiempo que tarda la señal en viajar desde el emisor hasta el receptor.
- Inductance – la calculadora de impedancia utiliza el valor Impedance para calcular la inductancia por unidad de longitud.
- Capacitance – la calculadora de impedancia utiliza el valor Impedance para calcular la capacitancia por unidad de longitud.
-
Board
- Stack Symmetry – active esta opción para añadir capas en pares coincidentes, centrados en torno a la capa dieléctrica central. Al activarla, se comprueba inmediatamente la simetría del apilado de capas respecto a la capa dieléctrica central. Si algún par de capas equidistantes de la capa dieléctrica central de referencia no es idéntico, se abre el cuadro de diálogo El apilado no es simétrico.
- Library Compliance – cuando está activada, para cada capa seleccionada de la biblioteca de materiales, se comparan las propiedades actuales de la capa con los valores de la definición de ese material en la biblioteca.
- Substack – esta información corresponde al subapilado seleccionado actualmente (capas, dieléctrico, espesores, etc.). Al cambiar de un subapilado a otro, esta información se actualizará en consecuencia (para el subapilado seleccionado actualmente).
- Stack Name – introduzca un nombre descriptivo para el subapilado. Este campo resulta útil al asignar un subapilado de capas a la región de apilado X/Y.
- Is Flex – active esta opción si el subapilado es flexible.
- Layers – el número total de capas.
- Dielectrics – el número total de dieléctricos.
- Conductive Thickness – el espesor de las capas conductoras. Las capas de señal de cobre se denominan capas conductoras.
- Dielectric Thickness – el espesor de las capas dieléctricas.
- Total Thickness – el espesor total de la placa.
- Other
-
Roughness – muestra la rugosidad de las capas conductoras.
- Model Type – modelo preferido para calcular el efecto de la rugosidad superficial (consulte los artículos siguientes para obtener más información sobre los distintos modelos). Se aplica a todas las capas de cobre del apilado (¿debería ser del subapilado?).
- Surface Roughness – valor de la rugosidad superficial (puede obtenerlo del fabricante). Introduzca un valor entre 0 y 10 µm; el valor predeterminado es 0,1 µm.
- Roughness Factor – caracteriza el aumento máximo previsto de las pérdidas en el conductor debido al efecto de la rugosidad. Introduzca un valor entre 1 y 100; el valor predeterminado es 2.
Configuración de las reglas de diseño
La impedancia de enrutamiento está determinada por el ancho y la altura de la pista y por las propiedades de los materiales dieléctricos circundantes. A partir de las propiedades de los materiales definidas en el Layer Stack Manager, se calculan los anchos de enrutamiento necesarios al crear cada perfil de impedancia. En función de las propiedades de los materiales, el ancho puede variar al cambiar de capa de enrutamiento. Este requisito de cambiar los anchos al cambiar de capa de enrutamiento se gestiona automáticamente mediante la regla de diseño de enrutamiento aplicable, configurada en el Editor de reglas y restricciones de PCB (Design » Rules).
En la mayoría de los diseños de placas, se enruta un conjunto específico de redes con impedancia controlada. Un método habitual consiste en crear una clase de redes o una clase de pares diferenciales que incluya estas redes y, después, crear una regla de enrutamiento que se aplique a esa clase, tal como se muestra en las imágenes siguientes.
Normalmente, se definen manualmente los valores Min, Max y Preferred Widths, ya sea en los ajustes de restricciones de la parte superior para aplicarlos a todas las capas, o de forma individual para cada capa en la tabla de capas. Para el enrutamiento con impedancia controlada, active en su lugar la opción Use Impedance Profile y, a continuación, seleccione el perfil de impedancia necesario en el menú desplegable. Al hacerlo, la región Constraints de la regla cambiará. Lo primero que observará es que la región de capas disponibles ya no mostrará todas las capas de señal de la placa. Ahora solo mostrará las capas habilitadas en el perfil de impedancia seleccionado. Los valores Preferred Width (y la separación del par diferencial) se actualizarán para reflejar los anchos (y las separaciones) calculados para cada capa. Estos valores preferidos no se pueden editar, pero los valores Min y Max sí. Establézcalos en valores menores o mayores adecuados. A continuación, las redes se pueden enrutar de forma interactiva como de costumbre.
Regla de diseño de ancho de enrutamiento
Para las redes de una sola línea, el ancho de enrutamiento se define mediante la regla de diseño Ancho de enrutamiento.
Al elegir Usar un perfil de impedancia, las capas disponibles y los anchos preferidos quedan determinados por el perfil seleccionado.
Regla de diseño de enrutamiento de pares diferenciales
El enrutamiento de pares diferenciales se controla mediante la regla de diseño Enrutamiento de pares diferenciales.
Para un par diferencial, las capas disponibles, el ancho preferido y la separación preferida quedan determinados por el perfil seleccionado.
► Más información sobre Enrutamiento de pares diferenciales
Regla de diseño de trayectoria de retorno
Las interrupciones o los estrechamientos en la trayectoria de retorno pueden detectarse mediante la regla de diseño Trayectoria de retorno. La regla de diseño Trayectoria de retorno comprueba que exista una trayectoria de retorno de señal continua en las capas de referencia designadas, por encima o por debajo de las señales a las que se aplica la regla. La trayectoria de retorno puede crearse a partir de rellenos, regiones y vertidos de polígonos colocados en la capa de señal de referencia o en una capa de plano.
Las capas de la trayectoria de retorno son las capas de referencia definidas en el Impedance Profile seleccionado en la regla de diseño Return Path. Estas capas se comprueban para garantizar que el Minimum Gap especificado (ancho más allá del borde de la señal) se mantenga a lo largo del recorrido de la señal. Añada una nueva regla de diseño Return Path en la categoría de reglas High Speed.
Las capas de la trayectoria de retorno se definen en el Impedance Profile seleccionado, y el ancho de la trayectoria (más allá del borde de la señal) se define mediante el Minimum Gap.
La imagen siguiente muestra los errores de trayectoria de retorno detectados para la señal, NetXcon un valor de Minimum Gap de 0.1mm. Puede resultar más fácil localizar los errores de trayectoria de retorno configurando el DRC Violation Display Style para mostrar los detalles de las infracciones, pero no la superposición de infracciones (mostrar imagen) en el cuadro de diálogo Preferences. De este modo, se resaltan las ubicaciones exactas donde se ha incumplido la regla en lugar de la totalidad de los objetos que la infringen.
► Más información sobre Diseño de alta velocidad en Altium Designer
Enrutamiento de redes con la impedancia requerida
A medida que enruta la placa y cambia de capa, el software ajusta automáticamente el ancho de pista al valor necesario para alcanzar la impedancia especificada. Este enrutamiento interactivo con impedancia controlada simplifica enormemente la tarea de diseñar una PCB con impedancia controlada.
Ajuste de longitud de las rutas
Dos de los principales retos al enrutar un diseño de alta velocidad son controlar la impedancia de las rutas e igualar las longitudes de las redes críticas. El enrutamiento con impedancia controlada garantiza que la señal que sale de un pin de salida se reciba correctamente en los pines de entrada de destino. La igualación de las longitudes de las rutas garantiza que las señales con requisitos temporales críticos lleguen a sus pines de destino al mismo tiempo. Ajustar e igualar las longitudes de las rutas también es una parte esencial del enrutamiento de pares diferenciales.
Se han añadido patrones en acordeón al enrutamiento para garantizar que los pares diferenciales tengan longitudes iguales.
Los comandos Interactive Length Tuning y Interactive Diff Pair Length Tuning (menú Route) ofrecen una forma dinámica de optimizar y controlar las longitudes de las redes o de los pares diferenciales, al permitir insertar patrones ondulados de amplitud variable (acordeones) en función del espacio disponible, las reglas y los obstáculos del diseño.
► Más información sobre Ajuste de longitud
Comprobación de la integridad de señal de la placa enrutada
Del mismo modo que comprobó las redes durante la captura del diseño utilizando una longitud y una impedancia de enrutamiento estimadas, una vez completado el enrutamiento debe repetir este proceso en la placa para comprobar si existen posibles desajustes de impedancia y problemas de reflexión. Ejecute el comando Signal Integrity desde el menú Tools del editor de PCB. Dado que la PCB forma parte del proyecto, se utilizarán las propiedades de los materiales y las dimensiones definidas en el Layer Stack Manager, junto con los anchos reales de las rutas de la placa, para calcular las impedancias utilizadas en las pruebas de integridad de señal.
Cómo lograr las impedancias especificadas
Además del proceso iterativo de ajuste de dimensiones que se realiza para obtener las impedancias correctas, existen otros factores que influyen en la impedancia final de la PCB fabricada. Entre ellos se incluyen la uniformidad y la estabilidad del material dieléctrico utilizado en la PCB, así como la uniformidad y la calidad del proceso de grabado. Si necesita una PCB con impedancia controlada, debe consultarlo con su fabricante de PCB. Algunos fabricantes pueden asesorarle sobre las geometrías de las pistas si les proporciona su apilado preferido. Muchos también pueden incluir un cupón de prueba de impedancia en cada panel que fabrican, que permite medir las impedancias reales obtenidas en la placa.
Lecturas y recursos adicionales
Este artículo ofrece una introducción a la integridad de señal y al diseño de PCB con impedancia controlada. Utilice los siguientes enlaces para obtener más información y acceder a recursos elaborados por expertos reconocidos del sector.



