Trabajar con capas mecánicas
Altium Essentials: PCB Configuration
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Aprende cuándo utilizar una capa mecánica individual o un par de capas de componentes, especialmente para la información que se aplica a una cara o a ambas caras de la placa.
- Descubre cómo añadir, configurar y gestionar las capas mecánicas en el panel Configuración de vista, incluidos sus nombres, números, visibilidad y tipos de capa.
- Comprende cómo los tipos de capa predefinidos y la configuración de las bibliotecas de PCB afectan a la creación y la asignación automáticas de capas en el diseño de tu placa.
Incluso la placa más sencilla necesita detalles de diseño más allá de las pistas y los pads que implementan el circuito. Puede tratarse de las dimensiones de la placa o de los detalles de fabricación, de los contornos de emplazamiento de los componentes o de sus modelos 3D. En Altium Designer, este tipo de información adicional se especifica en las capas mecánicas.
Capas mecánicas y pares de capas de componentes
Si la información que se incluye en una capa mecánica no está relacionada con una cara específica de la placa, por ejemplo, notas de fabricación que detallan el orden de las capas, se añade una individual mechanical layer.
Si la información es necesaria en ambas caras de la placa, por ejemplo, los contornos de emplazamiento de los componentes, se asignan dos capas mecánicas: una capa contiene los detalles del contorno de emplazamiento cuando el componente se coloca en la cara superior de la placa; la otra capa mecánica contiene la imagen especular de esos mismos detalles cuando el componente se voltea a la cara inferior de la placa. En esta situación, se añade un par de capas mecánicas como un Component Layer Pair. Cuando las capas mecánicas se añaden como un par de capas de componentes, se muestran en la sección Component Layer Pairs del panel View Configuration, como se muestra a continuación. Debajo aparecen las Mechanical Layers individuales.

Se han añadido varios pares de capas de componentes definidos por el usuario.
| Display of Layer Pairs | En el espacio de diseño, las dos capas de un par de capas de componentes se muestran en pestañas de capa independientes con los nombres Top <LayerPairName> y Bottom <LayerPairName> |
| In the Library editor | En el editor de bibliotecas de PCB, los objetos de diseño adicionales necesarios en la huella de un componente se colocan en la capa superior del par de capas de componentes. Cuando el componente se voltea a la cara inferior de la placa durante el diseño de la PCB (atajo L mientras se mueve un componente), el contenido de la capa superior del par se refleja automáticamente en la capa inferior del par. |
| Automatic layer creation | Si una capa mecánica o un par de capas de componentes definidos en la biblioteca de PCB tienen asignado un tipo de capa, esa capa mecánica o ese par de capas se crea automáticamente en la PCB cuando se coloca un componente que utiliza esas capas. Si la PCB ya tiene una capa mecánica o un par de capas de ese tipo, el contenido de esas capas se asigna a las capas correspondientes. |
| Layers without a Layer Type |
Para las capas mecánicas o los pares de capas definidos en la biblioteca de PCB que no tengan asignado un tipo de capa en la biblioteca, se crean capas mecánicas individuales en la PCB. En esta situación, defina previamente la capa mecánica o el par de capas en la PCB con los mismos números de capa antes de colocar el componente, ya que el software recurrirá a la coincidencia por número de capa si no puede encontrar una coincidencia por tipo de capa. |
Añadir capas mecánicas al diseño
Las capas mecánicas se añaden, editan y eliminan en el panel Configuración de vista, como se muestra a continuación. Su visibilidad y su color también se configuran en el panel. Utilice el botón
situado en la esquina inferior derecha del espacio de diseño y, a continuación, seleccione View Configuration, o pulse la tecla de acceso directo L para mostrar el panel.
Haga clic con el botón derecho en cualquier parte de la región Layers del panel para mostrar el menú contextual, que ofrece los comandos Add Component Layer Pair (un par de capas mecánicas) y Add Mechanical Layer (una capa mecánica individual).
Las capas mecánicas individuales o los pares de capas mecánicas se añaden mediante el menú contextual del panel View Configuration.
Añadir una capa mecánica individual
Al seleccionar el comando Add Mechanical Layer en el menú contextual del panel View Configuration para añadir una capa mecánica individual, se abre el cuadro de diálogo Edit Layer.
Configure la nueva capa mecánica.
Cuadro de diálogo Editar capa |
|
| Layer Name | Puede ser un nombre de capa definido por el usuario o uno asignado por el sistema si se elige un tipo predefinido en la lista desplegable Layer Type. Si se selecciona un tipo de capa predefinido y después se introduce un nombre definido por el usuario en este campo, el tipo de capa asignado aparecerá entre paréntesis junto al nombre definido por el usuario en el panel View Configuration. |
| Layer Number | El número de la capa mecánica que se está configurando; se propone el siguiente número de capa disponible. Si se selecciona otro número que ya está en uso, aparecerá un icono de advertencia Para continuar, deberá asignarse un número de capa que no esté en uso. |
| Layer Type | El tipo de capa puede quedar sin asignar (N/A), o puede seleccionar un tipo de la lista. Los tipos de capa disponibles se describen a continuación. |
Tipos de capas mecánicas disponibles
| Assembly Notes | Se utiliza habitualmente para detallar el orden de montaje de los componentes y/o instrucciones de montaje importantes. |
| Board | Utilice esta capa para instrucciones o detalles relacionados con la placa. |
| Board Shape | Utilice esta capa para el contorno general de la placa (forma de la placa). |
| Dimensions | Se utiliza para definir los detalles dimensionales necesarios para la placa. |
| Fab Notes | Se utiliza para detallar notas de fabricación importantes. |
| Route Tool Path | Se utiliza para indicar la capa que contiene la información de fresado mecánico. Tenga en cuenta que no se permite un nombre definido por el usuario al utilizar este tipo de capa |
| Sheet | Utilice esta capa para definir el borde exterior de la plantilla de dibujo del documento. Consulte los detalles en la sección Representación y configuración de la hoja más abajo. |
| V Cut | Se utiliza para definir los detalles de los cortes en V. Los cortes en V se utilizan para separar las placas de circuito mediante una ranura en forma de «V» en las caras superior e inferior de una placa, dejando una cantidad mínima de material para mantener unido el panel de placas. |
Añadir un par de capas de componentes
Al seleccionar el comando Add Component Layer Pair en el menú contextual del panel View Configuration, se abre el cuadro de diálogo Edit Layers Pair.
Cuadro de diálogo Editar par de capas |
|
| Layer Name | Puede ser un nombre de capa definido por el usuario o asignado por el sistema si se elige un tipo predefinido en la lista desplegable Layer Type. Si se selecciona un tipo de capa predefinido y luego se introduce un nombre definido por el usuario en este campo, el tipo de capa asignado aparecerá entre paréntesis junto al nombre definido por el usuario en el panel View Configuration. |
| Layer Number | Los números de las capas mecánicas que se están configurando; se proponen los siguientes números de capa disponibles. Si se selecciona otro número y ya está en uso, aparecerá un icono de advertencia Será necesario asignar un número de capa que no esté en uso para continuar. |
| Layer Type | El tipo de capa puede dejarse sin asignar (N/A), o puede seleccionar un tipo de la lista. Los tipos de capa disponibles se describen a continuación. |
Tipos de pares de capas de componentes disponibles
| Assembly | Se utiliza para dibujar o detallar los datos de montaje del componente. Esta capa puede incluirse en una vista de montaje de placa de Draftsman y, a continuación, seleccionarse como Geometry Source para los componentes en el cuadro de diálogo Component Display Properties de Draftsman. Más información sobre Draftsman. |
| Coating | Se utiliza para definir las áreas de los componentes que requieren un recubrimiento protector. |
| Component Center | Se utiliza para indicar el centroide del componente, proporcionando en la documentación de montaje una referencia visual de la ubicación utilizada por la máquina de colocación de componentes. |
| Component Outline | Se utiliza para definir el contorno del cuerpo del componente, que representa el área que ocupa en la placa. |
| Courtyard | Se utiliza para definir el espacio de colocación necesario para un componente. Normalmente, el área de ocupación (Courtyard) delimita el componente y los pads, con un margen de separación adecuado el contorno verde es el área de ocupación). Más información sobre la creación de huellas personalizadas. La forma definida en la capa de área de ocupación también se utiliza para la selección de componentes, para definir el área del componente y para la detección de colisiones cuando el componente no incluye un cuerpo 3D. |
| Designator | Utilice esta capa para colocar la cadena especial .Designator. Este par de capas puede incluirse después en los planos de montaje que requieran mostrar el designador del componente. Más información sobre las cadenas especiales. |
| Dimensions | Se utiliza para definir los detalles dimensionales necesarios para los componentes. |
| Glue Points | Se utiliza para definir los puntos de adhesivo de los componentes. |
| Gold Plating | Se utiliza para definir los requisitos de chapado selectivo en oro de los componentes. |
| Value | Utilice esta capa para colocar la cadena especial .Comment. Este par de capas puede incluirse después en los planos de montaje que requieran mostrar el valor del componente. Más información sobre las cadenas especiales. |
| 3D Body | Utilice esta capa para el modelo mecánico 3D del componente. Más información sobre la colocación de cuerpos 3D. |
| Die | Utilice esta capa para los pads y los cuerpos 3D del chip al crear un componente Chip-on-Board. Más información sobre la conexión por hilos. |
| Wire Bonding | Utilice esta capa para los hilos de conexión al crear un componente Chip-on-Board o directamente en un documento de PCB. Más información sobre la conexión por hilos. |
La ventaja de asignar un tipo de capa
Una práctica habitual para gestionar el uso de las capas mecánicas consiste en asignar un número de capa específico a cada función de capa mecánica necesaria. Este enfoque exige que todos los diseñadores sigan el mismo esquema de asignación y numeración de capas. También puede generar dificultades cuando se obtienen componentes de otras fuentes que no siguen el mismo esquema de asignación y numeración. Si se ha utilizado un esquema diferente, los objetos de diseño deben trasladarse de su capa mecánica actual a la capa mecánica asignada a esa función.
Este problema se resuelve asignando una propiedad Layer Type. Cuando se coloca un componente de una biblioteca en el editor de PCB, se copia de una biblioteca a otra o se crea mediante IPC Footprint Wizard, las asignaciones de tipo de capa existentes se hacen coincidir automáticamente, independientemente de los números de capa mecánica asignados a esos tipos de capa. Los objetos se reubican en las capas correctas según su tipo de capa. Si el software no puede encontrar una coincidencia por tipo de capa, recurrirá a la coincidencia por número de capa.
Tanto para las capas mecánicas individuales como para los pares de capas de componentes, puede seleccionar un tipo de capa de una lista de tipos predefinidos. Las imágenes siguientes muestran la lista de tipos de capa disponibles. Puede acceder a los cuadros de diálogo que se muestran a continuación haciendo clic con el botón derecho en una capa individual y seleccionando el comando Edit Layer o Add Component Layer en el menú.

Seleccione el tipo de capa de la lista de tipos predefinidos; las capas mecánicas individuales se muestran a la izquierda y los pares de capas de componentes, a la derecha.
Asignar nombres a capas con un tipo de capa asignado
Cuando se asigna un tipo de capa, la propiedad Nombre de capa cambia automáticamente para coincidir con el tipo de capa. Si es necesario, puede sustituirla introduciendo un nombre definido por el usuario. Cuando una capa tiene un nombre definido por el usuario y un tipo de capa asignado, se muestran ambos, con el tipo de capa entre paréntesis, como se muestra a continuación para el par de capas GP (Gold Plating).
El tipo de capa se utiliza para dar nombre a la capa; este nombre puede sustituirse si es necesario.
El tipo de capa de trayectoria de herramienta de fresado
Existe una excepción al comportamiento de asignación de nombres que se acaba de describir cuando se asigna un tipo de capa: no se permite un nombre definido por el usuario cuando Layer Type se establece en Route Tool Path. Esto se debe a que las versiones anteriores del software utilizan el nombre de la capa de trayectoria de herramienta de fresado para identificar la capa que contiene la información de fresado (también denominada información de rout). Mantener fijo el nombre de esta capa garantiza que el diseño siga funcionando correctamente en una versión anterior.
El tipo de capa de trayectoria de herramienta de fresado se utiliza para indicar la capa que contiene la información de fresado mecánico. Una práctica habitual al utilizar esta capa consiste en colocar pistas y arcos alrededor del borde exterior de la forma de la placa para definir la trayectoria y la anchura de mecanizado. Se dejan secciones de material intactas para sujetar la placa dentro del panel y, a continuación, se coloca una serie de pequeños taladros a lo largo de cada sección para crear perforaciones (a menudo denominadas «mordeduras de ratón»), que permiten separar la placa del panel una vez finalizado el proceso de montaje.
Cuando la placa se muestra en modo 3D, los objetos detectados en la capa Route Tool Path se muestran como una ranura fresada en la placa, como se muestra a continuación.

Los objetos detectados en la capa Route Tool Path se utilizan para visualizar la placa fresada en el modo de visualización 3D.
Utilice el cuadro de diálogo Line/Arc Primitives from Board Shape para trazar el contorno exterior de la placa con pistas y arcos (como se muestra a continuación). Active la opción Route Tool Outline en el cuadro de diálogo para que los objetos se coloquen fuera del contorno de la placa en lugar de quedar centrados sobre su borde. Algunos diseñadores prefieren añadir la información de fabricación cuando utilizan la función Embedded Board Array para crear un panel de ensamblaje, en lugar de incluir estos detalles en el archivo de la placa.
Más información sobre la panelización de placas mediante una matriz de placas integrada
Definición del tipo de capa en el editor de bibliotecas de PCB
Si una capa mecánica o un par de capas de componente definidos en la biblioteca de PCB tienen asignado un tipo de capa, esa capa mecánica o ese par de capas se crean automáticamente en la PCB al colocar un componente que utilice esas capas. Si la PCB ya tiene una capa mecánica o un par de capas de ese tipo, el contenido de dichas capas se asigna a las capas correspondientes.
Siempre que sea posible, se recomienda editar la biblioteca de origen y asignar tipos de capa. Cuando se coloca (o se copia) una huella de componente desde una biblioteca, las capas mecánicas y los pares de capas de componente de esos tipos se crean automáticamente en la placa (o biblioteca) de destino si no existen. Si esos tipos de capa ya existen en la placa (o biblioteca) de destino, el contenido de las capas se asigna automáticamente a la capa correcta.
Más información sobre la gestión de requisitos especiales específicos de cada capa en el editor de bibliotecas de PCB
Trabajo con capas mecánicas
Las capas mecánicas se añaden, editan, eliminan y muestran a través del panel View Configuration del editor de PCB. No se muestran ni se editan en Layer Stack Manager.
Visualización
Configure la visibilidad de las capas en el panel View Configuration y guarde los grupos de capas utilizados habitualmente como un conjunto de capas definido por el usuario.
| Controlling layer visibility | Haga clic en el icono de visibilidad situado junto al nombre de la capa para mostrar u ocultar esa capa mecánica. También puede hacer clic para seleccionar el nombre de la capa y, a continuación, pulsar Spacebar (esto alterna la visualización de ambas capas de un par de capas de componente). |
| Include in Single Layer Mode | Las capas mecánicas tienen una función de visualización adicional: se pueden configurar para que permanezcan visibles cuando la visualización esté en modo de capa única. Mantenga pulsado |
| Include in 3D View Mode | Las capas mecánicas también se pueden incluir en la visualización 3D cuando los ajustes 3D tienen activada la opción Colors - By Layer. Active esta opción en la pestaña View Options del panel View Configuration cuando la placa se muestre en modo de vista 3D. Se incluirán las capas mecánicas que estén configuradas como visibles |
Edición y eliminación
Para editar los ajustes de un par de capas de componente o de una capa mecánica existentes, haga doble clic directamente en su entrada en el panel View Configuration (o haga clic con el botón derecho en la entrada deseada y elija Edit Layer en el menú contextual). Realice los cambios necesarios en el cuadro de diálogo Edit Layers Pair / Edit Layer. La visibilidad y el color de las capas mecánicas se configuran directamente en el panel View Configuration.
Para eliminar una capa, haga clic con el botón derecho en la capa deseada y seleccione Delete Layer. Según cómo se esté utilizando la capa, se producirá uno de estos tres resultados:
| Nothing on the layer | Si no hay primitivas colocadas en la capa, esta se elimina inmediatamente al seleccionar Delete Layer (sin confirmación). |
| Contains unlocked primitives | Si hay primitivas desbloqueadas en la capa, aparecerá una ventana emergente que solicitará la confirmación de la eliminación. |
| Contains locked primitives | Si hay primitivas bloqueadas en la capa, por ejemplo, si contiene primitivas que pertenecen a un componente, aparecerá una ventana emergente de error que le avisará de que no se puede completar la acción. |
Exportación e importación
La estructura de capas mecánicas y pares de capas de componente añadidos a una PCB se puede duplicar en otra PCB exportando ese conjunto a un archivo desde el documento de PCB de origen e importando después el archivo al documento de PCB de destino.
Exportar/importar las capas
-
En el documento de PCB de origen que contiene la estructura de capas mecánicas y pares de capas de componente requerida, utilice el comando Tools » Export Mechanical Layers de los menús principales. Utilice el cuadro de diálogo Export Mechanical Layers que se abre para definir el nombre y el directorio del archivo
*.stackupque contendrá los datos sobre la estructura de capas mecánicas. -
En el documento de PCB de destino, utilice el comando Tools » Import Mechanical Layers de los menús principales y, en el cuadro de diálogo Import Mechanical Layers que se abre, seleccione el archivo
*.stackupguardado. La estructura de capas mecánicas y pares de capas de componente añadida se puede ver en el panel View Configuration.
Copiar/pegar el contenido de las capas
Tenga en cuenta que los comandos de importación/exportación transfieren la estructura de capas mecánicas y pares de capas de componente, pero no el contenido de estas capas.
Para copiar el contenido de:
-
Una sola capa mecánica, utilice el comando Edit » Select » All on Layer cuando la capa requerida sea la capa activa en la PCB de origen y, a continuación, utilice el procedimiento estándar de copiar y pegar para replicar esos datos en la PCB de destino.
-
Varias capas mecánicas: configure la visibilidad de las capas en el panel View Configuration para mostrar únicamente las capas mecánicas necesarias y, a continuación, arrastre un rectángulo de selección por contacto (de derecha a izquierda) alrededor de todas las primitivas necesarias en la PCB de origen. Después, utilice el proceso estándar de copiar y pegar para replicar esos datos en la PCB de destino.
Configuración de presentación y salida
Las capas mecánicas se suelen utilizar para detallar información que debe incluirse en las impresiones o en los archivos de fabricación generados. Esto puede incluir plantillas de dibujo, instrucciones de fabricación, instrucciones de ensamblaje, etc. Si es necesario, esto puede hacerse directamente en el editor de PCB.
Si es necesario, la información de la documentación de producción de la placa puede incluirse en las capas mecánicas.
Como alternativa, estas tareas de documentación pueden realizarse en Draftsman, un entorno de edición gráfica avanzado y flexible para crear documentos de producción del diseño de la placa. Con un conjunto específico de herramientas de dibujo, el sistema de dibujo de Draftsman ofrece un enfoque interactivo para combinar planos de fabricación y ensamblaje con plantillas personalizadas, anotaciones, cotas, llamadas y notas.
Más información sobre Draftsman
Presentación y configuración de la hoja
La imagen anterior muestra un fondo blanco que se ajusta exactamente a los objetos de dibujo colocados para representar la plantilla de la hoja. Este fondo se crea añadiendo una capa mecánica con Layer Type establecido en Sheet, que después se utiliza para definir el borde exterior de la plantilla de dibujo del documento.
El tamaño de este fondo blanco viene definido por Sheet Settings, que puede personalizarse en el panel Properties cuando no hay nada seleccionado en el área de edición. Los valores X/Y de la esquina inferior izquierda de la hoja, así como Width y Height, pueden configurarse manualmente. Como alternativa, cuando la opción Get Size From Sheet Layer está habilitada, el fondo de la hoja se calcula automáticamente a partir del rectángulo delimitador del conjunto de objetos colocados en la capa mecánica de tipo Sheet.
El tamaño del fondo de la hoja puede ajustarse automáticamente a partir de los objetos colocados en la capa de tipo Sheet.
El color y la visibilidad del fondo de la hoja se configuran en la sección System Colors del panel View Configuration. Haga clic en el botón de color para cambiar el color de Sheet Line y Area Color. Alterne entre
/
para mostrar u ocultar la hoja.
Inclusión de capas mecánicas en la salida
Las capas mecánicas se utilizan para una amplia variedad de tareas y detallan información utilizada durante el diseño, la fabricación y el ensamblaje de la placa, así como en la documentación del producto. Para satisfacer todos estos requisitos, las capas mecánicas pueden excluirse o incluirse en todas las formas de generación de salida basadas en capas, incluidas la impresión y la generación de archivos de salida.
Salida impresa
Cualquiera de las capas presentes en el diseño puede incluirse en la especificación de una impresión de PCB, incluidas las capas mecánicas. Las impresiones se configuran añadiendo las capas necesarias y estableciendo su orden en el cuadro de diálogo Print.

Se pueden crear planos de fabricación y ensamblaje muy detallados colocando objetos en las capas mecánicas.
Más información sobre Preparación de la salida de PCB basada en impresiones 2D
Salidas generadas
Todos los formatos de salida para fabricación, como Gerber y ODB++, permiten incluir capas mecánicas como un Layer to Plot de salida, o añadirlas como detalles a cada capa que se traza. La salida se genera al ejecutar el generador de salida configurado, por ejemplo, al utilizar un generador de salida ODB en un archivo de configuración OutputJob (*.OutJob).

Las capas mecánicas pueden trazarse o añadirse a todos los trazados si es necesario.
Más información sobre Preparación del diseño para la fabricación
).
).



).