Trabajar con plantillas de vías de pad

De un vistazo

Este artículo explica cómo Altium Designer utiliza plantillas de pads y vías para mejorar la reutilización, la coherencia y la gestión en los diseños de PCB. Verás cómo se crean automáticamente las plantillas locales en una placa, cómo se habilitan las bibliotecas externas de plantillas de pads y vías, y cómo el panel PCB Pad Via Templates sirve como punto central para ver, colocar, filtrar y gestionar estas definiciones de plantillas. También describe cómo las plantillas permanecen vinculadas a las bibliotecas de origen, cómo afecta esto a su edición y dónde pueden aplicarse a lo largo del flujo de trabajo de diseño. Sigue leyendo para descubrir cómo estas herramientas pueden ayudarte a trabajar de forma más eficiente y con mayor control.

- Descubre la diferencia entre las plantillas locales de pads y vías y las plantillas almacenadas en bibliotecas externas de pads y vías, y cómo se utiliza cada tipo en un diseño de PCB.
- Aprende a utilizar el panel PCB Pad Via Templates para colocar plantillas, consultar las bibliotecas disponibles, filtrar listas de plantillas y revisar cuáles se utilizan ya en la placa actual.
- Comprende cómo se generan los nombres de las plantillas, cómo afectan las plantillas vinculadas a bibliotecas a las posibilidades de edición y dónde pueden aplicarse las plantillas en las reglas de diseño y los flujos de trabajo de PCB.
Profundiza con IA:
 

Junto con los objetos de pista, los pads y las vías son elementos fundamentales de todos los diseños de placas de circuito. Cada pad y vía se puede configurar como un objeto personalizado durante o después de su colocación.

Pad y vía en 3D 
Pad y vía en 3D

Para mejorar las capacidades de reutilización y gestión de pads y vías en los diseños de PCB, Altium Designer también admite la creación automatizada de plantillas de pads y vías, bibliotecas de plantillas de pads y vías y diversos paneles asociados para su gestión.

El concepto de plantillas de pads y vías que se pueden agrupar en una biblioteca es similar al de las bibliotecas de huellas de PCB, aunque algo más básico. La biblioteca de plantillas de pads y vías no almacena pads y vías reales, sino definiciones preconfiguradas que se aplican a una instancia de un pad o una vía al colocarla. Las bibliotecas de plantillas de pads y vías guardadas se pueden cargar y utilizar para colocar instancias de pads y vías predefinidos en cualquier diseño de PCB o huella de PCB.

Para obtener más información sobre cómo crear bibliotecas de pads y vías, consulte la página Creación de plantillas y bibliotecas de pads y vías.

Como se ha mencionado, las plantillas existentes se pueden guardar en bibliotecas de plantillas de pads y vías, y también se pueden crear plantillas nuevas. Las plantillas de estas bibliotecas están disponibles para su uso a través del panel PCB Pad Via Templates. Las plantillas locales también se muestran en el panel, lo que lo convierte en el recurso central para trabajar con bibliotecas de plantillas de pads y vías.

El panel PCB Pad Via Templates

El panel PCB Pad Via Templates es un panel especializado que enumera tanto las plantillas de pads y vías almacenadas en el documento de PCB actual (locales) como las disponibles en bibliotecas de pads y vías que se han instalado o incluido en el proyecto de diseño actual (bibliotecas disponibles).

Haga clic en el botón situado en la parte inferior derecha del espacio de diseño y, a continuación, elija PCB Pad Via Templates para abrir el panel.

El panel ofrece la doble función de acceder tanto a las plantillas locales como a las de bibliotecas.
El panel ofrece la doble función de acceder tanto a las plantillas locales como a las de bibliotecas.

Los dos conceptos de biblioteca que presenta el panel se pueden resumir así:

  • Available Pad/Via Template Libraries – Bibliotecas de pads y vías cargadas o instaladas (colecciones de plantillas de pads y vías basadas en archivos). Esta sección del panel enumera las plantillas que contiene la biblioteca de pads y vías seleccionada actualmente.
  • Local Pad & Via Library – Término colectivo para las plantillas de pads y vías que se utilizan en el diseño de placa actual, incluidas las procedentes de una biblioteca de pads y vías o añadidas desde ella. Esta sección del panel enumera las plantillas que se aplican a los pads y vías del diseño de placa actual.

La biblioteca local de pads y vías

Las entradas que aparecen en la sección inferior Local Pad & Via Library del panel representan las configuraciones (plantillas) de pads y vías utilizadas y guardadas en el diseño de placa actual. En la parte inferior de la sección se muestra una vista previa de la plantilla seleccionada.

Las plantillas que aparecen aquí son plantillas de pads y vías guardadas dentro del archivo de PCB y no se encuentran en una «biblioteca» definida por separado como tal. Una plantilla seleccionada se puede reutilizar en la placa actual como una nueva instancia de pad o vía arrastrándola al diseño o seleccionando Place en el menú contextual del panel, que se abre con el botón derecho del ratón.

Colocación de una instancia de una plantilla de pad local.
Colocación de una instancia de una plantilla de pad local.

Bibliotecas de archivos de plantillas de pads y vías disponibles

La sección superior del panel, Available Pad/Via template Libraries, se utiliza para trabajar con bibliotecas de archivos de plantillas de pads y vías.

Se puede colocar una plantilla de la biblioteca seleccionada en la PCB arrastrándola desde el panel o mediante el menú contextual del botón derecho. Como el pad o la vía se coloca desde una biblioteca externa de archivos de plantillas, sus propiedades no se pueden editar en la PCB, como se puede ver en la imagen del panel Properties que se muestra a continuación, a la derecha. Para editar las propiedades de un pad o una vía basado en una biblioteca, es necesario desvincular su plantilla. Encontrará más información al respecto en la sección Desvincular una plantilla de una biblioteca.

Las plantillas de la biblioteca de pads y vías activa, Preferred.PvLib en este ejemplo. Las propiedades de una instancia colocada del pad seleccionado se muestran en la segunda imagen. Tenga en cuenta que las propiedades físicas, como la forma del pad y el tamaño del orificio, no se pueden editar. 
Las plantillas de la biblioteca de pads y vías activa, Preferred.PvLib en este ejemplo. Las propiedades de una instancia colocada del pad seleccionado se muestran en la segunda imagen. Tenga en cuenta que las propiedades físicas, como la forma del pad y el tamaño del orificio, no se pueden editar.

Cuando se coloca una plantilla de pad o vía basada en archivos en un diseño de placa, permanece vinculada a su plantilla de biblioteca de origen y al nombre de dicha biblioteca. Como ese origen es un archivo externo, no se pueden editar las propiedades físicas del pad o la vía que utiliza esa plantilla, lo que protege la integridad de la plantilla de origen en el archivo de biblioteca externo. Para editar una plantilla de pad o vía basada en archivos, se puede desvincular. Encontrará más información al respecto en la sección Desvincular una plantilla de una biblioteca.

El desplegable situado en la parte superior del panel se utiliza para seleccionar qué biblioteca disponible está activa; en la imagen siguiente es ExampleViaLib.PvLib. El botón  se utiliza para abrir el cuadro de diálogo Available Libraries, donde se pueden añadir y eliminar archivos de bibliotecas de plantillas. Las bibliotecas disponibles se describen más adelante. Utilice el campo Filter para mostrar únicamente las plantillas cuyo Name comience por esa cadena.

Utilice el campo Filter para filtrar rápidamente la lista de plantillas.
Utilice el campo Filter para filtrar rápidamente la lista de plantillas.

Habilitar bibliotecas de plantillas de pads y vías

El término Available Libraries hace referencia a las bibliotecas de plantillas de pads y vías cuyas plantillas están disponibles para su uso en el diseño de placa actual. Esto incluye las bibliotecas de plantillas que se han añadido al proyecto actual, así como las que se han instalado en Altium Designer. Ambos tipos se pueden revisar y gestionar en el cuadro de diálogo Available Libraries; haga clic en el botón  situado en la parte superior del panel PCB Pad Via Templates para abrirlo.

Instale una biblioteca externa de pads y vías o utilice la pestaña Project para añadir una biblioteca existente al proyecto actual.
Instale una biblioteca externa de pads y vías o utilice la pestaña Project para añadir una biblioteca existente al proyecto actual.

  • La pestaña Project del cuadro de diálogo enumera todos los archivos PvLib incluidos en el proyecto y también dispone de botones para añadir o eliminar bibliotecas del proyecto.
  • La pestaña Installed enumera todas las bibliotecas de plantillas de pads y vías que están disponibles actualmente en esta instalación de Altium Designer y, por tanto, para todos los proyectos de diseño de PCB. Tenga en cuenta que, con una biblioteca instalada, puede controlar si está disponible para su uso activando o desactivando la opción Activated asociada. Esto evita tener que eliminar y volver a añadir bibliotecas continuamente.

Uso de una plantilla en el diseño

Las plantillas que aparecen en el panel PCB Pad Via Templates se pueden utilizar en el diseño de placa actual de las siguientes maneras:

  • Colocación: coloque un pad o una vía de una plantilla local o de una biblioteca de plantillas directamente desde el panel.
  • Selección en el desplegable Template: en el panel Properties, cuando hay pads o vías seleccionados. Utilice este método para cambiar los pads o vías seleccionados de modo que utilicen una plantilla diferente.
  • Como restricción de una regla: se puede seleccionar una plantilla de pad o vía como restricción en la regla de diseño de estilo de vía de enrutamiento (que se muestra a continuación).
  • Como ámbito de una regla: se pueden utilizar las siguientes palabras clave de consulta al definir el ámbito de una regla de diseño (por ejemplo, la regla de diseño de estilo de punto de prueba):
  • Para el cosido/apantallamiento con vías: seleccione la Via Template requerida en el cuadro de diálogo Add Stitching to Net o en el cuadro de diálogo Add Shielding to Net.

Utilice plantillas de vías en la regla de diseño Routing Via Style o al añadir cosido con vías a una red.
Utilice plantillas de vías en la regla de diseño Routing Via Style o al añadir cosido con vías a una red.

La plantilla de pad/vía y cómo se nombra

Para cada pad o vía único colocado en un diseño de placa, se crea automáticamente una plantilla de pad/vía, se le asigna un nombre y se almacena en el archivo de la placa. La plantilla almacena la configuración básica del pad/vía, incluidos su tamaño, forma, tipo de pila de pads, información de las máscaras de pasta/soldadura y del taladro, etc. La configuración recibe automáticamente un nombre conforme a las normas IPC (en concreto, las convenciones de nomenclatura de pilas de pads IPC-7251/7351). Cada pad y vía utilizado en el diseño hace referencia a su plantilla; esto puede verse en el panel Properties, como se muestra a continuación.

El sistema de nomenclatura IPC se basa en el sistema métrico, donde una unidad equivale a una centésima de milímetro (10-5 metros, 10 µm). Así, por ejemplo, la plantilla de un pad circular de 1,5 mm con un taladro de 0,8 mm se denomina c150h80, donde c indica que es circular (redondo) y h precede al tamaño del taladro. Un pad denominado r155_125 es un pad rectangular de montaje superficial de 1,55 mm x 1,25 mm; y un pad denominado s160h100 es un pad cuadrado de orificio pasante de 1,6 mm, con un taladro de 1,0 mm. Los nombres de las plantillas de pads de forma personalizada llevan el prefijo u. Se añaden otras combinaciones de letras y números enteros para las propiedades especificadas de las máscaras de pasta/soldadura.

Para observar este comportamiento, examine las propiedades de un pad o vía existente desde su panel Properties asociado haciendo doble clic en el objeto o seleccionándolo y eligiendo Properties en el menú contextual del botón derecho.

El nombre de la plantilla de pad o vía generado automáticamente que se muestra en el panel Properties.
El nombre de la plantilla de pad o vía generado automáticamente que se muestra en el panel Properties.

Observe el nombre Template asignado en la región Pad/Via Template del panel. De acuerdo con las directrices IPC, el nombre se deriva de las propiedades básicas del pad/vía, como sus dimensiones, forma, taladro y configuración de las máscaras de pasta/soldadura. Si se modifican esas propiedades, el nombre de la plantilla cambiará para reflejar la nueva configuración. Como cabe esperar, la relación entre las propiedades de un pad o vía y el nombre de su plantilla resulta menos evidente al trabajar con unidades imperiales en lugar de métricas.

Localizar un pad o vía en el espacio de diseño de PCB

Cada vez que se coloca un pad o vía de tamaño único en un diseño de PCB mediante el menú Place o Active Bar, se crea automáticamente una nueva plantilla de pad/vía en el archivo de la placa. Estas plantillas se denominan plantillas <Local>. Para la PCB actual, la lista de todas las plantillas de pads y vías utilizadas puede consultarse en el panel PCB cuando está configurado en el modo Pad & Via Templates.

El panel PCB en el modo Pad &amp; Via Templates
El panel PCB en el modo Pad & Via Templates

El modo Pad & Via Templates proporciona un control avanzado de las plantillas de pads y vías utilizadas en el documento de PCB actual. Este modo del panel se divide en tres secciones:

  • Library Name
  • Templates
  • Pads/Vias

Nombre de la biblioteca

Esta lista muestra las instancias de plantillas de pads y vías del diseño como una colección de bibliotecas virtuales y físicas. Estas filtran las plantillas incluidas en la lista de la sección inferior del panel y se organizan de la siguiente manera:

  • All – muestra todas las plantillas de pads y vías, incluidas las utilizadas desde bibliotecas de pads y vías.
  • Pads – muestra todos los pads, tanto locales como procedentes de bibliotecas.
  • Vias – muestra todas las vías, tanto locales como procedentes de bibliotecas.
  • Local – muestra todas las plantillas de pads y vías aplicadas a la placa, pero no las añadidas desde bibliotecas de pads y vías.
  • Pad & Via Libraries – muestra únicamente las plantillas de pads y vías que se han aplicado desde la biblioteca de pads y vías seleccionada.

Plantillas

Esta región proporciona una lista de todas las plantillas de pads/vías utilizadas en el diseño de PCB actual. Sus columnas incluyen el origen de la plantilla Library Name (local o nombre de la biblioteca de pads y vías) y el número de instancias de pads/vías de cada plantilla (Count).

Cuando la sección Library Name del panel se ha configurado en una biblioteca de pads y vías concreta, la sección Template puede mostrar entradas con un Count de cero instancias. Esto indica que la plantilla no se utiliza actualmente en ningún pad/vía del diseño de la placa, pero sí se utiliza en el proyecto de diseño; por ejemplo, puede utilizarse como configuración predeterminada de pad/vía o para definir la restricción de una regla de diseño como Routing Via Style.

Se puede guardar cualquier cantidad de las plantillas de la lista en una biblioteca de pads y vías independiente. Para ello, seleccione varias plantillas mediante las técnicas habituales de Shift+Click y Ctrl+Click y haga clic en el botón Save as Library. La biblioteca se añadirá automáticamente al proyecto y podrá guardarse con el nombre de archivo *.PvLib deseado mediante File » Save As desde el panel Projects. Para obtener más información sobre cómo crear una biblioteca de plantillas de pads y vías, consulte la página Crear y editar una biblioteca de plantillas de pads y vías.

La sección Templates también permite colocar en el diseño de PCB una plantilla procedente de una biblioteca de pads y vías mediante el botón Place. Seleccione la biblioteca de pads y vías deseada en la sección Library Name superior del panel para habilitar esta función.

El botón Place permite colocar la plantilla de pad/vía seleccionada si esta pertenece a una biblioteca de plantillas de pads y vías. Para colocar un pad/vía local, utilice el panel PCB Pad Via Templates, como se describe a continuación.

Pads/vías

Esta región del panel muestra las instancias individuales de pads/vías de la plantilla seleccionada en la sección Templates anterior.

Al seleccionar cada instancia de pad/vía, el objeto se resalta gráficamente en el espacio de diseño según las opciones habituales de resaltado, zoom y selección del panel, situadas en la parte superior del panel PCB. Los pads o vías seleccionados pueden editarse después para utilizar una plantilla diferente en el panel Properties; elija la plantilla requerida en la lista desplegable Template.

Cada instancia de la lista de esta región va acompañada de una casilla indicadora Changed que se marca cuando una plantilla de origen de una biblioteca vinculada difiere de la utilizada en el pad o vía local, es decir, cuando se ha actualizado la biblioteca de pads y vías de origen. El indicador Changed también se marcará si se modifica el tipo de pila de pads del pad/vía local; por ejemplo, si una instancia de pad se cambia localmente de multicapa a una sola capa.

En todos los casos, la versión local del pad o vía puede actualizarse (o revertirse) a la plantilla actual de la biblioteca de pads y vías de origen mediante el botón del panel PCB Pad Via Templates Update.

Tareas de edición y gestión de plantillas de pads y vías

Esta sección describe las distintas situaciones en las que es necesario editar plantillas de pads o vías.

Aplicar una plantilla diferente a pads o vías existentes

Habrá ocasiones en las que querrá aplicar una plantilla diferente a pads o vías existentes (por ejemplo, para reducir la cantidad de vías distintas utilizadas en un diseño). En este caso, utilice el modo Pad & Via Templates del panel PCB para localizar y seleccionar los pads o vías que desea modificar. A continuación, podrá editar los pads o vías seleccionados para que utilicen una plantilla diferente en el panel Properties, eligiendo la plantilla deseada en la lista desplegable Template.

Aplicación de una plantilla diferente.
Aplicación de una plantilla diferente.

Desvincular una plantilla de una biblioteca

No es posible editar las propiedades de pads o vías que utilizan una plantilla de una biblioteca de plantillas basada en archivos, ya que, de ser posible, la instancia local dejaría de coincidir con la plantilla de biblioteca referenciada. Para editar un pad o una vía que hace referencia a una plantilla de biblioteca, debe desvincular la plantilla.

Haga clic en el botón Linked button, click to copy the template from the file library to the local library and reference the local template para desvincular una plantilla. Al hacer clic en este botón, se crea una copia de esa plantilla en la biblioteca local y las instancias seleccionadas del pad o la vía pasan a hacer referencia a la plantilla local. Tenga en cuenta que, si el botón Linked button, click to copy the template from the file library to the local library and reference the local template aparece atenuado, esto indica que la plantilla ya es local.

Haga clic para desvincular la plantilla de la biblioteca basada en archivos. La plantilla se copia a la biblioteca local y se utiliza esa copia.
Haga clic para desvincular la plantilla de la biblioteca basada en archivos. La plantilla se copia a la biblioteca local y se utiliza esa copia.

Si el pad o la vía que se desvincula tenía un nombre personalizado definido en la biblioteca de plantillas de pads y vías, este nombre se elimina y se aplica la convención de nomenclatura estándar IPC a la plantilla local.

Añadir una plantilla de biblioteca a la biblioteca local

Si es necesario, puede añadir una plantilla de biblioteca a la biblioteca local. Para ello, haga clic con el botón derecho en el nombre de la plantilla y seleccione Add to Internal Library en el menú contextual, o arrastre la plantilla desde la sección Pad/Via Library del panel y suéltela en un área vacía de la sección Local Pad & Via Library.

Añada una plantilla de pads o vías a la biblioteca local mediante el menú contextual o arrastrándola y soltándola.
Añada una plantilla de pads o vías a la biblioteca local mediante el menú contextual o arrastrándola y soltándola.

Las plantillas de biblioteca de pads o vías que no se utilicen pueden eliminarse de la biblioteca local haciendo clic en el botón Removed Unused Pad/Via.

Esto equivale a colocar un pad o una vía procedente de una plantilla de biblioteca de pads y vías y después eliminarlo de la placa, de modo que la plantilla quede registrada como disponible localmente. Para replace una plantilla local, en lugar de añadir una a la lista local, consulte Sustituir una plantilla local más abajo.

Actualizar desde la biblioteca de pads y vías

Si se ha actualizado una plantilla de pad o vía en la biblioteca y esa plantilla ya se ha utilizado en el diseño de una placa, haga clic en el botón Update del panel PCB Pad Via Templates para actualizar la plantilla de pad o vía en el diseño. La actualización se reflejará automáticamente en todas las instancias de pads o vías de la placa que utilicen esa plantilla.

Un pad o una vía que utilice una plantilla actualizada en la biblioteca puede actualizarse en el diseño de PCB mediante el botón Update del panel PCB Pad Via Templates.
Un pad o una vía que utilice una plantilla actualizada en la biblioteca puede actualizarse en el diseño de PCB mediante el botón Update del panel PCB Pad Via Templates.

Al iniciar una actualización, se abre el cuadro de diálogo Update Pads/Vias on Board, que muestra los detalles de los cambios detectados que se aplicarán.

Las plantillas de pads o vías que difieran de su versión en la biblioteca de origen pueden actualizarse desde la biblioteca al diseño de PCB.
Las plantillas de pads o vías que difieran de su versión en la biblioteca de origen pueden actualizarse desde la biblioteca al diseño de PCB.

El cuadro de diálogo ofrece tres opciones para controlar el proceso de actualización:

  • Update locked objects – fuerza la actualización de la plantilla de un objeto pad o vía, independientemente de su estado de bloqueo.
  • Update free objects – actualiza únicamente las plantillas de pads o vías que se aplican a pads y vías libres.
  • Update component objects – actualiza únicamente las plantillas de pads o vías que se aplican a los pads y vías utilizados en componentes.

Este comportamiento de sincronización se establece mediante la propiedad Library de los pads y las vías, que se muestra en el panel Properties al consultar las propiedades de un pad o una vía seleccionados, respectivamente. La columna Changed de la sección Pads/Vias del modo de plantillas de pads y vías del panel PCB indica si existen diferencias entre la versión local de la plantilla y la plantilla de origen.

Aunque el nombre de la plantilla haya cambiado en la biblioteca de pads y vías de origen, el vínculo con el pad o la vía al que se aplica en el diseño de PCB se mantiene mediante la referencia GUID de la plantilla, almacenada en los datos del diseño de la placa.

La sección inferior del cuadro de diálogo enumera los pads o vías que se actualizarán. Se muestra información sobre cada uno, incluidos Type, Description, Library, Template y Action. Además, puede marcar cada pad o vía como Locked y/o In Component. Al habilitar estas opciones, el objeto queda sujeto a los controles de la sección superior del cuadro de diálogo.

Sustituir una plantilla local

Una plantilla de pad o vía basada en una biblioteca también puede replace una plantilla local, lo que actualizará los pads o las vías de la placa que utilicen esa plantilla local.

Para ello, arrastre la plantilla de biblioteca deseada desde la sección Pad/Via Library del panel a la sección Local Pad & Via Library, pero, en este caso, suelte la plantilla de biblioteca on top of la entrada de la plantilla local existente. Todas las instancias de pads o vías libres o de componentes que utilicen la plantilla se actualizarán al estilo de la nueva plantilla de biblioteca.

En la animación siguiente, observe que los pads de los componentes C1 y C2 cambian físicamente al tipo determinado por la plantilla de biblioteca que se ha soltado: de r110_100 a s120.

Suelte una plantilla de biblioteca sobre la entrada de una plantilla local para sustituirla en todas las instancias del diseño.
Suelte una plantilla de biblioteca sobre la entrada de una plantilla local para sustituirla en todas las instancias del diseño.

Eliminar pads o vías no utilizados

Dado que los nombres de las plantillas que aparecen en la biblioteca local se derivan de los pads y vías del diseño de PCB actual, si se han eliminado de la placa todas las instancias de una configuración local de pad o vía determinada, su plantilla correspondiente se eliminará de la lista local.

Sin embargo, si un pad o una vía colocado procede de una biblioteca de pads y vías, su plantilla se conservará en la lista local cuando se hayan eliminado de la placa todas las instancias de ese pad o vía. Las instancias de plantillas de la biblioteca de pads y vías que ya no sean necesarias pueden eliminarse del registro de la «base de datos» local mediante el botón Remove Unused Pad/Via. Se abrirá el cuadro de diálogo Update Templates from Library, en el que podrá elegir qué plantillas de pads y vías se eliminarán de la biblioteca local de pads y vías. Utilice el botón Templates  o el menú contextual para seleccionar o deseleccionar todas las plantillas de la lista, o invertir la selección.

El cuadro de diálogo Update Templates from Library
El cuadro de diálogo Update Templates from Library

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents