Trabajar con pistas y arcos
De un vistazo
- Aprende a colocar, editar, mover y reenrutar segmentos de pista en el editor de PCB mediante los comandos y atajos principales.
- Comprende cómo responde el enrutamiento interactivo a las redes, las capas, los modos de esquina, la resolución de conflictos y las reglas de diseño aplicables.
- Descubre cómo se determina y ajusta el ancho de enrutamiento, y cómo las preferencias y las reglas influyen en los anchos que puedes utilizar.
Trabajo con pistas
Un segmento de pista es una línea recta de un ancho definido. Utilice pistas para definir una línea recta en el espacio de diseño de la PCB. Las pistas se colocan en una capa de señal para formar las interconexiones eléctricas, o el enrutado, entre los pads de los componentes. Las pistas colocadas en una capa no eléctrica se denominan líneas y se utilizan como elementos de dibujo de uso general para crear contornos de componentes, información orientativa, límites de exclusión, etc. Las pistas también se utilizan en objetos de diseño agrupados, como cotas y coordenadas.

Los objetos de pista se utilizan para el enrutado y para dibujar líneas de uso general. En la imagen anterior hay cuatro segmentos de pista colocados y otro en proceso de colocación.
Aunque las pistas y las líneas son en realidad el mismo objeto, la diferencia reside en cómo se comporta el software durante su colocación, por lo que existen comandos distintos. Cuando se ejecuta un comando de colocación de pistas, como Interactive Routing, el software supervisa la ubicación del clic y adopta automáticamente el nombre de la red de un objeto existente (como un pad) situado bajo esa ubicación. También supervisa y respeta las reglas de diseño aplicables. Cuando se ejecuta un comando de colocación de líneas (Place » Line), no se realizan estas comprobaciones.
Las pistas se pueden colocar tanto en el editor de PCB como en el editor de bibliotecas de PCB. Independientemente del comando utilizado (enrutado/colocación de pistas o colocación de líneas), el comportamiento básico de colocación es el mismo. Tras ejecutar el comando, el cursor cambiará a una cruz y se activará el modo de colocación de pistas. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto inicial del primer segmento de pista. Si se está ejecutando un comando de colocación de tipo enrutado y hace clic en un objeto existente para comenzar la colocación, la pista adoptará el nombre de la red de ese objeto. Para el enrutado, el ancho se determinará mediante la regla de diseño Ancho de enrutado aplicable; ciertas opciones de enrutado interactivo pueden modificar este comportamiento, como se describe con más detalle a continuación.
- Mueva el cursor para definir el segmento de pista y, a continuación, haga clic o pulse Enter para fijar el punto final de este primer segmento, que también será el punto inicial del siguiente segmento conectado.
- Siga posicionando el cursor y haciendo clic o pulsando Enter para fijar una serie de vértices que definan la sucesión de segmentos de pista conectados.
- Haga clic con el botón derecho o pulse Esc para finalizar la serie actual de segmentos de pista conectados.
Durante la colocación también se pueden realizar las siguientes acciones:
- Pulse la tecla * del teclado numérico para recorrer las capas de señal disponibles. También puede utilizar la combinación Shift+Ctrl+Wheel Roll para desplazarse por las capas de enrutado; cada paso de la rueda del ratón pasará a la siguiente (o anterior) capa de señal disponible.
- Pulse las teclas + y - del teclado numérico para recorrer hacia delante y hacia atrás todas las capas visibles actualmente en el diseño.
Al colocar segmentos de pista, hay cinco modos de esquina disponibles, cuatro de los cuales también tienen submodos de dirección de esquina. Durante la colocación:
- Pulse Shift+Spacebar para recorrer los modos de esquina disponibles.
- Pulse Spacebar para alternar entre los dos submodos de dirección de esquina.
- En cualquiera de los modos de esquina en arco, mantenga pulsada la tecla , o . para reducir o ampliar el arco. Mantenga pulsada la tecla Shift mientras pulsa para acelerar el cambio de tamaño del arco.
- Pulse el atajo de teclado 1 para alternar entre colocar un segmento por clic (como se muestra en las primeras cinco imágenes de abajo) o dos segmentos por clic (como se muestra en la última imagen). En el primer modo, el segmento de pista hueco se denomina segmento de anticipación.
- Pulse la tecla Backspace para eliminar el último vértice.



Pulse Shift+Spacebar para recorrer los cinco modos de esquina disponibles, pulse Spacebar para alternar la dirección de la esquina y pulse el atajo 1 para alternar entre la colocación de un segmento o dos segmentos.
El método de edición gráfica permite seleccionar un objeto de pista colocado directamente en el espacio de diseño y cambiar su tamaño, forma o ubicación de manera gráfica.
Cuando se selecciona un objeto de pista, están disponibles los siguientes tiradores de edición:
- Haga clic y arrastre A para reposicionar los extremos de la pista.
- Haga clic y arrastre B para cambiar la forma de la pista.
El editor de PCB incluye algoritmos sofisticados para mover segmentos de pista en la placa de modo que se pueda mantener la disposición del enrutado. Este deslizamiento de los segmentos de pista se puede activar de forma interactiva, bien haciendo clic para seleccionar primero el segmento de pista y, después, manteniendo pulsado el botón cuando aparezca el cursor especial para deslizar el segmento, o bien manteniendo pulsado el botón sobre un segmento de pista y deslizándolo. El comportamiento de deslizamiento se puede configurar mediante las opciones Dragging de la página Editor de PCB - Enrutado interactivo del cuadro de diálogo Preferences. Estas opciones permiten asignar la acción Mover a una pista, lo que resulta útil si desea mover libremente un segmento de pista individual.

Controle el comportamiento de deslizamiento de las pistas con las opciones de arrastre configuradas en Preferencias.
Si se asigna la acción Move mediante estas opciones, el segmento de pista se puede girar o reflejar durante el movimiento.
Enrutado interactivo y reglas de diseño aplicables
Durante el enrutado interactivo, el comportamiento predeterminado del software consiste en garantizar que los segmentos de pista se coloquen de acuerdo con las reglas de diseño eléctricas y de enrutado aplicables. Esto significa que el software no permitirá colocar un nuevo segmento de pista que incumpla las reglas respecto a un segmento de pista existente perteneciente a otra red; en su lugar, recortará el segmento de pista para cumplir las reglas de diseño. Este comportamiento de enrutado interactivo se conoce como modo Routing Conflict Resolution. El modo predeterminado es Stop at First Obstacle (el modo actual se muestra en la barra de estado). Pulse Shift+R para recorrer los modos disponibles.
El término applicable design rules se refiere a todas las reglas que se aplican al objeto que se está colocando. El motor de reglas de diseño funciona con un sistema que permite definir exactamente a qué objetos se debe aplicar cada regla. Durante la colocación, se consulta al motor de reglas de diseño para determinar la regla de mayor prioridad aplicable a la situación de colocación actual. Las reglas que se aplican durante el enrutado interactivo incluyen:
- Separación eléctrica
- Ancho de enrutado
- Estilo de vía de enrutado
La animación siguiente muestra el enrutado en acción. La red GND se está enrutando de acuerdo con una regla de diseño de ancho de enrutado definida y aplicable. Observe que, cuando el cursor se mueve sobre la vía asociada a la red +12V, el trazado se recorta automáticamente para garantizar que se cumpla la regla de diseño Restricción de separación eléctrica aplicable.

Las reglas de diseño aplicables de ancho de enrutado y separación se respetan automáticamente durante el enrutado interactivo.
Cómo se determina el ancho de enrutado
A menos que el motor de reglas esté desactivado, el comportamiento prioritario del software es garantizar siempre que el ancho de enrutado esté dentro del intervalo permitido por la regla de diseño de ancho de enrutado aplicable. Un enfoque habitual consiste en permitir el uso de un intervalo de anchos para una red que ofrezca flexibilidad al acomodar el trazado y, al mismo tiempo, satisfaga los requisitos de capacidad de corriente de esa red. Para ello, la regla de diseño de ancho de enrutado dispone de los ajustes Min, Preferred y Max en el Editor de reglas y restricciones de PCB, que pueden configurarse para permitir un intervalo de anchos o establecerse en el mismo valor para exigir un ancho específico. El ancho también puede configurarse en función de una impedancia y puede especificarse un intervalo diferente para cada capa de señal.

La regla de diseño de ancho de enrutado predeterminada se aplica a todas las redes de una PCB nueva.
Como diseñador, dispone de varias opciones que pueden ayudarle a seleccionar el ancho de enrutado más adecuado al comenzar a enrutar. Estas se configuran en la página Editor de PCB — Enrutado interactivo del cuadro de diálogo Preferences, como se muestra a continuación.

Las opciones Interactive Routing Width Sources determinan qué ancho se utiliza al iniciar un trazado.
Observe que Track Width Mode está establecido en Rule Preferred en la imagen. Esto indica que, cuando el trazado comienza en un objeto de red existente, como un pad, este es el ancho que se utilizará. Sin embargo, si el trazado comienza en una pista existente, la opción Pickup Track Width From Existing Routes prevalecerá sobre Track Width Mode y establecerá el nuevo ancho para que coincida con el existente.
Como diseñador, también puede pulsar el atajo Shift+W mientras enruta para acceder a un cuadro de diálogo donde puede seleccionar un ancho diferente, o puede pulsar Tab para abrir Properties panel e introducir un nuevo valor de Width . El valor seleccionado o introducido debe estar comprendido entre los ajustes Min y Max definidos en la regla aplicable. De lo contrario, se ajustará automáticamente al límite más cercano.
Atajos de enrutado interactivo
Durante el enrutado, hay varios atajos disponibles. Por ejemplo, puede pulsar Shift+R para alternar entre los modos de resolución de conflictos disponibles, o pulsar Backspace para eliminar el último vértice (esquina) colocado. Para mostrar una lista de atajos mientras enruta, pulse Shift+F1. Aparecerá un menú con los atajos interactivos disponibles; seleccione el atajo que necesite o pulse Esc para cerrar el menú y utilizar la secuencia de teclas del atajo.

Durante el enrutado interactivo, pulse Shift+F1 para mostrar un menú con los atajos interactivos disponibles
Mover una pista
El submenú Edit » Move y el menú de comandos de movimiento de Active Bar incluyen varios comandos que pueden utilizarse para cambiar la posición o la forma de una pista.
Volver a enrutar
Este comando permite volver a enrutar manualmente una pista existente en la placa. Tras ejecutar el comando, el cursor cambiará a una cruz y se le pedirá que elija una pista. Sitúe el cursor sobre la pista deseada y haga clic o pulse Enter. El funcionamiento de esta característica depende de si la opción Preserve Angle When Dragging está activada o no en la página Editor de PCB - Enrutado interactivo del cuadro de diálogo Preferences:
- Preserve Angle Dragging enabled - la pista se dividirá y se añadirá un nuevo segmento para mantener las conexiones ortogonales/diagonales. Mueva el cursor para deslizar este segmento según sea necesario y, a continuación, haga clic para colocarlo. Haga clic con el botón derecho o pulse Esc en este punto; de lo contrario, ese nuevo segmento se dividirá y se añadirá otro segmento. Utilice el atajo de teclado Shift+R para alternar entre las opciones que controlan cómo deben gestionarse los obstáculos durante el arrastre (Ignore Obstacles, Avoid Obstacles o Avoid Obstacles (Snap Grid)). Si uno de los modos de evitar obstáculos está activado, se respetarán las reglas durante el arrastre, lo que impedirá arrastrar un segmento a una posición que las infrinja.
- Preserve Angle Dragging disabled - ambos extremos del segmento de pista quedarán anclados y podrá colocar nuevos segmentos de pista entre ellos. Haga clic o pulse Enter para colocar un nuevo segmento de pista. Continúe colocando nuevos segmentos de pista para volver a enrutar o haga clic con el botón derecho o pulse Esc para detenerse.
Continúe volviendo a enrutar otras pistas o haga clic con el botón derecho o pulse Esc para salir.
Dividir pista
Este comando permite crear un vértice (o una división) en un segmento de pista. Tras ejecutar el comando, el cursor cambiará a una cruz y se le pedirá que seleccione una pista. Sitúe el cursor sobre el segmento de pista deseado, en el punto exacto donde quiera insertar una división, y haga clic o pulse Enter. Se insertará un vértice que dividirá el segmento original en dos.
Mueva el vértice a la posición deseada y haga clic o pulse Enter para colocarlo. Los segmentos de pista conectados se comportan según el ajuste de la opción Preserve Angle When Dragging en la página Editor de PCB - Enrutado interactivo del cuadro de diálogo Preferences:
- Preserve Angle When Dragging activada - se conservan los ángulos con los segmentos de pista adyacentes, manteniendo el estilo de enrutado.
- Preserve Angle When Dragging desactivada - los dos segmentos de pista individuales se estirarán como una banda elástica para adaptarse al movimiento sin mantener el estilo de enrutado existente.
Continúe dividiendo más segmentos de pista o haga clic con el botón derecho o pulse Esc para salir.
Arrastrar extremo de pista
Este comando permite reposicionar manualmente o arrastrar el extremo de un segmento de pista enrutado. Tras ejecutar el comando, el cursor cambiará a una cruz y se le pedirá que seleccione un objeto. Sitúe el cursor sobre una pista y haga clic o pulse Enter. El cursor saltará al extremo más cercano del segmento de pista y dicho extremo quedará unido al cursor. Mueva el extremo de la pista a la posición deseada y haga clic o pulse Enter para colocarlo.
- Si el extremo del segmento de pista elegido es un vértice al que no hay conectados otros segmentos de pista, mueva el vértice a la posición deseada.
- Si el extremo del segmento de pista elegido es un vértice al que hay conectados dos segmentos de pista, los segmentos conectados se estirarán al mover el vértice.
- Si el extremo del segmento de pista está conectado a un pad de componente, al moverlo se desconectará del pad. Tras cambiar la posición del extremo, se mostrará una línea de conexión lógica desde el extremo de la pista hasta el pad, siempre que la opción Smart Track Ends esté habilitada en la página Editor de PCB – General del cuadro de diálogo Preferences.
- Si el extremo del segmento de pista está conectado a un pad libre, el pad quedará unido al cursor para poder cambiarlo de posición. Todas las pistas conectadas al pad se estirarán en consecuencia.
- Si el extremo del segmento de pista está conectado a una vía, la vía quedará unida al cursor para poder cambiarla de posición. Todas las pistas conectadas a la vía se estirarán en consecuencia.
Continúe arrastrando otros extremos de pista o haga clic con el botón derecho o pulse Esc para salir.
Mover / Cambiar el tamaño de las pistas
Este comando permite mover los extremos de varios segmentos de pista seleccionados, cambiando así su tamaño. Tras ejecutar el comando, el cursor cambiará a una cruz y se le pedirá que elija un extremo de pista. Para mover las pistas o cambiar su tamaño:
- Sitúe el cursor sobre el extremo de uno de los segmentos seleccionados y haga clic o pulse Enter.
- Mueva el cursor; todos los segmentos de pista seleccionados cambiarán de tamaño dinámicamente manteniendo las distancias y los ángulos originales entre ellos. El otro extremo de cada segmento se estirará para mantener su conexión o ubicación actual.
- Una vez que los segmentos estén en la posición deseada, haga clic o pulse Enter para colocarlos y salir del modo de movimiento.
- Para cancelar la operación, haga clic con el botón derecho o pulse Esc.
Mientras mueve los segmentos, dispone de los siguientes controles adicionales:
- Pulse la tecla Tab para alternar la posición del cursor entre los extremos de cada segmento de pista seleccionado.
- Mantenga pulsada la tecla Alt mientras mueve los segmentos para restringir el movimiento a una dirección determinada según la dirección inicial del movimiento. Las direcciones posibles son horizontal, vertical y en un ángulo de 45 grados.
- Pulse Spacebar dos veces para alinear rápidamente todos los extremos de los segmentos de pista en horizontal o en vertical. Vuelva a pulsar Spacebar dos veces rápidamente para recuperar las dimensiones anteriores.
Cortar pistas
La herramienta de corte de pistas permite dividir fácilmente uno o varios segmentos de pista en dos y puede cortar pistas de la capa de señal actual o de todas las capas de señal visibles. Para acceder a la herramienta, seleccione el comando Edit » Slice Tracks en los menús principales.
Tras ejecutar el comando, el cursor cambiará a una cruz y se le pedirá que elija la posición inicial del corte. Además, se aplica un filtro para mostrar únicamente objetos de pista en el espacio de trabajo. Se mostrarán todas las pistas de todas las capas de señal visibles o solo las pistas de la capa de señal actual, según la configuración activa de la herramienta de corte de pistas. Para cortar una o varias pistas:
- Sitúe el cursor y haga clic o pulse Enter para fijar el punto inicial del corte.
- Mueva el cursor por el punto de la pista, o de las pistas, donde desee realizar el corte: la trayectoria de la herramienta se muestra mediante una línea con una representación visual de los cortes previstos.
- Haga clic o pulse Enter para fijar el punto final de la trayectoria de la herramienta de corte.
- Continúe cortando otros segmentos de pista, o haga clic con el botón derecho o pulse Esc para salir del modo de corte.
Tras elegir el punto de anclaje inicial del corte y mientras mueve la «línea de corte», puede realizar las siguientes acciones adicionales:
- Pulse la tecla B para alternar entre cortar únicamente las pistas de la capa de señal actual o las pistas de todas las capas de señal visibles.
- Pulse Spacebar para alternar el ángulo de corte entre incrementos de 45 grados o cualquier ángulo.
- Pulse la tecla N para alternar el lado de la cuchilla de corte entre izquierda, derecha y centro.
- Pulse la tecla / para seleccionar todas las pistas cortadas.
- Pulse la tecla «,» para seleccionar las pistas cortadas a la izquierda de la herramienta de corte.
- Pulse la tecla «.» para seleccionar las pistas cortadas a la derecha de la herramienta de corte.
- Pulse la tecla M para no seleccionar ninguna pista cortada.
-
Pulse la tecla Tab para acceder al cuadro de diálogo Slicer Properties, desde el que puede cambiar las propiedades de la herramienta de corte de pistas sobre la marcha.

El cuadro de diálogo Slicer Properties
Conversión de pistas en trazados achaflanados
El achaflanado de las esquinas de enrutamiento de 90 grados es una técnica utilizada para reducir las reflexiones causadas por la esquina en un trazado que opera a frecuencias de microondas. Se pueden utilizar arcos, pero deben tener un radio de al menos 3 veces el ancho del trazado. El achaflanado (también llamado corte a inglete) es una alternativa en la que se recorta el vértice exterior de la esquina. Como los objetos de pista de Altium Designer tienen extremos redondeados, no se pueden utilizar para crear una esquina achaflanada. Para crearla, los segmentos de pista seleccionados se sustituyen por objetos de región.
Seleccione todos los segmentos de pista que desee achaflanar y, a continuación, seleccione el comando Tools » Convert » Convert Selected Tracks to Chamfered Path en los menús principales. Se abrirá el cuadro de diálogo Convert Tracks to Chamfered Path. Utilice este cuadro de diálogo para configurar el chaflán y luego haga clic en OK. Cada par de segmentos de pista seleccionado (con ángulos de 90 grados que requieren corrección) se sustituirá por una esquina achaflanada, y los segmentos de pista originales de cada par se convertirán en un único objeto de región sólida (de cobre).

Las pistas seleccionadas se achaflanarán en la medida especificada en cada esquina de ángulo recto.
Utilice las siguientes opciones del cuadro de diálogo para configurar el chaflán:
- Chamfer - porción de la esquina exterior que se recortará o achaflanará, expresada como porcentaje de la distancia diagonal existente de la esquina.
- Inside Chamfer - cantidad de material que se añadirá a la esquina interior como porcentaje de la distancia diagonal existente de la esquina.
How big should the Chamfer be?
El porcentaje de corte a inglete es la fracción recortada de la diagonal entre las esquinas interior y exterior del codo sin cortar a inglete.
Douville y James han determinado experimentalmente el corte a inglete óptimo para una amplia variedad de geometrías de microcinta. Según sus resultados, una buena aproximación del porcentaje óptimo de corte a inglete viene dada por
Siempre que se cumpla
y con una constante dieléctrica del sustrato
.
Esta fórmula es completamente independiente de
. El intervalo real de parámetros para el que Douville y James presentan pruebas es
y
. Indican una ROE inferior a 1,1 (es decir, un retorno inferior a −26 dB) para cualquier porcentaje de corte a inglete que se encuentre dentro del 4 % (del
original) del valor obtenido con la fórmula. Para el valor mínimo de
de 0,25, el porcentaje de corte a inglete es del 98,4 %, por lo que la cinta queda casi completamente seccionada.
Propiedades de la pista

El modo Track del panel Properties.
Información de la red
Esta sección proporciona información sobre la red a la que pertenece la pista, así como sobre el par diferencial y/o la xSignal de los que forme parte dicha red. Se muestra información sobre las clases cuando corresponde. También se proporcionan los valores de Delay, Length, Max Current y Resistance.
Consulte la página Técnicas de colocación y edición de PCB para obtener más información sobre las redes.
Ubicación
-
(X/Y)
- X (primer campo): la coordenada X (horizontal) actual del punto de referencia de la pista con respecto al origen actual del espacio de diseño. Edítela para cambiar la posición X de la pista. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actualmente.
- Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia de la pista con respecto al origen actual. Edítela para cambiar la posición Y de la pista. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actualmente.
Propiedades
- Component – este campo solo se muestra en el editor de PCB cuando la pista seleccionada forma parte de un componente de PCB, y muestra el designador del componente de PCB al que pertenece. Seleccione el enlace Component para abrir el modo Componente del panel Propiedades correspondiente al componente al que pertenece.
- Net – utilice este campo para elegir una red para la pista. Todas las redes del diseño de placa activo aparecerán en la lista desplegable. Tenga en cuenta que, si la colocación del objeto comienza en la misma ubicación que un objeto existente ya conectado a una red, la propiedad Net del nuevo objeto se asignará automáticamente a esa red. Seleccione No Net para especificar que la pista no está conectada a ninguna red. El comprobador de reglas de diseño utiliza la propiedad Net de una primitiva para determinar si la colocación de un objeto de PCB cumple las reglas. Como alternativa, puede hacer clic en el icono Assign Net para elegir un objeto en el espacio de diseño; la red de ese objeto se asignará a las pistas seleccionadas.
- Layer – utilice la lista desplegable para seleccionar la capa en la que se encuentra la pista.
- Width – muestra el ancho actual de la pista. Edite este campo para cambiar el ancho de la pista dentro del intervalo de 0.001mil a 10000mil.
- Start (X/Y) – muestra las coordenadas X/Y actuales del punto inicial de la pista con respecto al origen actual.
- End (X/Y) – muestra las coordenadas X/Y actuales del punto final de la pista con respecto al origen actual.
-
Length – muestra la longitud actual de la pista. Edite este campo para cambiar la longitud de la pista dentro del intervalo de 0.001mil a 10000mil.
Expansión de la máscara de pasta
- Rule/Manual – seleccione la configuración de expansión de la máscara de pasta deseada. Seleccione Rule para que la expansión de la máscara de pasta de la pista siga el valor definido en la regla de diseño Expansión de la máscara de pasta aplicable. Seleccione Manual para anular la regla de diseño aplicable y especificar el valor de expansión de la máscara de pasta para la pista. A continuación, puede habilitar e introducir la medida deseada.
Expansión de la máscara de soldadura
- Rule/Manual – seleccione la configuración de expansión de la máscara de soldadura deseada. Seleccione Rule para que la expansión de la máscara de soldadura de la pista siga el valor definido en la regla de diseño Expansión de la máscara de soldadura aplicable. Seleccione Manual para anular la regla de diseño aplicable y especificar el valor de expansión de la máscara de soldadura para la pista. A continuación, puede habilitar e introducir la medida deseada.
Trabajo con arcos
Un arco es un objeto de diseño primitivo. Es esencialmente un segmento circular de pista que puede colocarse en cualquier capa. Los arcos pueden tener diversos usos en el diseño de PCB. Por ejemplo, pueden utilizarse para definir los contornos de los componentes en las capas de serigrafía, o en una capa mecánica para indicar el contorno de la placa, los bordes de los recortes, etc. También pueden utilizarse para crear trayectorias curvas durante el enrutamiento interactivo. Los arcos pueden estar abiertos o cerrados para crear un círculo (lo que suele denominarse arco de círculo completo).

Dos arcos colocados; a la izquierda, un arco de círculo completo; a la derecha, un arco seleccionado para su edición.
Los arcos pueden colocarse tanto en el Editor de PCB como en el Editor de bibliotecas de PCB. Hay cuatro modos de colocación de arcos disponibles (Centro, Borde, Cualquier ángulo y Círculo completo). La forma de colocar un arco depende del método de colocación que haya elegido:
-
Place arc by center – este método permite colocar un objeto de arco utilizando el centro del arco como punto de partida.
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de arcos. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto central del arco.
- Mueva el cursor para ajustar el radio del arco y, a continuación, haga clic o pulse Enter para establecerlo.
- Mueva el cursor para ajustar el punto inicial del arco y, a continuación, haga clic o pulse Enter para fijarlo.
- Mueva el cursor para cambiar la posición del punto final del arco y, a continuación, haga clic o pulse Enter para fijarlo y completar la colocación del arco.
- Continúe colocando más arcos o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
-
Place arc by edge – este método permite colocar un objeto de arco utilizando el borde del arco como punto de partida. El ángulo del arco está fijado en 90°.
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de arcos. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto inicial del arco.
- Mueva el cursor para cambiar la posición del punto final del arco y, a continuación, haga clic o pulse Enter para fijarlo y completar la colocación del arco.
- Continúe colocando más arcos o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
-
Place arc by edge (any angle) – este método permite colocar un objeto de arco utilizando el borde del arco como punto de partida. El ángulo del arco puede tener cualquier valor.
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de arcos. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto inicial del arco.
- Mueva el cursor para ajustar el radio del arco y, a continuación, haga clic o pulse Enter para fijar el punto central.
- Mueva el cursor para cambiar la posición del punto final del arco y, a continuación, haga clic o pulse Enter para fijarlo y completar la colocación del arco.
- Continúe colocando más arcos o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
-
Place full circle arc – este método permite colocar un arco de 360° (círculo completo).
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de arcos. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto central del arco.
- Mueva el cursor para ajustar el radio del arco y, a continuación, haga clic o pulse Enter para establecerlo y completar la colocación del arco.
- Continúe colocando más arcos o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Durante la colocación también pueden realizarse las siguientes acciones:
- En todos los métodos (excepto en los arcos de círculo completo), pulse Spacebar antes de definir el punto final del arco para trazar el arco en el sentido opuesto.
- Pulse la tecla L para voltear el arco al otro lado de la placa; tenga en cuenta que esto solo es posible antes de fijar el punto inicial o central del arco.
- Pulse las teclas + y - (en el teclado numérico) o utilice los atajos Shift+Ctrl+Wheelroll para recorrer hacia delante y hacia atrás todas las capas visibles del diseño y cambiar rápidamente la capa de colocación.
El método de edición gráfica permite seleccionar un objeto de arco colocado directamente en el espacio de diseño y modificar gráficamente su tamaño, forma o ubicación.
Cuando se selecciona un objeto de arco, están disponibles los siguientes controles de edición:

Un arco seleccionado
- Haga clic y arrastre A para ajustar el radio.
- Haga clic y arrastre B para ajustar los extremos (ángulos inicial y final).
-
Haga clic en cualquier punto del arco alejado de los controles de edición y, a continuación, arrastre para cambiar su posición. También puede hacer clic en el punto central del arco y arrastrarlo. Mientras lo arrastra, el arco puede girarse o reflejarse:
- Pulse Spacebar para girar el arco en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. La rotación se realiza de acuerdo con el valor de Rotation Step, definido en la página Editor de PCB – General del cuadro de diálogo Preferences.
- Pulse las teclas X o Y para reflejar el arco respecto al eje X o al eje Y.
Propiedades del arco
Información de la red
Esta sección proporciona información sobre la red a la que pertenece el arco, así como sobre el par diferencial y/o xSignal si la red forma parte de ellos. La información de clase se muestra cuando corresponde. También se proporcionan los valores de Delay, Length, Max Current y Resistance.
Consulte la página Técnicas de colocación y edición de PCB para obtener más información sobre las redes.
Ubicación
-
(X/Y)
- X (primer campo): este campo muestra la posición X actual del centro del arco respecto al origen actual. Edite el valor del campo para cambiar la posición del arco respecto al origen actual. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actuales. Las unidades predeterminadas (métricas o imperiales) se determinan mediante el ajuste Units de la sección Other del panel Properties en el modo Board (al que se accede cuando no hay objetos seleccionados en el espacio de diseño) y se utilizan si no se especifica la unidad.
- Y (segundo campo): este campo muestra la posición Y actual del centro del arco respecto al origen actual. Edite el valor del campo para cambiar la posición del arco respecto al origen actual. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actuales. Las unidades predeterminadas (métricas o imperiales) se determinan mediante el ajuste Units de la sección Other del panel Properties en el modo Board (al que se accede cuando no hay objetos seleccionados en el espacio de diseño) y se utilizan si no se especifica la unidad.
Propiedades
- Component – este campo se muestra en el editor de PCB solo cuando el arco seleccionado forma parte de un componente de PCB y muestra el designador del componente de PCB al que pertenece. Seleccione el enlace Component para abrir el modo Componente del panel Propiedades para dicho componente.
- Net – permite elegir una red para el arco. Todas las redes del diseño de placa activo aparecerán en la lista desplegable. Tenga en cuenta que, si la colocación del objeto comienza en la misma ubicación que un objeto existente que ya está conectado a una red, la propiedad Net del nuevo objeto se asigna automáticamente a esa red. Seleccione No Net para especificar que el arco no está conectado a ninguna red. El comprobador de reglas de diseño utiliza la propiedad Net de una primitiva para determinar si un objeto de PCB está colocado conforme a las reglas. También puede hacer clic en el icono Assign Net para elegir un objeto en el espacio de diseño; la red de ese objeto se asignará a los arcos seleccionados.
- Layer – este campo muestra la capa a la que está asignado actualmente el arco. Los arcos se pueden asignar a cualquier capa disponible. Para cambiar la capa asignada, haga clic en el campo y seleccione una capa de la lista desplegable.
- Width – este campo muestra el ancho de la línea del arco. Introduzca un valor diferente para el ancho si es necesario.
- Radius – este campo muestra el radio del arco, medido desde el punto central hasta el centro de la línea del arco. Introduzca un valor diferente para el radio si es necesario.
- Start Angle – este campo muestra el ángulo inicial del arco, medido desde el eje X en el primer cuadrante (geometría plana). Introduzca un valor diferente para el ángulo inicial si es necesario.
- End Angle – este campo muestra el ángulo final del arco. Introduzca un valor diferente para el ángulo final si es necesario.
- Propagation Delay – este campo muestra el tiempo que tarda una señal en propagarse a lo largo de esa ruta.
Expansión de la máscara de pasta
- Rule – seleccione esta opción para que la expansión de la máscara de pasta del arco siga el valor definido en la regla de diseño de expansión de la máscara de pasta aplicable. El valor de expansión asociado quedará deshabilitado si se elige esta opción.
- Manual – seleccione esta opción para anular la regla de diseño aplicable y especificar el valor de expansión de la máscara de pasta del arco en el campo siguiente.
Expansión de la máscara de soldadura
- Rule – marque la casilla para que la expansión de la máscara de soldadura del arco siga el valor definido en la regla de diseño de expansión de la máscara de soldadura aplicable. El valor de expansión asociado quedará deshabilitado si se elige esta opción.
- Manual – marque la casilla para anular la regla de diseño aplicable y especificar el valor de expansión de la máscara de soldadura del arco en el campo siguiente.
Creación de contornos alrededor de objetos seleccionados con pistas y arcos
El comando Tools » Outline Selected Objects de los menús principales se puede utilizar para colocar un contorno de pistas y arcos alrededor de las primitivas libres seleccionadas en el diseño. Esta función puede resultar especialmente útil si desea aislar eléctricamente redes críticas conectando el contorno a una fuente de tierra. Tras ejecutar el comando, se creará un contorno de pistas y/o arcos alrededor de los objetos. Las pistas y los arcos del contorno se colocan con un ancho de 8 mil y con la propiedad Net establecida en No Net.
Se respetan las reglas de diseño de separación, ancho y cortocircuito del diseño, por lo que el comprobador de reglas de diseño señalará las infracciones de separación.
Trabajo con rectángulos
Se puede colocar un rectángulo en cualquier capa. Los rectángulos de distintos tamaños se pueden combinar para cubrir áreas de forma irregular y también se pueden combinar con segmentos de pista o arco.
Los rectángulos también se pueden colocar en capas no eléctricas. Por ejemplo, coloque un rectángulo en la capa de exclusión (Keep-Out) para definir un área prohibida para el enrutamiento automático. Coloque un rectángulo en una capa de plano de alimentación, máscara de soldadura o máscara de pasta para crear un vaciado en esa capa.

Un rectángulo colocado
Los rectángulos se pueden colocar tanto en el editor de PCB como en el editor de bibliotecas de PCB de las siguientes formas:
- Editor de PCB: están disponibles los siguientes métodos de acceso:
- Seleccione Place » Rectangle en los menús principales.
- Haga clic en el botón Rectangle del menú desplegable de Active Bar situado en la parte superior del espacio de diseño. (Mantenga pulsado un botón Active Bar para acceder a otros comandos relacionados. Una vez utilizado un comando, este pasará a ser el primer elemento de esa sección de Active Bar.)
- Haga clic con el botón derecho en el espacio de diseño y, a continuación, haga clic en Place » Rectangle en el menú contextual.
-
Editor de bibliotecas de PCB: están disponibles los siguientes métodos de acceso:
- Seleccione Place » Rectangle en los menús principales.
- Haga clic en el botón Rectangle del menú desplegable de Active Bar situado en la parte superior del espacio de diseño. (Mantenga pulsado un botón Active Bar para acceder a otros comandos relacionados. Una vez utilizado un comando, este pasará a ser el primer elemento de esa sección de Active Bar.)
- Haga clic con el botón derecho en el espacio de diseño y, a continuación, seleccione Place » Rectangle en el menú contextual.
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de rectángulos. Para colocar un rectángulo, realice la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar la primera esquina del rectángulo.
- Mueva el cursor para ajustar el tamaño del rectángulo y, a continuación, haga clic o pulse Enter para fijar la esquina diagonalmente opuesta y completar la colocación del rectángulo.
- Continúe colocando más rectángulos o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Durante la colocación también puede realizar las siguientes acciones:
- Pulse la tecla Tab para pausar la colocación y acceder al modo Rectángulo del panel Properties , en el que puede cambiar sus propiedades sobre la marcha. Haga clic en el botón de pausa superpuesto en el espacio de diseño para reanudar la colocación.
- Pulse la barra espaciadora para alternar entre los distintos modos de esquina. Seleccione Rectangle para esquinas rectas, Fillet para esquinas redondeadas o Chamfer para esquinas inclinadas o angulares.
- Pulse las teclas + y - (del teclado numérico) para recorrer hacia delante y hacia atrás todas las capas visibles del diseño y cambiar rápidamente la capa de colocación.
- Mantenga pulsada la tecla Alt para restringir la dirección del movimiento al eje horizontal o vertical, según la dirección inicial del movimiento.
El método de edición gráfica permite seleccionar un objeto rectángulo colocado directamente en el espacio de diseño y cambiar su tamaño, forma o ubicación de manera gráfica.
Al seleccionar un objeto rectángulo, estarán disponibles los siguientes controles de edición.
Un rectángulo seleccionado
- Haga clic en las esquinas (A) y arrástrelas para cambiar el tamaño del rectángulo en las direcciones vertical y horizontal simultáneamente.
- Haga clic en los puntos centrales de los lados (B) y arrástrelos para cambiar el tamaño del rectángulo en las direcciones vertical y horizontal por separado.
-
Haga clic en cualquier punto del rectángulo alejado de los controles de edición y arrástrelo para cambiar su posición. Mientras lo arrastra, puede girar el rectángulo o reflejarlo:
- Pulse Spacebar para girar el rectángulo en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. El giro se realiza según el valor de Rotation Step definido en la página Editor de PCB – General del cuadro de diálogo Preferences.
- Pulse las teclas X o Y para reflejar el rectángulo respecto al eje X o al eje Y.
Propiedades del rectángulo

El modo Rectangle del panel Properties.
Ubicación
-
(X/Y)
- X (primer campo): la coordenada X (horizontal) actual del punto de referencia del rectángulo, con respecto al origen actual del espacio de diseño. Edite este campo para cambiar la posición X del rectángulo. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actuales.
- Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia del rectángulo, con respecto al origen actual. Edite este campo para cambiar la posición Y del relleno. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actuales.
- Rotation : el ángulo de giro del rectángulo (en grados), medido en sentido antihorario desde cero (la 3 o'clock horizontal). Edite este campo para cambiar el giro del rectángulo. La resolución angular mínima es de 0,001°.
Propiedades
-
Corner Mode: utilice el menú desplegable para seleccionar el modo de esquina deseado para el rectángulo entre las siguientes opciones:
- Rectangle: especifica que el rectángulo colocado tendrá esquinas rectas.
- Fillet: especifica que el rectángulo colocado tendrá esquinas redondeadas.
- Chamfer: especifica que el rectángulo colocado tendrá esquinas inclinadas o angulares.
- Track Width : muestra el ancho actual de la pista. Edite este campo para cambiar el ancho de la pista dentro del intervalo de 0,001 mil a 10000 mil.
- Fillet/Chamfer Size: solo está disponible cuando se selecciona Fillet o Chamfer en el menú desplegable Corner Mode, o si se ha elegido el modo de redondeo o de chaflán durante la colocación.
- Layer : la capa a la que está asignado actualmente el rectángulo. Los rectángulos se pueden asignar a cualquier capa disponible. Utilice el menú desplegable para seleccionar una capa diferente.
- Width : muestra el ancho (eje X) del Rectángulo seleccionado.
- Height : muestra la altura (eje Y) del Rectángulo seleccionado.
-
- haz clic en este icono para mantener la proporción actual entre X e Y del rectángulo.

