Création de modèles et de bibliothèques de pastilles et de vias
En un coup d'œil
- Découvrez comment créer une bibliothèque à partir de zéro ou à partir des pastilles et des vias d’un circuit imprimé existant.
- Apprenez à ajouter, supprimer et modifier des modèles de pastilles et de vias.
- Explorez les options de configuration des dimensions des trous, des masques, des empilements de pastilles et de vias, ainsi que des freins thermiques.
Avec les objets piste, les pastilles et les vias sont des éléments fondamentaux de toute conception de circuit imprimé. Pour améliorer les possibilités de réutilisation et de gestion des pastilles et des vias dans les conceptions de PCB, Altium Designer prend en charge les bibliothèques de modèles de pastilles et de vias.
Le concept de modèles de pastilles et de vias regroupés dans une bibliothèque est similaire à celui des bibliothèques d’empreintes PCB, bien qu’il soit un peu plus simple. Une bibliothèque de modèles de pastilles et de vias ne stocke pas les pastilles et les vias eux-mêmes, mais des définitions préconfigurées qui sont appliquées à une instance de pastille ou de via lors de son placement. Les bibliothèques de modèles de pastilles et de vias enregistrées peuvent être chargées et utilisées pour placer des instances de pastilles et de vias prédéfinis dans n’importe quelle conception de PCB ou empreinte PCB.
Les bibliothèques de modèles de pastilles et de vias constituent un autre type de document de conception pouvant être créé dans Altium Designer et portent l’extension de fichier *.PvLib. Ces bibliothèques peuvent être incluses en tant que documents de projet ; dans ce cas, leurs modèles sont toujours accessibles au projet via le panneau PCB Pad Via Templates. Les bibliothèques de modèles peuvent également être installées dans le panneau, ce qui les rend accessibles à tous les projets ouverts. Pour en savoir plus sur la mise à disposition des modèles, consultez la page Utilisation des modèles de pastilles et de vias.
Pour créer et modifier des modèles de pastilles et de vias, ouvrez un fichier PvLib. Les modèles de pastilles et de vias du fichier PvLib sont répertoriés dans le panneau Pad Via Library, et le modèle sélectionné s’affiche dans l’éditeur de modèles de pastilles/vias, comme illustré ci-dessous.
|
Les modèles de pastilles et de vias se modifient en ouvrant le fichier PvLib. Les options de l’éditeur s’adaptent au type d’objet en cours de modification. L’éditeur de modèles de pastilles est présenté ici. Les modèles de pastilles et de vias se modifient en ouvrant le fichier PvLib. Les options de l’éditeur s’adaptent au type d’objet en cours de modification. L’éditeur de modèles de vias est présenté ici. |
Création d’une bibliothèque de modèles de pastilles et de vias
Une nouvelle bibliothèque de modèles de pastilles/vias peut être créée des manières suivantes :
-
Sélectionnez la commande File » New » Library dans les menus principaux, puis l’option Pad Via Library dans la zone File de la boîte de dialogue New Library qui s’ouvre, et cliquez sur Create. La nouvelle bibliothèque de modèles de pastilles et de vias reçoit le nom par défaut
PvLib1.PvLib. À ce stade, le fichier n’a pas été enregistré sur le disque dur ; il existe uniquement dans la mémoire de l’ordinateur. Comme il n’est pas encore enregistré, lors du premier enregistrement, la boîte de dialogue Save As s’ouvre et propose de l’enregistrer dans le Default Location défini sur la page Système – Emplacements par défaut de la boîte de dialogue Preferences. -
Vous pouvez également ajouter une nouvelle bibliothèque de modèles de pastilles et de vias au projet actuel en faisant un clic droit sur le projet dans le panneau Projects et en sélectionnant Add New to Project » Pad Via Library dans le menu contextuel. Le fichier apparaît dans le dossier
Libraries/Pad Via Library Documentsde l’arborescence du projet. Lors de l’enregistrement du fichier, l’emplacement proposé par défaut est le dossier du projet. -
Une bibliothèque de modèles de pastilles et de vias peut être créée à partir des pastilles et des vias d’un PCB ouvert, dans le mode Pad & Via Templates du panneau PCB. À l’aide des techniques de sélection standard de Windows, sélectionnez les modèles de pastilles/vias à enregistrer dans la bibliothèque, puis cliquez sur le bouton Save as Library. La nouvelle bibliothèque PvLib s’ouvre, prête à être modifiée, mais elle n’est pas encore enregistrée sur le disque dur. Enregistrez le fichier à un emplacement approprié, en lui attribuant le nom souhaité. Lorsque la bibliothèque de modèles de pastilles et de vias s’ouvre pour la première fois dans l’éditeur de modèles, il se peut qu’un seul modèle de pastille apparaisse dans le panneau Pad Via Library (le modèle par défaut). Dans ce cas, enregistrez le fichier, fermez-le, puis rouvrez-le pour actualiser la liste des modèles dans le panneau Pad Via Library.

Une bibliothèque de modèles de pastilles et de vias peut être créée à partir des pastilles/vias sélectionnés dans le PCB actuel.
Panneau de bibliothèque de pastilles et de vias
Le panneau Pad Via Library permet d’accéder aux modèles contenus dans la bibliothèque de pastilles et de vias active. Le panneau Pad Via Library, disponible dans l’éditeur de modèles de pastilles/vias, répertorie les modèles de pastilles et de vias contenus dans la bibliothèque de modèles actuelle. Les unités à utiliser pour cette session de modification sont sélectionnées dans le menu déroulant Display Units en haut du panneau.
Accès au panneau
Le panneau est accessible depuis l’éditeur de modèles de pastilles/vias (avec un document *.PvLib ouvert comme document actif dans l’espace de conception) des manières suivantes :
- Cliquez sur le bouton Panels dans le coin inférieur droit de l’espace de conception, puis sélectionnez Pad Via Library.
- Cliquez sur View » Panels » Pad Via Library dans les menus principaux.
Création d’un modèle de pastille ou de via
Pour créer un modèle de pastille ou de via, faites un clic droit dans le panneau, puis sélectionnez Add Pad template ou Add Via template dans le menu contextuel. Utilisez Delete pour supprimer un modèle de la bibliothèque.

Le panneau permet d’accéder aux modèles contenus dans la bibliothèque de pastilles et de vias actuelle. Faites un clic droit pour ajouter un nouveau modèle.
Éditeur de modèles de pastilles/vias
L’Pad Template Editor permet de définir les options de configuration de base d’un modèle de pastille ou de via qui pourra ensuite être appliqué à une pastille ou à un via dans un document PCB ou d’empreinte PCB. Ces options comprennent les principales propriétés de configuration d’une pastille ou d’un via, tandis que les propriétés propres au document (position, orientation, couche, etc.) sont définies lors du placement de la pastille ou du via dans un document de conception.

L’éditeur de modèles permet de configurer le modèle de pastille ou de via actuellement sélectionné dans le panneau Pad Via Library.
La plupart des options de configuration des pastilles/vias sont les paramètres de pastilles et de vias standard et familiers d’Altium Designer (dimensions, perçage, masque, etc.). L’éditeur de modèles de pastilles partage la même structure d’interface et de nombreuses options avec l’éditeur de modèles de vias. Chaque zone de l’éditeur de modèles est décrite ci-dessous ; les options propres aux pastilles ou aux vias sont signalées comme telles.
Général
-
Name – par défaut, un nom est généré automatiquement à partir des attributs de la pastille ou du via, conformément à IPC-7251/7351 Padstack naming conventions (décrit ici). Un nom peut être défini manuellement si nécessaire, puis supprimé en cliquant sur le bouton
. Si un modèle nommé manuellement a été utilisé dans une conception de carte et qu’il est ensuite dissocié de la bibliothèque de modèles (de sorte que ses propriétés deviennent modifiables), le nom manuel est remplacé par le nom automatique.
- Description – description facultative.
- Pad Type (pastilles uniquement) – Montage en surface ou traversant.
Informations de perçage
- Hole Size – indiqué par h<Value> dans le nom, diamètre du trou.
- Tolerance – indiqué par Tol dans le nom, saisissez les tolérances + et - du trou, si nécessaire. Saisissez N/A si cela ne s’applique pas.
- Hole Type (pastille uniquement) – Rond, carré ou oblong.
- Length (pastille uniquement) – indiqué par l’ajout de _<Value> à la taille du trou dans le nom ; longueur du trou carré ou oblong.
- Rotation (pastille uniquement) – angle de rotation du trou carré ou oblong.
- Plated (pastille uniquement) – métallisé ou non métallisé (non métallisé indiqué par n dans le nom).
Masque de pâte à braser (pastille uniquement)
- Manual Expansion – cochez la case pour définir une valeur d’expansion manuelle qui remplacera celle de la règle de conception lorsque la pastille sera placée dans une conception de PCB. Cette valeur est indiquée par p<Value> dans le nom du modèle de pastille.
- Expansion – valeur d’agrandissement (valeur positive) ou de réduction (valeur négative) de l’ouverture dans le masque de pâte à braser. Elle peut être définie en valeur absolue (mil/mm) ou en pourcentage de la surface de la pastille. Lorsqu’une valeur absolue est définie, le pourcentage s’affiche à droite du champ, et inversement. Décochez la case Use Paste à gauche du champ pour désactiver l’utilisation du masque de pâte à braser pour le modèle de pastille.
Masque de soudure
- Manual Expansion – indiqué par m<Value> dans le nom, où m<Value> représente la taille totale de l’ouverture dans le masque de soudure. L’élément du nom devient m<Value>mx<Value> si les valeurs d’expansion des faces supérieure et inférieure ne sont pas liées.
- Top/Bottom – valeur d’expansion, mesurée à partir du bord de la pastille ou du via, sauf si l’option Solder mask from the hole edge est activée.
-
– les valeurs des faces supérieure et inférieure sont liées (identiques) ; cliquez pour définir des valeurs différentes pour les deux faces.
- Tented – activez cette option pour fermer l’ouverture dans le masque de soudure (la taille de l’ouverture est définie sur zéro).
- Solder mask from the hole edge – activez cette option pour mesurer la valeur d’expansion à partir du bord du trou plutôt que du bord de la pastille ou du via.
Types et caractéristiques des vias (via uniquement)
- IPC 4761 Via Type – utilisez la liste déroulante pour sélectionner un type de via selon la norme IPC 4761, Design Guide for Protection of Printed Board Via Structures.
-
Grid – s’affiche lorsqu’un type de via autre que
Noneest sélectionné dans la liste déroulante IPC 4761 Via Type. Sélectionnez Side de la carte et saisissez une valeur Material pour les caractéristiques disponibles selon le type de via sélectionné.
Taille et forme
- Offset From Hole Center (X/Y) (pastille uniquement) – indiqué par o<Xvalue>_<Yvalue> dans le nom ; décalage du trou de la pastille par rapport au centre de celle-ci.
-
Mode – type d’empilement de pastille/via ; les options sont
Simple,Top-Middle-BottomouFull Stack(pour les pastilles, cette option n’est disponible que lorsque Pad Type est de type trou traversant). Permet aux pastilles et aux vias d’avoir des propriétés de taille et de forme différentes sur les couches disponibles pour ce mode. L’élément x<Xvalue_Yvalue> est ajouté au nom lorsqu’une taille ou une forme différente est définie pour la couche inférieure. L’élément z<Xvalue_Yvalue> est ajouté au nom lorsqu’une taille ou une forme différente est définie pour les couches internes. -
Attributes on Layer – attributs standard des pastilles et des vias.
-
Shape (pastille uniquement) – indiqué par c<SizeValue> (circulaire) ; s<SizeValue> (carré) ou r<xSizeValue_ySizeValue> (rectangulaire), selon que les dimensions X/Y sont identiques ou différentes ; s<SizeValue>c<Value> (octogonal) ; s<Sizevalue>r<Radius%Value> ou r<xSizeValue_ySizeValue>r<Radius%Value> (rectangle arrondi).
-
X & Y Size (pastille uniquement) – dimensions de la pastille dans le plan X et Y.
-
Corner Radius (pastille uniquement) – valeur absolue du rayon des coins de la pastille. La valeur doit être inférieure ou égale à la moitié du côté le plus court de la pastille. Saisissez une valeur suivie du symbole
%pour définir le rayon en pourcentage de la moitié du côté le plus court de la pastille, où100%arrondit complètement le côté le plus court. Cette option n’est accessible que si Rounded Rectangle est sélectionné pour le paramètre Shape de la pastille. -
Diameter (via uniquement) – diamètre du via (les vias ne peuvent être que circulaires).
-
-
Thermal Relief – paramètres de connexion par frein thermique entre cette pastille et un polygone environnant du même net ; décochez la case From Rule pour modifier et utiliser ces paramètres locaux.
- From Rule – les paramètres locaux ne sont pas appliqués lorsque cette option est activée ; décochez-la pour définir et utiliser les paramètres locaux.
- Connect Style – style de connexion par frein thermique.
- Air Gap – distance entre le bord de la pastille et le polygone environnant.
- Conductors – nombre de conducteurs reliant la pastille au polygone environnant.
- Width – largeur des conducteurs reliant la pastille au polygone environnant.
- Angle – disposition angulaire des conducteurs du frein thermique.
- Layer – couches de cet empilement de pastille/via ; les couches disponibles dépendent du paramètre Mode actuel ; cliquez avec le bouton droit pour ajouter, supprimer ou réinitialiser les couches lorsque Mode est défini sur Empilement complet.


