Utilisation des blocs de réutilisation et des snippets (ancien panneau de réutilisation de conception)

En un coup d'œil

Cet article explique comment Altium Designer vous aide à enregistrer et à réutiliser des sections de circuit courantes grâce aux blocs de réutilisation et aux extraits, pour vous éviter de recréer de toutes pièces les éléments récurrents de vos conceptions. Il présente le contenu de chaque option de réutilisation, explique comment accéder au panneau Design Reuse et l’utiliser, puis détaille la création, la gestion, le renommage et l’organisation des contenus de conception, qu’ils soient stockés dans un espace de travail ou en local. Si vous utilisez régulièrement des sections récurrentes de schéma ou de PCB, ce guide vous montre comment intégrer ces outils à votre flux de travail et commencer à les utiliser efficacement. Poursuivez votre lecture pour accélérer et harmoniser votre processus de conception.

- Découvrez les différences entre les blocs de réutilisation, les extraits de schéma et les extraits de PCB, ainsi que les cas d’utilisation de chacun.
- Apprenez à utiliser le panneau Design Reuse pour trouver, filtrer, trier, rechercher et gérer les contenus de conception réutilisables.
- Suivez les étapes de création, d’enregistrement, de renommage et d’organisation des blocs de réutilisation et des extraits, aussi bien dans un espace de travail qu’en local.
Approfondissez avec l'IA :

L’interface utilisateur de la fonctionnalité de réutilisation de conception décrite sur cette page correspond à la version précédente du panneau Design Reuse, disponible lorsque l’option UI.ModernDesignReusePanel est désactivée dans la boîte de dialogue Advanced Settings. Lorsque cette option est activée, une nouvelle version du panneau, décrite sur les pages Travailler avec les blocs de réutilisation et Travailler avec les extraits, est utilisée. Le nouveau panneau Design Reuse est en bêta ouverte.

Si vos conceptions incluent souvent des « sections » de circuits communes, Altium Designer offre un moyen simple et pratique d’enregistrer et de réutiliser des sections de circuits, qu’elles soient stockées dans un espace de travail ou dans des fichiers locaux. Ces sections peuvent être ajoutées à n’importe quelle conception de PCB sans avoir à repartir de zéro à chaque fois. Cette fonctionnalité est particulièrement utile pour les fragments fréquemment utilisés et les petites sections de circuits que vous souhaitez réutiliser. Le système vous permet d’enregistrer toute sélection de :

  • Circuits sur une seule feuille de schéma (un extrait de schéma).

  • Circuits dans une conception de PCB, y compris les composants et le routage (un extrait de PCB).

Lorsque vous êtes connecté à un espace de travail, vous pouvez créer une entité unique, un bloc de réutilisation, qui peut contenir à la fois les circuits du schéma et leur représentation physique pour le PCB. Lorsqu’un tel bloc de réutilisation est placé sur une feuille de schéma, sa représentation physique est automatiquement placée dans le document PCB au cours du processus ECO.

Le panneau Design Reuse est le centre de commande permettant de créer, de gérer et d’utiliser les blocs de réutilisation et les extraits, qu’ils soient stockés dans un espace de travail ou dans des fichiers locaux.

Le panneau Design Reuse
Le panneau Design Reuse

Vous pouvez accéder au panneau de différentes manières :

  • Cliquez sur le bouton Panels en bas à droite de l’espace de conception, puis sur Design Reuse.
  • Sélectionnez View » Panels » Design Reuse dans les menus principaux.
  • Sélectionnez Place » Reuse Block dans les menus principaux.

Le menu déroulant situé en haut du panneau répertorie tous les dossiers disponibles dans l’espace de travail auquel vous êtes connecté qui contiennent des blocs de réutilisation et des extraits stockés dans l’espace de travail. Le nombre indiqué à côté du nom de chaque dossier correspond au nombre de blocs de réutilisation et d’extraits que contiennent ce dossier et ses sous-dossiers. Sélectionnez un dossier dans la liste déroulante pour afficher les blocs de réutilisation et les extraits qu’il contient, ainsi que ceux de ses sous-dossiers, dans la section principale du panneau. Sélectionnez l’entrée de l’espace de travail auquel vous êtes connecté dans la liste déroulante pour afficher tous les blocs de réutilisation et extraits disponibles.

La structure des dossiers de l’espace de travail peut être définie depuis Altium Designer à l’aide du panneau Explorer.

Utilisez les boutons de filtrage de la fenêtre contextuelle de l’icône  pour afficher ou masquer les contenus de types spécifiques (Reuse Blocks, Schematic Snippets, PCB Snippets) dans le panneau. Utilisez la commande Sort By pour sélectionner l’option de tri souhaitée.

Utilisez les options de filtrage et de tri pour configurer l’affichage du contenu dans le panneau
Utilisez les options de filtrage et de tri pour configurer l’affichage du contenu dans le panneau

Pour rechercher des blocs de réutilisation et des extraits disponibles dans le dossier sélectionné par leur nom ou leur description, saisissez une expression dans le champ Search afin de filtrer la liste et de la restreindre à vos besoins spécifiques.

Chaque bloc de réutilisation et chaque extrait est présenté dans la section principale du panneau sous forme d’une vignette contenant les données suivantes :

  • Image d’aperçu – cliquez dessus pour passer de l’affichage normal à l’affichage en taille réelle. Pour un bloc de réutilisation, utilisez le bouton  Cliquez et faites glisser pour déplacer​ pour basculer entre les aperçus de ses documents PCB et schéma ;

  • Icône de type –  Cliquez et faites glisser pour déplacer​ pour un bloc de réutilisation,  Cliquez et faites glisser pour déplacer​ pour un extrait de schéma,  Cliquez et faites glisser pour déplacer​ pour un extrait de PCB ;

  • Nom et description (si elle est définie) ;

  • Identifiant de la dernière révision, date de création et auteur d’un bloc de réutilisation ou d’un extrait de schéma/PCB stocké dans l’espace de travail.

Les informations et les commandes relatives à un bloc de réutilisation ou à un extrait sont présentées dans une vignette au sein du panneau.
Les informations et les commandes relatives à un bloc de réutilisation ou à un extrait sont présentées dans une vignette au sein du panneau.

Création d’un bloc de réutilisation

Un nouveau bloc de réutilisation peut être créé de différentes manières :

  1. Sélectionnez la commande de création d’un nouveau bloc de réutilisation :

    • Depuis le panneau Design Reuse, en cliquant sur le bouton  en haut du panneau.

    • À l’aide de la commande File » New » Reuse Block du menu principal.

    • Depuis le panneau Explorer, en cliquant sur le bouton  situé en haut à droite du panneau lorsque vous parcourez un dossier de type Design Reuse Blocks.

  2. Une structure temporaire modifiable du bloc de réutilisation, semblable à celle d’un projet PCB, s’ouvre dans le panneau Projects (sous une entrée correspondant à l’espace de travail auquel vous êtes actuellement connecté), et l’éditeur de schéma temporaire s’ouvre dans la fenêtre de conception principale, prêt pour la définition du document schématique du bloc de réutilisation. Utilisez les commandes et les techniques de placement standard pour définir le document schématique du bloc de réutilisation.

  3. Une fois cette opération terminée, utilisez la commande Design » Update PCB Document et le processus ECO pour transférer le schéma saisi vers le document PCB du bloc de réutilisation, puis apportez les modifications nécessaires à ce document (définition de l’emplacement des composants, routage, etc.).

    Plusieurs documents PCB peuvent être ajoutés au bloc de réutilisation en cours de définition. Pour ce faire, utilisez la commande Add New to Project » PCB du menu contextuel de l’entrée du bloc de réutilisation dans le panneau Projects.

    Utilisez la commande Rename du menu contextuel de l’entrée du document PCB ajouté dans le panneau Projects pour lui attribuer un nom significatif. Utilisez une commande Design » Update du menu principal de l’éditeur de schéma pour mettre à jour le document PCB souhaité.

    Lorsque les documents schématique et PCB du bloc de réutilisation sont définis, enregistrez le bloc de réutilisation dans l’espace de travail à l’aide de la commande Save to Server du menu contextuel de son entrée dans le panneau Projects, ou de la commande Save to Server à droite de cette entrée.

    Les blocs de réutilisation étant stockés dans l’espace de travail connecté, ils doivent utiliser des composants issus de cet espace de travail. Vous profitez ainsi pleinement du système de gestion de contenu fourni par l’espace de travail.

    • Les documents schématiques et PCB du bloc réutilisable doivent chacun contenir au moins un composant pour pouvoir être enregistrés dans l'espace de travail.

    • Si les documents schématiques et PCB du bloc réutilisable ne sont pas synchronisés (des différences sont détectées entre les documents schématiques et PCB), une boîte de dialogue d'avertissement s'affiche lorsque vous tentez d'enregistrer le bloc réutilisable dans l'espace de travail. Vous pouvez annuler l'enregistrement pour revenir au bloc réutilisable et corriger les différences, ou poursuivre l'enregistrement.

  4. La boîte de dialogue New Reuse Block s'affiche. Vous pouvez y définir Name, Description et le Folder de l'espace de travail dans lequel le nouveau bloc réutilisable sera enregistré.

    La boîte de dialogue New Reuse Block
    La boîte de dialogue New Reuse Block

  5. Après avoir cliqué sur OK, le bloc réutilisable est enregistré dans l'espace de travail et sa structure temporaire est fermée.

Un bloc réutilisable enregistré est ensuite accessible dans le panneau Design Reuse lorsque le dossier dans lequel il a été enregistré (ou l'entrée correspondant à votre espace de travail connecté) est sélectionné dans la liste déroulante supérieure. Il peut être nécessaire d'utiliser la commande Refresh du menu du bouton pour que le nouveau bloc réutilisable apparaisse dans le panneau.

Renommer un bloc réutilisable

Après sa création, un bloc réutilisable peut être renommé pour lui attribuer un titre plus approprié, si nécessaire. Pour renommer un bloc réutilisable, utilisez la commande Rename , accessible depuis le sous-menu  et le menu contextuel du panneau Design Reuse . Dans la boîte de dialogue Rename Reuse Block qui s'ouvre, saisissez le nouveau titre, puis cliquez sur OK. Le bloc réutilisable porte désormais le nom souhaité, comme illustré dans les images suivantes.

Créer un fragment

Vous pouvez créer rapidement un nouveau fragment schématique ou PCB à partir d'un circuit existant sur une feuille de schéma ou dans un document PCB :

  1. Sélectionnez le circuit souhaité dans l'éditeur de schémas ou de PCB.

  2. Faites un clic droit et choisissez Snippets » Create Snippet from selected objects dans le menu contextuel, ou sélectionnez la commande Tools » Convert » Create Snippet from selected objects dans les menus principaux.

  3. La boîte de dialogue New Schematic Snippet ou New PCB Snippet s'affiche. Vous pouvez y définir le nom, la description, la destination d'enregistrement (un espace de travail ou un dossier local) et le dossier dans lequel le nouveau fragment sera enregistré.

    Lors de l'enregistrement d'un fragment dans un dossier local, cliquez sur le bouton  à droite du champ Path dans la boîte de dialogue pour accéder à la boîte de dialogue Choose Snippet Folder. Celle-ci vous permet de sélectionner un dossier local de fragments existant dans lequel enregistrer le fragment, ou de créer un sous-dossier dans un dossier local de fragments existant.

    Pour plus d'informations sur l'organisation des fragments locaux en dossiers, consultez la section Organisation des fragments locaux ci-dessous.
  4. Après avoir cliqué sur OK, le fragment est enregistré.

Un fragment enregistré est ensuite accessible dans le panneau Design Reuse lorsque l'entrée correspondant à votre espace de travail connecté (ou le dossier dans lequel il a été enregistré) est sélectionnée dans la liste déroulante supérieure.

Un fragment peut être créé à partir d'un ensemble d'objets sélectionnés. La création d'un fragment schématique est illustrée ici. Survolez l'image avec le curseur pour voir la création d'un fragment PCB.
Un fragment peut être créé à partir d'un ensemble d'objets sélectionnés. La création d'un fragment schématique est illustrée ici. Survolez l'image avec le curseur pour voir la création d'un fragment PCB.

Il peut être nécessaire d'utiliser la commande Refresh du menu du bouton  du panneau pour que le nouveau bloc réutilisable apparaisse dans le panneau.

Pour accéder aux fragments locaux depuis le panneau Design Reuse, l'option Local Snippets doit être activée dans le menu .

Vous pouvez également créer un fragment dans l'espace de travail à partir d'un fragment local existant en cliquant sur le bouton  de la vignette du fragment (ou en faisant un clic droit n'importe où sur la vignette), puis en sélectionnant la commande Save to Server dans le menu. Dans la boîte de dialogue New Schematic Snippet ou New PCB Snippet qui s'affiche, définissez Name, Description et le Folder de l'espace de travail dans lequel le fragment sera enregistré.

Un fragment local peut être enregistré dans l'espace de travail connecté à l'aide de la commande Save to Server.
Un fragment local peut être enregistré dans l'espace de travail connecté à l'aide de la commande Save to Server.

Les fragments de l'espace de travail doivent utiliser des composants provenant de cet espace de travail. Vous profitez ainsi pleinement du système de gestion de contenu fourni par l'espace de travail.

Organisation des fragments locaux

Le panneau Design Reuse permet d'organiser les fragments locaux dans des dossiers afin de regrouper les fragments apparentés et de les retrouver plus facilement. Les dossiers de fragments sont des dossiers Windows existants qui ne peuvent pas être créés depuis le panneau Design Reuse. Ils sont simplement « ouverts » ou « fermés » lors de la navigation parmi les fragments locaux qu'ils contiennent. Ces dossiers ne peuvent être créés que directement sur votre disque dur ou sur le réseau, en dehors d'Altium Designer.

Les dossiers de fragments peuvent être ouverts et fermés depuis la boîte de dialogue Available Snippets Folders, accessible en cliquant sur le bouton en haut à droite du panneau Design Reuse, puis en sélectionnant la commande Snippet Folders dans le menu. Cliquez sur Open Folder pour rechercher le dossier souhaité sur votre disque dur ou sur le réseau. Le dossier sélectionné est ajouté à la liste de la boîte de dialogue, puis apparaît dans la liste déroulante en haut du panneau Design Reuse.

Pour retirer un dossier de fragments de la liste (ce qui revient à le fermer pour la navigation), sélectionnez-le dans la liste, puis cliquez sur Remove Folder. Utilisez les boutons Move Up et Move Down pour modifier l'ordre dans lequel les fragments locaux seront présentés dans le panneau Design Reuse lorsque l'entrée Local est sélectionnée dans la liste déroulante du panneau.

Placer des blocs réutilisables et des fragments

Pour placer un bloc réutilisable ou un fragment dans une conception, cliquez dans sa vignette, puis sur le bouton , cliquez sur le bouton de sa vignette, ou faites un clic droit n'importe où sur la vignette et sélectionnez l'une des commandes suivantes :

  • Place – sélectionnez cette commande pour placer le bloc réutilisable ou le fragment directement dans le document schématique ou PCB actif.
  • Place as Sheet Symbol – lorsqu'un document schématique est actif, sélectionnez cette commande pour placer le bloc réutilisable ou le fragment schématique sous forme de symbole de feuille sur la feuille de schéma. Le contenu du bloc réutilisable ou du fragment schématique est placé sur une feuille de schéma enfant créée automatiquement et référencée par le symbole de feuille placé.

Placez un bloc réutilisable ou un extrait à l’aide du menu du bouton Place situé dans sa vignette dans le panneau. L’image montre la sélection de la commande Place, qui place le bloc réutilisable ou l’extrait de schéma sur la feuille de schéma active. Survolez l’image avec le curseur pour voir la sélection de la commande Place as Sheet Symbol, qui place le bloc réutilisable ou l’extrait de schéma sur la feuille enfant référencée par le symbole de feuille placé.
Placez un bloc réutilisable ou un extrait à l’aide du menu du bouton Place situé dans sa vignette dans le panneau. L’image montre la sélection de la commande Place, qui place le bloc réutilisable ou l’extrait de schéma sur la feuille de schéma active. Survolez l’image avec le curseur pour voir la sélection de la commande Place as Sheet Symbol, qui place le bloc réutilisable ou l’extrait de schéma sur la feuille enfant référencée par le symbole de feuille placé.

Cliquez sur la commande Show more dans la vignette du bloc réutilisable pour afficher la section PCB contenant la liste des documents PCB du bloc réutilisable. Sélectionnez le document PCB souhaité dans la liste ; le bloc réutilisable sera placé avec ce document. Le document PCB sélectionné s’affiche dans la zone d’aperçu de la vignette du bloc réutilisable lorsque PCB est sélectionné pour l’aperçu.

Sélectionnez un document PCB à placer avec le bloc réutilisable pour en afficher l’aperçu.
Sélectionnez un document PCB à placer avec le bloc réutilisable pour en afficher l’aperçu.

Après avoir placé le document schématique d’un bloc réutilisable, vous pouvez placer son document PCB dans le document PCB de conception via le processus ECO. Dans l’éditeur de schémas, utilisez la commande Design » Update PCB Document depuis les menus principaux, puis validez et exécutez les modifications à l’aide de la boîte de dialogue Engineering Change Order. Le document PCB sera placé dans le document PCB de conception sous forme d’union et pourra être géré depuis le mode Unions du panneau PCB.

Lorsqu’un composant de schéma ou de PCB sélectionné fait partie d’un bloc réutilisable placé dans la conception, vous pouvez consulter ses propriétés en cliquant sur le lien Reuse Block disponible dans le panneau Properties . Les propriétés du bloc réutilisable parent du composant s’affichent alors dans le panneau. Pour revenir aux propriétés du composant initialement sélectionné, utilisez le lien Component .

Accédez aux propriétés du bloc réutilisable depuis un composant qui en fait partie. Les images ci-dessus montrent l’accès aux propriétés depuis un composant de schéma. Survolez l’image avec le curseur pour voir l’accès depuis un composant de PCB.
Accédez aux propriétés du bloc réutilisable depuis un composant qui en fait partie. Les images ci-dessus montrent l’accès aux propriétés depuis un composant de schéma. Survolez l’image avec le curseur pour voir l’accès depuis un composant de PCB.

Pour un bloc réutilisable, son document schématique ou PCB sera utilisé lors de l’exécution de la commande de placement, selon le type de document actif à ce moment-là.

Pour un extrait, assurez-vous que le document cible approprié est ouvert et actif avant de le placer. La commande de placement ne sera disponible que si l’extrait peut être placé correctement dans ce document, c’est-à-dire si le type de l’extrait et celui du document sont identiques.

Modification des blocs réutilisables et des extraits

Pour modifier un bloc réutilisable ou un extrait stocké dans un Workspace, cliquez sur le bouton dans sa vignette (ou faites un clic droit n’importe où sur la vignette), puis sélectionnez la commande Edit dans le menu.

Ouvrez un bloc réutilisable ou un extrait stocké dans un Workspace pour le modifier à l’aide de la commande Edit disponible dans sa vignette dans le panneau.
Ouvrez un bloc réutilisable ou un extrait stocké dans un Workspace pour le modifier à l’aide de la commande Edit disponible dans sa vignette dans le panneau.

L’éditeur temporaire s’ouvre avec le document contenant le bloc réutilisable ou l’extrait source, issu de la dernière révision de l’élément du Workspace, prêt à être modifié. Effectuez les modifications nécessaires, puis enregistrez le document dans la révision suivante du bloc réutilisable ou de l’extrait à l’aide de la commande File » Save to Server du menu principal ou de la commande Save to Server du menu contextuel de l’entrée du bloc réutilisable ou de l’extrait dans le panneau Projects.

Les propriétés (nom, description et chemin) d’un extrait local peuvent être modifiées dans la boîte de dialogue Snippet Properties accessible en cliquant sur le bouton  dans la vignette de l’extrait local (ou en faisant un clic droit n’importe où sur la vignette), puis en sélectionnant la commande Edit Properties dans le menu.

Modifiez les propriétés d’un extrait local à l’aide de la boîte de dialogue Snippet Properties accessible depuis le panneau Design Reuse.
Modifiez les propriétés d’un extrait local à l’aide de la boîte de dialogue Snippet Properties accessible depuis le panneau Design Reuse.

Suppression des blocs réutilisables et des extraits

Pour supprimer un bloc réutilisable ou un extrait, cliquez sur le bouton  dans la vignette de l’extrait (ou faites un clic droit n’importe où sur la vignette), puis sélectionnez la commande Delete dans le menu.

  • Pour un bloc réutilisable ou un extrait stocké dans un Workspace, la boîte de dialogue Delete Items s’affiche pour vous permettre de confirmer la suppression. Il s’agit en fait d’une « suppression réversible » : le bloc réutilisable ou l’extrait sera déplacé vers la zone Trash du Workspace. La zone Trash est essentiellement une corbeille dans laquelle tout contenu de votre Workspace peut être déplacé par une suppression réversible. Elle est isolée du reste du Workspace. Pour un bloc réutilisable, vous pouvez également choisir de supprimer le contenu associé (par exemple, les extraits de schéma et de PCB).

    Effectuez une suppression réversible d’un bloc réutilisable ou d’un extrait à l’aide de la commande Delete disponible dans sa vignette dans le panneau.
    Effectuez une suppression réversible d’un bloc réutilisable ou d’un extrait à l’aide de la commande Delete disponible dans sa vignette dans le panneau.

  • Pour un extrait local, la boîte de dialogue Confirm s’affiche pour confirmer la suppression. Cette action supprime les fichiers de l’extrait de votre disque dur.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents