Travailler avec les blocs de réutilisation

En un coup d'œil

Cet article explique comment utiliser le panneau Design Reuse d’Altium Designer pour créer, gérer, rechercher, placer, modifier et organiser des blocs de réutilisation formels stockés dans un Workspace connecté. Il décrit comment ces blocs peuvent inclure à la fois des données de schéma et de PCB, et comment les éléments PCB sont transférés vers une carte au moyen du processus ECO. Il présente également les principales actions du panneau, telles que la navigation dans les ressources du Workspace, la consultation des détails, la sélection des options de placement, l’enregistrement des révisions et les opérations de gestion comme le renommage, le déplacement, le partage, le téléchargement et la suppression. Si vous recherchez une méthode plus claire et plus efficace pour réutiliser des sections de conception éprouvées dans différents projets, poursuivez votre lecture : cet article vous montrera par où commencer et comment utiliser les outils disponibles en toute confiance.

- Découvrez comment créer des blocs de réutilisation formels, les enregistrer dans un Workspace et les réutiliser dans des conceptions de schémas et de PCB à l’aide du panneau Design Reuse.
- Apprenez à rechercher, examiner et placer des blocs de réutilisation, notamment grâce aux options de placement direct, de placement sous forme de symbole de feuille et de gestion de plusieurs documents PCB.
- Comprenez les principales opérations de gestion disponibles pour les blocs de réutilisation, notamment la modification, la mise à jour des révisions, le partage, le déplacement, le téléchargement et la suppression réversible.
Approfondissez avec l'IA :

Le panneau Design Reuse utilisé pour gérer les blocs réutilisables et décrit sur cette page est en bêta ouverte et disponible lorsque l’option UI.ModernDesignReusePanel est activée dans la boîte de dialogue Advanced Settings. Lorsque cette option est désactivée, la version précédente du panneau, décrite sur la page Utilisation des blocs réutilisables et des extraits, est utilisée.

Si vos conceptions comprennent souvent des « sections » communes de circuits schématiques et de circuits imprimés, Altium Designer propose des moyens simples et pratiques d’enregistrer et de réutiliser ces sections, ce qui évite de devoir les recréer à chaque fois.

Lorsque vous êtes connecté à un espace de travail, vous pouvez créer un reuse block pouvant contenir à la fois un circuit schématique et sa représentation physique pour le circuit imprimé. Lorsqu’un tel bloc réutilisable est placé sur une feuille de schéma, sa représentation physique est automatiquement placée dans le document PCB au cours du processus ECO.

Le panneau Design Reuse vous permet d’accéder rapidement à toutes les commandes nécessaires pour utiliser et gérer vos blocs réutilisables.

  • Le panneau permet également d’accéder à vos feuilles de schéma gérées et à vos extraits.

  • Outre les méthodes standard d’accès à un panneau (le menu du bouton  et le sous-menu View » Panels des menus principaux), vous pouvez accéder au panneau Design Reuse en sélectionnant la commande Place » Reuse Block dans les menus principaux de l’éditeur de schémas ou de circuits imprimés.

Pour utiliser les blocs réutilisables via le panneau Design Reuse, assurez-vous que le panneau est configuré pour parcourir les ressources de l’espace de travail. Pour ce faire, cliquez sur l’icône située tout à gauche de la barre d’adresse en haut du panneau, puis sélectionnez l’entrée de l’espace de travail auquel vous êtes connecté. L’icône s’affiche alors sous la forme .

Création d’un bloc réutilisable

Vous pouvez créer un bloc réutilisable comme décrit ci-dessous.

  1. Cliquez sur le bouton  en haut à droite du panneau Design Reuse. Vous pouvez également sélectionner la commande File » New » Reuse Block dans les menus principaux.

  2. Une structure temporaire et modifiable du bloc réutilisable, semblable à celle d’un projet PCB, s’ouvre dans le panneau Projects (sous une entrée correspondant à l’espace de travail connecté), et l’éditeur de schémas temporaire s’ouvre, prêt à définir le document schématique du bloc réutilisable. Utilisez les commandes et techniques de placement standard pour définir le document schématique du bloc réutilisable.

    Si vous souhaitez créer un bloc réutilisable contenant uniquement un schéma ou uniquement un circuit imprimé, vous pouvez supprimer le document PCB ou le document schématique de la structure de l’extrait en cliquant avec le bouton droit sur le document correspondant dans le panneau Projects, puis en sélectionnant la commande Remove from Project.

  3. Utilisez la commande Design » Update PCB Document et le processus ECO pour transférer le schéma saisi vers le document PCB du bloc réutilisable, puis apportez les modifications nécessaires à ce document (définition de l’emplacement des composants, routage, etc.).

    Vous pouvez ajouter plusieurs documents PCB au bloc réutilisable en cours de définition. Pour ce faire, utilisez la commande Add New to Project » PCB du menu contextuel de l’entrée du bloc réutilisable dans le panneau Projects.

    Utilisez la commande Rename du menu contextuel de l’entrée du document PCB ajouté dans le panneau Projects pour lui attribuer un nom explicite. Utilisez une commande Design » Update du menu principal de l’éditeur de schémas pour mettre à jour le document PCB souhaité.

  4. Une fois les documents schématique et PCB du bloc réutilisable définis, enregistrez le bloc réutilisable dans l’espace de travail à l’aide de la commande Save to Server du menu contextuel de l’entrée du bloc réutilisable dans le panneau Projects, ou de la commande Save to Server située à droite de l’entrée.

    Les blocs réutilisables étant stockés dans l’espace de travail connecté, il est recommandé d’y utiliser des composants provenant de cet espace de travail. Ainsi, vous profitez pleinement du système de gestion de contenu fourni par l’espace de travail.

    • Les documents schématique et PCB du bloc réutilisable doivent chacun contenir au moins un composant pour pouvoir être enregistrés dans l’espace de travail.

    • Si les documents schématique et PCB du bloc réutilisable ne sont pas synchronisés (des différences sont détectées entre les deux documents), une boîte de dialogue d’avertissement s’affiche lorsque vous tentez d’enregistrer le bloc réutilisable dans l’espace de travail. Vous pouvez annuler l’enregistrement pour revenir au bloc réutilisable et corriger les différences, ou poursuivre l’enregistrement.

  5. La boîte de dialogue Create New Reuse Block s’affiche. Vous pouvez y définir Name, Description, ainsi que le Folder de l’espace de travail dans lequel le nouveau bloc réutilisable sera enregistré.

  6. Après avoir cliqué sur OK dans la boîte de dialogue Create New Reuse Block, le bloc réutilisable est enregistré dans l’espace de travail et sa structure temporaire est fermée.

Recherche et placement d’un bloc réutilisable

Vous pouvez parcourir et utiliser les blocs réutilisables stockés dans l’espace de travail connecté depuis le panneau Design Reuse lorsqu’il est configuré pour afficher les ressources de l’espace de travail (). Dans ce mode, le panneau présente l’arborescence des dossiers de votre espace de travail afin que vous puissiez parcourir les dossiers contenant vos blocs réutilisables. Chaque dossier et chaque bloc réutilisable sont présentés dans la liste en haut du panneau avec leur nom et leur description.

Pour trouver le bloc réutilisable souhaité, vous pouvez parcourir les dossiers ou utiliser le champ Search en haut du panneau Design Reuse pour rechercher un bloc réutilisable par son nom ou sa description ().

  • Seule la dernière révision de chaque bloc réutilisable est présentée dans le panneau Design Reuse.

  • Si la dernière révision d’un bloc réutilisable se trouve dans un état de cycle de vie pour lequel l’option Visible in Vault panels est désactivée (en savoir plus), ce bloc réutilisable n’est pas affiché par défaut dans le panneau. Pour afficher les blocs réutilisables actuellement masqués, cliquez sur le bouton  en haut à droite du panneau, puis activez l’option Show Hidden Revisions dans le menu associé.

Cliquez sur la commande Details en bas du panneau pour développer le volet Details, qui affiche les détails du bloc réutilisable sélectionné, notamment :

  • Le nom du bloc réutilisable.

  • L’icône d’état du cycle de vie et la révision (cliquez sur le lien pour ouvrir la vue détaillée de l’historique de l’élément de bloc réutilisable, avec la dernière révision sélectionnée).

  • La description du bloc réutilisable.

  • Les informations générales du bloc réutilisable et ses paramètres.

  • Des images d’aperçu des documents schématique et PCB du bloc réutilisable.

  • La liste des projets () et des versions publiées de projets () dans lesquels le bloc réutilisable est utilisé (la zone Where Used).

En utilisant un accès contrôlé au contenu de l’espace de travail, conjointement avec un schéma de cycle de vie adapté, le personnel autorisé (gestionnaires de bibliothèques, responsables de la conception) peut approuver et mettre à disposition uniquement les blocs réutilisables destinés à être utilisés dans les conceptions. Le concepteur peut ainsi travailler en toute confiance, sachant qu’il utilise uniquement des blocs réutilisables autorisés.

Pour placer un bloc réutilisable dans une conception, survolez son entrée dans le panneau Design Reuse, cliquez sur le bouton  (ou faites un clic droit sur l’entrée), puis sélectionnez l’une des commandes suivantes dans le menu :

  • Place – sélectionnez cette commande pour placer le bloc réutilisable directement dans le document schématique ou PCB actif. Selon le type de document actif lors de l’exécution de la commande, le document schématique ou PCB du bloc réutilisable sera placé.

     
  • Place as Sheet Symbol – lorsqu’un document schématique est actif, sélectionnez cette commande pour placer le bloc réutilisable sous forme de symbole de feuille sur la feuille de schéma. Le symbole de feuille placé comprendra des entrées de feuille correspondant aux ports du bloc réutilisable. Le contenu du bloc réutilisable sera placé sur une feuille de schéma enfant créée automatiquement et référencée par le symbole de feuille. Le symbole de feuille d’un bloc réutilisable placé comporte une icône distinctive.

Si le bloc réutilisable comprend plusieurs documents PCB, sélectionnez le document PCB souhaité en cliquant sur son onglet sous l’image d’aperçu du document PCB dans la zone Preview du volet Details avant de placer le bloc réutilisable (). Lorsque le bloc réutilisable est placé dans le schéma, le document PCB sélectionné lui est associé et sera placé dans le PCB lors de sa mise à jour via le processus ECO.

Après avoir placé le document schématique d’un bloc réutilisable, son document PCB peut être placé dans le document PCB via le processus ECO. Dans l’éditeur de schémas, utilisez la commande Design » Update PCB Document des menus principaux, puis validez et exécutez les modifications à l’aide de la boîte de dialogue Engineering Change Order.

Modification d’un bloc réutilisable

Pour modifier un bloc réutilisable, survolez son entrée dans le panneau Design Reuse et cliquez sur le bouton  (ou faites un clic droit sur l’entrée), puis sélectionnez la commande Edit dans le menu.

La structure de projet temporaire du bloc réutilisable, contenant la dernière révision de l’élément de bloc réutilisable, s’ouvre pour modification. Effectuez les modifications nécessaires, puis enregistrez le bloc réutilisable dans sa révision suivante (File » Save to Server).

Autres actions sur les blocs réutilisables

Le menu du bouton  (ainsi que le menu contextuel) d’une entrée de bloc réutilisable dans le panneau Design Reuse donne également accès aux commandes suivantes :

  • Rename – permet de modifier le nom du bloc réutilisable. Après avoir sélectionné la commande, saisissez le nouveau nom souhaité dans la boîte de dialogue Rename Reuse Block qui s’affiche, puis cliquez sur OK.

  • Move – permet de modifier l’emplacement de l’élément de bloc réutilisable dans l’arborescence des dossiers de l’espace de travail. L’exécution de cette commande ouvre la boîte de dialogue Move Item, dans laquelle vous pouvez sélectionner le dossier de destination où placer l’élément.

  • Share – permet de définir les autorisations de partage du bloc réutilisable. Après avoir sélectionné la commande, la boîte de dialogue Share For Item s’ouvre pour vous permettre de configurer le partage selon vos besoins. En savoir plus sur le partage au niveau des éléments.

  • Operations – permet d’accéder à un menu déroulant proposant des fonctions supplémentaires pour les blocs réutilisables, décrites ci-dessous.

    • Make a Copy – permet de copier le bloc réutilisable. Une structure de projet temporaire du bloc réutilisable s’ouvre, avec le même contenu que le bloc réutilisable d’origine. Effectuez les modifications nécessaires et enregistrez le bloc réutilisable dans l’espace de travail. 

    • Change Revision State – permet de modifier l’état de révision de la dernière révision du bloc réutilisable. Après avoir sélectionné la commande, la boîte de dialogue de modification d’état par lot s’ouvre pour vous permettre de modifier l’état de révision du bloc réutilisable.

    • Download – permet de télécharger les données stockées dans le bloc réutilisable (ses documents schématiques et/ou PCB). Les données associées sont téléchargées dans un sous-dossier du répertoire choisi, nommé d’après l’identifiant de révision de l’élément de bloc réutilisable. Les fichiers se trouvent dans le ou les dossiers Released qu’il contient.

  • Delete – permet de supprimer le bloc réutilisable de l’espace de travail auquel vous êtes connecté. Après avoir sélectionné la commande, la boîte de dialogue Delete Items s’affiche pour vous permettre de confirmer la suppression. Vous pouvez également choisir de supprimer le contenu associé au bloc réutilisable (c’est-à-dire les fragments de schéma et de PCB).

    Il s’agit en réalité d’une « suppression réversible » : le bloc réutilisable est déplacé vers la zone Trash de l’espace de travail. En savoir plus sur la suppression réversible.

  • History – permet d’accéder à une vue détaillée du bloc réutilisable, qui s’ouvre dans un nouvel onglet d’Altium Designer.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents