Lavorare con le direttive in uno schema elettrico
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
A colpo d'occhio
- Scopri cosa sono le direttive di progettazione e come vengono utilizzate nella creazione e nella validazione degli schemi.
- Comprendi quando utilizzare No ERC e quando una maschera di compilazione per sopprimere i messaggi di validazione indesiderati.
- Scopri come posizionare, abilitare, disabilitare e modificare le maschere di compilazione nell’editor degli schemi.
Le direttive di progettazione sono oggetti posizionati sullo schema durante l'acquisizione del progetto e consentono di specificare istruzioni da trasmettere ad altre parti del software. Sono disponibili diverse direttive di progettazione, utilizzabili nei due modi seguenti:
- Direttive associate alla compilazione automatica dei documenti schematici sorgente.
- Direttive utilizzate per trasferire al PCB le informazioni definite su un foglio schematico.
Le sezioni seguenti esaminano più da vicino questi ambiti e le direttive associate.
Direttive relative alla compilazione
I progetti evolvono nel tempo e vengono acquisiti per fasi. Man mano che ciascuna fase viene consolidata, è comune volerla verificare separatamente dal resto del progetto. La compilazione di un singolo documento schematico (o dell'intero progetto) in momenti intermedi del processo di acquisizione genera spesso una serie di messaggi di errore dovuti a circuiti non ancora acquisiti o a collegamenti di interfaccia tra porzioni di circuito ancora incomplete. Questi messaggi non hanno alcuna utilità reale, poiché creano soltanto rumore attorno alle informazioni effettivamente rilevanti. Il modo più rapido e semplice per sopprimere questi errori di compilazione consiste nel posizionare direttive No ERC o Compile Mask.
Direttiva No ERC
La direttiva No ERC viene posizionata su un nodo del circuito per sopprimere tutti gli avvisi e/o gli errori di violazione del controllo delle regole elettriche rilevati durante la validazione del progetto schematico. Per saperne di più, consulta la pagina Validazione del progetto.
Direttiva Compile Mask
Le direttive No ERC sono ideali per sopprimere le violazioni relative a un numero limitato di pin, porte, ingressi di foglio o reti all'interno di un progetto. In alcuni casi, tuttavia, può essere opportuno escludere un'intera sezione del progetto, inclusi i componenti. Utilizza una direttiva Compile Mask (comando Place » Directives » Compile Mask) oppure fai clic sul pulsante Compile Mask nel menu a discesa delle direttive sulla Active Bar per nascondere al compilatore l'area del progetto contenuta nella maschera. In questo modo puoi impedire manualmente il controllo degli errori per circuiti che potrebbero non essere ancora completi e che sai genereranno errori di compilazione. Questa funzione può risultare molto utile quando devi compilare il documento attivo o il progetto per verificare l'integrità della progettazione in altre aree specifiche, ma non vuoi il «rumore» dei messaggi generati dal compilatore per le parti non ancora completate.
Come suggerisce il nome, questa direttiva indica al compilatore di ignorare tutti gli oggetti che rientrano completely nei limiti della maschera definita. Posiziona la maschera esattamente come faresti con una nota o un oggetto rettangolare.
Considera il circuito schematico di esempio nell'immagine seguente, in cui i collegamenti al dispositivo LCD1 non sono ancora completi. La compilazione del solo schema (Project » Validate PCB Project) produrrà numerosi messaggi di violazione (mostrati di seguito), ciascuno dei quali è causato dal circuito incompleto. Passa il puntatore sull'immagine per vedere l'effetto del posizionamento di una direttiva Compile Mask attorno al circuito incompleto. Queste violazioni verranno ignorate dal compilatore, mentre il resto del circuito nello schema, i cui collegamenti sono completi, verrà verificato. Nota che gli oggetti effettivamente mascherati, ovvero quelli che rientrano completamente nel rettangolo di delimitazione della maschera, appariranno in grigio.

Passa il puntatore sull'immagine per mostrare l'effetto dell'utilizzo di una direttiva Compile Mask per nascondere le violazioni rilevate dal compilatore a causa di circuiti incompleti.
Maschera di compilazione
Una Compile Mask posizionata, mostrata sul lato sinistro dello schema sopra.
Riepilogo
Una Compile Mask è una direttiva di progettazione utilizzata per nascondere al compilatore l'area del progetto che contiene durante la validazione eseguita con il comando Project » Validate Project . Consente di impedire manualmente il controllo degli errori per circuiti che potrebbero non essere ancora completi e che genereranno errori di validazione. La Compile Mask è utile quando occorre validare il progetto corrente per verificare l'integrità della progettazione in altre aree specifiche, ma si vuole evitare la confusione causata dai messaggi generati dal compilatore per le parti non ancora completate.
Disponibilità
Le Compile Mask possono essere posizionate solo nell'editor schematico. Per posizionare una Compile Mask:
- Fai clic sul comando Place » Directives » Compile Mask nei menu principali.
- Fai clic sul pulsante Compile Mask nel menu a discesa delle direttive sulla Active Bar situata nella parte superiore dell'area di progettazione. Tieni premuto un pulsante Active Bar per accedere ad altri comandi correlati. Una volta utilizzato, un comando diventerà la prima voce in quella sezione della Active Bar.
- Fai clic con il pulsante destro del mouse nell'editor schematico, quindi fai clic su Place » Directives » Compile Mask.
Posizionamento
Dopo l'avvio del comando, il cursore assume la forma di un mirino, indicando la modalità di posizionamento della Compile Mask. Per posizionarla, esegui la seguente sequenza di azioni:
- Posiziona il cursore, quindi fai clic o premi Enter per fissare il primo angolo della maschera.
- Sposta il cursore per regolare le dimensioni della maschera in modo che racchiuda completamente l'area del progetto da nascondere al compilatore, quindi fai clic o premi Enter per fissare l'angolo diagonalmente opposto e completare il posizionamento della maschera. Gli oggetti di progettazione che rientrano completamente nei limiti della maschera appariranno in grigio.
- Continua a posizionare altre maschere di compilazione oppure fai clic con il pulsante destro del mouse o premi Esc per uscire dalla modalità di posizionamento.
Modifica grafica
Questo metodo di modifica consente di selezionare una maschera di compilazione posizionata direttamente nell'area di progettazione e di modificarne graficamente le dimensioni, la forma o la posizione.
Una maschera di compilazione può essere visualizzata in modalità attiva (riquadro completo) o compressa (triangolo in un riquadro), che corrispondono rispettivamente alla maschera abilitata e disabilitata. Per alternare la modalità di visualizzazione, fai clic sull'icona ▲ o ▼ nell'angolo superiore sinistro di una maschera di compilazione posizionata.
Fai clic sul triangolo nell'angolo superiore sinistro per comprimere (e disabilitare) una maschera di compilazione.
Quando viene selezionata una maschera di compilazione attiva (espansa), sono disponibili le seguenti maniglie di modifica:
Una Compile Mask selezionata (quando è attiva).
- Fai clic e trascina A per ridimensionare la maschera di compilazione contemporaneamente in direzione verticale e orizzontale.
- Fai clic e trascina B per ridimensionare la maschera di compilazione separatamente in direzione verticale e orizzontale.
- Fai clic in un punto qualsiasi della maschera di compilazione, lontano dalle maniglie di modifica, e trascina per riposizionarla. Durante il trascinamento, la maschera di compilazione può essere ruotata (Spacebar/Shift+Spacebar) o specchiata (tasti X o Y per specchiarla rispettivamente lungo l'asse X o Y).
Modifica non grafica
Sono disponibili i seguenti metodi di modifica non grafica.
Modifica tramite la finestra di dialogo Maschera di compilazione o il pannello Proprietà
Panel page: Proprietà della maschera di compilazione
Questo metodo di modifica utilizza la finestra di dialogo Compile Mask associata e la modalità del pannello Properties per modificare le proprietà di un oggetto maschera di compilazione.
Dopo il posizionamento, è possibile accedere alla finestra di dialogo Compile Mask nei seguenti modi:
- Facendo doppio clic sull'oggetto maschera di compilazione posizionato.
- Selezionando l'oggetto maschera di compilazione, facendo clic con il pulsante destro del mouse e scegliendo Properties dal menu contestuale.
Durante il posizionamento, è possibile accedere alla modalità Maschera di compilazione del pannello Properties premendo il tasto Tab. Una volta posizionata la maschera di compilazione, vengono visualizzate tutte le opzioni.
Dopo il posizionamento, è possibile accedere alla modalità Maschera di compilazione del pannello Properties in uno dei seguenti modi:
- Se il pannello Properties è già attivo, selezionando l'oggetto maschera di compilazione.
- Dopo aver selezionato l'oggetto maschera di compilazione, selezionando il pannello Properties dal pulsante Panels nella sezione in basso a destra dell'area di progettazione oppure selezionando View » Panels » Properties dal menu principale.
Modifica di più oggetti
Il pannello Properties supporta la modifica di più oggetti, consentendo di modificare le impostazioni delle proprietà identiche in tutti gli oggetti attualmente selezionati. Quando si selezionano più oggetti dello stesso tipo manualmente, tramite la finestra di dialogo Trova oggetti simili oppure tramite un pannello Filtro o Elenco, è possibile modificare per tutti gli oggetti selezionati un campo del pannello Properties il cui valore non è visualizzato come asterisco (*).
Modifica tramite un pannello Elenco
Panel pages: Pannelli Elenco, Filtro SCH
Un pannello List visualizza i tipi di oggetti di progettazione di uno o più documenti in formato tabellare, consentendo di esaminare e modificare rapidamente gli attributi degli oggetti. Utilizzato insieme a un filtro appropriato, selezionando i tipi di oggetti (tramite le opzioni Include del pannello) oppure utilizzando il pannello Filter pertinente o la finestra di dialogo Trova oggetti simili, consente di visualizzare solo gli oggetti che rientrano nell'ambito del filtro attivo. Le proprietà degli oggetti elencati possono quindi essere modificate direttamente nel pannello List.
Proprietà della maschera di compilazione
Le proprietà degli oggetti dell'editor schematico sono opzioni configurabili che specificano lo stile visivo, il contenuto e il comportamento dell'oggetto posizionato. Le impostazioni delle proprietà per ciascun tipo di oggetto sono definite nel modo seguente:
- Post-placement settings – tutte le proprietà dell'oggetto Maschera di compilazione possono essere modificate nella finestra di dialogo Compile Mask e nel pannello Properties quando una maschera di compilazione posizionata è selezionata nell'area di progettazione.
Posizione
-
(X/Y)
- X (primo campo) - la coordinata X (orizzontale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente dell'area di progettazione. Modifica il valore per cambiare la posizione X dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore con unità diverse da quelle predefinite correnti.
- Y (secondo campo) - la coordinata Y (verticale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente. Modifica il valore per cambiare la posizione Y dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore con unità diverse da quelle predefinite correnti.
Proprietà
- Width - inserisci la larghezza dell'oggetto.
- Height - inserisci l'altezza dell'oggetto.
- Border - usa il menu a discesa per selezionare il bordo desiderato.
- Fill Color - fai clic sul riquadro del colore per selezionare il colore desiderato per l'oggetto.
- Collapsed and Disabled - seleziona la casella per comprimere e disabilitare l'oggetto.
Direttive relative al PCB
In quanto ambiente di progettazione unificato, Altium Designer consente di definire i requisiti del PCB prima di procedere al layout della scheda. Ciò avviene aggiungendo e specificando parametri per gli oggetti posizionati sui fogli schematici.
Per alcuni oggetti dello schema, come componenti, simboli di foglio, porte e così via, questo comporta l'aggiunta dei parametri pertinenti alle proprietà dell'oggetto. Per gli oggetti net, come fili e bus, i parametri non possono essere aggiunti direttamente come proprietà del filo o del bus. I parametri necessari per contenere le informazioni vengono invece specificati mediante direttive di progettazione dedicate.
Le seguenti informazioni possono essere specificate tramite direttive e vengono trasferite alle corrispondenti definizioni del PCB durante la sincronizzazione del progetto:
- Vincoli di layout del PCB
- Coppie differenziali
- Classi di net
Includendo direttive di progettazione nello schema elettrico, i progettisti possono specificare vincoli di progettazione espliciti e garantire che lo schema elettrico rimanga il riferimento principale del progetto. Qualsiasi modifica al progetto viene apportata esclusivamente nello schema elettrico e poi trasferita al PCB. Questo può diventare particolarmente importante quando più persone lavorano al progetto, soprattutto se si trovano in sedi geograficamente distanti. Anziché tentare di comunicare tramite lunghe catene di e-mail o telefonate, chi realizza lo schema può assicurarsi che determinati vincoli vengano effettivamente utilizzati durante la fase di layout.
Alla base di questa funzionalità vi è la direttiva Parameter Set.
Si tratta essenzialmente di oggetti Parameter Set definiti dall'utente, che possono essere associati a un oggetto net all'interno di uno schema elettrico. Posiziona una direttiva PCB Layout su un filo, un bus o un cablaggio di segnali per definire uno o più vincoli di progettazione destinati alle net associate. Quando si crea un PCB a partire dallo schema elettrico, le informazioni contenute nella direttiva PCB Layout vengono utilizzate per creare le relative regole di progettazione del PCB. Le informazioni specificate da una direttiva PCB Layout si applicano solo alla net (o all'insieme di net) a cui la direttiva è collegata.
Questa funge da contenitore per un numero qualsiasi di parametri destinati alla net a cui è collegata la direttiva Parameter Set. È possibile posizionare una direttiva Parameter Set predefinita priva di parametri (Place » Directives » Parameter Set) e aggiungere i parametri pertinenti in un secondo momento. Le sezioni seguenti illustrano più in dettaglio l'uso di queste direttive basate sui parametri. Sono disponibili sia direttive di insiemi di parametri definite dall'utente (Parameter Set) sia preconfigurate (Differential Pair). L'unica differenza tra un insieme di parametri vuoto e uno preconfigurato è che quest'ultimo include un parametro, come descritto di seguito.
Insieme di parametri
Panoramica
Un insieme di parametri è una direttiva di progettazione che consente di associare specifiche di progettazione a un oggetto di tipo net all'interno di uno schema elettrico. Ad esempio, puoi utilizzare un insieme di parametri per dichiarare che due net fanno parte di una coppia differenziale. Il software determina quale direttiva di progettazione stai posizionando in base alla presenza, nell'insieme, di parametri con nomi specifici.
Disponibilità
Gli insiemi di parametri possono essere posizionati solo nell'editor degli schemi elettrici. Sono disponibili sia direttive di insiemi di parametri predefinite (vuote) sia preconfigurate (Differential Pair). L'unica differenza tra un insieme di parametri vuoto e uno preconfigurato è che quest'ultimo include un parametro, come descritto di seguito.
Accedi ai comandi corrispondenti dal menu principale Place come segue:
| • | Place » Directives » Parameter Set | |
| • | Place » Directives » Differential Pair | |
Posizionamento
Un insieme di parametri può essere utilizzato per associare parametri a:
- Un filo
- Un bus
- Un cablaggio di segnali
- Un simbolo di foglio
Dopo aver avviato il comando, il cursore assumerà la forma di un mirino e si attiverà la modalità di posizionamento delle direttive di progettazione. Per effettuare il posizionamento, procedi come segue:
- Posiziona il cursore su un filo o su un altro oggetto net e fai clic oppure premi Enter per posizionare la direttiva.
- Continua a posizionare altre direttive oppure fai clic con il pulsante destro del mouse o premi Esc per uscire dalla modalità di posizionamento.
Durante il posizionamento, mentre l'insieme di parametri è ancora agganciato al cursore, puoi eseguire anche le seguenti azioni:
-
Premi il tasto Tab per sospendere il posizionamento e accedere alla modalità Parameter Set del pannello Properties, da cui puoi modificarne le proprietà al volo. Fai clic sul pulsante di pausa sovrapposto all'area di progettazione per riprendere il posizionamento.
-
Premi il tasto Alt per vincolare la direzione del movimento all'asse orizzontale o verticale, a seconda della direzione iniziale del movimento.
-
Premi Spacebar per ruotare l'arco in senso antiorario o Shift+Spacebar per ruotarlo in senso orario. L'operazione può essere eseguita anche durante il trascinamento dell'oggetto. La rotazione avviene a incrementi di 90°.
-
Premi i tasti X o Y in modalità di posizionamento per ribaltare l'insieme di parametri lungo l'asse X o Y.
Modifica grafica
Questo metodo di modifica consente di selezionare una direttiva Parameter Set già posizionata direttamente nell'area di progettazione e di modificarne graficamente la posizione o l'orientamento.
Quando si seleziona una direttiva Parameter Set nell'area di progettazione, attorno alla direttiva compare un riquadro tratteggiato. Il riquadro racchiude solo l'area occupata dalla direttiva. Per ciascun parametro dell'insieme con visibilità abilitata, sarà visibile una linea tratteggiata che collega il campo di testo del parametro al corpo della direttiva, confermandone l'associazione:
Fare clic in un punto qualsiasi all'interno del riquadro tratteggiato, quindi trascinare per riposizionare il set di parametri secondo necessità. Durante il trascinamento, il set di parametri può essere ruotato (Spacebar/Shift+Spacebar) o specchiato (tasti X o Y per specchiare lungo l'asse X o Y).
Le dimensioni dei campi di testo del set di parametri (che possono essere modificati graficamente indipendentemente dalla direttiva a cui appartengono) possono essere regolate solo modificando l'opzione Style nella pagina Schematic – Defaults della finestra di dialogo Preferences. Pertanto, quando si seleziona uno di questi oggetti, non sono disponibili maniglie di modifica.
Fare clic in un punto qualsiasi all'interno del riquadro tratteggiato, quindi trascinare per riposizionare l'oggetto di testo secondo necessità. Durante il trascinamento, l'oggetto di testo può essere ruotato (Spacebar/Shift+Spacebar) o specchiato (tasti X o Y per specchiare lungo l'asse X o Y).
Se l'opzione Enable In-Place Editing è abilitata nella pagina Schematic – General della finestra di dialogo Preferences, è possibile modificare il valore di un parametro direttamente nell'area di progettazione (ad eccezione dei parametri aggiunti come regole). Selezionare l'oggetto di testo, quindi fare clic una volta per attivare la funzione. Digitare il nuovo valore secondo necessità, quindi fare clic al di fuori dell'oggetto di testo o premere Enter per applicare la modifica.
Modifica non grafica
Sono disponibili i seguenti metodi di modifica non grafica.
Modifica tramite la finestra di dialogo Parameter Set o il pannello Properties
Panel page: Proprietà del set di parametri
Questo metodo di modifica utilizza la finestra di dialogo Parameter Set associata e la modalità Properties del pannello per modificare le proprietà di un oggetto set di parametri.

La finestra di dialogo Parameter Set nella prima immagine e la modalità Parameter Set del pannello Properties nella seconda immagine
Dopo il posizionamento, è possibile accedere alla finestra di dialogo Parameter Set nei seguenti modi:
- Facendo doppio clic sull'oggetto set di parametri posizionato.
- Posizionando il cursore sull'oggetto set di parametri, facendo clic con il pulsante destro del mouse e scegliendo Properties dal menu contestuale.
Durante il posizionamento, è possibile accedere alla modalità Parameter Set del pannello Properties premendo il tasto Tab. Una volta posizionato il set di parametri, vengono visualizzate tutte le opzioni.
Dopo il posizionamento, è possibile accedere alla modalità Parameter Set del pannello Properties in uno dei seguenti modi:
- Se il pannello Properties è già attivo, selezionando l'oggetto set di parametri.
- Dopo aver selezionato l'oggetto set di parametri, selezionando il pannello Properties dal pulsante Panels in basso a destra nell'area di progettazione oppure selezionando View » Panels » Properties dal menu principale.
Modifica di più oggetti
Il pannello Properties supporta la modifica di più oggetti, consentendo di modificare le impostazioni delle proprietà identiche in tutti gli oggetti attualmente selezionati. Quando si selezionano più oggetti dello stesso tipo manualmente, tramite la finestra di dialogo Find Similar Objects oppure tramite un pannello Filter o List, è possibile modificare per tutti gli oggetti selezionati qualsiasi voce di campo del pannello Properties che non sia visualizzata come un asterisco (*).
Modifica tramite un pannello List
Panel pages: Pannelli List, SCH Filter
Un pannello List consente di visualizzare in formato tabellare gli oggetti di progettazione di uno o più documenti, permettendo di esaminarne e modificarne rapidamente gli attributi. Utilizzato insieme a un filtro appropriato, tramite il pannello Filter applicabile o la finestra di dialogo Find Similar Objects, consente di visualizzare solo gli oggetti che rientrano nell'ambito del filtro attivo, permettendo di individuare e modificare più oggetti di progettazione con maggiore precisione ed efficienza.
Note
- Quando si posiziona una direttiva set di parametri predefinita, non sono presenti parametri. Dopo averla posizionata, aggiungere i parametri pertinenti tramite la sezione Parameters del pannello Properties .
- Una direttiva set di parametri consente di assegnare informazioni sul layout del PCB a una net nello schema. Quando viene creato un PCB dallo schema, le informazioni del set di parametri vengono utilizzate per creare le regole di progettazione PCB pertinenti. Le informazioni specificate da una direttiva set di parametri vengono applicate solo alle net a cui è collegata.
- Quando si aggiunge una direttiva set di parametri a una net, i campi Power Net e High Speed sono disponibili nel pannello Properties della net. Durante l'aggiornamento del documento PCB dagli schemi, viene proposta l'aggiunta della regola di progettazione Supply Nets a ciascuna net con il parametro Power Net abilitato.
- Le direttive Net Class consentono di creare classi di net definite dall'utente nello schema. Quando viene creato un PCB dallo schema, le informazioni contenute in una direttiva Net Class vengono utilizzate per creare la classe di net corrispondente sul PCB. Per rendere una net membro di una classe di net, collegare una direttiva set di parametri al filo o al bus pertinente e aggiungere una classe il cui nome sia impostato su quello della classe desiderata. Per utilizzare questa funzione, l'opzione Generate Net Classes (per le classi definite dall'utente) deve essere abilitata nella scheda Class Generation della finestra di dialogo Project Options.
- Se per una net è stata definita una direttiva Net Class, tutte le regole di progettazione PCB create dallo stesso oggetto set di parametri avranno come ambito la classe di net quando il progetto verrà trasferito all'editor PCB.
- È possibile creare una direttiva Net Class dalla direttiva Parameter Set posizionata aggiungendo una classe il cui valore deve essere impostato sulla classe di net PCB desiderata.
-
Un Blanket, insieme a una direttiva Parameter Set, può essere utilizzato anche per applicare classi di componenti e parametri ai componenti che si trovano interamente all'interno dell'area definita dal Blanket. A tale scopo, utilizzare le opzioni Component Class e Parameter del menu a discesa del pulsante Add nelle proprietà della direttiva Parameter Set associata al Blanket. Le informazioni sulla classe di componenti e sui parametri verranno trasferite al documento PCB del progetto durante il processo ECO, quando si aggiorna il PCB.
Proprietà del set di parametri
Le proprietà degli oggetti dell'editor schematico sono opzioni configurabili che specificano lo stile visivo, il contenuto e il comportamento dell'oggetto posizionato.
Le impostazioni delle proprietà per ogni tipo di oggetto vengono definite in due modi diversi:
-
Pre-placement settings – la maggior parte delle proprietà dell'oggetto Parameter Set, o quelle che possono essere logicamente predefinite, sono disponibili come impostazioni predefinite modificabili nella pagina Schematic – Defaults della finestra di dialogo Preferences (accessibile dal pulsante
in alto a destra nell'area di progettazione). Selezionare l'oggetto in Primitive List per visualizzarne le opzioni sulla destra.
-
Post-placement settings – tutte le proprietà dell'oggetto Parameter Set possono essere modificate nelle finestre di dialogo Parameter Set e nel pannello Properties quando si seleziona un Parameter Set nell'area di progettazione.
Posizione
-
(X/Y)
- X (primo campo) – la coordinata X (orizzontale) corrente del punto di riferimento dell'oggetto rispetto all'origine corrente dell'area di progettazione. Modificare questo valore per cambiare la posizione X dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; specificare le unità quando si inserisce un valore con unità diverse da quelle predefinite correnti.
- Y (secondo campo) – la coordinata Y (verticale) corrente del punto di riferimento dell'oggetto rispetto all'origine corrente. Modificare questo valore per cambiare la posizione Y dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; specificare le unità quando si inserisce un valore con unità diverse da quelle predefinite correnti.
- Rotation – utilizzare il menu a discesa per selezionare la rotazione.
Proprietà
- Label – l'etichetta del set di parametri. Modificarla se necessario.
- Style – utilizzare il menu a discesa per selezionare lo stile. Fare clic sul riquadro del colore per accedere a un menu a discesa dal quale è possibile selezionare il colore predefinito.
Parametri
- Grid – elenca Name e Value dei parametri associati al parametro attualmente selezionato. Una volta aggiunti, i campi Name e Value possono essere modificati. È possibile assegnare un nome a Value facendo clic sul campo e inserendo il testo desiderato. Il campo Name può essere modificato solo nella modalità Properties del pannello dell'oggetto Parameter Set utilizzando Ctrl+Click. Questo metodo apre la modalità Parameter del pannello Properties, in cui è possibile inserire il nome desiderato nel campo Name. Utilizzare l'icona del lucchetto per bloccare/sbloccare un parametro elencato. Utilizzare l'icona dell'occhio per mostrare/nascondere il parametro. In questa area è possibile visualizzare tutti i parametri, singoli parametri o nessun parametro, attivando o disattivando il pulsante All e i pulsanti dei singoli parametri. I parametri sono disabilitati quando i rispettivi pulsanti sono grigi e abilitati quando i rispettivi pulsanti sono blu.
-
Add – utilizzare il menu a discesa per aggiungere un tipo di classe:
-
Net Class – selezionare per aggiungere una nuova classe di net.
- Component Class – selezionare per aggiungere una nuova classe di componenti. Questa opzione è accessibile solo nella variante Parameter Set della finestra di dialogo Parameter Set o del pannello Properties.
-
Diff. Pair Net Class – selezionare per aggiungere una nuova classe di net per coppie differenziali. Questa opzione è accessibile solo nella variante Differential Pair della finestra di dialogo Parameter Set o del pannello Properties.
-
Parameter – selezionare per aggiungere un nuovo parametro.
-
Rule – fare clic per aprire la finestra di dialogo Select Design Rule Type, in cui è possibile selezionare il tipo di una nuova regola Dopo aver scelto un tipo di regola e aver fatto clic su
, si apre la finestra di dialogo Edit PCB Rule (From Schematic), che consente di modificare la nuova regola, se necessario.
-
Fare clic sull'icona della matita per aprire la finestra di dialogo Edit PCB Rule (From Schematic) e modificare l'elemento selezionato. Fare clic su
per eliminare l'elemento selezionato.
- Font Settings – fare clic sul carattere visualizzato per modificarne lo stile. Questa opzione è disponibile solo dopo aver aggiunto una classe di net, una classe di net per coppie differenziali, un parametro o una regola.
-
Other – se è stata aggiunta una classe di net, una classe di net per coppie differenziali, un parametro o una regola, fare clic per aprire un menu a discesa e modificare ulteriori opzioni:
- Show Parameter Name – abilitare per mostrare il nome del parametro.
- Allow Synchronization with Database – abilitare per sincronizzare con il database.
- X/Y – inserire le coordinate X e Y.
- Rotation – utilizzare il menu a discesa per selezionare la rotazione.
- Autoposition – selezionare per abilitare il posizionamento automatico.
Posizionamento delle direttive Parameter Set
Posizionare una direttiva di questo tipo scegliendo il comando Place » Directives » Parameter Set dal menu principale oppure dal menu visualizzato facendo clic con il pulsante destro del mouse nell'area di progettazione. Quando si posiziona una direttiva Parameter Set predefinita, non sono presenti parametri. Un set di parametri è una direttiva di progettazione che consente di associare specifiche di progettazione a un oggetto di tipo net all'interno di uno schema elettrico. Ad esempio, è possibile utilizzare un set di parametri per dichiarare che due net appartengono a una coppia differenziale. Il software determina quale direttiva di progettazione si sta posizionando in base alla presenza di parametri con nomi specifici nel set di parametri.
Oltre alle direttive con parametri definiti dall'utente, è possibile definire una direttiva con parametri basati su regole dalla finestra di dialogo Choose Design Rule Type, accessibile dalla modalità Properties del pannello associata al parametro. Per accedervi, procedere come segue:
-
Premere
Tabprima di posizionare il Parameter Set oppure fare doppio clic su una direttiva Parameter Set già posizionata per visualizzarne le proprietà nel pannello Properties. -
Quindi, fare clic sul pulsante
nell'area Parameters del pannello Properties e scegliere Rule dal menu a discesa per selezionare una regola dalla finestra di dialogo Select Design Rule Type.

Modifica del valore di una regola.
Utilizzare la finestra di dialogo Select Design Rule Type per selezionare il tipo di regola da aggiungere alla direttiva come parametro di regola. Facendo doppio clic su un tipo di regola si accede alla relativa finestra di dialogo Edit PCB Rule (From Schematic), in cui è possibile definire i vincoli della regola.

Definizione dei vincoli per una regola selezionata.
La voce nell'area Parameters riporterà il tipo di regola scelto insieme ai vincoli specificati. L'immagine seguente illustra i parametri della regola di vincolo della larghezza definiti per una direttiva Parameter Set. Per visualizzare la regola nell'area di progettazione, fare clic sull'icona di visibilità nell'area Rules.

Più vincoli di regola definiti per una determinata net mediante una direttiva Parameter Set.
Quando il progetto viene trasferito al PCB tramite il processo di sincronizzazione, vengono create le regole di progettazione pertinenti in base alle informazioni contenute in una direttiva. La parola Schematic viene utilizzata nel nome di ogni regola generata per distinguerne l'origine.

Regole di progettazione generate sul lato PCB.
Posizionamento delle direttive Net Class
Una direttiva Net Class consente di creare classi di net definite dall'utente nello schema. È possibile posizionare una direttiva Net Class scegliendo il comando Place » Directives » Parameter Set dai menu principali e quindi definendo il set di parametri come direttiva di classe di net, come indicato nel suggerimento n. 2 nella pagina del comando. Quando si crea un PCB a partire dallo schema, le informazioni contenute in una direttiva Net Class vengono utilizzate per creare la classe di net corrispondente sul PCB. Per aggiungere una net a una classe di net, collegare una direttiva Net Class al filo, al bus o al cablaggio di segnali pertinente, quindi impostare il parametro ClassName della direttiva sul nome della classe desiderata. Per utilizzare questa funzionalità, è necessario abilitare l'opzione Generate Net Classes (per le classi definite dall'utente) nella scheda Class Generation della finestra di dialogo Project Options.
Se per una net è stata definita una direttiva Net Class, tutte le regole di progettazione PCB create dallo stesso oggetto set di parametri avranno come ambito di applicazione la classe di net quando il progetto viene trasferito all'editor PCB. È possibile creare una direttiva Net Class a partire da una direttiva Parameter Set già posizionata aggiungendo una classe il cui valore deve essere impostato sulla classe di net PCB desiderata.
Requisiti importanti per le opzioni di progetto
Per garantire che i set di parametri definiti nello schema vengano propagati al PCB, è necessario configurare le seguenti opzioni nella finestra di dialogo Options for PCB Project:
- Abilitare l'opzione Generate Net Classes situata nell'area User-Defined Classes della scheda Class Generation della finestra di dialogo.
-
Nella scheda Comparator della finestra di dialogo, impostare la modalità di controllo Differences Associated with Nets » Extra Net Classes su
Find Differences.

Per propagare le direttive Parameter Set al PCB, è necessario configurare due opzioni di progetto. Innanzitutto, abilitare l'opzione Generate Net Classes nella scheda Class Generation. Passare il puntatore sull'immagine per visualizzare la scheda Comparator, in cui occorre impostare l'opzione Extra Net Classes su Find Differences.
Quando il progetto viene trasferito al PCB tramite il processo di sincronizzazione, vengono create le classi di net pertinenti in base alle informazioni contenute in una direttiva.
Posizionamento delle direttive Blanket
Le direttive Parameter Set possono essere applicate solo alla net specifica a cui sono collegate, ma, se combinate con una direttiva Blanket, il loro ambito di applicazione può essere esteso a tutte le net all'interno del Blanket.
Posiziona una direttiva di questo tipo scegliendo il comando Place » Directives » Blanket dai menu principali. Quando posizioni un Blanket, puoi definirne una semplice forma rettangolare oppure una forma poligonale. Quest'ultima consente un controllo più preciso sulla copertura degli oggetti net desiderati nel foglio.
Il Blanket identifica le net di interesse: posiziona una direttiva Parameter Set in un punto qualsiasi del suo bordo per applicare i requisiti di progettazione a tali net. Affinché la direttiva sul perimetro si applichi a una net sotto una direttiva Blanket, un oggetto associato a quella net (un pin, una porta, un'etichetta di net, una porta di alimentazione o un segmento di filo/bus/harness, comprese entrambe le estremità) deve rientrare nei limiti del Blanket. Tieni presente che, per gli identificatori di net, come le etichette di net, il punto attivo deve trovarsi all'interno del Blanket. Se le net appartenenti al gruppo non vengono trasferite al Parameter Set del PCB come previsto, prova a regolare di conseguenza l'area del Blanket.

Esempio di utilizzo di una direttiva Blanket per applicare una direttiva Parameter Set alle net al suo interno.
Alcuni esempi di utilizzo di una direttiva Blanket:
- Collegare una direttiva Parameter Set a un oggetto Blanket per applicarne i parametri delle regole a ogni singola net coperta dal Blanket.
- Collegare una direttiva Parameter Set a un oggetto Blanket per creare un Parameter Set i cui membri siano le singole net coperte dal Blanket.
- Collegare una direttiva Differential Pair a un oggetto Blanket per creare oggetti coppia differenziale a partire dalle net differenziali entro i limiti del Blanket.
Un Blanket, insieme a una direttiva Parameter Set, può essere utilizzato anche per applicare classi e parametri ai componenti che si trovano interamente all'interno dell'area definita dal Blanket. A tale scopo, usa le opzioni Component Class e Parameter del menu a discesa del pulsante Add nelle proprietà della direttiva Parameter Set collegata al Blanket. Le informazioni sulla classe e sul parametro dei componenti verranno trasferite al documento PCB del progetto durante il processo ECO, quando si aggiorna il PCB.
Blanket
Un Blanket rettangolare e un Blanket poligonale, ciascuno con una direttiva collegata
Riepilogo
Un Blanket è un oggetto direttiva di gruppo di forma rettangolare o poligonale che viene posizionato su un insieme di net e/o componenti. Una direttiva (oggetto Parameter Set) applicata al Blanket si applicherà quindi a tutte le net e a tutti i componenti coperti dal Blanket. Quando posizioni un Blanket, puoi definirne una semplice forma rettangolare oppure una forma poligonale. Quest'ultima consente un controllo più preciso sulla copertura degli oggetti net desiderati nel foglio.
Il Blanket si applica a tutte le net che:
- si trovano interamente all'interno dell'area definita dal Blanket, oppure
- hanno almeno un vertice terminale collegato del filo / bus / harness sotto il Blanket, oppure
- hanno un'etichetta di net collegata al filo / bus / harness e tale etichetta si trova sotto il Blanket.
Per quanto riguarda i componenti, il Blanket si applica a tutti quelli all'interno dell'area definita dal Blanket.
Una direttiva applicata al perimetro del Blanket (Place » Directive), come No ERC, Differential Pair o un Parameter Set con regole/classi specifiche, si applicherà a tutte le net e a tutti i componenti individuati dall'oggetto Blanket. I Blanket possono essere disabilitati e nascosti.
Disponibilità
I Blanket possono essere posizionati solo nell'editor degli schemi. Per posizionare un Blanket:
- Fai clic su Place » Directives » Blanket nei menu principali.
- Fai clic sul pulsante Blanket nel menu a discesa delle direttive sulla Active Bar situata nella parte superiore dell'area di progettazione. Fai clic e tieni premuto un pulsante Active Bar per accedere agli altri comandi correlati. Una volta utilizzato, il comando diventerà la prima voce di quella sezione della Active Bar.
- Fai clic con il pulsante destro del mouse nell'editor degli schemi, quindi fai clic su Place » Directives » Blanket.
Posizionamento
Per posizionare un Blanket rettangolare:
- Avvia il comando come descritto sopra.
- Posiziona il cursore, quindi fai clic o premi Enter per posizionare l'angolo superiore sinistro.
- Posiziona il cursore, quindi fai clic o premi Enter per posizionare l'angolo inferiore destro.
- Fai clic con il pulsante destro del mouse o premi Enter per completare il posizionamento.
- Continua a posizionare altri Blanket oppure fai clic con il pulsante destro del mouse o premi Esc per uscire dalla modalità di posizionamento.
Per posizionare un Blanket di forma poligonale:
- Avvia il comando di posizionamento.
- Posiziona il cursore, quindi fai clic o premi Enter per fissare il punto iniziale del Blanket.
- Posiziona il cursore, quindi fai clic o premi Enter per fissare una serie di segmenti che definiscono la forma del Blanket.
- Dopo aver posizionato l'ultimo segmento, fai clic con il pulsante destro del mouse o premi Esc per completare il posizionamento. Non è necessario «chiudere» il poligono, poiché il software completerà automaticamente la forma aggiungendo i segmenti necessari per collegare il punto iniziale all'ultimo segmento posizionato.
- Continua a posizionare altri Blanket oppure fai clic con il pulsante destro del mouse o premi Esc per uscire dalla modalità di posizionamento.
Durante il posizionamento dei segmenti del Blanket puoi inoltre eseguire le seguenti azioni:
- Premi il tasto Tab per sospendere il posizionamento e accedere alla modalità Blanket del pannello Proprietà, da cui puoi modificarne al volo le proprietà della linea. Fai clic sul pulsante di pausa sovrapposto all'area di progettazione per riprendere il posizionamento.
- Premi Spacebar per cambiare la direzione dell'angolo di un segmento non ancora confermato.
- Premi Backspace per eliminare il segmento precedentemente confermato durante la definizione di una forma poligonale per il Blanket. L'uso ripetuto di Backspace eliminerà i segmenti precedenti in ordine.
Modifica grafica
Questo metodo di modifica consente di selezionare un oggetto Blanket posizionato direttamente nell'area di progettazione e di modificarne graficamente le dimensioni, la forma o la posizione. Quando si seleziona un oggetto Blanket, sono disponibili le seguenti maniglie di modifica:
Blanket rettangolari e poligonali selezionati con le relative maniglie di modifica grafica.
Fare clic su una maniglia di modifica al centro di un segmento e trascinarla per spostare quel bordo del Blanket.
Per un Blanket rettangolare, fare clic su una maniglia di modifica d'angolo e trascinarla per ridimensionarlo contemporaneamente in verticale e in orizzontale.
Fare clic in un punto qualsiasi del contorno del Blanket lontano dalle maniglie di modifica e trascinare per riposizionarlo. Durante il trascinamento, è possibile ruotare o ribaltare il Blanket:
- Premere Spacebar per ruotare il Blanket in senso antiorario attorno alla posizione del cursore. Shift+Spacebar ruota il Blanket in senso orario attorno al cursore. La rotazione avviene a incrementi di 90°.
- Premere i tasti X o Y per ribaltare il Blanket lungo l'asse X o Y rispetto alla posizione del cursore.
Modifica non grafica
Sono disponibili i seguenti metodi di modifica non grafica.
Modifica tramite la finestra di dialogo Blanket o il pannello Properties
Panel page: Proprietà del Blanket
Questo metodo di modifica utilizza la modalità finestra di dialogo Blanket e la modalità pannello Properties associate per modificare le proprietà di un oggetto Blanket.
La finestra di dialogo Blanket a sinistra e la modalità Blanket del pannello Properties a destra
Dopo il posizionamento, è possibile accedere alla finestra di dialogo Blanket nei seguenti modi:
- Facendo doppio clic sull'oggetto Blanket posizionato.
- Posizionando il cursore sull'oggetto Blanket, facendo clic con il pulsante destro del mouse e scegliendo Properties dal menu contestuale.
Durante il posizionamento, è possibile accedere alla modalità Blanket del pannello Properties premendo il tasto Tab. Una volta posizionato il Blanket, vengono visualizzate tutte le opzioni.
Dopo il posizionamento, è possibile accedere alla modalità Blanket del pannello Properties in uno dei seguenti modi:
- Se il pannello Properties è già attivo, selezionando l'oggetto Blanket.
- Dopo aver selezionato l'oggetto Blanket, selezionando il pannello Properties dal pulsante Panels nella sezione in basso a destra dell'area di progettazione oppure selezionando View » Panels » Properties dal menu principale.
Modifica di più oggetti
Il pannello Properties supporta la modifica di più oggetti, consentendo di modificare le impostazioni delle proprietà identiche in tutti gli oggetti attualmente selezionati. Quando si selezionano più oggetti dello stesso tipo manualmente, tramite la finestra di dialogo Trova oggetti simili oppure tramite un pannello Filter o List, è possibile modificare per tutti gli oggetti selezionati il valore di un campo del pannello Properties che non sia visualizzato come un asterisco (*).
Modifica tramite un pannello List
Panel pages: Pannelli List, SCH Filter
Un pannello List visualizza i tipi di oggetti di progettazione di uno o più documenti in formato tabellare, consentendo di esaminare e modificare rapidamente gli attributi degli oggetti. Utilizzato insieme a un filtro appropriato, selezionando i tipi di oggetto (tramite le opzioni Include del pannello) oppure utilizzando il pannello Filter pertinente o la finestra di dialogo Trova oggetti simili, consente di visualizzare soltanto gli oggetti che rientrano nell'ambito del filtro attivo. Le proprietà degli oggetti elencati possono quindi essere modificate direttamente nel pannello List.
Supporto per il filtraggio
Sono disponibili due parole chiave particolarmente utili per individuare gli oggetti Blanket tramite espressioni di query logiche. Queste integrano le altre parole chiave utilizzate per individuare un Blanket in base alle sue proprietà.
-
Collapsed– l'oggetto è compresso (utile anche per individuare le Compile Mask). Questa parola chiave si trova nella categoria SCH Functions - Fields quando si utilizza Query Helper. -
IsBlanket– verifica se l'oggetto è un Blanket. Questa parola chiave si trova nella categoria SCH Functions - Object Type Checks quando si utilizza Query Helper.
Creare espressioni logiche per le query per individuare e restituire i Blanket nel progetto in base alle necessità. Alcuni esempi di espressioni di query logiche per individuare i Blanket sono:
IsBlanket And Collapsed – individua tutti gli oggetti Blanket attualmente compressi.
IsBlanket And Not Collapsed – individua tutti gli oggetti Blanket attualmente non compressi.
Disabilitazione di un Blanket
Una volta posizionati, i Blanket possono essere disabilitati temporaneamente facendo clic sul piccolo triangolo in alto a sinistra Fare clic una volta per disabilitare e nascondere il Blanket; fare nuovamente clic per riabilitarlo. Questo offre un modo pratico per controllare l'effetto del Blanket senza doverlo rimuovere completamente dal progetto.
Proprietà del Blanket
Le proprietà degli oggetti dell'editor degli schemi sono opzioni configurabili che specificano lo stile visivo, il contenuto e il comportamento dell'oggetto posizionato. Le impostazioni delle proprietà per ogni tipo di oggetto vengono definite in due modi diversi:
-
Pre-placement settings – la maggior parte delle proprietà degli oggetti Blanket, o quelle che possono essere logicamente predefinite, sono disponibili come impostazioni predefinite modificabili nella pagina Schematic - Defaults della finestra di dialogo Preferences (accessibile dal pulsante
in alto a destra nell'area di progettazione). Seleziona l'oggetto in Primitive List per visualizzarne le opzioni sulla destra.
- Post-placement settings – tutte le proprietà degli oggetti Blanket sono modificabili nella finestra di dialogo Blanket e nel pannello Properties quando si seleziona un Blanket posizionato nell'area di progettazione.
Proprietà
- Border Width - usa il menu a discesa per selezionare lo spessore desiderato per il bordo.
- Stile della linea - usa il menu a discesa per selezionare lo stile di linea desiderato.
- Border Color - fai clic sul riquadro del colore per selezionare il colore desiderato per il bordo.
- Fill Color - fai clic sul riquadro del colore per selezionare il colore desiderato per il riempimento.
- Collapsed and Disabled - seleziona per comprimere e disabilitare i Blanket.
Direttive indirette (basate sui parametri)
Le direttive Parameter Set sono necessarie per applicare direttive agli oggetti dello schema che non possono contenere parametri; per gli oggetti che possono contenerli, invece, le direttive di progettazione possono essere applicate indirettamente aggiungendole (e definendole) come parametri dell'oggetto schematico pertinente. In sostanza, sono parameter-based directives.
Tra gli esempi di utilizzo delle direttive basate sui parametri vi sono la limitazione dell'altezza di un particolare componente o l'aggiunta di un vincolo di distanza di isolamento applicato a tutti gli oggetti del progetto. Il parametro necessario a definire il vincolo viene aggiunto all'oggetto come regola.
Durante la sincronizzazione con il PCB, le direttive basate sui parametri aggiunte agli oggetti nello schema diventano regole di progettazione del PCB. L'ambito della regola di progettazione del PCB corrispondente sarà determinato dalla natura dell'oggetto a cui il parametro è stato inizialmente assegnato. La tabella seguente riepiloga le opzioni supportate per la corrispondenza tra i parametri dello schema e l'ambito delle regole del PCB.
| Aggiungi un parametro (come regola) a... | Da... | Per un ambito della regola PCB di... |
|---|---|---|
| Pin | la scheda Parameters della modalità Pin del pannello Properties. | Pad |
| Porta | la scheda Parameters della modalità Port del pannello Properties. | Net |
| Componente | la sezione Parameters della modalità Components del pannello Properties. | Componente |
| Simbolo di foglio | la scheda Parameters della modalità Sheet Symbol del pannello Properties, quando nella sezione Source è selezionato Local. | Classe di componenti |
| Simbolo di foglio dispositivo | la scheda Parameters della modalità Sheet Symbol del pannello Properties, quando nella sezione Source è selezionato Device. | Classe di componenti |
| Simbolo di foglio gestito | la sezione Parameters della modalità Sheet Symbol del pannello Properties, quando nella sezione Source è selezionato Managed. | Classe di componenti |
| Foglio | la scheda Parameters della modalità Document Options del pannello Properties. | Tutti gli oggetti |
In ogni caso, il metodo per aggiungere un parametro basato su regole è lo stesso. Dalla scheda o dalla finestra di dialogo pertinente, procedi come segue:
- Aggiungi un parametro come regola.
- Seleziona il tipo di regola da utilizzare.
- Configura i vincoli per il tipo di regola scelto.
Definizione delle classi di componenti
Analogamente, le classi di componenti possono essere definite nello schema aggiungendo un parametro ClassName ai componenti interessati e impostandone il valore sul nome della classe desiderata. Quando il progetto viene trasferito al PCB, verranno create le classi di componenti definite.
Per garantire che le classi di componenti definite nello schema vengano propagate al PCB, è necessario impostare le seguenti opzioni nella finestra di dialogo Project Options:
- Abilita l'opzione Generate Component Classes nella sezione User-Defined Classes della scheda Class Generation della finestra di dialogo.
-
Nella scheda Comparator della finestra di dialogo, imposta Differences Associated with Components » Extra Component Classes Mode su
Find Differences.
L'opzione della scheda Class Generation sopra elencata è mostrata nell'immagine seguente. Passa il puntatore sull'immagine per visualizzare l'impostazione dell'opzione della scheda Comparator .

Per propagare le classi di componenti al PCB, abilita l'opzione Generate Component Classes nella scheda Class Generation. Passa il puntatore sull'immagine per visualizzare la scheda Comparator, dove dovrai impostare Extra Component Classes Mode su Find Differences.
Una volta definite, le classi possono essere bloccate nella sezione Properties del pannello Properties delle proprietà del rispettivo componente.
Controllo della stampa delle direttive
Per impostazione predefinita, tutte le direttive di progettazione sono incluse nella stampa dei fogli dello schema. Tuttavia, è possibile modificare questa impostazione:
- Dalla finestra di dialogo Schematic Print Properties, quando si stampa direttamente dallo schema o come parte di un output configurato in un file Output Job Configuration.
- Dalla sezione Schematics include, nella pagina Additional PDF Settings della procedura guidata Smart PDF.

Controlla la stampa delle direttive in base alle tue esigenze. Per le direttive No ERC, puoi scegliere di stampare determinati stili di simbolo, escludendone altri.




).
).