既存のライブラリを接続済みワークスペースにインポートする

概略

Altium DesignerのLibrary Importerを使用して、既存のコンポーネントライブラリを接続先のワークスペースに取り込みましょう。この記事では、ImporterのSimpleモードで一般的なインポートを自動化する方法と、Advancedモードでコンポーネントの種類、パラメーター、インポート設定をより細かく制御する方法を説明します。また、対応するライブラリ形式、転送されるデータ、インポート時の問題の特定に役立つ検証チェックについても解説します。お使いのライブラリに適したインポート方法を見つけ、コンポーネントの一元管理に向けた次の一歩を踏み出しましょう。

- Library Importerへのアクセス方法と、SimpleモードおよびAdvancedモードの選択方法を学びます。
- インポート可能なライブラリとコンポーネントデータ、および主な制限事項を把握します。
- インポートのプレビュー、コンポーネントの分類、パラメーター設定、レポート機能を活用して、インポート内容を確認し、調整する方法を紹介します。
AIでさらに深掘り:

Altium Designerは、接続先のWorkspaceと連携し、既存のライブラリをそのWorkspaceにすばやくインポートするための、効率的かつ高度に自動化されたプロセスを提供します。このプロセスのインターフェースであるLibrary Importer は、選択したライブラリを自動的に解析し、現在接続しているWorkspaceにワンクリックでインポートします。

Library Importerは、従来のコンポーネント管理手法で使用されるあらゆる種類のライブラリ(SchLib、PcbLib、IntLib、DbLib、SVNDbLib)に対応しており、社内のWorkspaceコンポーネントライブラリをすばやく構築するための専用ソリューションです。これにより、高いデータ整合性、一元的な保存と管理、設計の再利用の容易さ、リアルタイムのサプライチェーン情報といった多くのメリットを活用できます。

Library Importerには、必要最小限の操作で使用できるSimpleインターフェースモードが用意されています。このモードでは、選択したデータベースライブラリやファイルベースのコンポーネントライブラリを、1つのステップでWorkspaceコンポーネントとしてインポートできます。タイプの分類、インポート先のソースフォルダー、パラメーターの取り込みと値の型、および関連するすべてのデータの転送は、インポーターが自動的に処理します。また、インポート予定のライブラリの全体プレビューを表示し、関連データや設定にアクセスできるAdvancedモードも用意されています。デフォルトではワンクリックでインポートできますが、インポート方法をより細かく制御できるよう、Propertiesパネルから高度な設定オプションも利用できます。

インポートされる内容

元のソースライブラリに含まれるすべての情報が、Workspaceコンポーネントにインポートされます。これには、参照されているすべてのドメインモデル(回路図シンボル、PCBフットプリント、シミュレーションモデル)、パラメーター情報、割り当てられた部品候補、データシートファイルなどが含まれます。必要に応じてコンポーネントテンプレートも作成され、後から調整して以降のライブラリインポートに使用できます。

元のコンポーネントに複数のPCBフットプリントが定義されている場合、Library Importerはそれらのモデルを取り込み、現在のデフォルトフットプリントを維持します。また、PCBライブラリのみを使用している場合、つまりPCBレイアウトのみを扱う場合は、それらのライブラリだけをインポートできます。モデルのみのインポートモードに切り替えて、統合ライブラリやデータベースライブラリから指定した種類のモデルをインポートすることもできます。複数のコンポーネントタイプを含むライブラリ(モノリシックライブラリ)も、自動的に検出され、処理されます。

ライブラリのインポートでは、さまざまな書式規則を使用している可能性のあるデータベースおよびファイルベースのライブラリソースを処理する必要がありますが、自動解析プロセスによって、ソースライブラリ内のコンポーネントの種類(抵抗、コンデンサーなど)に加え、パラメーター名とその値の型(ボルト、オームなど)が検出されます。また、システムはさまざまな検証を実行し、処理します。たとえば、作成されるWorkspaceライブラリコンポーネントのIDが重複しないこと、モデルやコンポーネントテンプレートが重複して作成されないこと、必要に応じてこれらが複数のコンポーネントで再利用(リンク)されることを確認します。問題が発生した場合は、システムがその問題を示し、解決方法を提案することで、できる限り迅速かつ円滑にインポートを再開できるようにします。

インポートできるライブラリの種類は次のとおりです。

  • 回路図ライブラリ(*.SchLib)。

  • PCBフットプリントライブラリ(*.PcbLib)。

  • 統合ライブラリ(*.IntLib)

  • データベースライブラリ(*.DbLib)。

  • SVNデータベースライブラリ(*.SVNDbLib)。

現在、ピンマッピング情報(シミュレーションモデル用)のインポートには対応していません。

Library Importerへのアクセス

Library Importerは、Workspaceに接続しているときに使用できます。Simpleモードでインポーターにアクセスするには、次のいずれかの操作を行います。

  • Componentsパネルで、 メニューからImport Libraryオプションを選択します。パネルのCategories列(パネルがコンパクトモードの場合は上部のドロップダウンメニュー)でデータベースライブラリまたはファイルベースのライブラリが選択されている場合は、そのライブラリを対象にLibrary Importerが開きます。Workspaceライブラリのコンポーネントタイプが選択されている場合は、標準のWindowsのOpenダイアログが開き、インポートするライブラリファイルを参照して選択できます。

    ソフトウェアで現在使用できるデータベースライブラリとファイルベースのライブラリは、Libraries Preferencesダイアログで表示および管理できます。このダイアログには、Componentsパネルの ボタンメニューにあるLibraries Preferencesオプションからアクセスできます。

    現在インストールされているファイルベースのライブラリは、PreferencesダイアログのData Management – File-based Librariesページでも表示および管理できます。

  • Projectsパネルでライブラリファイルを右クリックし、コンテキストメニューからImport Libraryを選択します。

  • ローカルのライブラリファイルを開いた状態で、回路図シンボルエディターまたはPCBフットプリントエディターのTools » Import Libraryを選択します。

  • データベースライブラリエディターで、File » Import Library またはTools » Import Library を選択します。

  • Libraries Preferencesダイアログで、Installedタブのライブラリエントリを選択し、Import コントロールをクリックします。

  • WindowsフォルダーからExplorerパネルにライブラリファイルをドラッグ&ドロップします。

Simpleモードでは、選択したライブラリをすぐにインポートする()か、Library ImporterをフルGUIモードで開く()かを選択できます。

Simpleのワンクリックインポートモードで開いたLibrary Importer。
Simpleのワンクリックインポートモードで開いたLibrary Importer。

Library ImporterをAdvancedインターフェースモードで直接開くには、メインメニューからFile » Library Importerを選択します。

フル機能のAdvancedインターフェースモードで開いたLibrary Importerも、ワンクリックでのインポートに対応しています。
フル機能のAdvancedインターフェースモードで開いたLibrary Importerも、ワンクリックでのインポートに対応しています。

Simpleモード

Library ImporterのSimpleモードでは、ソースライブラリと接続先のWorkspaceの解析に基づき、インポートプロセスのすべての項目が事前に選択されます。続いて、Library Importerダイアログに、項目の種類ごとの合計数を含むインポート構成の概要が表示されます。ライブラリのインポートは、コマンドから1つのステップで実行されます。

このSimpleインターフェースモードは、一般的なコンポーネントタイプ(抵抗、コンデンサー、集積回路など)や標準化されたパラメーター値を含む、多くの一般的なソースライブラリ形式に適しています。最初の解析プロセスで、システムはデジグネーターまたはパラメーターのキーワード(LD?、LEDなど)に基づいてライブラリ内のコンポーネントの種類を推定し、インポート先のWorkspaceで対応するコンポーネントテンプレート(LED)を検索します。このテンプレートが対象コンポーネントのインポートに適用され、インポート先フォルダー(Components/LED)、パラメーターマッピング、パラメーター値の単位などのインポート設定が指定されます。Altium 365 Workspaceのアクティベーション時、またはAltium On-Prem Enterprise Serverのインストール時に、サンプルデータを含めるオプションを選択していれば、適切なテンプレートをWorkspaceで利用できます。

ライブラリのインポート結果は、新しく作成されたWorkspaceコンポーネントとして、ExplorerパネルとComponentsパネルの両方で確認できます。インポートされたコンポーネントには、すべてのモデル、適用されたコンポーネントテンプレートによって解釈されたパラメーター、サプライヤーリンクのソースデータから取得された部品候補、および参照リンクやファイルが含まれます。

Library Importerで作成されたコンポーネントテンプレートには、ExplorerパネルのManaged Content\Templates\Component Templatesフォルダーからアクセスできます。

インポート結果が期待どおりでないなどの理由でコンポーネントをまとめて削除する場合は、Componentsパネルで対象を選択し、右クリックのコンテキストメニューからDelete オプションを選択すると、関連データも含めて削除できます。選択したコンポーネントに関連付けられたモデルも、他のコンポーネントで使用されていなければ、一緒に削除できます。

ライブラリのインポート処理に関する主な注意点は次のとおりです。

  • モノリシックライブラリ(複数の種類のコンポーネントを含むライブラリ)は、コンポーネントの種類ごとのサブグループに自動的に分割されます。各グループは個別のライブラリとして処理されます。

  • コンポーネントの種類を認識(検出)できないソースライブラリは、解釈されずに、種類が未割り当てのコンポーネントとしてWorkspaceのComponents/Uncategorizedフォルダーにインポートされます。インポートを実行する前に、Advanced(フルUI)モードでデジグネーターのマッピングまたはパラメーターによるグループ化を適用すると、この問題を解決できます。また、そのままインポートを進め、後からExplorerパネルでコンポーネントの設定やフォルダーを変更することもできます。
  • ライブラリのインポート処理には、コンポーネントの自動検証段階が含まれます。検証エラーが発生したコンポーネントはスキップされます。
  • インポート対象のソースライブラリで重複するモデルが検出された場合、そのうち1つのモデルのみがインポートされ、インポート先Workspaceに作成されたコンポーネントにリンクされます。Library Importerダイアログの上部には、対応する通知が表示されます。
  • 処理中に発生したエラーは、インポート完了後にボタンから開くことができるImporting Reportで確認できます。

詳細モード

Advancedモードでは、Library ImporterのフルGUIが表示され、ライブラリ、コンポーネントの種類、コンポーネントパラメーターの管理を細かく制御できます。Propertiesパネルと併用することで、Workspaceへのコンポーネントライブラリのインポートを、特定のニーズに合わせて設定できます。インポーターの設定は、設定ファイルのエクスポート/インポートによって保存および復元できます。

詳細モードは、File » Library Importer コマンドからLibrary Importerを開いたとき、またはシンプルモードでボタンを選択したときに有効になります。インポーターのSOURCE LIBRARIESセクションにライブラリがまだ追加されていない場合は、その領域にライブラリファイルをドラッグ&ドロップするか、<All Libraries>を右クリックしてコンテキストメニューからAdd Libraryを選択するか、ボタンを選択して追加します。

Import Previewセクションには、ソースライブラリから識別されたコンポーネントの種類別グループが、Types()または提案されたFolder Structure()として一覧表示され、それらのコンポーネントをパラメーターごとに表示するグリッドビュー(Components)も含まれます。グリッド内のパラメーター値はその場で編集できるため、ソースライブラリを開いて編集する必要がありません。下部のDetails領域には、現在選択されているコンポーネントの追加情報(部品候補、モデル、データシート)が表示されます。

コンポーネントの種類を変更するには、Typesリスト内の種類を右クリックし、Change Component Typeコマンドを選択します。

インターフェースに詳細なオプションやデータが表示されていても、インポーターの詳細ビューはシンプルビューと同じように使用できます。ボタンをクリックするだけで、手を加えることなくインポート処理を開始できます。シンプルビューでの処理と同様に、インポーターはライブラリを解析し、含まれるコンポーネントの種類を推定して、適切なコンポーネントテンプレートを適用しています。このテンプレートによって、Workspaceのインポート先フォルダー、適用する命名規則とライフサイクル定義、およびパラメーターのマッピングと解釈が決まります。

  • 左上のボタンを使用すると、Library Importerを更新できます。すべてのソースライブラリとWorkspaceデータが再読み込みされ、インポーターを開いてからの変更が反映されます。
  • 右上の検索フィールドを使用すると、一致するパラメーター値でコンポーネントのエントリを絞り込めます。

モノリシックライブラリ

複数の種類のコンポーネントを含むソースライブラリは、インポーターの解析ルーチンによって検出され、種類ごとのライブラリとして処理できるサブライブラリグループに分割されます。コンポーネントの種類は、ソースコンポーネントのデジグネーター(R?、C?など)と、その他の主要なコンポーネントパラメーター(説明、IDなど)に含まれるキーワード(Resistor、Resなど)に基づいて検出されます。

以下の例では、ソースライブラリ(ProjectABC.IntLib)が、検出されたコンポーネントの種類(コンデンサー、抵抗など)に応じて自動的に「分割」されています。Folder Structure列(またはTypes列)で種類を選択すると、それに属するコンポーネントのエントリをComponentsグリッドでプレビューできます。

現在Workspaceに存在せず、インポート処理中に作成されるコンポーネントの種類には、アイコンが付けられます。

Componentsリストの表示は、次の方法で変更できます。

  • 列ヘッダーをクリックすると、そのパラメーター列を基準にリストが並べ替えられます。もう一度クリックすると、並び順が反転します。

  • ヘッダーの右クリックコンテキストメニューでは、次の操作ができます。

    • Clear Sortingを選択すると、リストの並び順が既定の設定(Name列の昇順)に戻ります。

    • Best Fitを選択すると、特定の列の幅がその内容に合わせて調整されます。

    • Select Best Fit All Columnsを選択すると、使用可能なすべての列の幅がそれぞれの内容に合わせて調整されます。

    • Select Columnsを選択すると、Select Columnsダイアログが開き、パラメーター列の表示/非表示の切り替えや、リスト内の配置順の変更ができます。

  • ヘッダー内のフィルターアイコン()をクリックすると、パラメーター列で選択可能な値、空白/空白以外の値、またはCustomフィルター設定でリストを絞り込めます。適用されたフィルターはリストの下部に表示され、対応するチェックボックスで有効/無効を切り替えたり、Filter Editorで変更したり、削除したりできます。ヘッダーのフィルターアイコン()からAllを選択しても、適用されたフィルターを解除できます。

未分類のコンポーネント

ライブラリのサブグループエントリの1つがUncategorizedという名前になっている場合(TypesまたはFolder Structureの下にUncategorizedとして表示され、が付いている場合)アイコン)は、インポーターがそのコンポーネントグループのタイプを検出して割り当てられなかったことを示します。実質的に、コンポーネントタイプは None に設定されています。この場合、検出されなかったコンポーネント(インバーターロジックIC)には、認識されないデジグネーターのプレフィックス(U?)が使用されており、パラメーターには IC、logic などの検出対象キーワードが含まれていません。

インポートを実行すると、これらのコンポーネントは解釈されず、未分類のタイプとしてインポートされます。ただし、主要なパラメーターや標準パラメーター(Resistance、Capacitance、Tolerance など)が含まれている場合、インポーターはそれらに適切なパラメーターの単位タイプ(Ohm、Farad、Percent など)を自動的に設定します。

この問題は、Library Splitting ダイアログで、これらのコンポーネントに使用されているデジグネーターを目的のコンポーネントタイプに手動でマッピングすることで解決できます。このダイアログは、ソースライブラリ(ProjectABC.IntLib)を選択すると使用できる ボタンから開きます。デフォルト値が設定された Library Splitting ダイアログには、コンポーネントタイプごとのデジグネーターマッピングとパラメーターに基づく分割を使用して、未分類のコンポーネントのライブラリグループ化オプションをカスタマイズするためのコントロールが用意されています。

ダイアログの Map Designators  オプションを選択した状態で、Component Type ドロップダウンリストから、未分類のコンポーネントに該当するコンポーネントタイプを選択します(使用可能なすべてのコンポーネントタイプが表示されます)。 ボタンをクリックして、設定したタイプとデジグネーターのマッピング(コンポーネントタイプ Logic とデジグネーター U? の対応)を確定します。

適用したマッピングによってコンポーネントタイプが指定されると、インポーターは対応するコンポーネントテンプレート(Logic)を使用し、テンプレートの設定(フォルダー、命名など)に従ってライブラリのインポートを構成します。

  • Library Splitting ダイアログには、ソースライブラリで定義されている場合に、指定したパラメーター値(たとえば Category または Component_Type パラメーターの値)によって、分割したコンポーネントをグループ化するオプションもあります。これを行うには、ダイアログの Parameter Grouping オプションを選択し、ドロップダウンメニューから適切なパラメーターを選択します。
  • また、プロパティパネルの General セクションで、ライブラリのコンポーネントタイプを手動で選択することもできます。
  • Components リスト内の個々のエントリのコンポーネントタイプを変更するには、その Component Type セルをクリックしてドロップダウンメニューから別のタイプを選択するか、コンポーネントタイプを右クリックしてコンテキストメニューから Change Component Type を選択します。

Library Importerの設定は柔軟に変更できるため、新しい(未分類の)タイプのコンポーネントライブラリをインポートする際に、今後そのライブラリタイプをインポートするために必要な環境をすべて整えることができます。適切なインポート設定(新しいコンポーネントタイプ、コンポーネントテンプレート、ターゲットフォルダー、パラメーターマッピング、パラメーター値の単位タイプ)を選択しておけば、次回そのライブラリタイプをインポートする際は、事前に定義したコンポーネントタイプを選択するだけで済みます。選択したコンポーネントタイプによって、インポートのその他すべての設定が決まります。

インポート対象から除外

特定のコンポーネントタイプをインポート対象から除外することもできます。コンポーネントタイプを除外するには、Types リストで除外するコンポーネントタイプを右クリックし、コンテキストメニューから Exclude from Importer を選択します。必要に応じて、列の表示を Folder Structure から Types に変更してください()。

除外したコンポーネントタイプは、Types リスト内でグレー表示されます。除外したコンポーネントをグリッドに表示するには、Show Excluded Component (n) をクリックします。n は除外されたコンポーネントの数を示します。

インポート対象に含める

上記の Exclude from Importer コマンドを使用してコンポーネントタイプをインポート対象から除外した後、そのコンポーネントタイプをやはり対象に含めたい場合は、Types(または Folder Structure)リストでグレー表示されたコンポーネントタイプを右クリックし、コンテキストメニューから Include to Importer を選択します。コンポーネントタイプは再び Types リストに表示され、除外されていないことを示します。

検証エラーと警告

Workspaceに正しくインポートされないコンポーネント、またはまったくインポートされないコンポーネントには、Library Importerの実行時()、またはインポートの検証時()に、詳細UIで警告タグまたはエラータグが表示されます。検証では、空のWorkspaceフォルダーパス、競合するシステムパラメーター、重複モデルもチェックされます。致命的なエラーがある場合、インポートはブロックされます。

インポートを実行しようとすると、検出された違反の内容が Messages パネルに表示され、現在のインポート設定での処理を中止するか、続行するかを選択するダイアログが表示されます。続行した場合、無効なコンポーネントはインポートされないか、インポート処理が失敗します。

インポートをキャンセルした場合、または手動で検証を実行した場合、インポートチェックに合格しなかったコンポーネントにはエラー/警告アイコンが表示され、下部の Details 領域に詳細情報が表示されます。プレビューの Status 列のアイコンは、インポートルールのチェックに違反している具体的なコンポーネントエントリを示します。

組み込みの検証チェックを以下に示します。

ユーザー定義のチェックは、PropertiesパネルのImport Checks領域で設定します。Report Modeドロップダウンメニューを使用して、対応する違反の種類のレポートレベルを変更できます。これらのチェックを以下に示します。

エラーと警告の解決

ここに示す例のように、コンポーネントのForward Voltage値を有効な電圧として解釈できない場合などのパラメーターエラーは、次の方法で解決できます。

  • 問題のあるパラメーター値を編集する — 該当するセルを見つけ、適切な形式に編集します。

  • 適用されているコンポーネントテンプレートによって決まるマッピング先のパラメーター単位Typeを、Voltageから解釈しない設定のTextに変更する — インポーターのUIでソースライブラリを選択し、Propertiesパネル Parameter Mappingのリスト(Generalタブ内)でForward Voltage Typeを変更します。

  • コンポーネントをインポート処理から除外する — 該当するエントリを右クリックし、Exclude from Importer オプションを選択します。

ここに示すデータシートファイルが見つからない例のような、ファイル欠落エラーは、次の方法で解決できます。

  • 基本的な解決方法として、見つからないファイルを探し、想定される場所に復元します。
  • データシートファイルのインポートを無効にする — Propertiesパネル Datasheetのセクション(Advancedタブ内)でMigrateオプションを変更します。
  • コンポーネントをライブラリのインポート処理から除外する — 上記の方法で行います。

特定のコンポーネントエントリを探すには、右上のSearchフィールドを使用します。検索では、現在選択されているコンポーネントタイプについて、パラメーター値が一致する項目に一覧が絞り込まれます。利用可能なソースライブラリ内のすべてのコンポーネントを検索対象にするには、Types(Folder Structure)の下でAllを選択します。

回路図ライブラリのインポート

回路図ライブラリをインポートしようとしたときに、「モデルが見つからない」というエラー(Footprint <footprint name> not found in available librariesなど)が発生する場合、Library ImporterがSCHLIB内のコンポーネントにリンクされたモデルを見つけられないことを意味します。

シンプルモードでは、このようなエラーはHTML形式のImporting Reportに表示されます。これは、インポート実行後に使用可能になるボタンからアクセスできます。詳細モードでは、検証チェック()の実行時、またはライブラリのインポート()を試みたときに、メインインターフェースのステータスアイコン()と、Messagesパネルのエントリによってエラーが示されます。

欠落しているフットプリントは検証処理によって正しく検出され、エラーレポートにはChoose a Libraryオプション(Detailsドロップダウン内)も表示されます。複数のコンポーネントのフットプリントが欠落していると検出された場合、Apply PcbLib Selectionダイアログで、指定したPcbLibをこのコンポーネントだけに使用するか、フットプリントが欠落しているすべてのコンポーネントに使用するかを選択できます。

この問題を解決(または回避)するもう1つの方法は、必要なモデルライブラリファイルをAltium Designer内から利用できるようにすることです。ライブラリは、Preferencesダイアログのデータ管理 – ファイルベースのライブラリページからインストールします。

また、複数のモデルライブラリをインストールしたくない場合は、それらをソフトウェアのデフォルトのライブラリパスに配置する(またはパスを編集する)必要があります。さらに、回路図ライブラリのコンポーネントにモデルのソースライブラリが指定されていることを確認します。

  • モデルライブラリをソフトウェアのデフォルトの検索パスに含めます。対応するPCBライブラリなどのモデルライブラリを、システムのデフォルトのライブラリパスで指定された場所に追加します。この場所を確認するには、Preferencesダイアログのシステム – デフォルトの場所ページにあるLibrary Pathエントリを参照してください。そのパスの場所にライブラリファイルを追加またはコピーした場合、変更を認識させるためにAltium Designerの再起動が必要になることがあります。
  • 回路図ライブラリのコンポーネントに、対象のモデルライブラリ名を指定します。回路図ライブラリのコンポーネントがリンクするモデルライブラリをLibrary Importerが認識できるように、ライブラリのPCBモデルダイアログでその名前を指定します。

必要なモデルのインポートとリンクはLibrary Importer自体が行うため、回路図ライブラリと一緒に対応するPCBライブラリをインポートする必要はなく、むしろ推奨されません。インポート処理では、各コンポーネントに適したモデルを識別して検索し、転送することで、対象のWorkspaceに統合されたコンポーネントを作成します。

重複の検出

Library Importerには、インポート先のWorkspaceでコンポーネントが重複して作成されるのを防ぐ仕組みも備わっています。検証時に、ソースライブラリのコンポーネント識別子パラメーターとPart Choicesを、インポート先のWorkspaceおよびインポート対象のソースライブラリ内のコンポーネントのものと比較することで、これを実現します。インポーターのデフォルト設定では、検証ステップ()で同じコンポーネントのNameまたはPart Choicesエントリーが検出されると、コンポーネントが重複している可能性を示すWarningメッセージが表示されます。表示される警告/エラーメッセージには、重複違反の種類(パラメーターまたはPart Choice)、違反しているライブラリコンポーネントの名前、および重複相手のコンポーネントのIDが含まれます。

検証プロセスで検出された2つの重複候補。コンポーネントのName(上の画像)またはPart Choice(下の画像)が、Workspace内のコンポーネントにすでに存在しています。
検証プロセスで検出された2つの重複候補。コンポーネントのName(上の画像)またはPart Choice(下の画像)が、Workspace内のコンポーネントにすでに存在しています。

重複違反の検出に使用するパラメーター名と値のペアは、PropertiesパネルのAdvancedタブにあるDuplicates Detection領域で指定します。Unique Fieldドロップダウンメニュー(デフォルトはName)を使用して、ソースライブラリで利用可能なパラメーターから選択します。この選択は、企業全体のシステムと連携する独自の識別子フィールドを使用している社内ライブラリ構成で特に役立ちます。

指定したパラメーター(ERP-REF)の値がローカルライブラリのコンポーネントとWorkspaceのコンポーネントで同じであるために検出された重複違反。
指定したパラメーター(ERP-REF)の値がローカルライブラリのコンポーネントとWorkspaceのコンポーネントで同じであるために検出された重複違反。

PropertiesパネルのGeneralタブにあるImport Checks領域で別のReport Modeを選択すると、重複違反に対して異なる種類のステータスフラグを設定できます。

重複の検出は、コンポーネントのシンボルモデルに対しても実行されます。インポート対象のコンポーネントがソースライブラリ内で同じ形状のシンボルモデルを持つ場合、これらのモデルのうち1つだけがインポートされます。

この機能は、Advanced SettingsダイアログでLibraryMigrator.DuplicatedModelCheckオプションを有効にすると使用できます。

単一モデルのライブラリ

自動重複検出は、すべてのコンポーネントで共通のシンボルモデルを使用するソースライブラリの処理にも使用されます。このようなライブラリは、特定のパッケージ形式の抵抗器など、スタイルや値が異なる単一種類のコンポーネントで構成されることが多く、それぞれのシンボルには標準的なモデル図形が使用されています。

Library Importerは、この単一の共通モデルを使用している状態を検出し、各コンポーネントに対応する個別の名前付きシンボルではなく、インポートされるすべてのコンポーネントに適用する1つのシンボルモデルを転送するようにインポートを設定します。インポートするシンボルには、インポート対象のシンボルのいずれかの名前が使用され、すべてのコンポーネントパラメーターは変更されません。

インポートされたライブラリシンボル(汎用的な名前が付けられ、Descriptionフィールドは空白)は、必要に応じて編集できます。Componentsパネルで、右クリックメニューのEditオプションを使用して操作を開始します。処理中に、Create Revisions for ItemダイアログでUpdate items related to <symbol ID>オプションを選択し、インポートされたコンポーネントが新しいシンボルリビジョンを使用するようにしてください。

コンポーネントタイプの統合

システム(実際には接続先のWorkspace)に登録されているコンポーネントタイプは、PreferencesダイアログのData Management – Component Typesページ で表示および管理できます。タイプは、関連するコンポーネントのTemplateおよびWorkspaceのFolder とともに一覧表示され、Library ImporterがライブラリファイルをWorkspaceにインポートした際に作成した新しいタイプも含まれます。

複数の新しいコンポーネントタイプが作成されるのは、通常、Library Importerの設定でパラメーターによるグループ化(指定したコンポーネントパラメーターの値)を使用して、インポートする各コンポーネントのタイプを決定した場合です。たとえば、Categoriesパラメーターが、あるインポート対象のコンポーネント群ではResistor-0608、別のコンポーネント群ではResistor-0402になっている場合などです。この場合、今後の使用に向けて、すべてを単一のResistorsコンポーネントタイプにまとめるのが適切です。

このような状況で、すべてのコンポーネントタイプを手動で変更する代わりに、PreferencesのComponent Typesページでは、選択したタイプのエントリーを指定した単一のエントリーに統合できます。詳細は、コンポーネントタイプページのコンポーネントタイプの統合セクションを参照してください。

このように統合すると、Library ImporterでインポートするコンポーネントのタイプとしてResistorsを選択した場合だけでなく、代わりに統合済みのテンプレート(Resistor_0402など)のいずれかを選択した場合にも、そのタイプが適用されます。

モデルのみのインポート

Library Importerは、ソースライブラリ内で利用可能なコンポーネントモデルを検出して処理する、特別なModels Onlyインポートモードに切り替えることができます。

この機能は、Advanced SettingsダイアログでLibraryMigrator.ModelsOnlyModeオプションを有効にすると使用できます。

Models Onlyモードでは、インポーターの解析プロセスがソースライブラリ(IntLib、SchLib、PcbLibなど)内で利用可能なすべてのシンボル、フットプリント、シミュレーションモデルを検出し、システムのデフォルトの保存先、命名規則、ライフサイクル定義を使用して、それらのモデルをWorkspaceにインポートします。

Library ImporterをAdvancedモードに切り替えるか()、Advancedモードで開くと(File » Library Importer)、予定されているモデルのインポートの詳細をすべて確認できます。Import Preview 領域には、インポート先のWorkspaceで使用されるFolder Structureが表示されます。これは、Propertiesパネルの各モデルタイプのFolderフィールドで、デフォルト設定から変更できます。各モデルに適用する命名規則とライフサイクル定義は、利用可能なシステムの種類から選択できます(後述のPropertiesパネルを参照)。

必要に応じて、Propertiesパネルで各モデルタイプに対応するボタンを使用して特定のモデルタイプを無効(または有効)にすることで、Workspaceにインポートするコンポーネントモデルをタイプ別に制限できます。

Library Importerの設定が完了したら、ボタンを選択して、一覧に表示されているコンポーネントモデルのインポートを完了します。結果は、Library Importer 進行状況ダイアログ()から開けるインポートログファイルで確認するか、Componentsパネルでインポートされたモデルを表示して確認できます。

コンポーネントのみのインポート

前述のModels Onlyインポートモードと同様に、Library Importerは、ソースライブラリ内で利用可能なコンポーネントを、リンクされたモデルなしでインポートできる特別なComponents Onlyインポートモードに切り替えることができます。

この機能は、Advanced SettingsダイアログでLibraryMigrator.ReleaseComponentsWithoutModelsオプションを有効にすると使用できます。

Components Onlyモードでは、インポーターの解析プロセスがソースライブラリ内のすべてのコンポーネント、パラメーター、Part Choicesを検出し、システムのデフォルトの保存先、命名規則、ライフサイクル定義を使用して、これらのコンポーネントをWorkspaceにインポートします。

Library Importerを詳細モードに切り替えた場合()、または詳細モードで開いた場合(File » Library Importer)、インポート予定のコンポーネントの詳細情報をすべて確認できます。適用するフォルダー、命名規則、ライフサイクル定義は、利用可能なシステムタイプから選択できます(下記のPropertiesパネルを参照)。

Library Importerの設定が完了したら、ボタンを選択して、一覧に表示されているコンポーネントのインポートを完了します。Workspaceにはコンポーネントアイテムのみが作成され、リンクされたモデルは含まれません。 結果は、Library Importer 進捗ダイアログ()から開けるインポートログファイルで確認するか、Componentsパネルでインポートされたコンポーネントを表示して確認できます。 

Propertiesパネル

Library Importerに関連付けられたPropertiesパネルの設定では、選択したライブラリ(またはサブライブラリグループ)のインポート設定を詳細に制御できます。 このパネルには、Library Importerの詳細モードで、設計スペース右下のボタンメニューからProperties オプションを選択するか、Library Importerビュー右上のボタンをクリックするか、Source Librariesリスト内の<All Libraries>または特定のカテゴリー項目の横にあるボタンをクリックしてアクセスできます。

パネルのオプション設定は、システムのデフォルト設定、または適用されているコンポーネントテンプレートで指定された設定によって定義されます。このテンプレートは、ライブラリで検出されたコンポーネントタイプ(ここに示す例ではLED)によって決まります。設定はユーザーが編集することもできるため、必要に応じてインポート処理を調整できます。また、右上のReset to Defaultリンクで元に戻すこともできます。

パネルのGeneralタブには、次のセクションがあります。

  • General:
    • Component Type – 選択したライブラリに対してインポーターが検出したコンポーネントタイプと、それに関連付けられて適用されるテンプレートです(下記のComponent Templateを参照)。この設定を変更するには、フィールドを編集して新しいコンポーネントタイプを作成するか、ドロップダウンメニューのオプション(またはボタン)から別のタイプを選択します。これは、未分類のコンポーネントの問題に対処するもう1つの方法です。タイプを選択したライブラリの名前に設定するには、[LibraryName]オプションを選択します。
    • Component Template – インポートするコンポーネントに適用されるWorkspaceのコンポーネントテンプレートと、それに関連付けられたコンポーネントタイプの設定です。この設定を変更するには、ドロップダウンメニューのオプション(またはボタン)から別のテンプレートを選択します。このオプションを[Create new]に設定すると、ソースライブラリのパラメーターとLibrary Importerの現在の設定に基づいてテンプレートが自動作成されます。テンプレートを適用も作成もしない場合は、[No Template]を選択します。

      なお、Component TypeとComponent Templateの設定は、利用可能なタイプ/テンプレートに設定されている場合、実質的に連動します。たとえば、どちらかをCapacitorsに設定すると、もう一方は自動的にCapacitorsに設定されます。ただし、この状態でComponent Templateの設定を[Create New]に変更すると、現在の設定に適合する別のCapacitorsテンプレートが、適切なバージョン/リビジョンの接尾辞を付けた名前で作成されます。既存のコンポーネントテンプレートがインポート処理によって変更されることはありません。
  • Parameter Mapping – ライブラリのパラメーターと、適用されるコンポーネントテンプレートのパラメーター(テンプレートがない場合はデフォルト設定)との対応付け、および各パラメーターの値のタイプ(テキストまたは単位を認識するタイプ)です。Source Library Parameter列のドロップダウンメニューのオプションでマッピングを変更し、Type列のメニューのオプションで、テンプレートまたはデフォルトによって決まる既存の設定を変更できます。パラメーターを含めない場合は、<Skip>オプションを選択します。ソースライブラリのパラメーターに自動的に対応付けられていないパラメーター(システムによって<Skip>に設定されているもの)は、適切なテンプレートパラメーターに手動でマッピングできます。たとえば、ソースパラメーターのROHSを選択して、Workspaceテンプレートで定義されているRoHS Compliantパラメーターに対応付けることができます。パラメーター名は編集でき、パラメーターセットは追加、編集、削除できます。基本コンポーネントパラメーター(ID、Name、Description)は再マッピングできますが、それ以外は読み取り専用です。

    WorkspaceパラメーターのIDでは、ソースライブラリパラメーターが<Auto>に設定されています。そのため、パネルのAdvancedタブにあるComponentセクションで指定されたNaming Templateに基づいて、コンポーネントIDが自動作成されます。IDのマッピングは、ソースライブラリパラメーターのドロップダウンメニューから別のパラメーターを選択することで、ソースライブラリ内の任意のパラメーター(各コンポーネント項目で一意であるもの)を使用するように変更できます。なお、基本コンポーネントパラメーター(ID、Name、Description)は再マッピングできますが、それ以外は読み取り専用です。
  • Part Choice Mapping – インポーターが認識したメーカー部品またはサプライヤーリンクのパラメーターの一覧です。これらは、インポートされるコンポーネントのPart Choicesの項目を生成するために使用されます。ドロップダウンメニューのオプションを使用してマッピングを再定義したり、マッピングセットを追加、削除したりできます。デフォルトでは、メーカー部品およびサプライヤーリンクのパラメーターはインポート処理に含まれず、スキップされます。ライブラリコンポーネントに複数のサプライヤーリンクが含まれている場合、Part Choicesフィールドの項目にはプライマリーサプライヤーの参照(Supplier 1 / Supplier Part Number 1)が使用されます。
  • Import Checks – インポート検証ルールへの違反に対する、インポーターのエラー/警告の応答を表示または設定します。Report Modeドロップダウンメニューで、Violation Type項目の応答とアイコンを変更できます。なお、Fatal Errorレポートモードを選択すると、この違反が検出された際にインポート処理がブロックされます。

パネルのAdvancedタブでは、システムのデフォルトまたは適用されているコンポーネントテンプレートで設定された、インポーターのすべてのデータオブジェクトアイテムに関する設定を行えます。これには、コンポーネントモデル、データシートファイル、および作成されるコンポーネントテンプレートが含まれます。Datasheetオプション(有効/無効の切り替え)を除き、各インポートオブジェクトの設定には次の項目があります。

  • Folder – インポートするオブジェクトの保存先となるWorkspaceフォルダーです。手動で編集することも(たとえば新しい保存先フォルダーを作成する場合)、参照ボタン()から選択することもできます。
  • Naming Scheme – コンポーネントテンプレートで定義された、オブジェクトのWorkspaceでの命名仕様です。有効なテンプレートがない場合は、保存先フォルダーに設定されている規則(または手動で入力した規則)が使用されます。ドロップダウンメニューで、利用可能な命名規則から選択します。なお、保存先フォルダーのパス(Folder)を変更すると、フォルダー自体、または適用/関連付けられたコンポーネントテンプレートの設定に応じて、適用される命名規則も変更される場合があります。
  • Revision Naming Scheme – オブジェクトのWorkspaceリビジョンに使用する命名方式です。適用されているテンプレートによって設定されるか、項目のドロップダウンメニューのオプションから選択します。選択肢として使用できるのは、システムで有効になっている規則のみです。
  • Lifecycle Definition – オブジェクトに使用するライフサイクルシステムです。適用されたテンプレートによって設定されるか、該当項目のドロップダウンメニューから選択します。システムで有効になっている定義のみが選択肢として表示されます。
Componentオブジェクトのセクションには、前述のとおり、Duplicates Detectionの設定が含まれています。

設定のエクスポートとインポート

Library Importerには、現在の設定内容を記録した詳細なテキストベースのファイルをエクスポートする機能があります。このファイルには、保存先パス、パラメーターマッピング、命名規則、ライフサイクル定義、インポート先のコンポーネントタイプなど、構成可能なすべてのインポート設定が含まれます。

Importer設定ファイルは、File » Export » Importer Configコマンドを使用して*.lmcfg形式で保存でき、File » Import » Importer Config メニューオプションからいつでも復元できます。

設定の復元機能は、ソースデータベースやファイルベースのライブラリが更新され、その変更をWorkspaceにインポートする必要がある場合に特に役立ちます。ライブラリを初めてインポートした際に設定をエクスポートしておけば、その設定を復元(インポート)することで、当時使用した設定を正確に再現できます。これにより、そのライブラリ(または複数のライブラリ)で一貫したデータ転送方式を維持できます。

エクスポート(保存)されたImporter 設定ファイルには、設定のエクスポート時にソースライブラリとして開かれていたライブラリファイルへの参照が含まれることに注意してください。このImporter 設定ファイルを後でインポート(再読み込み)する際には、設定内で参照されているライブラリのうち、少なくとも1つが利用可能である必要があります。つまり、Library Importerでソースライブラリとして利用できる状態になっている必要があります。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents