リジッド領域とフレックス領域の計画 - 標準モード

概略

この記事では、Altium Designerの標準リジッドフレックスモードの仕組みを、基板プランニングモードで分割線を使って基板領域を計画する方法を中心に解説します。PCBが標準モードと高度なリジッドフレックスモードのどちらを使用しているかを確認する方法、標準的なワークフローで分割線によって基板領域を分ける仕組み、設計の進行に合わせて分割線を配置、移動、削除する方法を学べます。また、レイヤースタックの割り当て、領域名の変更、基板外形の定義や再定義についても説明し、リジッド領域とフレックス領域を最初から適切に構成できるようにします。Altium Designerでシンプルなリジッドフレックス基板の領域計画を管理するための実践的なガイドをお探しなら、この記事を通じて操作への理解と自信を深め、レイアウト作業を円滑に進めることができます。

- 標準リジッドフレックスモードと高度なリジッドフレックスモードの主な違いと、PCBがどちらのモードを使用しているかをすばやく確認する方法を学びます。
- 分割線の配置、移動、削除を含め、標準モードで基板領域を作成・編集する基本的なワークフローを確認します。
- レイヤースタックの割り当て、領域名の変更、基板外形の定義を通じて、リジッド領域とフレックス領域を適切に設定する方法を理解します。
AIでさらに深掘り:

AltiumのPCB設計ソフトウェアでは、2つのリジッドフレックス設計モードを使用できます。従来の標準モードであるRigid-Flexは、シンプルなリジッドフレックス設計に対応しています。フレックス領域の重なりなど、より複雑なリジッドフレックス要件がある設計では、Advanced Rigid-Flexモード(リジッドフレックス2.0とも呼ばれます)が必要です。モードは、レイヤースタックマネージャーのToolsメニューで選択します。

これらのモードの根本的な違いは、従来のモードでは、分割線を配置して基板外形を個別の基板領域に分割し、その分割線が、各基板領域の境界を定義するオブジェクトとして残る点です。Advancedモードでは、各基板領域を個別に配置します。また、大きな領域をスライスすると、2つの独立した領域オブジェクトになります。Advancedモードでは、分割線の有無ではなく、隣接する基板領域のエッジによって、2つの領域の境界が定義されます。この違いにより、Advanced Rigid-Flexモードの基板には分割線オブジェクトが存在しません。

► 詳細はこちら:リジッドフレックスPCBの設計

Viewメニューには、覚えやすいショートカットが割り当てられた3つのPCBエディター動作モードがあり、次のモードをすばやく切り替えることができます。

  • Board Planning Mode(1)
  • 2D Layout Mode(2)
  • 3D Layout Mode(3)

2D表示モードと3D表示モードを切り替える際、デフォルトでは、各表示モードのズームと向きの設定が個別に保持されます。切り替え時に基板の同じ位置を同じ向きで表示したい場合は、2または3の代わりに、 Ctrl+Alt+2 または Ctrl+Alt+3を押してください。

開いたPCBで、標準のリジッドフレックスモードと高度なリジッドフレックスモードのどちらが使用されているかを確認したい場合は、どうすればよいでしょうか。

レイヤースタックマネージャーを開いて確認できます。または、基板プランニングモード(ショートカット:1)に切り替えて、アクティブバーを確認してください。

標準のRigid-Flexモード
Advanced Rigid-Flexモード

分割線を配置すると、基板外形を2つの領域に分割できます。この操作は、PCBエディターをBoard Planning Modeにして行います。 基板領域とは分割線の間のエリアであり、デフォルトの領域名が割り当てられます。

分割線の配置

分割線を配置するには:

  1. View » Board Planning Modeを選択するか、ショートカット1を押して、Board Planning Modeに切り替えます。
  2. Design » Define Split Lineを選択して、分割線配置モードに入ります(キーを D, S の順に押すと、このコマンドにすばやくアクセスできます)。
  3. 基板外形のwithinをクリックして、分割線の定義を開始します。線の一端は、クリックした位置に最も近い基板外形の輪郭上の点に接続され、もう一端はカーソルに追従します。
  4. カーソルを目的の位置に移動し、1回クリックしてもう一端を配置します。 位置が有効な場合、分割線は青色のままです。無効な位置(基板外形の外側など)では、分割線が赤色になります。赤色の状態でクリックして配置しようとすると、分割線は削除されます。
  5. 分割線配置モードは継続され、必要に応じて別の分割線を配置できます。配置を終了するには、右クリックするか、 Esc を押して分割線配置モードを終了します。

基板領域とは分割線の間のエリアであり、デフォルトの領域名が割り当てられます。

基板外形のあるエッジから別のエッジまで延びる分割線を配置すると、基板が個別の領域に分割されます。
基板外形のあるエッジから別のエッジまで延びる分割線を配置すると、基板が個別の領域に分割されます。

分割線を配置して、基板を複数の個別の領域に分割した例です。曲げ線も配置されています。
分割線を配置して、基板を複数の個別の領域に分割した例です。曲げ線も配置されています。

分割線の移動

分割線を移動するには:

  1. View » Board Planning Modeを選択するか、ショートカット 1を押して、Board Planning Modeに切り替えます。
  2. 線の端点の位置を変更するには、端点をクリックしたまま、基板外形の周囲にある目的の位置までドラッグします。カーソルの移動は、現在のスナップグリッドに制限されます。

編集した分割線の新しい位置に基づいて、基板領域が再定義されます。

有効な分割を維持できる位置へドラッグしている間、分割線は青色のままです。移動する端点の新しい位置が無効な場合、たとえば固定されている端点と同じ基板外形のエッジ上にある場合、分割線は赤色になります。線が赤色の状態で配置しようとすると、分割線は削除されます。

分割線の端点ノードを選択してドラッグし、基板領域の範囲を再定義します。
分割線の端点ノードを選択してドラッグし、基板領域の範囲を再定義します。

分割線の削除

分割線を削除するには:

  1. View » Board Planning Modeを選択するか、ショートカット 1を押して、Board Planning Modeに切り替えます。
  2. いずれかの端点をクリックしたまま、Deleteキーを押します。または、端点をクリックしたまま、分割線が赤色になる(無効な分割を示す)基板外形上の位置まで移動し、マウスボタンを離します。

アクティブな基板から既存の分割線を1本以上削除するには、 Board Planning Mode で、メインメニューの Design » Delete Split Line コマンドを使用することもできます。 コマンドを実行すると、カーソルが十字に変わり、分割線削除モードに入ります。分割線を削除するには、いずれかの端点(編集ハンドル)にカーソルを合わせ、クリックするか、 Enterを押します。同じ方法で他の分割線を続けて削除できます。右クリックするか、 Esc を押すと、分割線削除モードを終了します。

レイヤースタックの割り当てと基板領域名の編集

Related page: レイヤースタックの定義

新しい基板を作成すると、Default Layer Stack Regionという名前の領域が1つ作成されます。この領域には、Board Layer Stackという名前のデフォルトのレイヤースタックが割り当てられます。

基板外形を複数の領域に分割すると、新しい各領域にもデフォルトのレイヤースタックが割り当てられます。元の領域には Default Layer Stack Regionという名前が付けられ、それ以降の領域には Layer Stack Regionという形式で名前が付けられます。 必要なレイヤースタックがレイヤースタックマネージャーで定義されていれば、各領域にスタックを割り当て、わかりやすい名前を付けることができます。

各領域には、その領域名と割り当てられたレイヤースタック名を Region Name - Layer Stack Nameの形式で示すラベルが表示されます。レイヤースタックのフレックス設定が有効な場合は、(flex)も表示されます。スタックのフレックス設定は、Layer Stack Managerで有効にします。

レイヤースタックを割り当て、領域に名前を付けるには:

  1. View » Board Planning Modeを選択するか、ショートカット 1を押して、Board Planning Modeに切り替えます。
  2.  Multi-Layerをクリックします。ワークスペース下部のタブをクリックして、アクティブレイヤーにします(レイヤータブが表示されていない場合は、Lを押してView Configurationパネルを開き、表示を有効にします)。
  3. 基板領域をダブルクリックして、Board Regionダイアログを開きます。領域が選択されず、ダイアログも開かない場合は、Selection FilterでRegionsが除外されていないことを確認してください。
  4. Layer stackドロップダウンから必要なスタックを選択して、レイヤースタックを割り当てます。
  5. 必要に応じてNameを編集します。
  6. 3D表示モードで物理的なグラウンド基準を定義するために、いずれか1つの基板領域で 3D Locked オプションを有効にする必要があります。
  7. OKをクリックして設定を確定し、ダイアログを閉じます。

基板領域をダブルクリックして、領域の名前を定義し、レイヤースタックを割り当てます。
基板領域をダブルクリックして、領域の名前を定義し、レイヤースタックを割り当てます。

Board Regionダイアログは、PCBパネルのLayer Stack Regionsモードで、目的のスタックアップ領域をダブルクリックして開くこともできます。Board Planning Modeに切り替えると、PCBパネルは自動的にこのモードで表示されます。

基板外形の分割による領域作成の概要

分割線を配置すると、基板形状が個別の基板領域に分割されます。基板形状を定義する方法はいくつかあります。以下の動画では、メカニカルレイヤー上の線と円弧で作成した外形を使用する方法を紹介しています。全体の外形を定義した後、それをリジッド領域とフレックス領域に分割します。

基板形状と領域の定義:

  • 基板形状は、Board Planning Mode(View » Board Planning Mode)で対話的に定義することも、上の動画で示すように2Dレイアウトモード(View » 2D Layout Mode)で既存の外形に基づいて定義することもできます。
  • 既存の外形から基板形状を定義するには、2Dレイアウトモードで外形を選択し、Design » Board Shape » Define Board Shape from Selected Objectsコマンドを実行します。ソフトウェアは、選択されたトラック/円弧オブジェクトの中心線に沿ってトレースし、基板形状の外周を定義します。トレースアルゴリズムが中心線をたどれるようにするには、外形を構成するトラック/円弧の端点が一致している必要があります。トレースに失敗した場合は、選択したオブジェクトの外周に沿ってトレースを試みるかどうかを確認するメッセージが表示されます。
  • 基板形状を対話的に定義するには、Board Planning Mode(ショートカット:1)に切り替え、Design » Redefine Board Shapeコマンドを選択します。基板形状の定義には、標準の領域オブジェクトの配置操作が適用されます。スナップグリッドとワークスペースのガイドを活用して作業を進めてください。基板形状をより正確に編集できるように、 Snap OptionsパレットでBoard Shapeオプションを有効にします。詳細は、スナップ動作についてを参照してください。
  • 各領域のNameを定義し、Layer stackを割り当てるには、その領域をダブルクリックします。または、PCBパネルをLayer Stack Regionsモードに設定すると、領域と曲げ線を確認、編集できます。
  • 基板領域を2つの小さな領域に分割するには、Design » Define Split Lineコマンドを使用します。このコマンドは、2つのクリック位置の間に直線を配置します。基板形状の内部をクリックすると、クリックした位置に最も近い基板端が最初の位置になります。カーソルを移動して2つ目の位置を指定し、もう一度クリックします。分割線の頂点をクリックしたままドラッグすると、新しい位置に移動できます。
  • 既存の基板領域の位置と形状は編集できます。Design Design » Edit Board Shapeコマンドを実行し、標準のポリゴンオブジェクトの編集手法を使用して形状を調整します。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents