データベースおよびファイルベースのライブラリからのフットプリントの更新

概略

この記事では、Altium Designerの「Update From PCB Libraries」ツールを使用して、PCB上に配置済みのフットプリントをライブラリ内の元のフットプリントと比較し、差異を特定して詳細を確認したうえで、ECOを通じて更新を適用する方法を説明します。また、ファイルベースやデータベースのライブラリをソースとする場合など、このコマンドを使用できるケースと、Workspaceのリビジョン更新に関する一部のケースなど、使用できないケースについても解説します。比較オプションの設定方法、一致・不一致の結果の読み取り方、比較レポートの生成方法に加え、PCBライブラリエディターから配置済みフットプリントを直接更新する方法も紹介します。PCBのフットプリントと承認済みライブラリとの整合性を、より明確かつ確実に管理する方法をお探しの方は、ぜひ読み進めてください。

- 「Update From PCB Libraries」を使用すべきケースと、別の更新方法が必要なケースを理解します。
- PCB上に配置済みのフットプリントを元のライブラリのフットプリントと比較し、差異の詳細を確認して、更新する内容を選択する方法を学びます。
- フットプリントの比較レポートを生成し、Engineering Change Order(ECO)プロセスを通じて承認済みの変更を適用する方法を確認します。
AIでさらに深掘り:

こちらで説明している Update From Libraries コマンドと Update Selected From Libraries コマンドは、回路図シートに配置されたコンポーネントの更新にのみ使用されます。更新にモデルを含めることもできますが、対象となるのはモデルのリンクであり、リンクされたモデルの実際のグラフィカル属性ではありません。ソースのPCBフットプリントライブラリで行ったPCBフットプリントのグラフィカル属性の変更を反映するには、Altium Designerに用意されている別の更新ツール、Update From PCB Libraries を使用する必要があります。この更新ツールは、各フットプリントのプリミティブを物理的に比較することで、基板上のコンポーネントフットプリントをソースのPCBフットプリントライブラリ内の対応するフットプリントと照合し、必要に応じて選択したコンポーネントを更新します。これにより、設計内のすべてのフットプリントが承認済みのフットプリントライブラリに準拠していることを保証できます。

このコマンドは、ファイルベースおよびデータベースライブラリ、つまりPCBフットプリントライブラリ(*.PcbLib)、統合ライブラリ(*.IntLib)、データベースライブラリ(*.DbLib、*.SVNDbLib)をソースとするPCBコンポーネントを対象とします。データベースライブラリの場合、更新には、リンクされた外部データベースの対応するレコードで参照されているライブラリが使用されます。フットプリントの取得元となるライブラリへの参照は、該当する回路図が利用可能な場合はそこから取得され、そうでない場合はPCBフットプリント自体から取得されます。すべてのソースライブラリが、利用可能なライブラリのセットに含まれている必要があります。

PCB設計で使用しているPCBフットプリントのソースがWorkspaceライブラリで、そのライブラリ内でフットプリントが更新されている場合(かつ、関連するコンポーネントも新しいリビジョンのフットプリントを使用するように更新されている場合)、Update From PCB Libraries コマンドは適用されません。PCBフットプリントをWorkspaceに保存すると新しいリビジョンが作成されますが、PCB設計内のフットプリントは引き続き以前のリビジョン(現在の最新ではない古いリビジョン)を参照しているためです。この場合にPCB上のフットプリントを更新するには、まず回路図内の関連コンポーネントを更新し(詳細はこちら)、次に回路図エディターの Design » Update PCB Document コマンドと、それに続くECOプロセスを使用してPCBを更新します。これにより、PCB設計内のフットプリントが最新のリビジョンに更新されます。

Workspaceライブラリのコンポーネントをソースとする配置済みフットプリントに、PCB設計内で「ローカル」な変更(たとえば、パッドプロパティの変更や、フットプリントのプリミティブのロック解除と変更)が加えられている場合は、Update From PCB Libraries コマンドを使用して、配置済みフットプリントとライブラリ内のフットプリントの差異を検出し、配置済みフットプリントを更新できます(実質的には「ローカル」な変更を取り除きます)。

このツールの使い方を説明するため、以下のコンポーネントフットプリントを例に考えます。これらはPCBドキュメント上にすでに配置されているフットプリントです。右側には、ソースのPCBフットプリントライブラリ(*.PcbLib)にある変更済みのフットプリントを示しています。変更はわずかで、上のフットプリントでは「記号の位置」が移動し、下のフットプリントでは「記号と円弧」の線幅が太くなっていますが、ここでの説明には十分です。

PCBドキュメント上の既存のフットプリント(左の画像)と、ソースのPCBフットプリントライブラリ内の変更済みフットプリント(右の画像)
PCBドキュメント上の既存のフットプリント(左の画像)と、ソースのPCBフットプリントライブラリ内の変更済みフットプリント(右の画像)

更新オプションの設定

更新は、PCBドキュメントから、メインの Tools メニューにある Update From PCB Libraries コマンドを使用して実行します。このコマンドを実行すると、Update From PCB Libraries - Options ダイアログが開きます。このダイアログでは、Layers To Include 領域の Include チェックボックス、または Include All ボタンのドロップダウンメニューのコマンドを使用して、PCBとライブラリのフットプリントのどのレイヤーを比較するかを選択します。設計によってはフットプリントの一部のレイヤーが使用されておらず、余分な比較を行うと処理時間が増えるため、この設定は重要です。

アクティブなPCBドキュメントで、カーソルの下にあるコンポーネントのフットプリント(または現在選択されているコンポーネント)を確認するには、配置済みの未選択コンポーネント、または選択済みコンポーネント(複数選択されたコンポーネントの1つでも可)の上で右クリックし、コンテキストメニューから Component Actions » Update Current Components From PCB Libraries コマンドを選択します。

Update From PCB Libraries - Options ダイアログ
Update From PCB Libraries - Options ダイアログ

この時点で、すべてのフットプリントをソースライブラリ内のフットプリントと一致するように更新したい場合は、Update All Footprints (Create ECO) ボタンをクリックし、続いて表示されるEngineering Change Order(ECO)を通じて設計に変更を適用するだけです。一方、ECOを生成する前に、検出された差異を詳しく確認して更新対象のフットプリントを決めたい場合は、OK  をクリックして Update From PCB Libraries ダイアログを開きます。詳細は以下を参照してください。

比較結果の表示

Update From PCB Libraries - Options ダイアログで必要なオプションを設定したら、OK をクリックします。比較が実行され、その結果が続いて表示される Update From PCB Libraries ダイアログに示されます。

Update From PCB Libraries ダイアログ
Update From PCB Libraries ダイアログ

ソースのPCBライブラリは、ソース回路図内の対応するコンポーネントに関連付けられたPCBモデルリンクから特定されます。ソースライブラリは、利用可能なファイルベースライブラリに含まれている必要があります。フットプリントのソースが見つからない場合、そのフットプリントは不一致としてマークされます。

ダイアログは、主に2つのセクションに分かれています。上部の Part List 領域には比較結果が表示されます。PCB上の各コンポーネントのフットプリントが、表示されているソースライブラリ内の対応するフットプリントと比較されます。最上部のヘッダー行には、一致した項目の概要が表示されます。フットプリント内の各プリミティブの比較結果が指定された許容範囲内であれば、フットプリントは一致していると判断され、Match 列に緑色のチェックアイコン()が表示されます。一致している場合、更新は不要です。

一方、フットプリント内の1つ以上のプリミティブの位置が許容範囲を超えている場合、そのフットプリントは不一致としてマークされます。Match 列には赤いバツ印のアイコン()が表示されます。配置済みコンポーネントのフットプリントとソースライブラリのフットプリントを再び同期させるには、更新が必要です。

ソースライブラリ内にフットプリントが見つからない場合、比較対象のライブラリコンポーネントの Path  フィールドに <Footprint not found> と表示されます。この場合、そのコンポーネントの比較は実行できません。

フットプリントが一致しない各コンポーネントには、対応する Update オプションがあります。デフォルトでは、一致しないコンポーネントはすべて自動的に更新対象に含まれます。Altium Designerの他の操作と同様に、選択権は常にユーザーにあります。チェックボックスをオフにするか、Include All ボタンのドロップダウンメニューのコマンドを使用して、不一致のコンポーネントを更新対象から除外できます。

ダイアログ下部の Difference Details 領域には、上部の領域で現在選択されている(一致しない)コンポーネントのプリミティブ間で検出された差分が一覧表示されます。 一致しないフットプリントについては、差分の原因となっているコンポーネントプリミティブが、比較対象として有効になっているレイヤーごとに一覧表示されます。この領域の上部にあるタブを使用して、すべてのレイヤーの差分、または特定のレイヤーの差分を確認できます。 Component Primitives causing Differences for 領域には、差分の原因となったコンポーネントプリミティブが左側に一覧表示され、そのデータが右側に表示されます。 表示される情報は次のとおりです。

  • Object Type - オブジェクトの種類。
  • Identifier - 特別なデジグネーター情報。
  • Detail - コンポーネントプリミティブの詳細。

フットプリントをセルに分割したグラフィカルな比較が表示されます。 Highlight Cell Density スライダーバーを使用して、表示領域内のセルのサイズを大きく(右方向)または小さく(左方向)できます。差分があるセルはフルカラーで表示され、差分がハイライトされます。現在のPCB内のプリミティブオブジェクトはフルカラーで表示され、ライブラリの更新されたコンポーネントプリミティブは、その上に「ゴースト」イメージとして重ねて表示されます。

  • 選択したPCBコンポーネントのフットプリントとライブラリのフットプリントの間にフットプリントパラメーターの差分がある場合、ダイアログの Difference Details 領域に、パラメーターの差分を一覧表示する Parameters タブが表示されます。

  • 選択したPCBコンポーネントのフットプリントとライブラリのフットプリントの間に、パッドデジグネーターまたは3Dボディの差分がある場合(PCB上でフットプリントをミラー反転した場合など)、ダイアログの Difference Details 領域に、パラメーターの差分を一覧表示する Properties タブが表示されます。

  • 選択したPCBコンポーネントのフットプリントとライブラリのフットプリントの間に差分がない場合、この領域のタイトルは No Difference For [Designator name (Footprint Name)] となり、選択したレイヤータブに対応する、選択中のコンポーネントが表示されます。

  • Part List の Path 列 に <Footprint not found> と表示される場合、Difference Details 領域のヘッダーには、フットプリントが見つからなかったことが示されます。

比較レポートの生成

フットプリント比較レポート(フットプリント比較 - PCBDocumentName.html)を作成するには、Update From PCB Libraries ダイアログの左下にある Create Report ボタンをクリックします。レポートには次の情報が含まれます。

  • 一致しないコンポーネントの一覧
  • 一致するコンポーネントの一覧
  • 一致しないコンポーネント一覧に含まれる各コンポーネントのプリミティブの差分詳細。

フットプリント比較レポート
フットプリント比較レポート

比較レポートを生成すると、Update From PCB Libraries ダイアログが閉じます。再度コマンドを実行する必要があります。

フットプリント比較レポートは、出力ジョブ設定ファイルの検証出力の一部として追加することもできます。

更新の実行

更新内容に問題がなければ、Accept Changes (Create ECO) ボタンをクリックします。開いた Engineering Change Order ダイアログで更新内容を検証し、更新を実行します。適用したくない変更は無効にしてください。変更が適用され、更新対象のコンポーネントのフットプリントが、ソースライブラリのフットプリントに更新されます。

フットプリントの更新を検証および実行する準備が整った Engineering Change Order ダイアログ
フットプリントの更新を検証および実行する準備が整った Engineering Change Order ダイアログ

ECOを通じて意図しないフットプリントのミラー反転を修正すると、配置済みフットプリントインスタンスのミラー反転が解除され、ソースライブラリで定義されている状態と同じになります。 修正の適用時には、ミラー反転に関連する要素(ピン、オーバーレイ、3Dボディ)のみが対象となることに注意してください。回転など、配置済みコンポーネントのフットプリントに加えられたその他の変更は、そのまま維持されます。

PCBライブラリエディターから直接変更を適用する

ソースPCBライブラリ内から、配置済みPCBフットプリントを直接更新できます。この更新方法は、独立したPCBフットプリントライブラリ(*.PcbLib)から配置されたコンポーネントを更新する場合で、それらのライブラリがプロジェクトで利用可能なファイルベースのライブラリに含まれている場合に特に適しています。

ソースPCBライブラリ内の1つ以上のコンポーネントフットプリントに加えた変更は、PCB上に配置された対応するフットプリントのインスタンスに直接反映できます。PCBライブラリエディターのメインの Tools メニューには、現在のフットプリントのみを更新するコマンド(Update PCB With Current Footprint)と、すべてのフットプリントを更新するコマンド(Update PCB With All Footprints)があります。これらのコマンドには、PCB Libraryパネルの右クリックメニューからもアクセスできます。

ソースPCBライブラリから、PCB Library パネルの右クリックメニューを使用して変更を適用できます
ソースPCBライブラリから、PCB Library パネルの右クリックメニューを使用して変更を適用できます

開いているすべてのPCBドキュメント内に配置されている該当コンポーネントフットプリントのすべてのインスタンスが、所属するプロジェクトに関係なく更新されます。基本的に、配置済みコンポーネントのフットプリント名がライブラリコンポーネントの名前と同じであれば、更新されます。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents