Multi-channel 설계하기

개요

이 문서에서는 Altium Designer의 멀티 채널 설계 기능을 활용해 반복되는 회로 구간을 한 번만 작성하고, 소프트웨어가 부품, 네트 및 PCB로의 전송을 자동으로 관리하면서 설계 전체에 해당 구간을 반복 배치하는 방법을 설명합니다. 동적 컴파일과 통합 데이터 모델이 이 과정을 어떻게 지원하는지, 반복된 시트 심볼이나 Repeat 키워드로 채널을 생성하는 방법은 무엇인지, 명명 규칙과 룸, 연결 설정이 최종 결과를 체계적으로 구성하는 데 어떻게 도움이 되는지 살펴봅니다. 반복되는 회로 블록을 더 효율적으로 구성하는 방법과 Altium Designer가 회로도에서 PCB에 이르기까지 이를 처리하는 방식을 이해하고 싶다면, 이 문서를 통해 기초를 다질 수 있습니다. 각 요소가 어떻게 맞물려 작동하는지 계속 읽어보세요.

- 반복 회로도 작성부터 PCB 레이아웃을 위한 자동 확장까지, Altium Designer에서 멀티 채널 설계가 작동하는 방식
- 여러 시트 심볼로 채널을 생성하는 방식과 Repeat 키워드를 사용하는 방식의 차이점
- 명명, 컴파일, 룸 및 연결 설정이 체계적인 설계에서 반복 채널을 지원하는 방식
AI로 더 깊이 알아보기:

전자 설계에 반복되는 회로 구간이 포함되는 것은 흔한 일입니다. 스테레오 증폭기일 수도 있고, 64채널 믹싱 콘솔일 수도 있습니다. 이러한 유형의 설계는 multi-channel design라는 기능 모음을 통해 완벽하게 지원됩니다.

비디오 멀티플렉서의 두 디코더 채널입니다. 멀티채널 설계 구조를 사용하면 디코더 채널을 한 번만 작성하면 됩니다.
비디오 멀티플렉서의 두 디코더 채널입니다. 멀티채널 설계 구조를 사용하면 디코더 채널을 한 번만 작성하면 됩니다.

멀티채널 설계에서는 반복되는 회로를 한 번 작성한 다음, 소프트웨어가 필요한 횟수만큼 반복하도록 지정합니다. 설계가 자동으로 컴파일되면 사용자 정의 채널 명명 규칙에 따라 모든 컴포넌트와 연결이 필요한 횟수만큼 반복되어 메모리에서 확장됩니다.

작성한 Logical 설계는 실제로 평탄화되지 않으며, 소스는 항상 멀티채널 Schematic으로 유지됩니다. 이를 PCB 레이아웃으로 전송하면 Physical 컴포넌트와 Net이 필요한 횟수만큼 자동으로 생성됩니다. Schematic과 PCB 간 작업에 사용할 수 있는 표준 교차 탐색 및 교차 선택 도구를 모두 활용할 수 있습니다. 또한 PCB Editor에는 한 채널의 배치와 라우팅을 다른 모든 채널에 복제하는 도구가 있으며, 채널 전체를 손쉽게 이동하고 방향을 변경할 수도 있습니다.

동적 컴파일

Related page: 설계 프로젝트 유효성 검사

설계 연결 모델은 사용자가 작업할 때마다 동적 컴파일을 통해 점진적으로 업데이트됩니다. 컴파일은 자동으로 수행되므로 프로젝트를 수동으로 컴파일할 필요가 없습니다. 설계 프로젝트의 자동 컴파일 프로세스는 다음 세 가지 기능을 수행합니다.

  1. 설계 계층 구조를 인스턴스화합니다.
  2. 모든 설계 시트 간의 Net 연결을 설정합니다.
  3. 설계의 내부 통합 데이터 모델(Unified Data Model, UDM)을 구축합니다.

이를 통해 모든 설계 변경 사항이 Navigator 및 Projects Panel에 즉시 반영됩니다.

컴파일된 프로젝트 모델을 통합 데이터 모델(UDM)이라고 합니다. UDM에는 설계에 포함된 모든 컴포넌트에 대한 상세 설명과 각 컴포넌트가 서로 연결된 방식이 포함됩니다.

UDM과 컴파일러 설정 간의 Logical 오류, 전기적 오류 및 도면 작성 오류를 확인하려면 프로젝트 유효성 검사를 수행해야 합니다. 이 명령은 기본 메뉴에서 Project » Validate Project 명령을 선택하거나, Projects Panel에서 프로젝트 항목을 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Validate Project 명령을 선택하여 실행할 수 있습니다.

컴파일러가 감지한 위반 사항은 Messages Panel에 경고 및/또는 오류로 표시됩니다. 컴파일러는 소스 문서의 위반 사항을 검사할 때 프로젝트 유형에 따라 Options for Project 대화 상자의 오류 보고 및 Connection 매트릭스 탭에 정의된 옵션을 사용합니다.

통합 데이터 모델

멀티채널 설계를 이해하려면 설계 데이터가 어떻게 관리되는지 이해하는 것이 도움이 됩니다. 소프트웨어의 핵심 요소 중 하나는 통합 데이터 모델(UDM)입니다. 프로젝트가 자동으로 컴파일되면 설계 프로세스의 중심이 되는 하나의 일관된 모델이 생성됩니다. 이후 소프트웨어 내의 다양한 Editor와 서비스를 통해 모델의 데이터에 접근하고 이를 조작할 수 있습니다. UDM은 각 설계 영역에 별도의 데이터 저장소를 사용하는 대신, 컴포넌트와 그 연결을 비롯해 설계의 모든 측면에 걸친 정보를 수용하도록 구성되어 있습니다.

통합 데이터 모델은 모든 Editor에서 모든 설계 데이터를 사용할 수 있게 하며, 멀티채널 설계와 같은 고급 기능을 구현하는 데 기여합니다.
통합 데이터 모델은 모든 Editor에서 모든 설계 데이터를 사용할 수 있게 하며, 멀티채널 설계와 같은 고급 기능을 구현하는 데 기여합니다.

UDM은 계층적 설계 시스템과 함께 활용되어 멀티채널 설계 기능을 제공합니다. "채널"은 시트 심볼 내의 회로를 의미합니다. 이 시트 심볼 아래에는 싱글 시트가 있을 수도 있고, 다른 하위 시트들을 포함하는 프로젝트 구조의 전체 분기가 있을 수도 있습니다. 채널 안에 채널을 만들 수도 있습니다. 2단계 멀티채널 설계에서는 상위 채널을 뱅크라고 하고 하위 채널을 채널이라고 합니다.

이처럼 PCB에 바로 사용할 수 있는 완전한 설계 정보가 메모리에 존재하므로, 컴포넌트 Designator와 Net 같은 반복 객체를 체계적으로 처리할 방법만 있다면 회로의 일부를 반복할 수 있습니다. 체계적인 명명 방식은 Options for Project 대화 상자의 멀티채널 탭에서 정의하며, 아래에서 설명합니다.

멀티채널 설계 만들기

회로의 일부가 반복되면 해당 설계는 멀티채널 설계가 됩니다. 이는 시트 심볼 수준에서 다음 중 한 가지 방식으로 구현합니다.

  • 동일한 하위 Schematic을 참조하는 여러 시트 심볼을 배치하거나
  • 참조하는 하위 Schematic을 필요한 횟수만큼 반복하도록 싱글 시트 심볼을 구성합니다.

첫 번째 이미지에는 동일한 하위 시트(PortIO.SchDoc)를 참조하는 시트 심볼이 4개 있습니다. 두 번째 이미지에서는 Repeat 키워드를 사용하여 InputChannel.SchDoc을 8회, OutputChannel.SchDoc을 2회 반복합니다.
첫 번째 이미지에는 동일한 하위 시트(PortIO.SchDoc)를 참조하는 시트 심볼이 4개 있습니다. 두 번째 이미지에서는 Repeat 키워드를 사용하여 InputChannel.SchDoc을 8회, OutputChannel.SchDoc을 2회 반복합니다.

위 이미지는 멀티채널 설계를 만드는 두 가지 방법을 보여줍니다. 첫 번째 이미지에는 동일한 하위 시트(PortIO.SchDoc)를 참조하는 시트 심볼이 4개 있습니다. 두 번째 이미지에서는 시트 심볼의 Designator 필드에 Repeat 키워드를 넣어 InputChannel.SchDoc을 8회, OutputChannel.SchDoc을 2회 반복합니다.

프로젝트에서 반복되는 컴포넌트 Designator와 Net 이름은 표준 명명 규칙을 사용하여 구분합니다. 예를 들어, 아래 이미지에서 강조 표시된 것처럼 반복되는 컴포넌트와 Net 식별자(Net 레이블 및 포트)에 채널 인덱스를 추가하는 명명 규칙을 사용할 수 있습니다.

프로젝트를 열면 Schematic 하단에 표시되는 탭을 확인하세요. Editor 탭에는 작성한 그대로의 Logical 설계가 포함되어 있으며, PCB Editor로 전송될 Physical 설계를 나타내는 다른 컴파일된 탭(COUT1 및 COUT2)도 표시됩니다. 각 Physical 채널마다 탭이 하나씩 있습니다.

컴파일된 프로젝트에는 Logical 보기 탭과 PCB로 전송되는 각 Physical 채널의 탭이 표시됩니다. 반복되는 Designator와 Net 식별자가 어떻게 관리되는지 확인하세요.
컴파일된 프로젝트에는 Logical 보기 탭과 PCB로 전송되는 각 Physical 채널의 탭이 표시됩니다. 반복되는 Designator와 Net 식별자가 어떻게 관리되는지 확인하세요.

채널 명명 규칙은 Options for Project 대화 상자의 멀티채널 탭에서 정의합니다.

Repeat 키워드

앞서 설명했듯이, 동일한 하위 시트를 참조하는 여러 시트 심볼을 배치하거나 시트 심볼의 Designator 필드에 Repeat 키워드를 넣어 채널을 반복할 수 있습니다. Repeat 키워드를 사용하면 시트 심볼이 여러 개 겹쳐진 형태로 표시됩니다.

Repeat 문은 채널 Designator와 채널 수를 정의합니다. 반복되는 채널임을 나타내기 위해 시트 심볼이 여러 심볼을 겹친 형태로 표시되는 점에 주목하세요.
Repeat 문은 채널 Designator와 채널 수를 정의합니다. 반복되는 채널임을 나타내기 위해 시트 심볼이 여러 심볼을 겹친 형태로 표시되는 점에 주목하세요.

각 채널은 시트 심볼의 Designator에서 가져온 채널 Designator로 식별됩니다. 여러 시트 심볼을 배치하여 설계를 채널화한 경우, 채널 Designator는 각 시트 심볼에 정의된 Designator 값입니다. Repeat 키워드를 사용하여 설계를 채널화한 경우, 채널 Designator는 Repeat 키워드로 정의된 ChannelIdentifier+ChannelIndex입니다.

Repeat 키워드를 사용할 때 Designator 필드의 구문은 다음과 같습니다.

Repeat(<ChannelIdentifier>,<ChannelIndex_1>,<LastChannelIndex_n>)

Project Options 대화 상자의 Options 탭에서 New Indexing of Sheet Symbols 옵션을 활성화하면, 반복되는 시트 심볼의 첫 번째 또는 마지막 인덱스로 0을 포함한 모든 숫자를 사용할 수 있습니다. 마지막 인덱스는 항상 첫 번째 인덱스보다 커야 하며, 음수는 사용할 수 없습니다.

멀티채널 명명

한 번 작성한 후 반복해서 사용하는 멀티채널 설계 개념은 소프트웨어의 통합 데이터 모델(UDM)을 기반으로 구현됩니다. 반복되는 컴포넌트에는 체계적인 명명 규칙에 따라 이름이 지정되며, 이 규칙은 아래와 같이 Options for Project 대화 상자의 Multi-Channel 탭에서 설정합니다.

이 대화 상자의 상단 영역에서는 Room의 이름을, 하단 영역에서는 해당 Room 내 컴포넌트의 이름을 제어합니다. Room 수준에서는 2가지 평면형 명명 스타일과 3가지 계층형 명명 스타일을 사용할 수 있습니다. 일반적으로 설계의 채널 안에 다른 채널이 있는 경우에만 계층형 명명 스타일을 선택하면 됩니다. 그 외에는 평면형 Room 명명 스타일이 더 간결하고 이해하기 쉽습니다.

컴포넌트 명명에는 $Component$ChannelAlpha 또는 $Component_$ChannelIndex 옵션을 사용하면 가장 짧고 쉽게 이해할 수 있는 컴포넌트 식별자를 얻을 수 있습니다. 사용 가능한 키워드를 사용하여 고유한 Designator 명명 규칙을 구성할 수도 있습니다.

반복되는 컴포넌트와 Net은  Project Options 대화 상자의 Multi-Channel 탭에서 선택한 체계적인 명명 규칙을 적용하여 관리합니다.
반복되는 컴포넌트와 Net은 Project Options 대화 상자의 Multi-Channel 탭에서 선택한 체계적인 명명 규칙을 적용하여 관리합니다.

  • 컴포넌트뿐 아니라 각 채널 내의 Net을 고유하게 식별하는 데에도 Component Naming 규칙이 사용됩니다. 이 규칙은 Net 레이블과 포트를 비롯한 Net 식별자의 이름을 변경하는 데 사용됩니다.
  • Schematic 시트에서 이러한 이름을 표시하는 방법은 아래의 컴파일된 이름 표시 섹션에서 설명합니다.

Room의 역할

Room은 보드의 영역을 정의하는 데 사용되는 PCB 설계 객체로, 다음 두 가지 방식으로 사용할 수 있습니다.

  1. Contain objects - Room은 다른 다각형 객체처럼 배치되지만, 실제로는 배치 Design Rule로 생성됩니다. Room을 정의할 때는 해당 Room 안에 포함되어야 하는 객체를 지정하며, 이 객체는 대개 컴포넌트입니다. Room을 이동하면 그 안의 모든 컴포넌트도 함께 이동합니다.
  2. To scope other design rules - Room은 그 자체로 Rule일 뿐 아니라 다른 Design Rule의 적용 범위를 지정하는 데에도 사용할 수 있습니다. 예를 들어, 하나의 라우팅 폭 Design Rule이 특정 Net 클래스의 라우팅 폭을 정의하는 경우, 우선순위가 더 높고 적용 범위가 Room인 Design Rule을 사용하여 해당 Room 내의 동일한 Net 클래스에 다른 폭을 적용할 수 있습니다.

Room은 멀티채널 설계에 매우 유용합니다. Project Options 대화 상자의 Class Generation 탭에 있는 옵션에 따라, 설계를 Schematic Editor에서 PCB Editor로 전송할 때 각 시트 심볼에 대한 Room을 자동으로 생성할 수 있습니다. Room은 해당 채널의 컴포넌트를 한데 모을 뿐 아니라, 그 안의 컴포넌트 이름을 지정하는 데에도 사용할 수 있습니다. Room과 보드 설계 프로세스에서의 역할은 이 문서의 멀티채널 PCB 설계 섹션에서 자세히 설명합니다.

평면형 컴포넌트 번호 지정 방식을 선호한다면 보드 수준 어노테이션을 수행하여 체계적인 명명 규칙을 대체할 수 있습니다. 컴포넌트 Designator가 PCB로 구현될 전체 컴파일된 설계(Physical 설계)에만 적용되기 때문에 이를 보드 수준 어노테이션이라고 합니다.

멀티채널 설계의 연결성

멀티채널 설계에서는 Net Identifier Scope를 Automatic, Hierarchical 또는 Strict Hierarchical로 설정합니다. 소프트웨어는 설계를 컴파일할 때 이 구조 모델을 사용하여 메모리에 채널 인스턴스를 생성하므로, 멀티채널 설계는 반드시 계층 구조여야 합니다.

반복되는 채널에 연결되는 Net에 대해 소프트웨어가 지원해야 하는 연결 요구 사항은 두 가지입니다. Net은 다음 중 하나에 해당합니다.

  • 모든 채널에 공통으로 사용되거나
  • 각 채널에서 고유하게 사용됩니다.

이에 대한 지원 수준은 채널을 정의하는 데 사용한 방법(여러 시트 심볼 또는 Repeat 키워드)에 따라 달라집니다. 설계에서 여러 시트 심볼(채널마다 개별 시트 심볼)을 사용하는 경우, Net 연결은 설계자가 배치한 배선에 따라 명시적으로 정의됩니다.

이 설계에서는 Repeat 키워드를 사용하여 여러 채널을 생성합니다.
이 설계에서는 Repeat 키워드를 사용하여 여러 채널을 생성합니다.

설계에서 Repeat 키워드를 사용하는 경우 다음 연결 규칙이 적용됩니다.

Passing a Net to all Channels 모든 채널에서 Net을 사용할 수 있어야 한다면, 위 이미지에서 InputChannel.SchDoc 시트 심볼에 연결된 Monitor Net처럼 시트 Entry에 배선하기만 하면 됩니다. Effects, MB1, MB2 Net도 모든 채널에서 사용할 수 있습니다. 버스의 Net도 같은 방식으로 처리됩니다. 버스를 시트 Entry에 연결하면 해당 버스의 각 요소를 모든 채널에서 사용할 수 있습니다.
Passing a net to a Specific Channel 버스에서 각 채널에 하나의 Net을 할당하려면 시트 Entry에 Repeat 키워드를 사용합니다. 위 이미지의 Headphone 버스가 그 예이며, 시트 Entry의 이름은 Repeat(Headphone)입니다. 이 경우 Headphone1 Net은 CIN1 채널에 연결되고, Headphone2은 CIN2 채널에 연결되는 식입니다. Repeat 키워드를 사용하여 채널을 생성한 경우, 개별 Net을 특정 채널 하나에만 전달할 수는 없습니다. 이 기능이 필요하다면 채널마다 개별 시트 심볼을 배치해야 합니다.
Repeat 키워드를 사용할 때는 하니스를 채널에 전달하는 기능이 지원되지 않습니다.

Net 이름 지정 방식

최종적으로 각 Net은 PCB에서 하나의 이름만 가질 수 있습니다(하나의 PCB Net은 두 개의 이름을 가질 수 없습니다). 소프트웨어는 프로젝트에서 여러 이름을 가진 Net을 자동으로 처리하여 하나의 이름만 갖도록 합니다. 따라서 멀티채널 설계에서는 Net에 의미 있는 이름이 지정되도록 명명 옵션을 설정하는 것이 중요합니다. Net 명명 옵션은 Options for Project 대화 상자의 Options 탭에 있는 Netlist Options 섹션에 있습니다.

멀티채널 설계에서 이러한 옵션을 설정하는 좋은 방법은 Higher Level Names Take Priority 옵션을 활성화하고, 채널화된 하위 시트에 연결되는 모든 Net에 Net 레이블을 배치하는 것입니다.

예를 들어 아래 이미지를 살펴보겠습니다. 두 시트 심볼은 모두 PCB_Decoder.SchDoc 시트를 참조하므로, 이 회로에는 U_PCB_DecoderA와 U_PCB_DecoderB로 식별되는 2개의 채널이 있습니다.

시트 심볼에는 TDI이라는 시트 Entry가 포함되어 있으며, 이는 JTAG 바운더리 스캔 체인의 테스트 데이터 입력(Test Data In) 라인입니다. DecoderA의 TDO(Test Data Out)는 체인의 다음 장치에 있는 TDI에 연결되며, 이 장치는 DecoderB 채널에 있습니다.

두 디코더 채널은 동일한 Schematic인 PCB_Decoder.SchDoc를 참조하는 시트 심볼 두 개를 배치하여 생성합니다.
두 디코더 채널은 동일한 Schematic인 PCB_Decoder.SchDoc를 참조하는 시트 심볼 두 개를 배치하여 생성합니다.

프로젝트를 열면 Schematic 보기 하단에 채널 탭 U_PCB_DecoderA 및 U_PCB_DecoderB가 나타납니다. 이 탭에는 PCB Editor로 전달될 Physical 설계가 표시됩니다. 아래 이미지에서 왼쪽의 Editor 탭에는 작성된 디코더 회로의 Schematic이 표시되고, 이어서 해당 Schematic의 두 Physical 채널인 U_PCB_DecoderA 및 U_PCB_DecoderB이 표시됩니다.

원래 작성된 Schematic에서는 설계자가 Net에 TDI이라는 라벨을 지정했습니다(첫 번째 이미지). DecoderA 탭(두 번째 이미지)에서는 소프트웨어가 상위 수준의 Net 이름인 TDO_CONTROLLER을 적용한 것을 확인할 수 있습니다. 이 설계에서는 상위 수준의 Net 이름에 우선순위를 부여하도록 설정되어 있기 때문입니다. DecoderB에는 상위 수준의 이름이 정의되어 있지 않으므로, 원래 Net 이름인 TDI이 이 채널에서는 TDI_2로 식별됩니다(세 번째 이미지). 이는 Project Options 대화 상자의 다중 채널 탭에 정의된 명명 규칙에 따른 것입니다(Component Naming 규칙은 각 채널 내의 컴포넌트와 Net을 모두 식별하는 데 사용됩니다).

PCB_Decoder.SchDoc Schematic: 첫 번째 이미지 - 작성된 Schematic, 두 번째 및 세 번째 이미지 - 두 채널의 컴파일된 보기.
PCB_Decoder.SchDoc Schematic: 첫 번째 이미지 - 작성된 Schematic, 두 번째 및 세 번째 이미지 - 두 채널의 컴파일된 보기.

컴파일된 이름 표시

다중 채널 설계에서 Net을 추적하고 분석하는 작업은 혼란스러울 수 있습니다. 반복되는 Net을 식별하면서도 각 이름의 고유성을 유지하려면 이름을 변경해야 하기 때문입니다. 이를 돕기 위해 컴포넌트 Designator, Net 라벨, 전원 포트, 포트 등 컴파일된 객체 이름의 표시를 제어하는 다양한 옵션이 제공됩니다. 시트 번호와 문서 번호에 대한 옵션도 있으며, 이는 인쇄용 Output을 생성할 때 중요합니다.

컴파일된 객체 이름의 표시는 Preferences 대화 상자의 Schematic - 컴파일러 페이지에서 설정하며, 아래 이미지에 표시되어 있습니다.

컴파일된 객체 이름의 표시를 설정합니다. 위 첨자는 컴포넌트 Designator를 표시할 때 유용합니다.
컴파일된 객체 이름의 표시를 설정합니다. 위 첨자는 컴포넌트 Designator를 표시할 때 유용합니다.

일반적으로 Designator와 Net 라벨을 표시하는 것이 좋으며, 문제를 진단할 때는 포트 표시가 유용합니다. 시트 번호와 문서 번호도 중요하므로 올바르게 설정해야 합니다. 컴포넌트 및 시트 번호 지정에 관한 정보 링크는 설계 어노테이션 섹션에서 확인할 수 있습니다.

Preferences 대화 상자의 Schematic - Compiler 페이지에 있는 Net Labels 옵션도 전원 포트 객체의 확장을 결정한다는 점에 유의하십시오.

Display superscript if necessary 옵션을 선택하면 현재 문서 보기에 보이지 않는 보기의 객체 식별자가 위 첨자로 포함됩니다. 원하는 방식에 맞게 설정하십시오.

다중 채널 설계의 채널 2(CIN2) 보기. 원래 Logical Schematic의 Designator와 Net 이름이 위 첨자로 표시되는 것을 확인할 수 있습니다.
다중 채널 설계의 채널 2(CIN2) 보기. 원래 Logical Schematic의 Designator와 Net 이름이 위 첨자로 표시되는 것을 확인할 수 있습니다.

채널(Physical) 탭에서 일부 Schematic 요소가 흐리게 표시되는 이유가 궁금하신가요? 기본적으로 채널 탭에서 편집할 수 있는 객체는 일반 밝기로 표시되고, 편집할 수 없는 객체는 흐리게 표시됩니다. 흐리게 표시하는 정도는 Preferences 대화 상자의 System - Navigation 페이지에서 설정합니다. 객체를 흐리게 표시하면 채널 탭에서 Net 라벨을 이동하는 등 지원되지 않는 편집 작업을 시도하는 것을 방지하는 데 도움이 됩니다. 필요에 따라 흐림 수준을 설정하십시오.

여러 Net 이름 오류 해결

Schematic Editor의 오류 검사 옵션은 기본적으로 이름이 여러 개인 Net의 모든 사례를 표시하도록 설정되어 있습니다. 이는 의도적으로 이름을 변경할 때 발생할 수 있습니다. 예를 들어 Net이 시트 심볼로 들어갈 때 해당 시트 내에서는 다른 이름을 사용하려는 경우입니다. 아래 이미지는 이러한 예를 보여 줍니다. 최상위 시트에서는 Left 및 Right 출력이 버스로 묶여 있지만, 시트 엔트리에서는 Left 및 Right이라는 이름으로 지정되어 있습니다.

Repeat 키워드가 있는 하나의 시트 심볼로 두 출력 채널을 나타낼 수 있도록 버스를 사용했습니다. Left 및 Right 채널에 별도의 와이어를 사용했다면 설계자는 Left 및 Right 출력 채널에 대해 별도의 시트 심볼을 배치하고(둘 다 동일한 하위 Schematic 시트를 참조), 각 출력을 해당 출력 시트 심볼에 배선해야 했을 것입니다.

여러 Net 식별자를 처리하는 방법을 소프트웨어에 지정해야 합니다. 이를 위해 다음 중 하나를 수행해야 합니다.

  • Options for Project 대화 상자의 오류 보고 탭에서 Nets with multiple names 오류 검사를 No Report(으)로 설정합니다. 이 방법은 설계 전체에서 해당 오류 조건에 대한 검사를 모두 차단하므로 권장되지 않습니다. 또는 다음과 같이 할 수 있습니다.
  • Messages Panel에서 오류/경고를 마우스 오른쪽 버튼으로 클릭하고 Place Specific No ERC Marker for this violation 명령을 선택하여 해당 Net에 특정 No ERC 지시자를 배치합니다. 그러면 NoERC 객체 배치 모드로 전환되고, 미리 설정된 특정 NoERC 마커가 커서에 부착되어 오류가 있는 Net에 바로 배치할 수 있습니다. 배치한 후 두 번 클릭하여 스타일과 색상을 설정하십시오.

주황색 원으로 표시된 작은 삼각형에 주목하십시오. 이는 MB1 및 MB2 Net의 중복 Net 이름 오류를 비활성화하기 위해 배치한 특정 No ERC 마커입니다.
주황색 원으로 표시된 작은 삼각형에 주목하십시오. 이는 MB1 및 MB2 Net의 중복 Net 이름 오류를 비활성화하기 위해 배치한 특정 No ERC 마커입니다.

멀티보드 설계 어노테이션

설계 작성 과정의 핵심 작업 중 하나는 설계에 어노테이션을 적용하는 것입니다. 즉, 각 컴포넌트와 각 Schematic 시트에 고유한 식별자를 부여하는 작업입니다. 다중 채널 설계에서는 이 작업이 두 단계로 이루어집니다. 먼저 배치한 컴포넌트와 작성한 시트에 번호를 지정해야 합니다. 그런 다음 반복 채널에 의해 인스턴스화되는 컴포넌트와 시트에도 번호를 지정해야 합니다.

단일 수준의 컴포넌트 번호 체계를 선호한다면 보드 수준 어노테이션을 수행하여 체계적인 명명 규칙을 대체할 수 있습니다. 보드 수준 어노테이션이라고 부르는 이유는 컴포넌트 Designator가 PCB로 구현될 전체 컴파일된 설계(Physical 설계)에만 적용되기 때문입니다. 보드 수준 어노테이션을 수행하려면 먼저 Schematic 어노테이션을 수행해야 합니다. 이를 통해 다중 파트 컴포넌트가 패키지로 구성되고 각 컴포넌트가 고유한 식별자를 갖게 됩니다.

이러한 보드 수준 어노테이션은 각 Logical Designator를 할당된 Physical Designator에 매핑하는 .Annotation 파일에 저장됩니다. 이 파일은 프로젝트의 일부이므로 저장하라는 메시지가 표시됩니다.

다중 채널 설계에서 어노테이션을 수행하면 컴포넌트 Designator가 상당히 길어질 수 있으므로 PCB에서 Designator 문자열을 배치하기 어려울 수 있습니다. PCB에서는 Logical 또는 Physical Designator 표시 중에서 선택할 수 있습니다. 자세히 알아보기.
PCB Editor에서 대상 컴포넌트의 위치를 기준으로 Designator를 체계적으로 할당하려면 PCB 위치 기반 어노테이션을 사용할 수도 있습니다.

다중 채널 PCB 설계

Schematic Editor에서 PCB Editor로 설계를 전송할 때 프로젝트 옵션에서 룸 생성이 활성화되어 있으면 각 시트의 컴포넌트가 PCB 배치 룸에 모여 배치됩니다.

멀티채널 설계에서 룸을 사용하는 가장 큰 장점은 PCB Editor에서 한 룸(채널)의 배치와 라우팅을 다른 룸(채널)으로 복제할 수 있다는 것입니다. 또한 룸을 하나의 객체처럼 이동할 수 있어 PCB에서 채널을 배치하는 과정이 간편해집니다.

설계를 Schematic Editor에서 PCB Editor로 전송한 후의 입력 채널 8개와 출력 채널 2개입니다. 빨간색 영역이 룸입니다.
설계를 Schematic Editor에서 PCB Editor로 전송한 후의 입력 채널 8개와 출력 채널 2개입니다. 빨간색 영역이 룸입니다.

PCB 룸의 역할

룸은 보드의 영역을 정의하는 데 사용되는 PCB 설계 객체이며, 다음 두 가지 방식으로 활용할 수 있습니다.

  1. Contain objects - 룸은 다른 다각형 객체처럼 배치되지만, 실제로는 배치 Design Rule로 생성됩니다. 룸 정의에는 해당 룸 안에 포함되어야 하는 객체를 지정하는 내용이 포함되며, 이러한 객체는 대부분 컴포넌트입니다. 룸을 이동하면 그 안의 모든 컴포넌트도 함께 이동합니다.
  2. To scope other design rules - 룸은 그 자체로 Rule인 동시에 다른 Design Rule의 적용 범위를 지정하는 데에도 사용할 수 있습니다. 예를 들어 하나의 라우팅 폭 Design Rule이 특정 네트 클래스의 라우팅 폭을 정의하는 경우, 룸을 적용 범위로 지정한 더 높은 우선순위의 Design Rule을 사용하면 해당 룸 내에서 그 네트 클래스에 다른 폭을 적용할 수 있습니다.

룸은 멀티채널 설계에서 매우 유용합니다. Options for Project 대화 상자의 Class Generation 탭 옵션에 따라, 설계를 Schematic Editor에서 PCB Editor로 전송할 때 각 시트 심볼에 대해 룸을 자동으로 생성할 수 있습니다. 룸은 해당 채널의 컴포넌트를 한데 모아 줄 뿐만 아니라 룸 내부 컴포넌트의 이름을 지정하는 데에도 사용할 수 있습니다.

유용한 룸 조작 명령

  • Design » Rooms - 이 하위 메뉴에는 룸을 정의하고 수정하는 데 유용한 여러 명령이 있습니다.
  • Design » Rooms » Copy Room Formats - 이 명령을 사용하면 한 룸(채널)의 배치와 라우팅을 다른 룸(채널)으로 복제할 수 있습니다.
  • Design » Rooms » Move Room - 커서 아래에 다른 설계 객체가 없는 곳을 클릭한 상태로 드래그하면 룸을 이동할 수 있습니다. 커서는 가장 가까운 컴포넌트 Pad 또는 룸 꼭짓점 중 더 가까운 쪽으로 Snap됩니다. 설계 객체를 클릭하지 않고는 룸을 클릭한 상태로 유지할 수 없을 때 이 명령을 사용하십시오.
  • Edit » Select » Room Connections - 이 명령을 사용하면 Pad에서 시작하여 룸 내부에서 끝나는 모든 구리 세그먼트를 선택할 수 있습니다.

PCB에 Designator 표시하기

멀티채널 설계에서는 Designator 문자열이 상당히 길어질 수 있어 배치하기가 어려울 수 있습니다. 짧은 이름을 생성하는 명명 옵션을 선택하는 방법 외에, 원래의 Logical 컴포넌트 Designator만 표시하는 방법도 있습니다. 예를 들어 C30_CIN1은 C30로 표시됩니다. 이 경우 컴포넌트 오버레이에서 각 채널 주위에 상자를 그리는 등, 개별 채널을 구분할 수 있는 별도의 표시를 보드에 추가해야 합니다.

PCB Editor의 Properties 패널(View » Panels » Properties)에 있는 Other 섹션에서 PCB의 Designator 표시 방식을 Logical 또는 Physical 중에서 선택할 수 있습니다. 멀티채널 설계에서 컴포넌트의 Logical Designator를 표시하도록 선택하면 PCB뿐 아니라 인쇄물, Gerber 파일 등 생성되는 모든 Output에도 해당 Designator가 표시됩니다. 단, BOM을 생성할 때는 항상 고유한 Physical Designator가 사용됩니다.

► 컴포넌트 어노테이션에 대해 자세히 알아보기

파라미터 기반 멀티채널 계층 설계

현재 프로젝트의 시트 심볼을 회사에서 선호하는 전원 공급 장치 Schematic에 연결하는 것처럼 설계의 일부를 재사용할 때 어려운 점은 설계마다 컴포넌트 값이 항상 같지는 않다는 것입니다.

파라미터 기반 계층 설계는 이 문제를 해결합니다. 컴포넌트 값의 지정 위치를 Schematic 시트에서 해당 시트를 참조하는 시트 심볼로 옮길 수 있습니다. 이 기능은 멀티채널 설계에서도 완벽하게 작동하므로 채널마다 서로 다른 컴포넌트 값을 사용할 수 있습니다. 단, 컴포넌트 값이 시트 심볼에 저장되므로 각 채널에는 자체 시트 심볼이 있어야 합니다.

예를 들어 그래픽 이퀄라이저에서는 동일한 회로를 여러 번 반복하면서 채널 간에 컴포넌트 값만 다르게 사용할 수 있습니다. 따라서 커패시터는 채널에 따라 0.12µF, 0.056µF, 0.033µF의 값을 가질 수 있습니다. 각 채널을 참조하는 시트 심볼에 이러한 값을 지정하면 되므로 구현은 간단하며, 컴포넌트 값만 다른 유사한 Schematic을 여러 개 만들 필요가 없습니다.

파라미터 기반 컴포넌트는 상위 시트 심볼의 파라미터로 값을 선언한 다음, 타겟 컴포넌트에서 해당 파라미터를 참조하여 정의합니다. 아래 이미지의 왼쪽에는 그래픽 이퀄라이저의 최상위 시트가 표시되어 있으며, 그 옆에는 1KHz 시트 심볼의 파라미터가 표시되어 있습니다. 또한 작성된 하위 계층 Schematic과 컴파일된 1KHz 채널도 표시되어 있습니다(하단 탭에서 선택).

채널마다 서로 다른 커패시터 및 저항 값을 사용하는 그래픽 이퀄라이저입니다. 실제 컴포넌트 값은 시트 심볼에 정의되므로 하위 계층 Schematic은 하나만 작성하면 됩니다.
채널마다 서로 다른 커패시터 및 저항 값을 사용하는 그래픽 이퀄라이저입니다. 실제 컴포넌트 값은 시트 심볼에 정의되므로 하위 계층 Schematic은 하나만 작성하면 됩니다.

아래 이미지와 같이, 이러한 각 시트 심볼 파라미터는 하위 계층 시트에 있는 Schematic 컴포넌트 파라미터의 value으로도 정의됩니다. 각 시트 심볼 파라미터의 값은 해당 Schematic 컴포넌트로 전달된 후 컴포넌트의 Comment 필드에 매핑됩니다. 컴포넌트의 Comment 파라미터 대신 Value 파라미터를 직접 사용하여 Schematic 컴포넌트의 값을 표시하는 경우에는 시트 심볼 파라미터를 컴포넌트의 Value 파라미터(Value=C2_Value)에 매핑하고 표시되도록 설정하기만 하면 됩니다.

Value 파라미터의 값이 =C2_Value이므로, 컴파일러는 상위 수준의 시트 심볼에서 실제 컴포넌트 값을 찾아야 한다는 것을 인식합니다.
Value 파라미터의 값이 =C2_Value이므로, 컴파일러는 상위 수준의 시트 심볼에서 실제 컴포넌트 값을 찾아야 한다는 것을 인식합니다.

파라미터 기반 계층 구조는 컴포넌트 값에만 국한되지 않습니다. 모든 컴포넌트 파라미터뿐 아니라 Schematic 시트에 있는 다른 객체의 텍스트 레이블도 파라미터 방식으로 참조할 수 있습니다. 단, 컴포넌트 ID, 포트 객체, 문서 파일 이름과 같은 기본 연결 요소는 제외됩니다. 계층 구조에서 여러 시트 위에 있는 심볼의 파라미터를 참조하는 경우, 시스템은 일치하는 파라미터를 찾을 때까지 계층 구조를 검색합니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents