Синхронизация базы данных цепочки поставок с данными Workspace
Краткий обзор
- Узнайте, как создать конфигурацию синхронизации и подключить поддерживаемые источники данных.
- Разберитесь, как сопоставлять параметры поставщиков и ценовые уровни в зависимости от объема заказа, используя номер компонента производителя для привязки записей поставщиков к компонентам рабочего пространства.
- Узнайте, как запускать синхронизацию вручную или по расписанию и где найти полученные данные пользовательского поставщика компонентов в Altium Designer.
Благодаря концепции вариантов компонентов компоненты, размещенные в рабочем пространстве Altium 365 или рабочем пространстве Enterprise Server, можно связать с реальными позициями поставщиков на основе указанного компонента производителя. По умолчанию эти данные о цепочке поставок поступают из облачной службы Altium Parts Provider и включают актуальные сведения о позициях поставщиков, такие как складские остатки, цена за единицу и пороговые объемы для ценовых скидок.
Однако во многих организациях данные поставщиков компонентов поступают — и должны поступать — из внутренней корпоративной системы, которая предоставляет собственный набор данных поставщиков компонентов. Он может основываться на строго утвержденном перечне поставщиков и/или специальных условиях ценообразования. Для таких случаев предусмотрен альтернативный механизм Altium Custom Parts Provider, который после настройки синхронизации через Altium Designer позволяет сопоставлять данные поставщиков из указанного источника базы данных с данными о цепочке поставок в рабочем пространстве.
С помощью функции Custom Parts Provider Synchronization в Altium Designer, описанной ниже, данные поставщиков из выбранной таблицы основной базы данных сопоставляются с параметрами системы и становятся альтернативным источником данных для вариантов компонентов, выбранных в Altium Designer. На практике созданная конфигурация сопоставления используется для синхронизации исходной базы данных с данными поставщиков в рабочем пространстве по расписанию или по запросу. В результате обновления данных поставщиков в основной базе данных переносятся в соответствующие данные поставщиков компонентов в подключенном рабочем пространстве.
Эта функция позволяет компаниям, централизованно управляющим данными поставщиков компонентов в базе данных корпоративной системы, использовать преимущества рабочего пространства Altium, сохраняя синхронизацию с корпоративной системой (PLM, PDM, ERP и т. д.) либо просто с общей базой данных или CSV-файлом. В режиме автоматической синхронизации обновление данных рабочего пространства из базы данных выполняется по расписанию Планировщика заданий Windows независимо от клиентского приложения Altium Designer.
-
Сведения об импорте библиотек баз данных в рабочее пространство см. в разделе Импорт существующих библиотек в подключенное рабочее пространство.
-
Сведения о связанном процессе синхронизации параметров компонентов рабочего пространства с источником базы данных см. в разделе Синхронизация данных базы данных компонентов с рабочим пространством.
Создание конфигурации синхронизации с пользовательским источником данных поставщиков компонентов
Синхронизация данных поставщиков компонентов между базой данных и рабочим пространством организуется путем создания и настройки документа Custom Parts Provider Synchronization Configuration (*.PrtSync) в Altium Designer. Интерфейс документа и его функции аналогичны интерфейсу и функциям синхронизатора компонентов. Подключившись к рабочему пространству Altium, создайте новый документ с помощью команды меню File » New » Custom Parts Provider Synchronization Configuration.
Добавьте нужный основной источник данных в конфигурацию синхронизации с помощью кнопки
или перетащите совместимые файлы данных в область Data Sources интерфейса. Конфигурация поддерживает следующие источники данных параметров компонентов:
-
Файлы баз данных Access (
*.mdb,*.accdb) -
Электронные таблицы Excel (
*.xlsx) -
CSV-файлы (
*.csv) -
Другие источники данных, например серверные интерфейсы, совместимые с OLE DB (включая базы данных PostgreSQL), с использованием соответствующей строки подключения. Порядок подключения MySQL через ODBC описан ниже в разделе «Настройка MySQL».
В приведенном здесь примере в конфигурацию добавлена база данных, содержащая данные поставщиков компонентов (стабилитронов). Исходная база данных (SupplierData.mdb) содержит две таблицы — CustomSupplierParts1 и CustomSupplierParts2, причем первая таблица включена для сопоставления и синхронизации.
Порядок настройки ODBC для MySQL
Синхронизация пользовательского источника данных поставщиков компонентов с базой данных MySQL настраивается с помощью Microsoft OLE DB Provider for ODBC и приложения MySQL Connector/ODB. Подключение и настройка выполняются следующим образом:
-
Скачайте и установите MySQL Connector, который можно получить, выбрав вариант установки Custom в MySQL Installer 8. Затем запустите приложение Windows ODB Data Sources, чтобы добавить тип MySQL ODBC ANSI Driver, укажите источник MySQL и базу данных в MYSQL Connector и подтвердите добавленный источник данных ODBC.
-
Создайте новую конфигурацию синхронизации компонентов в Altium Designer (File » New » Custom Parts Provider Synchronization Configuration) и выберите пункт Use Connection String в меню
.
-
В открывшемся диалоговом окне Data Link Properties выберите вариант
Microsoft OLER DB Provider for ODBC Driversна вкладке Provider, нажмите Next, а затем на вкладке Connection этого окна введите сведения об источнике данных, заданные выше в Step 1. -
Включите нужную таблицу базы данных MySQL на панели Properties в Altium Designer.
-
Выберите таблицу базы данных в иерархии Data Source и при необходимости сопоставьте столбцы данных с параметрами Altium на панели Properties.
Сопоставление параметров данных поставщиков
Новая конфигурация пользовательского источника данных поставщиков компонентов обращается к таблице базы данных как к источнику параметрических данных. После выбора таблицы в дереве Data Sources конфигурации ее можно сопоставить со стандартными параметрами данных поставщиков, используемыми в Altium Designer и рабочем пространстве Altium.
Параметры данных поставщиков сопоставляются с параметрами исходной базы данных в конфигурации источника данных поставщиков компонентов в области Parameter Mapping панели Properties. Используйте варианты в раскрывающемся меню поля Column, чтобы выбрать параметр исходной базы данных, соответствующий параметру данных поставщика, или исключить параметр из синхронизации (<Skip>). По мере сопоставления каждый набор данных параметра добавляется в список Components Preview. Порядок этих столбцов можно менять, перетаскивая их заголовки, а включать и отключать столбцы можно через меню Select Columns (доступное по щелчку правой кнопкой мыши на заголовке).
Поддерживается ряд системных параметров данных поставщиков, включая Manufacturer Name, Manufacturer Part Number, Category, Datasheet и т. д. Вы также можете добавлять и удалять пользовательские параметры данных поставщиков с помощью кнопок
и
в области Parameter Mapping панели Properties.
Пороги ценовых скидок на компоненты определяют количество компонентов, которое необходимо заказать у поставщика для снижения цены за единицу. Требуемые объемы заказа обычно увеличиваются на порядок — 10 единиц, 100 единиц и т. д. — и поддерживаются записями вариантов компонентов (Part Choice) в данных поставщиков Altium.
Эти числовые данные можно сопоставить с данными поставщиков в рабочем пространстве (Workspace), добавив записи Quantity для порогов ценовых скидок в разделе Price Breaks панели Properties, где объемы последовательно увеличиваются на порядок, а затем сопоставив эти записи с соответствующими полями базы данных. Обратите внимание, что стандартный параметр стоимости unit (Price) включен в общий раздел Parameter Mapping.
Синхронизация базы данных с рабочим пространством
Завершив настройку сопоставления данных поставщиков, сохраните документ конфигурации пользовательского поставщика данных о компонентах (File » Save) и запустите синхронизацию исходной базы данных с сервером с помощью кнопки
либо настройте синхронизацию по расписанию При первоначальной синхронизации сопоставленные данные поставщиков будут загружены из базы данных вашей компании в рабочее пространство Altium, а при последующих циклах синхронизации эти данные будут обновляться.
В приведенном примере данные поставщиков для стабилитронов, синхронизированные из исходной базы данных с рабочим пространством, становятся доступны как данные Custom Parts Provider для этих компонентов — в дополнение к стандартным данным поставщиков компонентов, предоставляемым облачной службой Altium Parts Provider.
Это можно сразу увидеть на панели Manufacturer Part Search при выборе категории Custom Parts Provider: на ней отображаются варианты поставки компонентов, полученные через службу Custom Parts Provider в результате синхронизации с базой данных поставщиков вашей организации.
Объединение данных поставщиков
Если название производителя и номер компонента производителя в синхронизированной базе данных поставщиков совпадают с названием производителя и номером компонента производителя, предоставленными Altium Parts Provider, данные поставщиков из настроенной вами службы Custom Parts Provider объединяются с данными Altium Parts Provider. В результате вся информация о поставщиках отображается совместно везде, где в интерфейсе программы представлены данные поставщиков (SPN), в том числе на панели Manufacturer Part Search , в ActiveBOM и при добавлении вариантов компонентов.
Варианты компонентов из данных пользовательского поставщика
При добавлении информации о вариантах компонентов к записям компонентов на панели Components (щелчок правой кнопкой мыши, Operations » Create/Edit PCL) данные поставщиков, предоставленные службой Custom Parts Provider, отображаются в начале списка в диалоговом окне Add Part Choices, как показано здесь для записи стабилитрона 1N4747A. Выбранная (выделенная) запись будет добавлена в качестве варианта компонента для выбранного компонента на панели Components.
Как и служба Altium Parts Provider, служба Custom Parts Provider поддерживает данные поставщиков для нескольких производителей и от нескольких поставщиков. Эти данные берутся из отдельных записей в таблице исходной базы данных. Обратите также внимание, что данные пользовательского поставщика включают сведения о порогах ценовых скидок и складских остатках, синхронизированные с исходной базой данных.
Помимо панели Components, показанной здесь, варианты компонентов от поставщиков можно привязать к ссылке на компонент в следующих интерфейсах Altium Designer:
- Панель Explorer.
- Документ ActiveBOM.
- Редактор отдельных компонентов.
- Редактор пакетного редактирования компонентов.
Синхронизация по расписанию
Сохраненные конфигурации синхронизации компонентов настраиваются для автоматической обработки данных из базы данных и их передачи в рабочее пространство в диалоговом окне Auto Synchronization Schedule, которое открывается кнопкой
в основном интерфейсе.
Синхронизацию по расписанию в соответствии с текущим профилем конфигурации можно настроить на определенное время каждый день, на заданное время в выбранные дни недели или на момент входа в Windows. Также можно отключить синхронизацию на время, когда вы не вошли в систему. После подтверждения настроек кнопкой
конфигурация будет добавлена как повторяющаяся задача в Windows Task Scheduler. Чтобы удалить существующее расписание синхронизации, выберите No automatic synchronization.
Синхронизацию данных компонентов с базой данных также можно запустить вручную из командной строки с помощью приложения ComponentSync.Executor.exe, расположенного в папке \System установленного программного обеспечения. Синтаксис команды: ComponentSync.Executor.exe [configuration file name]. На изображении ниже показан результат запуска конфигурации MyPrtSyncConfig из этого примера с помощью следующей командной строки:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync








).


