Синхронизация базы данных цепочки поставок с данными Workspace
Благодаря концепции вариантов компонентов компоненты, размещенные в рабочем пространстве Altium 365 или рабочем пространстве Enterprise Server, можно связать с реальными позициями поставщиков на основе указанного компонента производителя. По умолчанию эти данные о цепочке поставок поступают из облачного сервиса Altium Parts Provider и включают актуальную информацию о позициях поставщиков: остатки на складе, цену за единицу и пороговые объемы для ценовых скидок.
Однако во многих организациях данные о поставщиках компонентов поступают (и должны поступать) из внутренней корпоративной системы, которая предоставляет собственный набор таких данных — например, на основе строго утвержденного перечня поставщиков и/или специальных ценовых условий. Для таких случаев предусмотрен альтернативный механизм Altium Custom Parts Provider, который после настройки синхронизации в Altium Designer позволяет сопоставить данные о поставщиках из указанной базы данных с данными о цепочке поставок в рабочем пространстве.
С помощью функции Altium Designer Custom Parts Provider Synchronization, описанной ниже, данные о поставщиках из выбранной таблицы основной базы данных сопоставляются с параметрами и становятся альтернативным источником данных для вариантов компонентов, выбранных в Altium Designer. На практике созданная конфигурация сопоставления используется для синхронизации исходной базы данных с данными о поставщиках в рабочем пространстве — по расписанию или по запросу. В результате обновления данных о поставщиках в основной базе данных передаются в соответствующие данные о поставщиках компонентов в подключенном рабочем пространстве.
Эта функция позволяет компаниям, которые централизованно управляют данными о поставщиках компонентов в базе данных корпоративной системы, использовать преимущества рабочего пространства Altium, сохраняя синхронизацию со своей корпоративной системой (PLM, PDM, ERP и т. д.) — либо просто с общей базой данных или CSV-файлом. В режиме автоматической синхронизации задача в Планировщике заданий Windows выполняет обновление данных рабочего пространства из базы данных независимо от клиентского приложения Altium Designer.
-
Информацию об импорте библиотек баз данных в рабочее пространство см. в разделе Импорт существующих библиотек в подключенное рабочее пространство.
-
Информацию о связанном процессе синхронизации параметров компонентов рабочего пространства с исходной базой данных см. в разделе Синхронизация данных компонентов между базой данных и рабочим пространством.
Создание конфигурации синхронизации с пользовательским источником данных о поставщиках компонентов
Синхронизация данных о поставщиках компонентов между базой данных и рабочим пространством задается путем создания и настройки документа Custom Parts Provider Synchronization Configuration (*.PrtSync) в Altium Designer. Интерфейс документа и его функциональность аналогичны синхронизатору компонентов. Подключившись к рабочему пространству Altium, создайте новый документ с помощью команды меню File » New » Custom Parts Provider Synchronization Configuration.
Добавьте нужный основной источник данных в конфигурацию синхронизации с помощью кнопки
или перетащите совместимые файлы данных в область Data Sources интерфейса. Конфигурация поддерживает следующие источники данных параметров компонентов:
-
Файлы баз данных Access (
*.mdb,*.accdb) -
Электронные таблицы Excel (
*.xlsx) -
CSV-файлы (
*.csv) -
Другие источники данных, например серверные интерфейсы, совместимые с OLE DB (включая базы данных PostgreSQL), с использованием специальной строки подключения. Процедуру подключения MySQL через ODBC см. ниже в разделе «Настройка MySQL».
В приведенном примере в конфигурацию добавлена база данных, содержащая данные о поставщиках компонентов (стабилитронов). Исходная база данных (SupplierData.mdb) содержит две таблицы — CustomSupplierParts1 и CustomSupplierParts2, причем первая таблица включена для сопоставления и синхронизации.
Процедура настройки ODBC для MySQL
Синхронизация пользовательского источника данных о поставщиках компонентов с базой данных MySQL настраивается с помощью Microsoft OLE DB Provider for ODBC в приложении MySQL Connector/ODB. Процедура подключения и настройки:
-
Скачайте и установите MySQL Connector, который можно получить, выбрав вариант установки Custom в MySQL Installer 8. Затем запустите приложение Windows ODB Data Sources, чтобы добавить тип MySQL ODBC ANSI Driver, укажите источник MySQL и базу данных в MYSQL Connector и подтвердите добавленный источник данных ODBC.
-
Создайте новую конфигурацию синхронизации компонентов в Altium Designer (File » New » Custom Parts Provider Synchronization Configuration) и выберите пункт Use Connection String в меню
.
-
В открывшемся диалоговом окне Data Link Properties выберите вариант
Microsoft OLER DB Provider for ODBC Driversна вкладке Provider, нажмите Next, а затем на вкладке Connection этого окна введите сведения об источнике данных, заданные выше в Step 1. -
Включите нужную таблицу базы данных MySQL на панели Properties в Altium Designer.
-
Выберите таблицу базы данных в иерархии Data Source и затем сопоставьте столбцы данных с параметрами Altium на панели Properties в соответствии с вашими потребностями.
Сопоставление параметров данных о поставщиках
Новая конфигурация пользовательского источника данных о поставщиках компонентов обращается к таблице базы данных как к источнику параметрических данных. Выбрав таблицу в дереве Data Sources конфигурации, можно сопоставить ее поля со стандартными параметрами данных о поставщиках, используемыми в Altium Designer и рабочем пространстве Altium.
Параметры данных о поставщиках из исходной базы данных сопоставляются с параметрами конфигурации источника данных о поставщиках компонентов в области Parameter Mapping панели Properties. Используйте пункты раскрывающегося меню поля Column, чтобы выбрать параметр исходной базы данных, соответствующий параметру данных о поставщиках, или исключить параметр из синхронизации (<Skip>). Каждый набор данных параметров добавляется в список Components Preview по мере сопоставления. Порядок этих столбцов можно изменить, перетаскивая их заголовки, а включить или отключить столбцы — через меню Select Columns, доступное по щелчку правой кнопкой мыши на заголовке.
Поддерживается ряд системных параметров данных поставщиков, включая Manufacturer Name, Manufacturer Part Number, Category, Datasheet и т. д. Вы также можете добавлять и удалять пользовательские параметры данных поставщиков с помощью кнопок
и
в области Parameter Mapping панели Properties.
Пороги ценовых скидок на компоненты определяют количество компонентов, которое необходимо заказать у поставщика для снижения цены за единицу. Требуемые объемы заказа обычно задаются с шагом в один порядок — 10 единиц, 100 единиц и т. д. — и поддерживаются в записях вариантов компонентов в данных поставщиков Altium.
Эти числовые данные можно сопоставить с записями исходной базы данных и передать в данные поставщиков рабочего пространства, добавив записи Quantity для ценовых порогов в разделе Price Breaks панели Properties. Количества в этих записях последовательно увеличиваются в десять раз; затем записи сопоставляются с соответствующими полями базы данных. Обратите внимание, что стандартный параметр стоимости unit (Price) включен в общий раздел Parameter Mapping.
Синхронизация базы данных с рабочим пространством
Завершив настройку сопоставления данных поставщиков, сохраните документ конфигурации пользовательского поставщика данных о компонентах (File » Save) и выполните синхронизацию исходной базы данных с данными сервера с помощью кнопки
или настройте синхронизацию по расписанию При первоначальной синхронизации сопоставленные данные поставщиков будут загружены из базы данных вашей компании в рабочее пространство Altium, а при последующих циклах синхронизации эти данные будут обновляться.
В показанном здесь примере данные поставщиков для стабилитронов, синхронизированные из исходной базы данных с рабочим пространством, становятся доступными как данные Custom Parts Provider для этих компонентов — в дополнение к обычным данным поставщиков компонентов, предоставляемым облачным сервисом Altium Parts Provider.
Это сразу видно на панели Manufacturer Part Search при выборе категории Custom Parts Provider: на ней отображаются варианты поставки компонентов, полученные через сервис Custom Parts Provider и синхронизированные с базой данных поставщиков вашей организации.
Объединение данных поставщиков
Если название производителя и номер компонента производителя в синхронизированной базе данных поставщиков совпадают с названием производителя и номером компонента производителя, предоставленными Altium Parts Provider, данные поставщиков из настроенного вами Custom Parts Provider объединяются с данными Altium Parts Provider. В результате вся информация о поставщиках отображается совместно везде, где в интерфейсе программы представлены данные поставщиков (SPN), в том числе на панели Manufacturer Part Search , в ActiveBOM и при добавлении вариантов компонентов.
Варианты компонентов из данных пользовательского поставщика
При добавлении информации о вариантах компонентов к записям компонентов на панели Components (щелчок правой кнопкой мыши, Operations » Create/Edit PCL) данные поставщиков, предоставленные Custom Parts Provider, отображаются в начале списка в диалоговом окне Add Part Choices, как показано здесь для записи стабилитрона 1N4747A. Выбранная (выделенная) запись будет добавлена как вариант компонента для выбранного компонента на панели Components.
Как и сервис Altium Parts Provider, Custom Parts Provider также поддерживает данные поставщиков для нескольких производителей и от нескольких поставщиков — они формируются из отдельных записей в таблице исходной базы данных. Обратите также внимание, что данные пользовательского поставщика включают информацию о ценовых порогах и складских остатках, синхронизированную из исходной базы данных.
Помимо показанной здесь панели Components, варианты компонентов с данными поставщиков можно привязать к ссылке на компонент в следующих интерфейсах Altium Designer:
Синхронизация по расписанию
Сохраненные конфигурации синхронизации компонентов настраиваются для автоматической обработки данных из базы данных в рабочем пространстве через диалоговое окно Auto Synchronization Schedule, которое открывается кнопкой
в основном интерфейсе.
Синхронизацию по расписанию в соответствии с текущим профилем конфигурации можно настроить на определенное время каждого дня, на определенное время в выбранные дни недели или на момент входа в Windows. Также можно отключить синхронизацию на то время, когда вы не вошли в систему. После подтверждения настроек кнопкой
конфигурация будет добавлена как повторяющаяся задача в Windows Task Scheduler. Чтобы удалить существующее расписание синхронизации, выберите No automatic synchronization.
Синхронизацию данных компонентов с базой данных также можно запустить вручную из командной строки с помощью приложения ComponentSync.Executor.exe, расположенного в папке \System установленного программного обеспечения. Синтаксис команды: ComponentSync.Executor.exe [configuration file name]. На изображении ниже показан запуск конфигурации MyPrtSyncConfig из этого примера с помощью следующей командной строки:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync








).


