Система Board Insight

Altium Training

Altium Essentials: PCB Viewing and Navigation

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Краткий обзор

В этой статье рассказывается, как система Board Insight в Altium Designer помогает разобраться в сложных многослойных печатных платах с высокой плотностью компоновки, предоставляя удобные средства просмотра, идентификации объектов и взаимодействия с ними в рабочей области. В статье рассматриваются основные возможности системы: всплывающие инструменты просмотра, визуальный список выбора, информационная панель Heads Up Display, динамическая подсветка цепей, управление активным слоем, отображение имен цепей, параметры отображения сведений о контактных площадках и переходных отверстиях, настройки отображения заблокированных объектов и режимы 3D-просмотра. Все эти средства помогают лучше видеть проект и контролировать работу с ним. Хотите увереннее ориентироваться в сложных платах и эффективнее использовать инструменты просмотра Altium Designer? Читайте дальше — это руководство поможет вам начать работу и сделать рабочую область более наглядной.

- Узнайте, какие функции Board Insight помогают лучше рассматривать объекты, нарушения правил проектирования и участки с плотным размещением элементов.
- Ознакомьтесь с тем, как информационная панель Heads Up Display, динамическая подсветка, управление активным слоем и отображение имен цепей упрощают повседневную навигацию по печатной плате.
- Узнайте, как настраиваемые параметры отображения, включая визуальное выделение заблокированных объектов и режимы 3D-проекции, помогают лучше понимать сложную топологию платы.
Узнайте больше с ИИ:

Board Insight — это настраиваемая система функций, которая обеспечивает полный контроль над просмотром проекта печатной платы и работой с ним. Сложная многослойная плата создает визуально перегруженное и зачастую трудное для восприятия пространство проектирования. Система Board Insight в Altium Designer упрощает просмотр и понимание объектов проекта. Она представляет собой комплекс взаимосвязанных функций, разработанных для управления отображением.

В Board Insight интегрированы расширенный режим одного слоя и функции 3D-визуализации. В режиме одного слоя можно четко видеть содержимое выбранного слоя и при этом сохранять представление о том, что находится на других слоях. 

Для неподготовленного наблюдателя проект печатной платы практически непонятен и выглядит как множество линий, окружностей, дуг и строк разных цветов, нагроможденных друг на друга. Даже опытному специалисту бывает трудно разобраться в огромном количестве деталей проекта. Altium Designer содержит ряд функций, помогающих находить и идентифицировать элементы проекта, а также управлять их отображением. В совокупности эти функции образуют систему Board Insight.

Режим всплывающего окна Board Insight

Режим всплывающего окна Board Insight — удобный инструмент для просмотра объектов под курсором. Нажмите Shift+X (Tools » Browse Objects), чтобы просмотреть подробную информацию о компонентах и цепях под курсором, а также о принадлежащих им объектах, например контактных площадках и дорожках. Используйте Shift+V (Tools » Browse Violations), чтобы просмотреть информацию о нарушениях (заданных правил проектирования), находящихся под курсором. Также отображается графическое представление объекта или нарушения, выбранного во всплывающем окне. Список имеет иерархическую структуру, что позволяет, например, раскрывать его уровни для получения полной информации о примитивах, связанных с конкретным нарушением. Чтобы просмотреть подробную информацию об объекте или нарушении, выделить его либо приблизить область его расположения, щелкните по нему для открытия всплывающего меню или воспользуйтесь значками справа. Доступны следующие действия:

  • Properties или  — открывает Properties панель для этого объекта или диалоговое окно сведений о нарушении для этого нарушения.
  • Select или  — выделяет объект или нарушение в пространстве проектирования.
  • Zoom или  — приближает область расположения объекта или нарушения.
Поскольку всплывающее окно работает с объектами под курсором, рекомендуется вызывать команду, используя соответствующее сочетание клавиш.

Всплывающее окно визуального выбора

Всплывающее окно визуального выбора упрощает выбор нужного объекта в перегруженном пространстве проектирования. Проект многослойной печатной платы создает плотное и визуально перегруженное пространство проектирования, в котором множество объектов перекрывают друг друга. Всплывающее окно визуального выбора делает выбор объектов простым. Если под курсором находится несколько объектов, дважды щелкните, чтобы открыть всплывающее окно визуального выбора. При перемещении указателя мыши по списку текущий объект отображается во всплывающем окне, что позволяет легко его идентифицировать. Объекты в этом окне отсортированы по слоям.

Значок  справа от имени примитива означает, что этот примитив входит в состав компонента печатной платы, а примитивы родительского компонента заблокированы (свойство компонента Primitives находится в состоянии ).

Информационный дисплей

Информационный дисплей в реальном времени предоставляет сведения об объектах, находящихся под курсором в пространстве проектирования печатной платы. Дисплей можно настроить для отображения положения курсора, относительных координат (расстояния от точки последнего щелчка мышью), текущего слоя и текущей сетки привязки. Помимо состава информации, можно настроить шрифт и цвета дисплея. Информационный дисплей можно закрепить в любой точке экрана или настроить его перемещение вслед за курсором.

Если во время перемещения курсора вы ненадолго остановитесь, информационный дисплей переключится в режим Hover mode. В этом режиме отображаются дополнительные сведения: общая информация, доступные сочетания клавиш, нарушения правил, а также сведения о цепях, компонентах и примитивах.

Настроить информационный дисплей можно на странице Редактор печатных плат — режимы Board Insight диалогового окна Preferences .

В столбце Heads Up таблицы включите свойства, которые требуется отображать на информационном дисплее. В таблице также можно настроить параметры Font для этих свойств.

Для настройки информационного дисплея можно использовать следующие команды меню View » Board Insight (также доступного по нажатию F2 в пространстве проектирования): 

  • Toggle Heads Up Display (Shift+H) — включает или выключает информационный дисплей. 
  • Toggle Heads Up Tracking (Shift+G) — переключает информационный дисплей между фиксированным положением на плате и перемещением вслед за курсором. Дисплей не перемещается сразу к курсору, а движется относительно положения курсора на момент включения отслеживания. Перед использованием этой команды рекомендуется расположить курсор относительно текущего положения дисплея.
  • Resets Heads Up Delta Origin (Ins) — устанавливает начало отсчета относительных координат в текущую позицию мыши. Информационный дисплей может отображать расстояние по горизонтали и вертикали, на которое мышь перемещена от начала отсчета. Начало отсчета также можно переустановить щелчком левой кнопки мыши. Этот параметр можно настроить на странице PCB Editor - Board Insight Modes диалогового окна Preferences .

    Возможность установки начала отсчета относительных координат и используемые для этого средства управления определяются параметрами Insert Key Resets Heads Up Delta Origin и Mouse Click Resets Heads Up Delta Origin на странице Редактор печатных плат — режимы Board Insight диалогового окна Preferences. Если оба параметра отключены, функция начала отсчета фактически отключается, и при перемещении мыши относительные координаты остаются равными 0,0.
  • Toggle Heads Up Delta Origin (Shift+D) — включает или выключает отображение относительных координат. Они показывают расстояние по горизонтали (dx) и вертикали (dy) от координат Delta Origin — точки, которую пользователь может задать в пространстве проектирования. Используйте относительные координаты для оценки расстояний относительно выбранной точки на плате.
Изменения в системе Board Insight влияют на пространство проектирования печатных плат и, следовательно, на все документы печатных плат и посадочных мест, с которыми вы работаете.

Динамическая подсветка

Разобраться в сложном проекте печатной платы непросто из-за плотного размещения компонентов, плотной трассировки и множества сигнальных слоев. Altium Designer содержит ряд функций подсветки цепей, помогающих изучать трассировку.

Используйте область Live Highlighting на странице Редактор печатных плат — отображение Board Insight в Preferences диалоговое окно для настройки этой функции. 

Используйте Ctrl+Click для выделения любой цепи на плате. Все элементы проекта, не принадлежащие этой цепи, отображаются приглушённо, благодаря чему трассировка выделяется на всех сигнальных слоях, как показано на изображении ниже. Чтобы выделить несколько цепей, удерживайте клавишу Shift и выполняйте Ctrl+Click  на каждой цепи. Выполните Ctrl+Click в любом свободном месте, чтобы восстановить обычное отображение.

Выделение цепей также может работать динамически: цепь выделяется при наведении на неё курсора. В этом режиме используется настраиваемое контурное выделение, которое не влияет на отображение остальных элементов печатной платы. На изображении ниже показана цепь, выделенная в динамическом режиме.

На изображении ниже приведён пример выделения цепи с помощью Ctrl+Click. 

Управление активным слоем

Редактор печатных плат представляет собой многослойную среду, в которой в каждый момент времени активен только один слой. Изменить активный слой можно несколькими способами. Обратите внимание: выбор текущего слоя применяется только в режиме 2D-просмотра.

  • Нажмите на вкладку Layer в нижней части рабочей области.
  • Используйте раскрывающийся список Active Layer в разделе Layers на вкладке Layers & Colors панели View Configuration.
  • Переключайтесь между слоями с помощью следующих сочетаний клавиш.
    • Ctrl+Shift+Mouse wheel — следующий слой / предыдущий слой
    • + (цифровая клавиатура) — следующий слой
    • - (цифровая клавиатура) — предыдущий слой
    • * (цифровая клавиатура) — следующий сигнальный слой

Отображение имён цепей на дорожках

Ещё одна полезная функция, помогающая работать эффективнее, — отображение имён цепей на дорожках (настраивается на вкладке View Options в разделе Additional Options панели View Configuration). Чтобы использовать эту функцию, включите опцию Repeated Net Names on Tracks в разделе Additional Options. В какой бы части платы вы ни работали, вы сможете сразу определить, относится ли рассматриваемая трассировка к нужной вам цепи. 

Отображение имён цепей на дорожках позволяет легко «читать» трассировку.Отображение имён цепей на дорожках позволяет легко «читать» трассировку.

Параметры отображения сведений о контактных площадках и переходных отверстиях

Управлять отображением сведений о контактных площадках и переходных отверстиях можно в разделе Pad and Via Display Options на странице Редактор печатных плат — Отображение Board Insight диалогового окна Preferences. Вы можете настроить цвет, фон и шрифт этих сведений. Текст автоматически отображается в удобной для чтения ориентации и выравнивается в направлении, обеспечивающем максимальную доступную площадь для его отображения. Опция Use Smart Display Color автоматически подбирает цвет шрифта с хорошим контрастом, чтобы текст легко читался.

Параметры отображения заблокированных объектов

Вы можете настроить отображение заблокированных объектов в рабочей области, чтобы их было проще распознавать визуально. Используйте элементы управления в разделе Show Locked Texture on Objects на странице Редактор печатных плат — Отображение Board Insight диалогового окна Preferences.

Пример с включённой опцией Only When Live Highlighting. Пример с включённой опцией Only When Live Highlighting.

3D Board Insight

Функция 3D Board Insight включает режимы проекции, позволяющие отображать плату в проекции Perspective или Orthographic . Для выбора нужного режима отображения используйте раздел Projection в режиме 3D-просмотра на вкладке View Options панели Конфигурация вида.

Выберите Orthographic , чтобы увидеть точное расположение объектов и текста на печатной плате без перекрытия окружающими объектами. Выберите Perspective, чтобы получить более реалистичный трёхмерный вид печатной платы.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents