Горячие клавиши PCB Editor и PCB Library Editor
Краткий обзор
- Наглядный обзор сочетаний клавиш в редакторах печатных плат и библиотек печатных плат Altium Designer.
- Сочетания клавиш, сгруппированные по задачам: редактирование, выбор, перемещение, выравнивание и просмотр платы.
- Пояснение обозначений сочетаний клавиш и действий мышью, которое поможет быстро ориентироваться в списках и применять их на практике.
В следующих разделах представлены сочетания клавиш, специфичные для редактора печатных плат и/или редактора посадочных мест. Общие сведения о сочетаниях клавиш, включая доступ к ним и их редактирование, общие сочетания клавиш среды Altium и клавиши быстрого доступа, см. в разделе Сочетания клавиш Altium Designer.
При просмотре списков сочетаний клавиш учитывайте следующее:
- В описаниях сочетаний клавиш символ «плюс» (+) означает, что нужно удерживать несколько клавиш на клавиатуре в указанной последовательности. Например, Shift+F1 означает, что нужно удерживать клавишу Shift, а затем нажать клавишу F1. Аналогично, Shift+Ctrl+PgUp означает, что нужно удерживать клавишу Shift , затем одновременно с ней удерживать клавишу Ctrl и нажать клавишу PgUp.
- При использовании стандартных кнопок мыши Click означает один щелчок левой кнопкой мыши, Double-Click — двойной щелчок левой кнопкой мыши, а Right-Click — один щелчок правой кнопкой мыши.
Стандартные сочетания клавиш
Следующие сочетания клавиш являются стандартными для редактора печатных плат и/или редактора посадочных мест. Они доступны в обычном режиме, и для их использования не требуется выполнять интерактивную операцию.
General Editing |
|
| Double-Click | Изменить свойства объекта, находящегося под курсором. |
| Right-Click | Открыть контекстное меню рабочей области или объекта, находящегося под курсором. Если выполняется интерактивная команда, выйти из текущей операции. |
| Ctrl+C | Копировать выделенное |
| Ctrl+X | Вырезать выделенное |
| Ctrl+V | Вставить выделенное |
| Alt+Insert | Вставить объекты на текущий слой независимо от того, каким слоям они были назначены изначально. |
| Ctrl+R | Скопировать выделенные объекты и многократно вставлять их в нужные места рабочей области (штамповка). |
| Delete | Удалить выделенное |
| Ctrl+Z | Отменить |
| Ctrl+Y | Повторить |
Selecting |
|
| Shift+F | Вызвать функцию поиска похожих объектов (щелкните объект, который будет использован в качестве исходного шаблона). |
| Click | Выделить объект под курсором или снять с него выделение. |
| Shift+Click | Изменить состояние выделения объекта под курсором, не затрагивая состояние других объектов. |
| Tab | Если в проекте уже выделен объект, расширить выделение, включив в него следующий объект или объекты более высокого уровня в соответствии с логической иерархией. Кроме того, эта функция позволяет расширять выделение для нескольких объектов, выбранных в разных цепях проекта. |
| Shift+Tab | Выделить только следующий объект проекта в группе объектов, расположенных в одном месте (перекрывающихся), без использования всплывающего окна выбора. Для использования этой команды убедитесь, что параметр Display popup selection dialog отключен на странице PCB Editor — General диалогового окна Preferences . |
| Shift+Ctrl+X | Включить или отключить режим перекрестного выделения. |
| Shift+Ctrl+Y | Включить или отключить параметр Reposition selected component in PCB режима перекрестного выделения. |
| Ctrl+A | Выделить все объекты в текущем документе. |
| Ctrl+B | Выделить все объекты, расположенные в пределах заданного контура платы. |
| Ctrl+H | Выделить все электрические объекты, соединенные с одним и тем же участком меди. |
| Alt+Click | На линии связи — выделить эту линию связи. |
| Alt+Shift+Click | На линии связи — выделить эту линию связи в дополнение к уже выделенным (накопительное выделение линий связи). |
| Click (вне объектов), Hold&Drag (слева направо) | Выделить все объекты, полностью попадающие в область выделения. |
| Click (вне объектов), Hold&Drag (справа налево) | Выделить все объекты, полностью попадающие в область выделения или пересекаемые ее границей. |
| Ctrl+Hold&Drag (слева направо) | Выделить все контактные площадки компонентов, полностью попадающие в область выделения. |
| Ctrl+Hold&Drag (справа налево) | Выделить все контактные площадки компонентов, полностью попадающие в область выделения или пересекаемые ее границей. |
| Alt+Click&Drag (справа налево) | Выделить все линии связи, пересекаемые растягиваемой прямоугольной рамкой. |
| Ctrl+n (n = от 1 до 8) | Сохранить текущее выделение в ячейке памяти n. |
| Alt+n (n = от 1 до 8) | Восстановить выделение из ячейки памяти n. |
| Shift+n (n = от 1 до 8) | Добавить текущее выделение к выделению, уже сохраненному в ячейке памяти n. |
| Alt+Shift+n (n = от 1 до 8) | Восстановить выделение из ячейки памяти n и добавить его к текущему выделению в рабочей области. |
| Shift+Ctrl+n (n = от 1 до 8) | Применить фильтрацию на основе набора выделенных объектов в ячейке памяти n. |
Moving |
|
| Click (на объекте), Hold&Drag |
|
| Ctrl+Click, Hold&Drag | На переходном отверстии в стеке переходных отверстий — переместить только это переходное отверстие в новое место (а не весь стек). |
| Left Arrow | Переместить курсор влево (для декартовой сетки) или к центру (для полярной сетки) в рабочей области текущего документа с шагом в одну единицу сетки привязки. |
| Shift+Left Arrow | Переместить курсор влево (для декартовой сетки) или к центру (для полярной сетки) в рабочей области текущего документа с шагом в 10 единиц сетки привязки. |
| Right Arrow | Переместить курсор вправо (для декартовой сетки) или от центра (для полярной сетки) в рабочей области текущего документа с шагом в одну единицу сетки привязки. |
| Shift+Right Arrow | Переместить курсор вправо (для декартовой сетки) или от центра (для полярной сетки) в рабочей области текущего документа с шагом в 10 единиц сетки привязки. |
| Up Arrow | Переместить курсор вверх (для декартовой сетки) или против часовой стрелки (для полярной сетки) в рабочей области текущего документа с шагом в одну единицу сетки привязки. |
| Shift+Up Arrow | Переместить курсор вверх (для декартовой сетки) или против часовой стрелки (для полярной сетки) в рабочей области текущего документа с шагом в 10 единиц сетки привязки. |
| Down Arrow | Переместить курсор вниз (для декартовой сетки) или по часовой стрелке (для полярной сетки) в рабочей области текущего документа с шагом в одну единицу сетки привязки. |
| Shift+Down Arrow | Переместить курсор вниз (для декартовой сетки) или по часовой стрелке (для полярной сетки) в рабочей области текущего документа с шагом в 10 единиц сетки привязки. |
| Ctrl+Left Arrow | Переместить текущее выделение (один или несколько выделенных объектов проекта) влево в рабочей области текущего документа с шагом в одну единицу сетки привязки. |
| Shift+Ctrl+Left Arrow | Переместить текущее выделение (один или несколько выделенных объектов проекта) влево в рабочей области текущего документа с шагом в 10 единиц сетки привязки. |
| Ctrl+Right Arrow | Переместить текущее выделение (один или несколько выделенных объектов проекта) вправо в рабочей области текущего документа с шагом в одну единицу сетки привязки. |
| Shift+Ctrl+Right Arrow | Переместить текущее выделение (один или несколько выбранных объектов проекта) вправо в рабочей области текущего документа с шагом 10 единиц сетки привязки. |
| Ctrl+Up Arrow | Переместить текущее выделение (один или несколько выбранных объектов проекта) вверх в рабочей области текущего документа с шагом в одну единицу сетки привязки. |
| Shift+Ctrl+Up Arrow | Переместить текущее выделение (один или несколько выбранных объектов проекта) вверх в рабочей области текущего документа с шагом 10 единиц сетки привязки. |
| Ctrl+Down Arrow | Переместить текущее выделение (один или несколько выбранных объектов проекта) вниз в рабочей области текущего документа с шагом в одну единицу сетки привязки. |
| Shift+Ctrl+Down Arrow | Переместить текущее выделение (один или несколько выбранных объектов проекта) вниз в рабочей области текущего документа с шагом 10 единиц сетки привязки. |
Aligning |
|
| Shift+Ctrl+L | Выровнять выбранные объекты по левым краям. |
| Shift+Ctrl+R | Выровнять выбранные объекты по правым краям. |
| Alt+Shift+L | Выровнять выбранные объекты проекта по левым краям, сохраняя необходимые расстояния в соответствии с применимыми правилами проектирования. |
| Alt+Shift+R | Выровнять выбранные объекты проекта по правым краям, сохраняя необходимые расстояния в соответствии с применимыми правилами проектирования. |
| Shift+Ctrl+H | Сделать расстояния между выбранными объектами по горизонтали одинаковыми. |
| Shift+Ctrl+T | Выровнять выбранные объекты по верхним краям. |
| Shift+Ctrl+B | Выровнять выбранные объекты по нижним краям. |
| Shift+Alt+I | Выровнять выбранные объекты проекта по верхним краям, сохраняя необходимые расстояния в соответствии с применимыми правилами проектирования. |
| Shift+Alt+N | Выровнять выбранные объекты проекта по нижним краям, сохраняя необходимые расстояния в соответствии с применимыми правилами проектирования. |
| Shift+Ctrl+V | Сделать расстояния между выбранными объектами по вертикали одинаковыми. |
| Shift+Ctrl+D | Переместить выбранные компоненты в ближайший узел требуемой сетки размещения компонентов. |
Viewing the Board |
|
| 1 | Переключить отображение рабочей области печатной платы в режим Board Planning Mode. |
| 2 | Переключить отображение рабочей области печатной платы в режим 2D Layout Mode. |
| 3 | Переключить отображение рабочей области печатной платы в режим 3D Layout Mode. |
| Ctrl+Alt+2 | Переключить отображение рабочей области печатной платы в режим 2D Layout Mode с сохранением текущего положения и ориентации платы. |
| Ctrl+Alt+3 | Переключить отображение рабочей области печатной платы в режим 3D Layout Mode с сохранением текущего положения и ориентации платы. |
| Shift+S | Циклически переключаться между доступными режимами просмотра одного слоя. Доступные режимы определяются включением соответствующих параметров в области Available Single Layer Modes на странице Редактор печатных плат — Отображение Board Insight диалогового окна Preferences. |
| Ctrl+F | Перевернуть активную плату или активный компонент так, словно вы переворачиваете их в руке. Используйте сочетание клавиш повторно, чтобы перевернуть плату или компонент обратно. |
| Ctrl+PgDn | Показать все объекты проекта в текущем документе. |
| PgUp | Увеличить масштаб относительно текущего положения курсора. Также можно использовать мышь для увеличения масштаба области документа одним из следующих способов (если применимо и в зависимости от назначения кнопок мыши):
|
| PgDn | Уменьшить масштаб относительно текущего положения курсора. Можно использовать мышь для уменьшения масштаба области документа одним из следующих способов (если применимо и в зависимости от назначения кнопок мыши):
|
| Shift+PgUp | Увеличить масштаб относительно текущего положения курсора с постепенно уменьшающимся шагом. |
| Shift+PgDn | Уменьшить масштаб относительно текущего положения курсора с постепенно увеличивающимся шагом. |
| Ctrl+PgUp | Установить масштаб текущего документа на 400%. |
| Mouse Wheel | Прокрутить рабочую область по вертикали. Эта настройка задана по умолчанию; ее можно изменить на странице Система — Настройка колеса мыши диалогового окна Preferences. |
| Shift+Mouse Wheel | Прокрутить рабочую область по горизонтали. Эта настройка задана по умолчанию; ее можно изменить на странице Система — Настройка колеса мыши диалогового окна Preferences. |
| Home | Перерисовать изображение в главном окне проектирования, поместив в центр окна точку, в которой находился курсор перед запуском команды. |
| End | Обновить экран, перерисовав текущий документ, чтобы устранить нежелательные эффекты обновления изображения. |
| Alt+End | Перерисовать текущий слой текущего документа, чтобы устранить нежелательные эффекты обновления изображения. |
| Alt+F5 | Переключить редактор текущего документа между развернутым и обычным состоянием окна. |
| F5 | Включить или отключить визуальное отображение функции Net Color Override. |
| Shift+Z | Включить или отключить видимость 3D-модели в текущем документе печатной платы. |
| L | Открыть вкладку Layers And Colors панели Конфигурация отображения, на которой можно настроить отображение слоев платы и назначенные им цвета. |
| Ctrl+D | Открыть вкладку View Options панели Конфигурация отображения, на которой можно настроить режим отображения каждого из различных элементов проекта в рабочей области. |
| Right-Click, Hold&Drag | Включить курсор в виде руки для панорамирования, затем перетаскивать его для перемещения вида рабочей области. |
Board Insight Display |
|
| Shift+H | Включить или отключить информационный дисплей. |
| Shift+G | Включить или отключить отслеживание для информационного дисплея. |
| Insert | Сбросить точку начала отсчета относительных координат для информационного дисплея на 0,0. |
| Shift+D | Включить или отключить отображение координат Delta на информационном дисплее. |
| Shift+V | Открыть всплывающее окно Board Insight со списком всех нарушений заданных правил проектирования, находящихся в данный момент под курсором. |
| Shift+X | Открыть всплывающее окно Board Insight со списком всех компонентов и/или объектов цепей, находящихся в данный момент под курсором. |
| Ctrl+Mouse Wheel Click | Открыть всплывающее окно Board Insight со списком всех нарушений заданных правил проектирования, а также всех компонентов и/или объектов цепей, находящихся в данный момент под курсором. Эта настройка задана по умолчанию; ее можно изменить на странице Система — Настройка колеса мыши диалогового окна Preferences. |
Grids |
|
| Shift+E | Переключиться на следующий режим Hotspot Snapping объектов. |
| Ctrl+E | Открыть всплывающее окно, в котором можно указать объекты для привязки. Выбранные настройки отображаются в области Snap Options панели Properties (на вкладке General при просмотре параметров документа печатной платы). |
| Ctrl+G | Открыть специальное диалоговое окно редактирования сетки привязки, находящейся в данный момент под курсором. |
| Shift+Ctrl+G | Одновременно установите выбранное значение шага по X (горизонтали) и Y (вертикали) для Global Board Snap Grid по умолчанию. |
| Ctrl+Shift | Временно отключает сетку. |
| Shift+H | Включение и отключение привязки курсора к активной сетке. При включении курсор притягивается или привязывается к ближайшей точке группы привязки. |
Highlighting |
|
| Ctrl+Click |
|
| Shift+Ctrl+Click |
|
| Alt+Ctrl | При наведении курсора на вкладку слоя — подсветить содержимое только этого слоя. |
| ] | Увеличить уровень маскирования, уменьшив степень затемнения в рабочей области для всех объектов, не соответствующих текущему фильтру. Обратите внимание: это сочетание клавиш действует только в том случае, если для объектов, не соответствующих примененному фильтру, выбран способ подсветки Dim. В отличие от способа подсветки Mask, такие объекты по-прежнему можно выделять и редактировать. |
| [ | Уменьшить уровень маскирования, увеличив степень затемнения в рабочей области для всех объектов, не соответствующих текущему фильтру. Обратите внимание: это сочетание клавиш действует только в том случае, если для объектов, не соответствующих примененному фильтру, выбран способ подсветки Dim. В отличие от способа подсветки Mask, такие объекты по-прежнему можно выделять и редактировать. |
| Shift+C | Сбросить фильтр, примененный к активному документу. |
Quick Panel Access |
|
| F11 | Показать или скрыть панель Properties. |
| F12 | Показать или скрыть панель PCB Filter или панель PCBLIB Filter соответственно. |
| Shift+F12 | Показать или скрыть панель List (панель PCB List или PCBLIB List) соответственно. |
Layer Switching |
|
| + (на цифровой клавиатуре) | Перейти к следующему включенному слою. |
| - (на цифровой клавиатуре) | Перейти к предыдущему включенному слою. |
| * (на цифровой клавиатуре) | Перейти к следующему включенному сигнальному слою. |
| Shift+* (на цифровой клавиатуре) | Перейти к предыдущему включенному сигнальному слою. |
| Shift+Ctrl+Mouse Wheel | Последовательно переключаться между включенными слоями. При прокрутке колесика мыши вверх или вниз следующий или предыдущий включенный слой (в нижней части главного окна проектирования) становится активным. Это настройка по умолчанию, которую можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences. |
Routing/Track Modification |
|
| Shift+A | Трассировать выбранные соединения с помощью управляемого интерактивного трассировщика ActiveRoute. |
| Ctrl+W | Начать трассировку с помощью интерактивного трассировщика. |
| Shift+Ctrl+Click&Hold | Создать вершину (или излом) сегмента дорожки в текущей позиции курсора. |
| Backspace | Удалить один выделенный объект на конце трассы (дорожку, дугу, переходное отверстие или контактную площадку, не входящие в состав компонента). Единственный объект трассировки, соединенный с удаленным объектом, будет автоматически выделен и готов к последующему удалению. Повторяя команду, можно постепенно удалять проложенную трассу, как при использовании сочетания клавиш Backspace во время интерактивной трассировки. |
| Ctrl+Delete | Удалить один или несколько выделенных объектов трассировки (дорожки, дуги, переходные отверстия и контактные площадки, не входящие в состав компонентов) в текущем документе. Все объекты трассировки, соединенные с удаленными, будут автоматически выделены и готовы к последующему удалению. Повторяя команду, можно постепенно удалять проложенную трассу в обоих направлениях. |
| Ctrl+Alt+G | Использовать Glossing для улучшения качества выбранных трасс за счет уменьшения общей длины и количества углов. |
Commenting |
|
| Alt+Ctrl+C | Добавить новую ветку комментариев к точке, объекту или области активного документа печатной платы. Прежде чем использовать функцию комментирования, убедитесь, что вы открыли (извлекли из системы управления версиями) управляемый проект и работаете с его документом печатной платы. |
Miscellaneous |
|
| Ctrl+Home | Переместить курсор в абсолютное начало координат в левом нижнем углу рабочей области. |
| Ctrl+End | Переместить курсор в относительное начало координат текущего документа (документ печатной платы) или в опорную точку компонента (документ посадочного места печатной платы). |
| Ctrl+Q |
|
| Alt+Left Arrow | Перейти к предыдущему компоненту в текущем документе библиотеки и сделать его активным. Обратите внимание: после достижения первого компонента в списке команда не переходит к последнему компоненту. |
| Alt+Right Arrow | Перейти к следующему компоненту в текущем документе библиотеки и сделать его активным. Обратите внимание: после достижения последнего компонента в списке команда не переходит к первому компоненту. |
| Q | Переключить единицы измерения текущего документа между метрическими (мм) и дюймовыми (мил). |
| Ctrl+M | Измерить и отобразить расстояние между любыми двумя точками текущего документа. |
| |
Выполнить перекрестное зондирование от выбранного объекта в текущем документе печатной платы к соответствующему объекту в исходном документе схемы, оставаясь в документе печатной платы (Continuous Mode) |
| |
Выполнить перекрестное зондирование от выбранного объекта в текущем документе печатной платы к соответствующему объекту в документе схемы, сделав целевой документ схемы активным (Jump To Mode). |
Общие сочетания клавиш для интерактивных операций
Следующие сочетания клавиш становятся доступны после запуска интерактивного процесса, например размещения нового объекта проекта или перемещения существующего. Обратите внимание: доступные сочетания клавиш зависят от интерактивной команды и конкретного объекта проекта, с которым она работает.
| F1 | Открыть диалоговое окно Graphical Editing Hot key List, в котором приведен список доступных сочетаний клавиш (без возможности их выполнения), а также предоставлен доступ к документации по выполняемой команде. |
| Shift+F1 | Открыть меню со списком всех сочетаний клавиш, доступных на текущем этапе выполняемой интерактивной команды. |
| Enter | Действует как Click мыши при размещении или перемещении объекта. |
| Tab | Открыть соответствующий режим панели Properties , в котором можно изменять свойства размещаемого или перемещаемого объекта на лету. Повторное использование Tab в панели Properties (или в любом диалоговом окне) позволяет последовательно переходить между полями панели. |
| X | Зеркально отразить размещаемый или перемещаемый объект относительно оси X. |
| Y | Зеркально отразить размещаемый или перемещаемый объект относительно оси Y. |
| L | Перенести размещаемый или перемещаемый объект на другую сторону платы. |
| Alt | Ограничить направление перемещения горизонтальной или вертикальной осью в зависимости от начального направления движения. |
| Shift | При автоматическом панорамировании во время размещения или перемещения объекта — увеличить скорость панорамирования. |
| Esc (или Right-Click) |
Выход из текущего процесса — из этапа выполняемой интерактивной команды или из самой команды. |
| Spacebar | Поворот размещаемого/перемещаемого объекта против часовой стрелки. Угол поворота соответствует значению Rotation Step на странице Редактор печатных плат – Общие диалогового окна Preferences. |
| Shift+Spacebar | Поворот размещаемого/перемещаемого объекта по часовой стрелке. Угол поворота соответствует значению Rotation Step на странице Редактор печатных плат – Общие диалогового окна Preferences. |
сочетание клавиш для полигональных объектов
Следующие дополнительные сочетание клавиш используются при размещении/редактировании объектов полигональной формы: Полигональная заливка, Область, Полигон покровной плёнки, Полигональная комната, Вытянутое 3D-тело, Контур платы.
Placing |
|
| + (на цифровой клавиатуре) | Переключение на следующий включённый слой. |
| - (на цифровой клавиатуре) | Переключение на предыдущий включённый слой. |
| * (на цифровой клавиатуре) | Переключение на следующий включённый сигнальный слой. |
| Shift+* (на цифровой клавиатуре) | Переключение на предыдущий включённый сигнальный слой. |
| Shift+Spacebar | Циклическое переключение между пятью доступными режимами построения углов (45 градусов, 45 градусов с дугой, 90 градусов, 90 градусов с дугой и произвольный угол). |
| Spacebar | Переключение между вариантами направления угла (для соответствующих режимов построения углов). |
| , | Уменьшение радиуса дуги (с шагом 1 мил/0,025 мм) в режиме размещения со скруглением углов. |
| Shift+, | Уменьшение радиуса дуги (с шагом 10 мил/0,254 мм) в режиме размещения со скруглением углов. |
| . | Увеличение радиуса дуги (с шагом 1 мил/0,025 мм) в режиме размещения со скруглением углов. |
| Shift+. | Увеличение радиуса дуги (с шагом 10 мил/0,254 мм) в режиме размещения со скруглением углов. |
| 1 | Включение/выключение режима размещения с предварительным просмотром следующего сегмента. |
| Click или Enter | Размещение вершины. |
| Backspace | Удаление последней размещённой вершины. |
Editing |
|
| Ctrl+Click&Hold | В любой точке ребра выбранного полигонального объекта, вдали от маркеров редактирования — добавление новой конечной вершины. |
| Click&Hold+Delete | На конечной вершине выбранного полигонального объекта — удаление этой вершины. |
сочетание клавиш для интерактивной трассировки
Следующие дополнительные сочетание клавиш доступны при трассировке соединений с помощью одного из инструментов интерактивной трассировки: «Интерактивная трассировка», «Интерактивная трассировка дифференциальных пар» и «Интерактивная многопроводная трассировка». Обратите внимание: доступность сочетаний клавиш зависит от используемого инструмента интерактивной трассировки.
| Tab | Открытие режима Интерактивная трассировка / Трассировка дифференциальных пар / Многопроводная трассировка панели Properties , в котором можно на ходу менять настройки трассировки, а также свойства размещаемого проводника. |
| Esc | Завершение текущей трассировки. Все участки, зафиксированные до вызова завершения, сохраняются. |
| Click или Enter | Фиксация трассировки до текущего положения курсора и размещение проводников. |
| Backspace | Отмена последнего зафиксированного участка трассировки вплоть до его начальной точки. Если при размещении последнего сегмента какие-либо объекты были pushed, они возвращаются в исходные положения. |
| Ctrl+Click | Автоматическое завершение сегментов до целевой точки. |
| 1 | Включение/выключение режима размещения с предварительным просмотром следующего сегмента. |
| Spacebar | Переключение между вариантами направления угла (для соответствующих режимов построения углов). |
| Shift+Spacebar | Циклическое переключение между пятью доступными режимами построения углов (45 градусов, 45 градусов с дугой, 90 градусов, 90 градусов с дугой и произвольный угол). Обратите внимание: режим произвольного угла недоступен при использовании интерактивного трассировщика дифференциальных пар или интерактивного многопроводного трассировщика. |
| , | Уменьшение радиуса дуги (с шагом 1 мил/0,025 мм) в режиме размещения со скруглением углов. |
| Shift+, | Уменьшение радиуса дуги (с шагом 10 мил/0,254 мм) в режиме размещения со скруглением углов. |
| . | Увеличение радиуса дуги (с шагом 1 мил/0,025 мм) в режиме размещения со скруглением углов. |
| Shift+. | Увеличение радиуса дуги (с шагом 10 мил/0,254 мм) в режиме размещения со скруглением углов. |
| Shift+R | Циклическое переключение между включёнными режимами разрешения конфликтов трассировки. Доступные режимы (включая Ignore Obstacles, Push Obstacles, Walkaround Obstacles, Stop at First Obstacle, Hug and Push Obstacles, AutoRoute On Current Layer, AutoRoute On Multiple Layers) можно задать на странице Редактор печатных плат — Интерактивная трассировка диалогового окна Preferences и изменять на ходу (нажмите Tab для доступа к режиму Интерактивная трассировка / Трассировка дифференциальных пар / Многопроводная трассировка панели Properties). Обратите внимание: при интерактивной трассировке дифференциальных пар или нескольких проводников режимы AutoRoute On Current Layer и AutoRoute On Multiple Layers недоступны. |
| Shift+D | Включение/выключение автоматического удаления петель. |
| Ctrl+W | Включение/выключение отображения границ зазоров. |
| Shift+F | Переключение режима следования. |
| Shift+W | Выбор необходимой ширины проводника из предустановленных избранных значений ширины трассировки в режиме Проводник панели Properties . |
| Shift+V | Выбор необходимого размера переходного отверстия из предустановленных размеров, полученных из одного или нескольких связанных шаблонов переходных отверстий, в диалоговом окне Выбор размеров переходных отверстий. |
| 3 | Циклическое переключение источников ширины трассировки (User Choice --> Rule Minimum --> Rule Preferred --> Rule Maximum). При использовании User Choice значения ширины трассировки задаются и настраиваются в диалоговом окне Избранные значения ширины интерактивной трассировки. При интерактивной трассировке дифференциальных пар значения, определяемые правилами, берутся из применимого правила трассировки дифференциальных пар. |
| 4 | Циклическое переключение источников размеров переходных отверстий (User Choice --> Rule Minimum --> Rule Preferred --> Rule Maximum). При использовании User Choice размеры переходных отверстий задаются шаблонами переходных отверстий — локально в активном документе печатной платы или в связанных библиотеках контактных площадок и переходных отверстий (*.PvLib). |
| + или * (на цифровой клавиатуре) | Переключение на следующий включённый (и разрешённый правилами) сигнальный слой с размещением переходного отверстия. |
| - (на цифровой клавиатуре) | Переключение на предыдущий включённый (и разрешённый правилами) сигнальный слой с размещением переходного отверстия. |
| Shift+Ctrl+Mouse Wheel | Циклическое переключение между включёнными сигнальными слоями с размещением переходного отверстия. При прокрутке колеса мыши вверх/вниз следующий/предыдущий включённый сигнальный слой (в нижней части главного окна проектирования) становится активным, и размещается переходное отверстие. Это настройка по умолчанию, которую можно изменить на странице Система — Настройка колеса мыши диалогового окна Preferences. |
| 1-9 (на цифровой клавиатуре) | Переключение на трассировку на соответствующем сигнальном слое с размещением переходного отверстия. Номер можно определить по префиксу имени слоя ([n]) на вкладке слоя в нижней части основной рабочей области. Кроме того, номер можно узнать во всплывающем окне, открываемом с помощью сочетания клавиш Ctrl+L. |
| Ctrl+L | Открыть всплывающее окно со списком доступных слоев трассировки. Нажмите на элемент списка, чтобы переключиться на соответствующий слой (с установкой переходного отверстия). Число справа от каждого элемента ([n]) можно использовать для прямого переключения на этот слой без открытия окна. |
| L | При трассировке от многослойной контактной площадки или переходного отверстия переключает слой текущего соединения на следующий сигнальный слой, заданный для этой площадки или переходного отверстия. Обратите внимание: эта функция работает только в том случае, если трассировка начата от контактной площадки или переходного отверстия, и только до фиксации первого сегмента. |
| / | Добавить переходное отверстие для веерного вывода; после этого инструмент сразу ожидает трассировки следующего веерного вывода и размещения переходного отверстия. |
| 2 | Добавить переходное отверстие без смены слоя. |
| 5 | При интерактивной трассировке дифференциальной пары или нескольких проводников позволяет циклически переключать доступные схемы расположения переходных отверстий (в ряд или в шахматном порядке) при смене слоя. |
| 6 | Циклически переключать доступные типы переходных отверстий при смене слоя, если доступно несколько типов. |
| Shift+6 | При интерактивной трассировке дифференциальной пары позволяет циклически переключать значения зазора, заданные в применимом правиле трассировки дифференциальных пар (Min Gap --> Preferred Gap --> Max Gap). |
| Shift+B |
|
| B | При трассировке нескольких проводников позволяет уменьшить расстояние между соседними трассами. |
| C | При трассировке нескольких проводников устанавливает расстояние между соседними трассами равным зазору между проводниками, заданному в применимом правиле зазоров. |
| 8 | Открыть всплывающий список доступных типов переходных отверстий при смене слоя, если доступно несколько типов. |
| 7 | Циклически переключает доступные для трассировки соединения, если у текущей контактной площадки их несколько. |
| 9 | Перемещает курсор с выбранной контактной площадки или проводника на целевую площадку или проводник. Если целевой объект находится за пределами текущего окна проекта, вид смещается и центрируется относительно нового положения курсора. |
| Shift+G | Включить или выключить отображение индикатора настройки длины, который показывает, насколько текущая трасса соответствует применимым правилам проектирования, задающим длину и согласование длин. |
| Shift+Ctrl+G | Циклически переключать настройки Gloss Effort (Routed) — Off, Weak и Strong. Дополнительные сведения см. в разделе Сглаживание трасс. |
| Ctrl+Shift | Удерживайте, чтобы временно отключить автоматическое сглаживание. |
| Shift+C | Включить переключение подсетей. Если доступных для переключения целевых подсетей нет, на панели Messages появится соответствующее сообщение. |
| Shift+T | Переключить целевую подсеть — циклически перебирает все доступные для переключения целевые подсети. |
Сочетания клавиш для интерактивного сдвига
Следующие дополнительные сочетания клавиш доступны при изменении существующих трасс путем интерактивного сдвига (или перетаскивания) трассы по плате. Дополнительные сведения см. в разделе Поддержка интерактивного сдвига.
| Click+Hold&Drag | На сегменте проводника — для его сдвига. |
| Shift+Spacebar | Во время сдвига позволяет циклически переключать три режима Hugging Style (на странице PCB Editor - Interactive Routing диалогового окна Preferences ): 45 Degree, Mixed и Rounded. |
| Shift+R | Циклически переключать включенные режимы разрешения конфликтов трассировки. Доступные режимы (включая Ignore Obstacles, Push Obstacles, Walkaround Obstacles, Stop at First Obstacle, Hug and Push Obstacles, AutoRoute On Current Layer, AutoRoute On Multiple Layers) можно задать на странице PCB Editor — Interactive Routing диалогового окна Preferences и изменять на лету (нажмите Tab , чтобы перейти в режим Interactive Sliding панели Properties ). Обратите внимание: при интерактивном сдвиге проводника режимы AutoRoute On Current Layer и AutoRoute On Multiple Layers недоступны. |
| Spacebar | При перетаскивании вершины используйте это сочетание клавиш для циклического переключения режимов Vertex Action: Deform, Scale и Smooth. |
| Shift+Ctrl+G | Циклически переключать режимы Gloss Effort (Routed) — Off, Weak и Strong. Дополнительные сведения см. в разделе Сглаживание трасс. |
| Z | Включить или выключить параметр Keep Coupled. |
| C | Включить или выключить параметр Include Miters. |
| R | Включить или выключить параметр Merge Parallel. |
| Ctrl+W | Включить или выключить отображение границ зазоров. |
| Shift+G | Включить или выключить отображение индикатора настройки длины, который показывает, насколько текущая трасса соответствует применимым правилам проектирования, задающим длину и согласование длин. |
Сочетания клавиш для настройки длины
Следующие дополнительные сочетания клавиш предназначены для размещения и последующего редактирования дополнительных «шаблонов» проводников при настройке длины проложенных проводников с помощью одного из инструментов интерактивной настройки длины — Interactive Length Tuning или Interactive Diff Pair Length Tuning. Обратите внимание: доступные сочетания клавиш зависят от используемого инструмента интерактивной настройки длины или типа редактируемого размещенного шаблона.
During Pattern Placement |
|
| Spacebar | При настройке длины с помощью шаблонов Accordion или Trombone позволяет циклически переключать поддерживаемые стили углов в прямом порядке. Доступные стили: Mitered Lines, Mitered Arcs и Rounded. |
| Shift+Spacebar | При настройке длины с помощью шаблонов Accordion или Trombone позволяет циклически переключать поддерживаемые стили углов в обратном порядке. |
| Shift+G | Включить или выключить отображение индикатора настройки длины. |
| Tab | Открыть Interactive Length Tuning mode / Interactive Differential Pair Length Tuning mode панели Properties. Доступные действия зависят от того, когда используется сочетание клавиш:
|
| , |
|
| . |
|
| 1 | При настройке длины с помощью шаблонов Accordion или Trombone позволяет уменьшить процентное значение Miter для углов шаблона на величину, заданную в соответствующем поле Step. Обратите внимание: это применимо только при использовании стилей скоса Mitered Lines или Mitered Arcs. |
| 2 | При подстройке длины с использованием шаблонов Accordion или Trombone позволяет увеличить процентное значение Miter для углов шаблона на величину, заданную в соответствующем поле Step. Обратите внимание: это применимо только при использовании стилей скоса Mitered Lines или Mitered Arcs. |
| 3 | При подстройке длины с использованием шаблонов Accordion или Trombone позволяет уменьшить Space (шаг) на величину, заданную в соответствующем поле Step. |
| 4 | При подстройке длины с использованием шаблонов Accordion или Trombone позволяет увеличить Space (шаг) на величину, заданную в соответствующем поле Step. |
| Удерживайте Shift | При подстройке длины с использованием шаблонов Trombone или Sawtooth позволяет сдвигать шаблон. Отпустите, чтобы продолжить размещение шаблона. |
After Pattern Placement |
|
| Click&Drag |
|
| Ctrl+Click &Drag |
|
| Shift+Click &Drag | На границе «рукава» выбранного шаблона Trombone или Sawtooth — для сдвига шаблона вдоль исходной траектории трассировки с сохранением его поперечного распределения относительно этой траектории. |
| S | При подстройке длины с использованием шаблонов Trombone или Sawtooth позволяет включать и выключать параметр Single Side. Когда он включен, шаблон подстройки создается так, чтобы выступать только в одну сторону от исходной траектории трассировки. Включение и выключение параметра Single Side фактически заново центрирует выбранный шаблон. |
| R | При подстройке длины с использованием шаблона Accordion позволяет во время поворота включать и выключать привязку угла поворота с шагом 45 градусов. |
Сочетания клавиш для перемещения и перетаскивания компонентов
Следующие дополнительные сочетания клавиш доступны при интерактивном перетаскивании или перемещении одного или нескольких размещенных компонентов. Все они относятся к функции перемещения компонентов с учетом трассировки в редакторе печатных плат.
| Shift+R | Включение и выключение параметра Component re-route (на странице PCB Editor - Interactive Routing диалогового окна Preferences ). Когда этот параметр включен, функция разрывает трассировку у контактных площадок компонента, на участках веерного вывода или выхода из-под компонента, а затем пытается заново проложить разорванные соединения после размещения перемещаемого компонента. |
| R | Последовательное переключение режимов Component pushing: Avoid, Push и Ignore. |
| Shift+Tab | Если параметр Move component with relevant routing включен (на странице PCB Editor - Interactive Routing диалогового окна Preferences ), используйте это сочетание клавиш для последовательного переключения набора перемещаемых объектов следующим образом:
|
| Удерживайте клавишу Ctrl | При перемещении компонента — для отображения динамических направляющих выравнивания (зеленых индикаторных линий) относительно границ этого и соседних компонентов. |
| Удерживайте клавишу Shift | При перемещении компонента — для отображения динамических направляющих выравнивания (зеленых индикаторных линий) относительно контактных площадок этого и соседних компонентов. |
| N | Последовательное переключение режимов Net Line Connect: Pad To Pad (соединения от контактных площадок других подключенных компонентов), Breaks (соединения от концов дорожек частично проложенных трасс) и Hidden. |
| Shift+Ctrl+G | Последовательное переключение режимов Gloss Effort (Routed) — Off, Weak и Strong. Подробнее см. Глоссинг — сглаживание трасс. |
Сочетания клавиш для работы в 3D
Следующие дополнительные сочетания клавиш относятся к работе с 3D-телами или трехмерным представлением печатной платы (либо модели компонента).
3D Body Placement(Доступность зависит от типа размещаемой или перемещаемой 3D-модели — Generic 3D Model, Extruded, Cylinder или Sphere) |
|
| 8 (на цифровой клавиатуре) | Поворот размещаемого или перемещаемого 3D-тела против часовой стрелки вокруг оси X модели на 90°. Обратите внимание: это сочетание клавиш применимо только к моделям типов Generic 3D Model и Cylinder. |
| 2 (на цифровой клавиатуре) | Поворот размещаемого или перемещаемого 3D-тела по часовой стрелке вокруг оси X модели на 90°. Обратите внимание: это сочетание клавиш применимо только к моделям типов Generic 3D Model и Cylinder. |
| 4 (на цифровой клавиатуре) | Поворот размещаемого или перемещаемого 3D-тела против часовой стрелки вокруг оси Y модели на 90°. Обратите внимание: это сочетание клавиш применимо только к моделям типов Generic 3D Model и Cylinder. |
| 6 (на цифровой клавиатуре) | Поворот размещаемого или перемещаемого 3D-тела по часовой стрелке вокруг оси Y модели на 90°. Обратите внимание: это сочетание клавиш применимо только к моделям типов Generic 3D Model и Cylinder. |
| Spacebar | Поворот размещаемого или перемещаемого 3D-тела против часовой стрелки вокруг оси Z модели на 90°. Обратите внимание: это сочетание клавиш применимо только к модели типа Extruded при ее перемещении. |
| Shift+Spacebar | Поворот размещаемого или перемещаемого 3D-тела по часовой стрелке вокруг оси Z модели на 90°. Обратите внимание: это сочетание клавиш применимо только к модели типа Extruded при ее перемещении. |
| 9 (на цифровой клавиатуре) | Увеличение значения Standoff Height для размещаемого или перемещаемого 3D-тела на один шаг сетки привязки. Обратите внимание: это сочетание клавиш применимо только к модели типа Extruded при ее перемещении. |
| 3 (на цифровой клавиатуре) | Уменьшение значения Standoff Height для размещаемого или перемещаемого 3D-тела на один шаг сетки привязки. Обратите внимание: это сочетание клавиш применимо только к модели типа Extruded при ее перемещении. |
Visualization |
|
| 0 (или 1 на цифровой клавиатуре) | Изменение вида платы (или компонента) на вид строго сверху (перпендикулярно) без поворота. |
| 9 (или 9 на цифровой клавиатуре) | Изменение вида платы (или компонента) на вид строго сверху (перпендикулярно) с поворотом на 90 градусов по часовой стрелке в плоскости X. |
| 8 (или 0 на цифровой клавиатуре) | Изменение вида платы (или компонента) для отображения в ортогональной проекции. |
| 5 (или 5 на цифровой клавиатуре) | Переключение платы с гибкими участками между развернутым состоянием (параметры линий сгиба не применены) и согнутым состоянием (применены все параметры линий сгиба) |
| Удерживайте Shift | Доступ к сфере вращения в 3D. Когда сфера отображается, перемещайте мышь, чтобы подсветить и выбрать нужный элемент управления на сфере, а затем нажмите правую кнопку мыши:
|
| Ctrl+C | Копирование текущего вида из основной рабочей области проектирования в буфер обмена в растровом формате (*.bmp). Разрешение копируемого изображения можно настроить в диалоговом окне 3D Snapshot Resolution. |
| Ctrl+1 (на цифровой клавиатуре) | Изменение вида платы (или компонента) для просмотра снизу. |
| 7 (на цифровой клавиатуре) | Изменение вида платы (или компонента) для просмотра спереди. |
| Ctrl+7 (на цифровой клавиатуре) | Изменение вида платы (или компонента) для просмотра сзади. |
| 3 (на цифровой клавиатуре) | Изменение вида платы (или компонента) для просмотра со стороны левого края. |
| Ctrl+3 (на цифровой клавиатуре) | Изменение вида платы (или компонента) для просмотра со стороны правого края. |
| 4 (на цифровой клавиатуре) | Поворот вида платы (или компонента) на 30 градусов влево. |
| 6 (на цифровой клавиатуре) | Поворот вида платы (или компонента) на 30 градусов вправо. |
| 8 (на цифровой клавиатуре) | Поворот вида платы (или компонента) на 30 градусов вверх. |
| 2 (на цифровой клавиатуре) | Поворот вида платы (или компонента) на 30 градусов вниз. |
| Ctrl+4 (на цифровой клавиатуре) | Перемещение вида платы (или компонента) влево. |
| Ctrl+6 (на цифровой клавиатуре) | Перемещение вида платы (или компонента) вправо. |
| Ctrl+8 (на цифровой клавиатуре) | Перемещение вида платы (или компонента) вверх. |
| Ctrl+2 (на цифровой клавиатуре) | Перемещение вида платы (или компонента) вниз. |
| L | Открытие панели Конфигурация вида, на которой можно настроить отображение платы в 3D. |
Measurements(Доступно при просмотре платы в 3D в редакторе печатных плат и выполнении измерений с помощью команды Reports » Measure 3D Objects) |
|
| Q | Переключение между метрическими и британскими единицами измерения — отображаемые значения измерений обновляются соответствующим образом. |
| Удерживайте Ctrl клавишу нажатой | При наведении курсора на 3D-объект позволяет выбрать определенную грань этого объекта. |
| Shift+C | Удаление всех измерений, отображаемых в данный момент в рабочей области 3D. |
Сочетания клавиш для всплывающих меню
Следующие сочетания клавиш позволяют открывать определенные всплывающие меню команд непосредственно в рабочей области проектирования. Некоторые из них уже могут быть вам знакомы: это подменю главных меню редактора. Для каждого главного меню также назначена клавиша быстрого вызова из рабочей области проектирования. Подробнее см. в разделе Клавиши быстрого доступа.
| A | Подменю Align (из главного меню Edit). |
| B | Подменю Toolbars (из главного меню Вид). |
| G | Всплывающее меню с командами сетки привязки. |
| I | Подменю Component Placement (из главного меню Tools). |
| J | Подменю Jump (из главного меню Edit). |
| K | Подменю Panels (из главного меню View). |
| M | Подменю Move (из главного меню Edit). |
| N | Всплывающее меню с командами отображения соединений и перемычек. |
| O | Всплывающее меню для быстрого доступа к параметрам и настройкам. |
| S | Подменю Select (из главного меню Edit). |
| X | Подменю DeSelect (из главного меню Edit). |
| Y | Всплывающее меню с командами фильтрации. |
| Z | Всплывающее меню с командами масштабирования. |