Высокоскоростное проектирование

Краткий обзор

В этой статье рассказывается, как Altium Designer помогает проектировать высокоскоростные печатные платы: обеспечивать целостность сигналов, определять критически важные сигнальные пути и применять правила трассировки с контролируемым импедансом с учетом стека слоев и материалов платы. В ней рассматриваются ключевые аспекты проектирования, объясняется, как анализ целостности сигналов до и после трассировки позволяет выявлять проблемы с отражениями на ранних этапах, и показано, как xSignals, профили импеданса и правила трассировки совместно обеспечивают точную реализацию высокоскоростных соединений. Если вы хотите лучше разобраться в настройке Altium Designer для проектирования надежных высокоскоростных плат, этот обзор поможет понять взаимосвязь основных инструментов и настроек. Читайте дальше и шаг за шагом осваивайте их применение.

- Узнайте об основных аспектах проектирования высокоскоростных плат, которыми помогает управлять Altium Designer: от согласования линий и путей возвратного тока до переходных отверстий, дифференциальных пар и контроля длины проводников.
- Разберитесь, как анализ целостности сигналов до и после трассировки помогает выявлять потенциальные проблемы с отражениями и уточнять решения по согласованию линий.
- Узнайте, как xSignals, профили импеданса стека слоев и правила проектирования для трассировки используются для определения, измерения и контроля критически важных высокоскоростных соединений.
Узнайте больше с ИИ:

Проектирование высокоскоростных устройств в Altium Designer

Проектирование высокоскоростных печатных плат — это процесс поиска баланса между требованиями к схеме, технологиями компонентов, материалами и методами изготовления, позволяющий создать печатную плату, которая обеспечивает передачу сигналов между компонентами с сохранением их целостности.

На этой странице описаны различные параметры и настройки Altium Designer, необходимые для успешного проектирования высокоскоростной платы. Если вы хотите узнать больше о проектировании высокоскоростных устройств, ознакомьтесь с материалом Ключевые аспекты проектирования высокоскоростных печатных плат.

Что необходимо учитывать

При трассировке платы с высокоскоростными сигналами необходимо учитывать:

  • Согласующие компоненты, которые могут потребоваться

  • Определение сигналов, к которым необходимо применять правила проектирования высокоскоростных цепей

  • Геометрические размеры проводников — для трассировки с контролируемым импедансом

  • Свойства и размеры материалов платы

  • Количество и расположение слоев в стеке

  • Путь возвратного тока каждого высокоскоростного сигнала

  • Влияние и конфигурацию переходных отверстий

  • Конфигурацию и трассировку дифференциальных пар

  • Настройку и контроль длины трасс

Анализ целостности сигналов до и после трассировки

На ранних этапах проектирования важно определить сигналы, для которых может потребоваться согласование импеданса, чтобы добавить необходимые согласующие компоненты до завершения размещения компонентов. Поскольку выходные выводы обычно имеют низкий импеданс, а входные — высокий, для согласования импеданса может потребоваться добавить в проект согласующие компоненты.

Altium Designer включает симулятор целостности сигналов, доступный как на этапе разработки схемы, так и на этапе проектирования платы. Это позволяет выполнять анализ целостности сигналов до и после трассировки (Tools » Signal Integrity). Симулятор целостности сигналов моделирует поведение разведенной платы, используя в качестве входных данных рассчитанный волновой импеданс проводников в сочетании с данными макромоделей буферов ввода-вывода. В основе симулятора лежит механизм быстрого моделирования отражений и перекрестных помех, который обеспечивает высокую точность благодаря алгоритмам, проверенным на практике в отрасли.

Поскольку при разработке схемы и проектировании платы используется единая система компонентов, связывающая условные графические обозначения с соответствующими посадочными местами на печатной плате, моделями SPICE и макромоделями целостности сигналов, анализ целостности сигналов можно выполнять еще на этапе разработки схемы, до создания проекта платы. Если проект платы еще не создан, инструмент позволяет задать физические характеристики проекта, например требуемый волновой импеданс проводников, непосредственно в симуляторе целостности сигналов. На этом этапе, до трассировки, симулятор не может определить фактическую длину конкретных соединений, поэтому для расчета линий передачи он использует среднюю длину соединения, задаваемую пользователем. Если тщательно выбрать эту длину по умолчанию с учетом размеров будущей платы, можно получить достаточно точное представление об ожидаемой целостности сигналов в проекте.

Цепи с потенциальными проблемами отражения сигналов можно выявить, а необходимые дополнительные согласующие компоненты — добавить на схему до перехода к проектированию платы. Затем, после анализа целостности сигналов по результатам трассировки, номиналы этих компонентов можно уточнить.

Механизм анализа целостности сигналов помогает выявлять цепи с потенциальными проблемами отражения. Обратите внимание, что измерения можно выполнять непосредственно на осциллограммах.
Механизм анализа целостности сигналов помогает выявлять цепи с потенциальными проблемами отражения. Обратите внимание, что измерения можно выполнять непосредственно на осциллограммах.

► Подробнее о согласовании импеданса компонентов

Для доступа к механизму анализа целостности сигналов в Altium Designer необходимо установить системное расширение Signal Integrity Analysis. По умолчанию это расширение устанавливается вместе с Altium Designer. Его можно установить или удалить вручную.

Подробнее об управлении расширениями см. на Extending Your Installation странице (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Определение высокоскоростных сигналов

Main page: Определение путей высокоскоростных сигналов с помощью xSignals

Проектирование высокоскоростных устройств — это искусство управления потоком энергии от одной точки печатной платы к другой. Как разработчик, вы должны иметь возможность сосредоточить внимание и применить ограничения проектирования к сигналу, проходящему от одной точки платы к другой. Однако такой сигнал не обязательно соответствует одной цепи печатной платы. Это может быть одна из ветвей A0 в проекте, который вы собираетесь трассировать по Т-образной топологии. При этом другая ветвь A0 будет отдельным сигналом, которому также необходимо уделить внимание, а длины трасс этих двух сигналов потребуется сравнивать. Или на пути сигнала может находиться последовательный согласующий компонент, который редактор печатных плат воспринимает как один компонент и две цепи. Если такой сигнал входит в дифференциальную пару, его длину необходимо сравнивать с длиной второго сигнала этой пары.

Для выполнения этих требований можно использовать функцию xSignals, где xSignal, по сути, представляет собой заданный пользователем путь сигнала. Выберите исходную и конечную контактные площадки в рабочей области или на панели PCB, затем щелкните правой кнопкой мыши по любой из них, чтобы определить этот путь сигнала как xSignal. Помимо интерактивного определения xSignal по начальной и конечной площадкам, можно запустить интеллектуальный мастер xSignals Wizard, эвристические алгоритмы которого помогут быстро создать большое количество xSignals между выбранными компонентами. Затем эти xSignals можно использовать для применения правил проектирования к высокоскоростным сигналам. Программа учитывает структуру xSignals: например, она рассчитывает суммарную длину нескольких цепей, соединенных через согласующий компонент, а также длину пути через сам компонент.

На панели PCB предусмотрен режим xSignal, который используется для просмотра xSignals и управления ими. Панель также отображает сведения о длине сигналов, выделяя xSignals, близкие к предельным значениям применимых ограничений проектирования, желтым цветом, а нарушающие эти ограничения — красным. На изображении ниже длины xSignals дифференциальной пары CLK1 различаются больше, чем допускает применимое правило выравнивания длин Matched Length. На панели отображается Signal Length — точная длина между конечными точками. При расчете длины сигнала устраняются типичные погрешности учета длины, связанные с проводниками внутри контактных площадок и наложенными сегментами проводников, а также используются точные расстояния прохождения сигнала через переходные отверстия.

Используйте режим xSignals панели PCB для управления xSignals и их изучения. Обратите внимание на тонкую линию: она обозначает путь сигнала через последовательный компонент. (Изображение предоставлено FEDEVEL Open Source, www.fedevel.com)
Используйте режим xSignals панели PCB для управления xSignals и их изучения. Обратите внимание на тонкую линию: она обозначает путь сигнала через последовательный компонент. (Изображение предоставлено FEDEVEL Open Source, www.fedevel.com)

Также поддерживается учет задержки, обусловленной длиной вывода внутри корпуса компонента, с помощью параметра Задержка вывода в корпусе.

► Подробнее о xSignals.

Определение параметров трассировки

Main page: Трассировка с контролируемым импедансом

Традиционно разработчики печатных плат задавали ширину и толщину проводников, указывая значение ширины и выбирая толщину меди для соответствующего слоя. Как правило, этого было достаточно, поскольку требовалось лишь обеспечить прохождение необходимого тока и соблюдение зазоров с учетом рабочего напряжения. Для высокоскоростных сигналов в проекте такого подхода недостаточно: необходимо контролировать импеданс их трасс.

Трассировка с контролируемым импедансом предполагает настройку геометрических размеров проводников и свойств материалов платы для получения заданного импеданса. Для этого создают подходящий профиль импеданса, а затем назначают его критически важным высокоскоростным цепям в правилах трассировки.

Определение профиля импеданса

Main page: Настройка стека слоев для трассировки с контролируемым импедансом

Профили импеданса определяются в Layer Stack Manager (Design » Layer Stack Manager) редактора печатных плат. Layer Stack Manager открывается в редакторе документов так же, как лист схемы, печатная плата и другие типы документов.

После настройки свойств слоев перейдите на вкладку Layer Stack Manager's Impedance, чтобы добавить или изменить профили импеданса для одиночных проводников или дифференциальных пар.

Профиль импеданса 50 Ом для отдельных цепей, трассируемых на верхнем слое. Наведите курсор на изображение, чтобы увидеть настройки того же профиля для слоя L3.Профиль импеданса 50 Ом для отдельных цепей, трассируемых на верхнем слое. Наведите курсор на изображение, чтобы увидеть настройки того же профиля для слоя L3.

Расчет импеданса выполняется электромагнитным вычислительным ядром Simbeor® SFS для анализа целостности сигналов от компании Simberian. Simbeor SFS — это современный квазистатический двумерный решатель электромагнитного поля на основе метода моментов, точность которого подтверждена проверками сходимости, сравнительными испытаниями и измерениями. Ядро Simbeor SFS поддерживает все современные структуры и материалы печатных плат, включая использование полигонов на сигнальных слоях в качестве опорных слоев.

► Подробнее о настройке стека слоев для трассировки с контролируемым импедансом

Настройка правил проектирования

Импеданс трассы определяется шириной и толщиной проводника, а также свойствами окружающих диэлектрических материалов. На основе свойств материалов, заданных в Layer Stack Manager, при создании каждого профиля импеданса рассчитывается требуемая ширина проводников. В зависимости от свойств материалов эта ширина может меняться при переходе на другой слой трассировки. Необходимое изменение ширины при смене слоев автоматически обеспечивается соответствующим правилом трассировки, настроенным в редакторе правил и ограничений печатной платы (Design » Rules).

В большинстве проектов печатных плат есть определенный набор цепей, которые необходимо трассировать с контролируемым импедансом. Обычно для них создают класс цепей или класс дифференциальных пар, а затем задают правило трассировки, применяемое к этому классу, как показано на изображениях ниже.

Обычно минимальную, максимальную и предпочтительную ширину задают вручную: либо в верхней области настроек ограничений, чтобы применить их ко всем слоям, либо отдельно для каждого слоя в таблице слоев. Для трассировки с контролируемым импедансом вместо этого включите параметр Use Impedance Profile, а затем выберите нужный профиль импеданса в раскрывающемся списке. После этого область Constraints правила изменится. Прежде всего вы заметите, что в области доступных слоев правила проектирования больше не отображаются все сигнальные слои платы: теперь в ней показаны только слои, включенные в выбранном профиле импеданса. Значения предпочтительной ширины и зазора дифференциальной пары обновятся в соответствии со значениями, рассчитанными для каждого слоя. Эти предпочтительные значения нельзя изменить, но минимальные и максимальные значения можно редактировать — задайте для них подходящие меньшие и большие значения.

Правило проектирования для ширины трассировки

Для одиночных цепей ширина проводников задается правилом проектирования Ширина трассировки.

При выборе использования профиля импеданса доступные слои и предпочтительная ширина определяются выбранным профилем.При выборе использования профиля импеданса доступные слои и предпочтительная ширина определяются выбранным профилем.

Правило проектирования для трассировки дифференциальных пар

Трассировка дифференциальных пар регулируется правилом проектирования Трассировка дифференциальных пар.

Для дифференциальной пары доступные слои, предпочтительная ширина и предпочтительный зазор определяются выбранным профилем.Для дифференциальной пары доступные слои, предпочтительная ширина и предпочтительный зазор определяются выбранным профилем.

► Подробнее о трассировке дифференциальных пар

Углы поворота трасс высокоскоростных сигналов вызывают немало споров. Хотя все согласны с тем, что электроны не «вылетают» из проводника на повороте под 90 градусов, обычный прямоугольный поворот имеет увеличенную ширину по диагонали угла, что изменяет импеданс трассы. Предпочтительны скругленные повороты или повороты под 45 градусов — оба варианта входят в стандартные возможности интерактивного трассировщика редактора печатных плат. При необходимости на поворотах под 90 градусов можно срезать углы с помощью команды Convert Selected Tracks to Chamfered Path. Обратите внимание, что эта команда преобразует выбранные сегменты проводников в единый объект-область.

Выбор импеданса

Как определить, какое целевое значение импеданса выбрать? Обычно оно определяется характерным выходным импедансом используемого семейства логических элементов или технологии. Например, для логики ECL характерен импеданс 50Ом, а для TTL выходной импеданс находится в диапазоне от 70Ом до 100Ом. Во многих проектах обычно используют целевой импеданс от 50Ом до 60Ом, а для дифференциальных пар — дифференциальный импеданс 90Ом или 100 Ом. Помните: чем ниже импеданс, тем больше потребляемый ток; чем выше импеданс, тем выше вероятность излучения электромагнитных помех и тем чувствительнее сигнал к перекрестным помехам.

Дифференциальную пару с импедансом 100Ом можно также рассматривать как две одиночные трассы одинаковой длины с импедансом 50Ом каждая. Это не совсем точно из-за связи между проводниками пары: чем ближе они друг к другу, тем сильнее связь и тем ниже дифференциальный импеданс пары. Чтобы сохранить дифференциальный импеданс 100Ом , можно уменьшить ширину каждого проводника, что немного увеличит волновое сопротивление каждой трассы в паре — на несколько ом.

Определение свойств платы

Main page: Управление стеком слоев

Материалы слоев платы, их размеры, количество и порядок расположения задаются в менеджере стека слоев. Здесь настраиваются различные слои, необходимые для изготовления готовой платы, включая медные сигнальные слои и слои сплошной металлизации, разделяющие медь диэлектрические слои, защитные покрытия и слои шелкографии компонентов.

Все изготавливаемые слои задаются на вкладке Stackup менеджера стека слоев.
Все изготавливаемые слои задаются на вкладке Stackup менеджера стека слоев.

Подробные сведения о свойствах материалов, заданных в Layer Stack Manager, включаются в таблицу стека слоев, а также в легенду стека слоев, размещенную в документе Draftsman.

Вы также можете Save стек слоев как шаблон в Layer Stack Manager (меню File), а затем Load этот шаблон в последующие проекты.

Настройка переходных отверстий

Main page: Определение типов переходных отверстий

Как упоминалось в обзорном разделе этой страницы, переходные отверстия влияют на импеданс сигнальных трасс и являются важным фактором при высокоскоростном проектировании. Помимо длины, диаметра отверстия и площади контактной площадки переходного отверстия, влияющих на импеданс, который видит сигнал, любая неиспользуемая часть металлизированного ствола переходного отверстия может действовать как шлейф, вызывающий отражения сигнала. Для решения этой проблемы можно изготавливать переходные отверстия различных типов между слоями, включая глухие, скрытые, микропереходные и переходные отверстия с пропуском слоёв. Все эти типы переходных отверстий поддерживаются в Altium Designer.

Переходные отверстия определяются в составе стека слоёв на вкладке Layer Stack Manager's Via Types. Также поддерживается обратное высверливание неиспользуемых участков стволов переходных отверстий; его параметры задаются на вкладке Layer Stack Manager's Back Drills (подробнее о настройке платы для обратного высверливания).

Все типы переходных отверстий, которые можно изготовить, можно определить на вкладке Via Types в Layer Stack Manager.Все типы переходных отверстий, которые можно изготовить, можно определить на вкладке Via Types в Layer Stack Manager.

Для изучения влияния переходных отверстий проводились количественные исследования, например описанное в рекомендациях по применению Altera AN529 Методы оптимизации переходных отверстий при проектировании высокоскоростных каналов.

На основе этого исследования и других источников можно сформулировать следующие рекомендации по минимизации влияния переходных отверстий:

  • Уменьшайте размер контактного кольца переходного отверстия в месте подключения сигнальной трассы. В рекомендациях по применению для механически просверленных переходных отверстий предлагается диаметр площадки/отверстия 20/10 мил (0,5/0,25 мм).
  • Удаляйте неиспользуемые контактные кольца (также известные как NFP, или нефункциональные контактные площадки) на слоях, к которым переходное отверстие не подключено. Для этого используйте команду Tools » Remove Unused Pad Shapes.
  • Увеличивайте зазор между стволом переходного отверстия и соседними слоями-плоскостями. Этот зазор задаётся правилом проектирования Power Plane Clearance; в рекомендациях по применению предлагается значение от 40 до 50 мил (от 1,0 до 1,25 мм). Учтите, что это увеличивает размер вырезов в этих слоях-плоскостях.
  • Размещайте сшивающие переходные отверстия рядом с сигнальными переходными отверстиями всякий раз, когда смена слоя сигнальной трассы приводит к переходу пути возвратного тока на другой слой. Если новая опорная плоскость имеет то же напряжение, что и исходная, эти плоскости следует соединить переходным отверстием на расстоянии не более 35 мил (0,9 мм) от сигнального переходного отверстия (между центрами).
  • Если сигнальная трасса меняет слой и новая опорная плоскость имеет другое напряжение, размещайте развязывающие конденсаторы рядом с сигнальным переходным отверстием. Такой конденсатор обеспечивает развязку непосредственно между двумя плоскостями независимо от их напряжений. Учтите, что это решение может привести к передаче помех с одной плоскости на другую, поэтому применять его для уменьшения площади контура возвратного тока следует только в крайнем случае.
  • Удаляйте шлейфы переходных отверстий — лишние участки ствола за пределами слоя, на котором сигнальная трасса подключается к переходному отверстию. Для этого используют подходящие глухие и скрытые переходные отверстия либо обратное высверливание переходных отверстий при изготовлении.

Проектирование переходных отверстий — ключевой этап разработки высокоскоростной платы. Возможные варианты соединения слоёв переходными отверстиями определяются технологическим процессом, выбранным для изготовления стека слоёв. Поэтому технологию изготовления и сверления необходимо выбирать одновременно с определением типов переходных отверстий и стека слоёв.

Редактор печатных плат поддерживает обратное высверливание (также называемое сверлением с контролируемой глубиной). Эта функция позволяет выполнять обратное высверливание с обеих сторон платы, а места его выполнения можно легко просматривать с помощью панели PCB при отображении платы в 3D.

Подробнее о сверлении с контролируемой глубиной.

Организация пути возвратного тока для высокоскоростных сигналов

Для каждого высокоскоростного сигнала в проекте необходим качественный путь возвратного тока. Всякий раз, когда возвратный ток отклоняется от пути под сигнальной трассой, образуется контур, который становится источником электромагнитных помех. Уровень этих помех напрямую связан с площадью контура.

Создание плоскостей питания

  • Плоскость питания можно создать как на слое-плоскости, так и на сигнальном слое, покрытом одним или несколькими полигонами.
  • Создание плоскости питания на слое-плоскости:
    • Слои-плоскости добавляются в Layer Stack Manager: щёлкните правой кнопкой мыши по существующему слою и выберите Insert layer above или Insert layer below, чтобы добавить новый слой-плоскость.
    • Выберите слой-плоскость в качестве активного и дважды щёлкните в любой точке плоскости, чтобы открыть диалоговое окно Split Plane, в котором можно назначить цепь.
    • Программа автоматически отодвигает край плоскости от края платы на величину, указанную в столбце Pullback Distance для этого слоя в Layer Stack Manager. Если этот столбец не отображается, щёлкните правой кнопкой мыши по заголовку существующего столбца, чтобы получить доступ к команде Select Columns.
    • Слой-плоскость можно разделить на отдельные области, разместив линии (Place » Line). После начала размещения первого сегмента линии нажмите Tab, чтобы задать ширину разделительной линии. Размещайте сегменты линий от одного края платы до другого либо создайте замкнутый контур для формирования островка. Программа автоматически распознает отдельные фигуры, образованные разделительными линиями; дважды щёлкните по каждой фигуре, чтобы назначить ей цепь.
  • Создание плоскости питания с помощью полигонов на сигнальном слое:
    • Сигнальные слои добавляются в Layer Stack Manager: щёлкните правой кнопкой мыши по существующему слою и выберите Insert layer above или Insert layer below, чтобы добавить новый сигнальный слой.
    • Если требуются отдельные зоны питания, проще покрыть весь слой полигоном, а затем разрезать его (Place » Slice Polygon Pour). После начала размещения линии разреза нажмите Tab, чтобы открыть диалоговое окно Line Constraints, в котором можно задать ширину разреза. Эта ширина станет расстоянием между двумя полигонами, созданными при разрезании. Линия разреза должна начинаться и заканчиваться за пределами полигона.
    • Чтобы повторно залить полигон, щёлкните правой кнопкой мыши и выберите Polygon Actions » Repour Selected в контекстном меню. 
    • Полигоны также можно временно убирать (скрывать): щёлкните правой кнопкой мыши и выберите соответствующую команду в Polygon Actions подменю. Используйте эту функцию, когда необходимо переместить компоненты и трассы.
  • Для удобства разные цепи можно отображать разными цветами, как показано на изображениях ниже. Это можно сделать на схеме или печатной плате; подробнее см. Назначение цветов цепям.

На первом изображении показан слой-плоскость, разделённый на зоны 3v3 и 5v0; на втором — сигнальный слой с полигоном 3v3 и полигоном 5v0. Цепям назначены цвета, и включена подсветка.  Two power zones created by polygons on a signal layerНа первом изображении показан слой-плоскость, разделённый на зоны 3v3 и 5v0; на втором — сигнальный слой с полигоном 3v3 и полигоном 5v0. Цепям назначены цвета, и включена подсветка.

Плоскость как путь возвратного тока сигнала

Качественный путь возвратного тока отвечает следующим условиям:

  • В плоскости, обеспечивающей путь возвратного тока (ближайшей к рассматриваемому сигналу), под сигнальной трассой отсутствуют разрывы, разделительные линии и вырезы — отверстия в плоскости, образованные переходным отверстием или выводом, устанавливаемым в сквозное отверстие.
  • В идеале ширина пути возвратного тока должна быть равна утроенной ширине сигнальной трассы или утроенному расстоянию от трассы до плоскости — в зависимости от того, какое значение меньше. Хотя наибольшая плотность тока наблюдается непосредственно под сигнальной трассой, ток также растекается по плоскости в обе стороны от трассы, причём примерно 95% тока протекает в пределах утроенной ширины трассы. Разрывы в плоскости в этой области увеличивают импеданс пути возвратного тока, а любое отклонение этого пути приводит к образованию петли. С точки зрения целостности сигналов такое увеличение импеданса пути возвратного тока влияет на качество сигнала в той же степени, что и увеличение импеданса сигнального пути.
  • Площадь петли сведена к минимуму. Как правило, уменьшить площадь петли важнее, чем минимизировать длину сигнальной трассы. Если на пути возвратного тока встречается вырез в плоскости, рассмотрите возможность изменения трассировки сигнала с учётом доступного пути возвратного тока. 
  • Если путь возвратного тока проходит по плоскости питания, энергия возвратного тока в конечном итоге поступает на землю через развязывающий конденсатор. Тщательно продумайте расположение развязывающих конденсаторов рядом с выводом источника сигнала, чтобы минимизировать площадь образующейся петли.

Работа с разделёнными и несколькими плоскостями питания и земли

Общепринято, что плоскость земли не следует разделять, если только это не обусловлено конкретными требованиями и вы не понимаете, как правильно организовать такое разделение и работать с ним. Вместо этого компоненты следует размещать так, чтобы компоненты с высоким уровнем помех были отделены от малошумящих компонентов, а компоненты, использующие одну и ту же шину питания, были сгруппированы вместе.

При работе с плоскостями питания и земли также следует учитывать следующее:

  • Если в проекте требуется частичное разделение плоскости земли, сигналы, проходящие через эти области, следует трассировать над перемычкой — участком, под которым нет разрыва.
  • Если необходимо минимизировать шум в схеме, лучше использовать дополнительные плоскости земли, а не разделять одну плоскость. По возможности предусматривайте слои плоскостей как для шины питания, так и для земли каждого стабилизированного источника питания. 
  • Если в проекте используется несколько шин питания, каждая из которых распределена по собственной плоскости, убедитесь, что опорной для каждой плоскости питания служит только соответствующая ей плоскость земли. Не допускайте перекрытия плоскости питания с плоскостью земли другой шины. Это создаёт ёмкостную связь, по которой помехи передаются от одного источника питания к другому.
  • Если соседняя плоскость является плоскостью питания, которую необходимо разделить на области с разными напряжениями, для обеспечения подходящего пути возвратного тока может потребоваться установить развязывающий конденсатор непосредственно между этими областями.

Визуализация разделённых плоскостей

Чтобы упростить визуальную проверку путей возвратного тока, можно настроить отображение так, чтобы путь возвратного тока под критически важными сигнальными трассами было легче рассмотреть.

Проверка пересечения сигналами линии разделения при переходе между областями плоскости с разными напряжениями. Четыре выделенные цепи пересекают разрыв в плоскости питания VCC, что приводит к разрыву пути возвратного тока этих сигналов.
Проверка пересечения сигналами линии разделения при переходе между областями плоскости с разными напряжениями. Четыре выделенные цепи пересекают разрыв в плоскости питания VCC, что приводит к разрыву пути возвратного тока этих сигналов.

Для этого:

  • Назначьте цвет каждой цепи питания. Подробнее см. Назначение цветов цепям.
  • Оставьте видимыми только необходимые сигнальные слои и слои плоскостей. Этот набор слоёв можно сохранить как набор слоёв (Layer Set). Подробнее см. Создание набора слоёв.
  • Переключитесь на сигнальный слой и выполните Ctrl+Click на нужной цепи, чтобы подсветить её (для подсветки нескольких цепей удерживайте Shift при щелчке). Преимущество подсветки перед выбором заключается в том, что подсветка сохраняется: цепи останутся подсвеченными, даже если щёлкнуть в другом месте. Чтобы сбросить текущую подсветку, нажмите Shift+C .
  • Подсветка достигается за счёт затемнения остальных объектов в рабочей области. Уровень Dimmed Objects задаётся в разделе Mask and Dim Settings панели View Configuration.
  • Сделайте слой плоскости активным.

Цепи будут отчётливо выделяться, а любые разрывы или нарушения непрерывности на пути возвратного тока, например линии разделения или вырезы, образованные контактными площадками сквозного монтажа и переходными отверстиями, станут заметнее. 

  • В качестве плоскостей шин питания можно использовать как слои плоскостей, так и сигнальные слои с полигональной заливкой.
  • Чтобы исключить случайную трассировку сигналов через разрыв в плоскости, разместите вдоль него запретную область на слое запретных областей.

Обнаружение разрывов пути возвратного тока

Разрывы и сужения пути возвратного тока можно обнаружить с помощью правила проектирования Return Path. Правило проектирования Return Path проверяет непрерывность пути возвратного тока сигнала на заданных опорных слоях выше или ниже сигналов, к которым применяется правило. Путь возвратного тока может быть сформирован заливками, регионами и полигональными заливками на опорном сигнальном слое либо проходить по слою плоскости.

Слои пути возвратного тока — это опорные слои, определённые в Impedance Profile, выбранном в правиле проектирования Return Path. На этих слоях проверяется наличие заданного Minimum Gap (ширины за пределами края сигнальной трассы) вдоль всего пути сигнала. Добавьте новое правило проектирования Return Path в категории правил High Speed.

 
 
 
 
 

Слои пути возвратного тока определяются в выбранном Impedance Profile, а ширина пути (за пределами края сигнальной трассы) задаётся параметром Minimum Gap.
Слои пути возвратного тока определяются в выбранном Impedance Profile, а ширина пути (за пределами края сигнальной трассы) задаётся параметром Minimum Gap.

На изображении ниже показаны ошибки пути возвратного тока, обнаруженные для сигнала NetX при значении параметра Minimum Gap, равном 0.1mm. Найти ошибки Return Path будет проще, если настроить DRC Violation Display Style так, чтобы отображались подробности нарушений (Violation Details), но не их наложение (Violation Overlay), в диалоговом окне Preferences – показать изображение. При этом подсвечиваются точные места нарушения правила, а не объекты с нарушениями целиком. 

Чтобы не обнаруживать мелкие ошибки, например участок, выделенный на диагональном сегменте дорожки на изображении выше, настройте параметр PCB.Rules.ReturnPathIgnoreArea в диалоговом окне Advanced Settings. По умолчанию игнорируются области < 10 sq mils.

Проверка переходных отверстий пути возвратного тока

Эта функция доступна, если параметр PCB.Rules.CheckReturnPathVia включён в диалоговом окне Advanced Settings.

 
 
 
 
 

Когда высокоскоростной сигнал переходит с одной опорной плоскости на другую, необходимо также предусмотреть переходные отверстия для передачи обратных токов между этими плоскостями. Чтобы проверить наличие такого переходного отверстия на заданном расстоянии от сигнального переходного отверстия, укажите, должно ли переходное отверстие обратного тока находиться в пределах заданного расстояния от переходного отверстия сигнала, входящего в область действия правила, с помощью параметра Max Stitch Via Distance в соответствующем правиле проектирования Return Path. Переходное отверстие обратного тока должно обеспечивать соединение с опорным слоем, указанным в Layer Stack Manager для соответствующего профиля импеданса.

Если в правиле задан параметр Max Stitch Via Distance, наличие переходного отверстия обратного тока в пределах указанного расстояния проверяется при пакетной проверке правил проектирования (Batch DRC).

Пример нарушения ограничения максимального расстояния до сшивающего переходного отверстия. Здесь у переходного отверстия цепи DQS4R_N нет переходного отверстия обратного тока в пределах заданного расстояния.
Пример нарушения ограничения максимального расстояния до сшивающего переходного отверстия. Здесь у переходного отверстия цепи DQS4R_N нет переходного отверстия обратного тока в пределах заданного расстояния.

Настройка и трассировка дифференциальных пар

Main pages: Трассировка дифференциальных пар, Трассировка с контролируемым импедансом

Дифференциальные пары можно определить при разработке схемы или после переноса проекта в редактор печатной платы. Основное требование при определении пары на схеме — добавить _P или _N в конец имени каждой соответствующей цепи. Дифференциальные пары обозначаются на схеме размещением Differential Pair directive на каждой цепи либо на Blanket directive, при этом директива Blanket охватывает набор меток цепей с именами, характерными для дифференциальных пар, как показано на рисунке ниже.

Example of how a Blanket directive can be used with a Differential Pair directive to target multiple nets

С помощью Blanket можно назначить несколько цепей участниками дифференциальных пар.

Работа с дифференциальными парами:

  • В редакторе печатных плат дифференциальные пары можно определить в режиме Differential Pair Editor панели PCB. Чтобы упростить создание правил проектирования для дифференциальных пар, их можно включить в классы цепей или классы дифференциальных пар. Оба типа классов определяются в Object Class Explorer.
  • Для трассировки дифференциальной пары с контролируемым импедансом создайте профиль импеданса в Layer Stack Manager. Подробнее см. в разделе Трассировка с контролируемым импедансом.
  • Параметры трассировки дифференциальных пар определяются правилом проектирования Differential Pair Routing.
  • Для трассировки дифференциальной пары используется команда Interactive Differential Pair. Щелкните по контактной площадке _P или _N, чтобы начать трассировку, затем используйте Spacebar для переключения между доступными формами выхода трассы. Поведение при трассировке такое же, как и при трассировке отдельной цепи; нажмите Shift+F1, чтобы просмотреть список сочетаний клавиш интерактивной трассировки. При приближении к целевым контактным площадкам нажмите Ctrl+Click, чтобы завершить трассировку до этих площадок.

Практические рекомендации для дифференциальных пар:

  • Для эффективной работы дифференциальных пар критически важно согласование длин: обеспечивайте равенство длин в пределах допуска, подходящего для используемой технологии передачи сигналов. Например, для пар USB 3.x согласовывайте длины с допуском 5–10 мил. Еще одно практическое правило — рассогласование длин, выраженное через задержку распространения, не должно превышать 20 % времени нарастания сигнала. Дифференциальная передача работает благодаря тому, что энергия возвращается по другому проводнику пары. Чем больше рассогласование длин, тем большая доля энергии возвращается через ближайшую опорную плоскость.

  • Нарушения связи между проводниками, например при обходе препятствия с разных сторон, увеличивают импеданс. Чтобы уменьшить изменения импеданса из-за таких нарушений, иногда лучше трассировать всю пару с более слабой связью между проводниками (например, с зазором, равным двум ширинам сигнальной дорожки).

  • Прокладывайте дорожки — источники помех подальше от пары, особенно на наружных слоях; старайтесь выдерживать зазор до потенциальных цепей — источников помех, равный трем ширинам сигнальной дорожки.

  • Как правило, следует выдерживать зазор между парой и другими сигнальными дорожками, равный двум ширинам сигнальной дорожки.

  • Выдерживайте расстояние до полигонов земли на том же слое не менее трех ширин сигнальной дорожки.

  • Отражения, вызванные переходными отверстиями и неоднородностями связи, уменьшают с помощью трассировки с контролируемым импедансом. Для этого под сигнальным трактом необходима сплошная опорная плоскость.

  • Уменьшите расстояние между сигнальным слоем и опорной плоскостью, чтобы повысить устойчивость к перекрёстным помехам.

Контроль и подстройка длины трасс

Main pages: Подстройка длины, правило проектирования Length, правило проектирования Matched Length

Одно из ключевых требований при работе с высокоскоростными сигналами на плате — контроль и подстройка длины их трасс.

  • Абсолютную длину трасс можно контролировать с помощью правила проектирования Length, а относительную — с помощью правила проектирования Matched Length.
  • Текущую длину трасс набора цепей и её соответствие применимым правилам проектирования можно проверить на панели PCB в режиме Nets (как показано ниже).
  • Если задано правило Length и/или Matched Length, длину можно контролировать во время интерактивной трассировки или подстройки длины, включив отображение индикатора подстройки длины (Length Tuning Gauge) (Shift+G).
  • Поддерживается учёт задержки, обусловленной длиной вывода внутри корпуса компонента. Подробнее см. в разделе Задержка вывода в корпусе.
  • Для работы с цепями, в тракт которых включены последовательные компоненты, используются xSignals.

Правила проектирования

  • Managing the Overall Route Lengths — общую длину трассы одной цепи или набора цепей можно контролировать с помощью правила проектирования Length. Правило Length задаёт минимальную и максимальную допустимую длину. Если длина сигнала (Signal Length) меньше допустимого минимума, она выделяется жёлтым цветом на панели PCB (в режиме Nets), а если превышает допустимый максимум — красным.
  • Managing the Relative Route Lengths — относительную длину трасс набора цепей можно контролировать с помощью правила проектирования Matched Length. Правило Matched Length задаёт допуск и использует самую длинную трассу в выбранном наборе цепей в качестве эталонной. Жёлтая подсветка значения Signal Length на панели означает, что длина этого сигнала меньше длины самой длинной трассы за вычетом допуска. Красная подсветка означает, что длина этого сигнала превышает длину самой длинной трассы. 

Чтобы узнать, как согласуются настройки этих двух правил, когда оба присутствуют в проекте, см. страницу Подстройка длины.

Контроль длины трассы

Текущая длина трасс отображается в режиме Цепи панели PCB и обновляется по мере трассировки. Значение длины Routed становится жёлтым при приближении к целевой длине и красным при её превышении.

Если задано правило Length и/или Matched Length, длину можно контролировать во время интерактивной трассировки или подстройки длины, включив отображение индикатора подстройки длины. Во время трассировки используйте сочетание клавиш Shift+G, чтобы включать и выключать индикатор.

Индикатор показывает текущую длину проложенной трассы числом над ползунком, а положение ползунка соответствует расчётной длине. Во время подстройки длины Estimated Length = Current Routed Length; если индикатор используется при интерактивной трассировке, то Estimated Length = Routed Length + distance to target (length of connection line).

Параметры индикатора рассчитываются на основе ограничений, заданных применимыми правилами.Параметры индикатора рассчитываются на основе ограничений, заданных применимыми правилами.

  • Минимум индикатора (левый край шкалы) равен 45 (наименьшее значение MinLimit)
  • Максимум индикатора (правый край шкалы) равен 48 (наибольшее значение MaxLimit)
  • Левая жёлтая отметка (наибольшее значение MinLimit) — 46,58
  • Правая жёлтая отметка (наименьшее значение MaxLimit) — 47,58 (на изображении выше скрыта за зелёной отметкой)
  • Зелёная отметка (TargetLength) — 47,58 (длина трассы самой длинной цепи в наборе, равная MaxLimit)
  • Зелёный ползунок и отображаемое поверх него числовое значение (текущая длина трассы) — 47,197.

Подстройка длины трасс

После завершения трассировки длину трасс можно подстроить с помощью команды Interactive Length Tuning или команды Interactive Diff Pair Length Tuning (меню Route). Эти команды добавляют к трассам меандровые участки одной из трёх доступных форм.

Если применимы и правило Length, и правило Matched Length, инструмент подстройки длины учитывает оба правила и определяет наиболее строгий набор ограничений. Поэтому, если максимальная длина, заданная правилом Length, меньше наибольшей длины, на которую ориентируется правило Matched Length, приоритет получает правило Length, и при подстройке используется заданная им длина.

Чтобы посмотреть, какие правила применяются, или изменить параметры меандра во время подстройки длины, нажмите Tab, чтобы открыть панель Properties в режиме Interactive Length Tuning, как показано ниже. Обратите внимание на Target Length: это Max Limit из наиболее строгих настроек применимых правил.

Во время подстройки длины нажмите Tab, чтобы открыть панель в режиме Interactive Length Tuning, где можно выбрать режим задания целевой длины и настроить параметры меандра.
Во время подстройки длины нажмите Tab, чтобы открыть панель в режиме Interactive Length Tuning, где можно выбрать режим задания целевой длины и настроить параметры меандра.

Чтобы подстроить длину цепи, запустите команду и щёлкните в любой точке её трассы. Перемещайте курсор вдоль трассы — при этом будут добавляться меандровые участки подстройки. Они будут добавляться до тех пор, пока не будут выполнены требования к длине, заданные применимыми правилами проектирования. Если курсор выйдет за границы меандровых участков, они исчезнут; когда курсор вернётся в их границы, они появятся снова.

Подробнее см. в разделе Подстройка длины.

Правила контроля и согласования длины можно применять к цепям, дифференциальным парам или xSignals. xSignals идеально подходят для случаев, когда контролируемые или согласуемые трассы включают последовательные компоненты или ответвления. В режиме xSignals панели PCB отображается текущая длина проложенной трассы каждого xSignal.

Подробнее см. в разделе xSignals.

Заключение

Хотя невозможно сформулировать универсальный набор правил, применимый к любому высокоскоростному проекту, можно следовать проверенным рекомендациям, которые помогут успешно разработать такое устройство. Ряд отраслевых экспертов проводит популярные практические курсы по высокоскоростному проектированию. Перейдите по ссылкам ниже, чтобы узнать больше и подобрать специализированное обучение.

Источники

Автор с благодарностью отмечает работы перечисленных ниже отраслевых экспертов. На этой странице предпринята попытка обобщить накопленные ими знания.

Статьи Дугласа Брукса

  • Время распространения сигнала в микрополосковых линиях
  • Разделение плоскостей для высокоскоростных цепей и питания
  • Скин-эффект
  • Правила проектирования дифференциальных трасс: правда и вымысел

Статьи доктора Говарда Джонсона

  • Индуктивность переходного отверстия
  • 10-слойный стек

Книги и статьи Ли У. Ритчи

  • Правильно с первого раза
  • Дифференциальная передача сигналов и требования к её проектированию
  •  Влияние ламинатов печатных плат на скорость высокоскоростной передачи данных, часть 1, часть 2

Статьи In-Circuit Design — Барри Олни

  • Трассировка дифференциальных пар
  • Вся правда о перемычках между плоскостями
  • Критически важное размещение компонентов
  • Планирование стека слоёв (части 1, 2 и 3)
  • Идеальный стек слоёв

Передовые методы проектирования печатных плат — Тим Джарвис, RadioCAD Limited

Топология печатных плат — сайт Learn EMC

Статьи Кита Армстронга, информационный центр по ЭМС (требуется бесплатная регистрация)

Справочник по конструктивному исполнению электронной аппаратуры — Гленн Р. Блэквелл

Справочник по печатным платам — Клайд Кумбс и Хэппи Холден

Справочник по HDI — Хэппи Холден и другие

Методы оптимизации переходных отверстий при проектировании высокоскоростных каналов — руководство по применению Altera AN529

Особенности проектирования высокоскоростных печатных плат — руководство по применению Lattice Semiconductor TN 1033 

Измерение времени распространения сигнала — Крис Грачанен, EDN

Будущее структур переходных отверстий HDI, распределения питания и отвода тепла в печатных платах следующего поколения — Том Бак, TTM Technologies

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents