Представление платы

Altium Training

Altium Essentials: PCB Introduction

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Краткий обзор

В этой статье рассказывается, как работать с печатной платой в Altium Designer в режимах планирования платы, 2D и полноценного 3D, связывая традиционное послойное редактирование с физическим представлением готовой платы. В ней рассматриваются практические преимущества 3D-возможностей: проверка зазоров, визуальная оценка доступности компонентов, учет производственных требований и более наглядное представление проекта заинтересованным сторонам. Также объясняется, как панель View Configuration управляет отображением на экране с помощью настроек видимости слоев, цветов и других параметров. Кроме того, вы узнаете, как управлять видимостью слоев и использовать наборы слоев (Layer Sets), чтобы быстрее выполнять типовые задачи просмотра. Читайте дальше, чтобы узнать, как настроить отображение печатной платы под свои задачи и повысить эффективность проверки и представления проекта.

- Разберитесь в различиях между режимами Board Planning, 2D Layout и 3D Layout и узнайте, когда используется каждый из них.
- Узнайте, как с помощью панели View Configuration управлять слоями, цветами, видимостью объектов и другими параметрами отображения.
- Посмотрите, как инструменты управления видимостью слоев и наборы слоев (Layer Sets) упрощают и ускоряют навигацию по сложным проектам печатных плат.
Узнайте больше с ИИ:

Исторически печатные платы проектировались в двумерном рабочем пространстве, где различные слои платы обозначались цветами. Однако физическая печатная плата — это трёхмерный объект, поэтому разработчику приходится мысленно преобразовывать многослойное двумерное представление на экране в трёхмерное.

Значительное развитие видеокарт для работы с 3D и соответствующих программных технологий позволило Altium создать решение этой проблемы — полноценное трёхмерное редактирование печатных плат. Возможности 3D в Altium Designer не ограничиваются простой визуализацией и позволяют:

  • Выполнять проверку зазоров в 3D — точно размещать компоненты относительно друг друга и корпуса в соответствии с требованиями.

  • Визуально определять расположение разъёмов и других компонентов, к которым необходим доступ для обслуживания.

  • Точнее определять производственные процессы и порядок сборки, зная, что все механические ограничения учтены.

  • Создавать более подробные инструкции по ручной сборке, руководства пользователя и инструкции с изображениями, максимально близкими к тому, что человек увидит в действительности.

  • Экспериментировать с цветами паяльной маски, чтобы создать более эстетичный продукт, гармонирующий с корпусом и окружающей средой.

  • Легче заручаться поддержкой ключевых заинтересованных сторон, представляя им более наглядный вид конечного продукта.

Двумерный и трёхмерный виды одного и того же участка платы.
Двумерный и трёхмерный виды одного и того же участка платы.

ECAD-MCAD CoDesign

Для поддерживаемых MCAD-пакетов также доступна прямая передача платы и компонентов между MCAD и ECAD с помощью CoDesigner — технологии Altium для взаимодействия ECAD и MCAD. Работая через подключённое рабочее пространство, например рабочее пространство Altium 365, CoDesigner может передавать форму платы и размещённые компоненты в обоих направлениях между вашим MCAD-приложением и Altium Designer.

Подробнее: Прямое совместное проектирование в ECAD и MCAD с помощью Altium CoDesigner

Режимы отображения

Altium Designer поддерживает отображение и редактирование платы в 2D и 3D; эти режимы называются display modes. Выберите нужный режим в меню View или нажмите сочетание клавиш 1, 2 или 3, чтобы сразу переключиться в соответствующий режим.

Существует три режима отображения, каждый со своими функциями.

  • Board Planning Mode (сочетание клавиш 1) — используется для задания формы платы, а также для размещения и настройки линий разделения и линий сгиба в гибко-жёсткой конструкции. Линии разделения делят плату на области, каждой из которых можно назначить отдельный стек слоёв. Подробнее об областях платы, линиях разделения и линиях сгиба см. в разделе Определение стека слоёв.

  • 2D Layout Mode (сочетание клавиш 2) — традиционное двумерное многослойное представление печатной платы. Altium Designer включает набор функций для управления отображением платы, который называется Система Board Insight.

  • 3D Layout Mode (сочетание клавиш 3) — полноценное трёхмерное представление проекта. Используйте режим 3D совместно с 3D-мышью, чтобы просматривать загруженную трёхмерную модель платы и манипулировать ею так, словно вы держите её в руке. Подробнее об управлении видом печатной платы в 3D см. на странице Управление трёхмерным видом.

    Для 3D Layout Mode требуется видеокарта с поддержкой DirectX 9 или новее и Shader Model 3 или новее.

Одна и та же плата показана в режиме планирования платы, режиме 2D-компоновки и режиме 3D-компоновки. Одна и та же плата показана в режиме планирования платы, режиме 2D-компоновки и режиме 3D-компоновки.

Панель настройки отображения

На панели View Configuration можно настроить, что отображается в рабочем пространстве редактора печатных плат и как именно. Настройки включают видимость и цвет слоёв, видимость и прозрачность объектов, уровни маскирования и затемнения, текущий режим одного слоя и ряд дополнительных параметров отображения рабочего пространства, например отображение имён цепей на контактных площадках, переходных отверстиях и дорожках.

Помимо стандартных способов открытия панели (с помощью кнопки Panels в правом нижнем углу рабочего пространства или меню View » Panels), панель View Configuration также можно открыть сочетаниями клавиш L или Ctrl+D (при этом панель откроется на вкладке Layers & Colors или View Options соответственно) либо щелчком по цветовому образцу в элементе управления наборами слоёв в левом нижнем углу рабочего пространства ().

Содержимое панели разделено на две вкладки. Щёлкните вкладку в верхней части панели, чтобы отобразить доступные на ней параметры:

  • Layers and Colors — содержит параметры управления видимостью доступных слоёв, добавления, переименования и удаления механических слоёв, а также настройки цвета и видимости специальных системных элементов отображения, таких как отверстия контактных площадок, маркер начала координат и ошибки DRC.

    Сигнальные слои и слои сплошной металлизации добавляются, именуются и удаляются в Менеджере стека слоёв.
  • View Options — содержит параметры выбора, сохранения и загрузки конфигурации цветов и видимости слоёв, настройки видимости типов объектов, управления уровнями маскирования и затемнения, а также другие параметры отображения.

Доступные параметры зависят от текущего режима компоновки (2D или 3D).

В режиме 3D-компоновки на панели View Configuration также доступна вкладка Section View. Используйте эту вкладку для настройки вида печатной платы в разрезе — подробнее.

Настройка видимости слоёв

Каждый слой можно отобразить или скрыть в области Layers вкладки Layers & Colors панели View Configuration. Щёлкните значок видимости (), чтобы выключить или включить отображение слоя.

Управляйте видимостью слоёв с помощью значков видимости
Управляйте видимостью слоёв с помощью значков видимости

Там, где это применимо, у каждой группы также есть значок видимости. Например, на изображении выше:

  • Значок видимости слева от строки Component Layer Pairs (C) включает и выключает отображение слоёв компонентов all.
  • Значок видимости слева от строки Top переключает видимость слоев компонентов all top side. Аналогичным образом можно отображать и скрывать слои стороны Bottom.

Наборы слоев

Набор слоев — это именованный набор видимых слоев. Чтобы выбрать существующий набор слоев, используйте раскрывающийся список Layers Sets в области Layers на вкладке Layers & Colors панели View Configuration; отображение обновится, и будут показаны только слои, включенные в этом наборе.

По умолчанию доступно несколько наборов слоев:

  • All Layers — выберите, чтобы показать все слои.

  • Signal Layers — выберите, чтобы показать только слои, для которых в Layer Stack Manager задан тип Signal, а также слои Die и Wire Bonding, если они существуют.

  • Plane Layers — выберите, чтобы показать только слои, для которых в Layer Stack Manager задан тип Plane.

  • NonSignal Layers — выберите, чтобы показать только слои Overlay, Paste, Solder и Other Layers (Drill Drawing, Drill Guide, Keep-Out Layer и Multi-Layer).

  • Mechanical Layers — выберите, чтобы показать только механические слои и пары слоев компонентов.

Можно создать любое количество пользовательских наборов слоев, а также отредактировать выбранный набор.

  • Чтобы создать новый пользовательский набор слоев, настройте видимость слоев в области Layers нужным образом, а затем нажмите кнопку . Набор появится в раскрывающемся списке под именем My Layers. Каждому последующему добавленному набору слоев будет присвоен номер.

  • Чтобы изменить состав отображаемых слоев существующего пользовательского набора, выберите его в раскрывающемся списке Layers Sets, настройте видимость слоев нужным образом, а затем нажмите кнопку , чтобы сохранить изменения в наборе.

  • Чтобы переименовать существующий пользовательский набор слоев, выберите его в раскрывающемся списке Layers Sets и введите нужное имя в поля Layer Sets. Обратите внимание: при переименовании набора слоев отдельное сохранение не требуется — новое имя сохраняется автоматически.

  • Чтобы удалить существующий пользовательский набор слоев, выберите его в раскрывающемся списке Layers Sets и нажмите кнопку .

  • Чтобы импортировать нужный набор слоев из файла PCB Layer Set (*.layerset) или экспортировать его в файл PCB Layer Set, используйте кнопки Import и Export соответственно.

Для переключения отображаемых наборов слоев используйте:

  • Layer Set — раскрывающийся список на панели View Configuration
  • Design » Manage Layer Sets — подменю
  • Layer Set — элемент управления, доступный при нажатии на часть LS кнопки слева от вкладок слоев в нижней части рабочей области ().

Системные цвета

В области System Colors можно настроить цвета перечисленных элементов печатной платы. Цвета и видимость настраиваются стандартными способами.

Вкладки слоев

Вкладки всех слоев, отображение которых включено на панели View Configuration, расположены вдоль нижнего края рабочей области.

Они позволяют переключать активный слой (слой, на котором будут размещаться объекты) и наглядно показывают, какие слои отображаются в данный момент и какой из них активен (его вкладка выделена). Если все вкладки слоев не помещаются на экране одновременно, используйте стрелки  для их прокрутки.

Цвета слоев отображаются слева от вкладок слоев. Двойной щелчок по цвету слоя открывает диалоговое окно Choose Color.

Дважды щелкните имя слоя, чтобы открыть диалоговое окно Edit Layer, в котором можно изменить имя слоя (а для внутреннего слоя питания — также имя цепи).

Диалоговое окно Edit Layer 
Диалоговое окно Edit Layer

Однослойный режим

Однослойный режим отображения в 2D

Функции однослойного режима интегрированы с Board Insight и настраиваются на странице PCB Editor - Board Insight Display в Preferences диалогового окна. В однослойном режиме отображается содержимое текущего слоя, а содержимое всех остальных слоев скрывается или затемняется. Помимо скрытия всех объектов на других слоях для отображения только содержимого текущего слоя, однослойный режим поддерживает отображение в оттенках серого и монохромное отображение. Преобразование цветов всех остальных слоев в оттенки серого или в монохромную палитру позволяет сохранить информацию о взаимном расположении объектов в проекте, не отвлекая внимание от интересующего слоя. Для переключения между полным отображением и каждым из включенных однослойных режимов используйте сочетание клавиш Shift+S. При каждом нажатии Shift+S программа переходит к следующему включенному режиму, в конечном итоге возвращаясь к режиму полного отображения. Однослойные режимы включаются на странице PCB Editor - Board Insight Display диалогового окна Preferences. Отключите (снимите флажки) те режимы, которые не должны включаться при нажатии Shift+S. Эти настройки применяются ко всем проектам в данной установке Altium Designer.

Доступны следующие однослойные режимы:

  • Hide Other Layers — все остальные слои скрыты; отображается только содержимое активного (текущего) слоя.
  • Gray Scale Other Layers — все остальные слои отображаются в оттенках серого, полученных из их текущих цветов; активный слой отображается в своем стандартном цвете.
  • Monochrome Other Layers — все остальные слои отображаются одним и тем же оттенком серого; активный слой отображается в своем стандартном цвете.

На изображениях ниже показаны обычное многослойное отображение и три однослойных режима отображения.

Выбранный однослойный режим отображается в области General Settings на вкладке View Options панели View Configuration. Нажмите ссылку режима (рядом с кнопкой On ), чтобы открыть страницу PCB Editor - Board Insight Display диалогового окна Preferences, где можно настроить доступные однослойные режимы.

Используйте ползунок Masked Objects в области Mask and Dim Settings на вкладке View Options панели View Configuration для управления яркостью остальных слоев в однослойных режимах отображения в оттенках серого или монохромного отображения.

Однослойный режим 3D-отображения

Однослойный режим также доступен при отображении платы в 3D Layout Mode. Используйте его, например, для проверки качества трассировки на определенном слое или качества слоя плоскости питания. В однослойном режиме используйте сочетание клавиш Ctrl+Shift+Wheel Roll для последовательного переключения между слоями.

Постоянное отображение слоя в однослойном режиме

Чтобы включить слой в отображение в однослойном режиме, выполните Ctrl+Click на значке глаза нужного слоя на вкладке Layers & Colors панели View Configuration. За значком глаза появится квадрат (), обозначающий, что этот слой будет постоянно отображаться в однослойном режиме.

Просмотр платы с нижней стороны

Чтобы просмотреть плату с нижней стороны (то есть перевернуть ее), включите параметр View From Bottom Side в области Layers на вкладке Layers & Colors панели View Configuration, выберите команду View » Flip Board в главном меню или используйте сочетание клавиш Ctrl+F.

Для перевернутых плат и компонентов поддерживаются все действия и команды редактирования. Логически система координат остается прежней: начало координат рабочего пространства перемещается из нижнего левого угла в нижний правый. Текущая координата сетки по оси X (горизонтальной) увеличивается при перемещении мыши справа налево, а не слева направо, как обычно. Все выходные данные, сформированные при перевернутом виде, сохраняют корректные координаты для вида сверху.

При перевороте платы или компонента порядок отрисовки слоев также изменяется путем логической попарной перестановки. Это означает, что Top Overlay меняется местами в текущем порядке отрисовки слоев с Bottom Overlay, Top Layer — с Bottom Layer, Mid-Layer 1 — с Mid-Layer 30, Internal Plane 1 — с Internal Plane 16 и так далее. Порядок отрисовки механических слоев не изменяется.

Управление видимостью объектов

Помимо управления отображением объектов в рабочем пространстве путем включения и отключения слоев, можно управлять видимостью и прозрачностью объектов в зависимости от их типа. В режиме 2D-компоновки используйте параметры в области Object Visibility на вкладке View Options панели View Configuration для настройки видимости и прозрачности объектов по типам.

Раздел Object Visibility на вкладке View Options панели
Раздел Object Visibility на вкладке View Options панели

  •  — управляйте видимостью объектов определенных типов, нажимая соответствующий значок видимости. Нажмите значок видимости All Objects, чтобы переключить видимость всех объектов, а затем включите видимость объектов нужных типов.

  • Name — список всех объектов, параметры отображения которых можно настроить.

  • Draft — включите этот параметр, чтобы отображать объекты данного типа в виде контуров.

  • Transparency — настройте прозрачность объектов данного типа с помощью ползунка либо нажмите на значение и вручную введите нужный процент от 0 до 100 (0% — полностью видимый, непрозрачный объект; 100% — полностью прозрачный, невидимый объект). Прозрачность позволяет видеть места перекрытия объектов, например место соединения конца сегмента дорожки с контактной площадкой.

  • Advanced — нажмите, чтобы открыть диалоговое окно Object Visibility, в котором можно задать общий уровень прозрачности для определенного типа объектов на разных слоях, а также разные уровни прозрачности для разных типов объектов на конкретном слое.

Подробнее об управлении прозрачностью объектов и слоев см. на странице Прозрачность объектов и слоев.

Чтобы легко восстанавливать предпочтительные настройки видимости, создайте пользовательскую конфигурацию в области General Settings этой панели.

Настройки маскирования и затемнения

Чтобы упростить работу с большим количеством объектов, которые могут присутствовать даже в простом проекте печатной платы, редактор печатных плат позволяет приглушать отображение объектов, не представляющих интереса. Например, если нажать на цепь в режиме Nets панели PCB, когда в раскрывающемся списке панели выбрано Dim или Mask, отображение всех объектов, не принадлежащих этой цепи, будет приглушено. Это позволяет легче сосредоточиться на определенном элементе проекта, например на цепи или классе цепей, классе компонентов, объектах, на которые распространяется определенное правило проектирования, и т. д. Используйте ползунки в области Mask and Dim Settings на вкладке View Options панели View Configuration для настройки уровней маскирования и затемнения.

Область Mask and Dim Settings на вкладке View Options панели View Configuration
Область Mask and Dim Settings на вкладке View Options панели View Configuration

  • Dimmed Objects — объекты, которые в данный момент приглушены, сохраняют свой цвет, но отображаются бледнее. Используйте этот ползунок, чтобы настроить степень приглушения объектов. Приглушенные объекты можно редактировать.

    Чтобы увеличить или уменьшить степень приглушения, также можно использовать команды View » Increase Mask Level (сочетание клавиш: ]) или View » Decrease Mask Level (сочетание клавиш: [) в главном меню соответственно.
  • Highlighted Objects — если приглушение включено и вы щелкнете объект на панели, например цепь в режиме Nets панели PCB, эта цепь будет подсвечена, а все остальные цепи — приглушены. К цвету подсвеченных объектов добавляется белый, чтобы они выделялись. Этот ползунок позволяет настроить количество белого, добавляемого к цвету подсвеченных объектов.
  • Masked Objects — объекты, которые в данный момент маскированы, отображаются серым цветом и недоступны для редактирования. Используйте этот ползунок, чтобы настроить степень ослабления отображения маскированных объектов.
  • Маскирование и приглушение можно включить в различных местах, например на панели PCB, панели PCB Filter и панели PCB Rules and Violations.
  • Нажмите сочетание клавиш Shift+C, чтобы снять все примененные маскирование и приглушение.

Управление конфигурациями

Конфигурация — это готовый набор настроек цвета и видимости слоев. Выберите существующую конфигурацию в раскрывающемся списке Configuration в области General Settings на вкладке View Options панели View Configuration или используйте кнопки рядом со списком, чтобы создать, сохранить или удалить конфигурацию. Пользовательские конфигурации сохраняют текущие или последние использованные настройки отображения как в 2D, так и в 3D.

  • — нажмите, чтобы создать новую пользовательскую конфигурацию, затем введите новое имя и нажмите кнопку .
  • — нажмите, чтобы сохранить новую пользовательскую конфигурацию или изменения в выбранной пользовательской конфигурации.
  • — нажмите, чтобы удалить выбранную пользовательскую конфигурацию.
  • Созданные и сохраненные пользовательские конфигурации автоматически загружаются и становятся доступными для выбора в раскрывающемся списке поля Configuration.
  • Используйте пункт Load View Configuration в раскрывающемся списке поля Configuration, чтобы загрузить файл конфигурации из расположения, нестандартного для текущей установки Altium Designer. Обратите внимание: пользовательские конфигурации сохраняются как комплексные конфигурации (с расширением файла .config_complex), поэтому при загрузке пользовательской конфигурации может потребоваться изменить значение в раскрывающемся списке File Type диалогового окна Open.

Дополнительные параметры

В области Additional Options на вкладке View Options панели View Configuration доступны дополнительные параметры управления отображением отдельных элементов.

Раздел Additional Options на вкладке View Options панели View Configuration
Раздел Additional Options на вкладке View Options панели View Configuration

  • Test Points — включите этот параметр, чтобы отображать дополнительную информацию о контактных площадках и переходных отверстиях, назначенных тестовыми точками. Контактную площадку или переходное отверстие можно назначить тестовой точкой, включив параметры тестовой точки Fabrication и/или Assembly в соответствующем режиме панели Properties. Тестовые точки обозначаются добавлением строки <Layer> Fab Testpoint или <Layer> Assy Testpoint к контактной площадке или переходному отверстию.
  • Status Info — включите этот параметр, чтобы при наведении указателя на объект в рабочей области в Status Bar отображалась краткая информация, например координаты и слой.
  • Pad Nets — включите этот параметр, чтобы отображать имя соответствующей цепи на контактной площадке. Обратите внимание: имена цепей видны только при достаточно большом увеличении.
  • Pad Numbers — включите этот параметр, чтобы отображать номера контактных площадок. Обратите внимание: номера контактных площадок видны только при достаточно большом увеличении.
  • Via Nets — включите этот параметр, чтобы отображать имя соответствующей цепи на переходном отверстии. Обратите внимание: имена цепей видны только при достаточно большом увеличении.
  • Via Span — включите этот параметр, чтобы отображать диапазон слоев, который может охватывать переходное отверстие. Свойства размещенных переходных отверстий (диаметр, размер отверстия и т. д.) задаются правилами проектирования или вручную. Обратите внимание: имена цепей видны только при достаточно большом увеличении. Номера слоев, охватываемых переходным отверстием, могут отображаться внутри переходных отверстий всех типов.
  • All Connections in Single Layer Mode — включите этот параметр, чтобы в режиме одного слоя всегда отображались все линии соединений. Если этот параметр отключен, при переходе в режим одного слоя также скрываются все линии соединений, которые не начинаются и не заканчиваются на текущем слое, поскольку они считаются не относящимися к нему.
  • Net Color Override — каждой цепи можно назначить цвет. Чтобы настроить цвет, дважды щелкните имя цепи в режиме Цепи панели PCB; откроется диалоговое окно Edit Net. Цвет автоматически применяется к линиям соединений этой цепи, а при включении этого параметра его также можно применить к трассировке. Цвет применяется к трассировке в соответствии с текущими настройками на странице PCB Editor – Board Insight Color Overrides диалогового окна Preferences, где параметр Pattern определяет способ применения цвета, а Zoom Behavior — условия его применения в зависимости от масштаба. Нажмите сочетание клавиш F5, чтобы включить или отключить параметр переопределения цвета цепи.
  • Use Layer Colors for Connection Drawing — включите этот параметр, чтобы отображать линии соединений с использованием цветов начального и конечного слоев, между которыми проходит линия соединения. В точках начала и конца линии соединений отображаются чистым цветом соответствующего слоя, а по всей длине линии цвет плавно переходит от одного к другому. Эта функция полезна при трассировке многослойной платы, поскольку указывает целевой слой, на который должно перейти трассируемое соединение. Обратите внимание: плавный переход цвета применяется только к соединениям между разными слоями. Если соединение начинается и заканчивается на одном слое, оно сохраняет назначенный цвет цепи.
  • Repeated Net Names on Tracks — включите этот параметр, чтобы отображать повторяющиеся имена цепей на дорожках.
  • Special Strings — если этот параметр включен, поверх всех размещенных текстовых строк, полученных путем преобразования специальных строк, будет отображаться подпись с исходным именем специальной строки. Увеличьте масштаб текстовой строки, чтобы увидеть наложенную подпись.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents