Подготовка отчетов

Краткий обзор

Altium Designer позволяет формировать отчеты для документирования компонентов, отслеживания изменений проекта и подготовки производственных данных. В этой статье описаны доступные типы отчетов, настройка и экспорт отчетов с помощью диспетчера отчетов (Report Manager), а также способы их формирования и сохранения. Читайте далее, чтобы выбрать нужные отчеты и организовать их сохранение для своего проекта.

- Ознакомьтесь с типами отчетов, включая спецификацию (Bill of Materials), сравнение спецификаций (BOM Compare), производственные данные жгутов, перекрестные ссылки на компоненты, комментарии и историю проекта.
- Узнайте, как настраивать поддерживаемые отчеты, просматривать их перед печатью, печатать и экспортировать в различные форматы файлов.
- Разберитесь, как добавлять отчеты в файлы заданий на формирование выходных данных (Output Job) или формировать их напрямую, а также как управлять папками выходных данных, чтобы избежать перезаписи отчетов.
Узнайте больше с ИИ:

Для проекта или отдельного документа проекта можно настроить и сформировать ряд отчетов, в том числе:

  • Спецификация – этот отчет содержит наглядный список всех компонентов, необходимых для изготовления изделия, включая печатную плату без компонентов — основу, на которой устанавливаются все остальные детали. Спецификация служит руководством по закупке всего необходимого для изготовления изделия в соответствии с проектом. Она также позволяет рассчитать стоимость с учетом требуемого количества собранных плат в заказанной партии.

    Данные, представленные в диалоговом окне Report Manager, которое используется для настройки отчета спецификации, могут поступать из одного из двух источников. Если с проектом связан документ ActiveBOM (*.BomDoc), он будет использоваться в качестве источника данных. В противном случае данные будут извлечены из исходных документов схем проекта.

  • Сравнение спецификаций – отчет с информацией о компонентах, которые были изменены (например, добавлены, удалены или заменены) при выпуске проекта из рабочего пространства.

  • Manufacturing Data – единая книга Excel, содержащая данные для изготовителей жгутов. Сформированная книга включает четыре отдельных листа:

    • Bill of Materials – для быстрого расчета коммерческого предложения.

    • Wiring List – для использования с оборудованием для обработки проводов.

    • Labels – сводная информация о физических этикетках для пучков жгута, которые нужно напечатать на принтерах Zebra или других принтерах.

    • Coverings – сводная информация о защитных покрытиях, которые необходимо установить на пучки жгута.

     

    В качестве источника выходных данных для производства рекомендуется использовать документ ActiveBOM проекта жгута.

    Дополнительные сведения о проектировании жгутов см. на странице Проектирование жгутов.

  • Отчет о перекрестных ссылках компонентов – создает список компонентов с учетом листов схемы, на которых они расположены в проекте.

    Отчеты спецификации и перекрестных ссылок компонентов обладают широкими возможностями настройки благодаря специализированному мощному механизму формирования отчетов, интерфейсом которого служит диалоговое окно Report Manager. После того как содержимое требуемого отчета определено и упорядочено нужным образом, отчет можно сформировать — распечатать или экспортировать в один из нескольких форматов файлов: CSV (с разделителями-запятыми) (*.csv), лист Microsoft Excel (*.xls;*.xlsx;*.xlt;*.xltx), Portable Document Format (*.pdf), текст с разделителями-табуляциями (*.txt), веб-страница (*.htm;*.html), электронная таблица XML (*.xml). Экспортированный файл можно сохранить в любом указанном расположении. Кроме того, после создания его можно открыть в соответствующем приложении и/или добавить в проект. Используйте команду Report в меню диалогового окна Report Manager, чтобы открыть диалоговое окно Report Preview с уже загруженным отчетом. С помощью различных элементов управления в окне настройте отображение отчета. Нажмите кнопку Print , чтобы открыть диалоговое окно Print , в котором можно выбрать, что будет напечатано и на какое печатающее устройство будет отправлено задание. Предварительный просмотр отчета также можно экспортировать в различные форматы файлов.

  • Экспорт комментариев – создает PDF-файл с экспортированными комментариями к документам проекта.

  • История проекта – создает PDF-файл с экспортированной историей проекта. Настройте вывод с помощью диалогового окна Project History Report Configuration, в котором можно задать Period для экспорта отчета: всю историю проекта либо диапазон от/до определенного (или последнего) выпуска проекта.

  • Отчет об иерархии проекта – создает список исходных документов, используемых в проекте. Для этого вывода нет параметров настройки; отчет в формате ASCII записывается в указанную папку выходных данных.

  • Отчет о цепях с одним выводом – создает отчет со списком всех цепей, содержащих только одно подключение. Для этого вывода нет параметров настройки; отчет в формате ASCII записывается в указанную папку выходных данных. Отчет содержит список всех исходных документов схем проекта с учетом их иерархии в проекте. Файл формируется напрямую в формате <ActiveDocumentName>.REP.

Выходные отчеты можно добавить в активный файл Output Job из меню элемента управления [Add New Report Output] в области Report Outputs этого файла или из подменю Edit » Add Report Outputs главного меню.

Хотя файлы OutputJob упрощают подготовку выходных данных для проектов и их последующее формирование с помощью процесса выпуска проекта с высоким уровнем целостности данных, отчеты для активного проекта также можно сформировать напрямую с помощью команды из главного меню Reports редактора схем или подменю Reports » Project Reports редактора печатных плат.
  • Благодаря широким возможностям настройки диалогового окна Report Manager его также можно использовать для формирования отчетов в любом требуемом формате, например файла установки компонентов, данные в котором должны иметь определенную структуру для конкретного установщика компонентов.
  • Все выходные файлы будут записаны в папку, указанную в поле Output Path на вкладке Options диалогового окна Options for Project. По умолчанию путь вывода указывает на вложенную папку в папке, содержащей файл проекта, с именем Project Outputs for <ProjectName>. При необходимости путь вывода можно изменить. На панели Projects сформированные файлы будут отображаться во вложенных папках Generated\Text Documents (.csv, .txt, .rep) или Generated\Documents (.xls, .pdf, .htm, .xml). Учтите, что при формировании отчета в другом формате из того же активного документа ранее сформированный файл отчета будет перезаписан, если его имя совпадает.
  • Если включен параметр Use separate folder for each output type (также на вкладке Options ), выходные данные будут записаны в дополнительную вложенную папку с именем Reports (например, Project Outputs for <ProjectName>\Reports). На панели Projects выходные данные будут отображаться во вложенных папках Generated (Reports)\Text Documents (.csv, .txt, .rep) или Generated (Reports)\Documents (.xls, .pdf, .htm, .xml). Это позволяет формировать несколько отчетов из одного активного документа без перезаписи файлов.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.