Работа с блоками повторного использования и сниппетами (старая панель повторного использования проекта)

Краткий обзор

В этой статье рассказывается, как Altium Designer помогает сохранять и повторно использовать типовые фрагменты схем и печатных плат с помощью блоков повторного использования и сниппетов, избавляя от необходимости каждый раз создавать повторяющиеся элементы проекта с нуля. Вы узнаете, что включает каждый из этих вариантов, как открыть и использовать панель Design Reuse, а также как создавать, управлять, переименовывать и упорядочивать проектные данные как в рабочем пространстве, так и локально. Если вы регулярно работаете с повторяющимися фрагментами схем или печатных плат, это руководство поможет понять, как встроить эти инструменты в рабочий процесс и эффективно их использовать. Читайте дальше, чтобы ускорить проектирование и обеспечить единообразие результатов.

- Узнайте, чем отличаются блоки повторного использования, сниппеты схем и сниппеты печатных плат и когда применяется каждый из них.
- Ознакомьтесь с возможностями панели Design Reuse для поиска, фильтрации, сортировки и управления проектными данными для повторного использования.
- Следуйте пошаговым инструкциям по созданию, сохранению, переименованию и упорядочиванию блоков повторного использования и сниппетов как в рабочем пространстве, так и в локальных папках.
Узнайте больше с ИИ:

Описанный на этой странице пользовательский интерфейс функций повторного использования проектов представляет собой предыдущую версию панели Design Reuse, доступную, когда параметр UI.ModernDesignReusePanel отключен в диалоговом окне Advanced Settings. Если этот параметр включен, используется новая версия панели, описанная на страницах Работа с блоками повторного использования и Работа с фрагментами. Новая панель Design Reuse находится на этапе открытого бета-тестирования.

Если ваши проекты часто содержат типовые участки схемы, Altium Designer предлагает простой и удобный способ сохранять и повторно использовать такие участки — как в Workspace, так и в локальных файлах. Их можно добавлять в любой проект печатной платы, не создавая каждый раз с нуля. Эта возможность отлично подходит для часто используемых фрагментов и небольших участков схемы, которые вы хотите использовать повторно. Система позволяет сохранять любые выбранные:

  • Участки схемы на одном листе (фрагмент схемы).

  • Участки проекта печатной платы, включая компоненты и трассировку (фрагмент печатной платы).

При подключении к Workspace можно создать единый объект — блок повторного использования, — который может содержать как участок схемы, так и его физическое представление на печатной плате. При размещении такого блока на листе схемы его физическое представление автоматически размещается в документе печатной платы в ходе выполнения процедуры ECO.

Панель Design Reuse — это центр создания, управления и использования блоков повторного использования и фрагментов, хранящихся как в Workspace, так и в локальных файлах.

Панель Design Reuse
Панель Design Reuse

Открыть панель можно следующими способами:

  • Нажмите кнопку Panels в правом нижнем углу рабочей области, затем выберите Design Reuse.
  • Выберите View » Panels » Design Reuse в главном меню.
  • Выберите Place » Reuse Block в главном меню.

В верхнем раскрывающемся списке панели перечислены все доступные папки подключенного Workspace, содержащие блоки повторного использования и фрагменты Workspace. Число рядом с именем каждой папки показывает, сколько блоков повторного использования и фрагментов содержится в этой папке и ее вложенных папках. Выберите папку в раскрывающемся списке, чтобы отобразить в основной области панели блоки повторного использования и фрагменты, содержащиеся в этой папке и ее вложенных папках. Выберите в списке запись подключенного Workspace, чтобы отобразить все доступные блоки повторного использования и фрагменты.

Структуру папок Workspace можно задать непосредственно в Altium Designer с помощью панели Explorer.

Используйте кнопки фильтрации во всплывающем окне значка , чтобы отображать или скрывать в панели содержимое определенных типов (Reuse Blocks, Schematic Snippets, PCB Snippets). Используйте элемент управления Sort By, чтобы выбрать предпочтительный вариант сортировки.

Используйте параметры фильтрации и сортировки, чтобы настроить отображение содержимого в панели
Используйте параметры фильтрации и сортировки, чтобы настроить отображение содержимого в панели

Чтобы найти доступные блоки повторного использования и фрагменты в выбранной папке по имени или описанию, введите фразу в поле Search. Это позволит отфильтровать список и оставить только нужные элементы.

Каждый блок повторного использования и фрагмент представлен в основной области панели плиткой, содержащей следующие данные:

  • Изображение предварительного просмотра — нажмите на него, чтобы переключиться между обычным и полноразмерным отображением. Для блока повторного использования используйте кнопку  Нажмите и перетащите для перемещения​, чтобы переключаться между предварительным просмотром документа печатной платы и документа схемы;

  • Значок типа —  Нажмите и перетащите для перемещения​ для блока повторного использования,  Нажмите и перетащите для перемещения​ для фрагмента схемы,  Нажмите и перетащите для перемещения​ для фрагмента печатной платы;

  • Имя и описание (если задано);

  • Идентификатор последней ревизии, дата создания и автор блока повторного использования или фрагмента схемы/печатной платы, хранящегося в Workspace.

Сведения о блоке повторного использования или фрагменте и элементы управления им представлены на плитке в панели.
Сведения о блоке повторного использования или фрагменте и элементы управления им представлены на плитке в панели.

Создание блока повторного использования

Новый блок повторного использования можно создать следующими способами:

  1. Выберите команду создания нового блока повторного использования:

    • В панели Design Reuse, нажав кнопку  в верхней части панели.

    • С помощью команды File » New » Reuse Block в главном меню.

    • В панели Explorer, нажав кнопку  в правом верхнем углу панели при просмотре папки типа Design Reuse Blocks.

  2. В панели Projects будет открыта временная редактируемая структура блока повторного использования, аналогичная структуре проекта печатной платы (в разделе Workspace, к которому вы подключены). В главном окне проектирования откроется временный редактор схем, готовый к созданию документа схемы блока повторного использования. Используйте стандартные команды и приемы размещения, чтобы создать документ схемы блока.

  3. По завершении используйте команду Design » Update PCB Document и процедуру ECO, чтобы перенести созданную схему в документ печатной платы блока повторного использования, а затем внесите необходимые изменения в этот документ (размещение компонентов, трассировку и т. д.).

    В создаваемый блок повторного использования можно добавить несколько документов печатной платы. Для этого используйте команду Add New to Project » PCB в контекстном меню записи блока повторного использования в панели Projects.

    Используйте команду Rename в контекстном меню записи добавленного документа печатной платы в панели Projects, чтобы задать ему понятное имя. Используйте команду Design » Update в главном меню редактора схем, чтобы обновить нужный документ печатной платы.

    Когда документы схемы и печатной платы блока повторного использования будут готовы, сохраните блок в Workspace с помощью команды Save to Server в контекстном меню записи блока в панели Projects или элемента управления Save to Server справа от этой записи.

    Поскольку блоки повторного использования хранятся в подключенном Workspace, в них следует использовать компоненты из этого Workspace. Это позволит в полной мере воспользоваться возможностями системы управления содержимым Workspace.

    • Документы схемы и печатной платы блока повторного использования должны содержать хотя бы по одному компоненту, чтобы их можно было сохранить в рабочей области.

    • Если документы схемы и печатной платы блока повторного использования не синхронизированы (между ними обнаружены различия), при попытке сохранить блок в рабочей области появится диалоговое окно с предупреждением. Можно отменить сохранение, чтобы вернуться к блоку и устранить различия, или продолжить сохранение.

  4. Откроется диалоговое окно New Reuse Block, в котором можно задать Name, Description и Folder рабочей области, куда будет сохранен новый блок повторного использования.

    Диалоговое окно New Reuse Block
    Диалоговое окно New Reuse Block

  5. После нажатия OK блок повторного использования будет сохранен в рабочей области, а его временная структура будет закрыта.

Сохраненный блок повторного использования можно найти на панели Design Reuse, выбрав в верхнем раскрывающемся списке папку, в которую он был сохранен, или запись подключенной рабочей области. Чтобы новый блок появился на панели, может потребоваться выполнить команду Refresh из меню кнопки .

Переименование блока повторного использования

После создания блока повторного использования при необходимости ему можно присвоить более подходящее имя. Для этого используйте команду Rename , доступную в подменю  и в контекстном меню панели Design Reuse , открываемом щелчком правой кнопки мыши. В открывшемся диалоговом окне Rename Reuse Block введите новое имя и нажмите OK. Блок повторного использования получит указанное имя, как показано на следующих изображениях.

Создание фрагмента

Новый фрагмент схемы или печатной платы можно быстро создать на основе существующей части схемы на листе схемы или в документе печатной платы:

  1. Выделите нужную часть схемы в редакторе схем или печатных плат.

  2. Щелкните правой кнопкой мыши и выберите Snippets » Create Snippet from selected objects в контекстном меню либо выберите команду Tools » Convert » Create Snippet from selected objects в главном меню.

  3. Откроется диалоговое окно New Schematic Snippet или New PCB Snippet, в котором можно задать имя, описание, место сохранения (рабочая область или локальная папка) и папку, в которую будет сохранен новый фрагмент.

    При сохранении фрагмента в локальную папку нажмите кнопку  справа от поля Path в диалоговом окне, чтобы открыть диалоговое окно Choose Snippet Folder. В нем можно выбрать существующую локальную папку фрагментов для сохранения фрагмента или создать вложенную папку в существующей локальной папке фрагментов.

    Сведения об организации локальных фрагментов по папкам см. ниже в разделе Организация локальных фрагментов.
  4. После нажатия OK фрагмент будет сохранен.

Сохраненный фрагмент можно найти на панели Design Reuse, выбрав в верхнем раскрывающемся списке запись подключенной рабочей области или папку, в которую он был сохранен.

Фрагмент можно создать из набора выделенных объектов. Здесь показано создание фрагмента схемы. Наведите указатель на изображение, чтобы увидеть создание фрагмента печатной платы.
Фрагмент можно создать из набора выделенных объектов. Здесь показано создание фрагмента схемы. Наведите указатель на изображение, чтобы увидеть создание фрагмента печатной платы.

Чтобы новый блок повторного использования появился на панели, может потребоваться выполнить команду Refresh из меню кнопки  панели.

Для доступа к локальным фрагментам на панели Design Reuse необходимо включить параметр Local Snippets в меню .

Фрагмент в рабочей области также можно создать на основе существующего локального фрагмента. Для этого нажмите кнопку  на плитке фрагмента (или щелкните правой кнопкой мыши в любом месте плитки) и выберите в меню команду Save to Server. В появившемся диалоговом окне New Schematic Snippet или New PCB Snippet задайте Name, Description и Folder рабочей области, куда будет сохранен фрагмент.

Локальный фрагмент можно сохранить в подключенной рабочей области с помощью команды Save to Server.
Локальный фрагмент можно сохранить в подключенной рабочей области с помощью команды Save to Server.

Во фрагментах рабочей области следует использовать компоненты из этой рабочей области. Это позволит в полной мере воспользоваться возможностями предоставляемой ею системы управления содержимым.

Организация локальных фрагментов

Панель Design Reuse позволяет организовать локальные фрагменты по папкам, объединяя связанные фрагменты в группы для удобства поиска. Папки фрагментов — это существующие папки Windows, которые нельзя создать на панели Design Reuse. Вместо этого их «открывают» или «закрывают» при просмотре содержащихся в них локальных фрагментов. Создать такие папки можно только непосредственно на жестком диске или в сети вне Altium Designer.

Папки фрагментов можно открывать и закрывать в диалоговом окне Available Snippets Folders. Чтобы открыть его, нажмите кнопку в правом верхнем углу панели Design Reuse и выберите в меню команду Snippet Folders. Нажмите Open Folder, чтобы найти нужную папку на жестком диске или в сети. Выбранная папка будет добавлена в список диалогового окна, а затем появится в раскрывающемся списке в верхней части панели Design Reuse.

Чтобы удалить папку фрагментов из списка (то есть закрыть ее для просмотра), выберите ее в списке и нажмите Remove Folder. Используйте кнопки Move Up и Move Down, чтобы изменить порядок отображения локальных фрагментов на панели Design Reuse, когда в раскрывающемся списке панели выбрана запись Local.

Размещение блоков повторного использования и фрагментов

Чтобы разместить блок повторного использования или фрагмент в проекте, щелкните внутри его плитки и нажмите кнопку , нажмите кнопку на его плитке либо щелкните правой кнопкой мыши в любом месте плитки и выберите одну из следующих команд:

  • Place — выберите для размещения блока повторного использования или фрагмента непосредственно в активном документе схемы или печатной платы.
  • Place as Sheet Symbol — если активен документ схемы, выберите для размещения блока повторного использования или фрагмента схемы в виде символа листа на листе схемы. Содержимое блока повторного использования или фрагмента схемы будет размещено на автоматически созданном дочернем листе схемы, на который ссылается размещенный символ листа.

Разместите блок повторного использования или фрагмент с помощью меню кнопки Place на его плитке в панели. Здесь показан выбор команды Place, при которой блок повторного использования или фрагмент схемы размещается на активном листе схемы. Наведите курсор на изображение, чтобы увидеть выбор команды Place as Sheet Symbol, при которой блок повторного использования или фрагмент схемы размещается на дочернем листе, на который ссылается размещенный символ листа.
Разместите блок повторного использования или фрагмент с помощью меню кнопки Place на его плитке в панели. Здесь показан выбор команды Place, при которой блок повторного использования или фрагмент схемы размещается на активном листе схемы. Наведите курсор на изображение, чтобы увидеть выбор команды Place as Sheet Symbol, при которой блок повторного использования или фрагмент схемы размещается на дочернем листе, на который ссылается размещенный символ листа.

Нажмите элемент управления Show more на плитке блока повторного использования, чтобы открыть раздел PCB со списком документов печатной платы этого блока. Выберите нужный документ печатной платы в списке, и блок повторного использования будет размещен с этим документом. Выбранный документ печатной платы отображается в области предварительного просмотра на плитке блока повторного использования, если для предварительного просмотра выбран вариант PCB.

Выберите документ печатной платы для размещения вместе с блоком повторного использования, чтобы открыть его предварительный просмотр.
Выберите документ печатной платы для размещения вместе с блоком повторного использования, чтобы открыть его предварительный просмотр.

После размещения документа схемы блока повторного использования его документ печатной платы можно разместить в документе печатной платы проекта с помощью процедуры ECO. В редакторе схем выберите команду Design » Update PCB Document в главном меню, затем проверьте и примените изменения в диалоговом окне Engineering Change Order. Документ печатной платы будет размещен в документе печатной платы проекта как объединение (union), которым можно управлять в режиме Unions панели PCB.

Если выбранный компонент схемы или печатной платы входит в блок повторного использования, размещенный в проекте, для просмотра свойств этого блока нажмите ссылку Reuse Block на панели Properties . На панели отобразятся свойства блока повторного использования, которому принадлежит компонент. Чтобы вернуться к свойствам первоначально выбранного компонента, воспользуйтесь ссылкой Component.

Откройте свойства блока повторного использования через входящий в него компонент. На изображениях выше показан доступ к свойствам через компонент схемы. Наведите курсор на изображение, чтобы увидеть доступ через компонент печатной платы.
Откройте свойства блока повторного использования через входящий в него компонент. На изображениях выше показан доступ к свойствам через компонент схемы. Наведите курсор на изображение, чтобы увидеть доступ через компонент печатной платы.

При выполнении команды размещения блока повторного использования используется его документ схемы или печатной платы — в зависимости от типа документа, активного в момент выполнения команды.

Перед размещением фрагмента убедитесь, что нужный целевой документ открыт и активен. Команда размещения доступна только в том случае, если фрагмент можно разместить в этом документе, то есть тип фрагмента должен совпадать с типом документа.

Редактирование блоков повторного использования и фрагментов

Чтобы отредактировать блок повторного использования или фрагмент, хранящийся в Workspace, нажмите кнопку на его плитке (или щелкните правой кнопкой мыши в любом месте плитки) и выберите в меню команду Edit.

Откройте хранящийся в Workspace блок повторного использования или фрагмент для редактирования с помощью команды Edit в меню его плитки на панели.
Откройте хранящийся в Workspace блок повторного использования или фрагмент для редактирования с помощью команды Edit в меню его плитки на панели.

Откроется временный редактор с документом, содержащим исходный блок повторного использования или фрагмент из последней ревизии элемента Workspace. Внесите необходимые изменения, затем сохраните документ в следующую ревизию блока повторного использования или фрагмента с помощью команды File » Save to Server в главном меню или команды Save to Server в контекстном меню записи блока повторного использования или фрагмента на панели Projects.

Свойства локального фрагмента (имя, описание и путь) можно изменить в диалоговом окне Snippet Properties, которое открывается нажатием кнопки  на плитке локального фрагмента (или щелчком правой кнопкой мыши в любом месте плитки) и выбором команды Edit Properties в меню.

Измените свойства локального фрагмента в диалоговом окне Snippet Properties, открываемом из панели Design Reuse.
Измените свойства локального фрагмента в диалоговом окне Snippet Properties, открываемом из панели Design Reuse.

Удаление блоков повторного использования и фрагментов

Чтобы удалить блок повторного использования или фрагмент, нажмите кнопку  на плитке фрагмента (или щелкните правой кнопкой мыши в любом месте плитки) и выберите в меню команду Delete.

  • Для блока повторного использования или фрагмента, хранящегося в Workspace, появится диалоговое окно Delete Items для подтверждения удаления. Фактически выполняется «мягкое удаление»: блок повторного использования или фрагмент перемещается в область Trash среды Workspace. Область Trash по сути представляет собой корзину, в которую можно переместить любое содержимое Workspace с помощью мягкого удаления. Она изолирована от остальной части Workspace. Для блока повторного использования также можно выбрать удаление связанного с ним содержимого (например, фрагментов схемы и печатной платы).

    Выполните мягкое удаление блока повторного использования или фрагмента с помощью команды Delete в меню его плитки на панели.
    Выполните мягкое удаление блока повторного использования или фрагмента с помощью команды Delete в меню его плитки на панели.

  • Для локального фрагмента появится диалоговое окно Confirm для подтверждения удаления. При этом файлы фрагмента будут удалены с жесткого диска.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents