Работа с управляемыми листами схем

Краткий обзор

В этой статье рассказывается, как управляемые листы схем в подключенном рабочем пространстве Altium Designer делают повторное использование проектных решений более надежным, отслеживаемым и согласованным по сравнению с обычным копированием и вставкой. Вы узнаете, что такое управляемый лист схемы, чем он отличается от листов устройств, как хранится в рабочем пространстве и как ведется история его версий, а также об основных способах его создания и сохранения для дальнейшего использования. Кроме того, мы рассмотрим, какую роль тип папки, тип содержимого, правила именования, жизненный цикл и непосредственное редактирование играют в создании повторно используемых схемных решений, которым ваша команда может доверять. Читайте дальше, чтобы узнать, как листы, управляемые через рабочее пространство, помогают увереннее использовать проверенные проектные блоки.

- Узнайте, что такое управляемые листы схем, как они помогают повторно использовать проектные решения и почему хранение в рабочем пространстве обеспечивает контроль версий, прослеживаемость и целостность содержимого.
- Изучите различные способы создания и сохранения управляемых листов схем, включая непосредственное редактирование, сохранение текущего листа и загрузку документа схемы в ревизию.
- Посмотрите, как такие параметры, как тип папки, тип содержимого, схемы именования и настройки жизненного цикла, помогают организовывать повторно используемые схемные решения и управлять ими.
Узнайте больше с ИИ:

Возможность повторного использования проектных данных нужна всем компаниям, разрабатывающим продукцию, и может принести им значительную пользу. Повторное использование не только экономит время: если часть предыдущего проекта можно легко использовать снова, это означает, что все квалификационные испытания и проверки этой части уже выполнены. Однако повторное использование проектных данных — это гораздо больше, чем копирование и вставка. Для полноценного повторного использования данные должны быть защищены от изменений, чтобы можно было гарантировать их соответствие исходной версии. Никаких быстрых правок цвета компонента или небольших изменений номинала резистора: работа с повторно используемыми данными должна напоминать работу с готовыми компонентами — разместите их, подключите, и они будут работать точно так же, как в прошлый раз.

Altium Designer совместно с подключенным рабочим пространством позволяет создавать в этом рабочем пространстве управляемые листы схем (объекты Managed Schematic Sheet). Такие листы можно создавать:

  • Путем непосредственного редактирования.

  • Путем сохранения текущего листа схемы в рабочее пространство.

  • Путем загрузки соответствующего документа схемы (*.SchDoc) в ревизию целевого управляемого листа схемы.

После создания управляемого листа схемы (и сохранения данных в его ревизию) его можно повторно использовать в будущих проектах печатных плат.

Что такое управляемый лист схемы?

Управляемый лист схемы — это стандартный лист схемы Altium Designer, содержащий компоненты и соединения и сохраненный в рабочем пространстве для повторного использования в других проектах. Он редактируется так же, как и любой другой лист схемы. При этом концепция управляемых листов схем не ограничивается одним листом: в проект можно поместить управляемый лист схемы, который находится на вершине иерархии других управляемых листов схем.

Управляемые листы схем отличаются от листов устройств тем, что хранятся в рабочем пространстве, тогда как листы устройств хранятся в папке на жестком диске. Поэтому управляемые листы обладают преимуществами данных рабочего пространства, включая упрощенное хранение, обязательный контроль версий и, конечно, гарантированную целостность.

► См. информацию о локально управляемых листах устройств.

Решение о переходе от листов устройств к управляемым листам схем принимают, когда возникает желание перейти от повторно используемых данных к Workspace повторно используемым данным — то есть когда появляется желание или необходимость контролировать выпуск этих проектных данных и предоставить всей команде единый источник таких данных.

Размещая данные в рабочем пространстве, вы можете быть уверены, что ревизию управляемого листа схемы, используемую в проекте, при необходимости легко идентифицировать и проследить до ее источника. Кроме того, данные рабочего пространства можно пересматривать и обновлять по мере необходимости, а все связи использования — отслеживать как вниз по иерархии, до компонентов на листе, так и вверх, до проектов, в которых этот лист используется. Благодаря этому у вас будет вся информация, необходимая для принятия решения: следует ли внедрить обновленный лист в существующие проекты или в конкретном проекте нужно продолжить использовать предыдущую ревизию.

Тип папки

При создании папки для хранения управляемых листов схем можно указать ее тип. Это не влияет на содержимое папки: сохранение листа схемы всегда приводит к созданию соответствующего объекта Managed Schematic Sheet. Тип папки лишь служит визуальной подсказкой о ее содержимом и может быть полезен при поиске определенных данных в рабочем пространстве. Чтобы обозначить папку как хранилище управляемых листов схем, задайте для параметра Folder Type значение Managed Schematic Sheets при настройке свойств папки в диалоговом окне Edit Folder.

Указание типа папки — ее назначения — позволяет наглядно определить ее содержимое при просмотре рабочего пространства.
Указание типа папки — ее назначения — позволяет наглядно определить ее содержимое при просмотре рабочего пространства.

Тип содержимого

При создании целевого объекта Managed Schematic Sheet для хранения листа схемы убедитесь, что для его параметра Content Type установлено значение Managed Schematic Sheet в диалоговом окне Create New Item. Если объект создается в папке типа Managed Schematic Sheets, этот тип содержимого будет доступен в контекстном меню, вызываемом правой кнопкой мыши при создании объекта.

Создание управляемого листа схемы в папке Managed Schematic Sheets — нужный Content Type доступен в контекстном меню.
Создание управляемого листа схемы в папке Managed Schematic Sheets — нужный Content Type доступен в контекстном меню.

Сохранение листа схемы

Related page: Создание и редактирование содержимого

До сих пор мы рассматривали поддержку управляемых листов схем в Workspace с точки зрения соответствующих типов папок и содержимого. Сохранить готовый лист схемы в ревизии элемента управляемого листа схемы можно несколькими способами, описанными в следующих разделах.

Чтобы упростить повторное использование управляемых листов в ваших разработках, настоятельно рекомендуется вручную назначить позиционные обозначения на листе схемы (Tools » Annotation » Annotate Schematics), прежде чем сохранять его как управляемый лист. После завершения разработки с использованием управляемых листов все листы и компоненты можно перенумеровать в масштабе всего проекта.

► Подробнее см. в разделе Назначение обозначений компонентам и листам ниже.

Непосредственное редактирование

Благодаря поддержке непосредственного редактирования в Workspace лист схемы можно отредактировать и сохранить в начальной ревизии только что созданного элемента управляемого листа схемы. Непосредственное редактирование избавляет от необходимости отдельно хранить исходные данные под управлением системы контроля версий. Вы можете просто редактировать содержимое поддерживаемого типа во временном редакторе, в который загружаются актуальные исходные данные непосредственно из Workspace. По завершении редактирования объект сохраняется (или сохраняется повторно) в следующей запланированной ревизии родительского элемента, а временный редактор закрывается. На жестком диске нет файлов, не нужно сомневаться, работаете ли вы с нужной или последней версией исходных данных, и не требуется обслуживать отдельную систему контроля версий. Workspace берет все это на себя, обеспечивая целостность данных и значительно ускоряя внесение изменений.

При создании элемента управляемого листа схемы можно сразу после его создания отредактировать лист схемы и сохранить его в начальной ревизии этого элемента. Для этого включите параметр Open for editing after creation в нижней части диалогового окна Create New Item (по умолчанию он включен). Элемент будет создан, и откроется временный редактор схем, в котором документ .SchDoc станет активным документом в главном окне проектирования. Имя этого документа будет соответствовать элементу и его ревизии в формате: <Item><Revision>.SchDoc (например, SCH-0007-1.SchDoc).

Если в вашем Workspace есть хотя бы один сохраненный шаблон схемы, появится диалоговое окно Select configuration item (Schematic Templates). Выберите в нем шаблон, который следует применить к документу схемы.

Пример редактирования начальной ревизии управляемого листа схемы непосредственно из Workspace: временный редактор схем предоставляет документ для создания вашего листа схемы.
Пример редактирования начальной ревизии управляемого листа схемы непосредственно из Workspace: временный редактор схем предоставляет документ для создания вашего листа схемы.

Создайте в этом документе необходимую схему. Поскольку управляемые листы схем хранятся в Workspace, размещенные на них компоненты также следует хранить в Workspace. Это позволит в полной мере воспользоваться преимуществами системы управления содержимым Workspace, в том числе находить и определять все компоненты, используемые на управляемом листе схемы (дочерние объекты), а также проекты, в которых используется сам управляемый лист схемы (места использования). Подробнее см. в разделе Создание и сопровождение компонентов и библиотек.

Возможность использовать компоненты Workspace для создания более крупных проектных блоков позволяет еще больше оптимизировать процесс проектирования и перейти на более высокий уровень абстракции. Подобно тому как выбирают детали с полки, разработчик повторно использует эти управляемые листы схем с готовыми функциональными узлами в качестве составных частей более крупного проекта. Чем больше управляемых листов с такими схемами создано и сохранено в Workspace, тем больше функциональных возможностей доступно разработчику, что, в свою очередь, повышает производительность при работе над последующими проектами.

При непосредственном редактировании доступны три элемента управления, расположенные в Quick Access Bar (в левом верхнем углу главного окна приложения) или на панели инструментов Schematic Standard:

  • – Save Active Document. Эта кнопка позволяет локально сохранить изменения, внесенные в документ. Так можно сохранить текущие изменения, чтобы позднее вернуться к редактированию, прежде чем окончательно сохранить документ в Workspace.
  • / – Save to Workspace. Эта кнопка позволяет сохранить подготовленный лист схемы в Workspace, в начальной (запланированной) ревизии целевого элемента управляемого листа схемы. Откроется диалоговое окно Edit Revision, в котором при необходимости можно изменить имя и описание, а также добавить примечания к выпуску. После сохранения документ и редактор закроются. Документ с исходным листом схемы (*.SchDoc) будет сохранен в ревизии элемента.

    Элемент управления Save to Server также расположен справа от записи листа схемы непосредственно на панели Projects.
  • / – Discard Local Changes. Эта кнопка позволяет отменить редактирование и отклонить все внесенные изменения. Документ и редактор закроются, и в целевом элементе управляемого листа схемы ничего не будет сохранено.

Эти элементы управления также доступны в виде команд — Save (сочетание клавиш: Ctrl+S), Save to Server (сочетание клавиш: Ctrl+Alt+S) и Discard Local Changes — в главном меню File и в контекстном меню записи листа схемы на панели Projects.

Данные, сохраняемые в Workspace, включают исходный лист схемы, заданный в файле документа схемы (<Item><Revision>.SchDoc), а также все связанные файлы определений жгутов (*.Harness). На панели Explorer перейдите на вкладку представления Preview, чтобы увидеть графическое представление листа и список входящих в него компонентов (а также шаблон управляемого листа схемы, если он используется).

Щелкните гиперссылку ревизии дочернего элемента компонента, чтобы перейти к ней на панели Explorer. В области Child Items также доступно контекстное меню с командами для работы с ревизией дочернего элемента компонента.

Просмотрите сохраненную ревизию управляемого листа схемы, вернувшись на панель Explorer. Перейдите на вкладку представления Preview, чтобы увидеть графическое представление и список ревизий дочерних компонентов.
Просмотрите сохраненную ревизию управляемого листа схемы, вернувшись на панель Explorer. Перейдите на вкладку представления Preview, чтобы увидеть графическое представление и список ревизий дочерних компонентов.

Дочерние компоненты, используемые на листе, также можно просмотреть на вкладке представления Children. Дважды щелкните запись для перехода к соответствующему компоненту или щелкните правой кнопкой мыши для доступа к командам работы с ним.

Просмотр компонентов, входящих в управляемый лист схемы, в представлении Children.
Просмотр компонентов, входящих в управляемый лист схемы, в представлении Children.

Сохранение существующего листа в Workspace

Хотя непосредственное редактирование является предпочтительным подходом для большинства проектных данных, которые можно хранить в Workspace, существующие листы схем (в том числе листы устройств) также можно сохранять непосредственно в Workspace. Для этого необходима запланированная ревизия существующего элемента управляемого листа схемы, в которую будет сохранен лист. Порядок действий:

  1. Создайте новый элемент управляемого листа схемы с начальной запланированной ревизией или при необходимости используйте запланированную ревизию другого существующего элемента.

  2. Откройте лист схемы или лист устройства в Altium Designer.

  3. Выберите команду File » Save as Managed Sheet to Server в главном меню.

  4. Откроется диалоговое окно Choose Planned Item Revision. Выберите в нем целевую ревизию нужного элемента управляемого листа схемы (она должна находиться в состоянии Planned), затем нажмите OK.

    Если целевой элемент управляемого листа схемы не существует, его можно создать прямо в диалоговом окне Choose Planned Item Revision. В этом случае обязательно отключите параметр Open for editing after creation (в диалоговом окне Create New Item), иначе откроется режим непосредственного редактирования.
  5. Откроется диалоговое окно Edit Revision, в котором при необходимости можно изменить имя и описание, а также добавить примечания к выпуску.

  6. После нажатия OK лист будет сохранен в ревизии элемента.

Пример отправки существующего листа устройства в Workspace, к которому установлено активное подключение. Сохранение должно выполняться в существующую ревизию управляемого листа схемы, причем эта ревизия должна находиться в состоянии Planned.
Пример отправки существующего листа устройства в Workspace, к которому установлено активное подключение. Сохранение должно выполняться в существующую ревизию управляемого листа схемы, причем эта ревизия должна находиться в состоянии Planned.

Поиск и размещение управляемого листа схемы

Описанная ниже панель Design Reuse находится на этапе открытого бета-тестирования и доступна, когда параметр UI.ModernDesignReusePanel включен в диалоговом окне Advanced Settings. Когда этот параметр отключен, управляемый лист схемы можно разместить из панели Explorer. Для этого найдите нужный управляемый лист схемы с помощью просмотра или поиска, щелкните правой кнопкой мыши требуемую ревизию (обычно последнюю — в этом случае достаточно щелкнуть правой кнопкой мыши непосредственно запись элемента верхнего уровня) и выберите команду Place.

Управляемые листы схем, хранящиеся в подключенном Workspace, можно просматривать и использовать на панели Design Reuse, если она настроена на отображение ресурсов Workspace ().

Нужный управляемый лист схемы можно найти, просматривая папки Workspace. Также можно воспользоваться полем Search в верхней части панели Design Reuse для поиска управляемого листа схемы по имени или описанию.

  • На панели Design Reuse отображается только последняя ревизия каждого управляемого листа схемы.

  • Если последняя ревизия управляемого листа схемы находится в состоянии жизненного цикла, для которого отключен параметр Visible in Vault panels (подробнее), такой управляемый лист схемы по умолчанию не отображается на панели. Чтобы отобразить управляемые листы схем, которые сейчас скрыты, нажмите кнопку  в правом верхнем углу панели, затем включите параметр Show Hidden Revisions в открывшемся меню.

Нажмите элемент управления Details в нижней части панели, чтобы развернуть область Details, в которой отображаются сведения о выбранных управляемых листах схем, в том числе:

  • Имя управляемого листа схемы.

  • Значок состояния жизненного цикла и ревизия (нажмите ссылку, чтобы открыть подробное представление истории элемента управляемого листа схемы с выбранной последней ревизией).

  • Описание управляемого листа схемы.

  • Общие сведения об управляемом листе схемы.

Используя управление доступом к содержимому рабочего пространства в сочетании с подходящей схемой жизненного цикла, уполномоченные сотрудники (библиотекари, руководители проектирования) могут утверждать и предоставлять доступ только к тем управляемым листам схем, которые разрешено использовать в проектах. Это позволяет разработчику спокойно работать, будучи уверенным, что он использует только разрешенные листы с повторно используемыми схемными решениями.

Prior to Placement

Перед размещением управляемого листа схемы в проекте следует учесть несколько моментов:

  • Символ управляемого листа схемы нельзя разместить на свободном листе схемы: целевой лист должен входить в состав проекта.

  • Убедитесь, что лист схемы, на котором требуется разместить соответствующий символ листа, открыт в Altium Designer и является активным документом. Если документы открыты в нескольких окнах, также убедитесь, что фокус находится в окне с этим активным документом схемы.

Чтобы разместить управляемый лист схемы в проекте, наведите курсор на его запись на панели Design Reuse, нажмите кнопку  (или щелкните запись правой кнопкой мыши) и выберите в меню команду Place. Символ листа, ссылающийся на этот лист, будет прикреплен к курсору — щелкните в нужном месте листа схемы, чтобы разместить его.

При размещении символа листа Altium Designer копирует соответствующий управляемый лист из рабочего пространства в подпапку \Managed\Sheets в папке проекта. Здесь хранится копия каждого управляемого листа, причем для каждого создается отдельная подпапка, имя которой представляет собой сгенерированный системой уникальный идентификатор (GUID).

Подпапку с именем GUID, в которую загружается и в которой хранится экземпляр управляемого листа схемы, нельзя изменять или переименовывать.

Нумерация компонентов и листов

Чтобы гарантировать целостность схемных решений, используемых в управляемом листе схемы, этот лист нельзя редактировать при обычной работе над проектом. Это означает, что номер листа и назначенные позиционные обозначения нельзя изменить непосредственно на листе. Как же пронумеровать все листы проекта и назначить позиционные обозначения всем компонентам?

Для этих задач предусмотрены две команды: листы нумеруются с помощью команды Tools » Annotation » Annotate Compiled Sheets, а компонентам назначаются позиционные обозначения с помощью команды Tools » Annotation » Board Level Annotate. Номера листов и назначенные позиционные обозначения хранятся в отдельном файле <ProjectName>*.annotation. 

Инструментам назначения позиционных обозначений компонентов необходимо знать порядок обработки листов схемы. Поэтому рекомендуется сначала пронумеровать листы, а затем компоненты.

Принципы нумерации компонентов и листов такие же, как при использовании локальных листов устройств. Дополнительные сведения о назначении обозначений в проектах, содержащих управляемые листы схем, см. в следующих разделах страницы «Листы устройств»:

Редактирование управляемого листа схемы

Чтобы отредактировать управляемый лист схемы, наведите курсор на его запись на панели Design Reuse, нажмите кнопку  (или щелкните запись правой кнопкой мыши) и выберите в меню команду Edit. Откроется временный редактор с листом схемы из последней ревизии элемента управляемого листа схемы. Внесите необходимые изменения, затем сохраните документ в следующую ревизию элемента (File » Save to Server).​​​

Если необходимо изменить лист схемы, хранящийся в элементе управляемого листа схемы, и у вас есть обновленный лист, его можно загрузить в этот элемент с помощью панели Explorer — новый лист будет сохранен в следующей ревизии этого элемента. Дополнительные сведения см. на странице Создание и редактирование содержимого.

Другие действия с управляемыми листами схем

Меню кнопки  (а также контекстное меню) записи управляемого листа схемы на панели Design Reuse также предоставляет доступ к следующим командам:

  • Move — позволяет изменить расположение элемента управляемого листа схемы в структуре папок рабочего пространства. При запуске команды открывается диалоговое окно Move Item, в котором можно выбрать целевую папку для размещения элемента.

  • Share — позволяет задать права общего доступа к управляемому листу схемы. После выбора команды открывается диалоговое окно Share For Item, в котором можно настроить общий доступ нужным образом. Подробнее об общем доступе на уровне элементов.

  • Operations — открывает раскрывающееся меню дополнительных функций для управляемых листов схем, описанных ниже.

    • Make a Copy — позволяет скопировать управляемый лист схемы. Откроется временный редактор управляемого листа схемы с тем же содержимым, что и у исходного листа. Внесите необходимые изменения и сохраните управляемый лист схемы в рабочем пространстве. 

    • Change Revision State — позволяет изменить состояние последней ревизии управляемого листа схемы. После выбора команды открывается диалоговое окно пакетного изменения состояния, в котором можно изменить состояние ревизии управляемого листа схемы.

    • Download — позволяет скачать данные, хранящиеся в управляемом листе схемы. Связанные данные будут загружены в подпапку выбранного каталога, имя которой соответствует идентификатору ревизии элемента управляемого листа схемы. Файл находится во вложенной папке (папках) Released.

  • Delete — позволяет удалить управляемый лист схемы из подключенного рабочего пространства. После выбора команды появится диалоговое окно Delete Items, в котором необходимо подтвердить удаление. 

    Фактически выполняется «мягкое удаление»: управляемый лист схемы перемещается в область Trash рабочего пространства. Подробнее о мягком удалении.

  • History — позволяет открыть подробное представление управляемого листа схемы на новой вкладке в Altium Designer.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents