Работа с блоками повторного использования

Краткий обзор

В этой статье объясняется, как использовать панель Design Reuse в Altium Designer для создания, управления, поиска, размещения, редактирования и упорядочивания блоков повторного использования, хранящихся в подключенном рабочем пространстве. В ней описано, как такие блоки могут включать данные как схемы, так и печатной платы и как элементы печатной платы переносятся на плату посредством процедуры ECO. Также подробно рассматриваются основные действия на панели: просмотр ресурсов рабочего пространства и подробной информации, выбор вариантов размещения, сохранение ревизий и выполнение операций управления, таких как переименование, перемещение, предоставление общего доступа, скачивание и удаление. Если вы хотите проще и эффективнее использовать проверенные фрагменты проектов в других проектах, читайте дальше: эта статья поможет вам понять, с чего начать и как уверенно работать с доступными инструментами.

- Узнайте, как создавать блоки повторного использования, сохранять их в рабочем пространстве и повторно использовать при проектировании схем и печатных плат с помощью панели Design Reuse.
- Узнайте, как находить, изучать и размещать блоки повторного использования, в том числе напрямую или в виде символа листа, а также как работать с блоками, содержащими несколько документов печатных плат.
- Ознакомьтесь с основными операциями управления блоками повторного использования: редактированием, обновлением ревизий, предоставлением общего доступа, перемещением, скачиванием и обратимым удалением.
Узнайте больше с ИИ:

Панель Design Reuse, используемая для управления блоками повторного использования и описанная на этой странице, находится на стадии открытого бета-тестирования и доступна, когда включен параметр UI.ModernDesignReusePanel в диалоговом окне Advanced Settings. Если этот параметр отключен, используется предыдущая версия панели, описанная на странице Работа с блоками повторного использования и фрагментами.

Если ваши проекты часто содержат типовые участки схем и печатных плат, Altium Designer предлагает простые и удобные способы их сохранения и повторного использования, избавляя от необходимости каждый раз создавать их с нуля.

При подключении к рабочему пространству можно создать reuse block, который может содержать как схемную часть, так и ее физическое представление для печатной платы. При размещении такого блока повторного использования на листе схемы его физическое представление будет автоматически размещено в документе печатной платы в процессе ECO.

Панель Design Reuse обеспечивает быстрый доступ ко всем элементам управления, необходимым для работы с блоками повторного использования и управления ими.

  • Панель также предоставляет доступ к управляемым листам схем и фрагментам.

  • Помимо стандартных способов открытия панели (через меню кнопки  и подменю View » Panels главного меню), панель Design Reuse можно открыть, выбрав команду Place » Reuse Block в главном меню редактора схем или редактора печатных плат.

Чтобы работать с блоками повторного использования через панель Design Reuse, убедитесь, что она настроена на просмотр ресурсов рабочего пространства. Для этого нажмите крайний левый значок в адресной строке в верхней части панели и выберите запись подключенного рабочего пространства. Значок примет вид .

Создание блока повторного использования

Новый блок повторного использования можно создать описанным ниже способом.

  1. Нажмите кнопку  в правом верхнем углу панели Design Reuse. Также можно выбрать команду File » New » Reuse Block в главном меню.

  2. В панели Projects (под записью подключенного рабочего пространства) откроется временная редактируемая структура блока повторного использования, аналогичная структуре проекта печатной платы. Также откроется временный редактор схем, готовый к созданию документа схемы блока повторного использования. Для создания документа схемы блока используйте стандартные команды и приемы размещения.

    Если вы хотите создать блок повторного использования, содержащий только схему или только печатную плату, можно удалить из структуры фрагмента документ печатной платы или схемы соответственно. Для этого щелкните нужный документ правой кнопкой мыши в панели Projects и выберите команду Remove from Project.

  3. Используйте команду Design » Update PCB Document и процесс ECO, чтобы перенести созданную схему в документ печатной платы блока повторного использования, а затем внесите в этот документ необходимые изменения: разместите компоненты, выполните трассировку и т. д.

    В создаваемый блок повторного использования можно добавить несколько документов печатной платы. Для этого используйте команду Add New to Project » PCB из контекстного меню записи блока повторного использования в панели Projects.

    Чтобы задать понятное имя добавленному документу печатной платы, используйте команду Rename из контекстного меню его записи в панели Projects. Для обновления нужного документа печатной платы используйте команду Design » Update из главного меню редактора схем.

  4. Когда документы схемы и печатной платы блока повторного использования будут готовы, сохраните блок в рабочем пространстве с помощью команды Save to Server из контекстного меню записи блока в панели Projects или элемента управления Save to Server справа от этой записи.

    Поскольку блоки повторного использования хранятся в подключенном рабочем пространстве, рекомендуется использовать в них компоненты из этого рабочего пространства. Это позволит в полной мере воспользоваться преимуществами предоставляемой им системы управления данными.

    • Чтобы блок повторного использования можно было сохранить в рабочем пространстве, его документы схемы и печатной платы должны содержать хотя бы по одному компоненту.

    • Если документы схемы и печатной платы блока повторного использования не синхронизированы (между ними обнаружены различия), при попытке сохранить блок в рабочем пространстве появится диалоговое окно с предупреждением. Вы можете отменить сохранение, чтобы вернуться к блоку и устранить различия, или продолжить сохранение.

  5. Откроется диалоговое окно Create New Reuse Block, в котором можно задать Name, Description и Folder  рабочего пространства, куда будет сохранен новый блок повторного использования.

  6. После нажатия OK в диалоговом окне Create New Reuse Block блок повторного использования будет сохранен в рабочем пространстве, а его временная структура будет закрыта.

Поиск и размещение блока повторного использования

Блоки повторного использования, хранящиеся в подключенном рабочем пространстве, можно просматривать и использовать через панель Design Reuse, если она настроена на отображение ресурсов рабочего пространства (). В этом режиме панель отображает структуру папок рабочего пространства, позволяя переходить к папкам, в которых хранятся блоки повторного использования. Каждая папка и каждый блок представлены в списке в верхней части панели своим именем и описанием.

Чтобы найти нужный блок повторного использования, можно переходить по папкам или воспользоваться полем Search в верхней части панели Design Reuse для поиска блока по имени или описанию ().

  • В панели Design Reuse отображается только последняя ревизия каждого блока повторного использования.

  • Если последняя ревизия блока повторного использования находится в состоянии жизненного цикла, для которого отключен параметр Visible in Vault panels (подробнее), такой блок по умолчанию не отображается в панели. Чтобы отобразить скрытые блоки повторного использования, нажмите кнопку  в правом верхнем углу панели, затем включите параметр Show Hidden Revisions в открывшемся меню.

Нажмите элемент управления Details в нижней части панели, чтобы развернуть область Details, в которой отображаются сведения о выбранном блоке повторного использования, включая:

  • Имя блока повторного использования.

  • Значок состояния жизненного цикла и ревизию (нажмите ссылку, чтобы открыть подробное представление History элемента блока повторного использования с выбранной последней ревизией).

  • Описание блока повторного использования.

  • Общие сведения о блоке повторного использования и его параметры.

  • Изображения для предварительного просмотра документов схемы и печатной платы блока повторного использования.

  • Список проектов () и выпусков проектов (), в которых используется блок повторного использования (область Where Used).

Благодаря управляемому доступу к содержимому рабочего пространства в сочетании с подходящей схемой жизненного цикла уполномоченные сотрудники (библиотекари, руководители проектных подразделений) могут утверждать и предоставлять доступ только к тем блокам повторного использования, которые разрешено применять в проектах. Это позволяет разработчику спокойно работать, будучи уверенным, что он использует только разрешенные блоки.

Чтобы разместить блок повторного использования в проекте, наведите указатель на его запись на панели Design Reuse, нажмите кнопку  (или щелкните запись правой кнопкой мыши) и выберите в меню одну из следующих команд:

  • Place — выберите эту команду, чтобы разместить блок повторного использования непосредственно в активном документе схемы или печатной платы. В зависимости от типа документа, активного на момент выполнения команды, будет размещен документ схемы или печатной платы блока повторного использования.

     
  • Place as Sheet Symbol — если активен документ схемы, выберите эту команду, чтобы разместить блок повторного использования в виде символа листа на листе схемы. Размещенный символ листа будет содержать входы листа, соответствующие портам блока повторного использования. Содержимое блока будет размещено на автоматически созданном дочернем листе схемы, на который ссылается символ листа. Символ листа размещенного блока повторного использования будет отмечен специальным значком.

Если блок повторного использования содержит несколько документов печатной платы, перед размещением блока выберите нужный документ, щелкнув его вкладку под изображением предварительного просмотра документа печатной платы в области Preview панели Details (). При размещении блока повторного использования на схеме выбранный документ печатной платы будет связан с блоком и размещен на печатной плате при ее обновлении с помощью процедуры ECO.

После размещения документа схемы блока повторного использования его документ печатной платы можно разместить в документе печатной платы проекта с помощью процедуры ECO. В редакторе схем выберите команду Design » Update PCB Document в главном меню, затем проверьте и примените изменения в диалоговом окне Engineering Change Order.

Редактирование блока повторного использования

Чтобы отредактировать блок повторного использования, наведите указатель на его запись на панели Design Reuse, нажмите кнопку  (или щелкните запись правой кнопкой мыши) и выберите в меню команду Edit.

Для редактирования откроется временная структура проекта блока повторного использования, содержащая последнюю ревизию элемента блока повторного использования. Внесите необходимые изменения, затем сохраните блок повторного использования в виде следующей ревизии (File » Save to Server).

Другие действия с блоком повторного использования

Меню кнопки  (а также контекстное меню) записи блока повторного использования на панели Design Reuse предоставляет доступ к следующим командам:

  • Rename — используется для изменения имени блока повторного использования. После выбора команды введите новое имя в появившемся диалоговом окне Rename Reuse Block, затем нажмите OK.

  • Move — используется для изменения расположения элемента блока повторного использования в структуре папок рабочего пространства. При выполнении команды открывается диалоговое окно Move Item, в котором можно выбрать целевую папку для размещения элемента.

  • Share — используется для настройки прав общего доступа к блоку повторного использования. После выбора команды откроется диалоговое окно Share For Item, в котором можно настроить общий доступ нужным образом. Подробнее см. в разделе Общий доступ на уровне элементов.

  • Operations — открывает раскрывающееся меню дополнительных функций для блоков повторного использования, описанных ниже.

    • Make a Copy — используется для копирования блока повторного использования. Откроется временная структура проекта блока повторного использования с тем же содержимым, что и у исходного блока. Внесите необходимые изменения и сохраните блок повторного использования в рабочем пространстве. 

    • Change Revision State — используется для изменения состояния последней ревизии блока повторного использования. После выбора команды открывается диалоговое окно пакетного изменения состояния, в котором можно изменить состояние ревизии блока повторного использования.

    • Download — используется для скачивания данных, хранящихся в блоке повторного использования (его документов схемы и/или печатной платы). Связанные данные будут скачаны во вложенную папку выбранного каталога, имя которой соответствует идентификатору ревизии элемента блока повторного использования. Файлы находятся в расположенных внутри нее папках Released.

  • Delete — используется для удаления блока повторного использования из подключенного рабочего пространства. После выбора команды появится диалоговое окно Delete Items, в котором необходимо подтвердить удаление. Также можно выбрать удаление связанного содержимого блока повторного использования (то есть фрагментов схемы и печатной платы).

    Фактически выполняется «мягкое удаление»: блок повторного использования перемещается в область Trash рабочего пространства. Подробнее см. в разделе Мягкое удаление.

  • History — используется для открытия подробного представления блока повторного использования на новой вкладке в Altium Designer.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents