ActiveRoute

概览

本文介绍 Altium Designer 中的 ActiveRoute 如何将自动化与设计人员的控制相结合,加快 PCB 布线,而非依赖传统的自动布线器。文章阐述了 ActiveRoute 是什么、不是什么,以及它的主要优势,并介绍如何使用 PCB ActiveRoute 面板选择网络、定义布线引导、选择层、启用布线优化、调谐和引脚交换,以及调整布线行为。如果您希望在掌控布线过程的同时,实现更快速、更整洁且符合规则的布线,本指南将为您指明入门方向。请继续阅读,了解 ActiveRoute 如何改善您的工作流程。

- 了解 ActiveRoute 与自动布线器的区别,以及它为何更适合对选定网络进行引导式高质量布线。
- 学习 ActiveRoute 的主要功能,包括布线引导、多层布线、布线优化、调谐、蛇形走线控制和引脚交换。
- 了解如何使用 PCB ActiveRoute 面板,根据设计规则和布线目标配置并运行 ActiveRoute。
使用 AI 深入了解:

Concept image showing routing

电路板设计中最耗时的阶段之一是网络布线。虽然规则系统会处理线宽、过孔尺寸、间距等设计约束,但要完成整块电路板的布线,仍需设计人员放置成千上万条走线段。

自动布线器可以减轻这项负担,但通常被认为不够理想,原因如下: 

  • 它们无法正确考虑人工设计人员在布线时凭直觉就会遵循的各种细微设计约束。

  • 完整配置所需的时间太长,往往还不如直接以交互方式进行电路板布线更高效。

  • 后期整理可能是一个漫长而困难的过程,因此往往不如以交互方式进行电路板布线更高效。

PCB 布线的终极目标是在设计人员的控制下,快速获得符合设计规则的高质量结果。 这正是 ActiveRoute 致力于实现的目标。

Improving the Completed Routes

走线优化(Glossing)和重新走线(Retrace)功能与 ActiveRoute 相辅相成,但又彼此独立。无论现有布线是以何种方式创建的,都可以使用这些功能来提升其质量。

走线优化默认处于启用状态,并在 ActiveRoute 完成后运行;如有需要,可在 PCB ActiveRoute 面板中禁用。走线优化也有自己的一组选项,包括将走线拐角处理为圆弧的功能。

► 了解有关现有布线的走线优化与重新走线

什么是 ActiveRoute?

ActiveRoute 是一种自动化交互式布线技术,采用高效的多网络布线算法,对您选定的特定网络或连接进行布线。ActiveRoute 还允许设计人员以交互方式定义布线路径或引导线,从而确定新走线将沿其布设的 the river。

与常规交互式布线和自动布线相结合的方式相比,ActiveRoute 的以下主要功能使其具有显著优势: 

  • 自动优化引脚/过孔阵列的扇出布线——这是手动布线中最耗时的部分。
  • 性能出色——每个信号网络的布线时间 < 1 秒。
  • 遵循按网络和网络类定义的线宽、间距、层、拓扑及 Room 设计规则,并遵守规则优先级。
  • 同时在多个层上布线,并将走线分布到这些层上。
  • 提供直观的布线引导线,设计人员可用其引导走线的放置。
  • 采用河流式布线方法,无需过孔即可实现较高的布通率。
  • 能够穿过多边形覆铜区域进行布线,并重新铺铜(需启用重新铺铜选项)。
  • 支持单端网络和差分对网络。
  • 最后使用强大的走线优化工具,进一步减少拐角数量并缩短走线长度。

ActiveRoute 不是什么

ActiveRoute 不是自动布线器。它是一种引导式交互布线器,专注于对一组选定网络进行整洁、高质量的布线。使用 ActiveRoute 的方式与执行交互式布线任务相同: 选择所需网络,启用希望用于这些网络布线的层,考虑走线应遵循的路径,然后进行布线。

如果您选择电路板上的所有网络并使用 ActiveRoute 进行布线,结果很可能令您失望。 ActiveRoute 不是自动布线器; 它无法放置过孔,也不包含电源网络布线策略。

PCB ActiveRoute 面板

ActiveRoute 遵循 PCB 设计规则中定义的准则和限制,因此使用时只需选择所需的连接或网络 并运行即可。它也提供了一些专用控制功能,可在 PCB ActiveRoute 面板中配置。 PCB ActiveRoute 面板用于配置和操作 ActiveRoute 提供的各项功能,包括:执行交互式 ActiveRoute 布线;定义布线引导线及其内部的走线间距;启用自动长度调谐;以及启用自动引脚交换。强烈建议在启动 ActiveRoute 之前打开 PCB ActiveRoute 面板。

当 PCB 为活动文档时,要打开 PCB ActiveRoute 面板: 

  • 单击工作区右下角的  Panels button, click to enable the display of workspace panels available in the current editor 按钮,然后 选择 PCB ActiveRoute 菜单选项。

  • 单击 View » Panels » PCB ActiveRoute。

要在 Altium Designer 中使用 ActiveRoute 功能,必须安装 ActiveRoute 软件扩展。该扩展可以手动安装或移除。

有关管理扩展的更多信息,请参阅 Extending Your Installation 页面(Altium Designer Develop、Altium Designer Agile、Altium Designer)。

使用 PCB ActiveRoute 面板控制 ActiveRoute 过程。使用 PCB ActiveRoute 面板控制 ActiveRoute 过程。

PCB ActiveRoute 面板用于:

  • 启用允许 ActiveRoute 进行连接布线的信号层。
  • 对选定连接执行 ActiveRoute 布线。
  • 启用 ActiveRoute 完成后的走线优化。
  • 定义布线引导线。
    • 配置希望在布线引导线内使用的走线间距。
  • 配置并启用对 ActiveRoute 所布走线的长度调谐。
  • 配置蜿蜒布线选项,允许 ActiveRoute 定义更长的布线路径,这可能有助于提高布通率。
  • 配置并启用引脚交换。ActiveRoute 可在布线过程中交换引脚,以帮助提高布线质量。
ActiveRoute 对选定连接进行操作,面板中的某些控件只有在选中连接后才会启用。

 PCB ActiveRoute 面板的内容按可折叠部分组织,可使用各部分标题旁的 ► 图标展开或折叠。下文中的属性控件信息按对应的部分组织,每个可折叠部分均以相同方式展开或折叠。

ActiveRoute 的其他功能

ActiveRoute 是一款自动交互式布线器,使用起来简单直观:选择连接,然后按 Shift+A,即可使用 ActiveRoute 按照设计规则进行布线。ActiveRoute 还包含许多其他功能和控件,使设计人员能够更好地控制某些功能和能力。

其中包括:

  • 通过放置布线引导来定义布线路径和走线间距。
  • 通过绕行控件允许使用更长的布线路径。
  • 通过长度调节自动匹配走线长度。
  • 允许引脚交换,以简化布线难题。

下面逐一详细介绍这些功能。

使用布线引导定义路径

ActiveRoute 的主要目标之一是找出总体长度最短的一组布线路径,但这不一定是每组连接所期望的路径。布线引导为设计人员提供了一种工具,可用于绘制希望所选连接沿其布线的特定路径,即使该路径并非最短路径。

  • Defining the Route Guide - 首先选择要在引导内布线的连接,然后单击  Route Guide button, click to define a route guide that ActiveRoute will then attempt to route the selected nets along 按钮(位于 PCB ActiveRoute 面板中),然后单击以定义引导线的起点位置 ,继续移动鼠标并单击以定义路径。路径定义完成后,单击 ActiveRoute 按钮,沿该路径对所选连接进行布线。有关更多详细信息,请参阅本页后面的定义布线引导线部分。

避免将布线引导线的端点放在要布线的焊盘上。如果焊盘不包含在布线引导线内,焊盘出线的质量会更好。

  • Changing the Route Guide Width - 在放置布线引导线期间,可按  Keyboard Up arrow key 或  Keyboard Down arrow key 键加宽或收窄引导线。默认宽度为所选连接适用的线宽与间距设计规则值之和,除以层数,再乘以 1.3。如果需要定义其他路径,可按 Backspace 键逐步撤回引导线。
  • The Route Guide color - 由所选连接可供 ActiveRoute 使用的层决定。如果仅启用一个层,则以该层的颜色绘制; 如果启用了多个层,则以默认的布线引导线颜色绘制。
  • The track spacing within the Route Guide - 默认情况下,ActiveRoute 按照设计规则设置走线间距,不会尝试将走线分散开,也不会尝试用尽布线引导线内的所有可用空间。要在布线引导线内分散走线,请使用 Track-Track Space in Route Guide(布线引导线内的走线间距)功能,具体说明请参阅本页后面的内容。

此视频展示了布线引导线的放置过程,以及如何在放置期间交互式更改其宽度。
此视频展示了布线引导线的放置过程,以及如何在放置期间交互式更改其宽度。

布线引导线宽度

默认宽度为所选连接适用的线宽与间距设计规则值之和,除以层数,再乘以 1.3。 

  • RouteGuideWidth = ((W+C)/#Layers)*1.3)
  • 引导线默认按 1.3 倍扩宽,以确保有足够空间容纳走线,并允许走线绕过路径上的过孔等障碍物。该宽度是布线的硬性边界; 如果空间不足以容纳走线,则不会放置这些走线。
  • 在放置引导线期间,可按键盘上的  Keyboard Up arrow key 或  Keyboard Down arrow key 键增大或减小宽度。最小尺寸采用 1.0 倍系数; 最大尺寸采用 10.0 倍系数。

编辑引导线

布线引导线是放置在机械层上的一组走线。

  • 这些走线段默认处于锁定状态。将其解锁后,即可使用标准走线拖动方法调整引导线的形状。
  • 要移除引导线,请双击任意线段将其选中 ,然后按 Delete 键。

布线引导线内的走线间距

使用 Track-Track Space in Route Guide 功能,可以指示 ActiveRoute 在布线引导线的宽度范围内分散走线。使用滑块选择间距值,或在编辑框中输入数值。布线引导线会根据此设置自动调整尺寸。为此,必须先配置 Track-Track Space in Route Guide 设置,再放置布线引导线。在放置期间,还可按  Keyboard Up arrow key 和  Keyboard Down arrow key 键进一步调整布线引导线的宽度。

使用 Track-Track Space 功能分散布线引导线中的走线。
使用 Track-Track Space 功能分散布线引导线中的走线。

允许走线绕行

ActiveRoute 会尝试沿尽可能短的路径对所选连接进行布线,也就是尽量减少绕行。如果 ActiveRoute 的布通率低于预期,可通过 Meander(绕行)控件增大 ActiveRoute 允许的绕行量,这可能有助于提高布通率。默认的最大 Meander 设置为 100%,表示允许的走线总长度为 Manhattan Length + 100% of Manhattan Length。使用滑块选择绕行值 ,或在编辑框中输入百分比。

请注意,使用布线引导线时会忽略绕行设置 ,因为布线引导线用于定义路径,而该路径可能会显著增加绕行量。 

走线长度调谐

ActiveRoute 可对当前正在布线的连接 或选定的现有走线进行长度调谐。ActiveRoute 将尝试满足所选的 Matched Lengths(长度匹配)设计规则。

要配置 ActiveRoute 以进行长度调谐:

  • 启用面板 Action 区域中的 Tune Selected 复选框。

  • 在面板的 Tune 区域中启用所需的 Matched Lengths 设计规则。

  • 在面板的 Tune 区域中配置所需的 Max Amplitude 和 Min Space 设置(单端或差分对)。

PCB ActiveRoute panel, Tune section is used to configure the tuning shapes added by ActiveRoute to match the route lengths

目前,仅支持 Mitered Lines(斜接线)调谐样式,转角斜接比例约为 20%。ActiveRoute 放置的蛇形线也不是联合体(Union)。ActiveRoute 的长度调谐支持仍在持续开发中,其他调谐样式和蛇形线联合体功能正在评估中。

► 要了解有关 ActiveRoute 长度调谐设置的更多信息,请参阅 PCB ActiveRoute 面板页面上的长度调谐部分。

► 要了解如何使用可调节的蛇形线形状对现有走线进行长度调谐,请参阅长度调谐文章。

引脚交换

软件包含功能强大的引脚和部件交换系统,可在原理图与 PCB 编辑器之间联动。ActiveRoute 可以访问引脚交换设置,并在有助于缩短整体走线长度和提高布线质量的情况下,在布线过程中交换引脚。

要使用引脚交换:

  • 每次打开工程后,都必须先编译工程(Project 菜单),才能执行任何引脚交换操作(无论是交互式操作还是由 ActiveRoute 执行)。
  • 要配置和管理元器件的引脚交换设置,请运行 Tools » Pin/Part Swapping » Configure 命令,打开 Configure Swapping Information in Components 对话框。
  • 启用 PCB ActiveRoute 面板的 Action 区域中的 Pin Swap Routing 选项。
  • 在 PCB ActiveRoute 面板的 Pin Swap 区域中启用所需的元器件。

要了解有关引脚交换功能的更多信息,请参阅引脚、差分对和部件交换。

ActiveRoute 准备工作

ActiveRoute 可以使用布线优化功能(Route » Gloss Selected);如果在 PCB ActiveRoute 面板中启用了该功能,它就会在 ActiveRoute 过程中自动运行。

ActiveRoute 失败的最常见原因是没有足够的空间容纳走线,因此,确保正确配置线宽和间距规则非常重要。

执行 ActiveRoute

要执行 ActiveRoute:

提升操作熟练度

  1. 熟练掌握 ActiveRoute 的关键之一是熟练使用快捷键。您最常用的按键组合包括:

    • Alt+Click - 选择单条连接线。
    • Alt+Click&Drag - 选择区域内的连接线。从右向左拖动可选中所有接触到的连接线;从左向右拖动则仅选中完全位于选择框内的连接线。按 Tab 可扩展选择范围,将相同网络中的其他连接线也包含在内。状态栏会显示刚选中的连接线数量,直到光标移到其他对象上。
    • Ctrl+Click&Drag - 选择元件中的焊盘。从右向左拖动可选中所有接触到的焊盘;从左向右拖动则仅选中完全位于选择框内的焊盘。按 Tab 可扩展选择范围,将相同网络中的其他布线对象也包含在内。连续按 Tab 可循环切换所有可能的选择状态。
    • Click&Drag - 选择现有走线段。从右向左拖动可选中所有接触到的走线;从左向右拖动则仅选中完全位于选择框内的走线。按 Tab 可扩展选择范围,将相同网络中的其他布线对象也包含在内。连续按 Tab 可循环切换所有可能的选择状态。
    • 执行新的选择操作时,同时按住 Shift 可保留当前选择。
    • Shift+A 对当前选中对象执行 ActiveRoute 布线。
    • Ctrl+Alt+G - 对当前选中对象执行布线优化。
  2. 选择操作仅对可见对象生效(Ctrl+A 除外):

    • 按 Shift+S 可循环进入或退出单层模式,以便仅显示所需的层。
    • 如果设计使用了布局区域,可以在设计规则中定义这些区域时将其锁定,也可以将其隐藏,以防在单击并拖动时选中或移动这些区域。可在 视图配置面板的 View Options 选项卡中隐藏布局区域。
  3. 对 SMD 焊盘进行扇出。ActiveRoute 不会切换布线层,因此您需要对 SMD 焊盘进行扇出。要加快扇出过程:

    • 在对连接线进行布线时,按 / 快捷键(数字小键盘)可放置一个过孔并释放当前连接。如果没有数字小键盘,请使用 2 快捷键(放置过孔但不中断布线)。
    • 复制并粘贴现有扇出;PCB 编辑器会自动更新网络名称。此操作也适用于多个扇出。
  4. 保留现有扇出。如果 ActiveRoute 找到更好的方案,就会修改扇出;如果不希望扇出被更改,可将其锁定。锁定扇出的最简单方法是选中扇出走线和过孔(可借助 Properties 面板顶部的 Selection Filter 完成选择),按 F11 打开 Properties 面板,然后勾选 Locked 复选框。这样即可一次性锁定所有选中的对象。

  5. 如果使用布线引导时发现布通率较低,可能是因为路径上的障碍物过多,需要加宽引导。放置过程中按 Up 方向键可加宽引导。

  6. ActiveRoute 完成后,会执行布线优化(如果已在 PCB ActiveRoute 面板中启用)。要查看 ActiveRoute 刚完成布线时的结果,按一次 Ctrl+Z 即可撤销布线优化。Gloss 命令(Route » Gloss Selected)可用于平滑走线并改善走线进入焊盘的方式,适用于任何布线,而不仅限于 ActiveRoute 布线。该功能特别注重确保差分对以高质量的方式进入焊盘。要了解有关布线优化的更多信息,请参阅现有布线的优化与重布线页面。

  7. 如果 ActiveRoute 无法工作,通常是因为规则配置不正确。ActiveRoute 失败最常见的原因是没有足够的空间容纳走线。请检查规则是否合适,例如,新建 PCB 文件中的默认规则所要求的尺寸对于高密度 BGA 类设计而言可能过大。

  8. ActiveRoute 遵循按层、按布局区域和按类配置的线宽、间距及差分对间距等布线规则。ActiveRoute 不使用圆弧或任意角度走线进行布线。

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents