搜索和放置元件

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

概览

本文介绍如何使用 Altium Designer 的“元件”面板,查找、查看、管理和放置来自工作区、数据库库以及基于文件的库中的元件。文章重点介绍了多种搜索方式,包括按类别浏览、直接输入查询条件搜索,以及对工作区元件进行参数化筛选,同时说明该面板如何与“制造商器件搜索”面板、元件编辑器和“资源管理器”面板等相关工具协同使用。您还将了解如何从原理图和 PCB 文档中打开该面板、元件类别的确定方式,以及可用于简化工作流程的操作和显示控件。如果您希望更轻松地找到合适的器件,并将其高效地放置到设计中,请继续阅读。

- 了解如何在“元件”面板中使用类别、搜索查询和基于参数的筛选条件来搜索元件。
- 了解元件的来源,包括工作区、基于文件的库、数据库库以及“制造商器件搜索”面板的搜索结果。
- 了解如何放置元件,以及如何使用面板的主要功能来查看详细信息、编辑元件、管理库和整理元件列表。
使用 AI 深入了解:

元器件是所有电子设计的核心。 最终焊接到电路板上的元器件,需要在各个设计领域中以相应形式表示或建模:在原理图中表示为符号,在仿真器中表示为 SPICE 模型,在电路板上表示为封装,在交付给机械设计人员的文件中表示为 3D STEP 模型。

了解有关创建和维护元器件及库的更多信息。

Altium Designer 的 Components 面板提供了强大的界面,可用于访问和操作所有元器件,包括工作区元器件和非工作区元器件。 您可以指定类别,并使用简单搜索模式,在搜索字段中输入查询内容(完整或部分元器件名称、值等),查找所需的元器件。此外,该面板还提供基于筛选器的参数化(分面)搜索功能,可通过指定目标元器件参数来查找工作区元器件。您还可以通过该面板,在元器件编辑器的单元器件编辑模式下编辑工作区元器件,在其源工作区中查看元器件,以及执行元器件管理操作,例如创建和克隆元器件,或编辑所选元器件的备选器件和类型。 您可以通过拖放元器件,或使用元器件右键菜单中的 Place 命令,将其放置到原理图上。

当然,除了自行创建元器件外,您还可以使用 Altium Designer 提供的强大的制造商器件搜索面板 来搜索实际生产的器件。如果您拥有工作区,可以将这些器件保存到该工作区,然后通过 Components 面板访问它们。此 过程涉及在元器件编辑器的单元器件编辑模式下创建新的工作区元器件,并将其保存到工作区。

在 Altium Designer 中,Components 面板可用于直接访问可用的工作区元器件 以及数据库和基于文件的库元器件。

该面板从已连接的工作区以及任何已打开或已安装的库中获取元器件。面板提供所选元器件的完整详细信息(参数、模型、备选器件、供应商数据等)和元器件比较功能;对于工作区元器件,还提供基于筛选器的参数化搜索功能,可用于指定目标元器件参数。

处于普通模式的 Components 面板

处于紧凑模式的 Components 面板

 

Components 面板采用与制造商器件搜索面板相同的基础搜索引擎功能和视图。Manufacturer Part Search 面板利用 Altium Parts Provider 服务,侧重于搜索元器件制造商和供应商数据;而 Components 面板则显示来自已连接的工作区、数据库库和基于文件的库中可直接放置的元器件。

对于工作区元器件,面板仅显示每个元器件的最新修订版。
虽然大部分元器件操作功能都可以通过 Components 面板使用,但您也可以使用 Explorer 面板。前者本质上提供了后者功能的一个子集,侧重于元器件管理。某些与元器件本身相关的操作仍然只能通过 Explorer 面板执行(例如,无需编辑即可添加数据手册、更改状态、批量删除元器件和模型等),但这些操作更多用于非常规的特殊情况,或作为管理及工作区结构调整工作的一部分。请记住,元器件只是其中一种内容类型,而 Explorer 面板能够充分支持工作区所支持的全部内容类型。例如,元器件模板与元器件密切相关,但只能在 Explorer 面板中创建和管理(除非在导入库时使用库导入器创建模板)。

访问元器件面板

要打开 Components 面板,请从主菜单中选择 View » Panels » Components,或从主界面右下角的 按钮菜单中选择 Components 选项。该面板采用响应式设计,布局会在全屏普通模式()与紧凑模式()之间动态调整;在紧凑模式下,类别/筛选器选项会折叠为菜单。

在原理图文档中,使用 P, P 键盘快捷键打开 Components 面板。 您也可以使用主菜单中的 Place » Part 命令、原理图编辑器设计空间右键菜单中的 Place » Part 命令,或 Active Bar上的 Part 按钮()。

在 PCB 文档中,使用 P, C 键盘快捷键打开 Components 面板。您也可以使用主菜单中的 Place » Component 命令、PCB 编辑器设计空间右键菜单中的 Place » Component 命令,或 Active Bar上的 Component 命令()。

在当前 Altium Designer 会话中首次打开 Components 面板时,如果已连接到工作区,则可以使用以下控件:

  • Use Existing Components – 单击可浏览面板顶部下拉列表中当前选定的元器件类型。

  • Delete Existing Components – 单击可打开 Delete Existing Components 对话框,随后打开工作区 Settings中的 Data Cleanup 页面,您可以在其中选择要移除的内容类型。

  • Import Library – 单击可打开标准 Windows Open 对话框,然后选择保存在本地或网络文件夹中的数据库库或基于文件的库。打开库文件后,库导入器将以简单模式启动,并加载所选库。

  • Create Component – 单击可打开创建新元器件对话框,随后打开处于单元器件编辑模式的元器件编辑器,以便定义新元器件。

面板的 Categories 窗格(或紧凑模式下的下拉菜单)会在 All 类别条目下列出所有可用的工作区元器件,以及所有可用的库。当面板处于普通模式时,单击 Categories 列表图标 或 « 图标可折叠或展开该列的显示,并可使用右上角的 按钮切换元器件 Details 窗格的显示状态。浏览 Categories 窗格时,可以使用 Up/Down 和 PgUp/PgDn 键盘快捷键逐项浏览列表。使用 Left/Right 键盘快捷键可展开和折叠各个分支。

Workspace 元件的 Categories 分组依据各元件关联的 Component Type 参数确定。例如,如果某个元件的 Component Type 被指定为 Resistor,则该元件将列在 Components 面板的 Resistor 类别下(无论其位于 Workspace 的哪个文件夹中)。

要即时指定或更改元件类型,请右键单击其条目,然后从上下文菜单中选择 Operations » Change Component Type 选项,打开选择元件类型对话框。

元件的 Type 参数可在以下情况下设置:

元件类型在 Preferences 对话框的数据管理 – 元件类型页面中进行管理(创建、编辑和删除)。单击该对话框中的 Templates 按钮可打开 Edit Templates 对话框,在其中可以指定或更改与各元件类型关联的元件模板。

NOTE: 元件所属的 Category 由其元件类型参数定义,与其所在的 Workspace 文件夹无关。因此,如果通过 Explorer 面板将元件移动到其他文件夹,此更改不会反映在 Components 面板中。

操作菜单

操作菜单中的选项可用于设置基于文件的库的首选项、执行搜索,以及指定是否显示元件模型集合。要访问这些选项,请单击面板右上角的操作菜单 按钮。

  • Create Component – 选择此项可打开 Create new component 对话框,随后打开处于单元件编辑模式的元件编辑器,以便定义新元件。
  • Import Library – 选择此项可打开标准 Windows Open 对话框,并选择保存在本地或网络文件夹中的数据库库或基于文件的库。打开库文件后,将启动处于简单模式的 Library Importer,并加载所选库。
  • Clean-up Library – 选择此项可打开 Delete Existing Components 对话框,随后打开 Workspace 的 Settings 中的 Data Cleanup 页面,您可以在其中选择要移除的内容类型。
  • Models – 选择此项可在 Categories 列表中包含库模型集合条目。在此浏览模式下,新增的条目包括来自已连接 Workspace 的符号、封装和仿真模型集合,以及已安装的 PCB 封装库(*.PcbLib)。
  • File-based Libraries Preferences – 选择此项可打开 Available File-based Libraries 对话框,其中提供了相应控件,用于向当前项目添加数据库库和基于文件的库、从当前项目移除库、安装库以及指定库搜索路径。有关更多信息,请参阅 在基于文件的库和数据库库中搜索元件 页面的 管理可用的数据库库和基于文件的库部分。
  • File-based Library Search – 选择此项可打开 File-based Libraries Search 对话框。当您不知道某个元件位于哪个数据库库或基于文件的库中,甚至不确定该元件是否可用时,可以在此对话框中搜索。 有关更多信息,请参阅 在基于文件的库和数据库库中搜索元件 页面的 在数据库库和基于文件的库中搜索元件部分。
  • Refresh – 单击可快速刷新面板。当前选中的元件将予以保留。

元件列表

在元件列表表格中,可通过以下方式管理列表内容:

  • 设置元件列表的排序顺序 – 单击列标题可按该列数据对元件列表排序。再次单击该标题可反转排序顺序。

  • 设置显示列的顺序 – 将列标题拖放到新位置。

  • 指定显示哪些参数列 – 右键单击列标题并选择 Select Columns,打开 Select Columns 对话框,在其中可以控制 参数列的可见性并调整其位置顺序。

    Select columns 对话框
    Select columns 对话框

    • 此对话框列出了可在 Components 面板中显示的所有列。 当某项显示  时,该列将显示在 Components 面板中。当某项显示  时, 该列将not 显示在 Components 面板中。单击这些符号可切换显示/隐藏状态。

    • 您也可以单击列标题栏中的 / 图标来控制所有列的显示。当部分列可见而其他列隐藏时,会显示  图标。

    • 将光标悬停在第二列的标题栏上,然后单击  图标以打开下拉菜单,从中选择要显示的列。

    • 使用  /  按钮可在列表中向上或向下移动选中项。只有设为可见()的项才能移动。这决定了各列在 Components 面板中的显示顺序。

  • 按列数据对列表分组 – 右键单击列标题,选择 Enable Columns Grouping 选项,然后将某个列标题(例如 Footprint)拖到列表顶部的分组区域。列表条目将按指定分组列中各个唯一的参数值(例如封装类型)归组。

    使用 Grouping 整理列表中的元件时,最多可容纳 10,000 个条目。

  • 按特定列条目筛选列表 – 选择列标题中的 ,显示该列中不重复的参数条目列表,然后选择某个条目,将列出的元件限定为包含指定参数(例如封装类型代码)的元件。选择 All 选项可重置筛选器。选择 (Custom) 可打开 Filter Editor 对话框,以进一步细化所选列的筛选条件。

显示列

您可以通过多种方式显示 Components 面板中的内容。右键单击各列的名称(名称、描述、封装)时,可以根据所需的元件显示方式选择以下选项:

  • Best Fit – 将 Name 和 Descriptions 列的内容紧凑排列,消除列之间的多余空白。

  • Best Fit All Columns – 将所有列的内容紧凑排列,消除列之间的多余空白。

  • Clear Sorting – 用于撤销列排序。

  • Enable Columns Grouping – 允许按特定列拖动列标题,从而更改 Name、Description 和 Footprint 列的顺序。

  • Select Columns – 打开 Select Columns 对话框,您可以在其中选择要在此区域显示的其他列。

  • Apply Column Visibility to Child Categories – 当所选类别具有子类别时,使用此命令可将父类别的列可见性设置应用到子类别。此命令仅在存在子类别时可用。

元件搜索与功能

搜索元件

要在 Components 面板中搜索可用元件,请在 Search 字段中输入短语,和/或使用面板中的 Categories 和 Filters 选项,将元件列表缩小至符合特定需求的范围。筛选器仅支持 Workspace 元件,并且与 Manufacturer Part Search 面板一样,Components 面板支持可识别单位的(文本转数字)搜索筛选器。搜索功能会根据输入的搜索条件对结果进行优先排序。

Search 功能允许您选择当前的 Search 字符串,然后进行编辑或添加内容。

单击“当前”搜索字符串,将其输入到 Search 字段中。您可以在 Search 字段中重复使用或编辑该搜索内容。

Search 字段还支持使用通配符进行搜索,通配符以字符串中的星号 (*) 表示。

右键单击列表中的元件,然后选择 Find Similar Components,即可打开 Find Similar Components 对话框,在其中根据所选元件定义搜索偏好。

最终搜索结果取决于所选元件的类型(Workspace 元件或非 Workspace 元件)以及您的 Workspace 连接状态。例如,Workspace 元件通常会比非 Workspace 元件显示更多参数。要专门查找元件及其与所选元件相同或不同的参数,可以使用下拉列表选择 Same、Any 或 Different 选项。

放置元件

您可以通过拖放、从右键快捷菜单中选择 Place、使用 Details 窗格中的 按钮、双击所需元件的条目,或使用 Enter 快捷键,将选定元件放置到原理图上。

要从面板中放置元件,您可以:

  • 单击 Component Details 窗格中的 Place 按钮——光标会自动移到原理图图纸范围内,元件会悬浮在光标上;将其移至所需位置并单击即可放置。放置一个元件后,同一元件的另一个实例会出现在光标上;单击鼠标右键可退出放置模式。

    Components panel, placing from component details pane

  • 右键单击元件,然后从快捷菜单中选择 Place。元件会悬浮在光标上;将其移至所需位置并单击即可放置。请注意,如果面板悬浮在设计空间上方,它会淡出,以便您查看原理图并放置元件。放置一个元件后,同一元件的另一个实例会出现在光标上;单击鼠标右键可退出放置模式。

  • Click, Hold&Drag – 单击并将元件从面板的表格区域拖到原理图图纸上。在此模式下,需要按住鼠标按键;松开鼠标按键时即可放置元件。放置元件后,您可以选择另一个元件或其他命令。

    拖放操作会放置元件的单个实例。如果需要放置多个实例,请使用 Place 命令/按钮,或双击元件条目。

放置元件确实非常简单。但在进行任何操作之前,请先确保要放置元件的原理图图纸(或 PCB 文档)已在 Altium Designer 中打开,并且是活动文档。如果文档分布在多个窗口中打开,还应确保包含该活动原理图文档的窗口具有焦点。

在多个窗口中使用 Altium Designer 时,如果 Components 面板或 Explorer 面板以任何模式停靠在不包含目标原理图的窗口中,Place 命令将保持灰显状态。这是因为单击停靠面板内部会使该面板所属的窗口获得焦点。但是,当面板处于浮动状态时,可以使所需的 Altium 窗口(包含活动目标原理图的窗口)获得焦点,并且在面板内操作时,该窗口将保持焦点。

放置多部件元件

如果要放置的元件包含多个部件,则首先放置的是面板 Models 区域中符号预览图下方选定的部件。

放置多部件元件的某个部件后,可以选中该部件,然后使用 Properties 面板中的 Part 下拉列表将其更改为此元件的其他部件;也可以使用主菜单中的 Edit » Increment Part Number 命令或该部件右键菜单中的 Part Actions » Increment Part Number 命令,将其切换为下一个可用部件。

Altium Designer 支持通过定义的“正常”和“备用”显示模式,仅使用一个元件即可将多部件元件显示为单个符号(包含所有子部件)或多个符号(每个子部件各对应一个符号)(显示示例)。

  • 如果多部件元件在其显示模式(正常或备用)中包含空子部件,则放置时会忽略这些子部件 (显示示例)。

  • 如果多部件元件仅在一个子部件中定义了图元,则将该子部件放置到原理图图纸上时,会隐藏位号后缀(显示示例)。

  • 当子部件在当前所选显示模式下没有图元,或显示模式在当前所选子部件中没有图元时,元件 Properties 面板中 Mode 下拉列表的 Part 中对应的条目将显示为灰色()。在下拉列表中选择此类条目时,将显示警告图标 ()。

  • 如果元件包含没有图元的子部件,且这些子部件未放置在原理图上,则运行设计验证时不会出现 元件中存在未使用的子部件 违规。

筛选元件

查看工作区元件时,Filters 窗格中会根据当前搜索和可用参数填入所选的筛选选项。对列出的元件进行参数化筛选,可提供更多选项来查找特定元件或某类元件。使用 Categories 窗格上方的 按钮打开 Filters 窗格。在面板的紧凑模式下,单击 按钮可将 Filters 弹出为面板扩展区域。

请注意,筛选器仅支持 工作区元件。使用窗格中的筛选器 Search 字段可查找特定的参数筛选器。

Javascript ID: Pnl_Components_Filter
  • 面板的 Filters 参数化搜索功能依赖于托管工作区元件的工作区传入适当的元件参数数据。因此,当软件连接到较旧的 Altium 服务器产品时,筛选功能可能会被禁用。要为旧版服务器启用筛选功能,请在 高级设置对话框 中启用 ComponentSearch.LegacyAFS.Filters 选项。

  • 请注意,要使某个参数显示在 Filters 窗格中,所选类别中的元件必须为该参数使用至少两个不同的值。另外,Filters 窗格最多只显示 100 个最常用的参数(即在所连接工作区的所有元件类型中,被更多元件使用的参数)。以下参数(或以以下名称开头的参数)始终显示在窗格顶部: Power、Value、Resistance、Res、Capacitance、Case、Package、Tolerance、RoHS、Lead。

您可以根据需要,将特定参数类型选为 Favorites,以自定义面板的 Filters 选项;这些参数随后会移至当前元件类别列表的顶部。将鼠标悬停在参数筛选器名称的右侧,然后单击 图标,即可将该筛选器设为收藏。收藏筛选器设置按各个元件类别分别应用和保存。

对于工作区元件,右键菜单提供了通过元件编辑器编辑元件(Edit)的选项,以及执行元件管理功能的选项,例如创建和克隆元件,或编辑所选元件的备选器件和类型(Operations)。

 
 
 
 
 

元件 Details 窗格中的其他信息选项包括:查看模型图像、查看在线数据手册(References)、查看实时供应商信息(Part Choices)、查看该器件在工作区项目、受管图纸和复用块中的使用位置(Where Used),以及通过右键菜单以制表符分隔的格式复制所选或全部元件参数数据(技术详细信息),并将标记为收藏的参数重置为五个默认参数。

浏览已连接的 Altium 365 工作区 中的元件时,如果发现所选元件存在健康状况问题,元件参数列表上方的 Component issues 行中会显示 (表示错误)或 (表示致命错误)图标。图标右侧的数字表示发现的问题数量。单击数字右侧的向下箭头可查看问题的简要说明。

发现的库健康状况问题示例。
发现的库健康状况问题示例。

您可以通过 Altium 365 工作区浏览器界面中的“库健康状况”仪表板页面,更详细地了解工作区库的健康状况。有关更多信息,请参阅 库健康状况仪表板。

您可以使用自定义筛选功能,进一步细化 Components 面板中的筛选条件。​​​​​​

使用此功能的方法如下:

  1. 单击标题栏中的筛选图标(),显示“筛选”下拉菜单,

  2. 该菜单 支持通过选择 Filter Value(默认方式)或配置用户定义的 Filter Rule 进行筛选。如果从列表中选择一个值,该值会自动转换为表达式(随后可对其进行编辑)。

  3. 如果选择 Filter Rules 来定义自己的筛选条件,请先从第一个下拉列表中选择运算符,

  4. 然后在第二个下拉列表中选择或输入筛选值。

  5. 当前筛选条件显示在结果列表下方,单击 按钮可打开 Filter Editor 对话框并 编辑筛选条件。

使用位置

在 Components 面板中选择一个工作区元件,即可在 Where Used 区域查看其最新修订版当前的使用位置信息。该区域提供以下类别的快速筛选信息:

  • Projects – 使用了该元件的工作区项目。项目保存到工作区后,才会 only 显示相关信息。

  • Managed Sheets – 使用了该元件的受管原理图图纸。 

  • Reuse Blocks – 作为已连接工作区库的一部分存储的复用块。

请注意,只有当工作区中存在使用了所选元件的实体时,才会显示相应选项卡。

如果某个元件并非用于工作区项目的所有 设计变体,则 Where Used 区域中的项目条目会显示使用了该元件的变体数量和该项目的变体总数,以及使用了该元件的变体列表()。

元件数据缓存

使用 Components 面板时,工作区元件的数据会从工作区缓存到本地计算机。这样,当 Altium Designer 未连接到工作区时,便可通过离线访问模式访问工作区元件,从而正常浏览和放置元件等。

在当前 Altium Designer 会话中首次启动 Components 面板时,如果处于离线模式,面板中会显示警告,并提供用于继续使用缓存元件数据或清除缓存的控件。

单击 Use Cached Data 可使用缓存的元件。 面板元件列表窗格底部栏中的 Offline mode – cached data is being used 警告文本会指示此状态。请注意,此模式下不会启用 Filters。

缓存会随时间逐步积累元件数据,您可以随时使用 Preferences 对话框的 数据管理 – 服务器页面中 Known Servers 下的 Clear Cache 选项,清除所有工作区的缓存。

缓存机制仅显示当前已连接工作区(例如 Altium 365 工作区)中的缓存元件,因此某些缓存数据可能不可用。您可以在 Preferences 对话框的 Data Management – Servers 页面中管理此行为。

器件选型列表

从条目的右键菜单中选择 Operations » Create/Edit Part Choices 选项,即可编辑与工作区元件关联的 器件选型列表。

使用随后显示的 Edit Part Choices 对话框中的 按钮打开 Add Part Choices 对话框,该对话框会根据所选元件的 Name 参数自动搜索器件制造商。取消选择预定义的搜索词,即可手动搜索替代器件。从功能上看,该对话框是 制造商器件搜索面板的模态版本。

您可以通过选择相应的星级图标对器件选型列表进行评级,列表会自动重新排序,将评级最高的制造商器件选型置于顶部。

无论元件数据应用于何处,例如原理图设计、BOM 文档、输出报告等,器件选型信息都会随元件一同保留。

在 Components 面板中选择元件后,可在 Details 窗格的 Part Choices 区域中查看其器件选型列表。Details 窗格顶部还会显示相关器件选型的基本信息(库存、单价中位数和制造商生命周期)。 关联的彩色条带会根据推断的生命周期状态,指示该器件是否适合使用;例如,与评级为 Volume Production (绿色)的元件相比,不建议使用标记为 Obsolete (红色)的元件。将鼠标悬停在彩色条带上,可查看其制造商生命周期状态。

如果您使用 SiliconExpert 或 Z2Data 集成功能,Details 窗格顶部可能会显示其他数据和控件。 有关详细信息,请参阅从 SiliconExpert 获取器件数据 和 从 Z2Data 获取器件数据页面。

如果您的工作区已启用器件选型修订控制功能, 选择 Operations » Create/Edit Part Choices 选项将打开元件编辑器(处于单元件编辑或批量元件编辑模式),而不是 Edit Part Choices 对话框。根据需要修改器件选型, 然后将元件保存回工作区,生成下一版元件修订。

Components 面板右键菜单

该面板的右键弹出菜单提供以下命令:

 
 
 
 
 
  • Place [ComponentName/FootprintName/SimulationModelName] – 用于将当前选定的元件或仿真模型放置到活动原理图文档中,或将当前选定的封装放置到活动 PCB 文档中。

  • Find Similar Components – 用于打开查找相似元件对话框,设置搜索条件,以查找与所选元件相似的元件。

  • Navigate to [ComponentName] – 用于在 Explorer 面板中打开所选工作区元件。在此面板中,您可以访问详细的条目信息、管理条目的修订和生命周期设置,以及查看使用位置和供应链详情等。

  • Edit – 单击可通过元件编辑器(处于单元件编辑或批量元件编辑模式)编辑所选工作区元件,或在相应编辑器中编辑所选领域模型(符号、封装或仿真模型)。如果当前元件类型与当前使用的模板不同,将打开 Change component type 对话框()。使用此对话框可更改所选元件的元件类型。

  • Create – 单击可打开 Create new component 对话框,以便在添加新元件时选择元件类型。

  • Delete – 单击可从已连接的工作区中删除所选元件。

  • Operations – 用于访问包含工作区元件其他功能的下拉菜单,具体如下所述。

    • Submit Request – 用于访问处于活动状态的器件申请流程定义。如果“器件申请”流程主题没有可用的活动流程定义,Submit Request 按钮将呈灰色(不可用)。您可能需要退出工作区后重新登录,或重新启动 Altium Designer 以刷新。

    • Download – 用于将所选元件下载为压缩的已编译集成库 (*.IntLib),其中包含其源库包(*.LibPkg)和库文件。 选择多个元件条目,即可一次下载这些元件。

    • Make a copy – 单击可复制所选元件。元件编辑器将以 Single Component Editor 模式打开。

    • Change Component Type – 用于打开 Choose component type 对话框 (),您可以在其中将当前元件的类型更改为列表中其他已定义的现有类型。此对话框会显示与元件类型关联的元件模板信息,以及已连接工作区中用于查找/保存该类型元件的文件夹。 单击  按钮,可在 Preferences 对话框的数据管理 – 元件类型页面上管理可用元件类型列表。

    • Change State – 用于更改所选元件的修订状态。执行此命令后,将打开批量状态更改对话框,您可以在其中更改元件的修订状态。

    • Create/Edit Part Choices – 用于访问 Edit Part Choices 对话框,您可以在其中创建或编辑与工作区元件关联的器件选型列表。

      如果您的工作区已启用器件选型修订控制功能, 选择此命令将打开元件编辑器,并进入单元件编辑或批量元件编辑模式。
    • Full Item History – 用于访问当前所选元件的详细视图,该视图将作为新的选项卡视图在 Altium Designer 中打开。条目视图提供特定条目的详细修订和生命周期历史记录,并显示构成该条目的所有元素。此视图还包含时间线。使用时间线可查看该条目的修订级别或生命周期状态发生任何更改的确切日期和时间,以及执行更改的人员。

  • Refresh – 单击可快速刷新面板。当前选中的元件将保持不变。

元件比较功能

Compare 功能允许您比较两个所选元件(器件)的参数。在 图标已启用(蓝色)的情况下,选择网格区域中的两个元件即可使用此功能。 Selected Component Details 区域将在网格区域右侧打开。上部区域(下图中的区域 1)并排显示所选元件的图像、名称、描述和价格。单击 Datasheet 按钮可打开相应元件的制造商数据手册(如有)。单击 Place 按钮可将元件放置到设计空间中。元件将以悬浮状态出现在设计空间中;单击即可将元件放置到所需位置。您可以继续放置更多元件,也可以右键单击或按 Esc,退出放置模式并返回 Components 面板。

下部区域(下图中的区域 2)并排显示元件参数,并以红色文本突出显示差异,便于比较。

当 Components 面板处于紧凑模式时,也可以使用 Compare 功能,但其工作方式略有不同。选择网格区域中的两个元件即可使用此功能。Selected Component Details 区域将在网格区域下方打开。上部区域显示元件的名称、价格和参数,并以红色文本突出显示差异,便于比较。下部区域并排显示元件的 Symbols 和 Models。

Compare 功能也可在制造商器件搜索面板中使用。

编辑元件符号和封装

可以在 Details 窗格的 Models 部分中隐藏指定元件的符号和封装,单击右上角的 Info button 即可访问该窗格。隐藏后,符号和封装将替换为可单击的链接,单击这些链接可将隐藏项恢复为原始视图。此外,还可以缩放所显示模型的大小。对于符号和封装,单击并拖动模型区域的下边缘即可调整图像大小。

请注意,制造商器件搜索面板的 Details 窗格也支持隐藏模型视图和调整其大小。

对于在 Components 面板中浏览的原理图库(*.SchLib)文件,可以使用模型预览右下角的 按钮编辑所选元件的符号和封装。

访问 Components 时,只要已存在有效且已关联的封装,即可编辑封装。

元件选择对话框

Components 面板中使用的搜索引擎和视图也适用于 Altium Designer 中其他需要选择元件的应用。这些(模态)对话框中包含元件搜索功能,以及一个 OK 确认按钮,可用操作命令略有不同。该对话框通常称为 Component Search。

访问和放置通用元件

此功能处于公开测试阶段,且在 高级设置对话框中启用 ComponentSearch.GenericComponents 选项后可用。

为加快设计早期阶段的布局过程, 引入了标准、基本的 Generic Components 这一概念。通用元件可以快速放置到设计中,无需从可用元件来源中查找和选择特定的制造商器件。通用元件旨在用作占位元件,便于在设计流程的后期替换为合适的元件,也可将其视为虚拟元件或参数化元件。

要了解有关创建通用元件的更多信息,请参阅 创建通用元件 页面。

当 Altium Designer 连接到 Workspace 时,可从面板中访问可用的通用元件:在 Categories 窗格中选择 All 选项后即可显示这些元件;如果面板处于紧凑模式,也可以通过顶部的下拉菜单访问。单击通用元件磁贴中的 按钮,可将元件附着到光标上,以便放置到当前原理图文档中。元件放置到原理图后,其符号的引脚、线条和边框图元(实际上就是其外形)会显示为红色,表示正在使用通用元件。在 Components 面板中选择磁贴本身,将在面板中打开该元件类型的类别。

从 Components 面板放置通用元件
从 Components 面板放置通用元件

由于通用元件不得用于最终设计,因此将其放置到原理图中会引发 ERC 违规 – 通用元件。该违规的级别(默认为 Fatal Error)由 Project Options 对话框(Project » Project Options)中 错误报告设置的与元件相关的违规部分决定。

选择已放置的通用元件,即可在 Properties 面板中访问其属性,其中仅提供与此类元件相关的设置和参数。可用参数由关联的元件模板决定(此处示例中为 Resistors)。参数值可以手动输入,也可以从下拉菜单列表中选择,列表中的值来自该类型的所有可用元件。

指定通用元件的参数 – 从下拉列表中选择参数值。

指定通用元件的参数 – 结果。

 

支持跳线元件

跳线 也称为跨接线,允许您使用跳线元件替代布线,这通常是成功设计单面板的关键要素。Altium Designer 通过特殊的元件类型 Jumper 支持使用跳线元件。

虽然您可以先将跳线封装直接放置到 PCB 上,但建议从原理图开始工作流程。要了解更多信息,请参阅使用跳线元件页面。

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents