Board-Insight-System
Altium Essentials: PCB Viewing and Navigation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Erfahren Sie, welche Board Insight-Funktionen Ihnen helfen, Objekte, Regelverletzungen und dicht belegte Designbereiche genauer zu untersuchen.
- Entdecken Sie, wie Anzeigeoptionen wie das Heads-up-Display, die dynamische Hervorhebung, die Steuerung der aktiven Lage und die Sichtbarkeit von Netznamen die tägliche Navigation im PCB-Design verbessern können.
- Lernen Sie, wie konfigurierbare Anzeigeeinstellungen – darunter die Darstellung gesperrter Objekte und 3D-Projektionsmodi – komplexe Leiterplattenlayouts leichter verständlich machen.
Board Insight ist ein konfigurierbares System von Funktionen, mit dem Sie die Anzeige und die Arbeit mit Ihrem PCB-Design vollständig steuern können. Eine komplexe mehrlagige Leiterplatte führt zu einem visuell dichten und oft schwer zu interpretierenden Designbereich. Das Board Insight-System von Altium Designer erleichtert es Ihnen, die Objekte in Ihrem Design zu betrachten und zu verstehen. Es besteht aus einer Reihe integrierter Funktionen, die speziell für Ihre Anforderungen an die Ansichtsverwaltung entwickelt wurden.
In Board Insight sind ein erweiterter Einzellagenmodus und Funktionen zur 3D-Visualisierung integriert. Im Einzellagenmodus können Sie deutlich erkennen, was sich auf einer bestimmten Lage befindet, und erhalten zugleich einen Überblick über die Inhalte anderer Lagen.
Für den flüchtigen Betrachter ist ein PCB-Design kaum verständlich und wirkt wie eine Ansammlung von Linien, Kreisen, Bögen und Zeichenfolgen in verschiedenen Farben, die sich ungeordnet überlagern. Selbst mit einem geschulten Auge kann es schwierig sein, die enorme Menge an Designdetails zu erfassen. Altium Designer bietet eine Reihe von Funktionen, mit denen Sie Designinhalte finden, identifizieren und deren Anzeige verwalten können. Zusammen bilden diese Funktionen das Board Insight-System.
Board Insight-Pop-up-Modus
Der Board Insight-Pop-up-Modus ist ein hervorragendes Werkzeug zum Anzeigen von Objekten unter dem Cursor. Drücken Sie Shift+X (Tools » Browse Objects), um detaillierte Informationen zu allen Bauteilen und Netzen unter dem Cursor sowie zu den zugehörigen Objekten, beispielsweise Pads und Leiterbahnen, anzuzeigen. Verwenden Sie Shift+V (Tools » Browse Violations), um Informationen zu Verstößen (gegen definierte Designregeln) anzuzeigen, die sich aktuell unter dem Cursor befinden. Außerdem wird eine grafische Darstellung des im Pop-up ausgewählten Objekts oder Verstoßes angezeigt. Die Liste ist hierarchisch aufgebaut, sodass Sie beispielsweise bis zu den vollständigen Details der Grundobjekte navigieren können, die einem bestimmten Verstoß zugeordnet sind. Sie können detaillierte Informationen zum Objekt/Verstoß anzeigen, es bzw. ihn auswählen oder darauf zoomen, indem Sie auf das Objekt/den Verstoß klicken, um ein Pop-up-Menü zu öffnen, oder die Symbole auf der rechten Seite verwenden. Folgende Optionen sind verfügbar:
-
Properties oder
– öffnet das Properties Panel für dieses Objekt oder den Dialog „Verstoßdetails“ für den Verstoß.
-
Select oder
– wählt das Objekt oder den Verstoß im Designbereich aus.
-
Zoom oder
– zoomt auf das Objekt/den Verstoß.
Pop-up mit visueller Auswahlliste
Das Pop-up mit visueller Auswahlliste erleichtert die Auswahl des richtigen Objekts in einem dicht belegten Designbereich. Ein mehrlagiges PCB-Design führt zu einem dichten und visuell überladenen Designbereich, in dem viele Objekte übereinanderliegen. Das Pop-up mit visueller Auswahlliste vereinfacht die Objektauswahl. Doppelklicken Sie, wenn sich mehrere Objekte unter dem Cursor befinden, um das Pop-up mit visueller Auswahlliste anzuzeigen. Wenn Sie die Maus durch die Liste bewegen, wird das jeweilige Objekt im Pop-up angezeigt, sodass es sich leicht identifizieren lässt. Die Objekte im Pop-up mit visueller Auswahlliste sind nach Lage sortiert.
Heads-up-Display
Das Heads-up-Display liefert Ihnen Echtzeitinformationen zu den Objekten, die sich aktuell unter dem Cursor im PCB-Designbereich befinden. Das Heads-up-Display ist konfigurierbar und kann die Cursorposition, Delta-Informationen (Abstand vom letzten Mausklick), die aktuelle Lage und das aktuelle Fangraster anzeigen. Neben den angezeigten Informationen lassen sich auch Schriftart und Farben konfigurieren. Das Heads-up-Display kann an einer beliebigen Stelle auf dem Bildschirm fixiert werden oder dem Cursor folgen.
Wenn Sie beim Bewegen des Cursors kurz innehalten, wechselt das Heads-up-Display zu Hover mode. In diesem Modus werden zusätzliche Informationen angezeigt, darunter eine Zusammenfassung, verfügbare Tastenkürzel, Regelverstöße sowie Details zu Netzen, Bauteilen und Grundobjekten.
Sie können das Heads-up-Display auf der Seite PCB-Editor – Board Insight-Modi des Preferences Dialogs konfigurieren.
Aktivieren Sie in der Spalte Heads Up der Tabelle die Eigenschaften, die im Heads-up-Display angezeigt werden sollen. Die Font Einstellungen für diese Optionen können ebenfalls in der Tabelle konfiguriert werden.
Mit den folgenden Befehlen des View » Board InsightMenüs (das auch durch Drücken von F2 im Designbereich aufgerufen werden kann) können Sie das Heads-up-Display konfigurieren:
- Toggle Heads Up Display (Shift+H) – schaltet das Heads-up-Display ein oder aus.
- Toggle Heads Up Tracking (Shift+G) – schaltet zwischen einer festen Position des Heads-up-Displays auf der Leiterplatte und einer Bewegung mit dem Cursor um. Das HUD springt nicht zum Cursor, sondern bewegt sich relativ zu der Position, an der sich der Cursor beim Aktivieren der Nachverfolgung befand. Es empfiehlt sich, den Cursor vor der Verwendung dieses Befehls relativ zur aktuellen HUD-Position zu platzieren.
-
Resets Heads Up Delta Origin (Ins) – setzt den Delta-Ursprung auf die aktuellen Mauskoordinaten zurück. Die horizontale und vertikale Entfernung, um die die Maus vom Delta-Ursprung aus bewegt wird, kann im Heads-up-Display angezeigt werden. Der Delta-Ursprung kann auch mit der linken Maustaste zurückgesetzt werden. Diese Einstellung lässt sich auf der PCB Editor - Board Insight ModesSeite des Preferences Dialogs konfigurieren.
- Toggle Heads Up Delta Origin (Shift+D) – schaltet die Anzeige der Delta-Ursprungskoordinaten um. Die Delta-Koordinaten zeigen die horizontale (dx) und vertikale (dy) Entfernung von den Delta OriginKoordinaten an – einem Punkt, den der Benutzer innerhalb des Designbereichs festlegen kann. Verwenden Sie die Delta-Koordinaten, um Abstände relativ zu einer Position auf Ihrer Leiterplatte zu bestimmen.
Live-Hervorhebung
Ein komplexes PCB-Design mit dichter Bauteilplatzierung, eng geführten Leiterbahnen und mehreren Signallagen zu verstehen, ist nicht einfach. Altium Designer bietet eine Reihe von Funktionen zur Netzhervorhebung, die Ihnen helfen, das Routing zu untersuchen.
Verwenden Sie den Live HighlightingBereich auf der Seite „PCB-Editor – Board Insight-Anzeige“ des Preferences Dialog, um diese Funktion zu konfigurieren.
Verwenden Sie Ctrl+Click , um ein beliebiges Netz auf der Leiterplatte hervorzuheben. Alle Elemente im Design, die nicht zu diesem Netz gehören, werden abgeblendet, sodass die Leiterbahnführung auf allen Signallagen deutlich hervortritt, wie im folgenden Bild gezeigt. Um mehrere Netze hervorzuheben, halten Sie die Taste Shift gedrückt, während Sie auf jedes Netz Ctrl+Click . Ctrl+Click Sie in einen freien Bereich, um die ursprüngliche Darstellung wiederherzustellen.
Die Netzhervorhebung lässt sich auch dynamisch nutzen: Wenn Sie den Cursor über ein Netz bewegen, wird es hervorgehoben. Bei dieser Methode werden die Umrisse hervorgehoben. Diese Hervorhebung ist konfigurierbar und beeinflusst die Darstellung der übrigen Leiterplatte nicht. Das folgende Bild zeigt ein Netz mit dynamischer Hervorhebung.
Das folgende Bild zeigt ein Beispiel für ein Netz, das mit Ctrl+Click hervorgehoben wird.
Steuerung der aktiven Lage
Der PCB-Editor ist eine Umgebung mit mehreren Lagen, von denen jeweils nur eine aktiv ist. Es gibt verschiedene Möglichkeiten, die aktuell aktive Lage zu ändern. Beachten Sie, dass die Auswahl der aktuellen Lage nur für den 2D-Ansichtsmodus gilt.
- Klicken Sie auf die Registerkarte Layer am unteren Rand des Designbereichs.
- Verwenden Sie die Dropdown-Liste Active Layer im Bereich Layers auf der Registerkarte Layers & Colors des Panels View Configuration.
-
Wechseln Sie mit den folgenden Tastenkombinationen zwischen den Lagen.
- Ctrl+Shift+Mouse wheel – nächste Lage/vorherige Lage
- + (Ziffernblock) – nächste Lage
- - (Ziffernblock) – vorherige Lage
- * (Ziffernblock) – nächste Signallage
Anzeige von Netznamen auf Leiterbahnen
Eine weitere praktische Funktion für effizienteres Arbeiten ist die Anzeige von Netznamen auf den Leiterbahnen (konfigurierbar auf der Registerkarte View Options im Bereich Additional Options des Panels View Configuration ). Um diese Funktion zu nutzen, aktivieren Sie die Option Repeated Net Names on Tracks im Bereich Additional Options. Unabhängig davon, wo Sie auf der Leiterplatte arbeiten, erkennen Sie sofort, ob die betrachtete Leiterbahnführung zu dem Netz gehört, das Sie interessiert.
Die Anzeige von Netznamen auf den Leiterbahnen erleichtert das „Lesen“ der Leiterbahnführung.
Anzeigeoptionen für Pad- und Via-Details
Sie können die Anzeige von Pad- und Via-Details im Bereich Pad and Via Display Options auf der Seite PCB-Editor – Board-Insight-Anzeige des Dialogs Preferences steuern. Für Pad- und Via-Informationen lassen sich Farbe, Hintergrund und Schriftart konfigurieren. Die Texte werden automatisch in lesbarer Orientierung dargestellt und so ausgerichtet, dass möglichst viel Platz für ihre Anzeige zur Verfügung steht. Die Option Use Smart Display Color wählt automatisch eine Schriftfarbe mit gutem Kontrast, damit der Text leicht lesbar ist.
Anzeigeoptionen für gesperrte Objekte
Sie können festlegen, wie gesperrte Objekte im Designbereich dargestellt werden, damit sie sich leichter visuell erkennen lassen. Verwenden Sie dazu die Bedienelemente im Bereich Show Locked Texture on Objects auf der Seite PCB-Editor – Board-Insight-Anzeige des Dialogs Preferences .
Beispiel mit aktivierter Option Only When Live Highlighting.
3D Board Insight
3D Board Insight bietet Projektionsmodi, mit denen die Leiterplatte entweder in Perspective oder Orthographic Projektion dargestellt wird. Verwenden Sie im 3D-Ansichtsmodus den Bereich Projection auf der Registerkarte View Options des Panels Ansichtskonfiguration , um den gewünschten Darstellungsmodus auszuwählen.
Wählen Sie Orthographic , um die genaue Position von Objekten und Text auf der Leiterplatte zu sehen, ohne dass diese durch umgebende Objekte verdeckt werden. Wählen Sie Perspective, um eine realistischere 3D-Ansicht der Leiterplatte zu erhalten.





