Arbeiten mit Direktiven in einem Schaltplan
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Erfahren Sie, was Design-Direktiven sind und wie sie bei der Schaltplanerfassung und Validierung eingesetzt werden.
- Lernen Sie, wann Sie No ERC und wann eine Compile-Maske verwenden sollten, um unerwünschte Validierungsmeldungen zu unterdrücken.
- Sehen Sie, wie Compile-Masken im Schaltplaneditor platziert, aktiviert, deaktiviert und bearbeitet werden.
Designanweisungen sind Objekte, die während der Schaltplanerfassung im Schaltplan platziert werden und mit denen sich Anweisungen festlegen lassen, die an andere Teile der Software weitergegeben werden. Verschiedene Designanweisungen stehen für die folgenden beiden Anwendungsbereiche zur Verfügung:
- Anweisungen im Zusammenhang mit der automatischen Kompilierung von Quellschaltplandokumenten.
- Anweisungen zur Weitergabe von Informationen, die auf einem Schaltplanblatt definiert sind, an die Leiterplatte.
In den folgenden Abschnitten werden diese Bereiche und die zugehörigen Anweisungen näher erläutert.
Anweisungen für die Kompilierung
Designs entwickeln sich im Laufe der Zeit weiter und werden schrittweise erfasst. Sobald ein Abschnitt ausreichend ausgearbeitet ist, möchte man ihn häufig unabhängig vom restlichen Design prüfen. Die Kompilierung eines einzelnen Schaltplandokuments (oder des gesamten Projekts) während der Erfassung führt oft zu einer Reihe von Fehlermeldungen, die durch noch nicht erfasste Schaltungsteile oder unvollständige Schnittstellenverdrahtungen zwischen Schaltungsfragmenten verursacht werden. Solche Meldungen haben keinen wirklichen Nutzen, da sie lediglich von den relevanten Informationen ablenken. Am schnellsten und einfachsten lassen sich diese Kompilierungsfehler durch das Platzieren von No ERC- oder Compile Mask-Anweisungen unterdrücken.
No ERC-Anweisung
Die No ERC-Anweisung wird an einem Knoten der Schaltung platziert, um alle gemeldeten Warnungen und/oder Fehler der elektrischen Regelprüfung zu unterdrücken, die bei der Validierung des Schaltplanprojekts erkannt werden. Weitere Informationen finden Sie auf der Seite Validieren Ihres Designprojekts.
Compile Mask-Anweisung
No ERC-Anweisungen eignen sich hervorragend zum Unterdrücken einer geringen Anzahl von Regelverletzungen an Pins, Ports, Schaltplanblatteingängen oder Netzen innerhalb eines Designs. In manchen Fällen ist es jedoch sinnvoll, einen ganzen Bereich des Designs einschließlich der Bauteile auszuschließen. Verwenden Sie eine Compile Mask-Anweisung (Befehl Place » Directives » Compile Mask) oder klicken Sie im Dropdown-Menü für Anweisungen auf der Active Bar auf die Schaltfläche „Compile Mask“ , um den darin enthaltenen Designbereich für den Compiler auszublenden. So können Sie die Fehlerprüfung für Schaltungsteile manuell verhindern, die möglicherweise noch nicht vollständig sind und von denen Sie wissen, dass sie Kompilierungsfehler verursachen werden. Dies ist besonders hilfreich, wenn Sie das aktive Dokument oder Projekt kompilieren müssen, um die Integrität des Designs in bestimmten anderen Bereichen zu prüfen, ohne durch Compiler-Meldungen zu unfertigen Designabschnitten abgelenkt zu werden.
Wie der Name bereits vermuten lässt, weist diese Anweisung den Compiler an, alle Objekte zu ignorieren, die completely innerhalb der Grenzen der definierten Maske liegen. Platzieren Sie die Maske genauso wie ein Notiz- oder Rechteckobjekt.
Betrachten Sie die Beispielschaltung in der folgenden Abbildung, bei der die Verdrahtung des Bauteils LCD1 noch nicht vollständig ist. Wenn nur dieser Schaltplan kompiliert wird (Project » Validate PCB Project), führt dies zu zahlreichen Meldungen über Regelverletzungen (siehe unten), die jeweils durch die unvollständige Schaltung verursacht werden. Bewegen Sie den Mauszeiger über das Bild, um zu sehen, wie sich das Platzieren einer Compile Mask-Anweisung um die unvollständige Schaltung auswirkt. Diese Regelverletzungen werden vom Compiler ignoriert, während der restliche, vollständig verdrahtete Teil der Schaltung auf dem Schaltplan geprüft wird. Beachten Sie, dass tatsächlich maskierte Objekte – also solche, die vollständig innerhalb des Begrenzungsrechtecks der Maske liegen – ausgegraut dargestellt werden.

Bewegen Sie den Mauszeiger über das Bild, um zu sehen, wie eine Compile Mask-Anweisung Compiler-Meldungen zu Regelverletzungen aufgrund unvollständiger Schaltungen ausblendet.
Kompilierungsmaske
Eine platzierte Kompilierungsmaske auf der linken Seite des oben gezeigten Schaltplans.
Zusammenfassung
Eine Kompilierungsmaske ist eine Designanweisung, mit der der darin enthaltene Designbereich bei der Validierung mit dem Befehl Project » Validate Project für den Compiler ausgeblendet wird. Sie ermöglicht es, die Fehlerprüfung für Schaltungsteile manuell zu verhindern, die möglicherweise noch unvollständig sind und Validierungsfehler verursachen werden. Die Kompilierungsmaske ist hilfreich, wenn das aktuelle Projekt validiert werden muss, um die Integrität des Designs in bestimmten anderen Bereichen zu prüfen, die Vielzahl der vom Compiler erzeugten Meldungen zu unfertigen Designabschnitten jedoch nicht erwünscht ist.
Verfügbarkeit
Kompilierungsmasken können nur im Schaltplaneditor platziert werden. So platzieren Sie eine Kompilierungsmaske:
- Klicken Sie in den Hauptmenüs auf den Befehl Place » Directives » Compile Mask .
- Klicken Sie im Dropdown-Menü für Anweisungen auf der Active Bar oben im Designbereich auf die Schaltfläche „Compile Mask“ Klicken Sie auf eine Schaltfläche Active Bar und halten Sie die Maustaste gedrückt, um auf weitere zugehörige Befehle zuzugreifen. Sobald ein Befehl verwendet wurde, wird er zum obersten Eintrag in diesem Abschnitt der Active Bar.
- Klicken Sie mit der rechten Maustaste in den Schaltplaneditor und anschließend auf Place » Directives » Compile Mask.
Platzierung
Nach dem Aufrufen des Befehls wird der Mauszeiger zu einem Fadenkreuz und zeigt damit den Platzierungsmodus für Kompilierungsmasken an. Die Platzierung erfolgt in diesen Schritten:
- Positionieren Sie den Mauszeiger und klicken Sie oder drücken Sie Enter, um die erste Ecke der Maske festzulegen.
- Bewegen Sie den Mauszeiger, um die Größe der Maske so anzupassen, dass sie den Designbereich, der für den Compiler ausgeblendet werden soll, vollständig umschließt. Klicken Sie anschließend oder drücken Sie Enter , um die diagonal gegenüberliegende Ecke festzulegen und die Platzierung der Maske abzuschließen. Designobjekte, die vollständig innerhalb der Maskengrenzen liegen, werden ausgegraut.
- Platzieren Sie weitere Kompilierungsmasken oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Platzierungsmodus zu verlassen.
Grafische Bearbeitung
Bei dieser Bearbeitungsmethode können Sie eine platzierte Kompilierungsmaske direkt im Designbereich auswählen und ihre Größe, Form oder Position grafisch ändern.
Eine Kompilierungsmaske kann entweder aktiv (vollständiger Rahmen) oder eingeklappt (eingerahmtes Dreieck) angezeigt werden. Diese Modi entsprechen einer aktivierten bzw. deaktivierten Maske. Klicken Sie auf das Symbol ▲ oder ▼ in der oberen linken Ecke einer platzierten Kompilierungsmaske, um den Anzeigemodus umzuschalten.
Klicken Sie auf das Dreieck in der oberen linken Ecke, um eine Kompilierungsmaske einzuklappen und damit zu deaktivieren.
Wenn eine aktive (ausgeklappte) Kompilierungsmaske ausgewählt ist, stehen die folgenden Bearbeitungsgriffe zur Verfügung:
Eine ausgewählte Kompilierungsmaske im aktiven Zustand.
- Klicken und ziehen Sie A, um die Größe der Kompilierungsmaske gleichzeitig in vertikaler und horizontaler Richtung zu ändern.
- Klicken und ziehen Sie B, um die Größe der Kompilierungsmaske in vertikaler und horizontaler Richtung getrennt zu ändern.
- Klicken Sie an einer beliebigen Stelle auf die Kompilierungsmaske – außerhalb der Bearbeitungsgriffe – und ziehen Sie sie an eine neue Position. Während des Ziehens kann die Kompilierungsmaske gedreht (Spacebar/Shift+Spacebar) oder gespiegelt werden (mit den Tasten X bzw. Y zum Spiegeln an der X- bzw. Y-Achse).
Nichtgrafische Bearbeitung
Die folgenden Methoden zur nichtgrafischen Bearbeitung stehen zur Verfügung.
Bearbeitung über den Dialog „Compile Mask“ oder das Panel „Properties“
Panel page: Eigenschaften der Kompilierungsmaske
Bei dieser Bearbeitungsmethode werden der zugehörige Dialog Compile Mask und der Modus Properties des Panels verwendet, um die Eigenschaften einer Kompilierungsmaske zu ändern.
Nach der Platzierung können Sie den Dialog Compile Mask folgendermaßen aufrufen:
- Doppelklicken Sie auf die platzierte Kompilierungsmaske.
- Wählen Sie die Kompilierungsmaske aus, klicken Sie mit der rechten Maustaste darauf und wählen Sie anschließend Properties aus dem Kontextmenü.
Während der Platzierung können Sie den Modus „Compile Mask“ des Panels Properties durch Drücken der Taste Tab aufrufen. Sobald die Kompilierungsmaske platziert ist, werden alle Optionen angezeigt.
Nach der Platzierung können Sie den Modus „Compile Mask“ des Panels Properties auf eine der folgenden Arten aufrufen:
- Wenn das Panel Properties bereits aktiv ist, wählen Sie die Kompilierungsmaske aus.
- Wählen Sie nach der Auswahl der Kompilierungsmaske das Panel Properties über die Schaltfläche Panels unten rechts im Designbereich oder durch Auswahl von View » Panels » Properties im Hauptmenü aus.
Bearbeiten mehrerer Objekte
Das Panel Properties unterstützt die Bearbeitung mehrerer Objekte, wobei Eigenschaftseinstellungen geändert werden können, die bei allen aktuell ausgewählten Objekten identisch sind. Wenn mehrere Objekte desselben Typs manuell, über den Dialog Ähnliche Objekte suchen oder über ein Panel Filter oder List ausgewählt werden, kann ein Feldeintrag im Panel Properties, der nicht als Sternchen (*) angezeigt wird, für alle ausgewählten Objekte bearbeitet werden.
Bearbeitung über ein List-Panel
Panel pages: List-Panels, SCH Filter
Ein List Panel zeigt Designobjekttypen aus einem oder mehreren Dokumenten in Tabellenform an und ermöglicht so eine schnelle Prüfung und Änderung von Objektattributen. In Verbindung mit einer geeigneten Filterung – durch Auswahl von Objekttypen (über die Optionen Include des Panels) oder über das entsprechende Panel Filter bzw. den Dialog Ähnliche Objekte suchen – können gezielt nur die Objekte angezeigt werden, die in den Geltungsbereich des aktiven Filters fallen. Die Eigenschaften der aufgelisteten Objekte können anschließend direkt im Panel List bearbeitet werden.
Eigenschaften der Kompilierungsmaske
Objekteigenschaften im Schaltplaneditor sind konfigurierbare Optionen, die das Erscheinungsbild, den Inhalt und das Verhalten des platzierten Objekts festlegen. Die Eigenschaftseinstellungen für jeden Objekttyp werden wie folgt definiert:
- Post-placement settings – alle Eigenschaften von Kompilierungsmasken können im Dialog Compile Mask und im Panel Properties bearbeitet werden, wenn eine platzierte Kompilierungsmaske im Designbereich ausgewählt ist.
Position
-
(X/Y)
- X (erstes Feld) – die aktuelle X-Koordinate (horizontal) des Referenzpunkts des Objekts relativ zum aktuellen Ursprung des Designbereichs. Bearbeiten Sie diesen Wert, um die X-Position des Objekts zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht.
- Y (zweites Feld) – die aktuelle Y-Koordinate (vertikal) des Referenzpunkts des Objekts relativ zum aktuellen Ursprung. Bearbeiten Sie diesen Wert, um die Y-Position des Objekts zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht.
Eigenschaften
- Width – geben Sie die Breite des Objekts ein.
- Height – geben Sie die Höhe des Objekts ein.
- Border – wählen Sie den gewünschten Rahmen aus der Dropdown-Liste aus.
- Fill Color – klicken Sie auf das Farbfeld, um die gewünschte Farbe für das Objekt auszuwählen.
- Collapsed and Disabled – aktivieren Sie das Kontrollkästchen, um das Objekt einzuklappen und zu deaktivieren.
Leiterplattenbezogene Direktiven
Als einheitliche Designumgebung bietet Altium Designer die Möglichkeit, Leiterplattenanforderungen bereits vor dem Leiterplattenlayout festzulegen. Dazu werden Parameter zu Objekten auf den Schaltplanblättern hinzugefügt und entsprechend definiert.
Bei bestimmten Schaltplanobjekten – etwa Bauteilen, Blattsymbolen, Ports usw. – werden die entsprechenden Parameter als Teil der Objekteigenschaften hinzugefügt. Bei Netzobjekten wie Leitungen und Bussen können Parameter nicht direkt als Eigenschaft der Leitung oder des Busses hinzugefügt werden. Stattdessen werden die zur Aufnahme der Informationen erforderlichen Parameter mithilfe spezieller Designdirektiven festgelegt.
Die folgenden Informationen können mithilfe von Direktiven festgelegt werden und werden bei der Designsynchronisierung in die entsprechenden leiterplattenbezogenen Definitionen übertragen:
- Vorgaben für das Leiterplattenlayout
- Differenzielle Paare
- Netzklassen
Durch das Einbinden von Design-Direktiven in den Schaltplan können Entwicklungsingenieure explizite Designvorgaben festlegen und sicherstellen, dass der Schaltplan die maßgebliche Dokumentation des Designs bleibt. Änderungen am Design werden ausschließlich im Schaltplan vorgenommen und anschließend auf die Leiterplatte übertragen. Dies kann besonders wichtig sein, wenn mehrere Personen an einem Design arbeiten – insbesondere, wenn sie sich an unterschiedlichen Standorten befinden. Statt sich über lange E-Mail-Verläufe oder Telefonate abzustimmen, kann die für die Schaltplanerfassung zuständige Person sicherstellen, dass bestimmte Vorgaben während der Layoutphase tatsächlich berücksichtigt werden.
Das Herzstück dieser Funktionalität ist die Parametersatz-Direktive.
Dabei handelt es sich im Wesentlichen um benutzerdefinierte Parametersatz-Objekte, die einem Netzobjekt innerhalb eines Schaltplandesigns zugeordnet werden können. Platzieren Sie eine PCB-Layout-Direktive auf einer Leitung, einem Bus oder einem Signal-Harness, um eine oder mehrere Designvorgaben für die zugehörigen Netze festzulegen. Wenn aus dem Schaltplan eine Leiterplatte erstellt wird, werden die Informationen in der PCB-Layout-Direktive verwendet, um entsprechende PCB-Designregeln zu erstellen. Die durch eine PCB-Layout-Direktive festgelegten Informationen gelten nur für das Netz bzw. die Gruppe von Netzen, mit denen die Direktive verbunden ist.
Sie dient als Container für eine beliebige Anzahl von Parametern, die für das Netz gelten, mit dem die Parametersatz-Direktive verbunden ist. Eine standardmäßige Parametersatz-Direktive ohne Parameter kann platziert werden (Place » Directives » Parameter Set), und die entsprechenden Parameter können später hinzugefügt werden. In den folgenden Abschnitten wird die Verwendung dieser parameterbasierten Direktiven näher erläutert. Es stehen sowohl benutzerdefinierte (Parametersatz) als auch vordefinierte (Differenzpaar) Parametersatz-Direktiven zur Verfügung. Der einzige Unterschied zwischen einem leeren und einem vordefinierten Parametersatz besteht darin, dass die vordefinierten Parametersätze einen Parameter enthalten, wie nachfolgend beschrieben.
Parametersatz
Zusammenfassung
Ein Parametersatz ist eine Design-Direktive, mit der Designspezifikationen einem Objekt vom Typ Netz innerhalb eines Schaltplandesigns zugeordnet werden können. Verwenden Sie beispielsweise einen Parametersatz, um zwei Netze als Mitglieder eines Differenzpaars zu deklarieren. Anhand bestimmter Parameternamen im Parametersatz erkennt die Software, welche Design-Direktive Sie platzieren.
Verfügbarkeit
Parametersätze können nur im Schaltplan-Editor platziert werden. Es stehen sowohl standardmäßige (leere) als auch vordefinierte (Differenzpaar) Parametersatz-Direktiven zur Verfügung. Der einzige Unterschied zwischen einem leeren und einem vordefinierten Parametersatz besteht darin, dass die vordefinierten Parametersätze einen Parameter enthalten, wie nachfolgend beschrieben.
Die entsprechenden Befehle sind über das Hauptmenü Place wie folgt zugänglich:
| • | Place » Directives » Parameter Set | |
| • | Place » Directives » Differential Pair | |
Platzierung
Mit einem Parametersatz können Parameter an folgende Objekte angehängt werden:
- Leitung
- Bus
- Signal-Harness
- Schaltblattsymbol
Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz, und Sie befinden sich im Platzierungsmodus für Design-Direktiven. Gehen Sie zum Platzieren wie folgt vor:
- Positionieren Sie den Cursor über einer Leitung oder einem anderen Netzobjekt und klicken Sie oder drücken Sie Enter, um die Direktive zu platzieren.
- Platzieren Sie weitere Direktiven oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Platzierungsmodus zu beenden.
Während der Platzierung – solange der Parametersatz noch am Cursor hängt – können Sie außerdem folgende Aktionen ausführen:
-
Drücken Sie die Taste Tab, um die Platzierung zu unterbrechen und den Parametersatz-Modus des Panels Properties aufzurufen. Dort können Sie die Eigenschaften direkt ändern. Klicken Sie auf die im Arbeitsbereich eingeblendete Pause-Schaltfläche , um die Platzierung fortzusetzen.
-
Drücken Sie die Taste Alt, um die Bewegungsrichtung je nach anfänglicher Bewegungsrichtung auf die horizontale oder vertikale Achse zu beschränken.
-
Drücken Sie Spacebar, um den Bogen gegen den Uhrzeigersinn zu drehen, oder Shift+Spacebar, um ihn im Uhrzeigersinn zu drehen. Diese Aktion kann auch beim Ziehen des Objekts ausgeführt werden. Die Drehung erfolgt in 90°-Schritten.
-
Drücken Sie im Platzierungsmodus die Tasten X oder Y, um den Parametersatz an der X- bzw. Y-Achse zu spiegeln.
Grafische Bearbeitung
Bei dieser Bearbeitungsmethode können Sie eine platzierte Parametersatz-Direktive direkt im Arbeitsbereich auswählen und ihre Position oder Ausrichtung grafisch ändern.
Wenn eine Parametersatz-Direktive im Arbeitsbereich ausgewählt ist, wird sie von einem gestrichelten Rahmen umgeben. Dieser Rahmen umfasst nur den von der Direktive belegten Bereich. Für jeden auf sichtbar eingestellten Parameter des Satzes wird eine gestrichelte Linie angezeigt, die das Textfeld des Parameters mit dem Körper der Direktive verbindet und so die Zuordnung verdeutlicht:
Klicken Sie auf eine beliebige Stelle innerhalb des gestrichelten Rahmens und ziehen Sie den Parametersatz an die gewünschte Position. Während des Ziehens kann der Parametersatz gedreht (Spacebar/Shift+Spacebar) oder gespiegelt werden (X oder Y zum Spiegeln entlang der X- bzw. Y-Achse).
Die Größe der Textfelder des Parametersatzes (die unabhängig von der übergeordneten Direktive grafisch bearbeitet werden können) lässt sich nur durch Ändern der Option Style auf der Seite Schaltplan – Standardeinstellungen des Dialogs Preferences anpassen. Daher werden bei Auswahl dieser Objekte keine Bearbeitungsgriffe angezeigt.
Klicken Sie auf eine beliebige Stelle innerhalb des gestrichelten Rahmens und ziehen Sie das Textobjekt an die gewünschte Position. Während des Ziehens kann das Textobjekt gedreht (Spacebar/Shift+Spacebar) oder gespiegelt werden (X oder Y zum Spiegeln entlang der X- bzw. Y-Achse).
Wenn die Option Enable In-Place Editing auf der Seite Schaltplan – Allgemein des Dialogs Preferences aktiviert ist, können Sie den Wert eines Parameters direkt im Arbeitsbereich bearbeiten (mit Ausnahme von Parametern, die als Regeln hinzugefügt wurden). Wählen Sie das Textobjekt aus und klicken Sie anschließend einmal darauf, um die Funktion aufzurufen. Geben Sie den gewünschten neuen Wert ein und klicken Sie anschließend außerhalb des Textobjekts oder drücken Sie Enter, um die Änderung zu übernehmen.
Nichtgrafische Bearbeitung
Die folgenden Methoden zur nichtgrafischen Bearbeitung stehen zur Verfügung.
Bearbeitung über den Dialog „Parametersatz“ oder das Panel „Eigenschaften“
Panel page: Parametersatzeigenschaften
Bei dieser Bearbeitungsmethode werden der zugehörige Dialog Parameter Set und der Modus Properties des Panels verwendet, um die Eigenschaften eines Parametersatzobjekts zu ändern.

Der Dialog Parameter Set im ersten Bild und der Modus Parameter Set des Panels „Eigenschaften“ im zweiten Bild
Nach der Platzierung können Sie den Dialog Parameter Set wie folgt öffnen:
- Doppelklicken Sie auf das platzierte Parametersatzobjekt.
- Positionieren Sie den Cursor über dem Parametersatzobjekt, klicken Sie mit der rechten Maustaste und wählen Sie anschließend Properties aus dem Kontextmenü.
Während der Platzierung können Sie den Modus Parameter Set des Panels Properties durch Drücken der Taste Tab aufrufen. Sobald der Parametersatz platziert ist, werden alle Optionen angezeigt.
Nach der Platzierung können Sie den Modus Parameter Set des Panels Properties auf eine der folgenden Arten aufrufen:
- Wenn das Panel Properties bereits aktiv ist, wählen Sie das Parametersatzobjekt aus.
- Wählen Sie nach der Auswahl des Parametersatzobjekts das Panel Properties über die Schaltfläche Panels unten rechts im Arbeitsbereich aus oder wählen Sie View » Panels » Properties im Hauptmenü.
Bearbeiten mehrerer Objekte
Das Panel Properties unterstützt die Bearbeitung mehrerer Objekte. Dabei können Eigenschaftseinstellungen geändert werden, die bei allen aktuell ausgewählten Objekten identisch sind. Wenn mehrere Objekte desselben Typs manuell, über den Dialog Ähnliche Objekte suchen oder über ein Filter- oder Listen-Panel ausgewählt werden, kann ein Feldeintrag im Panel Properties, der nicht als Sternchen (*) angezeigt wird, für alle ausgewählten Objekte bearbeitet werden.
Bearbeitung über ein Listen-Panel
Panel pages: Listen-Panels, SCH-Filter
Mit einem Panel List können Sie Designobjekte aus einem oder mehreren Dokumenten in Tabellenform anzeigen und so Objektattribute schnell prüfen und ändern. In Verbindung mit einer geeigneten Filterung – über das entsprechende Panel Filter oder den Dialog Ähnliche Objekte suchen – lassen sich ausschließlich die Objekte anzeigen, die in den Geltungsbereich des aktiven Filters fallen. So können Sie mehrere Designobjekte gezielter und effizienter bearbeiten.
Hinweise
- Beim Platzieren einer standardmäßigen Parametersatzdirektive sind noch keine Parameter vorhanden. Fügen Sie nach der Platzierung die relevanten Parameter über den Abschnitt Parameters des Panels Properties hinzu.
- Mit einer Parametersatzdirektive können Sie einem Netz im Schaltplan Informationen zum Leiterplattenlayout zuweisen. Wenn aus dem Schaltplan eine Leiterplatte erstellt wird, werden die Informationen im Parametersatz verwendet, um entsprechende Leiterplatten-Designregeln zu erstellen. Die durch eine Parametersatzdirektive festgelegten Informationen gelten nur für die Netze, mit denen sie verbunden ist.
- Wenn einem Netz eine Parametersatzdirektive hinzugefügt wird, stehen die Felder Power Net und High Speed im Panel Properties des Netzes zur Verfügung. Beim Aktualisieren des Leiterplattendokuments anhand der Schaltpläne wird vorgeschlagen, die Designregel für Versorgungsnetze jedem Netz hinzuzufügen, bei dem der Parameter Power Net aktiviert ist.
- Mit Netzklassendirektiven können Sie benutzerdefinierte Netzklassen im Schaltplan erstellen. Wenn aus dem Schaltplan eine Leiterplatte erstellt wird, werden die Informationen in einer Netzklassendirektive verwendet, um die entsprechende Netzklasse auf der Leiterplatte zu erstellen. Um ein Netz einer Netzklasse zuzuordnen, fügen Sie der betreffenden Leitung oder dem betreffenden Bus eine Parametersatzdirektive hinzu und ergänzen Sie eine Klasse mit dem Namen der gewünschten Klasse. Die Option Generate Net Classes (für benutzerdefinierte Klassen) muss auf der Registerkarte Class Generation des Dialogs Projektoptionen aktiviert sein, um diese Funktion zu nutzen.
- Wenn für ein Netz eine Netzklassen-Direktive definiert wurde, erhalten alle PCB-Designregeln, die ebenfalls durch dieses Parametersatzobjekt erstellt werden, beim Übertragen des Designs in den PCB-Editor den Geltungsbereich „Netzklasse“.
- Eine Netzklassen-Direktive kann aus Ihrer platzierten Parametersatz-Direktive erstellt werden, indem Sie eine Klasse hinzufügen, deren Wert auf die gewünschte PCB-Netzklasse gesetzt werden muss.
-
Ein Blanket kann in Verbindung mit einer Parametersatz-Direktive auch verwendet werden, um Bauteilklassen und Parameter auf Bauteile anzuwenden, die vollständig innerhalb des durch das Blanket definierten Bereichs liegen. Verwenden Sie dazu die Optionen Component Class und Parameter im Dropdown-Menü der Schaltfläche Add in den Eigenschaften der mit dem Blanket verknüpften Parametersatz-Direktive. Die Informationen zu Bauteilklasse und Parameter werden beim Aktualisieren der Leiterplatte im Rahmen des ECO-Prozesses in das PCB-Dokument des Projekts übertragen.
Eigenschaften des Parametersatzes
Objekteigenschaften im Schaltplaneditor sind konfigurierbare Optionen, die das Erscheinungsbild, den Inhalt und das Verhalten des platzierten Objekts festlegen.
Die Eigenschaftseinstellungen für jeden Objekttyp werden auf zwei unterschiedliche Arten definiert:
-
Pre-placement settings – die meisten Eigenschaften von Parametersatz-Objekten sowie diejenigen, die sich sinnvoll vordefinieren lassen, stehen als bearbeitbare Standardeinstellungen auf der Seite Schematic – Defaults des Dialogs Preferences zur Verfügung (aufrufbar über die Schaltfläche
oben rechts im Arbeitsbereich). Wählen Sie das Objekt im Primitive List aus, um dessen Optionen auf der rechten Seite anzuzeigen.
-
Post-placement settings – alle Eigenschaften von Parametersatz-Objekten können in den Dialogen Parameter Set und im Panel Properties bearbeitet werden, wenn ein Parametersatz im Arbeitsbereich ausgewählt ist.
Position
-
(X/Y)
- X (erstes Feld) – die aktuelle X-Koordinate (horizontal) des Bezugspunkts des Objekts relativ zum aktuellen Ursprung des Arbeitsbereichs. Bearbeiten Sie diesen Wert, um die X-Position des Objekts zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht.
- Y (zweites Feld) – die aktuelle Y-Koordinate (vertikal) des Bezugspunkts des Objekts relativ zum aktuellen Ursprung. Bearbeiten Sie diesen Wert, um die Y-Position des Objekts zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht.
- Rotation – wählen Sie den Drehwinkel über die Dropdown-Liste aus.
Eigenschaften
- Label – die Beschriftung des Parametersatzes. Bearbeiten Sie diese bei Bedarf.
- Style – wählen Sie den Stil über die Dropdown-Liste aus. Klicken Sie auf das Farbfeld, um eine Dropdown-Auswahl zu öffnen, in der Sie die Standardfarbe auswählen können.
Parameter
- Grid – listet Name und Value der Parameter auf, die dem aktuell ausgewählten Parameter zugeordnet sind. Nach dem Hinzufügen können die Felder Name und Value bearbeitet werden. Der Value kann benannt werden, indem Sie auf das Feld klicken und den gewünschten Text eingeben. Das Feld Name kann nur im Panelmodus Properties des Parametersatzobjekts mithilfe von Ctrl+Click geändert werden. Dadurch wird der Modus Parameter des Panels Properties geöffnet, in dem Sie den gewünschten Namen im Feld Name eingeben können. Verwenden Sie das Schlosssymbol , um einen aufgelisteten Parameter zu sperren bzw. zu entsperren. Verwenden Sie das Augensymbol, um den Parameter ein- bzw. auszublenden. Durch Umschalten der Schaltfläche All und der einzelnen Parameterschaltflächen können in diesem Bereich alle, einzelne oder keine Parameter angezeigt werden. Die Parameter sind deaktiviert, wenn die jeweiligen Schaltflächen grau sind, und aktiviert, wenn sie blau sind.
-
Add – verwenden Sie die Dropdown-Liste, um einen Klassentyp hinzuzufügen:
-
Net Class – wählen Sie diese Option, um eine neue Netzklasse hinzuzufügen.
- Component Class – wählen Sie diese Option, um eine neue Bauteilklasse hinzuzufügen. Diese Option ist nur in der Parametersatz-Ansicht des Dialogs Parameter Set oder des Panels Properties verfügbar.
-
Diff. Pair Net Class – wählen Sie diese Option, um eine neue Differenzpaar-Netzklasse hinzuzufügen. Diese Option ist nur in der Differenzpaar-Ansicht des Dialogs Parameter Set oder des Panels Properties verfügbar.
-
Parameter – wählen Sie diese Option, um einen neuen Parameter hinzuzufügen.
-
Rule – klicken Sie hier, um den Dialog Select Design Rule Type zu öffnen, in dem Sie den Typ einer neuen Regel auswählen können. Nachdem Sie einen Regeltyp ausgewählt und auf
geklickt haben, wird der Dialog Edit PCB Rule (From Schematic) geöffnet, in dem Sie die neue Regel bei Bedarf bearbeiten können.
-
Klicken Sie auf das Stiftsymbol , um den Dialog Edit PCB Rule (From Schematic) zum Bearbeiten des ausgewählten Eintrags zu öffnen. Klicken Sie auf
, um den ausgewählten Eintrag zu löschen.
- Font Settings – klicken Sie auf die angezeigte Schriftart, um die Schriftformatierung zu ändern. Diese Option ist erst verfügbar, nachdem eine Netzklasse, eine Differenzpaar-Netzklasse, ein Parameter oder eine Regel hinzugefügt wurde.
-
Other – wenn eine Netzklasse, eine Differenzpaar-Netzklasse, ein Parameter oder eine Regel hinzugefügt wurde, klicken Sie hier, um ein Dropdown-Menü zum Ändern weiterer Optionen zu öffnen:
- Show Parameter Name – aktivieren, um den Parameternamen anzuzeigen.
- Allow Synchronization with Database – aktivieren, um mit der Datenbank zu synchronisieren.
- X/Y – die X- und Y-Koordinaten eingeben.
- Rotation – die Drehung über die Dropdown-Liste auswählen.
- Autoposition – aktivieren, um die automatische Positionierung einzuschalten.
Parametersatz-Direktiven platzieren
Platzieren Sie eine Direktive dieses Typs, indem Sie den Befehl Place » Directives » Parameter Set im Hauptmenü oder im Kontextmenü des Designbereichs auswählen. Beim Platzieren einer standardmäßigen Parametersatz-Direktive sind noch keine Parameter vorhanden. Ein Parametersatz ist eine Design-Direktive, mit der sich Designvorgaben einem netzartigen Objekt innerhalb eines Schaltplandesigns zuordnen lassen. Verwenden Sie beispielsweise einen Parametersatz, um zwei Netze als Mitglieder eines differenziellen Paars zu deklarieren. Anhand bestimmter benannter Parameter im Parametersatz erkennt die Software, welche Design-Direktive Sie platzieren.
Neben benutzerdefinierten Parameter-Direktiven lässt sich eine regelbasierte Parameter-Direktive im Dialogfeld Choose Design Rule Type definieren, das über den zugehörigen Modus des Panels Properties für den Parameter zugänglich ist. Gehen Sie dazu wie folgt vor:
-
Drücken Sie vor dem Platzieren des Parametersatzes
Taboder doppelklicken Sie auf eine bereits platzierte Parametersatz-Direktive, um deren Eigenschaften im Panel Properties anzuzeigen. -
Klicken Sie anschließend im Bereich Parameters des Panels Properties auf die Schaltfläche
und wählen Sie in der Dropdown-Liste Rule, um im Dialogfeld Select Design Rule Type eine Regel auszuwählen.

Den Wert einer Regel bearbeiten.
Wählen Sie im Dialogfeld Select Design Rule Type den Regeltyp aus, den Sie der Direktive als Regelparameter hinzufügen möchten. Durch Doppelklicken auf einen Regeltyp öffnen Sie das entsprechende Dialogfeld Edit PCB Rule (From Schematic), in dem Sie die Randbedingungen für die Regel festlegen können.

Randbedingungen für eine ausgewählte Regel festlegen.
Der Eintrag im Bereich Parameters enthält den ausgewählten Regeltyp sowie die festgelegten Randbedingungen. Die folgende Abbildung zeigt die definierten Parameter der Breitenregel für eine Parameter Set-Direktive. Um die Regel im Designbereich anzuzeigen, klicken Sie im Bereich Rules auf das Sichtbarkeitssymbol

Mehrere durch eine Parametersatz-Direktive definierte Regelvorgaben für ein bestimmtes Netz.
Wenn das Design im Rahmen der Synchronisierung auf die Leiterplatte übertragen wird, werden die entsprechenden Designregeln anhand der in einer Direktive enthaltenen Informationen erstellt. Das Wort Schematic wird im Namen jeder generierten Regel verwendet, um die Herkunft der Regel kenntlich zu machen.

Generierte Designregeln auf der PCB-Seite.
Netzklassen-Direktiven platzieren
Mit einer Netzklassen-Direktive können Sie benutzerdefinierte Netzklassen im Schaltplan erstellen. Sie können eine Netzklassen-Direktive platzieren, indem Sie den Befehl Place » Directives » Parameter Set in den Hauptmenüs auswählen und anschließend den Parametersatz als Netzklassen-Direktive definieren, wie in Tipp Nr. 2 auf der Seite zum Befehl beschrieben. Wenn aus dem Schaltplan eine Leiterplatte erstellt wird, werden die Informationen in einer Netzklassen-Direktive verwendet, um die entsprechende Netzklasse auf der Leiterplatte zu erstellen. Um ein Netz einer Netzklasse zuzuordnen, hängen Sie eine Netzklassen-Direktive an die entsprechende Verbindung, den Bus oder den Signal-Harness an und setzen Sie den Parameter ClassName der Direktive auf den Namen der gewünschten Klasse. Die Option Generate Net Classes (für benutzerdefinierte Klassen) muss auf der Registerkarte „Class Generation“ im Dialogfeld „Project Options“ aktiviert sein, um diese Funktion nutzen zu können.
Wenn für ein Netz eine Netzklassen-Direktive definiert wurde, erhalten alle PCB-Designregeln, die ebenfalls von diesem Parametersatz-Objekt erstellt werden, beim Übertragen des Designs in den PCB-Editor den Geltungsbereich „Netzklasse“. Sie können aus einer platzierten Parametersatz-Direktive eine Netzklassen-Direktive erstellen, indem Sie eine Klasse hinzufügen, deren Wert auf die gewünschte PCB-Netzklasse gesetzt werden muss.
Wichtige Anforderungen an die Projektoptionen
Damit im Schaltplan definierte Parametersätze auf die Leiterplatte übertragen werden, müssen im Dialogfeld Options for PCB Project die folgenden Optionen eingestellt werden:
- Aktivieren Sie die Option Generate Net Classes im Bereich User-Defined Classes auf der Registerkarte „Class Generation“ des Dialogfelds.
-
Setzen Sie auf der Registerkarte „Comparator“ des Dialogfelds den Prüfmodus Differences Associated with Nets » Extra Net Classes auf
Find Differences.

Um Parametersatz-Direktiven auf die Leiterplatte zu übertragen, müssen zwei Projektoptionen konfiguriert werden. Aktivieren Sie zunächst die Option Generate Net Classes auf der Registerkarte Class Generation. Bewegen Sie den Mauszeiger über die Abbildung, um die Registerkarte Comparator anzuzeigen. Dort müssen Sie die Option Extra Net Classes auf Find Differences setzen.
Wenn das Design im Rahmen der Synchronisierung auf die Leiterplatte übertragen wird, werden die entsprechenden Netzklassen anhand der in einer Direktive enthaltenen Informationen erstellt.
Blanket-Direktiven platzieren
Parameter-Set-Direktiven können nur auf das jeweilige Netz angewendet werden, mit dem sie verbunden sind. In Kombination mit einer Blanket-Direktive lässt sich ihr Geltungsbereich jedoch auf alle Netze innerhalb des Blankets erweitern.
Platzieren Sie eine Direktive dieses Typs, indem Sie in den Hauptmenüs den Befehl Place » Directives » Blanket wählen. Beim Platzieren eines Blankets können Sie entweder eine einfache rechteckige oder eine polygonale Form definieren. Letztere ermöglicht eine präzisere Kontrolle darüber, welche Netzobjekte auf einem Schaltplanblatt erfasst werden.
Das Blanket kennzeichnet die betreffenden Netze – platzieren Sie eine Parameter Set-Direktive an einer beliebigen Stelle am Rand des Blankets, um Designanforderungen auf diese Netze anzuwenden. Damit die am Rand platzierte Direktive auf ein Netz unter einer Blanket-Direktive angewendet wird, muss ein mit diesem Netz verknüpftes Objekt – ein Pin, ein Port, ein Netzlabel, ein Versorgungsanschluss oder ein Leitungs-/Bus-/Harness-Segment (einschließlich beider Enden) – innerhalb der Grenzen des Blankets liegen. Beachten Sie, dass bei Netzkennungen wie Netzlabels der Hotspot innerhalb des Blankets liegen muss. Wenn zugehörige Netze nicht wie erwartet in das PCB-Parameter-Set übernommen werden, versuchen Sie, den Bereich des Blankets entsprechend anzupassen.

Beispiel für die Verwendung einer Blanket-Direktive, um eine Parameter-Set-Direktive auf Netze innerhalb des Blankets anzuwenden.
Beispiele für die Verwendung einer Blanket-Direktive:
- Anbringen einer Parameter-Set-Direktive an einem Blanket-Objekt, um ihre Regelparameter auf jedes einzelne vom Blanket erfasste Netz anzuwenden.
- Anbringen einer Parameter-Set-Direktive an einem Blanket-Objekt, um ein Parameter-Set zu erstellen, dessen Mitglieder die einzelnen vom Blanket erfassten Netze sind.
- Anbringen einer Differential-Pair-Direktive an einem Blanket-Objekt, um Differentialpaar-Objekte auf Grundlage der differentiellen Netze innerhalb dieses Blankets zu erstellen.
Ein Blanket kann in Verbindung mit einer Parameter-Set-Direktive auch verwendet werden, um Bauteilklassen und Parameter auf Bauteile anzuwenden, die vollständig innerhalb des vom Blanket definierten Bereichs liegen. Verwenden Sie dazu die Optionen Component Class und Parameter im Dropdown-Menü der Schaltfläche Add in den Eigenschaften der am Blanket angebrachten Parameter-Set-Direktive. Die Informationen zur Bauteilklasse und zum Parameter werden beim Aktualisieren der Leiterplatte im Rahmen des ECO-Prozesses in das PCB-Dokument des Projekts übertragen.
Blanket
Ein rechteckiges und ein polygonales Blanket – jeweils mit einer angebrachten Blanket-Direktive
Zusammenfassung
Ein Blanket ist ein rechteckiges oder polygonales Gruppendirektivenobjekt, das über einer Gruppe von Netzen und/oder Bauteilen platziert wird. Eine auf das Blanket angewendete Direktive (Parameter-Set-Objekt) gilt dann für alle Netze und Bauteile, die das Blanket erfasst. Beim Platzieren eines Blankets können Sie entweder eine einfache rechteckige oder eine polygonale Form definieren. Letztere ermöglicht eine präzisere Kontrolle darüber, welche Netzobjekte auf einem Schaltplanblatt erfasst werden.
Das Blanket gilt für alle Netze, die:
- vollständig innerhalb des vom Blanket definierten Bereichs liegen oder
- mindestens einen verbundenen Endpunkt einer Leitung / eines Busses / eines Harnesses unter dem Blanket haben oder
- ein an der Leitung / am Bus / am Harness angebrachtes Netzlabel besitzen, das unter dem Blanket liegt.
Bei Bauteilen gilt das Blanket für alle Bauteile innerhalb des vom Blanket definierten Bereichs.
Eine am Rand des Blankets (Place » Directive) angebrachte Direktive, beispielsweise No ERC, Differential Pair oder ein spezifisches Regel-/Klassen-Parameter-Set, gilt für alle Netze und Bauteile, die vom Blanket-Objekt erfasst werden. Blankets können deaktiviert und ausgeblendet werden.
Verfügbarkeit
Blankets können nur im Schaltplaneditor platziert werden. So platzieren Sie ein Blanket:
- Klicken Sie in den Hauptmenüs auf Place » Directives » Blanket.
- Klicken Sie im Direktiven-Dropdown-Menü auf der Active Bar am oberen Rand des Designbereichs auf die Schaltfläche „Blanket“ Halten Sie eine Active Bar-Schaltfläche gedrückt, um auf weitere zugehörige Befehle zuzugreifen. Sobald ein Befehl verwendet wurde, wird er zum obersten Eintrag in diesem Abschnitt der Active Bar.
- Klicken Sie im Schaltplaneditor mit der rechten Maustaste und anschließend auf Place » Directives » Blanket.
Platzierung
So platzieren Sie ein rechteckiges Blanket:
- Starten Sie den Befehl wie oben beschrieben.
- Positionieren Sie den Cursor und klicken Sie oder drücken Sie Enter , um die obere linke Ecke zu platzieren.
- Positionieren Sie den Cursor und klicken Sie oder drücken Sie Enter , um die untere rechte Ecke zu platzieren.
- Klicken Sie mit der rechten Maustaste oder drücken Sie Enter , um die Platzierung abzuschließen.
- Platzieren Sie weitere Blankets oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc , um den Platzierungsmodus zu beenden.
So platzieren Sie ein polygonales Blanket:
- Starten Sie den Platzierungsbefehl.
- Positionieren Sie den Cursor und klicken Sie oder drücken Sie Enter , um den Startpunkt des Blankets festzulegen.
- Positionieren Sie den Cursor und klicken Sie oder drücken Sie Enter , um eine Reihe von Segmenten festzulegen, die die Form des Blankets definieren.
- Klicken Sie nach dem Platzieren des letzten Segments mit der rechten Maustaste oder drücken Sie Esc , um die Platzierung abzuschließen. Sie müssen das Polygon nicht „schließen“, da die Software die Form automatisch vervollständigt, indem sie die erforderlichen Segmente hinzufügt, um den Startpunkt mit dem zuletzt platzierten Segment zu verbinden.
- Platzieren Sie weitere Blankets oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc , um den Platzierungsmodus zu beenden.
Während der Platzierung der Blanket-Segmente können Sie außerdem folgende Aktionen ausführen:
- Drücken Sie die Taste Tab, um die Platzierung zu unterbrechen und auf den Modus Blanket des Panels Eigenschaften zuzugreifen. Dort können Sie die Linieneigenschaften direkt ändern. Klicken Sie auf die eingeblendete Pause-Schaltfläche im Designbereich , um die Platzierung fortzusetzen.
- Drücken Sie Spacebar, um die Eckrichtung eines noch nicht bestätigten Segments zu ändern.
- Drücken Sie Backspace um beim Definieren einer polygonalen Form für das Blanket das zuletzt bestätigte Segment zu löschen. Durch wiederholtes Betätigen von Backspace werden die vorherigen Segmente der Reihe nach gelöscht.
Grafische Bearbeitung
Mit dieser Bearbeitungsmethode können Sie ein platziertes Blanket-Objekt direkt im Designbereich auswählen und seine Größe, Form oder Position grafisch ändern. Wenn ein Blanket-Objekt ausgewählt ist, stehen die folgenden Bearbeitungsgriffe zur Verfügung:
Ausgewählte rechteckige und polygonale Blankets mit ihren grafischen Bearbeitungsgriffen.
Klicken Sie auf einen Bearbeitungsgriff in der Mitte eines Segments und ziehen Sie ihn, um diese Kante des Blankets zu verschieben.
Bei einem rechteckigen Blanket können Sie einen Bearbeitungsgriff an einer Ecke anklicken und ziehen, um die Größe gleichzeitig in vertikaler und horizontaler Richtung zu ändern.
Klicken Sie auf eine beliebige Stelle der Blanket-Kontur außerhalb der Bearbeitungsgriffe und ziehen Sie das Blanket an eine neue Position. Während des Ziehens kann das Blanket gedreht oder gespiegelt werden:
- Drücken Sie Spacebar, um das Blanket gegen den Uhrzeigersinn um die Cursorposition zu drehen. Shift+Spacebar dreht das Blanket im Uhrzeigersinn um die Cursorposition. Die Drehung erfolgt in 90°-Schritten.
- Drücken Sie die Taste X oder Y, um das Blanket relativ zur Cursorposition entlang der X- bzw. Y-Achse zu spiegeln.
Nichtgrafische Bearbeitung
Die folgenden Methoden zur nichtgrafischen Bearbeitung stehen zur Verfügung.
Bearbeitung über das Dialogfeld „Blanket“ oder das Panel „Properties“
Panel page: Blanket-Eigenschaften
Bei dieser Bearbeitungsmethode werden der zugehörige Blanket Dialogmodus und der Properties Panelmodus verwendet, um die Eigenschaften eines Blanket-Objekts zu ändern.
Das Dialogfeld Blanket links und der Modus Blanket des Panels „Properties“ rechts
Nach der Platzierung können Sie das Dialogfeld Blanket wie folgt öffnen:
- Doppelklicken Sie auf das platzierte Blanket-Objekt.
- Positionieren Sie den Cursor über dem Blanket-Objekt, klicken Sie mit der rechten Maustaste und wählen Sie anschließend Properties aus dem Kontextmenü.
Während der Platzierung können Sie den Modus Blanket des Panels Properties durch Drücken der Taste Tab aufrufen. Sobald das Blanket platziert ist, werden alle Optionen angezeigt.
Nach der Platzierung können Sie den Modus Blanket des Panels Properties auf eine der folgenden Arten aufrufen:
- Wenn das Panel Properties bereits aktiv ist, wählen Sie das Blanket-Objekt aus.
- Wählen Sie nach der Auswahl des Blanket-Objekts das Panel Properties über die Schaltfläche Panels unten rechts im Designbereich oder wählen Sie View » Panels » Properties aus dem Hauptmenü.
Bearbeiten mehrerer Objekte
Das Panel Properties unterstützt die Bearbeitung mehrerer Objekte, wobei die Eigenschaftseinstellungen geändert werden können, die bei allen aktuell ausgewählten Objekten identisch sind. Wenn mehrere Objekte desselben Typs manuell, über das Dialogfeld Find Similar Objects oder über ein Panel Filter bzw. List ausgewählt werden, kann ein Feldeintrag im Panel Properties, der nicht als Sternchen (*) angezeigt wird, für alle ausgewählten Objekte bearbeitet werden.
Bearbeitung über ein List-Panel
Panel pages: List-Panels, SCH Filter
Ein List Panel zeigt Designobjekttypen aus einem oder mehreren Dokumenten in Tabellenform an und ermöglicht so eine schnelle Überprüfung und Änderung von Objektattributen. In Verbindung mit einer geeigneten Filterung – durch die Auswahl von Objekttypen (über die Optionen Include des Panels) oder mithilfe des entsprechenden Panels Filter bzw. des Dialogfelds Find Similar Objects – lassen sich ausschließlich die Objekte anzeigen, die in den Geltungsbereich des aktiven Filters fallen. Die Eigenschaften der aufgelisteten Objekte können anschließend direkt im Panel List bearbeitet werden.
Filterunterstützung
Für die gezielte Auswahl von Blanket-Objekten mithilfe logischer Abfrageausdrücke stehen zwei besonders nützliche Schlüsselwörter zur Verfügung. Diese ergänzen die anderen Schlüsselwörter, mit denen ein Blanket anhand seiner Eigenschaften ausgewählt werden kann.
-
Collapsed– das Objekt ist eingeklappt (auch für die gezielte Auswahl von Compile Masks nützlich). Dieses Schlüsselwort finden Sie bei Verwendung des Query Helper in der Kategorie SCH Functions - Fields. -
IsBlanket– prüft, ob das Objekt ein Blanket ist. Dieses Schlüsselwort finden Sie bei Verwendung des Query Helper in der Kategorie SCH Functions - Object Type Checks.
Erstellen Sie logische Abfrageausdrücke, um die gewünschten Blankets in Ihrem Design gezielt auszuwählen und als Ergebnis zurückzugeben. Einige Beispiele für logische Abfrageausdrücke zur Auswahl von Blankets:
IsBlanket And Collapsed – wählt alle Blanket-Objekte aus, die derzeit eingeklappt sind.
IsBlanket And Not Collapsed – wählt alle Blanket-Objekte aus, die derzeit nicht eingeklappt sind.
Deaktivieren eines Blankets
Nach der Platzierung können Blankets vorübergehend deaktiviert werden, indem Sie auf das kleine Dreieck oben links klicken. Klicken Sie einmal, um das Blanket zu deaktivieren und auszublenden. Klicken Sie erneut, um es wieder zu aktivieren. So lässt sich die Wirkung des Blankets bequem steuern, ohne es vollständig aus dem Design entfernen zu müssen.
Blanket-Eigenschaften
Die Objekteigenschaften im Schaltplaneditor sind konfigurierbare Optionen, die den visuellen Stil, den Inhalt und das Verhalten des platzierten Objekts festlegen. Die Eigenschaften für jeden Objekttyp werden auf zwei verschiedene Arten definiert:
-
Pre-placement settings – die meisten Eigenschaften von Blanket-Objekten bzw. diejenigen, die sinnvoll vordefiniert werden können, sind als bearbeitbare Standardeinstellungen auf der Seite Schematic - Defaults des Dialogs Preferences verfügbar (Zugriff über die Schaltfläche
oben rechts im Designbereich). Wählen Sie das Objekt in Primitive List aus, um dessen Optionen auf der rechten Seite anzuzeigen.
- Post-placement settings – alle Eigenschaften von Blanket-Objekten können im Dialog Blanket und im Panel Properties bearbeitet werden, wenn ein platziertes Blanket im Designbereich ausgewählt ist.
Eigenschaften
- Border Width - wählen Sie über die Dropdown-Liste die gewünschte Rahmenbreite aus.
- Linienstil - wählen Sie über die Dropdown-Liste den gewünschten Linienstil aus.
- Border Color - klicken Sie auf das Farbfeld, um die gewünschte Rahmenfarbe auszuwählen.
- Fill Color - klicken Sie auf das Farbfeld, um die gewünschte Füllfarbe auszuwählen.
- Collapsed and Disabled - aktivieren Sie diese Option, um Blankets einzuklappen und zu deaktivieren.
Indirekte (parameterbasierte) Direktiven
Parameter-Set-Direktiven sind erforderlich, wenn Designobjekte im Schaltplan adressiert werden sollen, die keine Parameter enthalten können. Bei Objekten, die Parameter enthalten können, lassen sich Designdirektiven hingegen indirekt anwenden, indem sie dem jeweiligen Schaltplanobjekt als Parameter hinzugefügt (und definiert) werden. Im Wesentlichen handelt es sich dabei um parameter-based directives.
Parameterbasierte Direktiven können beispielsweise verwendet werden, um die Höhe eines bestimmten Bauteils zu begrenzen oder eine Abstandsbedingung hinzuzufügen, die für alle Objekte im Design gilt. Der erforderliche Parameter, der die Bedingung definiert, wird dem Objekt als Regel hinzugefügt.
Bei der Synchronisierung mit der Leiterplatte werden parameterbasierte Direktiven, die Objekten im Schaltplan hinzugefügt wurden, in PCB-Designregeln umgewandelt. Der Geltungsbereich der entsprechenden PCB-Designregel wird durch die Art des Objekts bestimmt, dem der Parameter ursprünglich zugewiesen wurde. Die folgende Tabelle fasst die unterstützten Zuordnungen zwischen Schaltplanparametern und dem Geltungsbereich von PCB-Regeln zusammen.
| Parameter (als Regel) hinzufügen zu … | Über … | Für den PCB-Regelgeltungsbereich … |
|---|---|---|
| Pin | die Registerkarte Parameters im Pin-Modus des Properties-Panels. | Pad |
| Port | die Registerkarte Parameters im Port-Modus des Properties-Panels. | Netz |
| Bauteil | den Bereich Parameters im Components-Modus des Properties-Panels. | Bauteil |
| Schaltplansymbol | die Registerkarte Parameters im Sheet Symbol-Modus des Properties-Panels, wenn im Bereich Source die Option Local ausgewählt ist. | Bauteilklasse |
| Device-Schaltplansymbol | die Registerkarte Parameters im Sheet Symbol-Modus des Properties-Panels, wenn im Bereich Source die Option Device ausgewählt ist. | Bauteilklasse |
| Verwaltetes Schaltplansymbol | den Bereich Parameters im Sheet Symbol-Modus des Properties-Panels, wenn im Bereich Source die Option Managed ausgewählt ist. | Bauteilklasse |
| Schaltplanblatt | die Registerkarte Parameters im Document Options-Modus des Properties-Panels. | Alle Objekte |
Das Vorgehen zum Hinzufügen eines regelbasierten Parameters ist in allen Fällen gleich. Führen Sie auf der jeweiligen Registerkarte bzw. im jeweiligen Dialog folgende Schritte aus:
- Fügen Sie einen Parameter als Regel hinzu.
- Wählen Sie den zu verwendenden Regeltyp aus.
- Konfigurieren Sie die Bedingungen für den ausgewählten Regeltyp.
Bauteilklassen festlegen
Auf ähnliche Weise können Bauteilklassen im Schaltplan definiert werden, indem den betreffenden Bauteilen ein Parameter ClassName hinzugefügt und dessen Wert auf den gewünschten Klassennamen gesetzt wird. Wenn das Design auf die Leiterplatte übertragen wird, werden die definierten Bauteilklassen erstellt.
Damit die im Schaltplan definierten Bauteilklassen auf die Leiterplatte übertragen werden, müssen im Dialog Project Options die folgenden Optionen eingestellt werden:
- Aktivieren Sie die Option Generate Component Classes im Bereich User-Defined Classes auf der Registerkarte Class Generation des Dialogs.
-
Setzen Sie auf der Registerkarte Comparator des Dialogs die Einstellung Differences Associated with Components » Extra Component Classes Mode auf
Find Differences.
Die oben aufgeführte Option auf der Registerkarte Class Generation ist in der folgenden Abbildung dargestellt. Bewegen Sie den Mauszeiger über die Abbildung, um die Optionseinstellung auf der Registerkarte Comparator anzuzeigen.

Um Bauteilklassen auf die Leiterplatte zu übertragen, aktivieren Sie die Option Generate Component Classes auf der Registerkarte Class Generation. Bewegen Sie den Mauszeiger über die Abbildung, um die Registerkarte Comparator anzuzeigen, auf der Sie die Einstellung Extra Component Classes Mode auf Find Differences setzen müssen.
Nach ihrer Definition können Klassen im Bereich Properties des Panels Properties der jeweiligen Bauteileigenschaften gesperrt werden.
Drucken von Direktiven steuern
Standardmäßig werden beim Drucken der Schaltplanblätter alle Designdirektiven mit ausgegeben. Dies lässt sich jedoch ändern:
- Im Dialog Schematic Print Properties, wenn Sie direkt aus dem Schaltplan drucken oder eine konfigurierte Ausgabe in einer Output-Job-Konfigurationsdatei verwenden.
- Im Bereich Schematics include auf der Seite Additional PDF Settings des Smart PDF Wizard.

Steuern Sie den Druck von Direktiven nach Bedarf. Bei No-ERC-Direktiven können Sie bestimmte Symbolstile drucken und andere ausschließen.




)
).