Définition des lignes de pliage - Mode avancé

En un coup d'œil

Cet article explique le fonctionnement des lignes de pliage dans le mode rigide-flexible avancé d’Altium Designer. Il met en évidence les différences entre ce mode et le mode rigide-flexible standard, ainsi que leur incidence sur la définition des zones flexibles et le pliage de la carte. Vous découvrirez comment identifier le mode rigide-flexible utilisé par un PCB, placer et ajuster les lignes de pliage dans le mode de planification de la carte, modifier leurs propriétés et contrôler la représentation des plis lorsque la carte est pliée en 3D. Si vous travaillez sur une conception rigide-flexible complexe et recherchez des conseils pratiques pour définir l’emplacement, l’angle, le rayon et l’ordre des plis, cet article vous aidera à avancer en toute confiance. Poursuivez votre lecture pour rendre votre processus de conception rigide-flexible plus précis et prévisible.

- Comprenez la différence entre les modes rigide-flexible standard et avancé, et notamment pourquoi le mode avancé n’utilise pas d’objets de type ligne de séparation.
- Découvrez les étapes essentielles pour placer, déplacer, supprimer et positionner précisément les lignes de pliage dans le mode de planification de la carte.
- Identifiez les propriétés des lignes de pliage qui déterminent le comportement des plis en 3D, notamment l’angle, le rayon, l’affectation à une zone d’empilage et l’ordre de pliage.
Approfondissez avec l'IA :

Le logiciel de conception de PCB d'Altium propose deux modes de conception rigide-flexible. Le mode d'origine, ou mode standard, appelé Rigide-flexible, prend en charge les conceptions rigides-flexibles simples. Si votre conception présente des exigences plus complexes, telles que des régions flexibles qui se chevauchent, vous devez utiliser le mode Rigide-flexible avancé (également appelé rigide-flexible 2.0). Le mode se choisit dans le menu Tools du Gestionnaire d'empilage des couches.

La différence fondamentale entre ces modes réside dans le fait que, dans le mode d'origine, la forme de la carte est divisée en régions distinctes par le placement d'une ligne de séparation. Cette ligne reste un objet qui définit où une région de carte se termine et où une autre commence. En mode avancé, chaque région de carte est placée séparément ; si une région plus grande est découpée, elle devient deux objets de région distincts. En mode avancé, ce sont les bords des régions de carte adjacentes qui définissent leur jonction, et non la présence d'une ligne de séparation. C'est pourquoi aucun objet de ligne de séparation n'existe lorsque la carte est en mode Rigide-flexible avancé.

► En savoir plus sur la conception d'un PCB rigide-flexible

Le menu View propose trois modes de travail de l'éditeur de PCB, avec des raccourcis faciles à mémoriser, pour basculer rapidement entre :

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Par défaut, lors du passage entre les modes d'affichage 2D et 3D, les paramètres de zoom et d'orientation sont conservés séparément pour chaque mode. Pour conserver la même position et la même orientation de la carte lors du changement de mode, appuyez sur Ctrl+Alt+2 ou Ctrl+Alt+3, plutôt que sur 2 ou 3.

Vous venez d'ouvrir un PCB et vous vous demandez s'il utilise le mode rigide-flexible standard ou avancé ?

Vous pouvez ouvrir le Gestionnaire d'empilage des couches pour le vérifier. Vous pouvez aussi passer en mode Planification de carte (raccourci 1) et examiner la barre active :

Mode Rigide-flexible standard
Mode Rigide-flexible avancé

Pour définir la manière dont une carte flexible doit se plier, placez une ou plusieurs lignes de pliage. Une ligne de pliage définit l'emplacement du pliage sur la surface de la région flexible. Elle définit également l'angle et le rayon de pliage. La largeur de la bande de surface de carte soumise au pliage est affichée en orange ; elle est calculée à partir de l'angle et du rayon de pliage (en savoir plus sur les propriétés de la ligne de pliage). Les lignes de pliage sont placées et modifiées dans l'éditeur de PCB en mode Board Planning Mode (View » Board Planning Mode, ou utilisez le raccourci 1).


Une ligne de pliage est placée sur la région flexible et configurée pour permettre à la carte de se plier à 180 degrés. Cette vidéo montre le placement d'une ligne de pliage en mode Rigide-flexible avancé.

Placer une ligne de pliage

Pour placer une ligne de pliage :

  1. Sélectionnez View » Board Planning Mode ou utilisez le raccourci 1 pour passer en mode Board Planning Mode.
  2. Sélectionnez la commande Place » Define Bending Line ou cliquez sur le bouton  dans la barre active.
  3. Une ligne de pliage se place sur la région de carte souhaitée, sans s'y attacher (les lignes de pliage sont associées à une ou plusieurs régions de carte au moyen de la propriété Stack Regions). Cliquez près du bord de la région de carte pour définir le point de départ de la ligne de pliage.
  4. Déplacez le curseur jusqu'au point d'arrivée souhaité et cliquez pour placer la ligne de pliage. Notez qu'au moins une extrémité de la ligne de pliage doit toucher ou traverser la limite de la région de carte à laquelle elle s'applique.
  5. Vous restez en mode de placement de ligne de pliage, prêt à en placer une autre si nécessaire. Sinon, faites un clic droit ou appuyez sur Esc pour quitter ce mode.

Les propriétés d'une ligne de pliage sélectionnée peuvent être modifiées dans le panneau Properties. Comme la ligne de pliage se trouve au-dessus d'une région, il se peut qu'un clic sur la ligne sélectionne plutôt la région située en dessous. Sans déplacer le curseur, cliquez une deuxième fois pour sélectionner la ligne de pliage au lieu de la région de carte.

Les propriétés de la ligne de pliage sélectionnée sont affichées dans le panneau Propriétés.
Les propriétés de la ligne de pliage sélectionnée sont affichées dans le panneau Propriétés.

  • Il n'est pas indispensable de placer précisément le début ou la fin de la ligne de pliage sur le bord de la région de carte : le logiciel prolonge ou raccourcit automatiquement la ligne pour qu'elle s'étende d'un bord à l'autre de la région.
  • Assurez-vous que la région de carte appropriée est activée dans la section Stack Regions du panneau Properties.

Déplacer une ligne de pliage

Pour modifier l'emplacement d'une ligne de pliage existante :

  1. Sélectionnez View » Board Planning Mode (ou utilisez le raccourci 1) pour passer en mode Board Planning Mode.
  2. Cliquez sur le sommet situé à l'une des extrémités de la ligne de pliage et maintenez le bouton enfoncé, puis faites glisser ce sommet jusqu'à l'emplacement souhaité et relâchez le bouton de la souris. Le curseur sera contraint par les paramètres d'accrochage actuels ; appuyez sur Ctrl+E pour modifier ces paramètres pendant l'opération.
  3. L'emplacement du pliage sera redéfini par la nouvelle position de la ligne de pliage.

Sélectionnez et faites glisser un sommet de la ligne de pliage pour modifier sa position sur la carte. Le curseur sera contraint par les paramètres d'accrochage actuels.
Sélectionnez et faites glisser un sommet de la ligne de pliage pour modifier sa position sur la carte. Le curseur sera contraint par les paramètres d'accrochage actuels.

Positionner précisément une ligne de pliage

Lorsque vous déplacez la poignée d'une ligne de pliage, elle s'accroche conformément aux paramètres d'accrochage actuels. Appuyez sur Ctrl+E pendant le déplacement pour afficher le panneau de commande interactif des paramètres d'accrochage, comme illustré ci-dessous. Après avoir modifié les paramètres, appuyez sur Esc pour les appliquer et fermer le panneau.

Outre l'accrochage à la grille et aux guides de l'espace de travail, la ligne de pliage peut également s'accrocher à des objets de conception existants, tels que des lignes sur une couche mécanique. L'image ci-dessous montre le positionnement de la poignée d'une ligne de pliage sur le sommet d'extrémité d'une ligne située sur une couche mécanique. Notez que le paramètre actuel d'accrochage aux points sensibles (affiché dans la barre d'état) s'applique pendant le déplacement. Si la couche mécanique n'est pas la couche de conception active, l'accrochage aux points sensibles doit être réglé sur All Layers pour que ce comportement fonctionne. Utilisez le raccourci Shift+E pour faire défiler les modes d'accrochage aux points sensibles disponibles pendant l'opération.

La poignée d'une ligne de pliage s'accroche au sommet d'une piste placée sur une couche mécanique.
La poignée d'une ligne de pliage s'accroche au sommet d'une piste placée sur une couche mécanique.

Supprimer une ligne de pliage

Pour supprimer une ligne de pliage :

  1. Sélectionnez View » Board Planning Mode (ou utilisez le raccourci 1) pour passer en mode Board Planning Mode.
  2. Cliquez sur l'un de ses sommets et maintenez le bouton enfoncé pour sélectionner la ligne de pliage, puis appuyez sur la touche Delete.

Configurer les propriétés de la ligne de pliage

Pour modifier les propriétés d'une ligne de pliage dans le panneau Properties :

  1. Passez en mode Board Planning Mode (appuyez sur 1).
  2. Cliquez n'importe où dans la bande orange de la ligne de pliage pour la sélectionner.
  3. La ligne de pliage peut être modifiée dans le panneau Properties.

Les pliages définis peuvent être appliqués lorsque la carte est affichée en mode 3D ; utilisez le raccourci 5 pour plier la carte. La région rigide de la carte dont la case 3D Locked est cochée sert de référence physique au sol pour le mode d’affichage 3D (où Z = 0). Si la carte ne se plie pas comme prévu, vérifiez que la case 3D Locked est cochée pour la bonne région rigide. Notez qu’il n’est pas nécessaire de décocher cette option dans une région de carte avant de l’activer dans une autre.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents