Techniques de placement et d’édition de PCB
En un coup d'œil
- Comprenez la différence entre les objets primitifs et les objets de groupe, ainsi que son incidence sur le placement et la manipulation dans l’éditeur de PCB.
- Découvrez le processus de modification habituel avant, pendant et après le placement, notamment les valeurs par défaut, l’accès aux propriétés et le changement des unités d’affichage.
- Découvrez les commandes de sélection de PCB disponibles pour travailler avec les objets superposés, les hiérarchies logiques de nets, le cuivre connecté et les sélections de routage associées aux composants.
Divers objets sont disponibles pour concevoir un PCB. La plupart des objets placés dans un document PCB définissent des zones de cuivre ou des évidements. Cela s’applique aussi bien aux objets électriques, tels que les pistes et les pastilles, qu’aux objets non électriques, tels que le texte et les cotations. Il est donc important de tenir compte de la largeur des lignes utilisées pour définir chaque objet et de la couche sur laquelle il est placé.
Il existe deux types d’objets dans l’éditeur PCB : les objets primitifs et les objets groupés :
-
Les objets primitifs sont les éléments fondamentaux de la conception et comprennent les pistes, les pastilles, les vias, les remplissages, les arcs et les objets texte. Ils sont appelés « primitifs » en raison de leur nature brute ou élémentaire.
-
Tout ensemble constitué de primitives et identifié comme un objet de conception est un objet groupé. Les composants, les cotations et les remplissages polygonaux sont des exemples d’objets groupés. Un objet groupé peut être manipulé comme un seul objet dans l’espace de conception. Il peut, par exemple, être placé, sélectionné, copié, modifié, déplacé et supprimé.
Principes communs de placement et de modification des objets
Dans Altium Designer, la procédure de placement d’un objet est à peu près la même, quel que soit l’objet à placer. Dans sa forme la plus simple, elle se déroule comme suit :
-
Sélectionnez l’objet à placer dans l’une des barres d’outils ou dans le menu Place .
-
À l’aide de la souris, définissez l’emplacement de l’objet dans l’espace de conception de l’éditeur PCB, ainsi que sa taille, le cas échéant.
-
Faites un clic droit (ou appuyez sur Esc) pour terminer la commande et quitter le mode de placement.
Modification avant le placement
Les propriétés par défaut d’un objet peuvent être modifiées à tout moment sur la page Éditeur PCB – Valeurs par défaut de la boîte de dialogue Preferences . Ces propriétés seront appliquées aux objets placés par la suite.

Utilisez la colonne Primitives pour accéder aux propriétés des objets et modifier les valeurs par défaut selon vos besoins.
Modification pendant le placement
Plusieurs attributs peuvent être modifiés lors du placement initial d’un objet. Pour accéder à ces attributs, appuyez sur la touche Tab en mode de placement afin d’ouvrir le panneau Properties associé. L’appui sur la touche Tab suspend le placement pour vous permettre d’effectuer les modifications nécessaires sur l’objet.
Exemple de boîte de dialogue des propriétés d’un objet Pastille .
Une fois les modifications effectuées, cliquez sur le bouton de pause superposé à l’espace de conception (
) pour reprendre le placement.
Modification après le placement
Une fois un objet placé, il existe plusieurs façons de le modifier. Elles sont décrites ci-dessous.
Panneau ou boîte de dialogue des propriétés associés
Cette méthode de modification utilise le mode associé du panneau Properties et la boîte de dialogue correspondante pour modifier les propriétés d’un objet placé.
Après le placement, vous pouvez accéder à la boîte de dialogue associée en :
-
Double-cliquant sur l’objet placé.
-
Plaçant le curseur sur l’objet, puis en faisant un clic droit et en choisissant Properties dans le menu contextuel.
Après le placement, vous pouvez accéder au mode associé du panneau Properties de l’une des façons suivantes :
- Si le panneau Properties est déjà actif, sélectionnez l’objet.
- Après avoir sélectionné l’objet, sélectionnez le panneau Properties à partir du bouton Panels situé en bas à droite de l’espace de conception, ou sélectionnez View » Panels » Properties dans les menus principaux.
Commandes de sélection des objets PCB
Outre les commandes standard de sélection et de désélection des objets, l’éditeur PCB propose plusieurs commandes spéciales qui facilitent ces opérations. Ces commandes sont accessibles depuis les sous-menus Edit » Select et Edit » DeSelect des menus principaux. Les commandes de sélection sont également accessibles depuis le menu du bouton
dans Active Bar.
-
Select overlapped - permet de sélectionner uniquement l’objet de conception suivant parmi un ensemble d’objets situés au même endroit (superposés), sans utiliser de fenêtre contextuelle de sélection. La sélection respecte l’ordre de priorité fixe suivant, parcouru à chaque utilisation successive de la commande :
- Pastille
- Via
- Piste/Arc
- Composant
- Polygone
- Région/Remplissage
- Texte
De plus, lorsque vous utilisez la touche Shift pour ajouter des objets à la sélection actuelle, vous pouvez utiliser Shift+Tab pour parcourir les objets superposés sans perdre votre sélection initiale.
-
Select next (raccourci : Tab) - lorsqu’un premier objet est sélectionné dans la conception, cette commande permet d’étendre la sélection à l’objet (ou aux objets) du niveau immédiatement supérieur dans la hiérarchie logique. Les séquences cycliques de sélection logique suivantes sont prises en charge :
- Segment de piste ---> Toutes les pistes connectées (contiguës) sur la même couche ---> Tout le cuivre connecté ---> Tous les objets électriques du net associé
- Pastille connectée ---> Toutes les pistes connectées (contiguës) sur la même couche ---> Tout le cuivre connecté ---> Tous les objets électriques du net associé
- Pastille non connectée ---> Tous les objets électriques du net associé
- Via ---> Toutes les pistes connectées (contiguës) sur les couches associées au via ---> Tout le cuivre connecté ---> Tous les objets électriques du net associé
- Cuivre (région/polygone de cuivre/remplissage) ---> Tout le cuivre connecté ---> Tous les objets électriques du net associé
- Pastille libre/via libre ---> Toutes les pistes connectées (contiguës) sur la même couche que la pastille ou sur les couches associées au via ---> Tout le cuivre connecté ---> Tous les objets électriques du net associé.
- Composant ---> Évasions par via, sorties de pastille, interconnexions
Cette fonction permet également d’étendre la sélection à plusieurs objets sélectionnés sur différents nets de la conception.

Exemple de sélection sur plusieurs nets, étendue depuis les segments de piste initialement sélectionnés vers les niveaux supérieurs de la hiérarchie logique.Cette commande est particulièrement utile pour sélectionner des nets routés. Pour en savoir plus, consultez Stratégies de sélection du routage.
-
Board - permet de sélectionner tous les objets situés à l’intérieur du contour défini de la carte.
-
Net - permet de sélectionner tous les objets électriques associés à un net donné.
Après avoir lancé la commande, vous pouvez cliquer sur un objet électrique ou une connexion pour sélectionner tous les objets électriques du net associé. Si vous connaissez le nom du net à sélectionner, cliquez dans une zone de la conception ne contenant aucun objet ; la boîte de dialogue Net Name s’ouvre. Vous pouvez alors saisir le nom du net souhaité ; celui-ci sera sélectionné lorsque vous fermerez la boîte de dialogue. Si vous n’êtes pas sûr du nom du net, saisissez ?, puis cliquez sur OK pour ouvrir la boîte de dialogue Nets Loaded, qui répertorie tous les nets actuellement chargés pour la conception.
-
Connected Copper - permet de sélectionner tous les objets électriques connectés à une même portion de cuivre.
-
Physical Connection - permet de sélectionner toutes les pistes physiquement routées entre des pastilles. Cliquez sur une piste, une pastille ou un via ; toutes les pistes contiguës jusqu’à une autre pastille seront sélectionnées, y compris les vias éventuels (les pastilles elles-mêmes ne seront pas incluses dans la sélection).
-
Physical Connection Single Layer - permet de sélectionner toutes les pistes physiquement routées entre des pastilles sur une seule couche. Cliquez sur une piste ou un via ; toutes les pistes contiguës situées sur la même couche et allant jusqu’à une autre pastille seront sélectionnées (les pastilles et les vias eux-mêmes ne seront pas inclus dans la sélection).
-
Component Connections - permet de sélectionner toutes les connexions routées partant des pastilles d’un composant choisi (y compris les pistes et les vias) jusqu’à la prochaine pastille rencontrée dans chaque cas. Les pastilles elles-mêmes ne seront pas incluses dans la sélection.
La commande est également accessible en cliquant avec le bouton droit sur un composant placé, puis en choisissant la commande Component Actions » Select Component Connections dans le menu contextuel.
-
Component Nets - permet de sélectionner tous les nets (ainsi que les objets qui leur appartiennent) reliés à un composant choisi dans le document actif.
La commande est également accessible en cliquant avec le bouton droit sur un composant placé, puis en choisissant la commande Component Actions » Select Component Nets dans le menu contextuel.
-
Room Connections - permet de sélectionner toutes les connexions routées de pastille à pastille qui se trouvent entièrement à l’intérieur des limites de la chambre choisie dans le document actif.
La commande est également accessible en cliquant avec le bouton droit sur une chambre placée, puis en choisissant la commande Room Actions » Select Room Connections dans le menu contextuel.
-
All on Layer - permet de sélectionner/désélectionner tous les objets de la couche active.
-
Free Objects - permet de sélectionner toutes les primitives libres de la conception. Les composants, les coordonnées, les cotations, les objets d’ajustement de longueur, les objets OLE et les polygones de cuivre sont tous des objets groupés et ne sont donc pas affectés par cette commande.
-
All Locked - permet de sélectionner tous les objets de la conception dont la propriété Locked est activée.
-
Off Grid Pads - permet de sélectionner toutes les pastilles qui ne sont pas placées sur la grille d’accrochage active.
Modification graphique
Cette méthode de modification vous permet de sélectionner directement un objet placé dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou sa position. La modification de la forme et/ou de la taille (le cas échéant) s’effectue à l’aide de « poignées » de modification qui apparaissent lorsque l’objet est sélectionné.

Exemple de poignées de modification pour un objet de remplissage sélectionné.
Cliquez n’importe où sur un objet, à l’écart des poignées de modification (lorsqu’elles existent), pour le faire glisser et le repositionner. Selon le type d’objet, vous pouvez le faire pivoter et/ou le retourner pendant le déplacement.
- Appuyez sur Spacebar pour faire pivoter l’objet dans le sens antihoraire ou sur Shift+Spacebar pour une rotation dans le sens horaire. La rotation s’effectue selon la valeur de Rotation Step définie sur la page Éditeur PCB – Général de la boîte de dialogue Preferences.
- Appuyez sur la touche L pour retourner l’objet sur l’autre face de la carte (le cas échéant).
- Appuyez sur les touches X ou Y pour retourner l’objet selon l’axe X ou Y, le cas échéant.
- Appuyez sur la touche Alt pour contraindre le déplacement à l’axe horizontal ou vertical, selon la direction initiale du déplacement.
- Déplacez l’objet par petits incréments (selon la valeur actuelle de la grille d’accrochage) en appuyant sur les touches fléchées tout en maintenant la touche Ctrl enfoncée. Déplacez-le par incréments plus importants (10 fois la valeur de la grille d’accrochage) en appuyant sur les touches fléchées tout en maintenant les touches Ctrl+Shift enfoncées.
Commandes de déplacement
La position d’un objet peut être modifiée à l’aide des commandes du sous-menu Edit » Move des menus principaux ou du sous-menu de déplacement dans Active Bar.
-
Move - cette commande permet de déplacer n’importe quel objet dans le document actif. Tous les nets associés à un objet restent connectés et les lignes de connexion suivent l’objet lorsqu’il est déplacé (elles sont affichées ou non selon le mode de connexion en vigueur). Les pistes routées connectées à l’objet ne sont pas déplacées.
-
Drag - cette commande permet de déplacer n’importe quel objet dans le document actif. Si des pistes et/ou des arcs sont connectés à l’objet (par exemple, un composant, une pastille ou un via), ils restent connectés pendant son déplacement.
-
Component - cette commande permet de déplacer des composants dans le document actif. Après avoir lancé la commande, cliquez sur le composant à déplacer dans la conception, déplacez-le jusqu’à la position souhaitée, puis cliquez. Vous pouvez également cliquer dans l’espace de conception, à l’écart de tout objet, pour ouvrir la boîte de dialogue Choisir un composant. Utilisez cette boîte de dialogue pour localiser le composant à déplacer (en accédant au composant ou en l’amenant au curseur), puis repositionnez-le comme décrit ci-dessus. Notez que cette fonctionnalité ne fonctionne que si le composant cible est not verrouillé.
Vous pouvez également accéder à cette commande en cliquant avec le bouton droit sur un composant dans l’espace de conception, puis en choisissant la commande Component Actions » Move Component dans le menu contextuel.
-
Move Selection - cette commande permet de repositionner manuellement les objets sélectionnés dans le document actif. Tous les nets associés à un objet de la sélection restent connectés et les lignes de connexion suivent l’objet lorsqu’il est déplacé (elles sont affichées ou non selon le mode de connexion en vigueur). Les pistes routées connectées à l’objet ne sont pas déplacées.
-
Move Selection by X, Y - cette commande permet de décaler la sélection actuelle d’objets d’une valeur précise selon les axes X et/ou Y. Après le lancement de la commande, la boîte de dialogue Get X/Y Offsets s’ouvre. Utilisez cette boîte de dialogue pour spécifier les valeurs de décalage delta X et/ou delta Y à appliquer à la sélection.

La boîte de dialogue Get X/Y OffsetsOptions et commandes de la boîte de dialogue Définir les décalages X/Y
- X Offset - utilisez ce champ pour spécifier la distance de déplacement de la sélection le long de l’axe horizontal. Vous pouvez saisir des valeurs positives ou négatives selon la direction de déplacement souhaitée. Utilisez le bouton à droite de ce champ pour inverser rapidement le signe de la valeur saisie.
- Y Offset - utilisez ce champ pour spécifier la distance de déplacement de la sélection le long de l’axe vertical. Vous pouvez saisir des valeurs positives ou négatives selon la direction de déplacement souhaitée. Utilisez le bouton à droite de ce champ pour inverser rapidement le signe de la valeur saisie.
- Toggle X/Y Offsets - cliquez sur ce bouton pour permuter rapidement les valeurs de décalage. La valeur X Offset sera utilisée comme valeur Y Offset et inversement.
- Reset X/Y Offsets - cliquez sur ce bouton pour remettre rapidement les deux valeurs de décalage à zéro.
- Define X/Y Offsets Interactively - cliquez sur ce bouton pour calculer les décalages de manière interactive. Vous serez dirigé vers l’espace de travail et invité à choisir successivement un point de départ et un point d’arrivée. Cliquez aux emplacements souhaités ; les valeurs dX et dY seront saisies respectivement dans les champs X Offset et Y Offset.
-
Rotate Selection - cette commande permet de faire pivoter les objets sélectionnés dans l’espace de conception dans le sens antihoraire ou horaire, selon un angle de rotation spécifié. Après le lancement de la commande, la boîte de dialogue Rotation Angle (Degrees) s’ouvre. Saisissez l’angle de rotation souhaité, de 0,001° à 360,00° (résolution de 0,001°). Saisissez une valeur positive pour une rotation dans le sens antihoraire ou une valeur négative pour une rotation dans le sens horaire. Cliquez sur OK pour fermer la boîte de dialogue, puis positionnez le curseur et cliquez pour définir le point de référence de la rotation. Les objets sélectionnés pivoteront autour du point de référence selon l’angle saisi.

La boîte de dialogue Rotation Angle -
Flip Selection - retourner horizontalement les objets sélectionnés (autour de l’axe Y) vers la couche correspondante sur la face opposée de la carte. Par exemple, les objets situés sur Top Layer seront transférés sur Bottom Layer, les objets situés sur Top Overlay seront transférés sur Bottom Overlay, etc.
Commandes d’alignement
Les objets peuvent également être déplacés en modifiant leur alignement. Pour aligner des objets sur d’autres objets, faites un clic droit sur un objet sélectionné, puis sélectionnez Align. Vous pouvez également utiliser le sous-menu Edit » Align des menus principaux ou le sous-menu d’alignement dans Active Bar. Le sous-menu d’alignement propose plusieurs options de répartition des objets sélectionnés.
La commande Align permet d’accéder à la boîte de dialogue Align Objects, qui propose des commandes pour aligner rapidement l’ensemble des objets de conception actuellement sélectionnés selon vos besoins. Utilisez cette boîte de dialogue pour définir les options d’alignement Vertical et/ou Horizontal des objets sélectionnés, selon vos besoins, puis cliquez sur OK pour appliquer l’alignement.

La boîte de dialogue Align Objects
Options et commandes de la boîte de dialogue Align Objects
-
Horizontal - choisissez l’une des options suivantes pour déterminer l’alignement horizontal des objets sélectionnés :
- No Change - conserver l’alignement horizontal des objets.
- Left - aligner les objets de sorte que le bord extérieur de leurs primitives les plus à gauche ait la même coordonnée X. L’objet dont la primitive est la plus à gauche sert de référence.
- Center - déplacer les objets horizontalement pour aligner leurs centres. Après avoir cliqué sur OK, vous êtes invité à cliquer pour choisir l’objet de référence.
- Right - aligner les objets de sorte que le bord extérieur de leurs primitives les plus à droite ait la même coordonnée X. L’objet dont la primitive est la plus à droite sert de référence.
- Space equally - espacer uniformément les objets dans le sens horizontal, entre l’objet le plus à gauche et l’objet le plus à droite (qui restent immobiles).
-
Vertical - choisissez l’une des options suivantes pour déterminer l’alignement vertical des objets sélectionnés :
- No Change - conserver l’alignement vertical des objets sélectionnés.
- Top - aligner les objets de sorte que le bord extérieur de leurs primitives les plus hautes ait la même coordonnée Y. L’objet dont la primitive est la plus haute sert de référence.
- Center - déplacer les objets verticalement pour aligner leurs centres. Après avoir cliqué sur OK, vous êtes invité à cliquer pour choisir l’objet de référence.
- Bottom - aligner les objets de sorte que le bord extérieur de leurs primitives les plus basses ait la même coordonnée Y. L’objet dont la primitive est la plus basse sert de référence.
- Space equally - espacer uniformément les objets dans le sens vertical, entre l’objet le plus haut et l’objet le plus bas (qui restent immobiles).
La commande Position Component Text permet d’ouvrir la boîte de dialogue Component Text Position, dans laquelle vous pouvez modifier la position du texte du repère et/ou du commentaire d’un ou de plusieurs composants sélectionnés dans le document actif.

La boîte de dialogue Component Text Position
La boîte de dialogue est essentiellement divisée en deux zones : le texte du repère et celui du commentaire. Pour le repère comme pour le commentaire, une représentation graphique d’un composant permet de visualiser l’emplacement du texte en fonction de la position sélectionnée. Les neuf styles de positionnement suivants sont disponibles pour le texte. Ils sont tous considérés comme des « positions automatiques », ce qui signifie que le texte reste à la position choisie lorsque le composant est déplacé ou pivoté :
- Left-Above
- Left-Center
- Left-Below
- Center-Above
- Center
- Center-Below
- Right-Above
- Right-Center
- Right-Below
Pour conserver le texte à sa position actuelle sans modification, laissez l’option No Change activée.
La commande Align Left / Align Right / Align Top / Align Bottom permet d’aligner les objets de conception sélectionnés sur leurs bords gauche, droit, supérieur ou inférieur, respectivement. Après le lancement de la commande, le bord gauche, droit, supérieur ou inférieur de l’objet situé le plus à gauche, à droite, en haut ou en bas sert de référence. Tous les autres objets de la sélection sont déplacés vers la gauche, la droite, le haut ou le bas, afin que leurs bords gauches soient alignés sur cette référence.
La commande Align Left (maintain spacing) / Align Right (maintain spacing) / Align Top (maintain spacing) / Align Bottom (maintain spacing) permet d’aligner les objets de conception sélectionnés sur leurs bords gauche/droit/supérieur/inférieur tout en maintenant un espacement adéquat, conformément aux règles de conception applicables. Après le lancement de la commande, le bord gauche/droit/supérieur/inférieur de l’objet situé le plus à gauche/à droite/en haut/en bas sert de référence, et tous les autres objets de la sélection sont déplacés vers la gauche/la droite/le haut/le bas afin que leurs bords gauches soient alignés sur cette référence. Chaque objet est déplacé vers la gauche/la droite/le haut/le bas aussi près de l’objet de référence que le permet la règle d’isolement applicable :
- Pour l’alignement de composants uniquement, la règle d’espacement des composants est respectée.
- Pour l’alignement d’objets autres que des composants uniquement, la règle d’isolement est respectée.
- Pour l’alignement de composants et d’objets autres que des composants, la règle d’isolement est respectée.
La commande Align Horizontal Centers / Align Vertical Centers permet de placer les objets sélectionnés sur une seule colonne/ligne, en les alignant sur leurs centres horizontaux/verticaux. Après le lancement de la commande, le curseur prend la forme d’une croix et vous êtes invité à choisir l’un des objets de la sélection ; cliquez sur cet objet. Il devient alors l’objet de référence. Tous les autres objets de la sélection sont déplacés par rapport à cet objet de référence, en étant alignés sur leurs centres horizontaux/verticaux.
La commande Distribute Horizontally / Distribute Vertically permet d’uniformiser l’espacement horizontal/vertical des objets d’une sélection. Après le lancement de la commande, les objets situés le plus à gauche et le plus à droite / le plus en haut et le plus en bas de la sélection restent à leur position, et tous les autres objets sont espacés uniformément entre eux. La position verticale/horizontale des objets n’est pas modifiée.
La commande Increase Horizontal Spacing / Increase Vertical Spacing permet d’augmenter l’espacement horizontal/vertical des objets d’une sélection. Après le lancement de la commande, l’objet situé le plus à gauche/en bas reste fixe, tandis que les autres objets de la sélection sont déplacés vers la droite/le haut. Le déplacement augmente la distance horizontale/verticale entre les points de référence d’objets consécutifs de la valeur spécifiée dans le champ Step X / Step Y du Global Board Snap Grid par défaut.
La commande Decrease Horizontal Spacing / Decrease Vertical Spacing permet de réduire l’espacement horizontal/vertical des objets d’une sélection. Après le lancement de la commande, l’objet situé le plus à gauche/en bas reste fixe, tandis que les autres objets de la sélection sont déplacés vers la gauche/le bas. Le déplacement réduit la distance horizontale/verticale entre les points de référence d’objets consécutifs de la valeur spécifiée dans le champ Step X / Step Y du Global Board Snap Grid par défaut.
La commande Align To Grid permet de déplacer les composants sélectionnés vers le point le plus proche sur la grille d’accrochage applicable et modifiée. Après le lancement de la commande, les points de référence de chacun des composants sélectionnés sont déplacés vers le point le plus proche sur la grille d’accrochage applicable.
La commande Move All Components Origin To Grid permet de déplacer le point de référence de tous les composants sur la grille d’accrochage actuelle. Après le lancement de la commande, tous les composants de l’espace de conception dont les pastilles sont sur la grille sont déplacés de façon à aligner leurs points de référence sur la grille d’accrochage actuelle. Par défaut, un rapport — Move Component(s) Origin To Grid - <PCBDocumentName>.html — est automatiquement généré et ouvert comme document actif. Il indique les composants qui ont été déplacés et ceux qui ne l’ont pas été.
Via le panneau PCB List
Le panneau PCB List permet d’afficher les objets de conception sous forme de tableau, afin d’inspecter et de modifier rapidement leurs attributs. Utilisé conjointement avec le panneau PCB Filter, il permet de n’afficher que les objets correspondant au filtre actif, pour cibler et modifier plusieurs objets de conception avec davantage de précision et d’efficacité.
Sélection de la couche active
La couche active est la couche sur laquelle vous placez les objets. Vous pouvez sélectionner la couche active parmi les couches actuellement visibles en cliquant sur son onglet en bas de l’espace de conception ou en utilisant la liste déroulante Active Layer dans la zone Layers de l’onglet Layers & Colors du panneau View Configuration.
Vous pouvez également utiliser les raccourcis suivants pour sélectionner rapidement la couche active :
- * (sur le pavé numérique) – passer à la couche de signal activée suivante.
-
Shift+* (sur le pavé numérique) – passer à la couche de signal activée précédente.
- + (sur le pavé numérique) – passer à la couche activée suivante.
- - (sur le pavé numérique) – passer à la couche activée précédente.
Utilisation des commandes Couper/Copier et Coller
Dans l’éditeur de PCB, vous pouvez couper/copier et coller des objets au sein d’un même document PCB ou entre plusieurs documents PCB. Par exemple, des composants d’un PCB peuvent être copiés dans un autre document PCB. Vous pouvez couper/copier des objets dans le presse-papiers Windows et les coller dans d’autres documents.
Lorsque vous utilisez 2D Layout Mode, sélectionnez les objets à couper/copier, cliquez sur Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) dans les menus principaux ou choisissez la commande Cut/Copy dans le menu contextuel. Le curseur prend la forme d’une croix et vous êtes invité à sélectionner un point de référence. Il s’agit d’une coordonnée relative aux objets sélectionnés, utilisée pour positionner précisément la sélection lors de l’utilisation de la commande Coller.
Pour copier les objets de conception actuellement sélectionnés dans le presse-papiers au format texte, utilisez la commande Edit » Copy As Text des menus principaux. Ces informations peuvent ensuite être collées dans n’importe quel champ de texte ou document texte externe. Les informations copiées dans le presse-papiers comprennent :
- Le type d’objet.
- Le désignateur et le commentaire (pour un objet composant).
- La position de l’objet dans l’espace de conception.
- La couche sur laquelle se trouve l’objet (ou les couches de départ et d’arrivée pour un via).
Voici un exemple de composant copié au format texte dans le presse-papiers :
Component Y1-25MHz (100.6mm,1.5mm) on Top Layer
Voici un exemple de piste et de via copiés au format texte dans le presse-papiers :
Track (20mm,6mm)(80mm,6mm) Top Layer
Via (45mm,6mm) Top Layer to Bottom Layer
Pour placer le dernier contenu coupé ou copié dans le presse-papiers dans le document actif, choisissez la commande Edit » Paste dans les menus principaux ou faites un clic droit dans l’espace de conception et choisissez la commande Paste dans le menu contextuel (raccourci : Ctrl+V). Le dernier contenu du presse-papiers apparaît attaché au curseur. La position du curseur par rapport au contenu est déterminée par le point de référence défini lors de l’utilisation de Cut ou de Copy pour ajouter la sélection au presse-papiers.
Pour placer du texte copié depuis une application compatible OLE dans un document PCB ouvert, utilisez la commande Edit » Paste Text des menus principaux. Le texte est converti et collé sous forme d’objets texte PCB, plutôt que sous la forme d’un seul objet OLE. Les types de fichiers pris en charge comprennent des formats universels, tels que les feuilles de calcul aux formats CSV et XLS et les documents texte aux formats DOC et RTF.
Pour contrôler le comportement de certains attributs des objets lorsqu’ils sont recollés dans l’espace de conception, utilisez la commande Edit » Paste Special des menus principaux. Après le lancement de la commande, la boîte de dialogue Paste Special s’ouvre.

La boîte de dialogue Paste Special
Options et commandes de la boîte de dialogue Collage spécial
Attributs de collage
- Paste on current layer - activez cette option pour coller les objets sur la couche courante.
- Keep net name - activez cette option pour conserver les noms de nets d’origine des objets.
- Duplicate designator - activez cette option pour coller un composant avec le même désignateur, sans incrémentation automatique.
- Add to component class - activez cette option pour ajouter le composant collé à la même classe de composants que le composant source.
Boutons
- Paste - cliquez pour coller l’objet avec tous les attributs spécifiés.
- Paste Array - cliquez pour ouvrir la boîte de dialogue Configuration du collage en réseau, dans laquelle vous pouvez configurer les options de collage en réseau.
Selon le contenu à coller, les attributs suivants peuvent être contrôlés :
-
Les objets peuvent être collés sur la couche courante, au lieu du comportement de collage par défaut, qui les place sur la couche depuis laquelle les objets sources ont été copiés.
- Possibilité de conserver les noms de nets attribués.
- Possibilité de dupliquer le désignateur (pour un composant collé).
- Possibilité d’ajouter un composant collé à la même classe de composants que le composant source d’origine.
Configurez les options selon vos besoins, puis cliquez sur le bouton Paste pour lancer l’opération de collage.
Un clic sur le bouton Paste Array dans la boîte de dialogue Paste Special ouvre la boîte de dialogue Setup Paste Array, qui vous permet de coller plusieurs copies des objets du presse-papiers dans le document courant.

La boîte de dialogue Setup Paste Array
Options et commandes de la boîte de dialogue Configuration du collage en réseau
Variables de placement
- Item Count - le nombre de placements répétés à effectuer. Par exemple, saisir 4 permet de placer 4 copies du contenu actuel du presse-papiers.
-
Text Increment - saisissez l’incrément automatique du texte affiché (par exemple, le désignateur d’un composant ou d’une pastille). Les incréments alphabétiques et numériques autres que 1 sont pris en charge. Par exemple, en définissant le désignateur d’une pastille avant de la copier dans le presse-papiers et en renseignant le champ Text Increment, vous pouvez placer les types de séquences de désignateurs de pastilles suivants :
- Numérique (1, 3, 5)
- Alphabétique (A, B, C)
- Combinaison alphabétique et numérique (A1, A2, ou 1A, 1B, ou A1, B1 ou 1A, 2A, etc.)
Type de réseau
- Circular- activez cette option pour coller un réseau circulaire en utilisant les paramètres actuels de Circular Array.
- Linear - activez cette option pour coller le réseau en ligne droite en utilisant les paramètres actuels de Linear Array.
Réseau circulaire
- Rotate Item to Match - si cette option est activée, les éléments du réseau seront tournés d’un angle égal à leur espacement angulaire.
- Spacing (degrees) - l’espacement angulaire entre deux éléments collés adjacents.
Réseau linéaire
- X-Spacing - saisissez l’espacement souhaité selon l’axe X entre deux éléments adjacents.
- Y- Spacing - saisissez l’espacement souhaité selon l’axe Y entre deux éléments adjacents.
Saisissez les valeurs appropriées dans cette boîte de dialogue, puis cliquez sur OK pour placer le réseau.
- Si vous placez un réseau linéaire, vous serez invité à sélectionner son point de départ. Positionnez le curseur, puis cliquez ou appuyez sur Enter pour placer le réseau.
- Lors du placement d’un réseau circulaire, vous serez invité à sélectionner le centre du réseau, puis son point de départ. Dans chaque cas, positionnez le curseur, puis cliquez ou appuyez sur Enter pour placer le réseau. Les objets seront placés dans le sens antihoraire autour du centre choisi.
Priorités lors du collage d’objets
Lorsqu’un objet est collé sur une couche de cuivre et qu’il chevauche un ensemble d’objets de différents types, le net de l’objet ayant la priorité la plus élevée est attribué à l’objet collé. Les priorités sont les suivantes (1 correspond à la priorité la plus élevée) :
- Pastille
- Remplissage
- Région
- Piste
- Arc
- Via
- Polygone de cuivre

Le net de l’objet ayant la priorité la plus élevée est attribué à l’objet collé. L’exemple présenté ici montre un objet (une piste) collé sur un ensemble d’objets de différents types auxquels sont attribués différents nets. La pastille étant l’objet ayant la priorité la plus élevée dans cet ensemble, son net (Pad_Net) sera attribué à l’objet collé. Survolez l’image avec le curseur pour voir le résultat.
Lorsqu’un objet est collé sur une couche de cuivre et qu’il chevauche un ensemble d’objets du même type, le net de l’objet situé sous le curseur au moment du clic de collage lui est attribué.

Le net de l’objet situé sous le curseur est attribué à l’objet collé. L’exemple présenté ici montre un objet (une piste) collé sur un ensemble d’objets du même type (des pastilles). La pastille 2 étant l’objet situé sous le curseur au moment du clic de collage, son net (Pad2_Net) sera attribué à l’objet collé. Survolez l’image avec le curseur pour voir le résultat.
Lorsqu’un ensemble d’objets physiquement connectés est collé sur une couche de cuivre et que des objets de différents types de cet ensemble chevauchent des objets existants ayant des nets différents, le net de l’objet ayant la priorité la plus élevée dans cet ensemble est attribué à tous les objets collés. Les priorités indiquées ci-dessus s’appliquent dans ce cas.

Le net attribué à l’objet ayant la priorité la plus élevée est attribué à l’ensemble des objets physiquement connectés. L’exemple présenté ici montre un ensemble d’objets connectés (de gauche à droite : remplissage, région, piste, arc, via, polygone de cuivre) collé sur des objets (des vias) auxquels sont attribués différents nets. Le remplissage étant l’objet ayant la priorité la plus élevée dans cet ensemble collé, le net qui lui est attribué (Via1_Net) sera attribué à chaque objet de cet ensemble. Survolez l’image avec le curseur pour voir le résultat.
Verrouillage des objets de conception
Vous pouvez empêcher le déplacement ou la modification des objets de conception dans le document PCB en activant leurs attributs Locked . Par exemple, si la position ou la taille de certains objets est critique, verrouillez-les. Le verrouillage peut être effectué dans le panneau Properties en cliquant sur l’icône de cadenas des objets concernés, comme illustré dans les exemples suivants.
Exemples de l’icône Lock dans le panneau Properties pour un composant et une pastille sélectionnés.
Pour changer l’état de la propriété Locked d’un objet placé qui possède la propriété Locked , vous pouvez également faire un clic droit sur l’objet dans l’espace de conception et choisir la commande <ObjectType> Locked dans le menu contextuel. Lorsque l’objet est déjà verrouillé, une coche apparaît à gauche de la commande dans le menu.
Si vous tentez de déplacer ou de faire pivoter un objet de conception dont la propriété Locked est activée, une boîte de dialogue vous demande de confirmer la modification.
Verrouillage des primitives de composants
Si les primitives d’un composant PCB sont verrouillées (l’option Primitives du mode Composant du panneau Propriétés est à l’état , toutes ou la plupart des propriétés de ces primitives ne peuvent pas être modifiées à l’aide des méthodes d’édition graphiques (par exemple, par glisser-déposer) ou non graphiques (par exemple, à l’aide du panneau Properties ou List). Cela permet d’éviter les modifications accidentelles des primitives de composants qui pourraient entraîner des erreurs dans les fichiers de sortie destinés à l’assemblage et à la fabrication.
À titre d’exemple, le mode Pastille du panneau Propriétés est présenté dans l’image ci-dessous pour une pastille faisant partie d’un composant PCB dont les primitives sont verrouillées. Notez que toutes les propriétés de la pastille (à l’exception des propriétés Net et Testpoint) sont grisées et ne peuvent pas être modifiées. Notez également que l’icône
apparaît à l’extrémité droite de la propriété Component de la pastille. champ, qui indique que les primitives du composant parent sont verrouillées et que les propriétés des pastilles ne peuvent pas être modifiées.

Le mode Pad du panneau Properties (à gauche) pour une pastille d’un composant de PCB dont les primitives sont verrouillées (à droite).
Édition réentrante
L’éditeur de PCB comprend une fonctionnalité puissante appelée re-entrant editing. Elle permet d’exécuter une seconde opération à l’aide de raccourcis clavier sans interrompre l’opération en cours. L’édition réentrante vous permet de travailler de manière plus souple et intuitive. Par exemple, imaginez que vous commencez à placer une piste, puis que vous vous rendez compte qu’un autre segment de piste doit être supprimé. Il n’est pas nécessaire de quitter le mode Routage interactif. Appuyez sur les touches de raccourci E, D, supprimez le segment de piste concerné, puis appuyez sur la touche Esc pour reprendre le routage interactif de la conception.
Configuration de l’apparence du curseur PCB
Par défaut, le curseur PCB prend la forme d’une petite croix verte à 90 degrés. Vous pouvez le configurer à l’aide des paramètres Cursor Type et Cursor Color, sur la page Éditeur de PCB – Général de la boîte de dialogue Preferences . Par exemple, une grande croix à 90 degrés qui s’étend jusqu’aux bords de la fenêtre de conception (option Large 90) peut être utile pour placer et aligner les objets de conception. Une croix à 45 degrés (option Small 45) peut également être utile si les options à 90 degrés sont difficiles à distinguer des lignes de la grille.
Prise en charge des polices TrueType
L’éditeur de PCB permet d’utiliser des polices vectorielles à traits ou des polices TrueType pour les objets liés au texte dans une conception (chaînes/cadres de texte, cotes, tableaux de perçage et/ou tableaux d’empilage des couches). Le choix de la police s’effectue dans le panneau Properties associé. Trois options de polices vectorielles à traits sont disponibles : Default, Sans Serif et Serif. Le style Default est une police vectorielle simple qui prend en charge le traçage au stylo et le phototraçage vectoriel. Les polices Sans Serif et Serif sont plus complexes et ralentissent la génération des sorties vectorielles, telles que Gerber. Les polices vectorielles à traits sont intégrées au logiciel et ne peuvent pas être modifiées. Les trois polices disposent du jeu complet de caractères ASCII étendu IBM, qui prend en charge l’anglais et d’autres langues européennes. Lorsque vous utilisez des polices TrueType, les polices TrueType et OpenType (un sur-ensemble de TrueType) présentes dans le dossier \Windows\Fonts sont disponibles. Cette fonctionnalité offre également une prise en charge complète d’Unicode.
Les géométries des objets texte utilisant des polices TrueType sont automatiquement enregistrées dans les documents PCB. Lorsque des objets d’un document PCB utilisent une police TrueType, ils sont affichés avec la même géométrie de police lorsque le document PCB est ouvert sur un autre ordinateur, même si cette police TrueType n’y est pas installée.
Lorsqu’un objet utilisant une police manquante est sélectionné, un message d’avertissement apparaît en haut du panneau Properties. Lorsque vous modifiez des propriétés de l’objet qui affectent son texte (par exemple, la hauteur du texte ou le texte lui-même), la boîte de dialogue Missing fonts s’ouvre pour vous permettre de sélectionner une police de remplacement (Replacement). Activez l’option Apply to all text elements pour appliquer la police de remplacement à tous les objets du document PCB qui utilisent la police manquante.
La boîte de dialogue apparaît également lorsque vous modifiez des propriétés liées au texte depuis le panneau PCB List.
Lorsque vous tentez de modifier plusieurs objets utilisant différentes polices manquantes, la boîte de dialogue vous permet de sélectionner une police de remplacement pour chacune d’elles.
Prise en charge du rendu des arcs véritables
Les arcs véritables générés dans l’espace de conception de l’éditeur de PCB et de l’éditeur de bibliothèques PCB sont pris en charge, à la place d’approximations. Cette prise en charge s’étend aux modes de disposition 2D/3D (et au mode de planification de la carte dans l’éditeur de PCB). Le rendu des arcs véritables est visible dans les éléments suivants :
-
Remplissages polygonaux (pleins, hachurés, sans remplissage)
-
Découpes de remplissage polygonal
-
Contour de sélection des remplissages polygonaux et des régions
-
Régions
-
Expansions du masque de soudure et du masque de pâte
-
Mise en surbrillance des nets
-
Limites d’isolement
-
Superposition des violations (remplissage polygonal distinct sur une région ou un remplissage polygonal)
Des exemples de rendu des arcs véritables dans des remplissages polygonaux réalisés autour d’autres objets d’un PCB sont présentés ci-dessous.
Informations sur le net
Pour les objets en cuivre d’un PCB (piste, via, polygone, etc.), les informations suivantes sont présentées dans la section Net Information du panneau Properties lorsque l’objet est sélectionné :
- Le Net, la Diff Pair et/ou le xSignal parents, ainsi que la classe associée dans chaque cas. Notez que les entrées Diff Pair et xSignal ne sont affichées que si l’objet fait partie d’une paire différentielle ou d’un xSignal, respectivement.
-
Delay – le délai des objets sélectionnés et le délai des segments routés de l’ensemble du net. Inclut les valeurs Propagation Delay des pastilles et des vias, si elles ont été définies pour ces derniers.
-
Length – la somme des longueurs des objets sélectionnés et le total de Signal Length. Le Signal Length correspond au calcul précis de la distance totale de nœud à nœud. Les objets placés sont analysés afin de prendre en compte les objets superposés ou qui se chevauchent, ainsi que les parcours sinueux à l’intérieur des pastilles ; les longueurs des vias sont également incluses. Le Pin Package Length est aussi inclus s’il a été défini pour les pastilles. Si le net n’est pas entièrement routé, la longueur de Manhattan (X + Y) de la ligne de connexion est également incluse. Pour en savoir plus sur la longueur du signal et ses applications, consultez les informations relatives au panneau PCB - Nets.
-
Max Current - le courant maximal que les objets Piste, Arc ou Via sélectionnés peuvent supporter, déterminé à partir de la formule IPC-2221A (section 6.2) :
I = k * ΔT0.44 * A0.725
où :
I = courant [ampères]
A = aire de la section transversale [mils carrés] (largeur de piste * épaisseur de cuivre de l’empilage des couches, ou Afût, comme illustré ci-dessous)
ΔT = élévation de température admissible au-dessus de la température ambiante [°C]
k = constante, telle que :k = 0.048 pour les couches externes
k = 0.024 pour les couches internes -
Resistance - la somme des résistances des objets Piste, Arc et Via sélectionnés, déterminée à partir de la formule dérivée :
R = (ρ * L / A)
où :
R = résistance [Ω]
ρ = résistivité du cuivre [Ω*mm2/m]
L = longueur de piste [m] (ou longueur du via, comme décrit ci-dessous)
A = aire de la section transversale = T * W [mm2] (ou Afût, comme illustré ci-dessous)
T = épaisseur de piste (issue de l’empilage des couches) [mm]
W = largeur de piste [mm]Assumptions:
- Température ambiante = 22 °C
- Élévation de température admissible = 20 °C
- Épaisseur de la paroi en cuivre du trou traversant = 0.018 mm
- Résistivité du cuivre = 0.017 Ω*mm2/m

La zone Net Information du panneau Properties. Un exemple pour une piste sélectionnée est présenté ici.
Cliquez sur un lien dans la zone Net Information pour ouvrir le net, la paire différentielle ou le xSignal associé dans le panneau PCB.
Attribution de nets aux objets
L’éditeur de PCB propose plusieurs méthodes pour attribuer des nets aux objets primitifs :
- Lorsqu’un ou plusieurs objets sont sélectionnés, utilisez la liste déroulante du champ Nets dans le panneau Properties. Tous les nets de la conception de carte active figurent dans cette liste. Sélectionnez No Net pour indiquer que la piste n’est connectée à aucun net. Vous pouvez également cliquer sur l’icône Assign Net pour choisir un objet dans l’espace de conception : le net de cet objet sera attribué aux objets sélectionnés.
- Faites un clic droit sur un ou plusieurs objets sélectionnés, puis choisissez Net Actions » Assign Net. Après le lancement de la commande, un curseur en croix apparaît. Placez ce curseur sur le net auquel vous souhaitez attribuer les objets, puis cliquez pour sélectionner ce net.
- Pour resynchroniser le nom de net des primitives de routage avec le nom de net des pastilles auxquelles elles sont connectées, sélectionnez la commande Design » Netlist » Update Free Primitives From Component Pads dans les menus principaux. Après le lancement de la commande, une boîte de dialogue de confirmation s’ouvre et vous demande si vous souhaitez mettre à jour les nets des primitives libres avec ceux des pastilles des composants. Après avoir cliqué sur Yes, le cuivre connecté est sélectionné à partir de chaque pastille et le nom de net de chaque primitive est défini pour correspondre à celui de la pastille. Cette opération n’affecte pas la netlist interne du PCB.
Pour vérifier que les objets physiquement connectés sont bien affectés au net correspondant à cette connexion physique (dans ce cas, physical net signifie connected copper), vous pouvez utiliser la boîte de dialogue Configure Physical Nets, accessible en choisissant la commande Design » Netlist » Configure Physical Nets dans les menus principaux. Le logiciel analyse la conception et vérifie que toutes les pastilles et les objets qui les relient physiquement (pistes, arcs, remplissages, etc.) sont affectés au même nom de net. Lorsque tous les objets du net sont correctement affectés, le net s’affiche en vert. Si des objets en contact mais affectés à des nets différents sont détectés, ils sont signalés en rouge. Cela peut notamment se produire lorsqu’une empreinte de composant contient des objets en cuivre supplémentaires. Lorsque cette empreinte est chargée pendant la synchronisation, le nom de net attribué est appliqué à chaque pastille, mais pas aux objets en cuivre supplémentaires. La boîte de dialogue est interactive : cliquez sur un net ou une primitive pour localiser l’objet correspondant dans la conception. Faites un clic droit ou cliquez sur le bouton Menu pour accéder aux commandes disponibles. La zone Action de la boîte de dialogue propose des commandes permettant de définir les actions à effectuer pour résoudre les problèmes liés au cuivre connecté. Par défaut, les actions sont définies automatiquement, mais elles peuvent être ajustées selon les besoins. Une fois les actions définies, cliquez sur le bouton Execute pour mettre à jour les affectations de nets.

La boîte de dialogue Configure Physical Nets (avec l’option Only Show Errors activée à l’arrière-plan et l’option Only Show Errors désactivée au premier plan).
Options et commandes de la boîte de dialogue Configure Physical Nets
-
Electrically Connected Copper - cette zone répertorie les groupes distincts de primitives en cuivre électriquement connectées, tels qu’ils sont détectés dans le routage de la conception. Pour chaque groupe, les informations suivantes sont présentées :
-
Primitive - au niveau supérieur, cette entrée indique le nombre de primitives constituant le cuivre connecté. Les primitives peuvent être affichées sous forme de liste simple ou regroupées par type de primitive. Ce regroupement est configuré en activant l’option Show Primitive Groups dans les options du bouton Menu . Dans ce cas, les primitives sont réparties dans les groupes suivants :
- Connected Component Primitives - répertorie toutes les primitives de pastilles de composants comme éléments enfants. Celles-ci peuvent également être regroupées par composant parent en activant l’option Show Components du bouton Menu .
- Connected Free Primitives - répertorie toutes les primitives en cuivre n’appartenant pas à un composant comme éléments enfants, elles-mêmes regroupées par type de primitive (remplissages, polygones, pistes, vias).
-
Primitive - au niveau supérieur, cette entrée indique le nombre de primitives constituant le cuivre connecté. Les primitives peuvent être affichées sous forme de liste simple ou regroupées par type de primitive. Ce regroupement est configuré en activant l’option Show Primitive Groups dans les options du bouton Menu . Dans ce cas, les primitives sont réparties dans les groupes suivants :
- Original Net Names - ce champ indique le nom de net actuellement affecté à la primitive, c’est-à-dire le net auquel elle est actuellement connectée. L’entrée correspond à l’un des nets définis pour la carte. Toutefois, si une primitive n’est connectée à aucun net, l’entrée affichée est <Unassigned>.
-
Status - ce champ indique l’état global du groupe, qui peut prendre l’une des quatre valeurs suivantes :
- Blank - l'affectation des nets au groupe de cuivre connecté est entièrement correcte et aucune mise à jour n'est nécessaire. L'entrée de niveau supérieur du groupe est affichée en vert.
- 1. Update Required - Unassigned Nets - dans cet état, aucune des primitives du groupe n'a été affectée à un net. L'entrée de niveau supérieur du groupe est affichée en jaune.
- 2. Update Required - Some Unassigned Nets - dans cet état, certaines primitives ont été affectées au même net, mais d'autres n'ont aucune affectation. L'entrée de niveau supérieur du groupe est affichée en orange.
- 3. Ambiguous - Multiple Net Names - dans cet état, certaines primitives du groupe ont été affectées à des nets différents. Il peut également y avoir des primitives qui ne sont pas encore affectées. L'entrée de niveau supérieur du groupe est affichée en rouge.
-
Action - cette zone propose des commandes permettant de définir les actions à effectuer pour résoudre les problèmes liés au cuivre connecté, ainsi que le résultat de l'application des modifications configurées. Pour chaque groupe, les éléments suivants sont présentés :
-
Proposed Action - ce champ permet de déterminer l'action à effectuer, le cas échéant. Au niveau le plus élevé d'un groupe, cette entrée peut être définie sur Update Net To ou Don't Update Net To. Lors d'une mise à jour, choisissez le nouveau net cible dans le champ New Net Name. En fonction de ces deux paramètres, le logiciel calcule les actions à effectuer au niveau des primitives enfants et propose l'une des options suivantes :
- No Action Required - la primitive est déjà affectée/connectée au net cible.
- Update - inclure la primitive dans la mise à jour afin qu'elle soit affectée/connectée au nouveau net cible.
- Don't Update - ne pas inclure la primitive dans la mise à jour. Elle restera connectée à son net actuel.
- New Net Name - utilisez ce champ pour définir un nouveau net cible auquel les primitives doivent être connectées. La liste déroulante du champ répertorie tous les nets détectés parmi les primitives du groupe de cuivre connecté. Si vous devez utiliser un autre net, faites un clic droit sur le champ et utilisez la commande Change Copper Net To Board Net du menu contextuel. La boîte de dialogue Choose Net s'ouvre et répertorie tous les nets actuellement définis pour la carte. Choisissez le net souhaité, puis cliquez sur OK. Ce net sera renseigné dans le champ.
- Done - ce champ indique la réussite ou l'échec de la mise à jour après avoir cliqué sur le bouton Execute et appliqué les modifications.
-
Proposed Action - ce champ permet de déterminer l'action à effectuer, le cas échéant. Au niveau le plus élevé d'un groupe, cette entrée peut être définie sur Update Net To ou Don't Update Net To. Lors d'une mise à jour, choisissez le nouveau net cible dans le champ New Net Name. En fonction de ces deux paramètres, le logiciel calcule les actions à effectuer au niveau des primitives enfants et propose l'une des options suivantes :
- Execute - une fois que les actions affectées à la netlist vous conviennent, cliquez sur ce bouton pour mettre à jour les affectations des nets.
-
Menu - cliquez pour accéder au menu suivant, qui contient des commandes concernant la liste principale dans son ensemble ou les primitives actuellement sélectionnées. Ces commandes sont identiques à celles du menu contextuel de la zone de liste principale.
- Update/Don't Update/No Action - utilisez cette commande pour modifier rapidement l'action proposée pour les primitives sélectionnées. À un niveau parent supérieur dans la hiérarchie des primitives, utilisez-la pour modifier l'action proposée pour tous les enfants descendants.
- Select All - utilisez cette commande pour sélectionner rapidement tous les groupes de cuivre connecté (les entrées de niveau le plus élevé de la liste).
- Select All With Same Status - lorsqu'une entrée de niveau supérieur d'un groupe de cuivre connecté est sélectionnée, utilisez cette commande pour sélectionner rapidement tous les autres groupes de niveau supérieur ayant le même état.
- Clear All Selected - utilisez cette commande pour désélectionner toutes les entrées de la liste.
- Expand All In Connected Copper - utilisez cette commande pour développer rapidement tous les groupes enfants du groupe de cuivre connecté actuellement actif.
- Expand All - utilisez cette commande pour développer rapidement tous les groupes de tous les groupes de cuivre connecté de la liste.
- Expand Children - utilisez cette commande pour développer rapidement tous les groupes enfants descendants du groupe actuellement sélectionné.
- Collapse All In Connected Copper - utilisez cette commande pour réduire rapidement tous les groupes enfants du groupe de cuivre connecté actuellement actif.
- Collapse All - utilisez cette commande pour réduire rapidement tous les groupes de tous les groupes de cuivre connecté de la liste.
- Collapse Children - utilisez cette commande pour réduire rapidement tous les groupes enfants descendants du groupe actuellement sélectionné.
- Only Show Errors - activez cette option pour afficher uniquement les erreurs dans la boîte de dialogue. La liste présentera uniquement les groupes de cuivre connecté dont le Status est de niveau 1, 2 ou 3. Désactivez cette option pour afficher également le cuivre connecté correctement affecté.
- Show Components - activez cette option pour regrouper les primitives de pastilles de composants par composant parent.
- Show Primitive Groups - activez cette option pour regrouper les primitives par type de primitive.
- Animate Action Execution - activez cette option pour que la boîte de dialogue fasse défiler la liste au fur et à mesure de l'exécution, afin de visualiser en temps réel la progression des modifications des nets. Si cette option est désactivée, les modifications seront effectuées sans cette animation.
-
Warn On Netlist Change - activez cette option pour être averti lorsque les modifications affecteront la netlist de la carte. La boîte de dialogue Netlist Change s'ouvrira pour vous informer du nombre de primitives dont les nets seront modifiés et vous indiquer que cela affectera la netlist. Vous pouvez cliquer sur Continue ou sur Filter Affected pour examiner plus en détail les modifications proposées.

La boîte de dialogue Netlist Change - Show Component Pads - activez cette option pour afficher les primitives de composants connectées dans la liste.
- Show Non Component Pads - activez cette option pour afficher les primitives libres connectées dans la liste.
- Show Changes That Affect Netlist - activez cette option pour présenter uniquement la liste des actions proposées (modifications) qui affecteront la netlist de la carte.
- Change Copper Net To - une ou plusieurs entrées de menu de ce type apparaissent lorsque peu de nets sont actuellement affectés aux primitives du groupe de cuivre connecté actif. Utilisez une telle entrée pour choisir rapidement le net cible du champ New Net Name.
- Change Copper Net To Net - cette entrée de menu apparaît lorsque les nets actuellement affectés aux primitives d'un groupe de cuivre connecté sont trop nombreux pour être affichés sous forme d'entrées de menu individuelles. Cette commande ouvre la boîte de dialogue Choose Net, qui répertorie tous les nets actuellement affectés aux primitives du groupe. Choisissez le net souhaité, puis cliquez sur OK ; ce net sera renseigné dans le champ New Net Name du groupe de cuivre connecté actif.
- Change Copper Net To Board Net - utilisez cette commande si vous devez utiliser un net différent de ceux actuellement affectés aux primitives du groupe de cuivre connecté actif. La boîte de dialogue Choose Net s'ouvre et répertorie tous les nets actuellement définis pour la carte. Choisissez le net souhaité, puis cliquez sur OK ; ce net sera renseigné dans le champ New Net Name.
- Show All Primitives - cliquez sur ce bouton pour afficher rapidement toutes les primitives. Ce bouton devient disponible si les options Show Component Pads et/ou Show Non Component Pads sont désactivées dans le menu.
Vous pouvez également supprimer tous les nets du document de conception actuel, ce qui revient à vider la netlist interne du PCB. Cela peut être utile si vous avez modifié les informations des nets dans les documents schématiques sources et souhaitez resynchroniser entièrement votre PCB avec les informations de netlist du schéma source. Pour ce faire, choisissez Design » Netlist » Clear All Nets dans les menus principaux. Après le lancement de la commande, une boîte de dialogue de confirmation s’ouvre pour vous avertir que cette opération effacera toutes les informations de nets du PCB. Après avoir cliqué sur Yes, toutes les informations de nets seront supprimées. Les pistes routées resteront routées, mais leur affectation sera No Net. Toutes les connexions logiques non routées seront supprimées.
Pour créer un fichier de netlist à partir de la connectivité établie par le routage dans la conception actuelle, choisissez la commande Design » Netlist » Create Netlist From Connected Copper dans les menus principaux. Après avoir cliqué sur Yes dans la boîte de dialogue de confirmation qui s’ouvre, une netlist (Generated <PCBDocumentName>.Net, ajoutée au panneau Projects en tant que document libre dans le sous-dossier Source Documents) est créée dans le même dossier que le document de conception du PCB et s’ouvre automatiquement comme document actif. Chaque net de la netlist tire son nom de l’une des pastilles auxquelles le cuivre routé est connecté.

