Placement des composants
Altium Essentials: PCB Component Placement
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Vous comprendrez ce que comprend l’empreinte d’un composant de circuit imprimé, des pastilles et des éléments de sérigraphie aux éventuels corps 3D.
- Vous découvrirez quelles propriétés des composants dans Altium Designer influent sur leur placement, leur orientation, leur affectation à une couche et leur identification.
- Vous verrez comment les différents types de composants et les définitions de leur surface sont gérés dans l’éditeur de circuits imprimés.
On dit souvent que la conception d'un PCB repose à 90 % sur le placement et à 10 % sur le routage. Si ces proportions peuvent être discutées, il est généralement admis qu'un bon placement des composants est essentiel à une bonne conception de carte. N'oubliez pas que vous devrez peut-être aussi ajuster le placement au cours du routage.
L'empreinte du composant définit l'espace et les points de connexion nécessaires au montage du composant physique sur le circuit imprimé. Il s'agit d'un objet de groupe constitué d'un ensemble de primitives simples, notamment des pastilles, des lignes et des arcs, ainsi que d'autres objets de conception.

L'empreinte du composant définit son montage et ses connexions sur le PCB et peut également inclure des objets de corps 3D pour représenter le composant réel.
Les pastilles fournissent les points de montage et de connexion des broches du composant. Des primitives de conception supplémentaires, telles que des lignes et des arcs, sont souvent ajoutées pour définir le contour du composant sur la couche de sérigraphie.
L'empreinte du composant peut également inclure des objets de corps 3D facultatifs, qui définissent l'espace physique ou l'enveloppe du composant réel monté sur la carte. Si le composant physique a été défini à l'aide d'objets de corps 3D ou de modèles STEP importés, il est possible de vérifier les distances d'isolement entre composants en trois dimensions.
Les empreintes de composants sont créées dans l'éditeur d'empreintes PCB en plaçant les objets de conception appropriés pour obtenir la forme nécessaire au montage et à la connexion du composant. Le point de référence du composant correspond à l'origine de l'espace de conception de l'éditeur d'empreintes PCB. Il peut être défini dans l'éditeur au niveau de la broche 1, au centre géométrique ou à un emplacement du composant choisi par l'utilisateur. Pour en savoir plus sur la création d'empreintes, consultez la page Création d'une empreinte PCB.
Propriétés du composant

Le mode Component du panneau Properties.
Onglet Général
Emplacement
-
(X/Y)
-
X (premier champ) – coordonnée X (horizontale) actuelle du point de référence du composant par rapport à l'origine actuelle de l'espace de conception. Modifiez cette valeur pour changer la position du composant sur l'axe X. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent de celles définies par défaut. Le point de référence d'une empreinte de composant est défini dans l'éditeur de bibliothèque.
-
Y (deuxième champ) – coordonnée Y (verticale) actuelle du point de référence du composant par rapport à l'origine actuelle. Modifiez cette valeur pour changer la position du composant sur l'axe Y. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent de celles définies par défaut. Le point de référence d'une empreinte de composant est défini dans l'éditeur de bibliothèque.
-
-
Rotation – angle de rotation du composant (en degrés), mesuré dans le sens antihoraire à partir de zéro (l'horizontale 3 o'clock). Modifiez cette valeur pour changer la rotation du composant. La résolution angulaire minimale est de 0,001°.
Propriétés
-
Layer – définit la couche sur laquelle le composant est placé. Les composants peuvent être affectés à la couche supérieure ou inférieure. Utilisez la liste déroulante pour sélectionner une autre couche. Le changement de couche transfère toutes les primitives du composant sur la couche opposée correspondante. Par exemple, déplacer un composant de la couche supérieure vers la couche inférieure transfère les pastilles monocouches de la couche supérieure vers la couche inférieure, réaffecte les primitives de la sérigraphie supérieure à la sérigraphie inférieure et transfère les primitives d'une couche mécanique appariée vers l'autre couche mécanique de la paire. L'orientation du composant est inversée selon l'axe X et son texte de sérigraphie devient lisible depuis la face inférieure.
-
Reuse Block – lorsque le composant fait partie d'un bloc de réutilisation, ce champ affiche le nom du bloc de réutilisation parent. Cliquez sur le lien hypertexte Reuse Block pour afficher les propriétés de ce bloc de réutilisation.
-
Designator – le repère du composant est une chaîne alphanumérique pouvant contenir jusqu'à 255 caractères. Chaque composant doit avoir un repère unique. Cliquez sur
ou
pour afficher ou masquer le repère. Cliquez sur le lien hypertexte Designator pour ouvrir les propriétés du repère du composant.
-
Comment – le commentaire du composant est une chaîne alphanumérique pouvant contenir jusqu'à 255 caractères. Cliquez sur
ou
pour afficher ou masquer le commentaire. Cliquez sur le lien hypertexte Comment pour ouvrir les propriétés du commentaire du composant.
-
Area – la surface du composant placé, affichée dans les unités actuelles de la carte. Cette surface peut être définie par l'utilisateur ; sinon, elle est calculée automatiquement à partir de la zone de sélection du composant :
-
Pour définir la surface du composant, modifiez le champ Area dans le panneau Properties de l’empreinte dans l’éditeur d’empreintes de PCB. Pour transférer une empreinte mise à jour vers un PCB ouvert, faites un clic droit sur le nom de l’empreinte dans le panneau PCB Library, puis sélectionnez Update PCB With <ComponentName> dans le menu contextuel.
-
Vous pouvez également définir manuellement la surface d’un composant déjà placé sur un PCB en sélectionnant le composant, puis en saisissant la valeur dans ce champ.
-
Pour passer d’une surface définie par l’utilisateur à une surface calculée pour un composant placé sur un PCB, supprimez la valeur de ce champ ; celui-ci sera automatiquement renseigné avec la valeur calculée.
-
La surface calculée automatiquement correspond à la zone mise en surbrillance lorsque vous cliquez pour sélectionner le composant. La zone de sélection est déterminée à partir des géométries de la couche Courtyard ou, si cette couche est absente, à partir de la combinaison des géométries de la sérigraphie, des objets Corps 3D et des couches de cuivre (les chaînes de texte sont exclues). Les images du haut ci-dessous montrent la surface du composant lorsqu’un contour est défini sur la couche Courtyard ; l’image du bas montre la surface calculée à partir des géométries de la sérigraphie, des objets Corps 3D et des couches de cuivre.
► En savoir plus sur le calcul de la zone de sélection et les autres modes disponibles pour déterminer cette zone.
► En savoir plus sur l’utilisation des couches mécaniques.
-
-
Description – description propre à ce composant. Elle est généralement définie lors de la création du composant, mais elle peut également être modifiée ou ajoutée au composant sur le schéma. Il s’agit de la description affichée dans le panneau Components.
-
Type – sélectionnez ici l’un des types de composants suivants pour l’empreinte du composant. Les types disponibles sont :
-
Standard– ces composants possèdent des propriétés électriques standard, sont toujours synchronisés entre le schéma et le PCB (l’empreinte, les broches/pastilles et les affectations de nets doivent toutes correspondre) et sont inclus dans la nomenclature. Un composant électrique standard, comme une résistance, en est un exemple. -
Mechanical– ces composants n’ont pas de propriétés électriques, ne sont pas synchronisés (vous devez les placer manuellement dans les deux éditeurs) et sont inclus dans la nomenclature. Un dissipateur thermique en est un exemple. -
Graphical– ces composants n’ont pas de propriétés électriques, ne sont pas synchronisés (vous devez les placer manuellement dans les deux éditeurs) et ne sont not pas inclus dans la nomenclature. Un logo d’entreprise en est un exemple. -
Net Tie (in BOM)– ces composants servent à court-circuiter deux nets différents ou plus. Ils sont toujours synchronisés entre le schéma et le PCB (l’empreinte, les broches/pastilles et les affectations de nets doivent toutes correspondre) et sont inclus dans la nomenclature. Ils diffèrent d’un composant standard en ce que la connectivité créée par le cuivre à l’intérieur de l’empreinte n’est pas vérifiée : c’est ce cuivre qui permet de court-circuiter les nets. Remarque : activez l’option Verify Shorting Copper dans la boîte de dialogue Design Rule Checker pour vérifier qu’il n’y a pas de cuivre non connecté à l’intérieur du composant. -
Net Tie– ces composants servent à court-circuiter deux nets différents ou plus. Ils sont toujours synchronisés entre le schéma et le PCB (l’empreinte, les broches/pastilles et les affectations de nets doivent toutes correspondre) et ne sont not pas inclus dans la nomenclature. Ils diffèrent d’un composant standard en ce que la connectivité créée par le cuivre à l’intérieur de l’empreinte n’est pas vérifiée : c’est ce cuivre qui permet de court-circuiter les nets. Remarque : activez l’option Verify Shorting Copper dans la boîte de dialogue Design Rule Checker pour vérifier qu’il n’y a pas de cuivre non connecté dans le composant. -
Standard (No BOM)– ces composants possèdent des propriétés électriques standard, sont toujours synchronisés entre le schéma et le PCB (l’empreinte, les broches/pastilles et les affectations de nets doivent toutes correspondre) et ne sont not pas inclus dans la nomenclature. Un composant de point de test que vous souhaitez exclure de la nomenclature en est un exemple. -
Jumper– ces composants servent à inclure des straps dans une conception de PCB, par exemple sur un PCB simple face qui ne peut pas être entièrement routé sur une seule couche. Pour ce type de composant, l’empreinte et les broches sont synchronisées entre le schéma et le PCB, mais pas les affectations de nets, et le composant est inclus dans la nomenclature. Outre la sélection de cette option au niveau du composant, les deux pastilles du composant doivent avoir leur JumperID défini sur la même valeur non nulle. Les composants de type Jumper n’ont pas besoin d’être câblés sur le schéma ; ils doivent uniquement y figurer s’ils sont requis dans la nomenclature. S’ils ne sont pas requis dans la nomenclature, ils peuvent être placés directement sur le PCB, où le Component Type est défini, les JumperIDs sont définis et le Nets est affecté manuellement aux pastilles.
-
-
Design Item ID – affiche l’identifiant Design Item ID du composant sélectionné. Ce champ n’est pas modifiable.
-
Source – affiche le document source du composant. Cliquez sur
pour ouvrir une boîte de dialogue permettant de rechercher et de sélectionner un autre document source.
-
Revision State – indique l’état de la révision du composant de la bibliothèque du Workspace, aussi bien son état dans le cycle de vie que son statut de révision, c’est-à-dire s’il s’agit de la dernière révision publiée de ce composant (
Up to date) ou d’une révision antérieure (Out of date). -
Height – champ de hauteur du composant. Ce champ définissait la hauteur du composant de PCB avant l’introduction de l’objet Corps 3D. Toutefois, le modèle 3D offre une meilleure méthode pour définir la hauteur du composant pour des tâches telles que la détection de collisions en 3D. Notez qu’Altium MCAD CoDesigner utilise la valeur définie dans ce champ Height, et non la hauteur du modèle 3D (en savoir plus).
-
3D Body Opacity – saisissez le pourcentage d’opacité souhaité ou utilisez le curseur.
-
Primitives – cliquez sur l’icône de cadenas associée pour verrouiller/déverrouiller.
– verrouiller toutes les primitives du composant afin qu’il puisse être traité comme un objet unique.
– déverrouiller pour modifier les différentes primitives qui constituent le composant. Après modification, les primitives du composant doivent être à nouveau verrouillées.
-
Strings – cliquez sur l’icône de cadenas associée pour verrouiller/déverrouiller.
– verrouiller toutes les chaînes de texte du composant.
– déverrouiller pour modifier les chaînes de texte du composant.
Empreinte
- Footprint Name – affiche le nom de l’empreinte correspondant au composant choisi.
- Design Item ID – l’identifiant du composant choisi.
- Source – nom de l’espace de travail dans lequel le composant choisi a été placé.
- Description – description de l’empreinte du composant, définie dans l’éditeur d’empreintes PCB.
Options de permutation
- Enable Pin Swapping – cochez cette case pour autoriser la permutation des broches.
- Enable Part Swapping – cochez cette case pour autoriser la permutation des unités (par exemple, les quatre unités d’un circuit intégré de la série 74).
Informations de référence du schéma
- Designator – le repère du composant du schéma auquel ce composant PCB a été associé.
- Hierarchical Path – indique où se trouve ce composant dans la structure hiérarchique du schéma.
- Channel Offset – lors du premier transfert d’une conception du schéma vers le PCB, chaque composant de chaque feuille de schéma reçoit un décalage de canal unique.
Onglet Paramètres
- Table – affiche les éléments Name, Value et Source de chaque paramètre répertorié.
Repères et commentaires des composants
Les champs de repère et de commentaire sont des objets paramètres enfants d’un composant PCB. Le repère sert à identifier de manière unique chaque composant placé afin de le distinguer de tous les autres composants placés dans l’ensemble des documents PCB du projet. Le commentaire sert à ajouter des informations complémentaires à un objet placé. Le commentaire et le repère sont tous deux configurés après le placement du composant parent. Il ne s’agit pas d’objets de conception que vous pouvez placer directement.

Un objet Repère placé
Les repères des composants PCB 2D/3D sont automatiquement incrémentés de un lors du placement si le composant initial possède un repère se terminant par un chiffre. Modifiez le repère du premier composant avant son placement dans le panneau Propriétés.
Pour obtenir des incréments alphabétiques ou numériques de repères autres que 1, utilisez la fonction Paste Array. Les commandes de cette fonction sont disponibles dans la boîte de dialogue Configuration du collage en réseau, accessible en appuyant sur le bouton Paste Array dans la boîte de dialogue Paste Special (Edit » Paste Special).
La méthode d’édition graphique vous permet de sélectionner un objet repère ou commentaire placé directement dans l’espace de conception et de modifier sa position, sa rotation, son orientation et sa taille.
Lorsqu’un objet repère ou commentaire est sélectionné, les poignées d’édition suivantes sont disponibles :

Un repère sélectionné
- Cliquez sur B et faites glisser pour faire pivoter le repère/commentaire autour de son point de référence A (indiqué par le petit x).
- Cliquez sur C et faites glisser pour redimensionner le cadre englobant du repère/commentaire simultanément dans les directions verticale et horizontale.
- Cliquez sur D et faites glisser pour redimensionner le cadre englobant du repère/commentaire séparément dans les directions verticale et horizontale.
-
Cliquez n’importe où sur le repère/commentaire, à l’écart des poignées d’édition, et faites glisser pour le repositionner. Pendant le déplacement, le commentaire peut être pivoté ou mis en miroir :
- Appuyez sur Spacebar pour faire pivoter le repère/commentaire dans le sens antihoraire, ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. La rotation s’effectue selon la valeur de Rotation Step définie sur la page Éditeur PCB – Général de la boîte de dialogue Preferences.
- Appuyez sur les touches X ou Y pour appliquer une symétrie au repère/commentaire selon l’axe X ou Y.
Les propriétés d’un objet Repère ou Commentaire peuvent être modifiées dans le mode Parameter du panneau Properties.
Propriétés des paramètres

Le mode Parameter du panneau Properties.
Position
-
(X/Y)
-
X (premier champ) - la coordonnée X (horizontale) actuelle du point de référence du repère par rapport à l’origine actuelle de l’espace de travail. Modifiez cette valeur pour changer la position X du repère. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si celles de la valeur saisie ne sont pas les unités par défaut actuelles.
-
Y (deuxième champ) - la coordonnée Y (verticale) actuelle du point de référence du repère par rapport à l’origine actuelle. Modifiez cette valeur pour changer la position Y du repère. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si celles de la valeur saisie ne sont pas les unités par défaut actuelles.
-
- Rotation - l’angle de rotation du repère (en degrés), mesuré dans le sens antihoraire à partir de zéro (l’horizontale 3 o'clock). Modifiez cette valeur pour changer la rotation du repère. La résolution angulaire minimale est de 0,001°.
Propriétés
-
Parameter type - affiche le type de paramètre (Composant, Symbole de feuille, etc.) et le nom du paramètre.
-
Name - le nom du repère.
-
Value - utilisez ce champ pour saisir la valeur souhaitée du repère. Cliquez sur l’icône en forme d’œil pour afficher ou masquer la valeur dans l’espace de conception.
-
Layer - utilisez la liste déroulante pour sélectionner la couche souhaitée. Activez Mirror si nécessaire.
-
Autoposition - utilisez la liste déroulante pour sélectionner la position automatique souhaitée par rapport à l’objet associé.
-
Text Height - utilisez ce champ pour saisir la hauteur de texte souhaitée.
-
Font Type
-
TrueType - sélectionnez cette option pour utiliser les polices disponibles sur votre PC (dans le dossier \Windows\Fonts ). Les polices TrueType prennent entièrement en charge Unicode. Par défaut, le logiciel établit un lien vers les polices TrueType utilisées (elles ne sont pas stockées dans le fichier PCB), ce qui signifie que ces mêmes polices doivent être présentes sur chaque PC vers lequel la conception est transférée. Vous pouvez également incorporer les polices TrueType utilisées dans le fichier PCB à l’aide des options de la page Éditeur PCB - Polices TrueType de la boîte de dialogue Preferences, où vous pouvez aussi sélectionner une Substitution Font à utiliser lorsqu’une police non incorporée n’est pas disponible.
-
Justification - permet de définir la position du repère dans le rectangle d’encadrement.
- Left - cliquez sur le bouton de gauche pour aligner le texte horizontal à gauche.
- Center - cliquez sur le bouton central pour centrer le texte horizontal.
- Right - cliquez sur le bouton de gauche pour aligner le texte horizontal à droite.
- Above - cliquez sur le bouton du haut pour aligner le texte vertical en haut.
- Middle - cliquez sur le bouton du milieu pour aligner le texte vertical au milieu.
- Below - cliquez sur le bouton du bas pour aligner le texte vertical en bas.
-
Font - utilisez la liste déroulante pour sélectionner la police TrueType souhaitée. Utilisez les options B (bold) et/ou I (italic) pour mettre le texte en valeur selon vos besoins.
-
Inverted - utilisez pour afficher le texte en négatif tout en contrôlant la taille de la bordure qui l’entoure. Vous pouvez utiliser les options suivantes pour configurer davantage le texte :
-
Size (Width/Height) -
- Width - la largeur du rectangle d’encadrement.
- Height - la hauteur du rectangle d’encadrement.
-
Size (Width/Height) -
-
Inverted - utilisez pour afficher le texte en négatif tout en contrôlant la taille de la bordure qui l’entoure. Vous pouvez utiliser les options suivantes pour configurer davantage le texte :
-
-
Stroke
-
Justification - permet de définir la position du repère dans le rectangle d’encadrement.
- Left - cliquez sur le bouton de gauche pour aligner le texte horizontal à gauche.
- Center - cliquez sur le bouton central pour centrer le texte horizontal.
- Right - cliquez sur le bouton de gauche pour aligner le texte horizontal à droite.
- Above - cliquez sur le bouton du haut pour aligner le texte vertical en haut.
- Middle - cliquez sur le bouton du milieu pour aligner le texte vertical au milieu.
- Below - cliquez sur le bouton du bas pour aligner le texte vertical en bas.
-
Font - utilisez la liste déroulante pour sélectionner la police vectorielle souhaitée. Les choix sont les suivants :
-
Default- une police vectorielle simple conçue pour le traçage à la plume et le phototraçage vectoriel. -
Sans Serif- une police complexe qui ralentit la génération des sorties vectorielles, telles que les fichiers Gerber. -
Serif- une police complexe qui ralentit la génération des sorties vectorielles, telles que les fichiers Gerber.
-
- Stroke Width - affiche la largeur du trait.
-
Justification - permet de définir la position du repère dans le rectangle d’encadrement.
-
TrueType - sélectionnez cette option pour utiliser les polices disponibles sur votre PC (dans le dossier \Windows\Fonts ). Les polices TrueType prennent entièrement en charge Unicode. Par défaut, le logiciel établit un lien vers les polices TrueType utilisées (elles ne sont pas stockées dans le fichier PCB), ce qui signifie que ces mêmes polices doivent être présentes sur chaque PC vers lequel la conception est transférée. Vous pouvez également incorporer les polices TrueType utilisées dans le fichier PCB à l’aide des options de la page Éditeur PCB - Polices TrueType de la boîte de dialogue Preferences, où vous pouvez aussi sélectionner une Substitution Font à utiliser lorsqu’une police non incorporée n’est pas disponible.
-
Border Mode
-
Margin - cliquez sur ce bouton pour activer la modification de l’option Bordure de marge.
- Text Offset - la distance de retrait du repère par rapport au bord ou au coin sur lequel il est aligné. Cette option n’a aucun effet lorsque le mode de justification Center est sélectionné. Cette option n’est pas disponible pour Margin.
-
Offset - cliquez sur ce bouton pour activer la modification de l’option Décalage du texte.
- Margin Border - permet de spécifier la taille de la bordure de marge entourant le repère. Cette option n’est pas disponible pour Offset.
-
Margin - cliquez sur ce bouton pour activer la modification de l’option Bordure de marge.
Disponibilité des composants sur le PCB
Lorsque la conception est transférée de l’éditeur de schémas vers l’éditeur PCB, les empreintes des composants sont automatiquement placées à partir des bibliothèques disponibles. C’est ce que l’on appelle la synchronisation de la conception, un processus qui permet de détecter et de résoudre les différences entre le schéma et le PCB.
Altium Designer propose un ensemble d’outils facilitant le placement de l’empreinte de composant requise dans l’espace de conception PCB. Consultez les pages suivantes pour en savoir plus sur ces outils :
Parcourir les composants placés
Dans le mode du panneau PCB Components, ses trois zones principales changent pour refléter la hiérarchie des composants de la conception PCB actuelle (de haut en bas) :
- Component Classes
- Components au sein d’une classe
- Component Primitives

Les zones du panneau PCB permettent d’effectuer une sélection par filtrage cumulatif, des classes de composants aux composants individuels, puis aux primitives des composants.
Faites un clic droit sur une entrée de composant ou de primitive de composant, puis choisissez la commande Properties (ou double-cliquez directement sur l’entrée) pour accéder au panneau Properties, dans lequel vous pouvez consulter ou modifier les propriétés du composant ou de la primitive selon vos besoins.
Faites un clic droit sur une entrée de classe de composants, puis choisissez Properties (ou double-cliquez directement sur l’entrée) pour ouvrir la boîte de dialogue Modifier la classe de composants correspondant à cette classe. Cette boîte de dialogue vous permet de consulter ou de modifier les composants appartenant à la classe, de la renommer ou d’ajouter d’autres classes.

Modification d’une classe de composants sélectionnée.
L’affichage ou l’inclusion de chaque type de primitive de composant dans la zone Component Primitives du panneau dépend de l’activation de l’option correspondante dans le menu contextuel accessible depuis les zones Components ou Component Primitives.

Faites un clic droit sur une entrée de composant ou de primitive de composant pour sélectionner les éléments à inclure.
Lors de la navigation, vous pouvez facilement verrouiller ou déverrouiller les composants en double-cliquant dans la case située à droite de la colonne Footprint dans la zone Components.

Le verrouillage et le déverrouillage depuis le panneau PCB vous évitent d’avoir à passer par le panneau Properties.
Cadre de sélection des composants
Lorsque vous cliquez sur un composant pour le sélectionner, son cadre de sélection apparaît. Pour déterminer les couches utilisées pour définir ce cadre, vous pouvez utiliser l’option PCB.ComponentSelection dans la boîte de dialogue Advanced Settings. Cette option propose trois modes (saisissez la valeur 0, 1 ou 2 ; le mode par défaut est 2) :
-
0 - legacy mode- ce mode combine les géométries de toutes les couches, à l’exception des chaînes de texte du repère et du commentaire sur la sérigraphie. -
1 - by layer mode- utilise les géométries de la première couche de la liste ci-dessous contenant des objets, selon l’ordre de priorité suivant :-
Type de couche Courtyard
-
Couche de corps 3D (les modèles STEP sont stockés dans un objet corps 3D dont les dimensions correspondent au plus petit prisme rectangulaire contenant le modèle. Pour la sélection du composant, c’est ce corps 3D qui est utilisé, et non la forme du modèle STEP)
-
Couche de sérigraphie et couches de cuivre
-
Couches de cuivre
-
-
2 - by graphic mode- ce mode combine les géométries détectées sur les couches de type Courtyard, la sérigraphie, les objets corps 3D et les couches de cuivre. Les chaînes de texte sont exclues.
Ajout de primitives à un composant
Les primitives sélectionnées peuvent être ajoutées à un composant en choisissant la commande Tools » Convert » Add Selected Primitives to Component dans les menus principaux. Après avoir sélectionné la commande, choisissez le composant auquel vous souhaitez ajouter les primitives sélectionnées. Après confirmation, les nouvelles primitives seront reconnues comme faisant partie de l’objet composant unique et pourront être utilisées conjointement avec les primitives d’origine du composant.
Les primitives du composant cible doivent être déverrouillées pour effectuer cette opération. Utilisez l’icône de verrouillage Primitives dans les propriétés du composant pour déverrouiller ses primitives.
Décomposition d’un composant en primitives
Un composant peut être converti en ses objets primitifs constitutifs à l’aide de la commande Tools » Convert » Explode Component to Free Primitives des menus principaux, ou en cliquant avec le bouton droit sur un composant placé (sélectionné ou non), puis en choisissant la commande Component Actions » Explode Component To Free Primitives (ou Explode Selected Components To Free Primitives) dans le menu contextuel. Un composant décomposé n’est plus un composant : son repère et son commentaire sont donc supprimés, et il redevient un ensemble de primitives.
La décomposition n’a aucun effet sur le modèle d’empreinte stocké dans la bibliothèque source correspondante ; elle affecte uniquement les instances converties des composants placés dans le document PCB.
Accès aux informations de référence par des liens cliquables
Lorsque des liens nommés vers des documents ont été ajoutés au composant, vous pouvez ouvrir l’URL du document ou de la page indiquée, spécifiée par un paramètre de lien URL sous-jacent défini, pour le composant sélectionné ou celui situé sous le curseur. Cette fonctionnalité permet de présenter les liens nommés vers des documents transférés depuis les composants du schéma sous forme de liens nommés de composants PCB vers des PDF, des fichiers texte ou des pages HTML. Cela se produit lorsque les liens nommés vers des documents du composant ont été mis à jour depuis le schéma vers le PCB (Design » Update PCB Document). Lors de ce processus de mise à jour (via un ECO), les liens nommés vers des documents du schéma sont convertis en paires de paramètres ComponentLink (ComponentLinknDescription/ComponentLinknURL) pour le composant PCB correspondant. Par exemple :
| Paramètre du composant du schéma | Paramètres du composant PCB | |||
|---|---|---|---|---|
| Name | Url |
⇒ |
Name | Value |
STM32 Family Web Page |
http://www.st.com/stm32 |
ComponentLink1Description |
STM32 Family Web Page |
|
ComponentLink1URL |
http://www.st.com/stm32 |
|||
Le numéro d’index du lien (n) utilisé dans les paramètres du composant définit la position du lien de composant PCB correspondant dans le sous-menu References. Lorsqu’un composant est sélectionné sur le PCB, les paires de paramètres ComponentLink définies sont présentées dans la section Parameters du panneau Properties.
Après le lancement de la commande, la page Web cible de l’URL ou le document indiqué s’ouvre directement (si disponible).


).