Conception haute vitesse

En un coup d'œil

Cet article explique comment Altium Designer facilite le routage des circuits imprimés à haute vitesse en vous aidant à gérer l’intégrité des signaux, à définir les chemins de signaux critiques et à appliquer des règles de routage à impédance contrôlée en fonction de l’empilage et des matériaux de votre carte. Il présente les principaux éléments de conception à prendre en compte, explique comment l’analyse de l’intégrité des signaux avant et après le routage permet de détecter les problèmes de réflexion en amont, et montre comment les fonctionnalités telles que les xSignals, les profils d’impédance et les règles de routage se complètent pour guider une mise en œuvre précise des circuits à haute vitesse. Si vous souhaitez mieux comprendre comment configurer Altium Designer pour concevoir des cartes à haute vitesse fiables, cette vue d’ensemble vous aidera à faire le lien entre les outils et les paramètres essentiels. Poursuivez votre lecture pour gagner en assurance, étape par étape.

- Découvrez les principaux facteurs de conception à haute vitesse qu’Altium Designer vous aide à maîtriser, des terminaisons et des chemins de retour aux vias, aux paires différentielles et au contrôle des longueurs.
- Découvrez comment utiliser l’analyse de l’intégrité des signaux avant et après le routage pour repérer les problèmes potentiels de réflexion et affiner les choix de terminaison.
- Apprenez à utiliser les xSignals, les profils d’impédance de l’empilage des couches et les règles de conception de routage pour définir, mesurer et contrôler les liaisons critiques à haute vitesse.
Approfondissez avec l'IA :

Conception à haute vitesse dans Altium Designer

La conception de circuits imprimés à haute vitesse consiste à trouver un équilibre entre les exigences de conception du circuit, les technologies des composants, ainsi que les matériaux et les méthodes de fabrication, afin de réaliser un PCB capable de transmettre les signaux entre les composants tout en préservant leur intégrité.

Cette page décrit les différentes options et les différents paramètres à configurer dans Altium Designer pour réussir la conception de votre carte à haute vitesse. Si vous souhaitez en savoir plus sur la conception à haute vitesse, consultez les Éléments clés de la conception de PCB à haute vitesse.

Éléments à prendre en compte

Le routage d’une carte comportant des signaux à haute vitesse nécessite de gérer les éléments suivants :

  • Les composants de terminaison éventuellement nécessaires

  • La définition des signaux auxquels appliquer des règles de conception à haute vitesse

  • Les dimensions physiques des pistes, pour le routage à impédance contrôlée

  • Les propriétés et les dimensions des matériaux de la carte

  • Le nombre et la disposition des couches dans l’empilage

  • Le chemin de retour de chaque signal à haute vitesse

  • L’impact et la configuration des vias

  • La configuration et le routage des paires différentielles

  • La configuration et le contrôle des longueurs de routage

Analyse de l’intégrité du signal avant et après le routage

Il est important d’identifier, dès le début du processus de conception, les signaux susceptibles de nécessiter une adaptation d’impédance afin de pouvoir ajouter des composants de terminaison avant la fin du placement des composants. Les broches de sortie présentant généralement une faible impédance et les broches d’entrée une impédance élevée, il peut être nécessaire d’ajouter des composants de terminaison à la conception pour assurer l’adaptation d’impédance.

Altium Designer comprend un simulateur d’intégrité du signal accessible pendant les phases de saisie de la conception et de routage de la carte, ce qui permet d’analyser l’intégrité du signal avant et après le routage (Tools » Signal Integrity). Le simulateur d’intégrité du signal modélise le comportement de la carte routée en utilisant comme données d’entrée l’impédance caractéristique calculée des pistes, combinée aux informations des macromodèles des buffers d’E/S . Il repose sur un simulateur rapide de réflexion et de diaphonie, qui produit des simulations très précises à l’aide d’algorithmes éprouvés dans l’industrie.

La saisie de la conception et la conception de la carte utilisent toutes deux un système de composants intégré qui associe les symboles schématiques aux empreintes PCB, aux modèles de simulation SPICE et aux macromodèles d’intégrité du signal correspondants. L’analyse de l’intégrité du signal peut donc être effectuée dès la saisie du schéma, avant la création de la carte. Lorsqu’aucune carte n’a encore été créée, l’outil permet de définir les caractéristiques physiques de la conception, telles que l’impédance caractéristique souhaitée des pistes, directement dans le simulateur d’intégrité du signal. À ce stade préalable au routage, le simulateur ne peut pas déterminer la longueur réelle de certaines connexions : il utilise donc une longueur de connexion moyenne, définie par l’utilisateur, pour effectuer ses calculs de lignes de transmission. En choisissant soigneusement cette longueur par défaut pour qu’elle reflète les dimensions de la carte prévue, vous pouvez obtenir une estimation assez précise des performances probables de la conception en matière d’intégrité du signal.

Les nets présentant des problèmes potentiels de réflexion peuvent être identifiés, et les composants de terminaison supplémentaires nécessaires peuvent être ajoutés au schéma avant de passer au routage de la carte. Les valeurs de ces composants peuvent ensuite être affinées après l’analyse de l’intégrité du signal effectuée à l’issue du routage.

Le moteur d’analyse de l’intégrité du signal aide à identifier les nets présentant des problèmes potentiels de réflexion. Notez que les mesures peuvent être effectuées directement sur les formes d’onde.
Le moteur d’analyse de l’intégrité du signal aide à identifier les nets présentant des problèmes potentiels de réflexion. Notez que les mesures peuvent être effectuées directement sur les formes d’onde.

► En savoir plus sur l’adaptation d’impédance des composants

Pour accéder au moteur d’analyse de l’intégrité du signal dans Altium Designer, l’extension système Signal Integrity Analysis doit être installée. Cette extension est installée par défaut avec Altium Designer. Elle peut être installée ou supprimée manuellement.

Pour plus d’informations sur la gestion des extensions, consultez la page Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Définition des signaux à haute vitesse

Main page: Définition des chemins des signaux à haute vitesse avec xSignals

La conception à haute vitesse est l’art de gérer le flux d’énergie d’un point à un autre d’un circuit imprimé. En tant que concepteur, vous devez pouvoir concentrer votre attention et appliquer les contraintes de conception à un signal qui circule d’un point de la carte à un autre. Toutefois, ce signal ne correspond pas nécessairement à un seul net du PCB. Il peut s’agir d’une branche de A0 dans une conception que vous prévoyez de router selon une topologie en T, l’autre branche de A0 constituant un autre signal qui nécessite également votre attention. Vous devez alors pouvoir comparer les longueurs de routage de ces deux signaux. Le signal peut aussi comporter un composant de terminaison en série sur son trajet, que l’éditeur PCB considère comme un composant et deux nets PCB. Si ce signal fait partie d’une paire différentielle, sa longueur doit être comparée à celle de l’autre signal de la paire.

Vous pouvez gérer ces exigences à l’aide de la fonctionnalité xSignals, un xSignal étant essentiellement un chemin de signal défini par l’utilisateur. Sélectionnez la pastille source et la pastille cible, dans l’espace de travail ou dans le panneau PCB, puis faites un clic droit sur l’une d’elles pour définir ce chemin de signal comme un xSignal. Outre la définition interactive d’un xSignal par ses pastilles de départ et d’arrivée, vous pouvez lancer l’assistant intelligent xSignals Wizard, dont les heuristiques vous aideront à configurer rapidement un grand nombre de xSignals entre les composants choisis. Ces xSignals peuvent ensuite servir à appliquer des règles de conception à vos signaux à haute vitesse. Le logiciel comprend la structure de ces xSignals : il peut, par exemple, calculer la longueur totale de plusieurs nets reliés par un composant de terminaison, ainsi que la distance parcourue à travers ce composant.

Le panneau PCB comprend un mode xSignal permettant d’examiner et de gérer les xSignals. Il fournit également des informations sur la longueur des signaux, en mettant en évidence les xSignals proches des limites des contraintes de conception applicables (en jaune) ou qui ne les respectent pas (en rouge). Dans l’image ci-dessous, l’écart entre les longueurs des xSignals de la paire différentielle CLK1 dépasse la valeur autorisée par la règle de conception d’égalisation des longueurs applicable. Le panneau comprend la Signal Length, qui correspond à une longueur précise de point à point. Les sources habituelles d’incohérences de longueur, telles que les pistes à l’intérieur des pastilles et les segments de piste superposés, sont prises en compte, et les distances exactes traversées par les vias sont utilisées pour calculer la longueur du signal.

Utilisez le mode xSignals du panneau PCB pour gérer et examiner vos xSignals. Remarquez la ligne fine : elle indique le chemin du signal à travers un composant en série. (Image reproduite avec l’aimable autorisation de FEDEVEL Open Source, www.fedevel.com)
Utilisez le mode xSignals du panneau PCB pour gérer et examiner vos xSignals. Remarquez la ligne fine : elle indique le chemin du signal à travers un composant en série. (Image reproduite avec l’aimable autorisation de FEDEVEL Open Source, www.fedevel.com)

Le retard dû à la longueur de la broche à l’intérieur du boîtier du composant est également pris en charge, en définissant le retard de broche dans le boîtier.

► En savoir plus sur xSignals.

Définition des propriétés du routage

Main page: Routage à impédance contrôlée

Traditionnellement, les concepteurs de circuits imprimés définissaient la largeur et l’épaisseur des pistes en saisissant une valeur de largeur et en sélectionnant une épaisseur de cuivre pour la couche concernée. Cela suffisait généralement, puisqu’il fallait simplement s’assurer que les pistes pouvaient supporter le courant et que les distances d’isolement requises pour la tension étaient respectées. Cette approche ne suffit pas pour les signaux à haut débit de votre conception : vous devez contrôler l’impédance de leurs pistes.

Le routage à impédance contrôlée consiste à configurer les dimensions des pistes et les propriétés des matériaux du circuit imprimé afin d’obtenir une impédance spécifique. Pour cela, il faut définir un profil d’impédance adapté, puis l’affecter aux nets critiques à haut débit dans les règles de conception du routage.

Définition du profil d’impédance

Main page: Configuration de l’empilage des couches pour le routage à impédance contrôlée

Les profils d’impédance sont définis dans le Layer Stack Manager (Design » Layer Stack Manager) de l’éditeur de PCB. Le Layer Stack Manager s’ouvre dans un éditeur de documents, de la même manière qu’une feuille de schéma, un PCB ou d’autres types de documents.

Une fois les propriétés des couches configurées, passez à l’onglet Layer Stack Manager's Impedance pour ajouter ou modifier des profils d’impédance en mode asymétrique ou différentiel.

Un profil d’impédance de 50 Ω défini pour des nets individuels routés sur la couche supérieure. Survolez l’image avec le curseur pour afficher les paramètres du même profil pour la couche L3.Un profil d’impédance de 50 Ω défini pour des nets individuels routés sur la couche supérieure. Survolez l’image avec le curseur pour afficher les paramètres du même profil pour la couche L3.

Les calculs d’impédance sont effectués par le moteur électromagnétique d’intégrité du signal Simbeor® SFS de Simberian. Simbeor SFS est un solveur de champ 2D quasi statique avancé basé sur la méthode des moments, validé par des études de convergence, des comparaisons et des mesures. Le moteur Simbeor SFS prend en charge toutes les structures et tous les matériaux modernes de circuits imprimés, y compris l’utilisation de polygones sur les couches de signal comme plans de référence.

► En savoir plus sur la configuration de l’empilage des couches pour le routage à impédance contrôlée

Configuration des règles de conception

L’impédance du routage est déterminée par la largeur et l’épaisseur de la piste, ainsi que par les propriétés des matériaux diélectriques environnants. À partir des propriétés des matériaux définies dans le Layer Stack Manager, les largeurs de piste requises sont calculées lors de la création de chaque profil d’impédance. Selon les propriétés des matériaux, la largeur peut varier lorsque vous changez de couche de routage. Cette nécessité de modifier la largeur lors d’un changement de couche de routage est gérée automatiquement par la règle de conception de routage applicable, configurée dans l’éditeur de règles et de contraintes du PCB (Design » Rules).

Dans la plupart des conceptions de circuits imprimés, un ensemble précis de nets doit être routé avec une impédance contrôlée. Une approche courante consiste à créer une classe de nets ou de paires différentielles regroupant ces nets, puis à créer une règle de routage ciblant cette classe, comme illustré dans les images ci-dessous.

Normalement, vous définissez manuellement les largeurs minimale, maximale et préférée, soit dans les paramètres de contrainte de la partie supérieure pour les appliquer à toutes les couches, soit individuellement pour chaque couche dans le tableau des couches. Pour le routage à impédance contrôlée, activez plutôt l’option Use Impedance Profile, puis sélectionnez le profil d’impédance souhaité dans la liste déroulante. La zone Constraints de la règle est alors modifiée. Vous remarquerez d’abord que la zone des couches disponibles de la règle de conception n’affiche plus toutes les couches de signal du circuit imprimé, mais uniquement celles activées dans le profil d’impédance sélectionné. Les valeurs de largeur préférée (et d’espacement des paires différentielles) sont mises à jour pour refléter les largeurs et les espacements calculés pour chaque couche. Ces valeurs préférées ne peuvent pas être modifiées, contrairement aux valeurs minimale et maximale : définissez pour celles-ci des valeurs inférieures et supérieures appropriées.

Règle de conception de largeur de routage

Pour les nets asymétriques, la largeur de routage est définie par la règle de conception Largeur de routage.

Lorsque vous choisissez d’utiliser un profil d’impédance, les couches disponibles et les largeurs préférées sont déterminées par le profil sélectionné.Lorsque vous choisissez d’utiliser un profil d’impédance, les couches disponibles et les largeurs préférées sont déterminées par le profil sélectionné.

Règle de conception de routage des paires différentielles

Le routage des paires différentielles est contrôlé par la règle de conception Routage des paires différentielles.

Pour une paire différentielle, les couches disponibles, la largeur préférée et l’espacement préféré sont déterminés par le profil sélectionné.Pour une paire différentielle, les couches disponibles, la largeur préférée et l’espacement préféré sont déterminés par le profil sélectionné.

► En savoir plus sur le routage des paires différentielles

Les angles dans les pistes de signaux à haut débit font l’objet de nombreux débats. S’il est admis que les électrons ne s’échappent pas lorsqu’ils rencontrent un angle à 90 degrés, un angle droit classique présente une largeur supérieure dans sa diagonale, ce qui modifie effectivement l’impédance de la piste. Les angles arrondis ou à 45 degrés sont préférables ; ces deux options sont des fonctions standard du routeur interactif de l’éditeur de PCB. Si nécessaire, les angles à 90 degrés peuvent être chanfreinés à l’aide de la commande Convert Selected Tracks to Chamfered Path. Notez que cette commande convertit les segments de piste sélectionnés en un seul objet de type région.

Choix de l’impédance

Comment savoir quelle impédance cible choisir ? Celle-ci est généralement déterminée par l’impédance caractéristique de source de la famille logique ou de la technologie utilisée. Par exemple, la logique ECL présente une impédance caractéristique de 50Ω, tandis que la logique TTL présente une impédance de source comprise entre 70Ω et 100Ω. Une impédance cible de 50Ω à 60Ω est couramment utilisée dans de nombreuses conceptions et, pour les paires différentielles, une impédance différentielle de 90Ω ou 100 Ω est courante. N’oubliez pas que plus l’impédance est faible, plus le courant consommé est élevé ; plus l’impédance est élevée, plus le risque d’émission d’interférences électromagnétiques augmente et plus le signal est sensible à la diaphonie.

Une paire différentielle de 100Ω peut également être considérée comme deux pistes asymétriques de 50Ω de même longueur. Ce n’est pas tout à fait exact en raison du couplage entre les deux pistes, qui s’intensifie lorsqu’elles se rapprochent et réduit l’impédance différentielle de la paire. Pour maintenir une impédance différentielle de 100Ω , la largeur de chaque piste peut être réduite, ce qui augmente légèrement l’impédance caractéristique de chaque piste de la paire de quelques ohms.

Définition des propriétés du circuit imprimé

Main page: Gestion de l’empilage des couches

Les matériaux utilisés pour les couches de votre circuit imprimé, leurs dimensions, ainsi que le nombre de couches et leur ordre sont tous définis dans le gestionnaire d’empilage des couches. Vous y configurez les différentes couches nécessaires à la fabrication du circuit imprimé final, notamment les couches de cuivre pour les signaux et les plans, les couches diélectriques qui séparent les couches de cuivre, les couches de protection et la sérigraphie des composants.

Toutes les couches à fabriquer sont définies dans l’onglet Empilage du gestionnaire d’empilage des couches.
Toutes les couches à fabriquer sont définies dans l’onglet Empilage du gestionnaire d’empilage des couches.

Les informations détaillées sur les propriétés des matériaux saisies dans le Layer Stack Manager figurent dans le tableau d’empilage des couches, ainsi que dans la légende d’empilage des couches placée dans un document Draftsman.

Vous pouvez également Save un empilage de couches en tant que modèle dans le Layer Stack Manager (menu File), puis Load ce modèle dans de futures conceptions.

Configuration des vias

Main page: Définition des types de vias

Comme indiqué dans la section de présentation de cette page, les vias influent sur l’impédance du routage des signaux et constituent un élément essentiel à prendre en compte dans la conception haute vitesse. Outre la longueur, le diamètre du trou et la surface de la pastille du via, qui influent sur l’impédance vue par le signal, toute portion inutilisée du fût d’un via peut agir comme un stub et contribuer aux réflexions du signal. Pour maîtriser ces effets, différents types de vias reliant les couches peuvent être fabriqués, notamment des vias borgnes, enterrés, des microvias (µVia) et des vias à saut de couche. Tous ces types de vias sont pris en charge dans Altium Designer.

Les vias sont définis dans le cadre de l’empilage des couches, dans l’onglet Layer Stack Manager's Via Types. Le contre-perçage des portions inutilisées des fûts de vias est également pris en charge ; ses paramètres sont définis dans l’onglet Layer Stack Manager's Back Drills (en savoir plus sur la configuration de la carte pour le contre-perçage).

Tous les types de vias pouvant être fabriqués peuvent être définis dans l’onglet Via Types du Layer Stack Manager.Tous les types de vias pouvant être fabriqués peuvent être définis dans l’onglet Via Types du Layer Stack Manager.

Des études quantitatives ont été menées pour comprendre l’incidence des vias, notamment la note d’application Altera AN529 Techniques d’optimisation des vias pour la conception de canaux haute vitesse.

En synthèse de cette étude et d’autres références, les recommandations suivantes permettent de minimiser l’incidence des vias :

  • Réduisez la taille de la couronne annulaire du via à l’endroit où la piste du signal se raccorde au via. La note d’application suggère un diamètre de via/trou de 20/10 mil (0,5/0,25 mm) pour les vias percés mécaniquement.
  • Supprimez les couronnes annulaires inutilisées (également appelées NFP, ou pastilles non fonctionnelles) sur les couches auxquelles le via n’est pas connecté. Utilisez la commande Tools » Remove Unused Pad Shapes pour cela.
  • Augmentez la distance d’isolement entre le fût du via et les couches de plan adjacentes. Ce paramètre est contrôlé par la règle de conception Power Plane Clearance ; la note d’application suggère une valeur de 40 à 50 mil (1,0 à 1,25 mm). Notez que cela augmente la taille des ouvertures dans ces couches de plan.
  • Placez des vias de couture à proximité des vias de signal chaque fois que le routage du signal change de couche et que ce changement fait passer le chemin de retour sur une autre couche. Si la nouvelle couche de plan de référence est au même potentiel que le plan de référence initial, ces plans doivent être reliés par un via situé à moins de 35 mil (0,9 mm) du via de signal, de centre à centre.
  • Lorsque le routage du signal change de couche et que la nouvelle couche de plan de référence est à un potentiel différent, placez des condensateurs de découplage à proximité du via de signal. Ce condensateur assure un découplage direct entre les deux plans, quels que soient leurs potentiels. Notez que cette solution peut entraîner un couplage du bruit d’un plan à l’autre ; elle ne doit donc être utilisée qu’en dernier recours pour réduire la surface de la boucle du chemin de retour.
  • Supprimez les stubs des vias (la longueur excédentaire du via au-delà de la couche sur laquelle la piste du signal rejoint le via). Pour cela, utilisez des vias borgnes et enterrés adaptés, ou procédez au contre-perçage des vias lors de la fabrication.

La conception des vias est un élément clé du processus de conception des cartes haute vitesse. Les possibilités de connexion entre couches par des vias sont dictées par le procédé de fabrication choisi pour réaliser l’empilage des couches. Vous devez donc choisir les procédés de fabrication et de perçage en même temps que vous définissez le type de via et l’empilage des couches.

L’éditeur de PCB prend en charge le contre-perçage (également appelé perçage à profondeur contrôlée). Cette fonctionnalité permet le contre-perçage depuis les deux faces de la carte. Les emplacements contre-percés peuvent être facilement examinés dans le panneau PCB, avec la carte affichée en mode 3D.

En savoir plus sur le perçage à profondeur contrôlée.

Gestion du chemin de retour des signaux haute vitesse

Un chemin de retour de bonne qualité est essentiel pour chaque signal haute vitesse de la conception. Chaque fois que le chemin de retour dévie et ne passe plus sous la piste du signal, une boucle se forme. Cette boucle génère des interférences électromagnétiques (IEM), dont l’intensité est directement liée à la surface de la boucle.

Création de plans d’alimentation

  • Un plan d’alimentation peut être créé soit à partir d’une couche de plan, soit à partir d’une couche de signal recouverte d’un ou de plusieurs polygones.
  • Création d’un plan d’alimentation à l’aide d’une couche de plan :
    • Les couches de plan sont ajoutées dans le Layer Stack Manager. Cliquez avec le bouton droit sur une couche existante pour sélectionner Insert layer above ou Insert layer below afin d’ajouter une nouvelle couche de plan.
    • Une fois la couche de plan sélectionnée comme couche active, double-cliquez n’importe où dans le plan pour ouvrir la boîte de dialogue Split Plane, dans laquelle vous pouvez attribuer le net.
    • Le logiciel applique automatiquement un retrait entre le bord du plan et le bord de la carte, selon la valeur indiquée dans la colonne Pullback Distance de cette couche dans le Layer Stack Manager. Si cette colonne n’est pas visible, cliquez avec le bouton droit sur un en-tête de colonne existant pour accéder à la commande Select Columns.
    • Une couche de plan peut être divisée en régions distinctes en plaçant des lignes (Place » Line). Appuyez sur Tab après avoir commencé à placer le premier segment de ligne pour définir la largeur de la ligne de séparation. Placez les segments de ligne d’un bord à l’autre de la carte, ou créez une forme fermée pour constituer un îlot. Le logiciel détecte automatiquement les formes distinctes créées par les lignes de séparation ; double-cliquez sur chaque forme pour lui attribuer un net.
  • Création d’un plan d’alimentation à l’aide de polygones sur une couche de signal :
    • Les couches de signal sont ajoutées dans le Layer Stack Manager. Cliquez avec le bouton droit sur une couche existante pour sélectionner Insert layer above ou Insert layer below afin d’ajouter une nouvelle couche de signal.
    • Si des zones d’alimentation distinctes sont nécessaires, il peut être plus simple de recouvrir toute la couche d’un polygone, puis de le découper (Place » Slice Polygon Pour). Appuyez sur Tab après avoir commencé à placer la ligne de découpe pour ouvrir la boîte de dialogue Line Constraints, dans laquelle vous pouvez définir la largeur de découpe. Cette largeur correspondra à la distance entre les deux polygones créés par la découpe. La ligne de découpe doit commencer et se terminer à l’extérieur du polygone.
    • Pour recalculer le remplissage d’un polygone, cliquez avec le bouton droit et sélectionnez Polygon Actions » Repour Selected dans le menu contextuel. 
    • Les polygones peuvent également être mis de côté (masqués temporairement) : cliquez avec le bouton droit et sélectionnez la commande appropriée dans le Polygon Actions sous-menu. Utilisez cette fonctionnalité lorsque vous devez déplacer des composants et des pistes.
  • Il peut être utile d’afficher les différents nets avec des couleurs distinctes, comme le montrent les images ci-dessous. Cela peut être fait dans le schéma ou dans le PCB. En savoir plus sur l’attribution de couleurs aux nets.

La première image montre une couche de plan divisée en zones 3v3 et 5v0 ; la seconde montre une couche de signal comportant un polygone 3v3 et un polygone 5v0. Des couleurs ont été attribuées aux nets et la mise en surbrillance a été activée.  Two power zones created by polygons on a signal layerLa première image montre une couche de plan divisée en zones 3v3 et 5v0 ; la seconde montre une couche de signal comportant un polygone 3v3 et un polygone 5v0. Des couleurs ont été attribuées aux nets et la mise en surbrillance a été activée.

Le plan comme chemin de retour du signal

Un chemin de retour de bonne qualité présente les caractéristiques suivantes :

  • Le plan assurant le chemin de retour (le plan le plus proche du signal concerné) ne présente aucune interruption, séparation ou ouverture (trou dans le plan créé par un via ou une broche traversante) sous la piste du signal.
  • La largeur du chemin de retour doit idéalement être égale à 3 fois la largeur de la piste du signal ou à 3 fois la distance entre la piste et le plan, selon la plus petite de ces deux valeurs. Bien que la densité de courant soit maximale directement sous la piste du signal, le courant se répartit également dans le plan de part et d’autre de la piste, environ 95 % circulant dans une zone correspondant à 3 fois la largeur de la piste. Les interruptions du plan dans cette zone augmentent l’impédance du chemin de retour, et toute déviation du chemin de retour crée une boucle. En matière d’intégrité du signal, cette augmentation de l’impédance du chemin de retour affecte autant la qualité du signal qu’une augmentation de l’impédance du trajet du signal.
  • La surface de la boucle a été réduite au minimum. En général, il est plus important de réduire la surface de la boucle que de minimiser la longueur du routage du signal. Si le chemin de retour rencontre une ouverture dans le plan, envisagez de modifier le routage du signal pour l’adapter à un chemin de retour disponible. 
  • Lorsqu’un plan d’alimentation assure le chemin de retour, l’énergie de retour finit par rejoindre la masse par l’intermédiaire d’un condensateur de découplage. Choisissez avec soin l’emplacement des condensateurs de découplage à proximité de la broche source du signal afin de minimiser la surface de toute boucle créée.

Gestion des plans d’alimentation et de masse divisés ou multiples

Il est généralement admis qu’un plan de masse ne doit pas être divisé, sauf si une exigence particulière le justifie et si vous savez comment le définir et le gérer. Il convient plutôt de disposer les composants de manière à séparer les composants bruyants des composants sensibles au bruit, et de regrouper les composants selon le rail d’alimentation qu’ils utilisent.

Voici d’autres points à garder à l’esprit concernant les plans d’alimentation et de masse :

  • Si la conception nécessite de diviser partiellement un plan de masse, les signaux qui traversent ces zones doivent être routés au-dessus du pont (la zone sans séparation en dessous).
  • Si vous cherchez à minimiser le bruit du circuit, il est préférable d’utiliser des plans de masse supplémentaires plutôt que de diviser un plan et, dans la mesure du possible, de prévoir des couches de plan pour les rails d’alimentation et de masse de chaque alimentation régulée. 
  • Si la conception comporte plusieurs rails, chacun étant distribué sur son propre plan, assurez-vous que chaque plan d’alimentation ne prend pour référence que son propre plan de masse. Ne laissez pas un plan d’alimentation chevaucher le plan de masse d’un autre rail (et le prendre pour référence). Cela crée un couplage capacitif, permettant au bruit de se propager d’une alimentation à une autre.
  • Si le plan adjacent est un plan d’alimentation qui doit être divisé en zones de tensions différentes, il peut être nécessaire de réaliser un découplage directement entre ces deux zones pour fournir un chemin de retour approprié.

Visualisation des plans divisés

Pour faciliter la vérification visuelle des chemins de retour, vous pouvez configurer l’affichage afin d’examiner plus facilement le chemin de retour sous les pistes critiques.

Vérification des signaux passant au-dessus d’une ligne de séparation lorsqu’ils traversent différentes zones de tension du plan. Les quatre nets mis en surbrillance traversent une séparation du plan d’alimentation VCC, ce qui crée une interruption dans le chemin de retour de ces signaux.
Vérification des signaux passant au-dessus d’une ligne de séparation lorsqu’ils traversent différentes zones de tension du plan. Les quatre nets mis en surbrillance traversent une séparation du plan d’alimentation VCC, ce qui crée une interruption dans le chemin de retour de ces signaux.

Pour ce faire :

  • Attribuez une couleur à chaque net d’alimentation. Pour en savoir plus, consultez Application de couleurs aux nets.
  • Limitez l’affichage aux seules couches de signal et de plan concernées. Cet ensemble de couches peut être enregistré comme jeu de couches. Pour en savoir plus, consultez Création d’un jeu de couches.
  • Passez à la couche de signal et Ctrl+Click sur le net souhaité pour le mettre en surbrillance (maintenez également Shift enfoncé pendant que vous cliquez pour mettre plusieurs nets en surbrillance). L’avantage de la mise en surbrillance par rapport à la sélection est sa persistance : les nets restent en surbrillance si vous cliquez ailleurs. Appuyez sur Shift+C pour effacer la mise en surbrillance actuelle.
  • La mise en surbrillance s’effectue en atténuant les autres objets de l’espace de conception. Le niveau de Dimmed Objects se règle dans la section Paramètres de masquage et d’atténuation du panneau View Configuration.
  • Définissez la couche de plan comme couche active.

Vos nets ressortiront, et les séparations ou discontinuités situées sur le chemin de retour, telles que les lignes de séparation ou les ouvertures créées par les pastilles traversantes et les vias, seront plus faciles à repérer. 

  • Les couches de plan comme les couches de signal recouvertes de polygones peuvent servir de plans de rail d’alimentation.
  • Pour éviter que des signaux soient routés par inadvertance au-dessus d’une séparation dans un plan, placez une zone d’exclusion le long de cette séparation, sur la couche d’exclusion.

Détection des interruptions du chemin de retour

Les interruptions ou rétrécissements du chemin de retour peuvent être détectés par la règle de conception Chemin de retour. La règle de conception Chemin de retour vérifie la continuité du chemin de retour du signal sur les couches de référence désignées, au-dessus ou au-dessous des signaux ciblés par la règle. Le chemin de retour peut être constitué de remplissages, de régions et de remplissages polygonaux placés sur la couche de signal de référence, ou être une couche de plan.

Les couches du chemin de retour sont les couches de référence définies dans le Impedance Profile sélectionné dans la règle de conception Chemin de retour. Ces couches sont vérifiées pour s’assurer que la Minimum Gap spécifiée (largeur au-delà du bord du signal) est respectée tout au long du trajet du signal. Ajoutez une nouvelle règle de conception Chemin de retour dans la catégorie de règles High Speed.

 
 
 
 
 

Les couches du chemin de retour sont définies dans le Impedance Profile sélectionné ; la largeur du chemin (au-delà du bord du signal) est définie par le Minimum Gap.
Les couches du chemin de retour sont définies dans le Impedance Profile sélectionné ; la largeur du chemin (au-delà du bord du signal) est définie par le Minimum Gap.

L’image ci-dessous montre les erreurs de chemin de retour détectées pour le signal NetX, avec le paramètre Minimum Gap réglé sur 0.1mm. Pour repérer plus facilement les erreurs de chemin de retour, vous pouvez configurer les DRC Violation Display Style afin d’afficher les détails des violations, mais pas leur superposition, dans la boîte de dialogue Préférences – afficher l’image. Cela met en évidence les emplacements exacts où la règle n’est pas respectée, plutôt que l’intégralité des objets en infraction. 

Pour éviter de détecter des erreurs mineures, comme la section mise en évidence sur le segment de piste diagonal dans l’image ci-dessus, configurez le paramètre PCB.Rules.ReturnPathIgnoreArea dans la boîte de dialogue Paramètres avancés. Par défaut, les zones < 10 sq mils sont ignorées.

Vérification des vias du chemin de retour

Cette fonctionnalité est disponible lorsque l’option PCB.Rules.CheckReturnPathVia est activée dans la boîte de dialogue Paramètres avancés.

 
 
 
 
 

Lorsqu’un signal haute vitesse passe d’un plan de référence à un autre, des vias de retour doivent également être présents pour transmettre les signaux de retour entre les plans. Pour vérifier la présence d’un tel via à une distance donnée d’un via de signal, indiquez si un via de retour doit être présent à une distance donnée d’un via du signal concerné à l’aide de l’option Max Stitch Via Distance de la règle de conception Chemin de retour applicable. Le via de retour doit assurer la connexion à la couche de référence définie dans Layer Stack Manager pour le profil d’impédance correspondant.

Lorsque le Max Stitch Via Distance est défini dans la règle, la présence d’un via de retour à la distance spécifiée est vérifiée dans le cadre du contrôle des règles de conception (DRC) par lots.

Exemple de violation de la contrainte de distance maximale du via de couture. Ici, un via du net DQS4R_N ne dispose d’aucun via de retour à la distance spécifiée.
Exemple de violation de la contrainte de distance maximale du via de couture. Ici, un via du net DQS4R_N ne dispose d’aucun via de retour à la distance spécifiée.

Configuration et routage des paires différentielles

Main pages: Routage des paires différentielles, Routage à impédance contrôlée

Les paires différentielles peuvent être définies pendant la saisie du schéma ou une fois la conception transférée vers l’éditeur de PCB. Pour définir une paire sur le schéma, il est indispensable d’ajouter un _P ou un _N à la fin du nom de chacun des nets concernés. Les paires différentielles sont identifiées sur le schéma en plaçant un Differential Pair directive sur chaque net, ou en en plaçant un sur un Blanket directive, la directive de couverture englobant alors un ensemble d’étiquettes de nets de type différentiel, comme illustré ci-dessous.

Example of how a Blanket directive can be used with a Differential Pair directive to target multiple nets

Une couverture peut être utilisée pour configurer plusieurs nets en tant que membres de paires différentielles.

Utilisation des paires différentielles :

  • Dans l’éditeur de PCB, les paires différentielles peuvent être définies dans le mode Éditeur de paires différentielles du panneau PCB. Pour simplifier la définition des règles de conception applicables aux paires différentielles, celles-ci peuvent être affectées à des classes de nets ou à des classes de paires différentielles, toutes deux définies dans l’Explorateur de classes d’objets.
  • Pour router une paire différentielle à impédance contrôlée, créez un profil d’impédance dans le Layer Stack Manager. Pour en savoir plus, consultez Routage à impédance contrôlée.
  • Les propriétés du routage des paires différentielles sont définies par la règle de conception Routage des paires différentielles.
  • Pour router une paire différentielle, utilisez la commande de routage Paire différentielle interactive. Cliquez sur la pastille _P ou _N pour commencer le routage, puis utilisez Spacebar pour parcourir les formes de routage de sortie disponibles. Le comportement du routage est identique à celui du routage d’un net unique ; appuyez sur Shift+F1 pour afficher la liste des raccourcis de routage interactif. À l’approche des pastilles cibles, appuyez sur Ctrl+Click pour terminer le routage jusqu’aux pastilles.

Règles pratiques pour les paires différentielles :

  • L’égalisation des longueurs est essentielle au bon fonctionnement des paires différentielles : maintenez l’écart de longueur dans une tolérance adaptée à la technologie de signalisation. Par exemple, pour les paires USB 3.x, visez un écart de 5 à 10 mils maximum. Une autre règle pratique consiste à limiter l’écart de longueur à l’équivalent de 20 % du temps de montée du signal. La signalisation différentielle fonctionne parce que l’énergie de retour circule dans l’autre membre de la paire ; plus les longueurs diffèrent, plus la quantité d’énergie qui revient par la couche de plan la plus proche est importante.

  • Les discontinuités de couplage, par exemple lorsque les membres de la paire passent de part et d’autre d’un obstacle, augmentent l’impédance. Il peut être préférable de router toute la paire avec un couplage plus lâche (par exemple, un espacement égal à 2 fois la largeur de piste du signal) afin de réduire les variations d’impédance dues aux discontinuités de couplage.

  • Éloignez les pistes perturbatrices, en particulier sur les couches externes ; visez un espacement de 3 fois la largeur de piste du signal par rapport aux nets potentiellement perturbateurs.

  • En règle générale, visez un espacement entre la paire et les autres signaux égal à 2 fois la largeur de piste du signal.

  • Maintenez les polygones de masse de la même couche à une distance d’au moins 3 fois la largeur de piste du signal.

  • Les réflexions introduites par les vias et les discontinuités de couplage sont maîtrisées grâce au routage à impédance contrôlée, qui nécessite un plan de référence continu sous le trajet du signal.

  • Réduisez la distance entre la couche de signal et le plan pour améliorer l’immunité à la diaphonie.

Contrôle et ajustement des longueurs de routage

Main pages: Ajustement des longueurs, Règle de conception de longueur, Règle de conception d’adaptation des longueurs

Le contrôle et l’ajustement des longueurs de routage constituent une exigence essentielle pour maîtriser les signaux à haute vitesse sur une carte.

  • Les longueurs absolues peuvent être surveillées par la règle de conception de longueur, et les longueurs de routage relatives par la règle de conception d’adaptation des longueurs.
  • Les longueurs actuelles d’un ensemble de nets, ainsi que leur conformité aux règles de conception applicables, peuvent être vérifiées dans le panneau PCB en mode Nets (comme illustré ci-dessous).
  • Si une règle de longueur et/ou une règle d’adaptation des longueurs est définie, vous pouvez surveiller la longueur pendant le routage interactif ou l’ajustement des longueurs en affichant la jauge d’ajustement des longueurs (Shift+G).
  • Le retard dû à la longueur de la broche à l’intérieur du boîtier du composant est pris en charge. Pour en savoir plus, consultez la section Retard des broches dans le boîtier.
  • Les nets dont le trajet comprend des composants en série sont gérés en définissant des xSignals.

Règles de conception

  • Managing the Overall Route Lengths - la longueur totale de routage d’un net ou d’un ensemble de nets peut être surveillée par une règle de conception de longueur. Cette règle définit une longueur minimale et une longueur maximale autorisées. Si la longueur du signal est inférieure au minimum autorisé, elle est surlignée en jaune dans le panneau PCB (en mode Nets) ; si elle dépasse le maximum autorisé, elle est surlignée en rouge.
  • Managing the Relative Route Lengths - les longueurs de routage relatives d’un ensemble de nets peuvent être surveillées par une règle de conception d’adaptation des longueurs. Cette règle définit une tolérance et utilise comme référence le routage le plus long de l’ensemble des nets ciblés. Le surlignage en jaune de la longueur du signal dans le panneau indique que cette longueur est inférieure à la longueur de routage la plus élevée moins la tolérance. Le surlignage en rouge indique que la longueur de ce signal est supérieure à la longueur de routage la plus élevée. 

Pour comprendre comment les paramètres de ces deux règles sont pris en compte lorsqu’elles sont toutes deux présentes dans une conception, consultez la page Ajustement des longueurs.

Surveillance de la longueur de routage

Les longueurs de routage actuelles sont affichées dans le mode Nets du panneau PCB et sont mises à jour au fur et à mesure du routage. La valeur de longueur Routed devient jaune lorsque vous approchez de la longueur cible, puis rouge si vous la dépassez.

Si une règle de longueur et/ou une règle d’adaptation des longueurs est définie, vous pouvez surveiller la longueur pendant le routage interactif ou l’ajustement des longueurs en affichant la jauge d’ajustement des longueurs. Pendant le routage, utilisez le raccourci Shift+G pour afficher ou masquer la jauge.

La jauge affiche la longueur routée actuelle sous forme de valeur numérique au-dessus du curseur, tandis que le curseur indique la longueur estimée. Pendant l’ajustement des longueurs, Estimated Length = Current Routed Length ; si vous utilisez la jauge pendant le routage interactif, Estimated Length = Routed Length + distance to target (length of connection line).

Les paramètres de la jauge sont calculés à partir des contraintes définies par les règles applicables.Les paramètres de la jauge sont calculés à partir des contraintes définies par les règles applicables.

  • Le minimum de la jauge (bord gauche) est de 45 (valeur MinLimit la plus basse).
  • Le maximum de la jauge (bord droit) est de 48 (valeur MaxLimit la plus élevée).
  • La barre jaune de gauche (valeur MinLimit la plus élevée) se situe à 46,58.
  • La barre jaune de droite (valeur MaxLimit la plus basse) se situe à 47,58 (masquée par la barre verte dans l’image ci-dessus).
  • La barre verte (TargetLength) se situe à 47,58 (longueur de routage du net le plus long de l’ensemble, égale à MaxLimit).
  • Le curseur vert et la valeur numérique superposée (longueur de routage actuelle) indiquent 47,197.

Ajustement des longueurs de routage

Les longueurs de routage peuvent être ajustées une fois le routage terminé, à l’aide de la commande Interactive Length Tuning ou de la commande Interactive Diff Pair Length Tuning (menu Route). Ces commandes ajoutent au routage des sections en accordéon, avec un choix de trois formes.

Si une règle de longueur et une règle d’adaptation des longueurs sont applicables, l’outil d’ajustement des longueurs tient compte des deux règles et détermine l’ensemble de contraintes le plus strict. Ainsi, si la longueur maximale spécifiée par la règle de longueur est inférieure à la longueur la plus élevée ciblée par la règle d’adaptation des longueurs, la règle de longueur prévaut et sa longueur est utilisée lors de l’ajustement.

Pour voir quelles règles sont appliquées ou modifier les propriétés de l’accordéon pendant l’ajustement des longueurs, appuyez sur Tab pour ouvrir le mode Interactive Length Tuning du panneau Properties, comme illustré ci-dessous. Notez la valeur Target Length : il s’agit de la valeur Max Limit correspondant aux paramètres de règle applicables les plus stricts.

Appuyez sur Tab pendant l’ajustement des longueurs pour ouvrir le panneau en mode Interactive Length Tuning, dans lequel vous pouvez sélectionner le mode de longueur cible et régler les paramètres de l’accordéon.
Appuyez sur Tab pendant l’ajustement des longueurs pour ouvrir le panneau en mode Interactive Length Tuning, dans lequel vous pouvez sélectionner le mode de longueur cible et régler les paramètres de l’accordéon.

Pour ajuster la longueur d’un net, exécutez la commande, puis cliquez n’importe où sur son trajet. Déplacez le curseur en suivant le trajet du routage : des sections d’ajustement en accordéon sont ajoutées au fur et à mesure. L’ajout de sections se poursuit jusqu’à ce que les exigences de longueur définies par les règles de conception applicables soient satisfaites. Si le curseur sort des limites des accordéons d’ajustement, ceux-ci disparaissent ; ils réapparaissent lorsque le curseur revient à l’intérieur de leurs limites.

En savoir plus sur l’ajustement des longueurs.

Les règles de longueur et d’adaptation des longueurs peuvent être appliquées aux nets, aux paires différentielles ou aux xSignals. Les xSignals sont particulièrement adaptés lorsque les longueurs surveillées ou adaptées comprennent des composants en série ou des ramifications de routage. Le mode xSignals du panneau PCB affiche la longueur routée actuelle de chaque xSignal.

En savoir plus sur les xSignals.

Conclusion

Bien qu’il ne soit pas possible de définir un ensemble universel de règles applicables à toutes les conceptions à haute vitesse, vous pouvez suivre de bonnes pratiques qui vous aideront à réussir votre conception. Plusieurs experts du secteur proposent des formations pratiques et reconnues sur la conception à haute vitesse. Utilisez les liens ci-dessous pour en savoir plus et découvrir les possibilités de formation spécialisée.

Références

L’auteur remercie les experts du secteur suivants pour leurs travaux. Cette page vise à résumer leurs connaissances collectives.

Articles de Douglas Brooks

  • Temps de propagation des lignes microruban
  • Fractionnement des plans pour la vitesse et l’alimentation
  • Effet de peau
  • Règles de conception des pistes différentielles : vérités et idées reçues

Articles du Dr Howard Johnson

  • Inductance des vias
  • Empilage à 10 couches

Livres et articles de Lee W. Ritchey

  • Réussir du premier coup
  • Analyse de la signalisation différentielle et de ses exigences de conception
  •  Les stratifiés de PCB influencent les débits de données à haute vitesse, partie 1, partie 2

Articles d’In-Circuit Design — Barry Olney

  • Routage des paires différentielles
  • Toute la vérité sur les cavaliers entre plans
  • Placement critique
  • Planification de l’empilage (parties 1, 2 & 3)
  • L’empilage parfait

Bonnes pratiques de conception des circuits imprimés - Tim Jarvis RadioCAD Limited

Routage des circuits imprimés - Site web Learn EMC

Articles de Keith Armstrong, EMC Information Centre (inscription gratuite requise)

Manuel de packaging électronique - Glenn R. Blackwell

Manuel des circuits imprimés - Clyde Coombs et Happy Holden

Manuel HDI - Happy Holden et autres auteurs

Techniques d’optimisation des vias pour la conception de canaux à haut débit - Note d’application Altera AN529

Considérations relatives à la conception de circuits imprimés à haut débit - Note d’application Lattice Semiconductor TN 1033 

Mesure du temps de propagation d’un signal - Chris Grachanen, EDN

L’avenir des structures de vias HDI, de la distribution d’alimentation et de la gestion thermique dans les circuits imprimés de nouvelle génération - Tom Buck TTM Technologies

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents