Instradamento a impedenza controllata
A colpo d'occhio
- Scopri in cosa consistono i problemi di integrità del segnale, come riflessioni e oscillazioni, e perché l’aumento delle velocità di commutazione rende più importante lo sbroglio a impedenza controllata.
- Scopri come valutare se il tuo progetto richiede particolare attenzione all’impedenza controllata, inclusa la regola pratica usata per stimare quando la lunghezza delle piste diventa critica.
- Comprendi come Altium Designer supporta l’adattamento di impedenza dei componenti e l’analisi delle reti tramite i suoi strumenti di analisi dell’integrità del segnale, prima di passare alle decisioni di sbroglio.
Con l'aumento delle velocità di commutazione dei dispositivi, lo sbroglio a impedenza controllata è diventato un tema di grande interesse per chi progetta circuiti digitali. Questa pagina illustra come utilizzare il motore di analisi dell'integrità del segnale per adattare le impedenze dei componenti e le funzionalità di sbroglio a impedenza controllata dell'editor PCB.
Negli ambienti ingegneristici si dice che esistano solo due tipi di ingegneri elettronici che lavorano nella progettazione digitale: quelli che hanno già avuto problemi di integrità del segnale e quelli che li avranno. Fino a non molti anni fa, l'integrità del segnale era un argomento riservato agli specialisti e occorreva occuparsene solo nei progetti ad alta velocità. Tuttavia, le velocità di commutazione dei dispositivi impiegati in quei progetti non sono più un'eccezione: stanno rapidamente diventando la norma. Con il progresso della tecnologia dei circuiti integrati, le dimensioni dei transistor diminuiscono e le loro velocità di commutazione aumentano. È proprio questa velocità di commutazione a influenzare l'integrità dei segnali digitali.
Fortunatamente, molti potenziali problemi di integrità del segnale possono essere evitati seguendo buoni principi di progettazione e realizzando una scheda a impedenza controllata. A questo scopo sono necessarie funzionalità specifiche negli strumenti di progettazione: servono strumenti di analisi che individuino le reti con potenziali problemi di oscillazioni e riflessioni e strumenti di progettazione PCB che consentano di ottenere le impedenze di sbroglio corrette. L'editor PCB di Altium Designer offre queste funzionalità.
Questa pagina ti aiuterà a capire quali sono le cause dei problemi di integrità del segnale e se è probabile che la tua scheda ne sia soggetta. Illustrerà inoltre i due approcci progettuali da adottare per ridurre al minimo i potenziali problemi di integrità del segnale: l'adattamento delle impedenze dei componenti e lo sbroglio a impedenza controllata.
Quando lo sbroglio diventa parte del circuito
Con l'aumento delle velocità di commutazione dei dispositivi, aumentano anche le esigenze per chi progetta e produce circuiti stampati. Quando la lunghezza del fronte di commutazione del segnale diventa inferiore alla lunghezza della pista PCB che lo trasporta, la pista deve essere trattata come parte del circuito. Tale pista ha un'impedenza, definita characteristic impedance (Zo).
Il modo migliore per gestire l'impatto di questi elementi circuitali aggiuntivi è progettare lo sbroglio delle piste in modo che l'impedenza caratteristica rimanga costante lungo tutto il percorso: una tecnica chiamata controlled impedance routing.
L'impedenza delle piste è definita dai seguenti fattori:
- Cross-sectional area of the trace - determinata dalla larghezza, dall'altezza (spessore del rame) e dall'inclinazione dei bordi della pista creati durante il processo di incisione.
- Distance from the trace to the reference plane(s) - il percorso di ritorno dell'energia del segnale è importante quanto il percorso del segnale stesso. Questo percorso di ritorno segue quello del segnale nei piani di riferimento adiacenti.
- Properties of the surrounding materials - l'energia del segnale non è contenuta all'interno del rame della pista; a causa dell'effetto pelle, si propaga anche nel materiale dielettrico che circonda la pista. La permittività del materiale dielettrico misura quanto il dielettrico influisce sul flusso di tale energia.

Il calcolatore di impedenza Simbeor calcola le larghezze necessarie per ottenere l'impedenza specificata.
Mi serve lo sbroglio a impedenza controllata?
Ti stai chiedendo se sia davvero necessario occuparsi dello sbroglio a impedenza controllata?
In una situazione ideale, tutta l'energia che esce da un pin di uscita di un componente verrebbe trasferita alla pista collegata sul PCB, percorrerebbe lo sbroglio fino al pin di ingresso del carico all'altra estremità e verrebbe assorbita dal carico stesso. Se il carico non assorbe tutta l'energia, quella residua può essere riflessa nelle piste del PCB, tornando verso il pin di uscita della sorgente. Questa energia riflessa può interagire con il segnale originale, sommandosi a esso o sottraendosi da esso (a seconda della polarità dell'energia), dando origine a oscillazioni. Se queste oscillazioni sono sufficientemente ampie, compromettono l'integrità del segnale, causando un comportamento imprevedibile ed errato del circuito.
Come puoi quindi sapere se questo fenomeno potrebbe verificarsi? Se il pin sorgente riesce a completare la transizione del fronte prima che il segnale raggiunga il pin del carico, esistono le condizioni perché l'energia riflessa influisca sul progetto. Una regola pratica comunemente usata per determinare la probabilità di problemi di integrità del segnale è la regola di «1/3 del tempo di salita». Questa regola stabilisce che, se il tempo di propagazione lungo la pista supera 1/3 del tempo di salita, possono verificarsi riflessioni (oscillazioni). Se il pin sorgente ha un tempo di salita di 1 ns, un percorso con un tempo di propagazione superiore a 0,33 ns (circa 2 pollici su FR4) deve essere considerato una linea di trasmissione, potenzialmente soggetta a problemi di integrità del segnale. Se i tuoi dispositivi hanno tempi di salita di questo ordine e sai che i percorsi avranno lunghezze di questo tipo, potresti riscontrare problemi di integrità del segnale sul PCB.
Come si controllano le impedenze?
Come si evita che l'energia venga riflessa avanti e indietro tra la sorgente e il carico? Adattando le impedenze. L'adattamento di impedenza garantisce che tutta l'energia venga trasferita dalla sorgente alle piste e poi dalle piste al carico. Lo sbroglio della scheda che tiene conto dell'impedenza è detto sbroglio a impedenza controllata; in altre parole, una scheda in cui le impedenze sono state gestite viene chiamata PCB a impedenza controllata.
L'adattamento di impedenza richiede due interventi distinti: il primo consiste nell'adattare le impedenze dei componenti; il secondo nello sbrogliare la scheda in modo da ottenere l'impedenza richiesta.
Adattamento delle impedenze dei componenti
Non è possibile ottenere un PCB a impedenza controllata con il solo sbroglio. Per prima cosa è necessario verificare e, se occorre, adattare le impedenze dei componenti.
Idealmente, le reti che potrebbero presentare problemi di integrità del segnale dovrebbero essere individuate durante la fase di acquisizione dello schema in modo da poter includere eventuali componenti di terminazione aggiuntivi prima di iniziare la progettazione della scheda. Poiché i pin di uscita sono a bassa impedenza e quelli di ingresso sono ad alta impedenza, è probabile che sia necessario aggiungere componenti di terminazione al progetto per ottenere l'adattamento di impedenza.
Puoi eseguire un'analisi dell'integrità del segnale sul progetto durante la fase di acquisizione dello schema. Quando esegui il comando Tools » Signal Integrity, spesso viene visualizzata la finestra di dialogo Errors or Warnings, a indicare che non a tutti i componenti sono stati assegnati modelli di integrità del segnale. Il motore di analisi dell'integrità del segnale seleziona automaticamente i modelli predefiniti in base ai designatori dei componenti; fai clic su Continue per utilizzare quelli predefiniti oppure su Model Assignments per esaminare e modificare i modelli. Puoi accedere alla finestra di dialogo Signal Integrity Model Assignments in qualsiasi momento tramite il pulsante Model Assignments nel pannello Signal Integrity.
Analisi del progetto
Quando viene eseguito il comando Tools » Signal Integrity, il progetto viene analizzato e le reti potenzialmente problematiche vengono identificate nel pannello Signal Integrity, come mostrato di seguito.
Verifica del progetto per individuare potenziali problemi di integrità del segnale durante la creazione dello schema.
Dal pannello è possibile eseguire un'analisi delle riflessioni su una o più reti selezionate. A sinistra sono riportati i risultati dell'analisi per tutte le reti del progetto. Selezionare una rete e fare clic sul pulsante
(oppure fare doppio clic sul nome di una rete) per trasferirla nel campo Net a destra del pannello, dove è possibile eseguire un'analisi dettagliata della rete, che comprende:
- Esaminare i pin della rete, facendo un singolo clic per individuare il pin corrispondente sullo schema tramite cross-probing oppure un doppio clic per verificare e configurare il modello assegnato a quel pin.
- Abilitare una o più opzioni di terminazione teoriche per la rete.
- Eseguire un'analisi delle riflessioni sulla rete, producendo una serie di forme d'onda che mostrano il comportamento in corrispondenza di ciascun pin della rete.
Il pannello consente di sperimentare possibili configurazioni e valori di terminazione. Si noti che nell'area Termination del pannello Signal Integrity mostrato nell'immagine precedente è abilitata l'opzione Serial Res. La sezione del pannello sottostante mostra un resistore di terminazione in serie. Qui si definiscono i valori teorici minimo e massimo della resistenza di terminazione in serie che verranno utilizzati per l'analisi delle riflessioni (deselezionare la casella di controllo Suggest per immettere valori personalizzati).
Esplorazione dei risultati
Facendo clic sul pulsante Reflection Waveforms, viene eseguita un'analisi accurata delle riflessioni sulla rete, i cui risultati vengono presentati in una nuova finestra delle forme d'onda (*.SDF).
La finestra delle forme d'onda includerà:
- Un diagramma per ogni rete analizzata; fare clic sulle schede nella parte inferiore della finestra per passare da un diagramma all'altro.
- Ogni diagramma includerà un grafico per ciascun pin della rete, che mostra il comportamento del segnale in corrispondenza di quel pin.
Le immagini seguenti mostrano due grafici dei risultati in corrispondenza del pin di ingresso della rete selezionata nell'immagine precedente del pannello. Il primo grafico mostra il pin di ingresso della rete senza terminazione; il secondo grafico mostra sei scansioni, una per la rete originale senza terminazione e altre cinque con la resistenza di terminazione in serie teorica inserita in corrispondenza del pin sorgente.
Sono state eseguite cinque iterazioni dell'analisi delle riflessioni (valore dell'opzione Sweep Steps = 5), variando gradualmente il resistore di terminazione teorico da Min = 20 ohm a Max = 60 ohm. Le cinque iterazioni (la prima a 20 ohm, l'ultima a 60 ohm) sono elencate sul lato destro del grafico. Facendo clic su ciascuna etichetta, viene evidenziato il relativo risultato e viene visualizzato in basso a destra il valore teorico della resistenza di terminazione. Per questa rete, una resistenza di terminazione in serie di 40 ohm produrrebbe il grafico selezionato nell'immagine a destra.
Il grafico a sinistra mostra l'analisi delle riflessioni di una rete con potenziali problemi di integrità del segnale; il grafico a destra mostra la stessa rete con l'aggiunta di un resistore di terminazione in serie teorico di circa 40 ohm.
Cosa determina l'impedenza delle piste?
La seconda fase per ottenere un PCB a impedenza controllata consiste nello sbrogliare la scheda in modo che le piste abbiano un'impedenza definita. Diversi fattori influenzano l'impedenza delle piste di segnale, tra cui le dimensioni dei percorsi e le proprietà dei materiali utilizzati per fabbricare il PCB.
L'editor PCB include il motore elettromagnetico per l'integrità del segnale Simbeor® di Simberian. L'accuratezza dei modelli di Simbeor viene convalidata mediante algoritmi avanzati per l'analisi elettromagnetica 3D a onda intera, test comparativi e validazione sperimentale. Il motore Simbeor supporta tutte le strutture e i materiali delle schede moderne.
Versione di Simbeor
Simbeor SFS
Le impedenze vengono calcolate da Simbeor SFS, un solutore di campo quasi-statico. Simbeor SFS è un solutore di campo 2D quasi-statico avanzato basato sul metodo dei momenti, convalidato mediante verifiche di convergenza, confronti e misurazioni. Il solutore discretizza i contorni dei dielettrici e dei conduttori e risolve le equazioni corrispondenti per costruire matrici RLGC dipendenti dalla frequenza per le equazioni dei telegrafisti.
Simbeor SFS non è un solutore a onda intera, poiché questo non è necessario per valutare l'impedenza, il ritardo o l'attenuazione nelle interconnessioni PCB, data la natura quasi-TEM delle onde che vi si propagano. Tali onde possono essere simulate accuratamente con parametri RLGC estratti mediante un solutore di campo 2D quasi-statico.
Una proprietà esclusiva del solutore Simbeor SFS è il supporto dei modelli di rugosità dei conduttori. Si noti che non supporta un modello di conduttore multistrato (placcatura) e che la rugosità è comune a tutti i conduttori. Il solutore è quasi-statico perché la soluzione non include la dispersione ad alta frequenza che si verifica nelle linee a microstriscia (maggiore concentrazione dei campi in un dielettrico con costante dielettrica più elevata alle alte frequenze).
► Ulteriori informazioni sulla tecnologia elettromagnetica di Simberian per l'integrità del segnale
Strutture PCB supportate
È possibile calcolare le impedenze per le seguenti strutture PCB:
- Microstriscia
- Stripline simmetrica
- Stripline asimmetrica
- Strutture complanari singole e differenziali
- Più strati dielettrici adiacenti con proprietà dielettriche diverse.
Configurazione del PCB per il routing a impedenza controllata
Il routing a impedenza controllata consiste nel configurare le dimensioni delle piste e le proprietà dei materiali della scheda per ottenere un'impedenza specifica. Questa operazione viene eseguita nel Layer Stack Manager dell'editor PCB. Per aprire il Layer Stack Manager,, selezionare Design » Layer Stack Manager dai menu principali. Il Layer Stack Manager si apre in un editor di documenti, proprio come un foglio schematico, il PCB e altri tipi di documento.
La larghezza della pista necessaria per ottenere un'impedenza specifica viene calcolata nell'ambito del profilo di impedenza, configurato nella scheda Impedance del Layer Stack Manager.
In base a:
- i valori di Target Impedance, Target Tolerance e Roughness configurati nella scheda Impedance, e
-
le impostazioni dei materiali definite nella scheda Stackup, tra cui:
- lo spessore dello strato di segnale,
- lo spessore degli strati dielettrici circostanti (le distanze dai piani di riferimento), e
- le proprietà del materiale dielettrico (permittività Dk e fattore di dissipazione Df).
Quando questi parametri sono configurati correttamente, il calcolatore di impedenza dispone di informazioni sufficienti per calcolare quanto segue:
- Larghezza della pista
- Impedenza calcolata (Z)
- Impedenza di modo comune (Zcomm)
- Deviazione dell'impedenza (Z Deviation)
- Ritardo di propagazione (Tp)
- Induttanza per unità di lunghezza (p.u.l.)
- Capacità per unità di lunghezza (p.u.l.)
I valori calcolati vengono visualizzati nella sezione Transmission Line del pannello Properties quando è selezionata la scheda Impedance nel Layer Stack Manager, come mostrato di seguito.
Un profilo di impedenza da 50Ω definito per singole net instradate sullo strato superiore. Passare il cursore sull'immagine per visualizzare le impostazioni dello stesso profilo per lo strato L3 (immagine per gentile concessione di FEDEVEL Open Source, www.fedevel.com).
Configurazione dello stackup degli strati
Main page: Definizione dello stack degli strati
Gli strati di fabbricazione in rame e dielettrici vengono configurati nella scheda Stackup del Layer Stack Manager.
- In questa scheda è possibile aggiungere, rimuovere e configurare gli strati. Per un progetto rigido-flessibile, in questa scheda è anche possibile abilitare e disabilitare gli strati.
-
Le proprietà dello strato attualmente selezionato possono essere modificate direttamente nella griglia o nel pannello Properties. Fare clic sul pulsante
nella parte inferiore dell'area di progettazione per abilitare il pannello.
- Fare clic con il pulsante destro del mouse nella griglia degli strati oppure utilizzare i comandi Edit » Add Layer per aggiungere uno strato. L'aggiunta di uno strato di rame comporta anche l'aggiunta di uno strato dielettrico quando uno strato adiacente esistente è anch'esso in rame.
- Se l'opzione Stack Symmetry è abilitata nella sezione Scheda del pannello Properties, gli strati vengono aggiunti in coppie simmetriche rispetto allo strato dielettrico centrale.
- Il materiale dello strato può essere digitato nella cella Materiale selezionata oppure selezionato nella finestra di dialogo Select Material; fare clic sul pulsante con i puntini di sospensione per aprirla.
- È possibile aggiungere una finitura superficiale a uno strato di rame. Utilizzare il sottomenu Add Layer per aggiungere uno strato Surface Finish allo strato di rame attualmente selezionato, quindi fare clic sul pulsante con i puntini di sospensione del nuovo strato di finitura superficiale per selezionare il tipo di finitura.
- Lo strato selezionato può essere spostato verso l'alto o verso il basso tra gli strati dello stesso tipo utilizzando il menu contestuale o i menu Edit.
- L'area Board del pannello Properties include opzioni per imporre Stack Symmetry e Library Compliance. Ulteriori dettagli sono riportati di seguito.
- L'area Board del pannello Properties visualizza un riepilogo dello stack attualmente selezionato (o del sotto-stack per un progetto rigido-flessibile con più stack).
Considerazioni sullo stack degli strati
Un requisito fondamentale per controllare l'impedenza è includere un percorso di ritorno del segnale al di sotto di ciascun percorso di segnale. Il motore Simbeor SI supporta sia gli strati di piano sia gli strati di segnale ricoperti da un poligono. Questi strati di ritorno dovrebbero essere distribuiti nello stackup della scheda. Idealmente, sono disposti in modo che almeno uno strato di ritorno sia adiacente a ogni strato di segnale che ospita piste a impedenza controllata. Lo strato di ritorno adiacente fornisce il percorso di ritorno del segnale e, per ragioni che non verranno trattate qui, lo fa indipendentemente dalla tensione continua distribuita da quel piano.
La corrente di ritorno che scorre nel piano tenderà a seguire lo stesso percorso fisico della pista sullo strato di segnale; è quindi importante evitare di introdurre discontinuità, come una separazione o un'apertura nello strato di ritorno al di sotto di qualsiasi pista di segnale critica.
Oltre a selezionare un ordine adeguato per gli strati di segnale e di piano, è necessario definire anche le proprietà dei materiali di ciascuno strato, tra cui:
- Spessore del rame
- Spessore del dielettrico
- Costante dielettrica
Questi valori e la larghezza delle piste contribuiscono tutti all'impedenza finale. Ottenere l'impedenza richiesta diventa quindi un processo di regolazione di tutti questi valori. Occorre ricordare che anche i valori possibili per lo spessore del rame e del dielettrico possono essere limitati dai materiali disponibili presso il produttore del PCB.
► Ulteriori informazioni sui possibili stackup degli strati
Definizione dei profili di impedenza
Il motore Simbeor è integrato nel Layer Stack Manager dell'editor PCB (Design » Layer Stack Manager). Per configurare lo stack degli strati per il routing a impedenza controllata, passare alla scheda Layer Stack Manager's Impedance, dove è possibile aggiungere e configurare un profilo di impedenza.
Un profilo di impedenza da 50Ω definito per singole net instradate sullo strato superiore. Passare il cursore sull'immagine per visualizzare le impostazioni dello stesso profilo per lo strato L3.
Note sulla creazione e sulla configurazione di un profilo di impedenza:
- Nel Layer Stack Manager, passare alla scheda Impedance, come mostrato sopra.
-
Fare clic sul pulsante
(o sul pulsante
se è già stato definito un profilo) per aggiungere un nuovo profilo.
- Definire Type, Target Impedance e Target Tolerance dell'impedenza richiesta nel pannello Properties. Il campo Description è facoltativo e verrà visualizzato ovunque compaia il nome del profilo di impedenza.
-
La griglia degli strati è suddivisa in 2 aree: gli strati dello stackup vengono visualizzati a sinistra, mentre per ogni strato di segnale dello stackup viene visualizzato uno strato nell'area Profilo di impedenza a destra. Utilizzare la casella di controllo dello strato nell'area Profilo per abilitare il calcolo dell'impedenza per quello strato. Prendendo come esempio l'immagine qui sopra e facendo riferimento al numero di strato mostrato nella colonna più a sinistra, gli strati
L1,L3,L10eL12hanno la relativa casella di controllo selezionata e sono quindi abilitati per il calcolo dell'impedenza. - Quando fai clic su un layer abilitato nella sezione Profile, tutti i layer dello stack vengono attenuati, tranne quelli utilizzati per calcolare l'impedenza del layer di segnale selezionato (come mostrato nell'immagine sopra). Modifica i layer di riferimento di quel layer nelle colonne Top Ref e Bottom Ref della sezione Impedance Profile . Tieni presente che i layer di riferimento possono avere un layer Type di tipo
Planeo Signal. Ad esempio, nell'immagine sopra, il layerL10nello stackup è abilitato per i calcoli dell'impedenza, con Top Ref impostato su9-L9, che è un layerPlane, e Bottom Ref impostato su11-L11, che è un layer Signal . Il software presuppone che, se un layer di segnale viene utilizzato come piano di riferimento, contenga un piano di rame continuo collegato a una net di alimentazione o di massa. - Abilita la casella di controllo Impedance Profile per ogni altro layer su cui verranno instradate piste con questa impedenza e configura i piani di riferimento. Passa il cursore sull'immagine sopra per visualizzare il profilo di impedenza S50 del layer L3.
- Se la larghezza della pista calcolata è un valore non realizzabile dal produttore, puoi regolare le impostazioni di larghezza e distanza.
Regolazione delle impostazioni di larghezza e distanza
Il software calcola la larghezza della pista a partire dall'impedenza desiderata e dalla tolleranza. Non è raro che la larghezza calcolata sia un valore non realizzabile dal produttore, ad esempio 0,0683 mm. Il produttore indicherà gli spessori dei materiali disponibili e la precisione che può ottenere per le larghezze delle piste. Si procede quindi partendo dai valori desiderati e verificando l'effetto sui valori di impedenza calcolati quando le dimensioni vengono adattate a quelle disponibili.
Per supportare questo processo di verifica e regolazione delle impostazioni, i calcolatori di impedenza consentono calcoli diretti e inversi. La modalità predefinita è quella diretta: si inserisce l'impedenza e il software calcola la larghezza. L'icona
indica la variabile calcolata.
Un'impedenza desiderata di 50Ω fornisce una larghezza (W1) di 94,6 µm mediante calcolo diretto. L'immagine a destra mostra il calcolo inverso quando la larghezza (W1) è impostata su 95 µm.
Per invertire il calcolo e valutare diverse larghezze di pista per il layer selezionato, digita il nuovo valore Width (W1) e premi Invio sulla tastiera. I valori calcolati si aggiorneranno per riflettere l'effetto della modifica della larghezza. Fai clic sul pulsante
per riportare il calcolatore alla modalità di calcolo diretto. L'inserimento di un nuovo valore in Width (W2) modifica il valore Etch.
Per valutare i risultati relativi alla linea di trasmissione a coppia differenziale, seleziona la variabile da calcolare, Trace Width oppure Trace Gap, facendo clic sul pulsante
corrispondente. Modifica l'altra variabile per cambiare Target Impedance, oppure modifica Target Impedance per valutare l'effetto sull'altra variabile.
Fattore di incisione
Le piste di segnale su un PCB vengono realizzate rimuovendo il rame indesiderato mediante incisione chimica. Poiché l'agente incisore inizia a rimuovere il rame dalla superficie, questo rame rimane più a lungo a contatto con l'agente incisore. Di conseguenza, i bordi della pista finita risultano inclinati, riducendo l'area della sua sezione trasversale, come mostrato nell'immagine seguente.
L'area di rame persa ai bordi della pista (su entrambi i lati) durante l'incisione = X * Y
L'entità dell'inclinazione viene espressa mediante il fattore di incisione, dove:
Etch Factor = Y/X
Se Y = X, allora Etch Factor = 1
Facendo riferimento all'immagine mostrata nel pannello Properties:
Passa il cursore sul simbolo ? per visualizzare la formula.
La definizione standard del fattore di incisione lo esprime come rapporto di trace thickness / amount of over-etching. Si ottiene così la seguente formula:
Etch Factor = T/[0.5(W1-W2)]
Lo svantaggio di questo approccio è che, per specificare l'assenza di sovraincisione (ovvero bordi della pista verticali), sarebbe necessario inserire un valore di inf (infinito) per il fattore di incisione. Per semplificare l'impostazione dell'entità dell'incisione, la formula è stata invertita, in modo da poter inserire un valore di 0 (zero) per indicare l'assenza di sovraincisione.
Etch = [0.5(W1-W2)]/T
Orientamento del rame
Un altro dettaglio di fabbricazione che contribuisce al fattore di incisione è l'orientamento del rame. Le piste del PCB vengono formate rimuovendo per incisione il rame indesiderato da un foglio continuo di rame laminato su un substrato dielettrico. L'orientamento del rame definisce la direzione in cui il rame si estende rispetto al substrato. Può anche essere inteso come la direzione da cui il rame viene inciso: dall'alto o dal basso.
Fai clic sulla casella di controllo Trace Inverted per commutare l'orientamento del rame da Above a Below.
Rugosità superficiale del conduttore
La superficie di ogni layer di rame di un circuito stampato presenta un certo grado di rugosità. Durante la fabbricazione del PCB, la superficie dei layer di rame viene trattata per aumentarne la rugosità e migliorare l'adesione tra il rame e i layer dielettrici. Questa rugosità superficiale contribuisce in modo significativo all'impedenza del conduttore a velocità di commutazione superiori a 10 GB/s. Attraverso ricerche e analisi approfondite, gli esperti del settore hanno concluso che la rugosità superficiale può essere modellata mediante un coefficiente di correzione della rugosità ricavato dai valori Surface Roughness e Roughness Factor.
Roughness Le impostazioni sono disponibili nella modalità Layer Stack Manager del pannello Properties . Questi parametri vengono utilizzati solo per i layer conduttivi.
La rugosità superficiale è inclusa nel calcolo dell'impedenza caratteristica.
Rugosità:
-
Model Type - modello preferito per calcolare l'effetto della rugosità superficiale (consulta gli articoli riportati di seguito per ulteriori informazioni sui vari modelli). Si applica a tutti i layer di rame del sottostack.
-
Surface Roughness - valore della rugosità superficiale (disponibile presso il produttore). Inserisci un valore compreso tra 0 e 10 µm; il valore predefinito è 0,1 µm.
-
Roughness Factor - caratterizza l'aumento massimo previsto delle perdite nel conduttore dovuto all'effetto della rugosità. Inserisci un valore compreso tra 1 e 100; il valore predefinito è 2.
Approfondimenti
- Metodologia pratica per analizzare l'effetto della rugosità dei conduttori sulle perdite di segnale e sulla dispersione nelle interconnessioni: Y. Shlepnev, C. Nwachukwu, DesignCon2012.
- Approccio unificato alla modellazione della rugosità superficiale dei conduttori delle interconnessioni: Y. Shlepnev, 2017 IEEE 26th Conference on Electrical Performance of Electronic Packaging and Systems (EPEPS2017)
Supporto per strutture di linee di trasmissione coplanari
Il calcolatore di impedenza in Layer Stack Manager supporta strutture coplanari singole e differenziali. Crea un nuovo profilo di impedenza, quindi seleziona Single-Coplanar o Differential-Coplanar dall'elenco a discesa Type del profilo di impedenza.
Lavorare con strutture coplanari:
- Come per le impedenze standard singole e differenziali, i valori di ciascuna variabile vengono calcolati automaticamente in base a Target Impedance e Target Tolerance definiti dall'utente e alle proprietà fisiche degli strati della scheda. Questi valori calcolati automaticamente possono essere modificati inserendo nuovi valori nelle caselle di modifica della modalità Layer Stack Manager del pannello Properties.
- Per individuare le net di segnale da sbrogliare con una struttura coplanare, configura una regola di progettazione Larghezza di sbroglio (o Sbroglio delle coppie differenziali) con l'opzione Use Impedance Profile abilitata e il profilo di impedenza coplanare richiesto selezionato.
- Le strutture coplanari richiedono un piano di riferimento su entrambi i lati del percorso del segnale; questo può essere creato posizionando un poligono oppure, se vengono aggiunte delle via di cucitura, tramite il comando Add Shielding to Net (ulteriori informazioni di seguito). Se posizioni un poligono, la separazione tra questo e il percorso del segnale è definita dal valore Clearance (S) determinato dal calcolatore di impedenza Simbeor (visualizzato nel pannello Properties, mostrato nelle immagini sopra e sotto). Configura una regola di progettazione della distanza di isolamento per controllare la distanza tra il poligono di riferimento e il percorso del segnale (mostra immagine).
-
Quando la struttura coplanare è collegata a massa, è prassi comune includere una barriera di via lungo entrambi i lati della pista di segnale. A tale scopo, utilizza il comando Tools » Via Stitching/Shielding » Add Shielding to Net nell'editor PCB. Oltre a posizionare le via, abilitando l'opzione Add shielding copper questo comando può anche posizionare un poligono attorno al percorso del segnale per coprire la barriera di via, come mostrato nell'immagine in basso a destra.
► Scopri di più sulla schermatura con via
Il calcolatore di impedenza determina le proprietà del segnale e le distanze di isolamento (prima immagine); utilizza tale distanza nell'impostazione Distanza della schermatura con via.
Selezione del materiale degli strati
In un progetto a impedenza controllata, la selezione dei materiali utilizzati nello stackup degli strati è molto importante.
Ad esempio, il materiale più comune per la fabbricazione dei PCB è la resina epossidica rinforzata con fibra di vetro, con una lamina di rame incollata su ciascun lato. La densità della trama del tessuto in fibra di vetro influisce sul valore e sull'uniformità della costante dielettrica Dk (permittività) e della tangente di perdita Df. Il tessuto in fibra di vetro è circondato dalla resina: anche la percentuale di resina utilizzata è importante per le prestazioni del materiale.
È disponibile un'ampia gamma di trame in fibra di vetro. Per contribuire a garantire la prevedibilità e le prestazioni dei materiali a base di fibra di vetro utilizzati nella fabbricazione dei PCB, l'IPC ha definito uno standard per le trame:
IPC standard IPC-4412B: Specification for Finished Fabric Woven from "E" Glass for Printed Boards
La libreria dei materiali
In qualità di progettista, puoi modificare le proprietà dei materiali direttamente in Layer Stack Manager oppure selezionare i materiali da Altium Material Library.
L'intera libreria può essere visualizzata e ampliata nella finestra di dialogo Libreria dei materiali Altium (Tools » Material Library).
I materiali sono organizzati in categorie di utilizzo, accessibili tramite una struttura ad albero sul lato sinistro della finestra di dialogo. Al di sotto di questo livello, ogni categoria di utilizzo è suddivisa in categorie funzionali, come Conductive layer material, Dielectric layer material, e Surface Layer Material i nella categoria PCB layer material.
Aggiunta, salvataggio e caricamento dei materiali
È possibile aggiungere nuovi materiali alla libreria quando nell'albero è selezionata una categoria di materiali specifica. I materiali definiti in una libreria esterna possono essere caricati (pulsante Load), mentre i materiali definiti dall'utente aggiunti nella finestra di dialogo Altium Material Library possono anche essere salvati in una libreria utente (pulsante Save). Vengono salvati solo i materiali definiti dall'utente.
Aggiunta di proprietà personalizzate ai materiali
È possibile aggiungere proprietà personalizzate ai materiali presenti nella libreria, sia predefiniti sia definiti dall'utente. Per aggiungere una proprietà personalizzata, seleziona prima il nodo appropriato nell'albero a sinistra per definire i materiali a cui aggiungerla, quindi fai clic sul pulsante
per aprire la finestra di dialogo Material Library Settings.
Il valore richiesto può quindi essere aggiunto al materiale selezionato nella finestra di dialogo Altium Material Library; seleziona la riga e fai clic sul pulsante Edit.
Pannello Proprietà
Quando la scheda Impedance del documento Stack degli strati è attiva, il pannello Properties consente di configurare i requisiti del profilo di impedenza. Il profilo di impedenza richiesto può quindi essere selezionato nelle regole di progettazione Larghezza di sbroglio o Sbroglio delle coppie differenziali.
-
Impedance Profile
- Description – inserisci una descrizione significativa. Questo campo è facoltativo e verrà visualizzato ovunque sia visualizzato il nome del profilo di impedenza.
- Type – utilizza l'elenco a discesa per scegliere il tipo di impedenza. Le opzioni disponibili sono Single, Differential, Single-Coplanar e Differential-Coplanar.
- Target Impedance – inserisci l'impedenza che desideri ottenere.
- Target Tolerance – inserisci la tolleranza che desideri ottenere. Consulta il fabbricante per individuare un valore di tolleranza realistico che sia in grado di garantire.
-
Transmission Line
- Trace inverted – abilita questa opzione per invertire la pista, come illustrato nel pannello Properties. Questa opzione equivale all'opzione Copper Orientation visualizzata quando la scheda Stackup è attiva e definisce la direzione in cui il rame viene laminato sul core. L'orientamento del rame definisce la direzione in cui il rame si estende rispetto al substrato. Puoi anche considerarlo come la direzione da cui viene inciso il rame, dall'alto o dal basso.
-
Etch – il fattore di incisione è
= T/[(W1-W2)/2], che riduce l'area totale della sezione trasversale della pista di una quantità pari al quadrato dello spessore del rame. Consulta il fabbricante della scheda per informazioni sul Etch risultante dai suoi processi.
-
Width (W1) / (W2) – W1 è la larghezza della pista che tracci, W2 è la larghezza della superficie superiore della pista dopo l'incisione, con il fattore Etch applicato. Per la larghezza della pista è disponibile una funzione di calcolo diretto/inverso. Per impostazione predefinita, la larghezza viene calcolata in base al Target Impedance inserito (calcolo diretto). Tale larghezza potrebbe essere un valore che il fabbricante non è in grado di realizzare, ad esempio 5,978, e per il quale richiederà un valore più pratico, come 6,0. Puoi inserire 6,0 nel campo Width e premere Enter sulla tastiera per ricalcolare i valori (Impedance, Deviation, ecc.). Il pulsante
diventa grigio (inattivo) e si passa alla modalità di calcolo inverso. Se fai clic sul pulsante per attivarlo, torni alla modalità di calcolo diretto e il Width (W1) torna al valore calcolato. Questa funzione consente di valutare larghezze realisticamente realizzabili. Inserendo manualmente un valore per W2, il fattore di incisione viene aggiornato di conseguenza.
- Impedance – il software calcola l'impedenza in base alle proprietà dei materiali utilizzati per realizzare la scheda (rame, core e prepreg) e all'area della sezione trasversale della pista (determinata da larghezza, spessore e fattore di incisione della pista).
- Deviation – misura la differenza tra il risultato desiderato (impedenza obiettivo) e quello ottenuto (impedenza calcolata). Il software calcola lo scostamento dell'impedenza (il risultato effettivo in base al materiale e alle dimensioni inseriti) in base alle proprietà dei materiali utilizzati per realizzare la scheda (rame, core e prepreg) e all'area della sezione trasversale della pista (determinata da larghezza, spessore e fattore di incisione della pista).
- Delay – è il tempo impiegato dal segnale per viaggiare dal trasmettitore al ricevitore.
- Inductance – il calcolatore di impedenza utilizza il valore Impedance per calcolare l'induttanza per unità di lunghezza.
- Capacitance – il calcolatore di impedenza utilizza il valore Impedance per calcolare la capacità per unità di lunghezza.
-
Board
- Stack Symmetry – abilita questa opzione per aggiungere strati in coppie corrispondenti, simmetriche rispetto allo strato dielettrico centrale. Quando l'opzione è abilitata, viene immediatamente verificata la simmetria dello stack degli strati rispetto allo strato dielettrico centrale. Se una qualsiasi coppia di strati equidistanti dallo strato dielettrico centrale di riferimento non è composta da strati identici, si apre la finestra di dialogo Stack non simmetrico.
- Library Compliance – quando questa opzione è abilitata, per ogni strato selezionato dalla libreria dei materiali, le proprietà correnti dello strato vengono confrontate con i valori della definizione del materiale nella libreria.
- Substack – queste informazioni si riferiscono al sotto-stack attualmente selezionato (strati, dielettrico, spessori, ecc.). Quando passi da un sotto-stack all'altro, le informazioni si aggiornano di conseguenza (per il sotto-stack attualmente selezionato).
- Stack Name – inserisci un nome significativo per il sotto-stack. Questo campo è utile quando si assegna un sotto-stack di strati alla regione X/Y dello stackup.
- Is Flex – abilita questa opzione se il sotto-stack è flessibile.
- Layers – il numero totale di strati.
- Dielectrics – il numero totale di dielettrici.
- Conductive Thickness – lo spessore degli strati conduttivi. Gli strati di segnale in rame sono definiti strati conduttivi.
- Dielectric Thickness – lo spessore degli strati dielettrici.
- Total Thickness – lo spessore totale della scheda.
- Other
-
Roughness – mostra la rugosità degli strati conduttivi.
- Model Type – modello preferito per calcolare l'impatto della rugosità superficiale (consulta gli articoli seguenti per ulteriori informazioni sui vari modelli). Si applica a tutti gli strati di rame dello stack (dovrebbe essere il sotto-stack?).
- Surface Roughness – valore della rugosità superficiale (disponibile presso il fabbricante). Inserisci un valore compreso tra 0 e 10 µm; il valore predefinito è 0,1 µm.
- Roughness Factor – caratterizza il massimo aumento previsto delle perdite nel conduttore dovuto all'effetto della rugosità. Inserisci un valore compreso tra 1 e 100; il valore predefinito è 2.
Configurazione delle regole di progettazione
L'impedenza di sbroglio è determinata dalla larghezza e dall'altezza della pista e dalle proprietà dei materiali dielettrici circostanti. In base alle proprietà dei materiali definite nel Layer Stack Manager, le larghezze di sbroglio richieste vengono calcolate quando viene creato ciascun profilo di impedenza. A seconda delle proprietà dei materiali, la larghezza può variare al cambiare dello strato di sbroglio. Questa necessità di variare la larghezza quando si cambia strato di sbroglio viene gestita automaticamente dalla regola di progettazione per lo sbroglio applicabile, configurata nell'Editor delle regole e dei vincoli PCB (Design » Rules).
Per la maggior parte dei progetti di schede, un insieme specifico di net viene sbrogliato a impedenza controllata. Un approccio comune consiste nel creare una classe di net o una classe di coppie differenziali che includa queste net, quindi creare una regola di sbroglio destinata a tale classe, come mostrato nelle immagini seguenti.
Normalmente, si definiscono manualmente Min, Max e Preferred Widths, nelle impostazioni dei vincoli in alto per applicarle a tutti gli strati oppure singolarmente per ciascuno strato nella griglia degli strati. Per lo sbroglio a impedenza controllata, abilita invece l'opzione Use Impedance Profile, quindi seleziona il profilo di impedenza richiesto dal menu a discesa. Una volta eseguita questa operazione, la sezione Constraints della regola cambia. La prima cosa che noterai è che la sezione degli strati disponibili non mostra più tutti gli strati di segnale della scheda. Mostra solo gli strati abilitati nel profilo di impedenza selezionato. I valori Preferred Width (e la spaziatura delle coppie differenziali) vengono aggiornati per riflettere le larghezze (e le spaziature) calcolate per ciascuno strato. Questi valori preferiti non possono essere modificati, mentre i valori Min e Max sì. Impostali su valori inferiori/superiori appropriati. Le net possono quindi essere sbrogliate interattivamente nel modo consueto.
Regola di progettazione per la larghezza delle piste
Per le net single-ended, la larghezza delle piste è definita dalla regola di progettazione Larghezza delle piste.
Quando si sceglie di utilizzare un profilo di impedenza, i layer disponibili e le larghezze preferite sono determinati dal profilo selezionato.
Regola di progettazione per lo sbroglio delle coppie differenziali
Lo sbroglio delle coppie differenziali è controllato dalla regola di progettazione Sbroglio delle coppie differenziali.
Per una coppia differenziale, i layer disponibili, la larghezza preferita e la distanza preferita sono determinati dal profilo selezionato.
► Scopri di più sullo sbroglio delle coppie differenziali
Regola di progettazione per il percorso di ritorno
Le interruzioni o le strozzature nel percorso di ritorno possono essere rilevate dalla regola di progettazione Percorso di ritorno. La regola di progettazione Percorso di ritorno verifica la presenza di un percorso di ritorno continuo del segnale sui layer di riferimento designati, sopra o sotto i segnali a cui si applica la regola. Il percorso di ritorno può essere creato con riempimenti, regioni e riempimenti poligonali posizionati sul layer di segnale di riferimento o su un layer di piano.
I layer del percorso di ritorno sono i layer di riferimento definiti nel Impedance Profile selezionato nella regola di progettazione Return Path. Questi layer vengono controllati per garantire che il valore specificato di Minimum Gap (larghezza oltre il bordo del segnale) sia rispettato lungo il percorso del segnale. Aggiungi una nuova regola di progettazione Return Path nella categoria di regole High Speed.
I layer del percorso di ritorno sono definiti nel Impedance Profile selezionato e la larghezza del percorso (oltre il bordo del segnale) è definita da Minimum Gap.
L'immagine seguente mostra gli errori del percorso di ritorno rilevati per il segnale, NetXcon un'impostazione di Minimum Gap pari a 0.1mm. Per individuare più facilmente gli errori del percorso di ritorno, è possibile configurare DRC Violation Display Style in modo da mostrare i dettagli delle violazioni ma non la relativa sovrapposizione grafica (mostra immagine) nella finestra di dialogo Preferences. In questo modo vengono evidenziati i punti esatti in cui la regola non è rispettata, anziché gli interi oggetti che la violano.
► Scopri di più sulla progettazione ad alta velocità in Altium Designer
Sbroglio delle net all'impedenza richiesta
Durante lo sbroglio della scheda e il passaggio da un layer all'altro, il software regola automaticamente la larghezza delle piste al valore necessario per ottenere l'impedenza specificata. Questo sbroglio interattivo a impedenza controllata semplifica notevolmente la progettazione di un PCB a impedenza controllata.
Regolazione della lunghezza delle piste
Due delle sfide principali nello sbroglio di un progetto ad alta velocità sono il controllo dell'impedenza delle piste e l'equalizzazione delle lunghezze delle net critiche. Lo sbroglio a impedenza controllata garantisce che il segnale in uscita da un pin venga ricevuto correttamente dai pin di ingresso di destinazione. L'equalizzazione delle lunghezze delle piste garantisce che i segnali con requisiti temporali critici arrivino contemporaneamente ai rispettivi pin di destinazione. La regolazione e l'equalizzazione delle lunghezze delle piste sono essenziali anche per lo sbroglio delle coppie differenziali.
Alle piste sono stati aggiunti tratti a fisarmonica per garantire che le coppie differenziali abbiano lunghezze uguali.
I comandi Interactive Length Tuning e Interactive Diff Pair Length Tuning (menu Route) consentono di ottimizzare e controllare dinamicamente le lunghezze delle net o delle coppie differenziali, inserendo tratti ondulati ad ampiezza variabile (a fisarmonica) in base allo spazio disponibile, alle regole e agli ostacoli presenti nel progetto.
► Scopri di più sulla regolazione della lunghezza
Verifica dell'integrità del segnale della scheda sbrogliata
Come hai verificato le net durante la stesura del progetto utilizzando valori ipotizzati di lunghezza e impedenza delle piste, una volta completato lo sbroglio dovresti ripetere questa procedura sulla scheda per verificare la presenza di potenziali disadattamenti di impedenza e problemi di riflessione. Avvia il comando Signal Integrity dal menu Tools dell'editor PCB. Poiché il PCB fa parte del progetto, le proprietà dei materiali e le dimensioni definite nel Layer Stack Manager, insieme alle larghezze effettive delle piste sulla scheda, verranno utilizzate per calcolare le impedenze impiegate nelle verifiche di integrità del segnale.
Ottenere le impedenze specificate
Oltre al processo iterativo di regolazione delle dimensioni necessario per ottenere le impedenze corrette, esistono altri fattori che influenzano l'impedenza finale del PCB prodotto. Tra questi rientrano l'uniformità e la stabilità del materiale dielettrico utilizzato nel PCB, nonché l'uniformità e la qualità del processo di incisione. Se hai bisogno di un PCB a impedenza controllata, dovresti discuterne con il produttore di PCB. Alcuni produttori possono consigliare le geometrie delle piste se fornisci loro lo stackup desiderato. Molti possono anche includere un coupon di prova dell'impedenza in ogni pannello prodotto, che può essere utilizzato per misurare le impedenze effettivamente ottenute sulla scheda.
Ulteriori letture e risorse
Questo articolo introduce il tema dell'integrità del segnale e della progettazione di PCB a impedenza controllata. Utilizza i seguenti link per approfondire e accedere alle risorse sviluppate da esperti riconosciuti del settore.



