Progettazione ad alta velocità

A colpo d'occhio

Questo articolo illustra come Altium Designer supporta il layout dei PCB ad alta velocità, aiutandoti a gestire l'integrità del segnale, definire i percorsi critici dei segnali e applicare regole di sbroglio a impedenza controllata basate sullo stackup e sui materiali della scheda. Presenta gli elementi progettuali fondamentali da considerare, spiega come utilizzare l'analisi dell'integrità del segnale prima e dopo il layout per individuare tempestivamente i problemi di riflessione e mostra come funzionalità quali xSignals, profili di impedenza e regole di sbroglio lavorino insieme per guidare una realizzazione accurata dei circuiti ad alta velocità. Se vuoi capire meglio come configurare Altium Designer per progettare schede ad alta velocità affidabili, questa panoramica ti aiuterà a comprendere come integrare gli strumenti e le impostazioni essenziali. Continua a leggere per acquisire maggiore sicurezza, passo dopo passo.

- Scopri i principali fattori della progettazione ad alta velocità che Altium Designer ti aiuta a gestire, dalle terminazioni e dai percorsi di ritorno ai via, alle coppie differenziali e al controllo delle lunghezze.
- Scopri come utilizzare l'analisi dell'integrità del segnale prima e dopo il layout per individuare potenziali problemi di riflessione e perfezionare le scelte relative alle terminazioni.
- Impara a utilizzare xSignals, i profili di impedenza dello stackup e le regole di progettazione per lo sbroglio per definire, misurare e controllare i percorsi critici dei segnali ad alta velocità.
Approfondisci con l'IA:

Progettazione ad alta velocità in Altium Designer

La progettazione di circuiti stampati ad alta velocità è un processo che bilancia i requisiti di progettazione del circuito, le tecnologie dei dispositivi e i materiali e i metodi di fabbricazione, per realizzare un PCB in grado di trasferire i segnali tra i componenti preservandone l'integrità.

Questa pagina descrive le varie opzioni e impostazioni da configurare in Altium Designer per progettare con successo una scheda ad alta velocità. Se desideri approfondire la progettazione ad alta velocità, consulta Elementi chiave della progettazione PCB ad alta velocità.

Elementi da considerare

Il processo di sbroglio di una scheda con segnali ad alta velocità richiede di gestire:

  • Gli eventuali componenti di terminazione necessari

  • La definizione dei segnali a cui applicare le regole di progettazione ad alta velocità

  • Le dimensioni fisiche delle piste, per lo sbroglio a impedenza controllata

  • Le proprietà e le dimensioni dei materiali della scheda

  • Il numero e la disposizione degli strati nello stackup

  • Il percorso di ritorno di ciascun segnale ad alta velocità

  • L'impatto e la configurazione dei via

  • La configurazione e lo sbroglio delle coppie differenziali

  • La configurazione e il controllo delle lunghezze delle piste

Analisi dell'integrità del segnale pre-layout e post-layout

Nelle prime fasi del processo di progettazione, è importante identificare i segnali che potrebbero richiedere un adattamento di impedenza, in modo da poter includere ulteriori componenti di terminazione prima di completare il posizionamento dei componenti. Poiché i pin di uscita sono in genere a bassa impedenza e quelli di ingresso ad alta impedenza, potrebbe essere necessario aggiungere componenti di terminazione al progetto per ottenere l'adattamento di impedenza.

Altium Designer include un simulatore dell'integrità del segnale accessibile sia durante l'acquisizione del progetto sia durante la definizione del layout della scheda, consentendo di eseguire analisi dell'integrità del segnale sia pre-layout sia post-layout (Tools » Signal Integrity). Il simulatore dell'integrità del segnale modella il comportamento della scheda sbrogliata utilizzando come dati di ingresso per le simulazioni l'impedenza caratteristica calcolata delle piste, combinata con le informazioni dei macromodelli dei buffer di I/O. Il simulatore si basa su un simulatore rapido di riflessioni e diafonia, che produce simulazioni molto accurate utilizzando algoritmi collaudati nel settore.

Poiché sia l'acquisizione del progetto sia la progettazione della scheda utilizzano un sistema integrato di componenti che collega i simboli dello schema ai relativi footprint PCB, ai modelli di simulazione SPICE e ai macromodelli dell'integrità del segnale, l'analisi dell'integrità del segnale può essere eseguita durante la fase di acquisizione dello schema, prima della creazione del progetto della scheda. Quando non è ancora presente un progetto della scheda, lo strumento consente di impostare le caratteristiche fisiche del progetto, come l'impedenza caratteristica desiderata delle piste, direttamente nel simulatore dell'integrità del segnale. In questa fase pre-layout del processo di progettazione, il simulatore dell'integrità del segnale non può determinare la lunghezza effettiva di specifiche connessioni, quindi utilizza una lunghezza media delle connessioni definibile dall'utente per eseguire i calcoli delle linee di trasmissione. Scegliendo con attenzione questa lunghezza predefinita in modo che rispecchi le dimensioni della scheda prevista, è possibile ottenere un quadro piuttosto accurato delle probabili prestazioni del progetto in termini di integrità del segnale.

È possibile identificare le net con potenziali problemi di riflessione e aggiungere allo schema eventuali componenti di terminazione aggiuntivi prima di procedere al layout della scheda. I valori di questi componenti possono quindi essere ulteriormente ottimizzati dopo aver eseguito l'analisi dell'integrità del segnale post-layout.

Il motore di analisi dell'integrità del segnale aiuta a identificare le net con potenziali problemi di riflessione. È possibile effettuare misurazioni direttamente sulle forme d'onda.
Il motore di analisi dell'integrità del segnale aiuta a identificare le net con potenziali problemi di riflessione. È possibile effettuare misurazioni direttamente sulle forme d'onda.

► Scopri di più su Adattamento di impedenza dei componenti

Per accedere al motore di analisi dell'integrità del segnale in Altium Designer, deve essere installata l'estensione di sistema Signal Integrity Analysis. Questa estensione viene installata per impostazione predefinita con Altium Designer. Può essere installata o rimossa manualmente.

Per ulteriori informazioni sulla gestione delle estensioni, consulta la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definizione dei segnali ad alta velocità

Main page: Definizione dei percorsi dei segnali ad alta velocità con xSignals

La progettazione ad alta velocità è l'arte di gestire il flusso di energia da un punto a un altro di un circuito stampato. Come progettista, devi poter concentrare l'attenzione e applicare i vincoli di progettazione a un segnale che viaggia da un punto della scheda a un altro. Il segnale su cui ti concentri, tuttavia, non corrisponde necessariamente a una singola net PCB. Potrebbe trattarsi di un ramo di A0 in un progetto che intendi sbrogliare con una topologia a T, mentre l'altro ramo di A0 costituisce un altro segnale su cui devi concentrarti, con la necessità di poter confrontare le lunghezze dei percorsi dei due segnali. Oppure il segnale potrebbe includere un componente di terminazione in serie lungo il suo percorso (che l'editor PCB interpreta come un componente e due net PCB) e, se tale segnale fa parte di una coppia differenziale, la sua lunghezza deve essere confrontata con quella dell'altro segnale della coppia.

Puoi gestire questi requisiti utilizzando una funzionalità chiamata xSignals, in cui un xSignal è essenzialmente un percorso di segnale definito dall'utente. Seleziona il pad di origine e il pad di destinazione (nell'area di lavoro o nel pannello PCB), quindi fai clic con il pulsante destro del mouse su uno dei due per definire quel percorso di segnale come xSignal. Oltre a definire interattivamente un xSignal tramite i pad iniziale e finale, puoi anche eseguire la procedura guidata intelligente xSignals Wizard, i cui algoritmi euristici ti aiutano a configurare rapidamente un gran numero di xSignals tra i componenti selezionati. Questi xSignals possono quindi essere utilizzati per applicare le regole di progettazione ai segnali ad alta velocità. Il software riconosce la struttura di questi xSignals: ad esempio, calcola la lunghezza complessiva di più net collegate attraverso un componente di terminazione, oltre alla distanza percorsa all'interno di tale componente.

Il pannello PCB include una modalità xSignal utilizzata per esaminare e gestire gli xSignals. Il pannello fornisce inoltre indicazioni sulla lunghezza del segnale, evidenziando gli xSignals che sono prossimi a rispettare (giallo) o che non rispettano (rosso) i vincoli di progettazione applicabili. Nell'immagine seguente, le lunghezze degli xSignals della coppia differenziale CLK1 differiscono tra loro più di quanto consentito dalla regola di progettazione Matched Length applicabile. Il pannello include la Signal Length, che rappresenta una lunghezza punto a punto accurata. Le consuete incongruenze nel calcolo della lunghezza, come le piste all'interno dei pad e i segmenti di pista sovrapposti, vengono risolte e, per calcolare la lunghezza del segnale, vengono utilizzate distanze precise di attraversamento dei via.

Utilizza la modalità xSignals del pannello PCB per gestire ed esaminare i tuoi xSignals. Nota la linea sottile: indica il percorso del segnale attraverso un componente in serie. (Immagine per gentile concessione di FEDEVEL Open Source, www.fedevel.com)
Utilizza la modalità xSignals del pannello PCB per gestire ed esaminare i tuoi xSignals. Nota la linea sottile: indica il percorso del segnale attraverso un componente in serie. (Immagine per gentile concessione di FEDEVEL Open Source, www.fedevel.com)

È supportato anche il ritardo causato dalla lunghezza del pin all'interno del package del dispositivo, definendo il ritardo del pin nel package.

► Scopri di più su xSignals.

Definizione delle proprietà dello sbroglio

Main page: Sbroglio a impedenza controllata

Tradizionalmente, i progettisti di PCB definivano la larghezza e lo spessore delle piste inserendo una dimensione per la larghezza e selezionando uno spessore del rame per il relativo layer. In genere questo era sufficiente, poiché bastava garantire che le piste potessero condurre la corrente e che fossero rispettate le distanze di isolamento richieste dalla tensione. Questo approccio non è sufficiente per i segnali ad alta velocità del progetto, per i quali è necessario controllare l'impedenza delle piste.

Il routing a impedenza controllata consiste nel configurare le dimensioni delle piste e le proprietà dei materiali della scheda per ottenere un'impedenza specifica. A tale scopo, si definisce un profilo di impedenza adeguato e lo si assegna alle net critiche ad alta velocità nelle regole di progettazione del routing.

Definizione del profilo di impedenza

Main page: Configurazione dello stack dei layer per il routing a impedenza controllata

I profili di impedenza vengono definiti nel Layer Stack Manager dell'editor PCB (Design » Layer Stack Manager). Il Layer Stack Manager si apre in un editor di documenti, proprio come un foglio schematico, il PCB e altri tipi di documenti.

Una volta configurate le proprietà dei layer, passare alla scheda Layer Stack Manager's Impedance per aggiungere o modificare i profili di impedenza single-ended o differenziali.

Un profilo di impedenza da 50 Ω definito per singole net instradate sul layer superiore; passare il cursore sull'immagine per visualizzare le impostazioni dello stesso profilo per il layer L3.Un profilo di impedenza da 50 Ω definito per singole net instradate sul layer superiore; passare il cursore sull'immagine per visualizzare le impostazioni dello stesso profilo per il layer L3.

I calcoli dell'impedenza vengono eseguiti dal motore elettromagnetico per l'integrità del segnale Simbeor® SFS di Simberian. Simbeor SFS è un solutore di campo 2D quasi statico avanzato basato sul metodo dei momenti, convalidato mediante analisi di convergenza, confronti e misurazioni. Il motore Simbeor SFS supporta tutte le strutture e i materiali delle schede moderne, compreso l'utilizzo di poligoni sui layer di segnale come layer di riferimento.

► Scopri di più sulla configurazione dello stack dei layer per il routing a impedenza controllata

Configurazione delle regole di progettazione

L'impedenza delle piste è determinata dalla loro larghezza e dal loro spessore, nonché dalle proprietà dei materiali dielettrici circostanti. In base alle proprietà dei materiali definite nel Layer Stack Manager, le larghezze delle piste richieste vengono calcolate quando si crea ciascun profilo di impedenza. A seconda delle proprietà dei materiali, la larghezza può variare al cambiare del layer di routing. La necessità di modificare le larghezze quando si cambia layer di routing viene gestita automaticamente dalla regola di progettazione del routing applicabile, configurata nell'editor delle regole e dei vincoli PCB (Design » Rules).

Per la maggior parte dei progetti di schede, esiste un insieme specifico di net da instradare a impedenza controllata. Un approccio comune consiste nel creare una classe di net o una classe di coppie differenziali che includa queste net, quindi creare una regola di routing che si applichi a tale classe, come mostrato nelle immagini seguenti.

Normalmente, le larghezze minima, massima e preferita vengono definite manualmente, nelle impostazioni dei vincoli in alto per applicarle a tutti i layer oppure singolarmente per ciascun layer nella griglia dei layer. Per il routing a impedenza controllata, invece, si abilita l'opzione Use Impedance Profile e si seleziona il profilo di impedenza desiderato dal menu a discesa. A questo punto, l'area Constraints della regola cambia. La prima cosa che si noterà è che l'area dei layer disponibili della regola di progettazione non mostrerà più tutti i layer di segnale della scheda, ma solo quelli abilitati nel profilo di impedenza selezionato. I valori della larghezza preferita e della distanza tra le piste della coppia differenziale verranno aggiornati in base alle larghezze e alle distanze calcolate per ciascun layer. Questi valori preferiti non possono essere modificati, mentre i valori minimo e massimo possono esserlo: impostarli su valori opportunamente inferiori e superiori.

Regola di progettazione della larghezza delle piste

Per le net single-ended, la larghezza delle piste è definita dalla regola di progettazione Larghezza delle piste.

Quando si sceglie di utilizzare un profilo di impedenza, i layer disponibili e le larghezze preferite sono controllati dal profilo selezionato.Quando si sceglie di utilizzare un profilo di impedenza, i layer disponibili e le larghezze preferite sono controllati dal profilo selezionato.

Regola di progettazione del routing delle coppie differenziali

Il routing delle coppie differenziali è controllato dalla regola di progettazione Routing delle coppie differenziali.

Per una coppia differenziale, i layer disponibili, la larghezza preferita e la distanza preferita sono controllati dal profilo selezionato.Per una coppia differenziale, i layer disponibili, la larghezza preferita e la distanza preferita sono controllati dal profilo selezionato.

► Scopri di più sul routing delle coppie differenziali

Gli angoli nelle piste dei segnali ad alta velocità sono oggetto di ampio dibattito. Sebbene sia assodato che gli elettroni non schizzino fuori quando incontrano un angolo di 90 gradi, un tradizionale angolo di 90 gradi presenta una larghezza maggiore lungo la diagonale, il che modifica l'impedenza della pista. Sono preferibili angoli arrotondati o a 45 gradi, entrambi disponibili come funzionalità standard del router interattivo dell'editor PCB; se necessario, gli angoli di 90 gradi possono essere smussati utilizzando il comando Convert Selected Tracks to Chamfered Path. Si noti che questo comando converte i segmenti di pista selezionati in un unico oggetto regione.

Scelta dell'impedenza

Come si determina quindi quale impedenza obiettivo scegliere? Normalmente, la scelta dipende dall'impedenza caratteristica della sorgente della famiglia logica o della tecnologia utilizzata. Ad esempio, la logica ECL ha un'impedenza caratteristica di 50Ω, mentre la logica TTL ha un'impedenza di sorgente compresa tra 70Ω e 100Ω. Un'impedenza obiettivo compresa tra 50Ω e 60Ω è comune in molti progetti; per le coppie differenziali, sono comuni impedenze differenziali di 90Ω o 100 Ω. Occorre ricordare che, più bassa è l'impedenza, maggiore è l'assorbimento di corrente; più alta è l'impedenza, maggiore è la probabilità di emissioni elettromagnetiche (EMI) e maggiore è la suscettibilità del segnale alla diafonia.

Una coppia differenziale da 100Ω può anche essere considerata come due piste single-ended da 50Ω della stessa lunghezza. Questo non è del tutto corretto a causa dell'accoppiamento tra le due piste, che diventa più forte man mano che si avvicinano, riducendo l'impedenza differenziale della coppia. Per mantenere un'impedenza differenziale di 100Ω , è possibile ridurre la larghezza di ciascuna pista, aumentando così leggermente, di alcuni ohm, l'impedenza caratteristica di ciascuna pista della coppia.

Definizione delle proprietà della scheda

Main page: Gestione dello stack dei layer

I materiali utilizzati per i layer della scheda, le loro dimensioni, il numero e l'ordine dei layer vengono tutti definiti nel gestore dello stack dei layer. Qui si configurano i vari layer necessari per fabbricare la scheda finale, compresi i layer di segnale e i piani in rame, i layer dielettrici che separano il rame, i layer di copertura e la serigrafia dei componenti.

Tutti i layer da fabbricare vengono definiti nella scheda Stackup del gestore dello stack dei layer.
Tutti i layer da fabbricare vengono definiti nella scheda Stackup del gestore dello stack dei layer.

Le informazioni dettagliate sulle proprietà dei materiali inserite nel Layer Stack Manager sono incluse nella tabella dello stack dei layer e anche nella legenda dello stack dei layer inserita in un documento Draftsman.

È inoltre possibile Save uno stack dei layer come modello nel Layer Stack Manager (menu File) e Load tale modello nei progetti futuri.

Configurazione dei via

Main page: Definizione dei tipi di via

Come accennato nella sezione panoramica di questa pagina, i via influiscono sull'impedenza delle piste di segnale e rappresentano un aspetto fondamentale nella progettazione ad alta velocità. Oltre alla lunghezza, al diametro del foro e all'area della piazzola del via, che influiscono sull'impedenza vista dal segnale, qualsiasi porzione inutilizzata del cilindro metallizzato di un via può agire da stub, contribuendo alle riflessioni del segnale. Per gestire questo fenomeno, è possibile realizzare vari tipi di via tra i layer, tra cui via ciechi, interrati, microvia e via a salto di layer. Tutti questi tipi di via sono supportati in Altium Designer.

I via vengono definiti come parte dello stack dei layer, nella scheda Layer Stack Manager's Via Types. È supportata anche la rimozione mediante back drilling delle porzioni inutilizzate dei cilindri metallizzati dei via; queste vengono definite nella scheda Layer Stack Manager's Back Drills (scopri di più sulla configurazione della scheda per il back drilling).

Tutti i vari tipi di via realizzabili possono essere definiti nella scheda Via Types del Layer Stack Manager.Tutti i vari tipi di via realizzabili possono essere definiti nella scheda Via Types del Layer Stack Manager.

Sono stati condotti studi quantitativi per comprendere l'impatto dei via, come la nota applicativa Altera AN529 Tecniche di ottimizzazione dei via per la progettazione di canali ad alta velocità.

Riassumendo questo studio e altri riferimenti, si riportano le seguenti linee guida per ridurre al minimo l'impatto dei via:

  • Ridurre le dimensioni dell'anello anulare del via nel punto in cui la pista di segnale si collega al via; la nota applicativa suggerisce un diametro del via/foro di 20/10 mil (0,5/0,25 mm) per i via realizzati mediante foratura meccanica.
  • Rimuovere gli anelli anulari inutilizzati (noti anche come NFP, ovvero piazzole non funzionali) sui layer ai quali il via non è collegato. A tale scopo, utilizzare il comando Tools » Remove Unused Pad Shapes.
  • Aumentare la distanza di isolamento tra il cilindro metallizzato del via e i layer di piano adiacenti. Questa distanza è controllata dalla regola di progettazione Power Plane Clearance; la nota applicativa suggerisce da 40 a 50 mil (da 1,0 a 1,25 mm). Tenere presente che questo aumenta le dimensioni delle aperture in tali layer di piano.
  • Posizionare via di cucitura accanto ai via di segnale ogni volta che la pista di segnale cambia layer, causando il passaggio del percorso di ritorno a un altro layer. Se il nuovo layer del piano di riferimento ha la stessa tensione del piano di riferimento originale, i due piani devono essere collegati tra loro con un via, entro 35 mil (0,9 mm) dal via di segnale (da centro a centro).
  • Quando la pista di segnale cambia layer e il nuovo layer del piano di riferimento ha una tensione diversa, posizionare condensatori di disaccoppiamento accanto al via di segnale. Il condensatore fornisce un disaccoppiamento diretto tra i due piani, indipendentemente dalle rispettive tensioni. Tenere presente che questa soluzione può causare l'accoppiamento del rumore da un piano all'altro; pertanto, deve essere adottata solo come ultima risorsa per ridurre l'area dell'anello del percorso di ritorno.
  • Rimuovere gli stub dei via (la porzione di via che si estende oltre il layer sul quale la pista di segnale si collega al via). A tale scopo si utilizzano via ciechi e interrati appropriati oppure il back drilling dei via durante la fabbricazione.

La progettazione dei via è un elemento fondamentale del processo di progettazione di schede ad alta velocità. Le possibili opzioni di collegamento tra i layer tramite via sono determinate dal processo di fabbricazione scelto per realizzare lo stack dei layer; questo significa che è necessario scegliere il processo di fabbricazione e foratura durante la definizione del tipo di via e dello stack dei layer.

L'editor PCB supporta il back drilling (detto anche foratura a profondità controllata). Questa funzionalità consente il back drilling da entrambi i lati della scheda e permette di esaminare facilmente i punti sottoposti a back drilling nel pannello PCB, con la scheda visualizzata in modalità 3D.

Scopri di più sulla foratura a profondità controllata.

Gestione del percorso di ritorno per i segnali ad alta velocità

Un percorso di ritorno di buona qualità è essenziale per ogni segnale ad alta velocità del progetto. Ogni volta che il percorso di ritorno devia e non scorre al di sotto della pista di segnale, si crea un anello che genera interferenze elettromagnetiche (EMI), la cui entità è direttamente correlata all'area dell'anello.

Creazione di piani di alimentazione

  • Un piano di alimentazione può essere creato a partire da un layer di piano oppure da un layer di segnale ricoperto da uno o più poligoni.
  • Creazione di un piano di alimentazione con un layer di piano:
    • I layer di piano vengono aggiunti nel Layer Stack Manager; fare clic con il pulsante destro del mouse su un layer esistente per Insert layer above o Insert layer below e aggiungere un nuovo layer di piano.
    • Con il layer di piano selezionato come layer attivo, fare doppio clic in un punto qualsiasi del piano per aprire la finestra di dialogo Split Plane, nella quale è possibile assegnare la net.
    • Il software arretra automaticamente il bordo del piano rispetto al bordo della scheda della distanza specificata nella colonna Pullback Distance per quel layer nel Layer Stack Manager. Se la colonna non è visibile, fare clic con il pulsante destro del mouse sull'intestazione di una colonna esistente per accedere al comando Select Columns.
    • Un layer di piano può essere suddiviso in regioni separate posizionando delle linee (Place » Line). Premere Tab dopo aver iniziato a posizionare il primo segmento di linea per impostare la larghezza della linea di separazione. Posizionare i segmenti di linea da un bordo all'altro della scheda oppure creare una forma chiusa per ottenere un'isola. Il software rileva automaticamente le forme separate create dalle linee di separazione; fare doppio clic su ciascuna forma per assegnarla a una net.
  • Creazione di un piano di alimentazione con poligoni su un layer di segnale:
    • I layer di segnale vengono aggiunti nel Layer Stack Manager; fare clic con il pulsante destro del mouse su un layer esistente per Insert layer above o Insert layer below e aggiungere un nuovo layer di segnale.
    • Se sono necessarie zone di alimentazione separate, può essere più semplice ricoprire l'intero layer con un poligono e poi dividerlo (Place » Slice Polygon Pour). Premere Tab dopo aver iniziato a posizionare la linea di taglio per aprire la finestra di dialogo Line Constraints, nella quale è possibile impostare la larghezza del taglio: questa larghezza diventerà la distanza tra i due poligoni creati dall'operazione di divisione. La linea di taglio deve iniziare e terminare all'esterno del poligono.
    • Per ricalcolare il riempimento di un poligono, fare clic con il pulsante destro del mouse e selezionare Polygon Actions » Repour Selected dal menu contestuale. 
    • I poligoni possono anche essere accantonati (nascosti temporaneamente): fare clic con il pulsante destro del mouse e selezionare il comando pertinente dal Polygon Actions sottomenu. Utilizzare questa funzionalità quando è necessario spostare componenti e piste.
  • Può essere utile visualizzare le diverse net con colori differenti, come mostrato nelle immagini seguenti. Questa operazione può essere eseguita nello schema elettrico o nel PCB; scopri di più su come applicare colori alle net.

La prima immagine mostra un layer di piano suddiviso in zone da 3,3 V e 5,0 V; la seconda immagine mostra un layer di segnale con un poligono da 3,3 V e un poligono da 5,0 V. Sono stati assegnati i colori alle net ed è stata abilitata l'evidenziazione.  Two power zones created by polygons on a signal layerLa prima immagine mostra un layer di piano suddiviso in zone da 3,3 V e 5,0 V; la seconda immagine mostra un layer di segnale con un poligono da 3,3 V e un poligono da 5,0 V. Sono stati assegnati i colori alle net ed è stata abilitata l'evidenziazione.

Il piano come percorso di ritorno del segnale

Un percorso di ritorno di buona qualità è un percorso in cui:

  • Non sono presenti interruzioni, separazioni o aperture (fori nel piano creati da un via o da un pin a foro passante) sotto la pista di segnale nel piano che fornisce il percorso di ritorno (il piano più vicino al segnale di interesse).
  • La larghezza del percorso di ritorno dovrebbe idealmente essere pari a 3 volte la larghezza della pista del segnale o a 3 volte la distanza tra la pista e il piano, scegliendo il valore minore. Sebbene la densità di corrente sia massima direttamente sotto la pista del segnale, la corrente si distribuisce anche nel piano su entrambi i lati della pista, con circa il 95% che scorre entro una larghezza pari a 3 volte quella della pista. Le interruzioni del piano all'interno di questa regione aumentano l'impedenza del percorso di ritorno e qualsiasi deviazione del percorso di ritorno crea una spira. In termini di integrità del segnale, questo aumento dell'impedenza del percorso di ritorno influisce sulla qualità del segnale tanto quanto un aumento dell'impedenza del percorso del segnale.
  • L'area della spira è stata ridotta al minimo. In generale, è più importante ridurre l'area della spira che minimizzare la lunghezza della pista del segnale. Se il percorso di ritorno incontra una zona priva di rame, valuta la possibilità di modificare il percorso del segnale per adattarlo a un percorso di ritorno disponibile. 
  • Quando un piano di alimentazione fornisce il percorso di ritorno, l'energia di ritorno raggiunge infine la massa attraverso un condensatore di disaccoppiamento. Valuta attentamente la posizione dei condensatori di disaccoppiamento vicino al pin sorgente del segnale per ridurre al minimo le dimensioni di qualsiasi spira che si viene a creare.

Gestione di piani di alimentazione e di massa divisi e multipli

È opinione comune che un piano di massa non debba essere diviso, a meno che non vi sia un'esigenza specifica e si sappia come definirlo e gestirlo. È preferibile, invece, disporre i componenti in modo da mantenere separati quelli rumorosi da quelli poco rumorosi e raggrupparli anche in base alla linea di alimentazione utilizzata.

Altri aspetti da tenere presenti riguardo ai piani di alimentazione e di massa:

  • Se il progetto richiede che un piano di massa sia parzialmente diviso, i segnali che attraversano tali aree devono essere instradati sul ponte, ovvero nella zona senza divisioni sottostanti.
  • Se l'obiettivo è ridurre al minimo il rumore del circuito, è preferibile utilizzare piani di massa aggiuntivi anziché dividere un piano e, ove possibile, includere strati di piano sia per la linea di alimentazione sia per la massa di ciascun alimentatore regolato. 
  • Se il progetto include più linee di alimentazione, ciascuna distribuita sul proprio piano, assicurati che ogni piano di alimentazione faccia riferimento esclusivamente al proprio piano di massa. Non consentire a un piano di alimentazione di sovrapporsi al piano di massa di un'altra linea, utilizzandolo come riferimento. Ciò crea un accoppiamento capacitivo che consente al rumore di passare da un'alimentazione all'altra.
  • Se il piano adiacente è un piano di alimentazione che deve essere diviso in aree a tensioni diverse, potrebbe essere necessario inserire un disaccoppiamento direttamente tra le due aree per fornire un percorso di ritorno adeguato.

Visualizzazione dei piani divisi

Per facilitare il controllo visivo dei percorsi di ritorno, puoi configurare la visualizzazione in modo da esaminare più facilmente il percorso di ritorno sotto le piste dei segnali critici.

Verifica dell'eventuale attraversamento di una linea di divisione da parte dei segnali che passano tra aree del piano a tensioni diverse. Le quattro net evidenziate attraversano una divisione nel piano di alimentazione VCC, creando un'interruzione nel percorso di ritorno di tali segnali.
Verifica dell'eventuale attraversamento di una linea di divisione da parte dei segnali che passano tra aree del piano a tensioni diverse. Le quattro net evidenziate attraversano una divisione nel piano di alimentazione VCC, creando un'interruzione nel percorso di ritorno di tali segnali.

Per farlo:

  • Assegna un colore a ciascuna net di alimentazione; per saperne di più, consulta Applicazione dei colori alle net.
  • Limita la visualizzazione ai soli strati di segnale e di piano pertinenti. Questo insieme di strati può essere salvato come set di strati; per saperne di più, consulta Creazione di un set di strati.
  • Passa allo strato di segnale e Ctrl+Click sulla net desiderata per evidenziarla (tieni premuto anche Shift mentre fai clic per evidenziare più net). Il vantaggio dell'evidenziazione rispetto alla selezione è che è persistente: le net rimangono evidenziate anche se fai clic altrove. Premi Shift+C per cancellare l'insieme di evidenziazioni corrente.
  • L'evidenziazione si ottiene attenuando tutti gli altri oggetti nell'area di progettazione; il livello di Dimmed Objects viene impostato nella sezione Impostazioni di mascheramento e attenuazione del pannello View Configuration.
  • Rendi attivo lo strato di piano.

Le net risalteranno e sarà più facile individuare eventuali divisioni o discontinuità nel percorso di ritorno, come linee di divisione o zone prive di rame create da pad a foro passante e via. 

  • Sia gli strati di piano sia gli strati di segnale ricoperti da poligoni possono essere utilizzati come piani delle linee di alimentazione.
  • Puoi assicurarti che i segnali non vengano instradati accidentalmente attraverso una divisione del piano posizionando un'area di keepout lungo la divisione, sullo strato di keepout.

Rilevamento delle interruzioni nel percorso di ritorno

Le interruzioni o le strozzature nel percorso di ritorno possono essere rilevate dalla regola di progettazione Return Path. La regola di progettazione Return Path verifica la presenza di un percorso di ritorno continuo per il segnale sugli strati di riferimento designati, sopra o sotto i segnali a cui si applica la regola. Il percorso di ritorno può essere creato mediante riempimenti, regioni e riempimenti poligonali posizionati sullo strato di segnale di riferimento, oppure può essere costituito da uno strato di piano.

Gli strati del percorso di ritorno sono gli strati di riferimento definiti nel Impedance Profile selezionato nella regola di progettazione Return Path. Questi strati vengono controllati per assicurare che il valore di Minimum Gap specificato (larghezza oltre il bordo del segnale) sia rispettato lungo il percorso del segnale. Aggiungi una nuova regola di progettazione Return Path nella categoria di regole High Speed.

 
 
 
 
 

Gli strati del percorso di ritorno sono definiti nel Impedance Profile selezionato; la larghezza del percorso (oltre il bordo del segnale) è definita da Minimum Gap.
Gli strati del percorso di ritorno sono definiti nel Impedance Profile selezionato; la larghezza del percorso (oltre il bordo del segnale) è definita da Minimum Gap.

L'immagine seguente mostra gli errori del percorso di ritorno rilevati per il segnale NetX, con un'impostazione di Minimum Gap pari a 0.1mm. Può essere più facile individuare gli errori Return Path configurando DRC Violation Display Style in modo da mostrare i dettagli delle violazioni ma non la sovrapposizione delle violazioni, nella finestra di dialogo Preferenze – mostra immagine. In questo modo vengono evidenziati i punti esatti in cui la regola non è rispettata, anziché tutti gli oggetti che presentano la violazione. 

Per evitare di rilevare piccoli errori, come la sezione evidenziata nel segmento di pista diagonale nell'immagine sopra, configura l'impostazione PCB.Rules.ReturnPathIgnoreArea nella finestra di dialogo Impostazioni avanzate. Per impostazione predefinita, vengono ignorate le aree < 10 sq mils.

Controllo dei via del percorso di ritorno

Questa funzionalità è disponibile quando l'opzione PCB.Rules.CheckReturnPathVia è abilitata nella finestra di dialogo Impostazioni avanzate.

 
 
 
 
 

Quando un segnale ad alta velocità passa da un piano di riferimento a un altro, devono essere presenti anche via di ritorno per consentire il passaggio dei segnali di ritorno tra i piani. Per verificare se un via di questo tipo è presente entro una distanza specifica da un via di segnale, definisci se deve essere presente un via del percorso di ritorno entro una determinata distanza da un via del segnale a cui si applica la regola, utilizzando l'opzione Max Stitch Via Distance nella regola di progettazione Return Path applicabile. Il via del percorso di ritorno deve fornire un collegamento al layer di riferimento definito in Layer Stack Manager per il profilo di impedenza corrispondente.

Con Max Stitch Via Distance definito nella regola, la presenza di un via del percorso di ritorno entro la distanza specificata viene verificata nell'ambito del DRC batch.

Un esempio di violazione del vincolo di distanza massima dei via di stitching. In questo caso, un via della net DQS4R_N non ha alcun via del percorso di ritorno entro la distanza specificata.
Un esempio di violazione del vincolo di distanza massima dei via di stitching. In questo caso, un via della net DQS4R_N non ha alcun via del percorso di ritorno entro la distanza specificata.

Configurazione e sbroglio delle coppie differenziali

Main pages: Sbroglio delle coppie differenziali, Sbroglio a impedenza controllata

Le coppie differenziali possono essere definite durante la creazione dello schema elettrico oppure dopo che il progetto è stato trasferito al layout della scheda. Un requisito fondamentale per definire una coppia nello schema elettrico è includere un _P o un _N alla fine del nome di ciascuna delle net interessate. Le coppie differenziali vengono identificate nello schema elettrico posizionando un Differential Pair directive su ciascuna net oppure posizionandone uno su un Blanket directive, dove la direttiva Blanket si sovrappone a un insieme di etichette di net in stile differenziale racchiuse al suo interno, come mostrato nell'immagine seguente.

Example of how a Blanket directive can be used with a Differential Pair directive to target multiple nets

È possibile utilizzare un Blanket per configurare più net come membri di coppie differenziali.

Lavorare con le coppie differenziali:

  • Nell'editor PCB, le coppie differenziali possono essere definite nella modalità Editor delle coppie differenziali del pannello PCB. Per semplificare la definizione delle regole di progettazione che si applicano alle coppie differenziali, queste possono essere assegnate a classi di net o a classi di coppie differenziali, entrambe definite in Esplora classi di oggetti.
  • Per sbrogliare una coppia differenziale a impedenza controllata, crea un profilo di impedenza in Layer Stack Manager. Scopri di più sullo sbroglio a impedenza controllata.
  • Le proprietà dello sbroglio delle coppie differenziali sono definite dalla regola di progettazione Sbroglio delle coppie differenziali.
  • Per sbrogliare una coppia differenziale, utilizza il comando di sbroglio Coppia differenziale interattiva. Fai clic sul pad _P o _N per iniziare lo sbroglio, quindi utilizza Spacebar per scorrere le forme disponibili per l'uscita delle piste. Il comportamento dello sbroglio è lo stesso di quello di una singola net; premi Shift+F1 per visualizzare un elenco delle scorciatoie per lo sbroglio interattivo. Quando ti avvicini ai pad di destinazione, premi Ctrl+Click per completare lo sbroglio fino ai pad.

Regole pratiche per le coppie differenziali:

  • L'equalizzazione delle lunghezze è fondamentale per l'efficacia delle coppie differenziali: mantieni le lunghezze uguali entro una tolleranza adeguata alla tecnologia di segnalazione. Ad esempio, per le coppie USB 3.x, mantieni la differenza di lunghezza entro 5–10 mil. Un'altra regola pratica consiste nel mantenere la differenza di lunghezza entro il 20% del tempo di salita del segnale. La segnalazione differenziale funziona perché l'energia di ritorno scorre attraverso l'altro membro della coppia: maggiore è la differenza tra le lunghezze, maggiore è la quantità di energia che ritorna invece attraverso il layer del piano più vicino.

  • Le discontinuità nell'accoppiamento, ad esempio quando i membri della coppia passano sui lati opposti di un ostacolo, aumentano l'impedenza. Può essere preferibile sbrogliare l'intera coppia con un accoppiamento meno stretto (ad esempio con una distanza pari a 2 volte la larghezza della pista del segnale) per ridurre le variazioni di impedenza dovute alle discontinuità di accoppiamento.

  • Mantieni lontane le piste interferenti, soprattutto sui layer superficiali; per le net potenzialmente interferenti, punta a una distanza pari a 3 volte la larghezza della pista del segnale.

  • Come regola generale, punta a una distanza tra la coppia e gli altri segnali pari a 2 volte la larghezza della pista del segnale.

  • Mantieni i poligoni di massa sullo stesso layer a una distanza di almeno 3 volte la larghezza della pista del segnale.

  • Le riflessioni introdotte dai via e dalle discontinuità di accoppiamento vengono gestite mediante l'instradamento a impedenza controllata, che richiede un piano di riferimento continuo al di sotto del percorso del segnale.

  • Ridurre la distanza tra lo strato di segnale e il piano per migliorare l'immunità alla diafonia.

Controllo e regolazione delle lunghezze dei percorsi

Main pages: Regolazione della lunghezza, Regola di progettazione Lunghezza, Regola di progettazione Corrispondenza delle lunghezze

Un requisito fondamentale per la gestione dei segnali ad alta velocità su una scheda è controllare e regolare le lunghezze dei loro percorsi.

  • Le lunghezze assolute possono essere monitorate tramite la regola di progettazione Lunghezza, mentre le lunghezze relative dei percorsi possono essere monitorate tramite la regola di progettazione Corrispondenza delle lunghezze.
  • Le lunghezze attuali di un insieme di net e la loro conformità alle regole di progettazione applicabili possono essere verificate nel pannello PCB in modalità Nets (come mostrato di seguito).
  • Se è definita una regola Lunghezza e/o Corrispondenza delle lunghezze, è possibile monitorare la lunghezza durante l'instradamento interattivo o la regolazione della lunghezza visualizzando l'indicatore di regolazione della lunghezza (Shift+G).
  • È supportato il ritardo causato dalla lunghezza del pin all'interno del package del dispositivo; per ulteriori informazioni, consultare Ritardo del pin nel package.
  • Le net che includono componenti in serie lungo il proprio percorso vengono gestite definendo xSignals.

Regole di progettazione

  • Managing the Overall Route Lengths - la lunghezza complessiva del percorso di una net o di un insieme di net può essere monitorata tramite una regola di progettazione Lunghezza. La regola di progettazione Lunghezza prevede una lunghezza minima e una massima consentite; se la lunghezza del segnale è inferiore al minimo consentito, viene evidenziata in giallo nel pannello PCB (in modalità Nets), mentre una lunghezza del segnale superiore al massimo consentito viene evidenziata in rosso.
  • Managing the Relative Route Lengths - le lunghezze relative dei percorsi di un insieme di net possono essere monitorate tramite una regola di progettazione Corrispondenza delle lunghezze. La regola di progettazione Corrispondenza delle lunghezze prevede una tolleranza e utilizza come lunghezza di riferimento il percorso più lungo dell'insieme di net interessate. L'evidenziazione in giallo della lunghezza del segnale nel pannello indica che la lunghezza di questo segnale è inferiore alla lunghezza del percorso più lungo meno la tolleranza. L'evidenziazione in rosso indica che la lunghezza di questo segnale è superiore alla lunghezza del percorso più lungo. 

Per comprendere come vengono determinate le impostazioni di queste due regole quando sono entrambe presenti in un progetto, consultare la pagina Regolazione della lunghezza.

Monitoraggio della lunghezza del percorso

Le lunghezze attuali dei percorsi vengono visualizzate nella modalità Net del pannello PCB e vengono aggiornate durante l'instradamento. Il valore della lunghezza Routed diventa giallo quando ci si avvicina alla lunghezza obiettivo e rosso se la si supera.

Se è definita una regola Lunghezza e/o Corrispondenza delle lunghezze, è possibile monitorare la lunghezza durante l'instradamento interattivo o la regolazione della lunghezza visualizzando l'indicatore di regolazione della lunghezza. Durante l'instradamento, utilizzare la scorciatoia Shift+G per mostrare o nascondere l'indicatore.

L'indicatore mostra la lunghezza attualmente instradata come valore numerico sopra il cursore, mentre il cursore mostra la lunghezza stimata. Durante la regolazione della lunghezza, Estimated Length = Current Routed Length; se si utilizza l'indicatore durante l'instradamento interattivo, Estimated Length = Routed Length + distance to target (length of connection line).

Le impostazioni dell'indicatore vengono calcolate in base ai vincoli definiti dalle regole applicabili.Le impostazioni dell'indicatore vengono calcolate in base ai vincoli definiti dalle regole applicabili.

  • Il minimo dell'indicatore (bordo sinistro) è 45 (il valore più basso di MinLimit)
  • Il massimo dell'indicatore (bordo destro) è 48 (il valore più alto di MaxLimit)
  • La barra gialla a sinistra (il valore più alto di MinLimit) è a 46.58
  • La barra gialla a destra (il valore più basso di MaxLimit) è a 47.58 (nascosta dalla barra verde nell'immagine sopra)
  • La barra verde (TargetLength) è a 47.58 (lunghezza del percorso della net più lunga dell'insieme, pari a MaxLimit)
  • Il cursore verde e il valore numerico sovrapposto (lunghezza attuale del percorso) indicano 47.197.

Regolazione delle lunghezze dei percorsi

Le lunghezze dei percorsi possono essere regolate dopo aver completato l'instradamento, utilizzando il comando Interactive Length Tuning o il comando Interactive Diff Pair Length Tuning (menu Route). Questi comandi aggiungono all'instradamento sezioni a fisarmonica, con tre forme tra cui scegliere.

Se sono applicabili sia una regola Lunghezza sia una regola Corrispondenza delle lunghezze, lo strumento di regolazione della lunghezza considera entrambe le regole e determina l'insieme di vincoli più restrittivo. Quindi, se la lunghezza massima specificata dalla regola Lunghezza è inferiore alla lunghezza più lunga prevista dalla regola Corrispondenza delle lunghezze, prevale la regola Lunghezza e il suo valore viene utilizzato durante la regolazione.

Per vedere quali regole vengono applicate o per modificare le proprietà della fisarmonica durante la regolazione della lunghezza, premere Tab per aprire la modalità Interactive Length Tuning del pannello Properties, come mostrato di seguito. Si noti il valore Target Length: si tratta del Max Limit delle impostazioni delle regole applicabili più restrittive.

Premere Tab durante la regolazione della lunghezza per aprire il pannello in modalità Interactive Length Tuning, dove è possibile selezionare la modalità della lunghezza obiettivo e regolare i parametri della fisarmonica.
Premere Tab durante la regolazione della lunghezza per aprire il pannello in modalità Interactive Length Tuning, dove è possibile selezionare la modalità della lunghezza obiettivo e regolare i parametri della fisarmonica.

Per regolare la lunghezza di una net, eseguire il comando e fare clic in un punto qualsiasi lungo la net. Spostare il cursore seguendo il tracciato del percorso: durante lo spostamento verranno aggiunte sezioni di regolazione a fisarmonica. Le sezioni di regolazione continueranno a essere aggiunte finché non saranno soddisfatti i requisiti di lunghezza definiti dalle regole di progettazione applicabili. Se il cursore esce dai limiti delle fisarmoniche di regolazione, le forme a fisarmonica scompaiono; quando il cursore viene riportato entro i limiti della forma a fisarmonica, ricompaiono.

Ulteriori informazioni sulla regolazione della lunghezza.

Le regole Lunghezza e Corrispondenza delle lunghezze possono essere applicate a net, coppie differenziali o xSignals. Gli xSignals sono ideali se le lunghezze da monitorare o uniformare includono componenti in serie o percorsi ramificati. La modalità xSignals del pannello PCB visualizza la lunghezza attualmente instradata di ciascun xSignal.

Ulteriori informazioni sugli xSignals.

Conclusioni

Sebbene non sia possibile ricavare un insieme universale di regole applicabili a ogni progetto ad alta velocità, è possibile seguire buone pratiche di progettazione che contribuiscono al successo del progetto. Diversi esperti del settore offrono corsi di formazione pratici e apprezzati sulla progettazione ad alta velocità. Utilizzare i collegamenti riportati di seguito per approfondire l'argomento e valutare le opzioni di formazione specialistica.

Riferimenti

L'autore ringrazia gli esperti del settore elencati di seguito per il loro lavoro; questa pagina è un tentativo di riassumere le loro conoscenze collettive.

Articoli di Douglas Brooks

  • Tempi di propagazione nelle microstrip
  • Divisione dei piani per velocità e alimentazione
  • Effetto pelle
  • Regole di progettazione delle piste differenziali: verità e falsi miti

Articoli del Dr. Howard Johnson

  • Induttanza dei via
  • Stackup a 10 strati

Libri e articoli di Lee W. Ritchey

Articoli di In-Circuit Design - Barry Olney

  • Instradamento delle coppie differenziali
  • La pura verità sui ponticelli tra piani
  • Posizionamento critico
  • Pianificazione dello stackup (Parti 1, 2 e 3)
  • Lo stackup perfetto

Buone pratiche nella progettazione di circuiti stampati - Tim Jarvis RadioCAD Limited

Layout PCB - Sito web Learn EMC

Articoli di Keith Armstrong, EMC Information Centre (è richiesta la registrazione gratuita)

Manuale del packaging elettronico - Glenn R. Blackwell

Manuale dei circuiti stampati - Clyde Coombs e Happy Holden

Manuale HDI - Happy Holden e altri

Tecniche di ottimizzazione dei via per la progettazione di canali ad alta velocità - Nota applicativa Altera AN529

Considerazioni sulla progettazione di PCB ad alta velocità - Nota applicativa Lattice Semiconductor TN 1033 

Misurare il tempo di propagazione di un segnale - Chris Grachanen, EDN

Il futuro delle strutture dei via HDI, della distribuzione dell'alimentazione e della gestione termica nei circuiti stampati di prossima generazione - Tom Buck TTM Technologies

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents