Posizionamento dei componenti
Altium Essentials: PCB Component Placement
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
A colpo d'occhio
- Capirai quali elementi comprende il footprint di un componente PCB, dalle piazzole agli elementi serigrafici, fino ai corpi 3D opzionali.
- Scoprirai quali proprietà dei componenti in Altium Designer influiscono su posizionamento, orientamento, assegnazione del layer e identificazione.
- Vedrai come vengono gestiti i diversi tipi di componenti e le definizioni delle aree nell’editor PCB.
Si dice che la progettazione PCB sia per il 90% posizionamento e per il 10% sbroglio. Sebbene si possa discutere sulla percentuale di ciascuna attività, è generalmente riconosciuto che un buon posizionamento dei componenti sia fondamentale per progettare una buona scheda. Ricorda che potrebbe essere necessario ottimizzare il posizionamento anche durante lo sbroglio.
Il footprint del componente definisce lo spazio e i punti di connessione necessari per montare il componente fisico sul circuito stampato. È un oggetto di gruppo costituito da un insieme di semplici oggetti primitivi, tra cui piazzole, linee e archi, oltre ad altri oggetti di progettazione.

Il footprint del componente definisce il montaggio e le connessioni del componente sul PCB e può anche includere oggetti corpo 3D per definire il componente reale.
Le piazzole forniscono i punti di montaggio e di connessione per i pin del componente. Spesso vengono incluse altre primitive di progettazione, come linee e archi, per definire il contorno della forma del componente sul layer serigrafico (overlay).
Il footprint del componente può anche includere oggetti corpo 3D opzionali, che definiscono lo spazio fisico o l'ingombro del componente reale montato sulla scheda. Se il componente fisico è stato definito utilizzando oggetti corpo 3D o modelli STEP importati, è possibile eseguire una verifica tridimensionale delle distanze tra i componenti.
I footprint dei componenti vengono creati nell'editor dei footprint PCB posizionando gli oggetti di progettazione appropriati per creare la forma necessaria al montaggio e al collegamento del componente. Il punto di riferimento del componente è l'origine dello spazio di progettazione dell'editor dei footprint PCB, che può essere impostata nell'editor sul pin 1, sul centro geometrico o su una posizione del componente definita dall'utente. Per ulteriori informazioni sulla creazione dei footprint, consulta la pagina Creazione di un footprint PCB.
Proprietà del componente

La modalità Component del pannello Properties.
Scheda Generale
Posizione
-
(X/Y)
-
X (primo campo) – la coordinata X (orizzontale) corrente del punto di riferimento del componente rispetto all'origine corrente dello spazio di progettazione. Modifica questo valore per cambiare la posizione X del componente. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore le cui unità non corrispondono a quelle predefinite correnti. Il punto di riferimento del footprint di un componente viene impostato nell'editor delle librerie.
-
Y (secondo campo) – la coordinata Y (verticale) corrente del punto di riferimento del componente rispetto all'origine corrente. Modifica questo valore per cambiare la posizione Y del componente. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore le cui unità non corrispondono a quelle predefinite correnti. Il punto di riferimento del footprint di un componente viene impostato nell'editor delle librerie.
-
-
Rotation – l'angolo di rotazione del componente (in gradi), misurato in senso antiorario a partire da zero (l'orizzontale 3 o'clock). Modifica questo valore per cambiare la rotazione del componente. La risoluzione angolare minima è di 0,001°.
Proprietà
-
Layer – imposta il layer su cui è posizionato il componente. I componenti possono essere assegnati al layer superiore o inferiore. Usa il menu a discesa per selezionare un layer diverso. La modifica del layer trasferisce tutte le primitive del componente sul rispettivo layer opposto. Ad esempio, spostando un componente dal layer superiore a quello inferiore, le piazzole a singolo layer vengono trasferite dal layer superiore a quello inferiore, le primitive sul Top Overlay vengono riassegnate al Bottom Overlay e le primitive su un layer meccanico accoppiato vengono trasferite all'altro layer meccanico della coppia. L'orientamento del componente viene ribaltato lungo l'asse X e il testo della serigrafia del componente sarà leggibile dal lato inferiore.
-
Reuse Block – quando il componente fa parte di un blocco di riutilizzo, questo campo mostra il nome del blocco di riutilizzo a cui appartiene. Fai clic sul collegamento ipertestuale Reuse Block per visualizzare le proprietà di questo blocco di riutilizzo.
-
Designator – il designatore del componente è una stringa alfanumerica di massimo 255 caratteri. Ogni componente deve avere una stringa di designatore univoca. Usa
o
per mostrare/nascondere il designatore. Fai clic sul collegamento ipertestuale Designator per aprire le proprietà del designatore del componente.
-
Comment – il commento del componente è una stringa alfanumerica di massimo 255 caratteri. Usa
o
per mostrare/nascondere il commento. Fai clic sul collegamento ipertestuale Comment per aprire le proprietà del commento del componente.
-
Area – l'area del componente posizionato, visualizzata nelle unità correnti della scheda. L'area può essere definita dall'utente; in caso contrario, viene calcolata automaticamente a partire dall'area di selezione del componente:
-
Per definire l'area del componente, modifica Area nel pannello Properties del footprint nell'editor PCB Footprint. Per trasferire un footprint aggiornato a un PCB aperto, fai clic con il pulsante destro del mouse sul nome del footprint nel pannello PCB Library, quindi seleziona Update PCB With <ComponentName> dal menu contestuale.
-
Puoi anche definire manualmente l'area di un componente già posizionato su un PCB selezionando il componente e inserendo il valore in questo campo.
-
Per passare da un'area definita dall'utente a un'area calcolata per un componente posizionato su un PCB, elimina il valore in questo campo; il campo verrà automaticamente compilato con il valore calcolato automaticamente.
-
L'area calcolata automaticamente è quella che viene evidenziata quando fai clic per selezionare il componente. L'area di selezione viene determinata dalle geometrie sul layer Courtyard oppure, quando tale layer non è presente, dalla combinazione delle geometrie sul layer serigrafico, degli oggetti 3D Body e dei layer in rame (le stringhe sono escluse). Le immagini superiori mostrate di seguito illustrano l'area del componente quando è presente un contorno definito sul layer Courtyard; l'immagine inferiore mostra l'area calcolata a partire dalle geometrie sul layer serigrafico, dagli oggetti 3D Body e dai layer in rame.
► Scopri di più su come viene calcolata l'area di selezione e sulle altre modalità disponibili per determinarla.
► Scopri di più su Utilizzo dei layer meccanici.
-
-
Description – descrizione di questo componente a livello di componente. In genere, la descrizione viene definita durante la creazione del componente, ma può anche essere modificata o aggiunta al componente nello schema elettrico. Questa è la descrizione mostrata nel pannello Components.
-
Type – seleziona qui uno dei seguenti tipi di componente per il footprint. I tipi disponibili sono:
-
Standard– questi componenti possiedono proprietà elettriche standard, sono sempre sincronizzati tra lo schema elettrico e il PCB (il footprint, i pin/pad e le assegnazioni delle net devono tutti corrispondere) e sono inclusi nella distinta base. Un esempio è un componente elettrico standard, come un resistore. -
Mechanical– questi componenti non hanno proprietà elettriche, non sono sincronizzati (devi posizionarli manualmente in entrambi gli editor) e sono inclusi nella distinta base. Un esempio è un dissipatore di calore. -
Graphical– questi componenti non hanno proprietà elettriche, non sono sincronizzati (devi posizionarli manualmente in entrambi gli editor) e sono not inclusi nella distinta base. Un esempio è un logo aziendale. -
Net Tie (in BOM)– questi componenti vengono utilizzati per cortocircuitare tra loro due o più net diverse. Sono sempre sincronizzati tra lo schema elettrico e il PCB (il footprint, i pin/pad e le assegnazioni delle net devono tutti corrispondere) e sono inclusi nella distinta base. Differiscono da un componente Standard in quanto la connettività creata dal rame all'interno del footprint non viene verificata: è proprio questo rame che consente di cortocircuitare le net. Nota: abilita l'opzione Verify Shorting Copper nella finestra di dialogo Design Rule Checker per verificare che non vi sia rame non connesso all'interno del componente. -
Net Tie– questi componenti vengono utilizzati per cortocircuitare tra loro due o più net diverse. Sono sempre sincronizzati tra lo schema elettrico e il PCB (il footprint, i pin/pad e le assegnazioni delle net devono tutti corrispondere) e sono not inclusi nella distinta base. Differiscono da un componente Standard in quanto la connettività creata dal rame all'interno del footprint non viene verificata: è proprio questo rame che consente di cortocircuitare le net. Nota: abilita l'opzione Verify Shorting Copper nella finestra di dialogo Design Rule Checker per verificare che non vi sia rame non connesso nel componente. -
Standard (No BOM)– questi componenti possiedono proprietà elettriche standard, sono sempre sincronizzati tra lo schema elettrico e il PCB (il footprint, i pin/pad e le assegnazioni delle net devono tutti corrispondere) e sono not inclusi nella distinta base. Un esempio è un componente punto di test che desideri escludere dalla distinta base. -
Jumper– questi componenti vengono utilizzati per includere ponticelli a filo in un progetto PCB, ad esempio su un PCB a singola faccia che non può essere sbrogliato interamente su un solo layer. Per questo tipo di componente, il footprint e i pin vengono sincronizzati tra lo schema elettrico e il PCB, ma le assegnazioni delle net no, e il componente viene incluso nella distinta base. Oltre a selezionare questa opzione a livello di componente, entrambi i pad del componente devono avere il parametro JumperID impostato sullo stesso valore diverso da zero. I componenti di tipo Jumper non devono necessariamente essere collegati nello schema elettrico; devono essere inclusi nello schema elettrico solo se sono richiesti nella distinta base. Se non sono richiesti nella distinta base, possono essere posizionati direttamente nel PCB, dove si imposta Component Type, si impostano JumperIDs e si assegna manualmente Nets ai pad.
-
-
Design Item ID – mostra il Design Item ID del componente selezionato. Questo campo non è modificabile.
-
Source – mostra il documento di origine del componente. Fai clic su
per aprire una finestra di dialogo in cui cercare e selezionare un documento di origine diverso.
-
Revision State – mostra lo stato della revisione del componente della libreria del Workspace in termini di stato del ciclo di vita e di stato della revisione, ovvero se si tratta dell'ultima revisione rilasciata di quel componente (
Up to date) o di una revisione precedente (Out of date). -
Height – un campo per l'altezza del componente. Questo campo definiva l'altezza del componente PCB prima dell'introduzione dell'oggetto 3D Body; tuttavia, il modello 3D offre un metodo migliore per definire l'altezza del componente per attività come il rilevamento delle collisioni 3D. Nota che Altium MCAD CoDesigner utilizza il valore definito in questo campo Height, non l'altezza del modello 3D (scopri di più).
-
3D Body Opacity – inserisci la percentuale di opacità desiderata oppure utilizza il cursore.
-
Primitives – fai clic sull'icona del lucchetto associata per bloccare/sbloccare.
– blocca tutte le primitive del componente in modo che possa essere trattato come un unico oggetto.
– sblocca per modificare le singole primitive che compongono il componente. Dopo la modifica, le primitive del componente devono essere nuovamente bloccate.
-
Strings – fai clic sull'icona del lucchetto associata per bloccare/sbloccare.
– blocca tutte le stringhe del componente.
– sblocca per modificare le stringhe del componente.
Footprint
- Footprint Name – mostra il nome del footprint corrispondente al componente scelto.
- Design Item ID – l'identificativo del componente scelto.
- Source – il nome del Workspace in cui è stato inserito il componente scelto.
- Description – la descrizione del footprint del componente, definita nell'editor dei footprint PCB.
Opzioni di scambio
- Enable Pin Swapping – seleziona per consentire la funzione di scambio dei pin.
- Enable Part Swapping – seleziona per consentire la funzione di scambio delle parti (ad esempio, quattro parti di un circuito integrato della serie 74).
Informazioni di riferimento dello schema
- Designator – il designatore del componente dello schema a cui è stato associato questo componente PCB.
- Hierarchical Path – mostra dove si trova questo componente nella struttura gerarchica dello schema.
- Channel Offset – quando un progetto viene trasferito per la prima volta dallo schema al PCB, a ciascun componente di ogni foglio dello schema viene assegnato un offset di canale univoco.
Scheda Parametri
- Table – mostra Name, Value e Source di ciascun parametro elencato.
Designatori e commenti dei componenti
I campi designatore e commento sono oggetti parametro figli di un componente PCB (parte). Il designatore viene utilizzato per identificare univocamente ogni parte posizionata e distinguerla da tutte le altre parti posizionate in tutti i documenti PCB del progetto. Il commento viene utilizzato per aggiungere ulteriori informazioni a un oggetto posizionato. Sia il commento sia il designatore vengono configurati dopo il posizionamento dell'oggetto componente padre. Non si tratta di oggetti di progettazione posizionabili direttamente.

Un oggetto Designatore posizionato

Un oggetto Commento posizionato
I designatori dei componenti PCB 2D/3D vengono incrementati automaticamente di un'unità durante il posizionamento se il componente iniziale ha un designatore che termina con un carattere numerico. Modifica il designatore del primo componente prima del posizionamento dal pannello Proprietà.
Per ottenere incrementi alfabetici o numerici del designatore diversi da 1, utilizza la funzione Paste Array. I controlli per questa funzione sono disponibili nella finestra di dialogo Configura incolla matrice, accessibile premendo il pulsante Paste Array nella finestra di dialogo Paste Special (Edit » Paste Special).
Il metodo di modifica grafico consente di selezionare un oggetto designatore o commento posizionato direttamente nell'area di progettazione e di modificarne posizione, rotazione, orientamento e dimensioni.
Quando viene selezionato un oggetto designatore o commento, sono disponibili le seguenti maniglie di modifica:

Un designatore selezionato
- Fai clic e trascina B per ruotare il designatore/commento attorno al suo punto di riferimento A (indicato dalla piccola x).
- Fai clic e trascina C per ridimensionare il riquadro di delimitazione del designatore/commento contemporaneamente in direzione verticale e orizzontale.
- Fai clic e trascina D per ridimensionare il riquadro di delimitazione del designatore/commento separatamente in direzione verticale e orizzontale.
-
Fai clic in un punto qualsiasi del designatore/commento lontano dalle maniglie di modifica e trascina per riposizionarlo. Durante il trascinamento, il commento può essere ruotato o specchiato:
- Premi Spacebar per ruotare il designatore/commento in senso antiorario oppure Shift+Spacebar per ruotarlo in senso orario. La rotazione avviene in base al valore di Rotation Step definito nella pagina Editor PCB – Generale della finestra di dialogo Preferences.
- Premi i tasti X o Y per specchiare il designatore/commento lungo l'asse X o Y.
Le proprietà di un oggetto Designatore o Commento possono essere modificate nella modalità Parameter del pannello Properties.
Proprietà dei parametri

La modalità Parameter del pannello Properties.
Posizione
-
(X/Y)
-
X (primo campo) - la coordinata X (orizzontale) corrente del punto di riferimento del designatore rispetto all'origine corrente dell'area di lavoro. Modifica questo valore per cambiare la posizione X del designatore. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore con unità diverse da quelle predefinite correnti.
-
Y (secondo campo) - la coordinata Y (verticale) corrente del punto di riferimento del designatore rispetto all'origine corrente. Modifica questo valore per cambiare la posizione Y del designatore. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore con unità diverse da quelle predefinite correnti.
-
- Rotation - l'angolo di rotazione del designatore (in gradi) misurato in senso antiorario a partire da zero (l'orizzontale 3 o'clock). Modifica questo valore per cambiare la rotazione del designatore. La risoluzione angolare minima è di 0,001°.
Proprietà
-
Parameter type - mostra il tipo di parametro (Componente, Simbolo di foglio, ecc.) e il nome del parametro.
-
Name - il nome del designatore.
-
Value - utilizza questo campo per inserire il valore desiderato del designatore. Fai clic sull'icona dell'occhio per attivare o disattivare la visibilità del valore nell'area di progettazione.
-
Layer - utilizzare il menu a discesa per selezionare il layer desiderato. Abilitare Mirror se necessario.
-
Autoposition - utilizzare il menu a discesa per selezionare la posizione automatica desiderata rispetto all'oggetto associato.
-
Text Height - utilizzare questo campo per inserire l'altezza desiderata del testo.
-
Font Type
-
TrueType - selezionare per utilizzare i caratteri disponibili sul PC (nella cartella \Windows\Fonts ). I caratteri TrueType offrono il supporto completo per Unicode. Per impostazione predefinita, il software crea un collegamento al carattere TrueType utilizzato (i caratteri non vengono memorizzati nel file PCB); pertanto, lo stesso carattere deve essere presente su ogni PC su cui viene trasferito il progetto. In alternativa, incorporare i caratteri TrueType utilizzati nel file PCB tramite le opzioni nella pagina Editor PCB - Caratteri TrueType della finestra di dialogo Preferences, dove è anche possibile selezionare un Substitution Font da utilizzare se un carattere non incorporato non è disponibile.
-
Justification - utilizzare per impostare la posizione del designatore all'interno del rettangolo di contorno.
- Left - fare clic sul pulsante a sinistra per allineare il testo orizzontale a sinistra.
- Center - fare clic sul pulsante centrale per allineare il testo orizzontale al centro.
- Right - fare clic sul pulsante a sinistra per allineare il testo orizzontale a destra.
- Above - fare clic sul pulsante in alto per allineare il testo verticale in alto.
- Middle - fare clic sul pulsante centrale per allineare il testo verticale al centro.
- Below - fare clic sul pulsante in basso per allineare il testo verticale in basso.
-
Font - utilizzare il menu a discesa per selezionare il carattere TrueType desiderato. Utilizzare le opzioni B (bold) e/o I (italic) per mettere in risalto il testo secondo necessità.
-
Inverted - utilizzare per visualizzare il testo in negativo controllando le dimensioni del bordo attorno al testo. È possibile utilizzare le seguenti opzioni per configurare ulteriormente il testo:
-
Size (Width/Height) -
- Width - la larghezza del rettangolo di contorno.
- Height - l'altezza del rettangolo di contorno.
-
Size (Width/Height) -
-
Inverted - utilizzare per visualizzare il testo in negativo controllando le dimensioni del bordo attorno al testo. È possibile utilizzare le seguenti opzioni per configurare ulteriormente il testo:
-
-
Stroke
-
Justification - utilizzare per impostare la posizione del designatore all'interno del rettangolo di contorno.
- Left - fare clic sul pulsante a sinistra per allineare il testo orizzontale a sinistra.
- Center - fare clic sul pulsante centrale per allineare il testo orizzontale al centro.
- Right - fare clic sul pulsante a sinistra per allineare il testo orizzontale a destra.
- Above - fare clic sul pulsante in alto per allineare il testo verticale in alto.
- Middle - fare clic sul pulsante centrale per allineare il testo verticale al centro.
- Below - fare clic sul pulsante in basso per allineare il testo verticale in basso.
-
Font - utilizzare il menu a discesa per selezionare il carattere a tratto desiderato. Le opzioni disponibili sono:
-
Default- un carattere vettoriale semplice progettato per il tracciamento a penna e il fototracciamento vettoriale. -
Sans Serif- un carattere complesso che rallenta la generazione di output vettoriali, come Gerber. -
Serif- un carattere complesso che rallenta la generazione di output vettoriali, come Gerber.
-
- Stroke Width - visualizza la larghezza del tratto.
-
Justification - utilizzare per impostare la posizione del designatore all'interno del rettangolo di contorno.
-
TrueType - selezionare per utilizzare i caratteri disponibili sul PC (nella cartella \Windows\Fonts ). I caratteri TrueType offrono il supporto completo per Unicode. Per impostazione predefinita, il software crea un collegamento al carattere TrueType utilizzato (i caratteri non vengono memorizzati nel file PCB); pertanto, lo stesso carattere deve essere presente su ogni PC su cui viene trasferito il progetto. In alternativa, incorporare i caratteri TrueType utilizzati nel file PCB tramite le opzioni nella pagina Editor PCB - Caratteri TrueType della finestra di dialogo Preferences, dove è anche possibile selezionare un Substitution Font da utilizzare se un carattere non incorporato non è disponibile.
-
Border Mode
-
Margin - fare clic su questo pulsante per abilitare la modifica dell'opzione Bordo del margine.
- Text Offset - la distanza di arretramento del designatore rispetto al bordo/angolo a cui è allineato. Questa opzione non ha effetto quando è selezionata la modalità di allineamento Center . Questa opzione non è disponibile per Margin.
-
Offset - fare clic su questo pulsante per abilitare la modifica dell'opzione Offset del testo.
- Margin Border - utilizzare per specificare le dimensioni del bordo del margine attorno al designatore. Questa opzione non è disponibile per Offset.
-
Margin - fare clic su questo pulsante per abilitare la modifica dell'opzione Bordo del margine.
Disponibilità dei componenti sul PCB
Quando il progetto viene trasferito dall'editor degli schemi all'editor PCB, i footprint dei componenti PCB vengono posizionati automaticamente dalle librerie disponibili. Questa operazione è chiamata Sincronizzazione del progetto ed è un processo che rileva e risolve le differenze tra lo schema e il PCB.
Altium Designer supporta un insieme di strumenti che facilitano il posizionamento del footprint del componente richiesto nell'area di progettazione PCB. Consultare le pagine seguenti per saperne di più su questi strumenti:
Esplorazione dei componenti posizionati
Nella modalità del pannello PCB Components, le tre aree principali cambiano per riflettere la gerarchia dei componenti del progetto PCB corrente (dall'alto verso il basso):
- Component Classes
- Components all'interno di una classe
- Component Primitives

Le aree del pannello PCB consentono una selezione cumulativa dei filtri, dalle classi di componenti ai singoli componenti fino alle primitive dei componenti.
Fare clic con il pulsante destro del mouse sulla voce di un componente o di una primitiva di componente, quindi scegliere il comando Properties (oppure fare doppio clic direttamente sulla voce) per accedere al pannello Properties, in cui è possibile visualizzare/modificare le proprietà del componente o della primitiva secondo necessità.
Fare clic con il pulsante destro del mouse sulla voce di una classe di componenti, quindi scegliere Properties (oppure fare doppio clic direttamente sulla voce) per aprire la finestra di dialogo Modifica classe di componenti relativa a tale classe. Nella finestra di dialogo è possibile visualizzare/modificare i componenti appartenenti alla classe, rinominarla o aggiungere altre classi.

Modifica di una classe di componenti selezionata.
La visualizzazione/inclusione di ciascun tipo di primitiva di componente nell'area Component Primitives del pannello dipende dall'abilitazione della rispettiva opzione nel menu contestuale accessibile dalle aree Components o Component Primitives.

Fare clic con il pulsante destro del mouse sulla voce di un componente o di una primitiva di componente per selezionare gli elementi da includere.
Durante l'esplorazione, è possibile bloccare o sbloccare facilmente i componenti facendo doppio clic nella casella a destra della colonna Footprint nell'area Components.

Il blocco/sblocco dal pannello PCB evita di dover accedere al pannello Properties.
Riquadro di delimitazione della selezione del componente
Quando fai clic su un componente e lo selezioni, viene visualizzato il riquadro di delimitazione della selezione. Per controllare quali layer vengono utilizzati per definire il riquadro di delimitazione, puoi utilizzare l'opzione PCB.ComponentSelection nella finestra di dialogo Impostazioni avanzate. L'opzione supporta tre modalità (inserisci il valore 0, 1 o 2; la modalità predefinita è 2):
-
0 - legacy mode- questa modalità combina le geometrie di tutti i layer, tranne le stringhe del designatore e del commento sulla serigrafia. -
1 - by layer mode- utilizza le geometrie del primo dei layer elencati di seguito che contiene oggetti, con la seguente priorità:-
Tipo di layer Courtyard
-
Layer del corpo 3D (i modelli STEP sono memorizzati in un oggetto corpo 3D delle dimensioni del più piccolo prisma rettangolare che contiene il modello. Per la selezione del componente, viene utilizzato questo corpo 3D, non la forma del modello STEP)
-
Layer serigrafico più layer di rame
-
Layer di rame
-
-
2 - by graphic mode- questa modalità combina le geometrie rilevate sul tipo di layer Courtyard, sulla serigrafia, negli oggetti corpo 3D e sui layer di rame. Le stringhe sono escluse.
Aggiunta di primitive a un componente
Le primitive selezionate possono essere aggiunte a un componente scegliendo il comando Tools » Convert » Add Selected Primitives to Component dai menu principali. Dopo aver selezionato il comando, scegli il componente a cui desideri aggiungere le primitive selezionate. Una volta confermata l'operazione, le nuove primitive verranno riconosciute come parte del singolo oggetto componente e potranno essere utilizzate insieme alle primitive originali del componente.
Per eseguire questa operazione, le primitive del componente di destinazione devono essere sbloccate. Utilizza l'icona del lucchetto Primitives nelle proprietà del componente per sbloccare le primitive.
Esplosione di un componente in primitive
Un componente può essere convertito negli oggetti primitivi che lo costituiscono utilizzando il comando Tools » Convert » Explode Component to Free Primitives dai menu principali oppure facendo clic con il pulsante destro del mouse su un componente posizionato (selezionato o meno) e scegliendo quindi il comando Component Actions » Explode Component To Free Primitives (o Explode Selected Components To Free Primitives) dal menu contestuale. Un componente esploso non è più un componente, quindi il designatore e il commento verranno rimossi e il componente tornerà a essere costituito dalle varie primitive da cui era composto.
L'esplosione non ha alcun effetto sul modello di footprint memorizzato nella libreria sorgente pertinente, ma solo sulle istanze convertite dei componenti posizionati nel documento PCB.
Accesso ai collegamenti cliccabili alle informazioni di riferimento
Quando a un componente sono stati aggiunti collegamenti a documenti con nome, è possibile aprire l'URL del documento o della pagina indicati, specificato tramite un apposito parametro di collegamento URL sottostante, per il componente selezionato o per quello sotto il cursore. Questa funzionalità consente di presentare i collegamenti a documenti con nome trasferiti dai componenti dello schema come collegamenti con nome dei componenti PCB a PDF, file di testo o pagine HTML. Ciò avviene quando i collegamenti a documenti con nome del componente vengono aggiornati dallo schema al PCB (Design » Update PCB Document). Durante questo processo di aggiornamento (tramite un ECO), i collegamenti a documenti con nome dello schema vengono convertiti in coppie di parametri ComponentLink (ComponentLinknDescription/ComponentLinknURL) per il componente PCB corrispondente. Ad esempio:
| Parametro del componente dello schema | Parametri del componente PCB | |||
|---|---|---|---|---|
| Name | Url |
⇒ |
Name | Value |
STM32 Family Web Page |
http://www.st.com/stm32 |
ComponentLink1Description |
STM32 Family Web Page |
|
ComponentLink1URL |
http://www.st.com/stm32 |
|||
Il numero di indice del collegamento (n) utilizzato nei parametri del componente definisce la posizione del collegamento del componente PCB corrispondente nel sottomenu References. Quando un componente sul PCB è selezionato, le coppie di parametri ComponentLink definite vengono visualizzate nella sezione Parameters del pannello Proprietà.
Dopo l'avvio del comando, la pagina di destinazione dell'URL web o il documento indicato verranno aperti direttamente (se disponibili).

).