Tecniche di posizionamento e modifica dei PCB
A colpo d'occhio
- Comprendi la differenza tra oggetti primitivi e oggetti di gruppo e come influisce sul posizionamento e sulla manipolazione nell'editor PCB.
- Scopri il flusso di lavoro comune per la modifica prima, durante e dopo il posizionamento, incluse le impostazioni predefinite, l'accesso a Properties e il cambio delle unità di misura visualizzate.
- Scopri quali comandi di selezione PCB sono disponibili per lavorare con oggetti sovrapposti, gerarchie logiche delle net, rame connesso e selezioni delle piste basate sui componenti.
Per la progettazione di un PCB sono disponibili diversi oggetti. La maggior parte degli oggetti inseriti in un documento PCB definisce aree di rame o zone prive di rame. Questo vale sia per gli oggetti elettrici, come piste e pad, sia per quelli non elettrici, come testi e quote. È quindi importante tenere presente la larghezza delle linee utilizzate per definire ciascun oggetto e il layer su cui viene posizionato.
Nell'editor PCB esistono due tipi di oggetti: oggetti primitivi e oggetti di gruppo:
-
Gli oggetti primitivi sono gli elementi fondamentali del progetto e comprendono piste, pad, via, riempimenti, archi e oggetti di testo. Sono chiamati «primitivi» per la loro natura elementare o di base.
-
Qualsiasi elemento composto da primitive e identificato come oggetto di progettazione è un oggetto di gruppo. Esempi di oggetti di gruppo sono componenti, quote e riempimenti poligonali. Un oggetto di gruppo può essere manipolato come un unico oggetto all'interno dell'area di progettazione. Ad esempio, può essere posizionato, selezionato, copiato, modificato, spostato ed eliminato.
Aspetti comuni del posizionamento e della modifica degli oggetti
In Altium Designer, il processo di posizionamento di un oggetto è sostanzialmente lo stesso, indipendentemente dall'oggetto da posizionare. Nella sua forma più semplice, il processo è il seguente:
-
Selezionare l'oggetto da posizionare da una delle barre degli strumenti o dal menu Place .
-
Utilizzare il mouse per definire la posizione dell'oggetto nell'area di progettazione dell'editor PCB e le sue dimensioni (ove applicabile).
-
Fare clic con il pulsante destro del mouse (o premere Esc) per terminare il comando e uscire dalla modalità di posizionamento.
Modifica prima del posizionamento
Le proprietà predefinite di un oggetto possono essere modificate in qualsiasi momento nella pagina Editor PCB – Impostazioni predefinite della finestra di dialogo Preferences . Queste proprietà verranno applicate al posizionamento degli oggetti successivi.

Utilizzare la colonna Primitives per accedere alle proprietà degli oggetti e modificare i valori predefiniti secondo necessità.
Modifica durante il posizionamento
Quando si posiziona un oggetto per la prima volta, è possibile modificarne diversi attributi. Per accedere a questi attributi, premere il tasto Tab durante la modalità di posizionamento per aprire il pannello Properties associato. Premendo il tasto Tab si mette in pausa il posizionamento per apportare le modifiche necessarie all'oggetto.
Esempio di finestra di dialogo delle proprietà di un oggetto Pad .
Dopo aver apportato le modifiche, fare clic sul pulsante di pausa sovrapposto all'area di progettazione (
) per riprendere il posizionamento.
Modifica dopo il posizionamento
Una volta posizionato un oggetto, è possibile modificarlo in diversi modi, descritti di seguito.
Il pannello o la finestra di dialogo delle proprietà associati
Questo metodo di modifica utilizza la modalità del pannello Properties e la finestra di dialogo associati per modificare le proprietà di un oggetto posizionato.
Dopo il posizionamento, è possibile accedere alla finestra di dialogo associata:
-
Facendo doppio clic sull'oggetto posizionato.
-
Posizionando il cursore sull'oggetto, facendo clic con il pulsante destro del mouse e scegliendo Properties dal menu contestuale.
Dopo il posizionamento, è possibile accedere alla modalità associata del pannello Properties in uno dei seguenti modi:
- Se il pannello Properties è già attivo, selezionare l'oggetto.
- Dopo aver selezionato l'oggetto, selezionare il pannello Properties dal pulsante Panels in basso a destra nell'area di progettazione oppure selezionare View » Panels » Properties dai menu principali.
Comandi di selezione degli oggetti PCB
Oltre ai comandi standard di selezione e deselezione degli oggetti, l'editor PCB include diversi comandi speciali che facilitano le operazioni di selezione e deselezione degli oggetti. Questi comandi sono accessibili dai sottomenu Edit » Select e Edit » DeSelect dei menu principali. È inoltre possibile accedere ai comandi di selezione dal menu del pulsante
nella Active Bar.
-
Select overlapped - utilizzare questo comando per selezionare singolarmente l'oggetto di progettazione successivo in un insieme di oggetti nella stessa posizione (sovrapposti) senza utilizzare una finestra popup di selezione. La selezione segue il seguente ordine di priorità fisso, che viene ripetuto ciclicamente a ogni utilizzo successivo del comando:
- Pad
- Via
- Pista/Arco
- Componente
- Poligono
- Regione/Riempimento
- Testo
Inoltre, mentre si utilizza il tasto Shift per aggiungere altri oggetti alla selezione corrente, è possibile utilizzare Shift+Tab per scorrere ciclicamente la selezione degli oggetti sovrapposti senza perdere la selezione originale.
-
Select next (scorciatoia: Tab) - con un oggetto iniziale selezionato nel progetto, questo comando estende la selezione includendo l'oggetto (o gli oggetti) del livello immediatamente superiore in base alla gerarchia logica. Sono supportate le seguenti sequenze cicliche di selezione logica:
- Segmento di pista ---> Tutte le piste connesse (contigue) sullo stesso layer ---> Tutto il rame connesso ---> Tutti gli oggetti elettrici della net associata
- Pad connesso ---> Tutte le piste connesse (contigue) sullo stesso layer ---> Tutto il rame connesso ---> Tutti gli oggetti elettrici della net associata
- Pad non connesso ---> Tutti gli oggetti elettrici della net associata
- Via ---> Tutte le piste connesse (contigue) sui layer associati al via ---> Tutto il rame connesso ---> Tutti gli oggetti elettrici della net associata
- Rame (regione/poligono di rame/riempimento) ---> Tutto il rame connesso ---> Tutti gli oggetti elettrici della net associata
- Pad/via libero ---> Tutte le piste connesse (contigue) sullo stesso layer del pad o sui layer associati al via ---> Tutto il rame connesso ---> Tutti gli oggetti elettrici della net associata.
- Componente ---> Fanout con via, piste di escape, interconnessioni
Inoltre, la funzionalità consente di estendere la selezione a più oggetti, selezionati su net diverse del progetto.

Esempio di selezione su più net, che si estende dai segmenti di pista inizialmente selezionati ai livelli superiori della gerarchia logica.Questo comando è particolarmente utile per selezionare le net sbrogliate. Per saperne di più, consultare Strategie per selezionare le piste.
-
Board - consente di selezionare tutti gli oggetti che si trovano all'interno del contorno della scheda definito.
-
Net - consente di selezionare tutti gli oggetti elettrici associati a una determinata net.
Dopo aver avviato il comando, è possibile fare clic su un oggetto elettrico o su una connessione per selezionare tutti gli oggetti elettrici della net associata oppure, se si conosce il nome della net da selezionare, fare clic su un'area del progetto priva di oggetti; si aprirà la finestra di dialogo Net Name. Da qui è possibile immettere il nome della net desiderata; la net verrà selezionata alla chiusura della finestra di dialogo. Se non si è sicuri del nome della net, digitare ?, quindi fare clic su OK per aprire la finestra di dialogo Nets Loaded, che elenca tutte le net attualmente caricate per il progetto.
-
Connected Copper - consente di selezionare tutti gli oggetti elettrici connessi alla stessa porzione di rame.
-
Physical Connection - consente di selezionare tutte le piste fisicamente sbrogliate tra i pad. Fare clic su una pista, un pad o un via; verranno selezionate tutte le piste contigue fino al pad successivo, compresi gli eventuali via (i pad stessi non saranno inclusi nella selezione).
-
Physical Connection Single Layer - consente di selezionare tutte le piste fisicamente sbrogliate tra i pad su un singolo layer. Fare clic su una pista o un via; verranno selezionate tutte le piste contigue sullo stesso layer fino al pad successivo (i pad e i via stessi non saranno inclusi nella selezione).
-
Component Connections - consente di selezionare tutte le connessioni sbrogliate che partono dai pad di un componente scelto (incluse piste e via) fino al primo pad incontrato in ciascun caso. I pad stessi non saranno inclusi nella selezione.
È inoltre possibile accedere al comando facendo clic con il pulsante destro del mouse su un componente posizionato e scegliendo il comando Component Actions » Select Component Connections dal menu contestuale.
-
Component Nets - consente di selezionare tutte le net (e gli oggetti che ne fanno parte) collegate a un componente scelto nel documento corrente.
È inoltre possibile accedere al comando facendo clic con il pulsante destro del mouse su un componente posizionato e scegliendo il comando Component Actions » Select Component Nets dal menu contestuale.
-
Room Connections - consente di selezionare tutte le connessioni sbrogliate da pad a pad che si trovano interamente all'interno dei confini della room scelta nel documento corrente.
È inoltre possibile accedere al comando facendo clic con il pulsante destro del mouse su una room posizionata e scegliendo il comando Room Actions » Select Room Connections dal menu contestuale.
-
All on Layer - consente di selezionare/deselezionare tutti gli oggetti sul layer corrente.
-
Free Objects - consente di selezionare tutti gli oggetti primitivi liberi all'interno del progetto. Gli oggetti componente, gli oggetti coordinata, gli oggetti quota, gli oggetti di ottimizzazione della lunghezza, gli oggetti OLE e gli oggetti poligono di rame sono tutti oggetti di gruppo e pertanto non saranno interessati da questo comando.
-
All Locked - consente di selezionare tutti gli oggetti del progetto la cui proprietà Locked è abilitata.
-
Off Grid Pads - consente di selezionare tutti i pad che non sono posizionati sulla griglia di snap corrente.
Modifica grafica
Questo metodo di modifica consente di selezionare un oggetto posizionato direttamente nello spazio di progettazione e di modificarne graficamente le dimensioni, la forma o la posizione. La modifica della forma e/o delle dimensioni (ove applicabile) viene eseguita tramite le «maniglie» di modifica che compaiono quando l'oggetto viene selezionato.

Esempio di maniglie di modifica per un oggetto Fill selezionato.
Fai clic su un punto qualsiasi di un oggetto lontano dalle maniglie di modifica (se presenti) per trascinarlo e riposizionarlo. A seconda del tipo di oggetto, durante il trascinamento è possibile ruotarlo e/o ribaltarlo.
- Premi Spacebar per ruotare l'oggetto in senso antiorario o Shift+Spacebar per ruotarlo in senso orario. La rotazione avviene in base al valore di Rotation Step definito nella pagina PCB Editor – General della finestra di dialogo Preferences.
- Premi il tasto L per ribaltare l'oggetto sull'altro lato della scheda (ove applicabile).
- Premi i tasti X o Y per ribaltare l'oggetto lungo l'asse X o Y, ove applicabile.
- Premi il tasto Alt per vincolare la direzione del movimento all'asse orizzontale o verticale, a seconda della direzione iniziale del movimento.
- Sposta l'oggetto a piccoli incrementi (in base al valore corrente della griglia di aggancio) premendo i tasti freccia mentre tieni premuto il tasto Ctrl . Per spostarlo a incrementi maggiori (10 volte il valore della griglia di aggancio), premi i tasti freccia mentre tieni premuti i tasti Ctrl+Shift.
Comandi di spostamento
La posizione degli oggetti può essere modificata utilizzando i comandi del sottomenu Edit » Move dei menu principali o del sottomenu di spostamento in Active Bar.
-
Move - questo comando consente di spostare qualsiasi oggetto nel documento corrente. Le net associate a un oggetto rimangono connesse e le linee di connessione seguono l'oggetto durante lo spostamento (visualizzate o meno in base alla modalità di connessione attiva). Le piste già sbrogliate collegate all'oggetto non vengono spostate.
-
Drag - questo comando consente di spostare qualsiasi oggetto nel documento corrente. Se all'oggetto sono collegate piste e/o archi (ad esempio, nel caso di un componente, un pad o un via), questi rimangono connessi durante lo spostamento dell'oggetto.
-
Component - questo comando consente di spostare i componenti nel documento corrente. Dopo aver avviato il comando, fai clic sul componente del progetto che desideri spostare, portalo nella posizione desiderata e fai nuovamente clic. In alternativa, fai clic nello spazio di progettazione lontano da qualsiasi oggetto per aprire la finestra di dialogo Scegli componente. Utilizza questa finestra di dialogo per individuare il componente da spostare (passando direttamente al componente oppure portandolo sul cursore), quindi riposizionalo come descritto sopra. Nota che questa funzione è disponibile solo se il componente di destinazione è not bloccato.
Puoi accedere al comando anche facendo clic con il pulsante destro del mouse su un componente nello spazio di progettazione e scegliendo il comando Component Actions » Move Component dal menu contestuale.
-
Move Selection - questo comando consente di riposizionare manualmente gli oggetti selezionati nel documento corrente. Le net associate a un oggetto della selezione rimangono connesse e le linee di connessione seguono l'oggetto durante lo spostamento (visualizzate o meno in base alla modalità di connessione attiva). Le piste già sbrogliate collegate all'oggetto non vengono spostate.
-
Move Selection by X, Y - questo comando consente di spostare la selezione corrente di oggetti di una quantità precisa lungo le direzioni X e/o Y. Dopo aver avviato il comando, si apre la finestra di dialogo Get X/Y Offsets. Utilizza questa finestra di dialogo per specificare i valori degli incrementi delta X e/o delta Y di cui spostare la selezione.

La finestra di dialogo Get X/Y OffsetsOpzioni e controlli della finestra di dialogo Get X/Y Offsets
- X Offset - utilizza questo campo per specificare la distanza di cui spostare la selezione lungo l'asse orizzontale. Puoi specificare valori positivi e negativi in base alla direzione di movimento desiderata. Utilizza il pulsante a destra di questo campo per cambiare rapidamente il segno del valore inserito da positivo a negativo e viceversa.
- Y Offset - utilizza questo campo per specificare la distanza di cui spostare la selezione lungo l'asse verticale. Puoi specificare valori positivi e negativi in base alla direzione di movimento desiderata. Utilizza il pulsante a destra di questo campo per cambiare rapidamente il segno del valore inserito da positivo a negativo e viceversa.
- Toggle X/Y Offsets - fai clic su questo pulsante per scambiare rapidamente i valori di offset. Il valore X Offset verrà utilizzato come valore Y Offset e viceversa.
- Reset X/Y Offsets - fai clic su questo pulsante per azzerare rapidamente entrambi i valori di offset.
- Define X/Y Offsets Interactively - fai clic su questo pulsante per calcolare gli offset in modo interattivo. Passerai all'area di lavoro e ti verrà richiesto di scegliere, in sequenza, un punto iniziale e un punto finale. Fai clic nelle posizioni desiderate; i valori dX e dY verranno inseriti rispettivamente nei campi X Offset e Y Offset.
-
Rotate Selection - questo comando consente di ruotare gli oggetti selezionati nell'area di progettazione in senso antiorario o orario di un angolo specificato. Dopo aver avviato il comando, si apre la finestra di dialogo Rotation Angle (Degrees). Inserisci l'angolo di rotazione desiderato da 0,001° a 360,00° (risoluzione 0,001°). Inserisci un valore positivo per la rotazione in senso antiorario o un valore negativo per la rotazione in senso orario. Fai clic su OK per chiudere la finestra di dialogo, quindi posiziona il cursore e fai clic per definire il punto di riferimento della rotazione. Gli oggetti selezionati verranno ruotati attorno al punto di riferimento dell'angolo inserito.

La finestra di dialogo Rotation Angle -
Flip Selection - ribalta gli oggetti selezionati orizzontalmente (attorno all'asse Y), trasferendoli sul layer corrispondente sul lato opposto della scheda. Ad esempio, gli oggetti su Top Layer verranno ribaltati su Bottom Layer, gli oggetti su Top Overlay verranno ribaltati su Bottom Overlay e così via.
Comandi di allineamento
Gli oggetti possono essere spostati anche modificandone l'allineamento. Per allineare gli oggetti ad altri oggetti, fai clic con il pulsante destro del mouse su un oggetto selezionato, quindi seleziona Align. In alternativa, utilizza il Edit » Align sottomenu dei menu principali o il sottomenu di allineamento in Active Bar. Il sottomenu di allineamento contiene diverse opzioni per distribuire gli oggetti selezionati.
Il comando Align consente di accedere alla finestra di dialogo Align Objects, che offre controlli per allineare rapidamente, secondo necessità, l'insieme degli oggetti di progetto attualmente selezionati. Utilizza la finestra di dialogo per impostare le opzioni di allineamento Vertical e/o Horizontal degli oggetti selezionati, secondo necessità, quindi fai clic su OK per applicare l'allineamento.

La finestra di dialogo Align Objects
Opzioni e controlli della finestra di dialogo Align Objects
-
Horizontal - scegli una delle seguenti opzioni per determinare l'allineamento orizzontale degli oggetti selezionati:
- No Change - lascia invariato l'allineamento orizzontale degli oggetti.
- Left - allinea gli oggetti in modo che il bordo esterno delle rispettive primitive più a sinistra abbia la stessa coordinata X. L'oggetto con la primitiva più a sinistra viene utilizzato come riferimento.
- Center - sposta gli oggetti orizzontalmente in modo da allinearne i centri. Dopo aver fatto clic su OK, ti viene richiesto di fare clic per scegliere l'oggetto di riferimento.
- Right - allinea gli oggetti in modo che il bordo esterno delle rispettive primitive più a destra abbia la stessa coordinata X. L'oggetto con la primitiva più a destra viene utilizzato come riferimento.
- Space equally - gli oggetti vengono distribuiti a intervalli uguali in direzione orizzontale, tra l'oggetto più a sinistra e quello più a destra (che non vengono spostati).
-
Vertical - scegli una delle seguenti opzioni per determinare l'allineamento verticale degli oggetti selezionati:
- No Change - lascia invariato l'allineamento verticale degli oggetti selezionati.
- Top - allinea gli oggetti in modo che il bordo esterno delle rispettive primitive più in alto abbia la stessa coordinata Y. L'oggetto con la primitiva più in alto viene utilizzato come riferimento.
- Center - sposta gli oggetti verticalmente in modo da allinearne i centri. Dopo aver fatto clic su OK, ti viene richiesto di fare clic per scegliere l'oggetto di riferimento.
- Bottom - allinea gli oggetti in modo che il bordo esterno delle rispettive primitive più in basso abbia la stessa coordinata Y. L'oggetto con la primitiva più in basso viene utilizzato come riferimento.
- Space equally - gli oggetti vengono distribuiti a intervalli uguali in direzione verticale, tra l'oggetto più in alto e quello più in basso (che non vengono spostati).
Il comando Position Component Text consente di aprire la finestra di dialogo Component Text Position, da cui puoi modificare la posizione del testo del designatore e/o del commento per uno o più componenti selezionati nel documento corrente.

La finestra di dialogo Component Text Position
La finestra di dialogo è sostanzialmente suddivisa in due aree: il testo del designatore e quello del commento. Per entrambi, una rappresentazione grafica di un componente aiuta a mostrare dove apparirà il testo in base alla posizione selezionata. Per il testo sono disponibili i seguenti nove stili di posizionamento, tutti classificati come «posizioni automatiche»: ciò significa che il testo rimane nella posizione scelta quando il componente viene spostato e ruotato:
- Left-Above
- Left-Center
- Left-Below
- Center-Above
- Center
- Center-Below
- Right-Above
- Right-Center
- Right-Below
Per lasciare il testo nella posizione corrente senza modificarlo, lascia abilitata l'opzione No Change.
Il comando Align Left / Align Right / Align Top / Align Bottom consente di allineare gli oggetti di progetto selezionati rispettivamente in base ai bordi sinistro/destro/superiore/inferiore. Dopo aver avviato il comando, il bordo sinistro/destro/superiore/inferiore dell'oggetto più a sinistra/a destra/in alto/in basso viene utilizzato come riferimento e tutti gli altri oggetti della selezione vengono spostati a sinistra/a destra/verso l'alto/verso il basso, in modo che i rispettivi bordi sinistri siano allineati a questo riferimento.
Il Align Left (maintain spacing) / Align Right (maintain spacing) / Align Top (maintain spacing) / Align Bottom (maintain spacing) consente di allineare gli oggetti di progetto selezionati in base ai rispettivi bordi sinistro/destro/superiore/inferiore, mantenendo una spaziatura adeguata nel rispetto delle regole di progettazione applicabili. Dopo aver avviato il comando, il bordo sinistro/destro/superiore/inferiore dell'oggetto più a sinistra/a destra/in alto/in basso viene utilizzato come riferimento e tutti gli altri oggetti selezionati vengono spostati verso sinistra/destra/l'alto/il basso, in modo che i loro bordi sinistri siano allineati a questo riferimento. Ogni oggetto viene spostato verso sinistra/destra/l'alto/il basso il più vicino possibile all'oggetto di riferimento, nei limiti consentiti dalla regola di distanza minima applicabile:
- Per l'allineamento dei soli componenti, viene rispettata la regola Component Clearance.
- Per l'allineamento dei soli oggetti che non sono componenti, viene rispettata la regola Clearance.
- Per l'allineamento di componenti e oggetti che non sono componenti, viene rispettata la regola Clearance.
Il comando Align Horizontal Centers / Align Vertical Centers consente di disporre gli oggetti selezionati in un'unica colonna/riga, allineandoli in base ai rispettivi centri orizzontali/verticali. Dopo aver avviato il comando, il cursore assume la forma di un mirino e viene richiesto di selezionare uno degli oggetti selezionati; fai clic su di esso. Questo diventa l'oggetto di riferimento. Tutti gli altri oggetti selezionati vengono spostati rispetto a questo oggetto di riferimento, allineandoli in base ai rispettivi centri orizzontali/verticali.
Il comando Distribute Horizontally / Distribute Vertically consente di uniformare la spaziatura orizzontale/verticale di una selezione di oggetti. Dopo aver avviato il comando, gli oggetti più a sinistra e più a destra / più in alto e più in basso della selezione rimangono fissi nelle rispettive posizioni, mentre tutti gli altri oggetti vengono distribuiti uniformemente tra essi. La posizione verticale/orizzontale degli oggetti non viene modificata.
Il comando Increase Horizontal Spacing / Increase Vertical Spacing consente di aumentare la spaziatura orizzontale/verticale di una selezione di oggetti. Dopo aver avviato il comando, l'oggetto più a sinistra/più in basso rimane fisso, mentre gli altri oggetti selezionati vengono spostati verso destra/l'alto. Lo spostamento aumenta la distanza orizzontale/verticale tra i punti di riferimento di oggetti consecutivi del valore specificato nel campo Step X / Step Y per il valore predefinito Global Board Snap Grid.
Il comando Decrease Horizontal Spacing / Decrease Vertical Spacing consente di diminuire la spaziatura orizzontale/verticale di una selezione di oggetti. Dopo aver avviato il comando, l'oggetto più a sinistra/più in basso rimane fisso, mentre gli altri oggetti selezionati vengono spostati verso sinistra/il basso. Lo spostamento riduce la distanza orizzontale/verticale tra i punti di riferimento di oggetti consecutivi del valore specificato nel campo Step X / Step Y per il valore predefinito Global Board Snap Grid.
Il comando Align To Grid viene utilizzato per spostare i componenti selezionati sul punto più vicino della griglia di aggancio applicabile e modificata. Dopo aver avviato il comando, i punti di riferimento di ciascun componente selezionato vengono spostati sul punto più vicino della griglia di aggancio applicabile.
Il comando Move All Components Origin To Grid viene utilizzato per spostare il punto di riferimento di tutti i componenti sulla griglia di aggancio corrente. Dopo aver avviato il comando, tutti i componenti nell'area di progettazione i cui pad si trovano sulla griglia vengono spostati in modo che i rispettivi punti di riferimento siano allineati alla griglia di aggancio corrente. Per impostazione predefinita, viene generato automaticamente un report, Move Component(s) Origin To Grid - <PCBDocumentName>.html, che viene aperto come documento attivo e indica in dettaglio quali componenti sono stati spostati e quali no.
Tramite il pannello PCB List
Il pannello PCB List consente di visualizzare gli oggetti di progetto in formato tabellare, permettendo di esaminarne e modificarne rapidamente gli attributi. Se utilizzato insieme al pannello PCB Filter, consente di visualizzare solo gli oggetti che rientrano nell'ambito del filtro attivo, permettendo di individuare e modificare più oggetti di progetto con maggiore precisione ed efficienza.
Selezione del layer attivo
Il layer attivo è il layer su cui verranno posizionati gli oggetti. Il layer attivo può essere selezionato tra quelli attualmente visibili facendo clic sulla relativa scheda nella parte inferiore dell'area di progettazione oppure utilizzando il menu a discesa Active Layer nella sezione Layers della scheda Layers & Colors del pannello View Configuration.
Puoi anche utilizzare le seguenti scorciatoie per selezionare rapidamente il layer attivo:
- * (sul tastierino numerico) – passa al layer di segnale abilitato successivo.
-
Shift+* (sul tastierino numerico) – passa al layer di segnale abilitato precedente.
- + (sul tastierino numerico) – passa al layer abilitato successivo.
- - (sul tastierino numerico) – passa al layer abilitato precedente.
Utilizzo di Taglia/Copia e Incolla
Nell'editor PCB puoi tagliare/copiare e incollare oggetti all'interno dello stesso documento PCB o tra documenti PCB diversi; ad esempio, i componenti di un PCB possono essere copiati in un altro documento PCB. Puoi tagliare/copiare gli oggetti negli Appunti di Windows e incollarli in altri documenti.
Quando utilizzi 2D Layout Mode, seleziona gli oggetti che desideri tagliare/copiare, fai clic su Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) nei menu principali oppure scegli il comando Cut/Copy dal menu contestuale. Il cursore assume la forma di un mirino e viene richiesto di selezionare un punto di riferimento. Si tratta di una coordinata relativa agli oggetti selezionati, utilizzata per posizionare con precisione la selezione quando si usa il comando Incolla.
Per copiare negli appunti in formato testuale gli oggetti di progetto attualmente selezionati, è possibile utilizzare il comando Edit » Copy As Text dai menu principali. Queste informazioni possono quindi essere incollate in qualsiasi campo di testo o documento di testo esterno. I dettagli copiati negli appunti includono:
- Il tipo di oggetto.
- Il designatore e il commento (per un oggetto componente).
- La posizione dell'oggetto nello spazio di progettazione.
- Il layer su cui si trova l'oggetto (oppure i layer iniziale e finale per una via).
Un esempio di componente copiato negli appunti come testo è:
Component Y1-25MHz (100.6mm,1.5mm) on Top Layer
Un esempio di pista e via copiate negli appunti come testo è:
Track (20mm,6mm)(80mm,6mm) Top Layer
Via (45mm,6mm) Top Layer to Bottom Layer
Per inserire nel documento attivo l'ultimo contenuto tagliato o copiato negli appunti, scegliere il comando Edit » Paste dai menu principali oppure fare clic con il pulsante destro del mouse nello spazio di progettazione e scegliere il comando Paste dal menu contestuale (scorciatoia: Ctrl+V). L'ultimo contenuto degli appunti apparirà agganciato al cursore. La posizione del cursore rispetto al contenuto è determinata dal punto di riferimento specificato quando è stato utilizzato Cut o Copy per aggiungere la selezione agli appunti.
Per inserire il testo copiato da un'applicazione OLE supportata in qualsiasi documento PCB aperto, è possibile utilizzare il comando Edit » Paste Text dai menu principali. Il testo viene convertito e incollato come oggetti stringa del PCB, anziché come un singolo oggetto OLE. I tipi di file supportati includono formati universali, come i fogli di calcolo in formato CSV e XLS e i documenti di testo DOC e RTF.
Per controllare cosa accade a determinati attributi degli oggetti quando vengono incollati nuovamente nello spazio di progettazione, è possibile utilizzare il comando Edit » Paste Special dai menu principali. Dopo aver avviato il comando, si aprirà la finestra di dialogo Paste Special.

La finestra di dialogo Paste Special
Opzioni e controlli della finestra di dialogo Incolla speciale
Attributi di incollaggio
- Paste on current layer - abilitare questa opzione per incollare gli oggetti sul layer corrente.
- Keep net name - abilitare questa opzione per mantenere i nomi originali delle net degli oggetti.
- Duplicate designator - abilitare questa opzione per incollare un componente con lo stesso designatore, senza incrementarlo automaticamente.
- Add to component class - abilitare questa opzione per aggiungere il componente incollato alla stessa classe di componenti del componente di origine.
Pulsanti
- Paste - fare clic per incollare l'oggetto con tutti gli attributi specificati.
- Paste Array - fare clic per aprire la finestra di dialogo Configura incollaggio in serie, in cui è possibile configurare le opzioni per l'incollaggio in serie.
A seconda del contenuto specifico da incollare, è possibile controllare i seguenti attributi:
-
Gli oggetti possono essere incollati sul layer corrente, anziché sullo stesso layer da cui sono stati copiati gli oggetti di origine, come avviene per impostazione predefinita.
- Possibilità di mantenere i nomi assegnati alle net.
- Possibilità di duplicare il designatore (per un componente incollato).
- Possibilità di aggiungere un componente incollato alla stessa classe di componenti del componente di origine.
Configurare le opzioni secondo necessità, quindi fare clic sul pulsante Paste per avviare l'operazione di incollaggio.
Facendo clic sul pulsante Paste Array nella finestra di dialogo Paste Special si apre la finestra di dialogo Setup Paste Array, che consente di incollare più copie degli oggetti presenti negli appunti nel documento corrente.

La finestra di dialogo Setup Paste Array
Opzioni e controlli della finestra di dialogo Configura incollaggio in serie
Variabili di posizionamento
- Item Count - il numero di posizionamenti ripetuti da eseguire. Ad esempio, inserendo 4 verranno posizionate 4 copie del contenuto corrente degli appunti.
-
Text Increment - inserire l'incremento automatico per il testo visualizzato (ad esempio, il designatore di un componente o di un pad). Sono supportati incrementi sia alfabetici sia numerici diversi da 1. Ad esempio, impostando il designatore di un pad prima di copiarlo negli appunti e configurando il campo Text Increment, è possibile posizionare le seguenti sequenze di designatori dei pad:
- Numerica (1, 3, 5)
- Alfabetica (A, B, C)
- Combinazione di lettere e numeri (A1, A2, oppure 1A, 1B, oppure A1, B1 oppure 1A, 2A, ecc.)
Tipo di serie
- Circular- abilitare questa opzione per incollare una serie circolare utilizzando le impostazioni correnti di Circular Array.
- Linear - abilitare questa opzione per incollare la serie in linea retta utilizzando le impostazioni correnti di Linear Array.
Serie circolare
- Rotate Item to Match - se abilitata, gli elementi della serie verranno ruotati dello stesso angolo definito dalla loro spaziatura.
- Spacing (degrees) - la distanza angolare tra due elementi incollati adiacenti.
Serie lineare
- X-Spacing - inserire la distanza desiderata lungo X tra due elementi adiacenti.
- Y- Spacing - inserire la distanza desiderata lungo Y tra due elementi adiacenti.
Inserire i valori appropriati in questa finestra di dialogo, quindi fare clic su OK per posizionare la serie.
- Se si sta posizionando una serie lineare, verrà richiesto di selezionare il punto iniziale della serie. Posizionare il cursore, quindi fare clic o premere Enter per posizionare la serie.
- Se si posiziona una matrice circolare, verrà richiesto di selezionare il punto centrale della matrice, seguito dal punto iniziale. Posizionare il cursore in ciascun caso, quindi fare clic o premere Enter per posizionare la matrice. Gli oggetti verranno disposti in senso antiorario attorno al punto centrale indicato.
Priorità quando si incollano gli oggetti
Quando un oggetto viene incollato su un layer di rame e si sovrappone a un insieme di oggetti di tipi diversi, all'oggetto incollato viene assegnata la net dell'oggetto con la priorità più alta. Le priorità sono le seguenti (1 indica la priorità più alta):
- Pad
- Riempimento
- Regione
- Pista
- Arco
- Via
- Poligono di rame

All'oggetto incollato viene assegnata la net dell'oggetto con la priorità più alta. Qui è mostrato un oggetto (pista) incollato sopra un insieme di oggetti di tipi diversi a cui sono assegnate net differenti. Poiché il pad è l'oggetto con la priorità più alta in questo insieme, la sua net (Pad_Net) verrà assegnata all'oggetto incollato. Passare il cursore sull'immagine per vedere il risultato.
Quando un oggetto viene incollato su un layer di rame e si sovrappone a un insieme di oggetti dello stesso tipo, viene assegnata la net dell'oggetto che si trova sotto il cursore al momento del clic per incollare.

All'oggetto incollato viene assegnata la net dell'oggetto sotto il cursore. Qui è mostrato un oggetto (pista) incollato sopra un insieme di oggetti dello stesso tipo (pad). Poiché il pad 2 è l'oggetto che si trova sotto il cursore al momento del clic per incollare, la net di questo pad (Pad2_Net) verrà assegnata all'oggetto incollato. Passare il cursore sull'immagine per vedere il risultato.
Quando un insieme di oggetti fisicamente connessi viene incollato su un layer di rame e gli oggetti di tipi diversi di questo insieme si sovrappongono a oggetti esistenti con net differenti, la net dell'oggetto con la priorità più alta nell'insieme verrà assegnata a tutti gli oggetti incollati. In questo caso si applicano le priorità indicate sopra.

La net assegnata all'oggetto con la priorità più alta viene assegnata all'insieme di oggetti fisicamente connessi. Qui è mostrato un insieme di oggetti connessi (da sinistra a destra: riempimento, regione, pista, arco, via, poligono di rame) incollato sopra oggetti (via) a cui sono assegnate net differenti. Poiché il riempimento è l'oggetto con la priorità più alta nell'insieme incollato, la net assegnata a esso (Via1_Net) verrà assegnata a ciascun oggetto dell'insieme. Passare il cursore sull'immagine per vedere il risultato.
Blocco degli oggetti di progettazione
È possibile impedire lo spostamento o la modifica degli oggetti di progettazione nel documento PCB abilitando i relativi attributi Locked . Ad esempio, se la posizione o le dimensioni di determinati oggetti sono critiche, è opportuno bloccarli. Il blocco può essere effettuato nel pannello Properties facendo clic sull'icona del lucchetto per gli oggetti desiderati, come mostrato negli esempi seguenti.
Esempi dell'icona Lock nel pannello Properties per un componente e un pad selezionati.
Per cambiare lo stato della proprietà Locked di un oggetto posizionato che dispone della proprietà Locked , è anche possibile fare clic con il pulsante destro del mouse sull'oggetto nell'area di progettazione e scegliere il comando <ObjectType> Locked dal menu contestuale. Quando l'oggetto è già bloccato, la voce del comando nel menu mostra un segno di spunta sulla sinistra.
Se si tenta di spostare o ruotare un oggetto di progettazione la cui proprietà Locked è abilitata, viene visualizzata una finestra di dialogo che richiede la conferma per procedere con la modifica.
Blocco delle primitive dei componenti
Se le primitive di un componente PCB sono bloccate (l'opzione Primitives nella modalità Componente del pannello Proprietà è nello stato , tutte o la maggior parte delle proprietà di tali primitive non possono essere modificate mediante metodi di modifica grafici (ad esempio, tramite trascinamento) e non grafici (ad esempio, tramite il pannello Properties o List). Ciò contribuisce a prevenire modifiche accidentali delle primitive dei componenti che possono generare output di assemblaggio e fabbricazione errati.
A titolo di esempio, nell'immagine seguente è mostrata la modalità Pad del pannello Proprietà per un pad che fa parte di un componente PCB le cui primitive sono bloccate. Si noti che tutte le proprietà del pad (ad eccezione delle proprietà Net e Testpoint) sono visualizzate in grigio e non possono essere modificate. Si noti inoltre che l'icona
è mostrata all'estrema destra della proprietà Component del pad campo, che indica che le primitive del componente padre sono bloccate e che le proprietà dei pad non possono essere modificate.

La modalità Pad del pannello Properties (a sinistra) per un pad di un componente PCB le cui primitive sono bloccate (a destra).
Modifica rientrante
L'editor PCB include una potente funzionalità chiamata re-entrant editing. Questa consente di eseguire una seconda operazione tramite scorciatoie da tastiera senza interrompere l'operazione corrente. La modifica rientrante consente di lavorare in modo più flessibile e intuitivo. Ad esempio, supponiamo di iniziare a posizionare una pista e poi accorgerci che è necessario eliminare un altro segmento di pista. Non è necessario uscire dalla modalità Routing interattivo. Premere i tasti di scelta rapida E, D, eliminare il segmento di pista desiderato, quindi premere il tasto Esc per tornare al routing interattivo del progetto.
Impostazione dell'aspetto del cursore PCB
Per impostazione predefinita, il cursore PCB è una piccola croce verde a 90 gradi. È possibile configurarlo tramite le impostazioni Cursor Type e Cursor Color, nella pagina Editor PCB – Generale della finestra di dialogo Preferences . Ad esempio, una grande croce a 90 gradi che si estende fino ai bordi della finestra di progettazione (opzione Large 90) può essere utile per posizionare e allineare gli oggetti del progetto. In alternativa, una croce a 45 gradi (opzione Small 45) può essere utile se le opzioni a 90 gradi sono difficili da distinguere dalle linee della griglia.
Supporto dei font TrueType
L'editor PCB offre la possibilità di utilizzare font a tratti o TrueType per gli oggetti testuali di un progetto (stringhe/riquadri di testo, quote, tabelle di foratura e/o tabelle dello stack dei layer). La scelta del font viene effettuata nel pannello Properties associato. Sono disponibili tre opzioni di font a tratti: Default, Sans Serif e Serif. Lo stile Default è un semplice font vettoriale che supporta il tracciamento a penna e il fototracciamento vettoriale. I font Sans Serif e Serif sono più complessi e rallentano la generazione degli output vettoriali, come Gerber. I font a tratti sono integrati nel software e non possono essere modificati. Tutti e tre i font includono il set completo di caratteri ASCII esteso IBM, che supporta l'inglese e altre lingue europee. Quando si utilizzano font TrueType, sono disponibili i font TrueType e OpenType (un'estensione di TrueType) presenti nella cartella \Windows\Fonts. La funzionalità offre inoltre il supporto completo di Unicode.
Le geometrie degli oggetti di testo che utilizzano font TrueType vengono memorizzate automaticamente nei documenti PCB. Quando gli oggetti di un documento PCB utilizzano un font TrueType, tali oggetti vengono visualizzati con la stessa geometria del font quando il documento PCB viene aperto su un altro computer, anche se quel font TrueType non è installato.
Quando si seleziona un oggetto che utilizza un font mancante, nella parte superiore del pannello Properties viene visualizzato un messaggio di avviso. Quando si modificano proprietà dell'oggetto che influiscono sul testo (ad esempio, l'altezza del testo o il testo stesso), si apre la finestra di dialogo Missing fonts, nella quale è possibile selezionare un font sostitutivo (Replacement). Abilitare l'opzione Apply to all text elements per applicare il font sostitutivo a tutti gli oggetti del documento PCB che utilizzano il font mancante.
La finestra di dialogo viene visualizzata anche quando si modificano le proprietà relative al testo dal pannello PCB List.
Quando si tenta di modificare più oggetti che utilizzano font mancanti diversi, la finestra di dialogo consente di selezionare un sostituto per ciascun font mancante.
Supporto del rendering di archi reali
Sono supportati gli archi reali generati nell'area di progettazione sia dell'editor PCB sia dell'editor delle librerie PCB, anziché le loro approssimazioni. Questo supporto si estende alle modalità di layout 2D/3D (e alla modalità di pianificazione della scheda per l'editor PCB). Il rendering di archi reali è visibile nei seguenti elementi:
-
Riempimenti poligonali (pieni, tratteggiati, nessuno)
-
Aree di esclusione dei riempimenti poligonali
-
Contorno di selezione per riempimenti poligonali e regioni
-
Regioni
-
Espansioni della maschera di saldatura e della maschera per pasta saldante
-
Evidenziazione delle net
-
Limiti delle distanze di isolamento
-
Sovrapposizione delle violazioni (riempimento poligonale separato su una regione o un riempimento poligonale)
Di seguito sono riportati esempi di rendering di archi reali per riempimenti poligonali attorno ad altri oggetti di un PCB.
Informazioni sulle net
Per gli oggetti in rame su un PCB (piste, via, poligoni, ecc.), quando l'oggetto è selezionato vengono visualizzate le seguenti informazioni nella sezione Net Information del pannello Properties:
- Net, Diff Pair e/o xSignal di appartenenza e la classe associata in ciascun caso. Si noti che le voci Diff Pair e xSignal vengono visualizzate solo se l'oggetto fa parte rispettivamente di una coppia differenziale o di un xSignal.
-
Delay – il ritardo degli oggetti selezionati e il ritardo dei segmenti instradati dell'intera net. Include i valori Propagation Delay dei pad e dei via, se sono stati definiti per tali pad e via.
-
Length – la somma delle lunghezze degli oggetti selezionati e il valore totale di Signal Length. Il valore Signal Length rappresenta il calcolo accurato della distanza totale da nodo a nodo. Gli oggetti posizionati vengono analizzati per risolvere gli oggetti sovrapposti o impilati e i percorsi tortuosi all'interno delle piazzole; sono incluse anche le lunghezze dei via. Anche il valore Pin Package Length viene incluso, se è stato definito per le piazzole. Se la net non è completamente sbrogliata, viene inclusa anche la lunghezza Manhattan (X + Y) della linea di connessione. Per ulteriori informazioni sulla lunghezza del segnale e sulle sue applicazioni, consultare le informazioni sul pannello PCB - Nets.
-
Max Current - la corrente massima che gli oggetti Pista, Arco o Via selezionati possono condurre, determinata mediante la formula IPC-2221A (Sezione 6.2):
I = k * ΔT0.44 * A0.725
dove:
I = corrente [ampere]
A = area della sezione trasversale [mil quadrati] (larghezza della pista * spessore del rame nello stack dei layer, oppure Abarrel, come mostrato di seguito)
ΔT = aumento di temperatura consentito rispetto alla temperatura ambiente [°C]
k = costante, tale che:k = 0.048 per i layer esterni
k = 0.024 per i layer interni -
Resistance - la somma delle resistenze degli oggetti Pista, Arco e Via selezionati, determinata mediante la formula derivata:
R = (ρ * L / A)
dove:
R = resistenza [Ω]
ρ = resistività del rame [Ω*mm2/m]
L = lunghezza della pista [m] (o lunghezza del via, come descritto di seguito)
A = area della sezione trasversale = T * W [mm2] (oppure Abarrel, come mostrato di seguito)
T = spessore della pista (dallo stack dei layer) [mm]
W = larghezza della pista [mm]Assumptions:
- Temperatura ambiente = 22 °C
- Aumento di temperatura consentito = 20 °C
- Spessore della parete di rame del foro passante = 0.018mm
- Resistività del rame = 0.017 Ω*mm2/m

La sezione Net Information del pannello Properties. Qui è mostrato un esempio relativo a una pista selezionata.
Fare clic su un collegamento nella sezione Net Information per aprire la net, la coppia differenziale o l'xSignal associato nel pannello PCB.
Assegnazione delle net agli oggetti
L'editor PCB offre diversi modi per assegnare le net agli oggetti primitivi:
- Quando sono selezionati uno o più oggetti, utilizzare il menu a discesa del campo Nets nel pannello Properties. Tutte le net del progetto della scheda attivo saranno elencate nel menu a discesa. Selezionare No Net per specificare che la pista non è collegata ad alcuna net. In alternativa, è possibile fare clic sull'icona Assign Net per scegliere un oggetto nell'area di progettazione: la net di quell'oggetto verrà assegnata agli oggetti selezionati.
- Fare clic con il pulsante destro del mouse su uno o più oggetti selezionati, quindi scegliere Net Actions » Assign Net. Dopo aver avviato il comando, viene visualizzato un cursore a croce. Posizionare il cursore a croce sulla net a cui si desidera assegnare gli oggetti, quindi fare clic per selezionarla.
- Per risincronizzare il nome della net delle primitive di routing con il nome della net dei pad a cui sono collegate, seleziona il comando Design » Netlist » Update Free Primitives From Component Pads dai menu principali. Dopo aver avviato il comando, si apre una finestra di conferma che chiede se desideri aggiornare le net delle primitive libere con quelle dei pad dei componenti. Dopo aver fatto clic su Yes, partendo da ciascun pad, viene selezionato il rame collegato e il nome della net di ogni primitiva viene impostato in modo che corrisponda a quello del pad. Questa operazione non modifica la netlist interna del PCB.
Per verificare e confermare che agli oggetti fisicamente collegati sia assegnata la net corretta, corrispondente alla net fisica a cui appartengono (in questo caso, physical net significa connected copper), puoi utilizzare la finestra di dialogo Configure Physical Nets, accessibile scegliendo il comando Design » Netlist » Configure Physical Nets dai menu principali. Il software analizza il progetto, verificando che a tutti i pad e agli oggetti che li collegano fisicamente tra loro (piste, archi, riempimenti, ecc.) sia assegnato lo stesso nome di net. Quando tutti gli oggetti della net sono corretti, la net viene visualizzata in verde. Se vengono rilevati oggetti a contatto ma con una net diversa assegnata, questi vengono evidenziati in rosso. Un caso comune in cui ciò può verificarsi è quando il footprint di un componente contiene oggetti in rame aggiuntivi. Quando questo footprint viene caricato durante la sincronizzazione, il nome della net assegnata viene applicato a ciascun pad, ma non al rame aggiuntivo. La finestra di dialogo è interattiva: fai clic su una net o su una primitiva per individuare l'oggetto corrispondente nel progetto tramite cross-probing. Fai clic con il pulsante destro del mouse o sul pulsante Menu per accedere ai comandi disponibili. La sezione Action della finestra di dialogo fornisce i controlli per specificare l'azione da eseguire per risolvere i problemi del rame collegato. Per impostazione predefinita, le azioni vengono impostate automaticamente, ma possono essere modificate secondo necessità. Una volta impostate le azioni, fai clic sul pulsante Execute per aggiornare le assegnazioni delle net.

La finestra di dialogo Configure Physical Nets (con l'opzione Only Show Errors attivata sullo sfondo e l'opzione Only Show Errors disattivata in primo piano).
Opzioni e controlli della finestra di dialogo Configura net fisiche
-
Electrically Connected Copper - questa sezione elenca gruppi distinti di primitive in rame che risultano elettricamente collegate nel routing del progetto. Per ogni gruppo vengono presentate le seguenti informazioni:
-
Primitive - al livello più alto, questa voce indica quante primitive sono presenti nel rame collegato. Le primitive possono essere visualizzate in un elenco semplice o raggruppate per tipo. Quest'ultima modalità si configura attivando l'opzione Show Primitive Groups tra le opzioni del pulsante Menu . In questo caso, le primitive verranno suddivise nei seguenti gruppi:
- Connected Component Primitives - elenca come voci figlie tutte le primitive dei pad dei componenti. Queste possono essere ulteriormente raggruppate in base al componente di appartenenza attivando l'opzione Show Components del pulsante Menu .
- Connected Free Primitives - elenca come voci figlie tutte le primitive in rame non appartenenti a componenti, ulteriormente raggruppate per tipo di primitiva (riempimenti, poligoni, piste, via).
-
Primitive - al livello più alto, questa voce indica quante primitive sono presenti nel rame collegato. Le primitive possono essere visualizzate in un elenco semplice o raggruppate per tipo. Quest'ultima modalità si configura attivando l'opzione Show Primitive Groups tra le opzioni del pulsante Menu . In questo caso, le primitive verranno suddivise nei seguenti gruppi:
- Original Net Names - questo campo indica il nome della net attualmente assegnata alla primitiva, ovvero la net a cui la primitiva è attualmente collegata. La voce corrisponde a una delle net definite per la scheda. Tuttavia, se una primitiva non è collegata a una net, verrà riportata la voce <Unassigned>.
-
Status - questo campo fornisce un'indicazione dello stato complessivo del gruppo, che può assumere uno dei quattro stati:
- Blank - l'assegnazione delle net al raggruppamento di rame connesso è corretta e non richiede alcun aggiornamento. La voce di primo livello del raggruppamento è di colore verde.
- 1. Update Required - Unassigned Nets - in questo stato, nessuna delle primitive del raggruppamento è stata assegnata a una net. La voce di primo livello del raggruppamento è di colore giallo.
- 2. Update Required - Some Unassigned Nets - in questo stato, alcune primitive sono state assegnate alla stessa net, mentre altre non sono state assegnate ad alcuna net. La voce di primo livello del raggruppamento è di colore arancione.
- 3. Ambiguous - Multiple Net Names - in questo stato, alcune primitive del raggruppamento sono state assegnate a net diverse. Potrebbero esserci anche primitive non ancora assegnate. La voce di primo livello del raggruppamento è di colore rosso.
-
Action - quest'area fornisce i controlli per specificare l'azione da eseguire per risolvere i problemi relativi al rame connesso, insieme al risultato dell'esecuzione delle modifiche configurate. Per ogni raggruppamento vengono presentati i seguenti elementi:
-
Proposed Action - questo campo consente di determinare quale azione eseguire, se necessaria. Al livello più alto di un raggruppamento, questa voce può essere impostata su Update Net To o Don't Update Net To. Per eseguire un aggiornamento, scegliere la nuova net di destinazione nel campo New Net Name. In base a queste due impostazioni, il software calcola le azioni da eseguire sulle primitive figlie, proponendo una delle seguenti opzioni:
- No Action Required - la primitiva è già assegnata/connessa alla net di destinazione.
- Update - includere la primitiva nell'aggiornamento in modo che venga assegnata/connessa alla nuova net di destinazione.
- Don't Update - non includere la primitiva nell'aggiornamento. Rimarrà connessa alla net attuale.
- New Net Name - utilizzare questo campo per impostare una nuova net di destinazione alla quale connettere le primitive. L'elenco a discesa del campo mostra tutte le net rilevate tra le primitive del raggruppamento di rame connesso. Se occorre utilizzare una net diversa, fare clic con il pulsante destro del mouse sul campo e utilizzare il comando Change Copper Net To Board Net del menu contestuale. Si apre la finestra di dialogo Choose Net, che elenca tutte le net attualmente definite per la scheda. Scegliere la net desiderata, quindi fare clic su OK. La net verrà inserita nel campo.
- Done - questo campo indica la riuscita o il fallimento dell'azione di aggiornamento dopo aver premuto il pulsante Execute e applicato le modifiche.
-
Proposed Action - questo campo consente di determinare quale azione eseguire, se necessaria. Al livello più alto di un raggruppamento, questa voce può essere impostata su Update Net To o Don't Update Net To. Per eseguire un aggiornamento, scegliere la nuova net di destinazione nel campo New Net Name. In base a queste due impostazioni, il software calcola le azioni da eseguire sulle primitive figlie, proponendo una delle seguenti opzioni:
- Execute - una volta verificate le azioni assegnate alla netlist, fare clic su questo pulsante per aggiornare le assegnazioni delle net.
-
Menu - fare clic per accedere al seguente menu di comandi, relativi all'elenco principale in generale o alle primitive attualmente selezionate. I comandi sono identici a quelli disponibili nel menu contestuale dell'area dell'elenco principale.
- Update/Don't Update/No Action - utilizzare per commutare rapidamente l'azione proposta per le primitive selezionate. A un livello padre superiore nella gerarchia delle primitive, consente di commutare l'azione proposta per tutti gli elementi figli discendenti.
- Select All - utilizzare per selezionare rapidamente tutti i raggruppamenti di rame connesso (le voci di livello più alto nell'elenco).
- Select All With Same Status - con una voce di primo livello di un raggruppamento di rame connesso selezionata, utilizzare questo comando per selezionare rapidamente tutti gli altri raggruppamenti di primo livello con lo stesso stato.
- Clear All Selected - utilizzare per deselezionare tutte le voci nell'elenco.
- Expand All In Connected Copper - utilizzare per espandere rapidamente tutti i raggruppamenti figli all'interno del raggruppamento di rame connesso attualmente attivo.
- Expand All - utilizzare per espandere rapidamente tutti i raggruppamenti per tutti i raggruppamenti di rame connesso nell'elenco.
- Expand Children - utilizzare per espandere rapidamente tutti i gruppi figli discendenti al di sotto del raggruppamento attualmente selezionato.
- Collapse All In Connected Copper - utilizzare per comprimere rapidamente tutti i raggruppamenti figli all'interno del raggruppamento di rame connesso attualmente attivo.
- Collapse All - utilizzare per comprimere rapidamente tutti i raggruppamenti per tutti i raggruppamenti di rame connesso nell'elenco.
- Collapse Children - utilizzare per comprimere rapidamente tutti i gruppi figli discendenti al di sotto del raggruppamento attualmente selezionato.
- Only Show Errors - abilitare per mostrare solo gli errori nella finestra di dialogo. L'elenco mostrerà solo i raggruppamenti di rame connesso il cui Status è di livello 1, 2 o 3. Disabilitare per mostrare anche il rame connesso assegnato correttamente.
- Show Components - abilitare per raggruppare le primitive dei pad dei componenti in base ai rispettivi componenti padre.
- Show Primitive Groups - abilitare per raggruppare le primitive in base al loro tipo.
- Animate Action Execution - abilitare per fare in modo che la finestra di dialogo scorra l'elenco durante l'esecuzione, mostrando in tempo reale l'avanzamento animato delle modifiche alle net. Disabilitando questa opzione, le modifiche verranno eseguite senza tale animazione.
-
Warn On Netlist Change - abilitare per ricevere un avviso quando le modifiche influiranno sulla netlist della scheda. Si aprirà la finestra di dialogo Netlist Change, che indica quante primitive subiranno una modifica delle net e avvisa che questa operazione influirà sulla netlist. È possibile fare clic su Continue oppure su Filter Affected per esaminare più attentamente le modifiche proposte.

La finestra di dialogo Netlist Change - Show Component Pads - abilitare per mostrare nell'elenco le primitive connesse dei componenti.
- Show Non Component Pads - abilitare per mostrare nell'elenco le primitive libere connesse.
- Show Changes That Affect Netlist - abilitare per mostrare solo un elenco delle azioni proposte (modifiche) che influiranno sulla netlist della scheda.
- Change Copper Net To - una o più voci di menu di questo tipo vengono visualizzate quando alle primitive del raggruppamento di rame connesso attivo sono attualmente assegnate poche net. Utilizzare una voce di questo tipo per scegliere rapidamente la net di destinazione per il campo New Net Name.
- Change Copper Net To Net - questa voce di menu viene visualizzata quando le net attualmente assegnate alle primitive di un raggruppamento di rame connesso sono troppo numerose per essere mostrate come singole voci di menu. Questo comando consente di accedere alla finestra di dialogo Choose Net, che elenca tutte le net attualmente assegnate alle primitive del raggruppamento. Scegliere la net desiderata, quindi fare clic su OK; la net verrà inserita nel campo New Net Name del raggruppamento di rame connesso attivo.
- Change Copper Net To Board Net - utilizzare questo comando se occorre utilizzare una net diversa da quelle attualmente assegnate alle primitive del raggruppamento di rame connesso attivo. Si apre la finestra di dialogo Choose Net, che elenca tutte le net attualmente definite per la scheda. Scegliere la net desiderata, quindi fare clic su OK; la net verrà inserita nel campo New Net Name.
- Show All Primitives - fare clic su questo pulsante per visualizzare rapidamente tutte le primitive. Questo pulsante diventa disponibile se le opzioni Show Component Pads e/o Show Non Component Pads sono disabilitate nel menu.
È inoltre possibile rimuovere tutte le net dal documento di progettazione corrente, svuotando di fatto la netlist interna del PCB. Questa operazione può essere utile se sono state modificate le informazioni sulle net nei documenti schematici di origine e si desidera risincronizzare completamente il PCB con le informazioni della netlist dello schema di origine. Per farlo, scegliere Design » Netlist » Clear All Nets comando dai menu principali. Dopo aver avviato il comando, si aprirà una finestra di dialogo di conferma che avvisa che questa operazione eliminerà tutte le informazioni sulle net dal PCB. Dopo aver fatto clic su Yes, tutte le informazioni sulle net verranno rimosse. Le piste già sbrogliate rimarranno tali, ma avranno un'assegnazione No Net. Tutte le connessioni logiche non sbrogliate verranno rimosse.
Per creare un file netlist basato sulla connettività realizzata mediante lo sbroglio nel progetto corrente, scegli il comando Design » Netlist » Create Netlist From Connected Copper dai menu principali. Dopo aver fatto clic su Yes nella finestra di dialogo di conferma che si apre, viene creata una netlist (Generated <PCBDocumentName>.Net, aggiunta al pannello Projects come documento libero nella sottocartella Source Documents) nella stessa cartella del documento di progetto PCB, che viene aperta automaticamente come documento attivo. Ogni net nella netlist prende il nome da uno dei pad a cui si collega il rame sbrogliato.

