Progettazione di un PCB rigido-flessibile
A colpo d'occhio
- Comprendi la differenza tra le modalità rigido-flessibili Standard e Advanced e quando è necessario utilizzare ciascuna.
- Scopri i passaggi principali per creare un PCB rigido-flessibile, inclusa la definizione di stack parziali, regioni della scheda e linee di piegatura.
- Scopri come Altium Designer integra gli aspetti elettrici e meccanici della progettazione in un flusso di lavoro rigido-flessibile.
Che cos'è un circuito rigido-flessibile?
Come suggerisce il nome, un circuito stampato flessibile è un insieme di piste conduttive stampate su una pellicola isolante flessibile. Rigido-flessibile è il nome dato a un circuito stampato che combina uno o più circuiti flessibili e uno o più circuiti rigidi, come mostrato nell'immagine.
La tecnologia dei circuiti flessibili è stata sviluppata inizialmente per il programma spaziale, con l'obiettivo di ridurre ingombro e peso. Oggi è ampiamente diffusa perché non solo consente di risparmiare spazio e peso, risultando ideale per dispositivi portatili come telefoni cellulari e tablet, ma può anche ridurre la complessità dell'integrazione meccanica, migliorare l'affidabilità del prodotto e ridurre i costi.
I circuiti flessibili vengono normalmente suddivisi in due classi di utilizzo: circuiti flessibili static e circuiti flessibili dynamic. I circuiti flessibili statici (detti anche use A) sono quelli sottoposti a flessioni minime durante l'assemblaggio e l'utilizzo. I circuiti flessibili dinamici (detti anche use B) sono invece progettati per flessioni frequenti, come nel caso della testina di un'unità disco, della testina di una stampante o di un circuito integrato nella cerniera dello schermo di un portatile. Questa distinzione è importante perché influisce sia sulla scelta dei materiali sia sulla metodologia costruttiva. Esistono diverse configurazioni di stackup realizzabili come circuiti rigido-flessibili, ciascuna con i propri vantaggi elettrici, fisici ed economici.
Progettazione meccanica dei circuiti rigido-flessibili
La progettazione di un circuito flessibile o rigido-flessibile è un processo prettamente elettromeccanico. La progettazione di qualsiasi PCB è un processo tridimensionale, ma per un progetto flessibile o rigido-flessibile i requisiti tridimensionali sono molto più importanti. Perché? Perché la scheda rigido-flessibile può essere fissata a più superfici all'interno dell'involucro del prodotto e le operazioni di fissaggio e piegatura avvengono spesso durante l'assemblaggio del prodotto. Per realizzare un progetto elettromeccanico funzionante è necessaria una collaborazione stretta e costante tra i team di ingegneria meccanica ed elettronica. L'approccio tradizionale per verificare che la scheda ripiegata entri nel suo involucro consiste nel creare un modello meccanico, noto come sagoma di carta ritagliata. Per sua stessa natura, con questo approccio è difficile ottenere la precisione e il realismo necessari.
Una scheda con due regioni rigide collegate da una regione flessibile nell'editor PCB ECAD e in MCAD.
Altium contribuisce a risolvere questa sfida con CoDesigner, una sofisticata tecnologia di interfaccia tra progettazione meccanica ed elettronica. CoDesigner consente agli ingegneri di scambiare in entrambe le direzioni la forma della scheda e le modifiche ai componenti tra gli ambienti di progettazione ECAD e MCAD, direttamente dai rispettivi software.
-
Panoramica della tecnologia MCAD CoDesigner di Altium
-
Documentazione tecnica: scopri di più sulla coprogettazione ECAD-MCAD
-
Scopri di più sul trasferimento di un progetto rigido-flessibile in MCAD
Progettazione di un PCB rigido-flessibile
Un circuito stampato viene progettato come una serie di strati sovrapposti. Per un circuito stampato rigido tradizionale, la forma della scheda definisce la scheda nel piano X-Y, mentre lo stack degli strati la definisce lungo l'asse Z. La forma della scheda nel piano X-Y viene definita nella finestra principale di modifica del PCB, mentre gli strati vengono configurati nel Layer Stack Manager. In un PCB rigido-flessibile, il circuito stampato finito presenta più zone o regioni, ognuna delle quali può utilizzare un insieme diverso di strati.
Per progettare una scheda rigido-flessibile, è necessario:
-
Abilitare la modalità Rigid-Flex richiesta (Layer Stack Manager, comando Tools » Features » Rigid-Flex oppure Tools » Features » Rigid-Flex (Advanced))
-
Definire il sotto-stack necessario per ogni regione della scheda e configurare l'allineamento reciproco dei sotto-stack lungo l'asse Z.
-
Definire la forma di ogni regione rigida e flessibile nel piano X-Y e assegnare il sotto-stack corretto a ciascuna regione.
Abilitazione della progettazione rigido-flessibile
Per supportare le strutture complesse presenti in un moderno circuito stampato rigido-flessibile, l'editor lungo l'asse Z, ovvero il Layer Stack Manager, offre diverse modalità di visualizzazione per modificare la struttura della scheda. Seleziona il comando Design » Layer Stack Manager per aprire il Layer Stack Manager, dove puoi abilitare la modalità rigido-flessibile richiesta e creare e allineare i sotto-stack necessari per il progetto rigido-flessibile.
All'apertura, il Layer Stack Manager mostra lo stackup attuale degli strati della scheda. Per un nuovo PCB, si tratterà di una semplice scheda a due strati. Per abilitare le funzionalità necessarie alla progettazione di una scheda rigido-flessibile, apri il sottomenu Tools » Features oppure fai clic sul pulsante Features (
) per selezionare la modalità standard Rigid-Flex (detta anche RF1) oppure la modalità Rigid-Flex (Advanced) (detta anche RF2).
Seleziona il comando per abilitare la modalità rigido-flessibile richiesta.
Scelta della modalità rigido-flessibile standard o avanzata
Nel software di progettazione PCB di Altium sono disponibili due modalità di progettazione rigido-flessibile. La modalità originale, o standard, denominata Rigid-Flex (o rigid-flex 1), supporta progetti rigido-flessibili che includono una o più definizioni di stackup rigidi e flessibili. Per utilizzare la modalità rigido-flessibile standard, deve essere possibile definire l'intera scheda come un'unica forma piana vista dall'alto, senza regioni sovrapposte. Questo è l'approccio utilizzato nella modalità rigid-flex 1: si definisce un'unica forma complessiva della scheda, quindi si posizionano linee di divisione per suddividerla nelle varie regioni rigide e flessibili. A questo punto, a ciascuna regione può essere assegnato uno stack di strati.
Scopri di più sulla progettazione di una scheda rigido-flessibile in modalità standard.
Se il progetto presenta requisiti rigido-flessibili più complessi, come regioni flessibili sovrapposte, è necessario utilizzare la modalità rigido-flessibile avanzata (nota anche come rigid-flex 2.0). Oltre alle regioni flessibili sovrapposte, la modalità avanzata offre anche: definizione visiva del piano Z dei sotto-stack, definizione indipendente di ciascuna regione rigida e flessibile della scheda, piegature su ritagli annidati, suddivisioni con forme personalizzate, possibilità di definire strutture di tipo bookbinder, possibilità di includere un coverlay su una regione flessibile e supporto per progetti interamente flessibili.
Scopri di più sulla progettazione di una scheda rigido-flessibile in modalità avanzata.
Passaggio dalla modalità standard alla modalità avanzata
Il passaggio dalla modalità standard alla modalità avanzata si effettua in Layer Stack Manager, come mostrato nell'immagine sopra. Quando si sceglie l'opzione Rigid-Flex (Advanced) nel menu Tools » Features, il software converte automaticamente l'unica sagoma della scheda in più oggetti regione della scheda e assegna gli stack di layer secondo necessità. Il video seguente illustra il processo.
Panoramica del passaggio dalla modalità rigido-flessibile standard alla modalità avanzata.
Lavorare con le regioni della scheda
Una regione della scheda è un'area definita dall'utente a cui deve essere assegnato uno stack di layer specifico: un requisito comune per un PCB rigido-flessibile. Nell'immagine seguente, la sagoma della scheda è stata suddivisa in tre regioni distinte: la regione circolare superiore, la sottile striscia centrale e la regione circolare inferiore.

Una scheda rigido-flessibile visualizzata in modalità di pianificazione della scheda. Si noti che la sagoma della scheda è stata suddivisa in tre regioni distinte, ciascuna delle quali mostra il proprio nome e lo stack di layer assegnato.
Quando si crea una nuova scheda, questa presenta per impostazione predefinita una sola regione. Se il progetto della scheda richiede più regioni, è possibile:
- suddividere un'unica regione della scheda in più regioni (modalità rigido-flessibile standard o avanzata), oppure
- posizionare più regioni della scheda per comporre la sagoma complessiva (modalità rigido-flessibile avanzata).
Le regioni della scheda vengono definite e modificate in modalità di pianificazione della scheda (menu View).
Lavorare con le linee di piegatura
Le linee di piegatura vengono definite e modificate in modalità di pianificazione della scheda (menu View).
Le proprietà di una linea di piegatura
Le linee di piegatura presentano le seguenti proprietà correlate:
- Bend Angle (a) - l'angolo di piegatura della superficie della regione flessibile.
-
Radius (
r) - la distanza tra la superficie di piegatura e il centro di curvatura. -
Width (
w) - la larghezza della superficie che verrà piegata per i valori specificati di Radius e Bend Angle.
La relazione tra Bend Angle, Radius e width può essere espressa come:
-
w = a/360 * 2*Pi*r -
oppure, a parole,
width = Fraction of the circumference being bent * Circumference
Esplorazione delle regioni dello stack di layer e delle linee di piegatura
Nella modalità Layer Stack Regions del pannello PCB, le tre sezioni principali del pannello cambiano per mostrare quanto segue (dall'alto verso il basso):
- I nomi degli Layer Stacks disponibili.
- Le Stackup Regions definite sulla scheda o quelle assegnate a uno stack di layer selezionato.
- L'elenco delle Bending Lines nella regione dello stack selezionata.
Quando si utilizza la modalità Layer Stack Regions del pannello PCB, passare alla vista della modalità di pianificazione della scheda tramite il menu View » Board Planning Mode oppure utilizzare la scorciatoia 1.

Una scheda può essere suddivisa in regioni distinte (regioni dello stack) a cui vengono assegnate specifiche configurazioni dello stack di layer. Le aree di piegatura (linee di piegatura) vengono definite nelle regioni flessibili della scheda.
Quando si seleziona il nome di uno stack di layer nell'area Layer Stacks del pannello PCB, viene applicato un filtro che utilizza lo stack di layer come ambito. Tutte le regioni della scheda assegnate a quello stack vengono quindi elencate nell'area Stackup Regions del pannello. A loro volta, tutte le linee di piegatura definite in una regione dello stack selezionata vengono elencate nell'area Bending Lines.
Facendo doppio clic su una regione dello stack nell'elenco (o sulla regione della scheda stessa nell'area di progettazione), si apre la finestra di dialogo Board Region (modalità rigido-flessibile standard) oppure la modalità Board Region del pannello Properties (modalità rigido-flessibile avanzata). Utilizzare questa finestra di dialogo o questo pannello per rinominare una regione, assegnarla a uno stack di layer o bloccarne le proprietà 3D.
Facendo doppio clic su una linea di piegatura nell'elenco dell'area Bending Line del pannello, si apre la finestra di dialogo Bending Line, in cui è possibile modificare in dettaglio le proprietà della linea.
Visualizzazione e piegatura di un progetto rigido-flessibile in 3D
L'editor PCB include un potente motore di rendering 3D che consente di visualizzare una rappresentazione tridimensionale altamente realistica della scheda caricata. Questo motore supporta anche i circuiti rigido-flessibili e, utilizzato insieme al cursore Fold State nel pannello PCB , consente al progettista di esaminare il progetto rigido-flessibile nello stato piano (senza applicare le impostazioni delle linee di piegatura), nello stato completamente piegato (con tutte le impostazioni delle linee di piegatura applicate) e in qualsiasi stato intermedio.
Per passare alla modalità di visualizzazione 3D, premere il tasto di scelta rapida 3 (premere 2 per tornare al 2D o 1 per tornare alla modalità di pianificazione della scheda). La scheda verrà visualizzata in 3D. Se i footprint dei componenti includono oggetti corpo 3D che definiscono il componente montato, verranno visualizzati anche questi. Nell'immagine seguente è possibile vedere che la scheda include una batteria e una clip per batteria.
Per applicare tutte le linee di piegatura, spostare il cursore Fold State nel pannello PCB impostato sulla modalità Layer Stack Regions, come evidenziato nell'immagine seguente. Le piegature vengono applicate nell'ordine definito dal rispettivo numero di sequenza. Le linee di piegatura possono condividere lo stesso numero di sequenza; ciò significa semplicemente che tali piegature verranno eseguite contemporaneamente quando si utilizza il cursore Fold State. La scheda può anche essere piegata o distesa eseguendo il comando View » 3D View Control » Fold/Unfold (oppure premendo la scorciatoia da tastiera 5).

Utilizzare il cursore Fold State (o la scorciatoia da tastiera 5) per applicare tutte le linee di piegatura nell'ordine definito dal rispettivo valore di sequenza (indice di piegatura).
Supporto di 3D Movie Maker per i progetti rigido-flessibili
La piegatura di un progetto rigido-flessibile può anche essere acquisita in un filmato 3D. L'operazione è molto semplice e non richiede l'utilizzo di fotogrammi chiave durante la sequenza di piegatura.
Consultare la pagina Preparazione di un video 3D del PCB per una descrizione dettagliata di come creare un filmato 3D. Di seguito sono riportati i passaggi principali:
- Passare alla modalità 3D nell'editor PCB.
- Aprire il pannello PCB 3D Movie Editor e creare un nuovo video facendo clic sul pulsante New . Fare clic sul video appena creato nella sezione Movie Title, quindi assegnargli un nome appropriato.
- Creare un Key Frame iniziale che mostri la scheda completamente distesa.
- Spostare il cursore Fold State per mostrare il progetto rigido-flessibile nello stato piegato, quindi posizionare la scheda piegata come desiderato.
- Creare ora un secondo Key Frame per questa vista e impostare il tempo. Valutare quanto deve durare la piegatura del progetto rigido-flessibile (impostazione Duration); in genere sono sufficienti pochi secondi.
-
Per verificare che il video riproduca correttamente il processo di piegatura, fare clic sul pulsante di riproduzione (situato nei controlli del lettore nella parte inferiore del pannello).
- Per generare un file video, aggiungere un output di documentazione PCB 3D Video in un file Output Job. Ricordarsi di configurare le opzioni del formato video nella finestra di dialogo delle impostazioni video.
- Fare clic sul collegamento Generate Content nel file Output Job per creare il file video.
Il video seguente è stato creato con questa procedura. Contiene i due fotogrammi chiave descritti sopra, più un ulteriore fotogramma chiave aggiunto alla fine per mantenere la posizione finale per un secondo.
Un semplice filmato 3D creato a partire da tre fotogrammi chiave; il comportamento di piegatura è definito dai valori di sequenza delle linee di piegatura.
► Ulteriori informazioni sulla preparazione di un video 3D del PCB
Considerazioni di progettazione
Di seguito è riportato un riepilogo degli aspetti principali da considerare durante la progettazione di un PCB rigido-flessibile:
- Instradamento dei conduttori - la scelta della forma degli angoli per le piste che attraversano una regione flessibile è importante; evitare gli spigoli vivi e utilizzare curve per ridurre al minimo le sollecitazioni.
- Forma e area delle piazzole - per i circuiti flessibili a singola faccia, utilizzare raccordi a goccia (teardrop) con «orecchie di coniglio» (speroni di ancoraggio). L'obiettivo è fare in modo che una parte della piazzola sia trattenuta dallo strato di copertura.
- Fori passanti - cercare di evitare i fori passanti nella zona di piegatura, soprattutto nelle applicazioni dinamiche.
- Strato di copertura - evitare punti di concentrazione delle sollecitazioni (lasciando esposta la pista in ingresso); ridurre l'apertura nello strato di copertura a 250 µm.
- Piani - utilizzare una struttura reticolare, se possibile.
- Lunghezze sfalsate - per evitare l'instabilità degli strati durante la flessione (effetto rilegatura), sfalsare le lunghezze degli strati di circa 1,5 volte lo spessore dello strato.
- Ansa di servizio - rendere la regione flessibile leggermente più lunga per facilitare il montaggio e lo smontaggio e compensare le variazioni dimensionali del prodotto (la lunghezza aggiuntiva è detta ansa di servizio).
- Ottimizzazione del rame - valutare come verrà pannellizzato il circuito flessibile; potrebbe essere preferibile modificare il progetto per garantire il miglior utilizzo del materiale.
- Pannellizzazione - orientare le regioni flessibili in base alla direzione della grana del materiale (piegare lungo la grana).
- Resistenza allo strappo - arrotondare gli angoli; praticare un foro in corrispondenza dell'angolo; prevedere un foro all'estremità dell'intaglio; lasciare del metallo negli angoli.
- Instradamento - sfalsare le piste sulle schede a due strati per evitare l'effetto trave a I e allargare le piste nella zona di piegatura (questo è particolarmente importante per le piegature permanenti).
- Rapporto di piegatura statica - definisce il rapporto tra il raggio di piegatura e lo spessore del circuito. Idealmente, i circuiti multistrato dovrebbero avere un rapporto di piegatura di almeno 15:1. Per i circuiti a doppia faccia, il rapporto minimo dovrebbe essere di almeno 10:1. Per i circuiti a singolo strato, il rapporto minimo dovrebbe essere di almeno 5:1. Per un'applicazione dinamica, puntare a un rapporto di piegatura di 20–40:1.
- Il rame laminato e ricotto è più duttile; il rame elettrodepositato non è la scelta migliore per le regioni flessibili.
Requisiti di documentazione e disegno
I requisiti di documentazione generalmente consigliati includono:
- Il PCB flessibile deve essere fabbricato in conformità alla norma IPC-6013, classe (inserire qui il requisito).
- Il PCB flessibile deve essere realizzato in modo da soddisfare almeno la classe di infiammabilità V-0 (se richiesto).
- Il PCB flessibile deve essere conforme alla direttiva RoHS (se richiesto).
- Il materiale rigido deve essere GFN conforme a IPC-4101/24 (se si utilizza materiale epossidico).
- Il materiale rigido deve essere GIN conforme a IPC-4101/40 (se si utilizza materiale poliimmidico).
- Il materiale flessibile rivestito in rame deve essere conforme a IPC 4204/11 (materiale dielettrico flessibile rivestito in rame senza adesivo).
- Il materiale del rivestimento protettivo deve essere conforme a IPC 4203/1.
- Lo spessore massimo della scheda non deve superare (inserire qui il requisito) e si riferisce alla scheda dopo tutti i processi di laminazione e metallizzazione. La misura viene effettuata sulle superfici metallizzate finite.
- Lo spessore dell'adesivo acrilico nella porzione rigida del pannello non deve superare il 10% dello spessore complessivo della struttura. Vedere le osservazioni precedenti al riguardo.
- Per facilitare la fabbricazione è possibile utilizzare materiale di protezione a busta, che deve essere rimosso dalla porzione flessibile della scheda prima della spedizione.
- Lo spessore della sezione flessibile deve essere (inserire qui il requisito). Non aggiungere questa nota se tale spessore non è critico.
- Lo spessore minimo della parete in rame dei fori passanti metallizzati deve essere pari a (inserire qui il requisito; si consiglia uno spessore medio di 0,001”) con una corona anulare minima di (inserire qui il requisito; si consiglia 0,002”).
- Applicare una maschera di saldatura LPI verde (se richiesta) sul rame nudo su entrambi i lati solo nelle sezioni rigide della scheda. Tutte le superfici metalliche esposte dovranno avere (specificare qui la finitura superficiale richiesta).
- Applicare la serigrafia su entrambi i lati della scheda (se richiesta) utilizzando inchiostro epossidico non conduttivo bianco o giallo (i colori più comuni).
- Requisiti di marcatura e identificazione.
- Requisiti di collaudo elettrico.
- Requisiti di imballaggio e spedizione.
- Requisiti di impedenza.
Ulteriori dettagli del disegno
- Una tabella di foratura che specifichi il diametro finito dei fori, le relative tolleranze e se i fori sono metallizzati o non metallizzati.
- Un disegno quotato che includa i riferimenti geometrici, le dimensioni critiche, le interfacce tra sezioni rigide e flessibili, la posizione delle pieghe e gli indicatori della direzione di piegatura.
- Dettagli di pannellizzazione, se richiesti.
- Dettagli costruttivi e della stratificazione, con indicazione del materiale utilizzato per ogni strato, degli spessori e delle grammature del rame.
Riferimenti
Guida tecnica di ingegneria per circuiti flessibili e rigido-flessibili - Epec Engineering Technologies
Tecnologia dei circuiti flessibili - Joe Fjelstad
Guida alla progettazione dei circuiti flessibili - Minco Products Inc
Risorse sui circuiti flessibili di Minco Products
- Fondamenti di progettazione dei circuiti flessibili - Robert Repas
- Mantenere la flessibilità - Mark Finstad, ingegnere applicativo