プロジェクト・オプションへのアクセス、定義、管理
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Project OptionsダイアログのGeneral、Error Reporting、Optionsタブ
概要
既存のプロジェクトや新規作成したプロジェクトには、そのプロジェクト固有の各種オプション設定が関連付けられています。これらはプロジェクトファイル(例:*.PrjPcb)に保存され、プロジェクトの種類によって異なります。オプション設定はProject Optionsダイアログで行います。
アクセス方法
Project Optionsダイアログには、次のいずれかの方法でアクセスできます。
- Projectsパネルでプロジェクトの項目を右クリックし、コンテキストメニューから Project Options をクリックします。
-
Projectsパネルで目的のプロジェクトにフォーカスがある状態で、
アイコンをクリックします。
- 任意のエディターで、メインメニューからProject » Project Optionsを選択します。
ダイアログのタブ
一般

Project Options ダイアログのGeneralタブ
Project Options ダイアログのGeneralタブでは、Workspaceプロジェクトのオンライン利用と同期を制御できます。
オプション/コントロール
プロジェクトのWorkspaceから切断されている状態でアクセスした場合、使用できるのはTurn Off Synchronizationボタンのみです。
Workspace以外のプロジェクトでアクセスした場合、Project OptionsダイアログのGeneralタブにはMake Project Available Onlineボタンのみが表示されます。このボタンをクリックすると、Make Available Onlineダイアログが開き、必要な手順を完了するとプロジェクトがWorkspaceに追加されます。完了後、このダイアログタブ内のすべてのオプションが使用可能になります。
一般
- Description - このフィールドには、プロジェクトの説明を任意で入力できます。この説明は、Workspaceのブラウザーインターフェースでプロジェクトを参照する際に説明フィールドに表示されます。
オンライン利用と同期
-
Version Control - このチェックボックスは、現在のオンライン利用方式を示します。このオプションを有効にすると、WorkspaceのVersioned Storage Git設計リポジトリ内で、このプロジェクトがVCS管理下に保存されます。無効にすると、単純な同期が使用されます。正式なバージョン管理を有効にすると、複数のユーザーがプロジェクトで作業できるようになり、Workspaceに接続している他のすべての共同作業者とプロジェクトが共有されます。
-
Migrate to Altium 365 Versioned Storage - このオプションを有効にすると、外部VCSシステムを使用するプロジェクトをAltium 365 WorkspaceのネイティブVCSに移行できます。変換された設計プロジェクトでは、過去のVCSコミット履歴が保持され、イベントベースの履歴タイムラインなど、WorkspaceのネイティブVCS対応機能を利用できます。このオプションは、ミラープロジェクトでのみ使用できます。
-
Server Folder - プロジェクトが保存されているWorkspaceフォルダーです。
-
Enable Conflict Prevention Notifications - このオプションを有効にすると、チームメンバーがWorkspaceプロジェクトの同じドキュメントを編集中の場合に通知を受け取り、ファイルの編集アクセスを管理して、データの競合を回避できます。
-
Turn Off Synchronization - このボタンをクリックすると同期が無効になり、ローカルのプロジェクトコピーとWorkspace上のプロジェクトとのリンクが解除されます。Workspace上のプロジェクトは変更されません。
要件
-
Link Requirements – Requirements Portalのブロックが設計プロジェクトにリンクされていない場合、このボタンをクリックするとLink Requirements ダイアログが開き、プロジェクトにリンクするブロックを選択できます。
-
Linked Requirements – Requirements Portalのブロックが設計プロジェクトにリンクされている場合、この項目にはリンクされたブロック(
)が表示されます。リンクをクリックすると、現在のプロジェクトとブロックの対応付けを変更できます。Unlinkボタンをクリックするとリンクが解除されます。
詳細については、設計における要件ページを参照してください。
エラーレポート

Project OptionsダイアログのError Reportingタブ(PCBプロジェクトの場合)
Project OptionsダイアログのError Reportingタブでは、プロジェクトの検証時に、ソース回路図ドキュメントに存在し得る電気的違反や作図上の違反それぞれに対して、レポートレベルを定義できます。プロジェクトを検証すると、これらの違反設定とConnection Matrixタブの設定を組み合わせて、ソースドキュメントの接続違反がチェックされます。
オプション/コントロール
違反リスト
このリストには、プロジェクトのソースドキュメントに存在し得るすべての電気的違反と作図上の違反が表示されます。違反は、次のカテゴリーに分類されています。
PCB Design:
Multi-board Design:
Harness Design:
各違反の種類には、次のフィールドが表示されます。
- Violation Type Description - 違反の種類についての簡単な説明です。
-
Report Mode - このフィールドで、チェックに違反した場合の重大度レベルを指定します。ドロップダウンから、次のレポートレベルを選択します。
-
右クリックメニュー
右クリックメニューでは、次のコマンドを使用できます。
- All Off - すべての違反の種類のReport ModeをNo Reportに設定します。
- All Warning - すべての違反の種類のReport ModeをWarningに設定します。
- All Error - すべての違反の種類のReport ModeをErrorに設定します。
- All Fatal - すべての違反の種類のReport ModeをFatal Errorに設定します。
- Selected Off - 選択したすべての違反の種類のReport ModeをNo Reportに設定します。
- Selected To Warning - 選択したすべての違反の種類のReport ModeをWarningに設定します。
- Selected To Error - 選択したすべての違反タイプのReport ModeをErrorに設定します。
- Selected To Fatal - 選択したすべての違反タイプのReport ModeをFatal Errorに設定します。
- Default - すべての違反タイプのReport Modeをデフォルト設定に戻します。
- Report Suppressed Violations in Messages Panel - このオプションを有効にすると、このタブで抑制された違反もMessagesパネルに表示されます。
追加オプション
- Set To Installation Defaults - クリックすると、このタブのオプションをインストール時のデフォルト設定に戻します。
接続マトリックス

Project OptionsダイアログのConnection Matrixタブ
Project OptionsダイアログのConnection Matrixタブには、コンポーネントのピンと、ポートやシートエントリなどのネット識別子との間の接続ルールを設定するためのマトリックスが用意されています。このマトリックスでは、警告またはエラーとして報告する論理的または電気的な条件を定義します。たとえば、出力ピンが別の出力ピンに接続されている場合は通常エラーと見なされますが、2つのパッシブピンが接続されている場合はエラーにはなりません。プロジェクトの検証時には、これらの違反設定が(エラー報告タブで定義した設定とともに)使用され、ソースドキュメントの違反がチェックされます。
オプション/コントロール
接続マトリックス
このマトリックスには、ピン、ポート、シートエントリの組み合わせに対して可能なすべての配線接続チェックが示されており、未接続の要素もチェックできます。マトリックスは行と列をたどって読み取り、行と列の交点にある要素の色によって、その条件をチェックする際のコンパイラの動作が指定されます。
マトリックス内の違反チェックの報告モードを変更するには、2つの要素の行と列が交差する位置にある色付きの四角形をクリックします。クリックするたびに、モードが次の報告レベルに切り替わります。次のレベルがサポートされています。
- No Report
- Warning
- Error
- Fatal Error
右クリックメニュー
右クリックのコンテキストメニューでは、次のコマンドを使用できます。
- All Off - マトリックス内のすべての項目をNo Reportに設定します。
- All Warning - マトリックス内のすべての項目をWarningに設定します。
- All Error - マトリックス内のすべての項目をErrorに設定します。
- All Fatal - マトリックス内のすべての項目をFatal Errorに設定します。
- Default - すべての項目をデフォルト設定に戻します。
追加オプション
- Set To Installation Defaults - クリックすると、このタブのオプションをインストール時のデフォルト設定に戻します。
クラス生成

Project OptionsダイアログのClass Generationタブ
Project OptionsダイアログのClass Generationタブでは、クラス生成の設定と制御を行えます。クラスとは、特定の種類の設計オブジェクトを論理的にまとめたものです。たとえば、関連するコンポーネントを専用のコンポーネントクラスにまとめ、そのクラスを対象とするルールを作成できます。このタブには、ソース回路図ドキュメントをPCB設計ドキュメントと同期する際に、どのクラスを自動生成し、どのユーザー定義クラスを生成するかを指定するコントロールが用意されています。
オプション/コントロール
自動生成されるクラス
-
Generate Net Classes for Buses - このオプションをオンにすると、設計内のバスごとにネットクラスを自動生成します。クラスのメンバーは、そのクラスの生成元となったバスを構成する個々のネットです。
-
Generate Net Classes for Components - このオプションをオンにすると、設計内のコンポーネントごとにネットクラスを自動生成します。クラスのメンバーは、そのクラスの生成元となったコンポーネントのピンが接続されているネットです。
-
Generate Separate Net Classes for Bus Sections - このオプションをオンにすると、バスセクションごとに個別のネットクラスを自動生成します。バスセクションは、より大きなバスの一部に相当するバスを指定することで作成されます。たとえば、バス
D[15..0]の一部であるD[15..8]などです。 -
Generate Net Classes for Named Signal Harnesses - このオプションを有効にすると、設計内の名前付きシグナルハーネスごとにネットクラスを自動生成します。クラスのメンバーは、そのクラスの生成元となった名前付きシグナルハーネスにまとめられている信号に関連するネットです。
-
Sheet-Level Class Generation Grid - この領域では、回路図シートごとにコンポーネントクラスやネットクラスの自動生成を制御できます。プロジェクトのすべてのソース回路図シートが一覧表示され、各シートについて次の情報が表示されます。
- Sheet Name - 回路図ドキュメントの名前。
- Full Path - ドキュメントが保存されているフォルダーの絶対パス。
-
Component Classes - このオプションをオンにすると、シートのコンポーネントクラスが生成されます。
- Generate Rooms - このオプションをオンにすると、コンポーネントクラスのルームが生成されます。
-
Net Classes Scope - このフィールドで、シートのネットクラスを生成するかどうか、および生成する場合の対象範囲を指定します。ドロップダウンには次の選択肢があります。
- None - このシートのネットクラスを生成しません。
- Local Nets Only - このシートのネットクラスを生成しますが、シート内のローカルネットのみをメンバーとして含めます。
- All Nets - このシートに関連付けられたすべてのネット(ローカルネットと他のシートに接続するネット)をメンバーとして含むネットクラスを生成します。
-
Structure Classes Generate Structure - このオプションをオンにすると、シートの構造クラスが生成されます。
構造クラスは、任意の種類のクラス(ネットクラス、コンポーネントクラスなど)をメンバーとして保持できる特殊なクラスです。設計をPCBに転送する際に、コンポーネントやネットを含むプロジェクト内の各回路図シートから構造クラスを自動生成することで、プロジェクトの構造をPCB側でも忠実に再現できます。構造クラスを使用すると、PCB側で回路図ドキュメントの構造を再現して高度なナビゲーションを行えるだけでなく、デザインルールの適用範囲の指定やフィルタリングなどの論理クエリにも利用できます。
ユーザー定義クラス
- Generate Component Classes - このオプションをオンにすると、設計をPCBに転送する際にユーザー定義のコンポーネントクラスが生成されます。コンポーネントクラスは、回路図上の対象コンポーネントにClassName パラメーターを追加し、その値を目的のクラス名に設定することで手動で定義します。
- Generate Rooms for Component Class - このオプションをオンにすると、ユーザー定義のコンポーネントクラスに基づいてルームが生成されます。これらのコンポーネントには、パラメーター名が「ClassName」のコンポーネントパラメーターが必要です。
- Generate Net Classes - このオプションをオンにすると、設計をPCBに転送する際にユーザー定義のネットクラスが生成されます。ネットクラスは、回路図上でNet Classディレクティブを使用して手動で定義します。ネットをネットクラスのメンバーにするには、該当するワイヤーまたはバス(あるいはブランケット)にNet Classディレクティブを接続し、そのClassNameパラメーターの値を目的のクラス名に設定します。
追加オプション
- Set To Installation Defaults - クリックすると、このタブのオプションがインストール時の既定値に設定されます。
注意事項
-
設計をPCBに転送する際にクラス(自動生成またはユーザー定義)を生成するには、Project Optionsダイアログの比較タブで、対応する比較設定がFind Differencesに設定されていることを、次のように確認する必要があります。
- ネットクラス - 比較タイプExtra Net Classes(Differences Associated with Netsカテゴリー内)をFind Differencesに設定します。
- コンポーネントクラス - 比較タイプExtra Component Classes(Differences Associated with Componentsカテゴリー内)をFind Differencesに設定します。
-
さらに、Project Options ダイアログのECO生成タブで、対応するECO設定がGenerate Change Ordersに設定されていることを確認する必要があります。
- ネットクラス - 変更タイプAdd Net Classes(Modifications Associated with Netsカテゴリー内)をGenerate Change Ordersに設定します。
- コンポーネントクラス - 変更タイプAdd Component Classes(Modifications Associated with Componentsカテゴリー内)をGenerate Change Ordersに設定します。
比較

Project OptionsダイアログのComparatorタブ
Project OptionsダイアログのComparatorタブでは、ドキュメントを比較する際に検出する差異の種類と無視する差異の種類を定義できます。各比較項目について、Mode列のドロップダウンを使用して、差異を検出するか無視するかを選択できます。必要に応じて、コンポーネント、ネット、パラメーター、物理オブジェクトの差異を検出するように設定できます。
オプション/コントロール
このダイアログは、次の2つの主要領域に分かれています。
- 上部のComparison Type Description/Mode領域には、使用可能な各比較タイプの説明と比較モードが表示されます。
- 下部のObject Matching Criteria領域では、Net、Net Class、Component Class、Differential Pair、 Structure Classの照合基準を定義します。
比較タイプの説明/モード
- Comparison Type Description - この領域には、プロジェクト内で使用可能な各比較タイプの説明が表示されます。右端のスクロールバーでDifferences Associated with Components、Differences Associated with Nets、Differences Associated with Parameters、Differences Associated with Physical、 Differences Associated with Structure Classesまでスクロールし、各領域の比較モードを表示または変更します。
-
Mode - エントリをクリックし、ドロップダウンを使用して比較モードを変更します。
-
Find Differences- このオプションを選択すると、その比較タイプの差異が検出されます。 -
Ignore Differences- このオプションを選択すると、その比較タイプの差異はすべて無視されます(その比較タイプについては比較が行われません)。
-
オブジェクトの照合基準
- Object Type - Net、Net Class、Component Class、Differential Pair、Structure Class.
- Min Match %などのオブジェクトタイプの一覧です。必要な最小一致率を入力するか、列の右側をクリックして上下矢印キーで値を増減します。
- Min Matched Members - 必要な最小一致メンバー数を入力するか、列の右側をクリックして上下矢印キーで値を増減します。
- Use Name Matching - エントリをクリックするか、ドロップダウンを使用してAfter member matchingまたはNeverを選択します。
- Show Manual Matching Dialog - 項目をクリックするか、ドロップダウンから For unmatched objects または Never を選択します。
追加オプション
- Ignore Rules Defined in PCB Only - このオプションをオンにすると、設計プロジェクト内でPCBにのみ定義されているルールを無視します。たとえば、設計変更指示(ECO)を実行すると、回路図からPCBに変更を適用できますが、このオプションが有効な場合、PCBにのみ存在するルールは無視されます。 同じプロジェクトの回路図シートに対応するルールがない場合、コンパレーターは新しいルールの追加を試みません。
- Set To Installation Defaults - クリックすると、このタブのオプションをインストール時のデフォルト設定に戻します。
ECOの生成

Project Options ダイアログの ECO Generation タブ
Project Options ダイアログの ECO Generation タブでは、コンパレーターが検出した差分に基づいて設計変更指示(ECO)を生成する際に、含めることができる変更の種類を設定できます。
オプション/コントロール
変更の種類の一覧
この一覧には、ソース回路図ドキュメントとPCB設計ドキュメントを同期する際に、設計変更指示を通じて実行できるすべての変更が表示されます。一覧の項目には、Components、Nets、Parameters、Structure Classes などに関連する変更の種類のカテゴリが含まれます。
個々の変更の種類には、次のフィールドがあります。
- Modification Type Description – 変更の種類(シンクロナイザーが実行するアクション)の簡単な説明です。
-
Mode – このフィールドを使用して、生成されるECOにその変更の種類を含めるかどうかを制御します。ドロップダウンから次のいずれかを選択します。
- Generate Change Orders - 生成されるECOにその変更の種類を含めます。
- Ignore Differences - 生成されるECOからその変更の種類を除外します。
右クリックメニュー
右クリックのコンテキストメニューから、次のコマンドを使用できます。
- Report – このコマンドを使用すると、現在設定されている変更モードのレポートを生成できます。レポートが読み込まれた状態で Report Preview ダイアログが表示されます。このダイアログの各種ページ表示/ズームコントロールを使用してレポートを確認し、ファイルにエクスポートするか、印刷できます。
追加オプション
- Push Component Designator Changes to Annotation File (if any) – オンにすると、部品デジグネーターの変更をアノテーションファイルに含めます。
- Set To Installation Defaults – クリックすると、このタブのオプションをインストール時のデフォルト設定に戻します。
オプション

Project Options ダイアログの Options タブ
Project Options ダイアログの Options タブでは、プロジェクトの生成出力の出力先パスと関連オプションを指定できます。また、各種ネットリストオプションとネット識別子のスコープも指定できます。
オプション/コントロール
-
Output Path – 現在の設計プロジェクト(
*.PrjPcb)から出力ファイルを生成する際のデフォルトの出力先パスです。 - ECO Log Path – ECOログファイルのデフォルトの出力先パスです。
-
Schematic Template Location – このフィールドを使用して、プロジェクトの回路図テンプレートファイル(
*.SchDot、*.SchDoc)の取得元ディレクトリを指定します。
出力オプション
- Open outputs after compile – 有効にすると、設計プロジェクトのコンパイル後に生成されたファイルを開きます。統合ライブラリのパッケージプロジェクトの場合は、このオプションを有効にすると、パッケージプロジェクトのコンパイル後に統合ライブラリをインストールします。
-
Timestamp folder – 有効にすると、BOMレポート(Reports » Bill of Materials)などの生成出力用に、タイムスタンプ付きのフォルダーを作成します。フォルダー名の形式は
<FolderName> Date Timeです。<FolderName>は Output Path フィールドで指定し、DateとTimeはシステム設定と同じ形式になります。 - Archive project document – 有効にすると、プロジェクトドキュメントをアーカイブします。たとえば、PCB設計から製造用出力(File » Fabrication Outputs および File » Assembly Outputs)を生成すると、出力先フォルダーに関連するPCBドキュメントのコピーが含まれます。
- Use separate folder for each output type – 有効にすると、設計プロジェクトで生成される出力の種類ごとに個別のフォルダーを作成します。このフォルダー構造は Projects パネルにも表示されます。
ネットリストオプション
- Allow Ports to Name Nets – 有効にすると、システムが生成するデフォルトのネット名ではなく、配線されたポートのNameプロパティを使用してネットに名前を付けます。
- Allow Sheet Entries to Name Nets – 有効にすると、システムが生成するデフォルトのネット名ではなく、シートエントリ名を使用してネットに名前を付けます。
- Allow Single Pin Nets – 有効にすると、ピンを1つしか含まないネットの存在を許可します。
-
Append Sheet Numbers to Local Net – 有効にすると、そのシート内のローカルネットに、回路図ドキュメントのSheet Numberパラメーター(ドキュメントレベルのパラメーター)の値を付加します。ローカルネットとは、シートの外に出ないネットです。シートの外に出るネット(つまり、ローカルではないネット)には、このオプションは適用されません。
- Higher Level Names Take Priority – 有効にすると、階層の上位シートで使用されているネットラベルを、下位シートのネット名に使用します。
-
Power Port Names Take Priority – このソフトウェアでは、パワーポートを通常のポートに配線することで、グローバル電源ネットをローカル化できます。これにより、そのシートでそのパワーポートに接続されているすべてのピンが、独立したネットに属するようになります。このオプションを有効にすると、パワーポートに割り当てられたネットの名前を使用して、ネット名が強制的に設定されます。
ネット識別子のスコープ
複数シート設計は、電気的な(接続の)レベルではネット識別子によって定義されます。ネット識別子(ネットラベル、ポート、シートエントリ、電源ポート、非表示ピン)は、同じネット内の各点間に論理的な接続を作成します。この接続は、同一シート内にも複数のシート間にも作成できます。物理的な接続は、あるオブジェクトがワイヤを介して別の電気オブジェクトに直接接続されている場合に存在します。論理的な接続は、同じ種類の2つのネット識別子(例えば、2つのネットラベル)が同じNet プロパティを持つ場合に作成されます。
設計の接続モデルを作成する際には、ネット識別子を互いにどのように接続するかを定義する必要があります。これをNet Identifier Scopeの設定と呼びます。複数シート設計でシートを接続する方法は、基本的に2つあります。1つは、あるシートから別のシートへ、さらに次のシートへと直接つなぐ水平接続です。もう1つは、子シートから、親シート上でその子シートを表すシートシンボルへとつなぐ垂直接続です。水平接続では、ポート同士を接続します(ネットラベル同士の接続も可能です)。垂直接続では、シートエントリとポートを接続します。
ドロップダウンリストから、次のスコープを選択します。
-
Automatic (Based on project contents) – このモードでは、次の基準に基づいて、使用するネット識別子モードが自動的に選択されます。最上位シートにシートエントリがある場合はHierarchicalが使用されます。シートエントリはなく、ポートがある場合はFlatが使用されます。シートエントリもポートもない場合はGlobalが使用されます。
- Flat (Only ports global) – ポートは、設計内のすべてのシートにわたってグローバルに接続されます。このオプションでは、ネットラベルは各シート内でのみ有効であり、シート間では接続されません。同じ名前のポートは、すべてのシートで接続されます。このオプションは、フラットな複数シート設計に使用できます。シートをまたいでネットを追跡することが難しくなるため、大規模な設計には推奨されません。
- Hierarchical (Sheet entry <-> port connections, power ports global) – ポートと、それに対応するシートエントリを垂直方向に接続します。このオプションでは、シートシンボルのエントリと、それに対応する子シートのポートを介してのみ、シート間の接続が行われます。シート上のポートを使用して、ネットやバスを親シート上の対応するシートシンボルのシートエントリへ接続します。対応するシートエントリがないポートは、別のシートに同じ名前のポートが存在しても接続されません。ネットラベルは各シート内でのみ有効であり、シート間では接続されません。ただし、電源ポートはグローバルであり、同じ名前のすべての電源ポートが設計全体で接続されます。このオプションを使用すると、任意の深さや階層を持つ設計を作成でき、印刷した回路図上でも設計全体にわたってネットを追跡できます。
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) – この接続モードはHierarchical モードと同様に動作しますが、電源ポートが各シート内でのみ有効になる点が異なります。つまり、異なるシート上にある同じ名前の電源ポート同士は接続されません。
- Global (Netlabels and ports global) – ポートとネットラベルは、設計内のすべてのシートにわたって接続されます。このオプションでは、同じネットラベルを持つすべてのネットが、すべてのシートで相互に接続されます。また、同じ名前のすべてのポートも、すべてのシートで接続されます。ポートに接続されたネットにネットラベルも付いている場合、そのネット名はネットラベルの名前になります。このオプションもフラットな複数シート設計に使用できますが、回路図上でネット名を目視で見つけることは必ずしも容易ではないため、シート間の接続を追跡するのは困難です。
次の方法によるピンスワップを許可
PCBエディタでは、コンポーネントのパッドおよび対応する銅箔上のネットを入れ替えることで、ピン、差動ペア、パートのスワップを実行します。変更を回路図に反映する際、ピンスワップを処理する方法は2つあります。
-
Adding / Removing Net-Labels – 有効にすると、コンポーネントシンボル上のピンのスワップが許可されます。ネットラベルの入れ替えによって回路図上でスワップを行うには、ネットラベルを介して接続が確立されている必要があります。つまり、ピン同士が直接配線されていない場合にのみ実行できます。
-
Changing Schematic Pins – 有効にすると、コンポーネントのピンに接続されたワイヤ上のネットラベルのスワップが許可されます。ネットがコンポーネントに物理的に直接配線されている場合は、ピンのスワップのみが使用可能なオプションになります。この方法は、単純なコンポーネント(抵抗アレイなど)や、回路図設計の構造上、ほかに選択肢がない場合に使用できます。
一般
- Automatic Sheet Numbering – このオプションを有効にすると、このプロジェクト内の回路図シートに自動的に番号が付けられます。これにより、シート番号を管理し、それぞれの回路図ドキュメント内にパラメータとして保存できます。
-
Automatic Cross References – このオプションを有効にすると、アクティブなプロジェクト内のすべてのソース回路図ドキュメントに、ポート、オフシートコネクタ、シートエントリの相互参照情報が自動的に追加されます。この機能は、非階層設計でネットの接続を追跡する際に役立ちます。
- New Indexing of Sheet Symbols – 有効にすると、繰り返し配置するシートシンボルの最初または最後のインデックスに、0を含む任意の数字または数値を使用できます。負の数は使用できません。最後のインデックスは、常に最初のインデックスより大きい必要があります。
相互参照
-
Sheet Style – プロジェクト内の回路図シート上のポートをクロスリファレンスする際に使用する、次のいずれかのシートスタイルを選択します。
-
None– すべてのポートのクロスリファレンス文字列に、シートスタイルを追加しません。 -
Name– ポートのリンク先シートの名前をクロスリファレンス文字列に追加します。 -
Number– ポートのリンク先シートのシート番号をクロスリファレンス文字列に追加します。
-
-
Location Style – プロジェクト内の回路図シート上のポートをクロスリファレンスする際に使用する、次のいずれかの位置スタイルを選択します。
-
None– すべてのポートのクロスリファレンス文字列に、位置スタイルを追加しません。 -
Zone– シートシンボルなどの親オブジェクトに関連付けられているすべてのポートのクロスリファレンス文字列に、親オブジェクトの位置を示す参照ゾーン番号(シートの外枠にあるゾーン)を追加します。 -
Location X,Y– シートシンボルなどの親オブジェクトに関連付けられているすべてのポートのクロスリファレンス文字列に、ポートの位置を括弧付きで表示します。
-
- Follow Cross References settings in Preferences – このオプションを有効にすると、Sheet StyleおよびLocation Styleオプションの値が、PreferencesダイアログのSchematic – GeneralページにあるPort Cross References領域のオプションから継承されます。
-
Display Cross References for:
-
Ports – ドロップダウンから、ポートのクロスリファレンスの表示モードを選択します。
-
Disabled– ポートにクロスリファレンスを追加しません。 -
Only Related Sheet Entry– 親回路図シート上の、関連付けられたシートエントリへのクロスリファレンスを表示します。 -
Only Related Ports– 関連付けられたポートへのクロスリファレンスを表示します。 -
Sheet Entry & Ports– シートエントリとポートの両方へのクロスリファレンスを表示します。
-
- Off-sheet Connectors – このオプションを有効にすると、オフシートコネクタオブジェクトのクロスリファレンスを表示します。
- Sheet Entries – このオプションを有効にすると、シートエントリオブジェクトのクロスリファレンスを表示します。
-
Ports – ドロップダウンから、ポートのクロスリファレンスの表示モードを選択します。
差動ペア
-
Custom Diff Pair Suffix Grid – デフォルトの差動ペアサフィックス(
_P/_N)と、定義済みのすべてのカスタム差動ペアサフィックスを、次の項目で一覧表示します。- Positive Suffix – 差動ペアの正側ネットのサフィックス。
- Negative Suffix – 差動ペアの負側ネットのサフィックス。
- Add – クリックすると、新しいサフィックスのペアをリストに追加します。
- Remove – クリックすると、選択したサフィックスのペアをリストから削除します。
xNetsの作成
- Sources/Destinations – xNetsでソースまたはデスティネーションコンポーネントとして使用できるコンポーネントのデジグネータのプレフィックスを、カンマ区切りのリストで定義します。
- Discretes – xNetsで直列コンポーネントとして使用できるコンポーネントのデジグネータのプレフィックスを、カンマ区切りのリストで定義します。
マルチチャネル

Project OptionsダイアログのMulti-Channelタブ
Project OptionsダイアログのMulti-Channelタブでは、マルチチャネル設計で使用するルームの命名規則とコンポーネントのデジグネータ形式を定義できます。マルチチャネル設計とは、プロジェクト内で同じサブシートを複数回参照できる機能です。同じサブシートを参照するシートシンボルを複数配置するか、シートシンボルのデジグネータにRepeatキーワードを含めて複数のインスタンスを作成することで実現できます。
Altium Designerは、プロジェクト内で単一のシートを繰り返し参照できる、真のマルチチャネル設計を提供します。必要な変更を1か所に適用してプロジェクトを再コンパイルすると、その変更が各インスタンスに反映されます。Altium Designerは、複数のチャネルをサポートするだけでなく、チャネルを入れ子にすることもできます。
回路図上の単一の論理コンポーネントから、PCB上の複数の物理インスタンスへのマッピングは、このタブで定義するマルチチャネルのデジグネータ規則によって制御されます。
オプション/コントロール
ルームの命名
-
Room Naming Style - このフィールドで、ルームの命名に使用するスタイルを指定します。リストからスタイルを選択すると、下の画像が更新され、設計で使用される命名規則が反映されます。設計をコンパイルすると、各バンクと各下位レベルのチャネルを含め、設計内の各シートに対してルームが作成されます。使用できるスタイルは、フラット型が2種類、階層型(パスを含むもの)が3種類の計5種類です。
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths - このフィールドで、階層型の命名スタイル(パスを含むスタイル)を使用する際に、パス情報の区切りに使用する文字または記号を指定します。デフォルトでは、アンダースコア(_)が使用されます。
- Preview - Room Naming StyleやDesignator Formatを変更すると、この領域の画像が動的に更新され、設計で使用される命名規則が反映されます。画像は、2 × 2の入れ子構造のチャネル設計の例を示しています。大きな網掛けの領域は2つの上位レベルのチャネル(またはバンク)を表し、その内部の色付きの領域は下位レベルのチャネルを表します(それぞれにサンプルコンポーネントが2つ表示されています)。
コンポーネントの命名
-
Designator Format - このフィールドを使用して、設計コンポーネントにデジグネータを割り当てる際の形式を指定します。フィールドのドロップダウンリストから、次の8種類の定義済み形式を選択できます。フラット形式が5種類、階層構造で使用できる形式(チャネル名を含む)が3種類あります。
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
独自のデジグネータ形式の定義
Designator Formatフィールドに直接入力して、独自のコンポーネントデジグネータ形式を定義することもできます。形式文字列を作成する際には、次のキーワードを使用できます。
- $RoomName - Room Naming Style フィールドで選択した形式によって決まる、関連チャネルの名前です。
- $Component- コンポーネントの論理デジグネータです。
- $ComponentPrefix - コンポーネントの論理デジグネータの接頭辞です(例:U1のU)。
- $ComponentIndex - コンポーネントの論理デジグネータのインデックスです(例:U1の1)。
- $ChannelPrefix - 論理シートシンボルのデジグネータです。
- $ChannelIndex - チャネルのインデックスです。
- $ChannelAlpha - チャネルのインデックスを文字で表したものです。
注意事項
- チャネルのアルファベットによるインデックス付けが実際に役立つのは、設計内のチャネル総数が26未満の場合、または階層的なデジグネータ形式を使用している場合のみです。
- マルチチャネル設計では、設計ウィンドウの回路図シート下部に、チャネル(またはバンク)ごとのタブが表示されます。タブ名はシートシンボル名にチャネル番号を付けたものです(例:BANKA)。これらは設計のコンパイル済みビュー(物理ビュー)であり、論理設計は従来どおりEditorタブに表示されます。
デフォルトの印刷

Project OptionsダイアログのDefault Printsタブ
Project OptionsダイアログのDefault Printsタブでは、Altium Designerの各種エディタのデフォルト印刷出力を設定できます。各エディタのメインメニューから以下の印刷コマンドを実行すると、ここで指定したデフォルト設定が使用されます。
- File » Print
- File » Print Preview » Print
Project OptionsダイアログのDefault Printsタブには、回路図エディタおよびPCBエディタのメインメニューからFile » Default Printsコマンドを選択してアクセスすることもできます。
オプション/コントロール
タブのメイン領域には、回路図エディタおよびPCBエディタから生成できる、サポート対象のすべての印刷出力が一覧表示されます。出力タイプは次のカテゴリに分類されます。
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
各項目には、次の情報が表示されます。
- Output Description – この印刷出力タイプで出力される内容。
- Supports – この印刷出力タイプをサポートするエディタ。
-
Default Print – この印刷出力タイプをデフォルトの印刷タイプとして使用するか(有効)、使用しないか(無効)を示します。
追加オプション
-
Configure – このボタンをクリックすると、現在選択されている印刷出力を設定するためのダイアログが開きます。対象となるダイアログは次のとおりです。
- 印刷ダイアログ – 実装図、合成図、PCB印刷、PCBLIB印刷、回路図印刷、合成ドリル図、ドリル図/ガイド、最終アートワーク印刷、電源プレーン印刷、およびソルダーマスク/ペーストマスク印刷を設定します。
- PCB 3D印刷設定ダイアログ – PCB 3D印刷を設定します。
- PCB 3Dビデオダイアログ – PCB 3Dビデオ出力を設定します。
- PDF3Dダイアログ – PDF3DおよびPDF3D MBA出力を設定します。
- テキスト印刷の詳細プロパティダイアログ – レポート印刷およびテキスト印刷を設定します。印刷出力のオプション(ヘッダー、ページ番号/行番号など)を定義します。使用するフォントを指定することもできます。
- Wave Print Properties Formダイアログ – SimView印刷を設定します。
- レイヤースタックレポート設定ダイアログ – 基板スタックレポート出力を設定します。
- レポートマネージャーダイアログ – 部品表およびBOM比較レポートを設定します。
- コメントエクスポート設定ダイアログ – コメントのエクスポートレポートを設定します。
- 差分設定ダイアログ – 差分レポートを設定します。
- 電気ルールチェック設定ダイアログ – 電気ルールチェックの検証レポートを設定します。
- Page Setup – クリックすると、現在選択されている印刷出力のページ設定ダイアログが開きます。このダイアログでは、選択したプリンターでの印刷について、用紙、拡大縮小、色を設定できます。また、関連する設定ダイアログやプリンター設定ダイアログへのアクセス、印刷プレビューの表示、選択したプリンターからの印刷も行えます。
検索パス

Project OptionsダイアログのSearch Pathsタブ
Project OptionsダイアログのSearch Pathsタブでは、プロジェクトのライブラリファイルおよびモデルファイルの検索パスを指定できます。
オプション/コントロール
検索パスの順序付きリスト
このグリッドには、ライブラリファイルおよびモデルファイル(PCBフットプリントライブラリ、シミュレーションモデル、シグナルインテグリティモデルなど)の検索パスが、検索順に表示されます。各パスについて、フィルターおよび再帰検索の設定を指定できます。
- Path - 検索パスの場所。
- Filter - 検索用のフィルターです。デフォルトでは、すべてのファイルが検索対象になります。
- Recursive - オンにすると、検索パスのディレクトリ内にあるすべてのサブディレクトリを検索します。検索パスをダブルクリックすると、そのパスを編集できます。
次の種類のファイルがサポートされています。フットプリントライブラリ(*.PcbLib)、シミュレーションモデルファイル(*.mdl)、シミュレーションサブサーキットファイル(*.ckt)、IBISモデルファイル(*.ibs)。
- Delete - 選択した検索パスを削除します。
- Properties - Edit Search Pathダイアログを開き、選択した検索パスのプロパティを編集します。
- Move Up - 選択した検索パスを1行上に移動します。
- Move Down - 選択した検索パスを1行下に移動します。
すべての検索パスで見つかったファイル
このグリッドには、Ordered List of Search Pathsリストから見つかったライブラリファイルとモデルファイルが表示されます。Refresh Listボタンを使用すると、更新されたリストを表示できます。
パラメーター

Project OptionsダイアログのParametersタブ
Project OptionsダイアログのParametersタブでは、プロジェクトに定義されたパラメーターを管理できます。これらは一般にproject-level parametersと呼ばれます。プロジェクトレベルで定義したパラメーターは、特殊文字列を使用することで、プロジェクト内のすべての回路図シートおよびPCBドキュメントで使用できます。回路図では=<ProjectParameterName>(例:=Project)、PCBでは.<ProjectParameterName>(例:.Project)を使用します。パラメーターは、設計に関する追加情報を提供するために使用できます。たとえば、プロジェクトレベルのパラメーターは、回路図シートやPCBドキュメントに追加する特殊文字列のパラメーターデータのソースとして、全体で共通して使用できます。なお、PCBドキュメントはローカルパラメーターをサポートしていません。
Workspace側のプロジェクトパラメーターは、プロジェクトとともにWorkspaceに保存され、Workspaceのブラウザーインターフェースからのみ編集できます(Altium 356 WorkspaceまたはオンプレミスのEnterprise WorkspaceにおけるEditing a Projectの詳細を参照してください)。これに対して、設計側のプロジェクトパラメーターはプロジェクトファイル(*.PrjPcb)に保存され、Altium Designerで編集できます。Project OptionsダイアログのParameterタブでは、Workspace側のプロジェクトパラメーターは青色のアイコン(
)で表示され、設計側のプロジェクトパラメーターはオレンジ色のアイコン(
)で表示されます。
オプション/コントロール
-
Parameters Grid – メイン領域には、現在プロジェクトに定義されているすべてのパラメーターが、次の項目で一覧表示されます。
- Name – パラメーターの名前。
- Value – パラメーターの値。
-
Add – クリックするとParameter Propertiesダイアログが開き、パラメーターを追加できます。Nameフィールドには用途がわかる名前を、Valueフィールドには値をそれぞれ入力します。どちらのフィールドも最大255文字まで入力できます。
- Remove – クリックすると、選択したパラメーターをパラメーターリストから削除します。Workspace側のプロジェクトパラメーターはWorkspace内でのみ削除または編集できるため、このオプションは使用できません。
- Edit – クリックするとParameter Propertiesダイアログが開き、現在選択されているパラメーターの内容を変更できます。Workspace側のプロジェクトパラメーターはWorkspace内でのみ削除または編集できるため、このオプションは使用できません。
- Refresh – クリックすると、設計側のプロジェクトパラメーターに加えた直前の変更を元に戻します。Workspace側のプロジェクトパラメーターの場合は、クリックするとパラメーターが最新の状態に更新されます。Workspace内でWorkspace側のプロジェクトパラメーターに加えた変更は、このオプションを使用するまで、このダイアログには反映されません。
右クリックメニュー
右クリックメニューでは、次のコマンドを使用できます。
-
Edit – Parameter Propertiesダイアログで、現在選択されているパラメーターを変更します。Workspace側のプロジェクトパラメーターはWorkspace内でのみ削除または編集できるため、このコマンドは使用できません。
-
Add – Parameter Propertiesダイアログで、新しい設計側パラメーターをリストに追加します。
-
Remove – 選択したパラメーターをリストから削除します。 Workspace側のプロジェクトパラメーターはWorkspace内でのみ削除または編集できるため、このコマンドは使用できません。
-
Copy – 選択したパラメーターをWindowsのクリップボードにコピーします。
-
Paste – Windowsのクリップボードにあるパラメーターをパラメーターリストに貼り付けます。 Workspace側のプロジェクトパラメーターはWorkspace内でのみ削除または編集できるため、このコマンドは使用できません。
デバイスシート

Project OptionsダイアログのDevice Sheetsタブ
Project OptionsダイアログのDevice Sheetsタブでは、デバイスシートが保存されているフォルダーとその順序を指定できます。
オプション/コントロール
- Main region - 現在のプロジェクトの Device Sheet Folders パスを一覧表示します。 Include Sub-folders にチェックを入れると、リストに表示されている親フォルダーのサブフォルダーも含まれます。
- Move Up - 選択したデバイスシートフォルダーを 1つずつ上に移動します。
- Move Down - 選択したデバイスシートフォルダーを 1つずつ下に移動します。
- Add - 追加する新しいフォルダーを検索するための ダイアログを開きます。
- Remove - 選択したデバイスシートフォルダーを削除します。
管理対象のOutputJob

Project Options ダイアログのManaged OutputJobsタブ
Project Options ダイアログのManaged OutputJobsタブでは、接続先のWorkspaceから利用できる、プロジェクトで使用する出力ジョブテンプレートのリストを設定できます。
オプション/コントロール
- Outputjob List - Workspace内のすべての出力ジョブを、Item Revision、Revision State、Description、Nameの項目で一覧表示します。
- Add - クリックするとSelect configuration item (Output Jobs)ダイアログが開き、目的の出力ジョブを選択できます。
- Remove - クリックすると、選択した出力ジョブを削除します。
ライブラリオプション

Project OptionsダイアログのLibrary Optionsタブ
Project OptionsダイアログのLibrary Optionsタブでは、統合ライブラリプロジェクトの形式を選択できます。
オプション/コントロール
-
Integrated Library Format
- Original - 元の統合ライブラリ形式を使用する場合に選択します。これは、Altium Designerの登場以前のProtel DXP(DXP 2002)ソフトウェアとの互換性を確保するために使用します。
-
Altium Designer- 統合ライブラリ形式としてAltium Designer形式を使用する場合に選択します(最初のAltium Designer 2004以降、すべてのバージョンで使用されている形式です)。

