PCB上の部屋を操作する
概略
- PCB上のルームとは何か、また、定義した基板領域内でオブジェクトの配置や設計要件を制御するために、ルームをどのように使用するかを学べます。
- 対話的な配置、選択した部品からの作成、設計制約を通じた作成など、PCBエディターでルームを作成する主な方法を確認できます。
- Altium DesignerでルームオブジェクトとRoom Definition制約がどのように連携するかを、PCB Rules and Constraints EditorおよびConstraint Managerでの扱いも含めて理解できます。
概要
ルームは、PCBの表面レイヤーのいずれかに定義された領域です。ルームは、基板上のその領域内に適用する設計要件を定義するために使用します。例:these components must be in this area、route these nets this width、use routing vias of this size。
ルームは、他のポリゴンオブジェクトと同様に、矩形または多角形として配置します。
各ルームは、基板上で名前を持つX-Y形状として存在するだけでなく、同じ名前のRoom Definition設計制約(
)にも自動的になります。Room Definition制約の設定では、ルームの適用対象となるobjects、それらのオブジェクトをルームのinside or outsideに保持するかどうか、およびルームを適用するlayerを定義します。
ルームは、Room Definition制約で直接指定する単純な keep these objects in (or out)要件に加え、他の設計制約を適用する基板領域の定義にも使用できます。 たとえば、BGAの下の配線には特定の幅が必要な場合(
)や、BGAの下の差動ペア配線には特定のインピーダンスプロファイルの適用が必要な場合(
)があります。
使用可能な環境
ルームの配置と作成は、PCBエディターでのみ行えます。ルームを作成するには、次の方法を使用します。
-
Design » Rooms サブメニューから必要なコマンドを選択し、ルームの形状を対話的に定義する(Placeコマンドを選択した場合)か、ルームを自動的に作成します(Createコマンドを選択した場合)。
-
新しいRoom Definition設計制約を追加し、そのルーム制約を編集してから、Defineボタンをクリックして多角形ルームの形状を対話的に定義します。
-
Tools » Convert » Create Room from Selected Primitivesコマンドを使用して、トラックと円弧で構成された、選択済みの閉じた輪郭に基づいてルームを作成します。
-
回路図とPCBの設計同期中に、ルームを自動的に作成します。自動生成されるルームの詳細(無効にする方法を含む)をご覧ください。
ルームの作成
PCBドキュメント上でルームを作成する手順は、ルームを対話的に配置するか、その他の方法で作成するか、また、どの配置・作成方法を選択したかによって異なります。
ルームの対話的な配置
矩形または多角形のルームは、設計のトップレイヤーまたはボトムレイヤーに配置できます。どのレイヤーがアクティブな状態でも配置できますが、適用先のレイヤーはRoom Definition設計制約の一部として割り当てられることに注意してください。
矩形ルーム
Design » Rooms » Place Rectangular Roomコマンドを実行すると、カーソルが十字に変わり、ルーム配置モードになります。次の手順で配置します。
-
クリックするか、Enterを押して、ルームの最初のコーナーを確定します。
-
関連するRoom Definition制約のプロパティを配置中に編集するには、Tab キーを押します。
-
カーソルを移動してルームのサイズを調整し、クリックするか、Enterを押して対角のコーナーを確定し、ルームの配置を完了します。
-
続けて別のルームを配置するか、右クリックするか、Escを押して配置モードを終了します。
多角形ルーム
Design » Rooms » Place Polygonal Roomコマンドを実行すると、カーソルが十字に変わり、ルーム配置モードになります。次の手順で配置します。
-
カーソルを目的の位置に移動してクリックし、ルームの始点を確定します。
-
カーソルを移動してクリックする操作を繰り返し、ルームの多角形形状を定義する一連の頂点を確定します。
-
最後の頂点を配置したら、右クリックするか、Escを押してルームの配置を完了します。始点と最後に配置した点はソフトウェアによって自動的に接続され、形状が完成するため、ポリゴンを閉じる操作は不要です。
-
続けて別の多角形ルームを配置するか、右クリックするか、Escを押して配置モードを終了します。
選択したコンポーネントに基づく作成
コンポーネントがすでに基板上に配置されており、その配置に合わせて新しいルームを作成したい場合は、3つあるCreate xxx Room from selected componentsコマンドのいずれかを使用します。 これらのコマンドを使用すると、設計スペースで現在選択されているコンポーネントに基づいて、非直交、直交、または矩形のルームを自動的に作成できます。いずれの場合も、作成手順は同じです。
-
ルームの作成対象となるコンポーネントをすべて選択します。回路図からPCBコンポーネントを選択するには、Tools » Cross Select Modeコマンドを実行してから、回路図上でコンポーネントを選択します。
-
PCBエディターで、該当する作成コマンド(Design » Rooms » Create xxx Room from selected components)を実行します。 選択したコンポーネントを含むコンポーネントクラスが自動的に作成されます(すでに存在する場合を除く)。
-
選択したタイプのルームが作成され、そのルームのRoom Definitionデザインルールが、作成されたコンポーネントクラスに自動的に関連付けられます。
-
ルームのサイズは、コンポーネントの選択矩形に基づき、選択したすべてのコンポーネントが収まるように調整されます。
-
ルームをクリックしてドラッグすると、関連付けられたコンポーネントクラス内のすべてのコンポーネントも一緒に移動します。
Room Definitionデザイン制約の追加による作成
PCB Rule and Constraints Editor またはConstraint Managerで新しい制約を定義することでも、新しいルームを作成できます。
デザイン制約の定義にはどちらの方法を使用していますか?
Altium Designerでは、デザイン制約を定義する方法として、Constraint Manager とPCB Rule and Constraints Editorの2つをサポートしています。
PCB Rule and Constraints Editor は、PCBエディターで制約を定義するために最初に開発されたインターフェースです。 PCB Rule and Constraints Editor を使用する場合、設計者はwhat objects the constraint (rule) applies toおよびhow those objects are to be constrainedを定義します。この方法の強みは、制約の対象とするオブジェクトを正確に指定できることです。すべてのオブジェクト(たとえばすべてのネット)を対象にすることも、基板上の特定のオブジェクト(特定のパッドなど)だけを対象にすることもできます。このように設計オブジェクトを柔軟に指定する仕組みは、クエリ言語によって動作するルールエンジンで実現されています。
Constraint Managerでは、オブジェクトを中心に制約を定義します。設計者はオブジェクトの観点から、スプレッドシート形式のインターフェースで、設計に必要な各種の電気的および物理的制約を適用します。Constraint Managerでオブジェクトを選択すると、グラフィカルエディター内の該当オブジェクトがハイライト表示されます。これにより、オブジェクトに対するすべての要件を簡単に設定して確認できます。たとえば、あるネットクラスについて、配線幅、クリアランス、使用する配線ビア、ポリゴン接続スタイルを指定できます。また、そのネットクラスの配線に使用するレイヤーやインピーダンスを指定することもできます。このようなオブジェクト中心の表示は、PCB Rule and Constraints Editorでは利用できません。 最終的に、ソフトウェアはオブジェクト中心の制約を、PCB Rule and Constraints Editorで定義されるものと同じ形式のルールに変換します。PCBエディターから制約を開いた場合は、All Rulesビューに切り替えると、それらを確認できます。
このドキュメントページでは、PCB Rule and Constraints Editor ダイアログとConstraint Managerの両方で定義された制約の画像を掲載しています。なお、constraintとruleという用語は同じ意味で使用しています。
新しいRoom Definitionデザイン制約の追加
PCB Rules and Constraints Editorの場合
ルームを配置または作成するたびに、関連するRoom Definitionデザイン制約が自動的に作成されます。逆も同様で、このタイプのルールを新しく追加すると、対応するルームオブジェクトがデザインスペースに表示されます。削除についても同様で、グラフィカルエディターでルームを削除すると制約も自動的に削除され、デザイン制約を削除するとグラフィカルオブジェクトも削除されます。
PCB Rules and Constraint Editorからルーム制約を定義する場合、絶対原点(編集スペースの左下)から1インチの位置に、デフォルトの5インチ×5インチのルームオブジェクトが作成されます。なお、原点マーカーが示すのはユーザー定義の相対原点であり、編集スペース内の任意の位置に設定できます。
新しいルーム制約を追加すると、編集スペース内にデフォルトのルームが定義されます。
制約を追加したら、編集スペースに戻ってルームをグラフィカルに編集できます。また、PCB Rules and Constraints Editor でルーム制約を編集し、Defineボタンをクリックして形状を対話的に定義することもできます。 ルームは基板上の領域を定義するものなので、通常はルームを対話的に配置し、デザイン制約を自動的に作成する方法が用いられます。
PCB Rules and Constraints Editorで新しい制約を追加する方法については、こちらをご覧ください。
Constraint Managerの場合
Constraint Manager: で新しい閉じ込め(ルーム)制約を作成するには、All Rulesビューに切り替え、PlacementカテゴリのRoom Definitionを選択します。次に、以下に示すようにAdvanced Rulesリスト内で右クリックし、コンテキストメニューからAdd Advanced Ruleを選択します。
Constraint Managerで新しいルーム制約を追加できます。
この段階では、グラフィカル編集スペース内にルームオブジェクトはまだ存在しません。DefineボタンをクリックしてPCBエディターに切り替え、ルームの形状を定義する必要があります。この操作が完了すると、ルーム制約とルームオブジェクトの両方が存在する状態になり、制約を保存できるようになります。
-
ルーム制約を使用して、オブジェクトを基板上のその領域内(または領域外)に制限する場合は、次にConstraint Managerの下部でObject Matchおよびその他の制約設定を構成します。詳細は、以降の説明をご覧ください。
-
ルーム制約を配線幅など別の種類の制約で領域定義として使用する場合は、ルーム内の制約の定義セクションを参照してください。
Constraints Managerで新しい制約を追加する方法については、こちらをご覧ください。
ルーム制約とは?
前述のとおり、ルームとはPCBのいずれかの表面レイヤー上に定義された領域であり、基板上のその領域内における設計要件を定義するために使用します。
すべてのデザイン制約には、次の2つの主要な要素があります。
-
what objects this constraint applies to(
)、および
-
how those objects are to be constrained(
)。
コンポーネントが存在しない基板上の領域にルーム制約を定義した場合、Object Matchの条件(the objects this constraint applies to)はデフォルトでFalseとなり、この制約はどのオブジェクトにも適用されません。必要に応じて編集してください。
新しく作成されたルーム定義。ルールの適用範囲がFalseになっており、どのオブジェクトにも適用されないことに注意してください。
コンポーネントクラスの制約
ルーム制約の一般的な用途は、コンポーネントクラスの配置場所を定義し、そのクラスに属するコンポーネントを基板の特定の領域内に制限することです。
Encoderクラスのコンポーネントは、基板のTop Layer上にあるRoom-Encoderというルーム内に制限されています。
上の画像は、Encoderクラスのコンポーネントが、PCB Rules and Constraints Editorの基板のTop side上にあるRoom-Encoderルームのwithinに制限されている様子を示しています(基本的にはConstraint Manager
と同じです)。 コンポーネントをルームに割り当てると、ルームの移動に伴ってコンポーネントも移動します。コンポーネントを移動せずにルームだけを移動するには、関連するRoom Definitionルールを一時的に無効にします。
詳細については、Room Definition設計制約をご覧ください。
PCBエディターには、ルームを操作するための強力なツールが多数用意されています。詳細については、このページのルームの操作セクションをご覧ください。
ルームは、それ自体が設計制約(Room Definition)であるだけでなく、Width、Clearance、Via Styleなど、ほかの設計制約の適用範囲を基板の特定領域に限定するためのオブジェクトとしても使用できます。この内容については、このページのルーム内の制約の定義セクションで説明しています。
回路図とPCB設計の同期時に作成
設計を回路図からPCBに転送する際、各回路図シート上のコンポーネントを含むルームを作成できます。多階層の設計ではあまり有用でない場合もありますが、大規模なフラット設計では、シートごとにルームがあると、基板上にコンポーネントを配置する際に役立ちます。
Project Options ダイアログのClass Generationタブには、設計内の各シートに対してルームを生成するオプションがあります(
)。Generate Roomsオプションをオンにすると、Design » Updateコマンドの実行時にそのシートのルームが作成され、シート内のすべてのコンポーネントからなるクラスがそのルームに割り当てられます。各シートのコンポーネントはコンポーネントクラスに追加されるため、Generate Roomsオプションを使用するには、対応するComponent Classオプションも有効にする必要があります。
PCBでは、各ルーム制約は適用範囲をInComponentClass('<SheetSymbolDesignator>')として作成されます。シートにコンポーネントが含まれていない場合、ルームは作成されません。回路図を初めてPCBに転送すると、各コンポーネントクラス内のコンポーネントが一列に並べられ、次に、下の画像のように、そのコンポーネントクラスを囲むルームが作成されます。
自動生成されるルームが不要な場合は、Project OptionsダイアログのGenerate Roomsチェックボックスをオフにしてください。
初回の設計同期後のPCB。各シートに対してルームが作成され、そのシートのコンポーネントクラスが割り当てられています。
詳細については、回路図プロジェクトからのルーム、コンポーネントクラス、ネットクラスの自動生成をご覧ください。
設計の同期の詳細については、回路図とPCBの同期の維持ページをご覧ください。
選択したトラックと円弧から作成
ルームオブジェクトは、選択したトラックや円弧オブジェクトで構成される閉じた境界を使用して定義できます。これを行うには、設計スペースで閉じた境界を構成するすべてのトラックおよび円弧プリミティブを選択し、メインメニューからTools » Convert » Create Room from Selected Primitivesコマンドを選択します。以下のスライドショーは、その手順を示しています。
|
Encoderコンポーネントに使用できる基板領域を定義するため、メカニカルレイヤー上にトラックを配置しています。 Tools » Convert » Create Room from Selected Primitivesコマンドを実行して、同じ形状のRoom Definitionを作成します。 Edit Room Definitionダイアログが表示され、制約のパラメーターを定義できます。このルームには ルームの形状を調整するには、クリックして選択し、Design » Rooms » Edit Polygonal Verticiesコマンドを実行して、 頂点または辺をクリックし、ルームの形状を変更します。 |
ルームの編集
ルームのX-Y平面上の形状と基板上の位置は、対話的に変更できます。ルームを対話的に編集する方法には、選択時の矩形に基づく方法(サイズと位置の変更セクションで説明)と、形状編集用の頂点に基づく方法(形状の変更セクションで説明)の2種類があります。
Design » Roomsサブメニューからコマンドにアクセスできるほか、配置済みのルームを右クリックし、Room Actionsサブメニューを選択することで、そのルームに応じたコマンドにアクセスすることもできます。
ルームを右クリックすると、ルーム専用のコマンドにアクセスできます。
サイズと位置の変更
ルームを1回クリックして選択すると、最初に矩形またはポリゴンのどちらとして配置したかにかかわらず、次の編集ハンドルが表示されます。
ルームをクリックして選択すると、編集ハンドルが表示されます。
ルームのサイズ変更
-
コーナーハンドル(A)をドラッグすると、ルームの縦横のサイズを同時に変更できます。
-
エッジハンドル(B)をドラッグすると、その方向(水平方向または垂直方向)にオブジェクトのサイズを変更できます。
-
ドラッグ中に次のキーを押すと、ルームを回転または反転できます。
-
Spacebarを押すとオブジェクトが反時計回りに回転し、Shift+Spacebar を押すと時計回りに回転します。回転角度は、PreferencesダイアログのPCB Editor - Generalページ で定義されているRotation Stepの値に従います。
-
XまたはYキーを押すと、オブジェクトがX軸またはY軸に沿って反転します。
-
Lキーを押すと、オブジェクトが基板の反対側に反転します。ルームに関連付けられたコンポーネントがある場合、それらのコンポーネントもルームとともに反転します。
-
ルームの移動
ルームをクリックしてドラッグすると、新しい位置に移動できます。 ルームオブジェクトは、メインメニューのDesign » Rooms » Move Roomコマンド、またはルームのコンテキストメニューのRoom Actions » Move Roomコマンドを使用して移動することもできます。 コマンドを実行すると、カーソルが十字に変わり、ルーム移動モードになります。移動するルームをクリックしてください。
移動するルームをクリックすると、次のようになります。
-
ルームがカーソルに追従します。ルームを保持する位置は、現在のObject Snap Options(
)によって決まり、カーソルは有効なスナップポイント(コンポーネントのパッド、コンポーネントの基準点、またはルームの頂点)のうち最も近いものにスナップします。
-
ルームを目的の位置に移動し、クリックするかEnter を押して配置を確定します。
-
続けて他のルームを移動するか、右クリックするかEscを押して終了します。
-
移動するルーム内にコンポーネントがある場合、移動中にShiftまたはCtrlキーを押すと、緑色の動的な位置合わせガイドを表示できます。有効なグリッドへのスナップを維持するにはShiftを使用し、グリッドを一時的に無効にしてグリッド外の既存オブジェクトに位置を合わせるにはCtrlを使用します。
-
ルームにネットのないオブジェクトやロックされたオブジェクトが含まれている場合、Room containing No Net/Locked Objectsダイアログが開きます。このダイアログで、これらのオブジェクトをルームとともに移動するかどうかを指定し、OKをクリックします。 このダイアログを表示するには、Preferencesダイアログ(
)のPCB Editor - GeneralページでAsk when moving rooms containing No Net/Locked Objectsオプションを有効にする必要があります。

Room containing No Net / Locked Objectsダイアログ
ネットなし/ロックされたオブジェクトを含むルームのダイアログ |
|
| No Net Objects | ネットのないオブジェクトをルームとともに移動するには、有効にします。 |
| Locked Objects | ロックされたオブジェクトをルームとともに移動するには、有効にします。 |
| Don't ask me about moving room's locked/no net objects until next PCB session (use currently selected settings) | このオプションを有効にすると、選択した設定が保存され、現在のPCBセッション中は引き続きその設定が使用されます。新しいセッションが開始されるまで、ダイアログは再表示されません。 |
形状の変更
ルームの境界形状は、Edit Polygonal Room Verticesコマンドを実行して変更します。このコマンドには、Design » Roomsサブメニュー、または右クリックのRoom Actionsコンテキストサブメニューからアクセスできます。
コマンドを実行すると、ルームのポリゴン形状の境界編集ハンドルが表示され、次の操作を行えます。
-
Aハンドルをクリックし、カーソルを動かしてその頂点を移動します。新しい位置でもう一度クリックして、頂点の位置を確定します。
-
Aハンドルの移動中にキーボードのDeleteキーを押すと、その頂点をルームから削除できます。
-
Bをクリックするか、エッジ上(ハンドルの間)をクリックしてからカーソルを動かすと、そのエッジをスライドできます。エッジの移動中にShift+Spacebar を押すと、使用可能なエッジ動作モード(エッジのスライド、エッジの分割、エッジの湾曲)を切り替えられます。
-
Ctrl+Click B またはエッジ上でCtrl+Click を行い、カーソルを動かすと、そのエッジに頂点を追加して移動できます。新しい位置でもう一度クリックして、頂点の位置を確定します。これにより、新しい頂点がA頂点となり、その頂点と元のA頂点の間に新しいB頂点が追加されます。
-
グリッド外のハンドルを操作するには、Ctrlキーを押し続けて、グリッドスナップを一時的に無効にします。
-
必要に応じてルームの形状の変更を続けるか、右クリックするかEscを押して終了します。ルームの表示は、新しい境界形状に合わせて更新されます。
このコマンドは、対象のルームがロックされているかどうかにかかわらず使用できます。
ルームの分割
配置済みのルームオブジェクトを、グラフィカルに2つ以上の独立したルームにsliceするコマンドが用意されています。分割操作は線の配置と似ており、同じコーナーモードを使用できます(実際、分割用オブジェクトの幅は、現在のデフォルトの線幅になります)。分割経路を表示するために使用されるオブジェクトは、配置されるオブジェクトではありません。分割経路を示すためだけに表示され、分割操作の完了後に削除されます。また、ルームのエッジ上で正確に分割を開始する必要はありません。ルームの少し外側から開始し、終点もルームの少し外側にすると操作しやすくなります。
使用できるスライスコマンドは2つあります。スライスパスを定義する手順はどちらも同じですが、スライスするルーム内のコンポーネントの扱いが異なります。各コマンドの違いについては、スライス手順の後で説明します。
|
ルームを右クリックすると、Room ActionsメニューのSliceコマンドにアクセスできます。 以下の手順で2つのスライスを定義しました。 3つのルームが作成されました。 |
スライスの手順
Sliceコマンドを実行した後:
-
カーソルが十字に変わり、スライスの始点を選択するよう求められます。
-
スライスするルームのすぐ外側にカーソルを置き、クリックするかEnterを押します。これでスライスモード(基本的にはライン配置モード)になります。
-
カーソルをルーム内に移動して最初のスライスエッジを定義し、クリックするかEnterを押して、そのエッジの終点を固定します。
-
引き続きカーソルを移動してクリックし、スライスの形状を定義する一連の頂点を指定します。
-
最後の頂点をルームのすぐ外側に配置したら、右クリックするかEsc を押して、そのスライスの配置を完了します。
-
続けてルームに別のスライスを開始するか、右クリックするかEsc を押してスライスモードを終了できます。
-
確認ダイアログが開き、元のルームがいくつのルームに分割されるかが表示されます。Yesをクリックすると作成したスライスが確定され、No をクリックすると破棄されます。結果として生成される新しいルームオブジェクトがそれに応じて更新され、関連するRoom Definitionルールが作成されて関連付けられます。
-
スライス中は、次のキー操作を使用できます:
-
Shift+Spacebarを押すと、コーナーモードが順に切り替わります。
-
Spacebarを押すと、コーナーの方向が切り替わります。
-
各スライスエッジには始点と終点が必要です。
-
スライス配置モードにコーナーが含まれる場合は、 1 ショートカットを押すと、1回のクリックで1つのエッジを配置するか、2つのエッジを配置するかを切り替えられます。
-
Backspaceを押すと、最後に配置したスライスエッジが削除されます。
-
既存のルームの再ラップ
既存のルームの形状を変更するもう1つの方法は、そのルームに割り当てられたコンポーネントクラスを囲むようにルームを再ラップすることです。スライドショーに示すように、右クリックのRoom Actionsサブメニューと Design » Roomsサブメニューには、どちらも3つのWrap Roomコマンドが含まれています。
|
ルーム内のコンポーネント配置を変更した場合は、3つの Wrap コマンドのいずれかを使用してルームの形状を更新します。 Wrap Non-Orthogonalコマンドは、コンポーネント境界の最外端を結ぶようにルームのエッジを配置します。 Wrap Orthogonalコマンドは、コンポーネント境界の周囲に垂直および水平のルームエッジを配置します。 Wrap Rectangularコマンドは、コンポーネント境界を囲む最小の長方形ルームを配置します。 |
Propertiesパネルでの編集
ルームオブジェクトは、オブジェクトであると同時に設計制約でもあるという、独特な性質を持っています。
Propertiesパネルでの編集
編集領域内での位置や形状など、ルームオブジェクトのプロパティは、ルームを選択した状態でPropertiesパネルから編集できます。このパネルは、設計領域の右下にあるPanelsのPanelsボタン、または View » Panels » Propertiesコマンドから表示できます。
Properties パネルでは、ルームのグラフィカルなプロパティを編集できます。
| Name | ルーム(および関連するRoom Definitionルール)の現在の名前です。必要に応じて変更できます。名前は各ルームを識別するだけでなく、設計ルールで特定のルームを対象に指定するためにも使用できます。 |
| (X/Y)(2つのフィールド) | 現在の原点を基準とした、ルームの最初の頂点の現在のX位置とY位置です。 フィールドの値を編集すると、現在の原点に対するルームの位置を変更できます。 値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位を含めてください。 デフォルトの単位(メートル法またはヤード・ポンド法)はステータスバーに表示され、PropertiesパネルのOther領域で設定できます(デザインスペースでオブジェクトが選択されていない場合)。これらの値は、X/Yオプションのロックが解除されている場合( |
外形の頂点 |
|
| Vertices Grid | ルームに現在定義されているすべての頂点が、ルームの配置時に定義された順序で一覧表示されます。 各頂点は、次の頂点と直線の辺で接続されます。円弧で接続する場合は、必要なArc Angleの値を入力してください。値は接続元の頂点に対応するフィールドに入力します。円弧は、この頂点からリスト内の次の頂点まで描かれます。 右クリックして、Copy / PasteまたはImport / Export to CSVを実行します。 |
| Index | 頂点に割り当てられたインデックスです(編集不可。ルーム定義時の配置順序に基づきます)。 |
| X | 頂点のX(水平)座標です。クリックして編集します。 |
| Y | 頂点のY(垂直)座標です。クリックして編集します。 |
| Arc Angle (Neg = CW) | この頂点と次の頂点を接続する円弧の角度です。デフォルトでは直線の辺で接続され、このフィールドは空欄になります。クリックして編集し、必要な円弧の角度を入力してください。正の値を入力すると、反時計回りの円弧が描かれます。時計回りの円弧を描くには、負の値を入力します。 |
ルームの操作
本ソフトウェアには、ルームとその内部のオブジェクトを操作するためのさまざまな機能が用意されています。ルームを格子状に整列する、現在のスナップグリッドに合わせてルームを移動する、回路の繰り返し部分を含む設計で、あるルームの配置と配線を別のルームにコピーする、といったコマンドがあります。
ルームを使用して、他の設計制約の適用範囲を基板の特定の領域に限定することもできます。たとえば、このルーム内ではネットを特定の幅とクリアランスで配線する、または差動ペアを特定のインピーダンスプロファイルで配線する、といった要件を設定できます。
8チャンネルミキサーの例です。最初の入力チャンネルを配置・配線した後、Copy Room Formatコマンドを使用して、残りの7つの入力チャンネルに複製しています。
ルーム内の制約の定義
オブジェクトをルームの内側または外側に配置するよう制約するだけでなく(ルーム定義の設計制約セクションを参照)、ルームを使用して他の設計制約の適用領域を限定することもできます。たとえば、配線幅制約でBGAの下の配線を異なる幅にするよう指定したり、電気的クリアランス制約で基板の特定領域に異なるクリアランスを指定したりできます。
ルーム内の配線幅とクリアランスは、ルーム定義の設定に従って自動的に調整されます。
これは、以下のスライドショーに示す配線幅制約と電気的クリアランス制約を追加することで実現できます。
Constraint Managerでの設定
Constraint ManagerのAll Rulesビューでルーム制約を追加すると、そのルームオブジェクトはPhysicalビューでも使用できるようになります。このビューを使用すると、ルーム内に適用する領域ベースの制約をすばやく定義できます。これには、配線幅、電気的クリアランス、配線ビアスタイル、差動ペアのプロパティ、配線のネックダウン、ポリゴン接続スタイルが含まれます。以下のスライドショーは、上の動画に登場する基板の制約を示しています。
|
このルーム内では、すべての配線オブジェクトの幅を指定範囲内にする必要があります。 このルーム内では、すべての配線オブジェクトと他のネットに属するオブジェクトとの間に、少なくともこの値以上のクリアランスを確保する必要があります。 このルーム内では、すべての配線オブジェクトに対して、少なくともこの値以上の電気的クリアランスを確保する必要があります。 このルーム内では、すべての差動ペアを |
PCB Rules and Constraint Editorでの設定
PCB Rules and Constraint Editorで同じ結果を得るには、ルームの領域を定義するクエリを作成します。ルーム内のオブジェクトを検出する方法には、ルーム内に完全に収まるオブジェクトを対象にする方法(WithinRoomキーワードを使用)と、ルームに接触しているオブジェクトを対象にする方法(TouchesRoomキーワードを使用)の2つがあります。以下のスライドショーは、前のConstraint Manager スライドショーで示したものと同じ配線幅、電気的クリアランス、配線ビアスタイル、差動ペアのプロパティを示しています。
選択したルームの整列
デザインスペース内で選択したルームを整列するには、 Design » Rooms » Arrange Rooms コマンドを使用します。対象のルームを選択してからコマンドを実行すると、Arrange Roomsダイアログが開きます。
Arrange Roomsダイアログ。
ルームの整列方法と配置順序を指定します。開始位置は、ダイアログにX-Y座標を入力するか、ワークスペース内をクリックして指定できます。また、隣接するルーム間の間隔も指定できます。OKをクリックすると、選択したルームが指定位置に移動します。
列/行 |
|
| Columns | ルームの配置に使用する列数です。必要に応じてこのフィールドを編集します。 |
| Rows | ルームの配置に使用する行数です。必要に応じてこのフィールドを編集します。指定した行数と列数に収まりきらない数のルームがある場合は、上側に行が追加されます。 |
並べ替え基準 |
|
| SortBy | 選択した並べ替え順序、つまりルームの順序を決めるために使用する基準が表示されます。使用可能なオプションの詳細は以下のとおりです。 |
| Channel Name | チャンネル名に基づいて、ルームを英数字順に並べ替えます。マルチチャンネル設計の詳細をご覧ください。 |
| Room Area | ルームを面積に基づいて並べ替えます。 |
| Room Component Count | 含まれるコンポーネントの数に基づいてルームを並べ替えます。 |
| Room Width | ルームをX方向(水平方向)のサイズで並べ替えます。 |
| Room Height | ルームをY方向(垂直方向)のサイズで並べ替えます。 |
| Sort in Ascending order | 有効にすると、現在の SortBy の基準に従って、ルームを昇順(小さい順)に並べ替えます。このオプションを無効にすると、降順(大きい順)に並べ替えます。 |
位置 |
|
| Origin X | ルームの配置を開始するX方向(水平方向)の位置を定義します。このフィールドを編集してX座標を変更します。単位にはmmまたはmilを使用できます。数値を入力する際に単位を指定するには、値の後ろに mm または mil を付けます。 デフォルトの単位(メートル法またはヤード・ポンド法)は、プロパティパネルの Units 設定によって決まり、単位を指定しなかった場合に使用されます。 |
| Origin Y | ルームの配置を開始するY方向(垂直方向)の位置を定義します。このフィールドを編集してY座標を変更します。単位にはmmまたはmilを使用できます。数値を入力する際に単位を指定するには、値の後ろに mm または mil を付けます。 デフォルトの単位(メートル法またはヤード・ポンド法)は、プロパティパネルの Units 設定によって決まり、単位を指定しなかった場合に使用されます。 |
| Select Origin Using Mouse | 有効にすると、ルームを整列配置する際の原点を手動で設定するよう求められます。Origin X と Origin Yを編集するには、 オプションを無効にする必要があります。 |
| X-Spacing | 隣接するルーム間に確保するX方向(水平方向)の間隔を定義します。 |
| Y-Spacing | 隣接するルーム間に確保するY方向(垂直方向)の間隔を定義します。 |
| Auto Spacing | 有効にすると、X方向(水平方向)とY方向(垂直方向)の間隔を等しくしてルームを配置します。X-Spacing と Y-Spacingを編集するには、 オプションを無効にする必要があります。 |
| Place On Grid | 有効にすると、現在のPCBスナップグリッドに合わせてルームが配置されます。 |
ルームのフォーマットをコピー
ルームの特に強力な機能の1つに、あるルームの形状、部品配置、配線を、同一のコンポーネント構成を持つ別のルームにコピーする機能があります。このコマンドは、マルチチャネル設計のレイアウトで特に便利です。1つのチャネルで行った部品配置と配線を、ほかのすべてのチャネルに反映できます。
ルームのフォーマットをほかのルームにコピーするには、次の手順を実行します。
-
メインメニューから Design » Rooms » Copy Room Formats をクリックします。
-
ステータスバーにコピー元のルームを選択するよう表示されます。コピー元のルームにカーソルを合わせてクリックするか、 Enterを押します。
-
ステータスバーにコピー先のルームを選択するよう表示されます。フォーマットをコピーする先のルームにカーソルを合わせてクリックするか、 Enterを押します。複数のルームにフォーマットを適用する場合、この2回目のクリックは対象のいずれのルームでもかまいません。
-
Confirm Channel Format Copy ダイアログが開きます。オプションを使用して、コピーするフォーマットを設定します。 デフォルトでは、選択した Source Room から、選択した Destination Room にフォーマットがコピーされます。コピー元のルームから、検出されたチャネルクラス内の各ルームにコピーするには、Apply to Specified Channels オプションを有効にし、対象のルームに対して必要な Copy チェックボックスがオンになっていることを確認します。
-
ダイアログで OK をクリックして、コピー先のルームを更新します。
-
引き続き追加の コピー先の ルームを選択するか、右クリックして終了します。
ルームの非表示
ドキュメント内のルームは、View ConfigurationパネルのView Options タブにあるオプションを使用して、一括で表示、非表示、またはドラフトモードで表示できます。
ルームのObject Visibilityスライダーを調整すると、編集スペース内でルームの表示を薄くしたり、非表示にしたりできます。


)。有効にしなかった場合は、PCB Rule and Constraints Editor を使用する必要があります。 現在のPCBプロジェクトでどちらのデザイン制約管理方法が使用されているかをすばやく確認するには、プロジェクトのPCBドキュメントを開き、Design メニューをクリックして、使用可能なコマンドを確認します。Constraint Manager が表示される場合、このプロジェクトではConstraint Manager が使用されています。Rules が表示される場合、このプロジェクトではPCB Rule and Constraints Editor ダイアログが使用されています。














)で有効にしたチャネルにフォーマットがコピーされます。コピー元のチャネル(ルーム)のフォーマットをほかのチャネル(ルーム)にコピーするには、コピー元とコピー先のチャネル(ルーム)が同じチャネルクラスに属している必要があります。
