기존 라이브러리를 연결된 Workspace로 가져오기
개요
- Library Importer에 접근하고 Simple 모드와 Advanced 모드 중에서 선택하는 방법을 알아보세요.
- 가져올 수 있는 라이브러리와 컴포넌트 데이터, 주요 제한 사항을 살펴보세요.
- 가져오기 미리보기, 컴포넌트 분류, 파라미터 설정 및 보고 기능을 활용하여 가져오기 작업을 검토하고 개선하는 방법을 알아보세요.
Altium Designer는 연결된 워크스페이스와 함께 기존 라이브러리를 해당 워크스페이스로 빠르게 가져올 수 있는 간소화되고 고도로 자동화된 프로세스를 제공합니다. 이 프로세스의 인터페이스인 Library Importer 는 선택한 라이브러리를 자동으로 분석하고 현재 연결된 워크스페이스로 가져오는 원클릭 솔루션을 제공합니다.
Library Importer는 기존 컴포넌트 관리 방식과 관련된 모든 유형의 라이브러리(SchLib, PcbLib, IntLib, DbLib, SVNDbLib)를 지원하며, 회사의 워크스페이스 컴포넌트 라이브러리를 빠르게 구축하기 위한 전용 솔루션입니다. 이를 통해 높은 무결성, 중앙 집중식 저장 및 관리, 손쉬운 설계 재사용, 실시간 공급망 정보 등 다양한 이점을 누릴 수 있습니다.
Library Importer는 선택한 데이터베이스 및 파일 기반 컴포넌트 라이브러리를 한 단계로 워크스페이스 컴포넌트로 가져오는 간소한 Simple 인터페이스 모드를 제공합니다. 가져오기 도구가 유형 분류, 타겟 소스 폴더, 파라미터 포함 여부 및 값 유형, 모든 관련 데이터의 전송을 자동으로 처리합니다. 인터페이스는 Advanced 모드로도 사용할 수 있으며, 이 모드에서는 예정된 라이브러리 가져오기 작업의 전체 미리보기와 관련 데이터 및 설정에 대한 액세스를 제공합니다. 기본적으로 가져오기는 한 번의 클릭으로 진행되지만, 가져오기 도구는 Properties 패널을 통해 고급 구성 옵션도 제공하므로 가져오기 방식을 더욱 세밀하게 제어할 수 있습니다.
어떤 항목을 가져오나요?
원본 소스 라이브러리에 있는 모든 정보가 워크스페이스 컴포넌트로 가져와집니다. 여기에는 참조된 모든 도메인 모델(Schematic 심볼, PCB 풋프린트, 시뮬레이션 모델), 파라미터 정보, 지정된 부품 선택 항목, 데이터시트 파일 등이 포함됩니다. 필요한 경우 컴포넌트 템플릿도 생성되며, 이후 이를 수정하여 후속 라이브러리 가져오기에 사용할 수 있습니다.
원본 컴포넌트에 여러 PCB 풋프린트가 정의되어 있으면 Library Importer는 해당 모델을 가져오고 현재 기본 풋프린트를 유지합니다. PCB 라이브러리만 사용하는 경우, 즉 PCB 레이아웃만 필요한 경우에는 Library Importer로 해당 라이브러리만 가져올 수 있습니다. 또는 모델 전용 가져오기 모드로 전환하여 통합 라이브러리나 데이터베이스 라이브러리에서 지정된 모델 유형만 가져올 수도 있습니다. 여러 컴포넌트 유형이 포함된 라이브러리(모놀리식 라이브러리)도 자동으로 감지되어 처리됩니다.
라이브러리 가져오기 프로세스는 다양한 형식 표준을 사용할 수 있는 데이터베이스 및 파일 기반 라이브러리 소스를 처리해야 하지만, 자동 분석 프로세스를 통해 소스 라이브러리의 컴포넌트 유형(저항, 커패시터 등)과 파라미터 이름 및 해당 값 유형(볼트, 옴 등)을 감지합니다. 시스템은 여러 검증 작업을 수행하고 처리합니다. 예를 들어, 생성되는 워크스페이스 라이브러리 컴포넌트에 중복 ID가 없는지, 중복 모델이나 컴포넌트 템플릿이 생성되지 않는지, 필요한 경우 이러한 항목이 여러 컴포넌트에서 재사용(연결)되는지 확인합니다. 문제가 발생하면 시스템은 해당 문제를 표시하고 해결 방법을 제안하여 가져오기가 최대한 빠르고 원활하게 정상 진행되도록 돕습니다.
가져올 수 있는 라이브러리 유형은 다음과 같습니다.
-
Schematic 라이브러리(
*.SchLib). -
PCB 풋프린트 라이브러리(
*.PcbLib). -
통합 라이브러리(
*.IntLib) -
데이터베이스 라이브러리(
*.DbLib). -
SVN 데이터베이스 라이브러리(
*.SVNDbLib).
Library Importer 액세스
Library Importer는 워크스페이스에 연결되어 있을 때 사용할 수 있습니다. Simple 모드로 가져오기 도구에 액세스하려면 다음 방법을 사용합니다.
-
컴포넌트 패널의
메뉴에서 Import Library 옵션을 선택합니다. 현재 패널의 Categories 열(또는 패널이 간소 모드일 때 상단 드롭다운 메뉴)에서 데이터베이스 또는 파일 기반 라이브러리가 선택되어 있으면 해당 라이브러리에 대해 Library Importer가 열립니다. 워크스페이스 라이브러리 컴포넌트 유형이 선택되어 있으면 표준 Windows Open 대화 상자가 열려 가져올 라이브러리 파일을 찾아 선택할 수 있습니다.
-
Projects 패널에서 라이브러리 파일을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Import Library을 선택합니다.
-
로컬 라이브러리 파일이 열린 상태에서 Schematic 심볼 또는 PCB 풋프린트 편집기의 Tools » Import Library을 선택합니다.
-
Database Library Editor에서 File » Import Library 또는 Tools » Import Library 을 선택합니다.
-
Libraries Preferences 대화 상자의 Installed 탭에서 라이브러리 항목을 선택한 다음 Import 컨트롤을 클릭합니다.
-
Windows 폴더에서 라이브러리 파일을 Explorer 패널로 끌어다 놓습니다.
Simple 모드에서는 선택한 라이브러리를 즉시 가져오거나 Library Importer를 전체 GUI 모드로 여는 옵션을 제공합니다.

Simple 원클릭 가져오기 모드로 액세스한 Library Importer.
Library Importer에 Advanced 인터페이스 모드로 직접 액세스하려면 기본 메뉴에서 File » Library Importer을 선택합니다.

전체 Advanced 인터페이스 모드로 액세스한 Library Importer도 원클릭 가져오기 프로세스를 지원합니다.
Simple 모드
Library Importer의 Simple 모드는 소스 라이브러리와 연결된 워크스페이스의 분석 결과를 바탕으로 가져오기 프로세스의 모든 항목을 미리 선택합니다. 그런 다음 Library Importer 대화 상자에 각 항목 유형의 총개수를 포함한 가져오기 구조 요약이 표시됩니다. 라이브러리 가져오기는
명령을 통해 한 단계로 수행됩니다.
이 Simple 인터페이스 모드는 일반적인 컴포넌트 유형(저항, 커패시터, 집적 회로 등)과 표준화된 파라미터 값을 포함하는 대부분의 일반적인 소스 라이브러리 형식에 적합합니다. 초기 분석 과정에서 시스템은 Designator 또는 파라미터 키워드(LD?, LED 등)를 바탕으로 라이브러리 내 컴포넌트의 유형을 추론한 다음, 타겟 워크스페이스에서 해당하는 컴포넌트 템플릿(LED)을 찾습니다. 이 템플릿이 해당 컴포넌트의 가져오기에 적용되며, 타겟 폴더(Components/LED), 파라미터 매핑, 파라미터 값 단위 등의 가져오기 설정을 지정합니다. Altium 365 워크스페이스 활성화 또는 Altium On-Prem Enterprise Server 설치 중 샘플 데이터 포함 옵션을 선택했다면 워크스페이스에서 적합한 템플릿을 사용할 수 있습니다.
라이브러리 가져오기 결과로 새로 생성된 워크스페이스 컴포넌트는 Explorer 및 Components 패널에서 확인할 수 있습니다. 가져온 컴포넌트에는 모든 모델, 적용된 컴포넌트 템플릿에 따라 해석된 파라미터, 공급업체 링크 원본 데이터에서 추출한 부품 선택 항목, 참조 링크 또는 파일이 포함됩니다.
라이브러리 가져오기 프로세스와 관련하여 주목할 사항은 다음과 같습니다.
-
모놀리식 라이브러리(여러 유형의 컴포넌트가 포함된 라이브러리)는 자동으로 하위 그룹으로 분할되며, 각 그룹은 해당 라이브러리에서 발견된 컴포넌트 유형을 나타냅니다. 각 그룹은 개별 라이브러리로 처리됩니다.
-
컴포넌트 유형을 인식할 수 없는(감지되지 않은) 원본 라이브러리는 유형 해석 없이 가져오며,
Components/Uncategorized워크스페이스 폴더에 유형이 지정되지 않은 컴포넌트로 저장됩니다. 가져오기를 실행하기 전에 Advanced (전체 UI) 모드에서 Designator 매핑 또는 파라미터 그룹화를 적용하여 이 문제를 해결할 수 있습니다. 또는 가져오기를 진행한 다음 나중에 Explorer 패널을 통해 컴포넌트의 설정과 폴더를 수정할 수 있습니다. - 라이브러리 가져오기 프로세스에는 자동 컴포넌트 유효성 검사 단계가 포함됩니다. 유효성 검사 오류가 발생하는 컴포넌트는 건너뜁니다.
- 가져올 원본 라이브러리에서 중복 모델이 감지되면 해당 모델 중 하나만 가져오며, 대상 워크스페이스에 생성된 컴포넌트에 연결됩니다. Library Importer 대화 상자 상단에 관련 알림이 표시됩니다.
-
프로세스 중 발생한 오류는 가져오기가 완료된 후
버튼으로 열 수 있는 Importing Report에서 확인할 수 있습니다.
고급 모드
Advanced 모드에서는 Library Importer의 전체 GUI가 표시되며, 라이브러리, 컴포넌트 유형 및 컴포넌트 파라미터 관리를 세부적으로 제어할 수 있습니다. Properties 패널과 함께 사용하면 컴포넌트 라이브러리를 워크스페이스로 가져오는 방식을 특정 요구 사항에 맞게 설정할 수 있습니다. 가져오기 도구의 설정은 구성 파일 내보내기/가져오기를 통해 저장하고 복원할 수 있습니다.
File » Library Importer 명령으로 Library Importer를 열거나 간편 모드에서
버튼을 선택하면 고급 모드가 활성화됩니다. 가져오기 도구의 SOURCE LIBRARIES 섹션에 라이브러리가 아직 채워져 있지 않다면, 라이브러리 파일을 해당 영역으로 끌어다 놓거나, <All Libraries>을 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Add Library을 선택하거나,
버튼을 선택하여 라이브러리를 추가할 수 있습니다.
Import Preview 섹션에는 원본 라이브러리에서 식별된 컴포넌트 유형 그룹이 Types 또는 제안된 Folder Structure 형태로 나열되며, 해당 컴포넌트의 파라미터 기반 그리드 보기(Components)가 포함됩니다. 그리드에서 파라미터 값을 즉시 편집할 수 있으므로 원본 라이브러리를 열어 편집할 필요가 없습니다. 하단의 Details 영역에는 현재 선택한 컴포넌트에서 가져온 추가 정보인 부품 선택 항목, 모델 및 데이터시트가 포함됩니다.
인터페이스에 표시되는 세부 옵션과 데이터에 관계없이, 가져오기 도구의 고급 보기는 간편 보기와 동일한 방식으로 사용할 수 있습니다. 별도의 개입 없이
버튼을 클릭하기만 하면 가져오기 프로세스가 실행됩니다. 간편 보기 프로세스와 마찬가지로 가져오기 도구는 라이브러리를 분석하고, 포함된 컴포넌트 유형을 추론하고, 올바른 컴포넌트 템플릿을 적용합니다. 이 템플릿은 워크스페이스의 대상 폴더, 적용할 명명 규칙 및 수명 주기 정의, 파라미터 매핑/해석을 결정합니다.
모놀리식 라이브러리
여러 컴포넌트 유형이 포함된 원본 라이브러리는 가져오기 도구의 분석 루틴에 의해 감지되어 하위 라이브러리 그룹으로 분리되며, 각 그룹은 개별 유형 라이브러리로 처리할 수 있습니다. 컴포넌트 유형은 원본 컴포넌트의 Designator(R?, C? 등)와 다른 주요 컴포넌트 파라미터(설명, ID 등)에 포함된 키워드(Resistor, Res 등)를 기준으로 감지됩니다.
아래 예에서 원본 라이브러리(ProjectABC.IntLib)는 감지된 컴포넌트 유형(커패시터, 저항기 등)에 따라 자동으로 '분할'되었습니다. Folder Structure 열(또는 Types 열)에서 해당 유형을 선택하면 Components 그리드에서 각 유형에 속한 컴포넌트 항목을 미리 볼 수 있습니다.
Components 목록의 표시 방식은 다음과 같이 여러 방법으로 변경할 수 있습니다.
-
열 머리글 항목을 클릭하면 해당 파라미터 열을 기준으로 목록이 정렬되며, 다시 클릭하면 정렬 순서가 반전됩니다.
-
머리글의 마우스 오른쪽 버튼 클릭 컨텍스트 메뉴에서:
-
Clear Sorting을 선택하면 목록 순서가 기본 설정(Name 열 기준 오름차순)으로 돌아갑니다.
-
Best Fit을 선택하면 특정 열의 너비가 내용에 맞게 조정됩니다.
-
Select Best Fit All Columns을 선택하면 사용 가능한 모든 열의 너비가 각 내용의 너비에 맞게 조정됩니다.
-
Select Columns을 선택하면 Select Columns 대화 상자가 열리며, 여기서 파라미터 열을 활성화하거나 비활성화하고 목록 내 위치를 재정렬할 수 있습니다.
-
-
머리글 항목 안의 필터 아이콘을 클릭하면 사용 가능한 파라미터 열 값, 빈 값/비어 있지 않은 값 또는 Custom 필터 설정으로 목록을 제한할 수 있습니다. 적용된 필터는 목록 하단에 표시되며, 관련 확인란을 사용하여 활성화/비활성화하거나, Filter Editor에서 수정하거나, 삭제할 수 있습니다. 머리글 필터 아이콘을 통해 All을 선택해도 적용된 필터가 제거됩니다.
미분류 컴포넌트
라이브러리 하위 그룹 항목 중 하나의 이름이 Uncategorized인 경우(Types 또는 Folder Structure 아래에 Uncategorized로 나열되고
아이콘)는 가져오기 도구가 해당 컴포넌트 그룹의 유형을 감지하여 할당하지 못했음을 나타냅니다. 즉, 컴포넌트 유형이 None로 설정된 상태입니다. 이 경우 감지되지 않은 컴포넌트(인버터 로직 IC)는 인식되지 않는 Designator 접두사(U?)를 사용하며, 해당 파라미터에는 IC, logic 등의 감지 대상 키워드가 포함되어 있지 않습니다.
이 문제는 Library Splitting 대화 상자에서 해당 컴포넌트에 사용된 Designator를 원하는 컴포넌트 유형에 수동으로 매핑하여 해결할 수 있습니다. 이 대화 상자는 소스 라이브러리(ProjectABC.IntLib)를 선택하면 사용할 수 있는
버튼을 통해 열 수 있습니다. 기본값이 설정된 Library Splitting 대화 상자에서는 컴포넌트 유형별 Designator 매핑과 파라미터 기반 분할을 바탕으로 미분류 컴포넌트에 대한 사용자 지정 라이브러리 그룹화 옵션을 설정할 수 있습니다.
대화 상자의 Map Designators 옵션을 선택한 상태에서 Component Type 드롭다운 목록에서 미분류 컴포넌트에 해당하는 컴포넌트 유형 옵션을 선택합니다. 이 목록에는 사용 가능한 모든 컴포넌트 유형이 포함되어 있습니다.
버튼을 눌러 완료된 유형-Designator 매핑(Logic 컴포넌트 유형을 U? Designator에 매핑)을 확정합니다.
적용된 매핑에 따라 컴포넌트 유형이 지정되면 가져오기 도구는 일치하는 컴포넌트 템플릿(Logic)을 사용하여 템플릿 설정(폴더, 이름 지정 등)에 따라 라이브러리 가져오기를 구성합니다.
Library Importer 설정의 유연성 덕분에 새로운 미분류 컴포넌트 라이브러리 유형을 가져올 때 향후 해당 라이브러리 유형을 가져오는 데 필요한 전체 기반 설정도 함께 구축할 수 있습니다. 새로운 컴포넌트 유형, 컴포넌트 템플릿, 타겟 폴더, 파라미터 매핑 및 파라미터 값 단위 유형 등 적절한 가져오기 구성을 선택하면, 다음에 해당 라이브러리 유형을 가져올 때는 이전에 정의한 컴포넌트 유형을 선택하기만 하면 됩니다. 그러면 선택한 컴포넌트 유형에 따라 가져오기의 다른 모든 설정이 결정됩니다.
가져오기에서 제외
특정 컴포넌트 유형을 가져오기에서 제외할 수도 있습니다. 컴포넌트 유형을 제외하려면 Types 목록에서 제외할 컴포넌트 유형을 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Exclude from Importer을 선택합니다. 필요하면 열의 목록 표시를 Folder Structure에서 Types로 변경합니다
제외된 컴포넌트 유형은 Types 목록에서 회색으로 표시됩니다. 제외된 컴포넌트를 그리드에서 보려면 Show Excluded Component (n)을 클릭합니다. 여기서 n는 제외된 컴포넌트 수를 나타냅니다.
가져오기에 포함
위에서 설명한 Exclude from Importer 명령을 사용하여 컴포넌트 유형을 가져오기에서 제외했으나 다시 포함해야 하는 경우, Types(또는 Folder Structure) 목록에서 회색으로 표시된 컴포넌트 유형을 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Include to Importer을 선택합니다. 해당 컴포넌트 유형이 Types 목록에 다시 표시되어 더 이상 제외되지 않음을 나타냅니다.
유효성 검사 오류 및 경고
Library Importer를 실행하거나 가져오기 유효성 검사를 수행하면, 워크스페이스로 올바르게 가져올 수 없거나 전혀 가져올 수 없는 컴포넌트가 고급 UI에 경고 또는 오류 태그로 표시됩니다. 유효성 검사에서는 비어 있는 워크스페이스 폴더 경로, 충돌하는 시스템 파라미터 및 중복 모델도 확인합니다. 치명적인 오류가 있으면 가져오기가 차단됩니다.
가져오기를 시도하면 감지된 위반 사항이 Messages 패널에 표시되고, 현재 가져오기 구성을 사용한 가져오기를 중단할지 계속할지 선택할 수 있는 대화 상자가 나타납니다. 계속하는 경우 유효하지 않은 컴포넌트는 가져오지 않거나 가져오기 프로세스가 실패하게 됩니다.
가져오기를 취소하거나 수동 유효성 검사를 실행하면 가져오기 검사를 통과하지 못한 컴포넌트에 오류/경고 아이콘이 표시되고, 하단 Details 영역에 추가 정보가 제공됩니다. 미리보기의 Status 열에 있는 아이콘은 가져오기 규칙 검사를 위반한 특정 컴포넌트 항목을 나타냅니다.
기본 제공되는 유효성 검사 항목은 다음과 같습니다.
컴포넌트 설명이 너무 김
Report mode:
요약
이 위반은 가져올 컴포넌트의 설명이 256자를 초과할 때 발생합니다.
알림
Messages 패널에 다음 형식으로 알림이 표시됩니다.
<ComponentName> description more then 256 characters.
여기서:
-
ComponentName은(는) 문제가 있는 컴포넌트의 이름입니다.
해결 권장 사항
길이 제한을 초과하지 않도록 소스 라이브러리에서 컴포넌트 설명을 편집합니다.
컴포넌트 템플릿 오류
Report mode:
요약
이 위반은 가져올 컴포넌트에 적용된 컴포넌트 템플릿에 오류가 있을 때 발생합니다.
알림
Messages 패널에 다음 형식으로 알림이 표시됩니다.
Component template has errors: <Descripion>
여기서:
-
Descripion은(는) 컴포넌트 템플릿 오류에 대한 설명입니다.
해결 권장 사항
오류 설명을 바탕으로 소스 라이브러리 또는 라이브러리 가져오기 구성에서 오류를 찾아 수정합니다.
중복된 컴포넌트 HRID
Report mode:
요약
이 위반은 가져올 컴포넌트의 항목 ID가 동일할 때 발생합니다.
알림
Messages 패널에 다음 형식으로 알림이 표시됩니다.
<ComponentName1> component HRID is duplicated with <ComponentName2> component HRID.
여기서:
-
ComponentName1및ComponentName2은(는) 문제가 있는 컴포넌트의 이름입니다.
해결 권장 사항
Properties 패널의 Parameter Mapping 영역에서 ID 파라미터가 문제가 있는 각 컴포넌트에 대해 고유한 값을 갖는 소스 라이브러리 파라미터에 매핑되어 있는지 확인합니다. 이 파라미터의 매핑을 <Auto>로 설정할 수도 있습니다. 이 경우 컴포넌트 항목 ID는 패널의 Component 영역(Advanced 탭 아래)에 지정된 Naming Scheme를 기준으로 자동 설정됩니다.
또는 Item ID에 대해 선택한 파라미터가 소스 라이브러리에서 문제가 있는 각 컴포넌트에 대해 고유한 값을 갖는지 확인하세요.
중복된 모델 형상
Report mode:
요약
이 위반은 가져올 컴포넌트의 심볼 모델이 소스 라이브러리에서 동일한 형상을 갖는 경우 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
<SymbolModelName1> model has the same geometry as <SymbolModelName2> in your source library. Imported components will be linked to <SymbolModelName2>
각 항목의 의미:
-
SymbolModelName1및SymbolModelName2은(는) 문제가 있는 심볼 모델의 이름입니다.
비어 있는 컴포넌트 HRID
Report mode:
요약
이 위반은 가져올 컴포넌트의 Item ID가 비어 있는 경우 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
<ComponentName> component HRID is empty.
각 항목의 의미:
-
ComponentName은(는) 문제가 있는 컴포넌트의 이름입니다.
권장 해결 방법
Properties Panel의 Parameter Mapping Region에서 파라미터 ID이(가) 문제가 있는 컴포넌트에 대한 값을 가진 소스 라이브러리 파라미터에 매핑되어 있는지 확인하세요. 이 파라미터의 매핑을 <Auto>(으)로 설정할 수도 있습니다. 이 경우 컴포넌트 Item ID는 Panel의 Component Region(Advanced 탭 아래)에 지정된 Naming Scheme을(를) 기준으로 자동 설정됩니다.
또는 선택한 파라미터가 소스 라이브러리에서 값을 갖는지 확인하세요.
엔터티 설정의 수명 주기 정의가 비어 있음
Report mode:
요약
이 위반은 소스 라이브러리에 수명 주기 정의가 할당되지 않은 유형의 콘텐츠가 포함된 경우 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Lifecycle Definition.
각 항목의 의미:
-
ContentType은(는) 수명 주기 정의가 할당되지 않은 콘텐츠 유형(예: 컴포넌트 또는 심볼)입니다. -
LibraryName은(는) 수명 주기 정의가 할당되지 않은 유형의 콘텐츠가 포함된 소스 라이브러리의 이름입니다. -
LibraryType은(는) 수명 주기 정의가 할당되지 않은 유형의 콘텐츠가 포함된 하위 라이브러리 그룹의 이름입니다.
권장 해결 방법
Properties Panel(Advanced 탭 아래)에서 문제가 있는 콘텐츠 유형의 Lifecycle Definition 드롭다운에 수명 주기 정의가 선택되어 있는지 확인하세요. 드롭다운에 사용 가능한 항목이 있는 경우, 문제가 있는 콘텐츠 유형에 수명 주기 정의가 할당되어 있는지 확인하세요. 자세한 내용은 워크스페이스의 수명 주기 정의 설정 페이지를 참조하세요.
엔터티 설정의 리비전 명명 체계가 비어 있음
Report mode:
요약
이 위반은 소스 라이브러리에 리비전 명명 체계가 할당되지 않은 유형의 콘텐츠가 포함된 경우 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Revision Naming Scheme.
각 항목의 의미:
-
ContentType은(는) 리비전 명명 체계가 할당되지 않은 콘텐츠 유형(예: 컴포넌트 또는 심볼)입니다. -
LibraryName은(는) 리비전 명명 체계가 할당되지 않은 유형의 콘텐츠가 포함된 소스 라이브러리의 이름입니다. -
LibraryType은(는) 리비전 명명 체계가 할당되지 않은 유형의 콘텐츠가 포함된 하위 라이브러리 그룹의 이름입니다.
권장 해결 방법
Properties Panel(Advanced 탭 아래)에서 문제가 있는 콘텐츠 유형의 리비전 명명 체계 드롭다운에 수명 주기 정의가 선택되어 있는지 확인하세요. 드롭다운에 사용 가능한 항목이 있는 경우, 문제가 있는 콘텐츠 유형에 리비전 명명 체계가 할당되어 있는지 확인하세요. 자세한 내용은 워크스페이스의 리비전 명명 체계 설정 페이지를 참조하세요.
폴더가 존재하지 않음
Report mode:
요약
이 위반은 콘텐츠를 가져올 폴더가 연결된 워크스페이스에 존재하지 않는 경우 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
Folder '<FolderPath>' does not exist
각 항목의 의미:
-
FolderPath은(는) 연결된 워크스페이스에 존재하지 않는 타겟 폴더의 경로입니다.
권장 해결 방법
Properties Panel에서 워크스페이스에 저장할 콘텐츠의 Folder 필드 오른쪽에 있는
버튼을 클릭하여 타겟 폴더를 지정하세요. 열리는 Choose Folder 대화 상자에서 기존 폴더를 찾아 선택하거나 새 폴더를 즉석에서 생성하세요.
사용 가능한 라이브러리에서 풋프린트를 찾을 수 없음
Report mode:
요약
이 위반은 컴포넌트에 연결된 풋프린트를 사용 가능한 라이브러리에서 찾을 수 없는 경우 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
Footprint <FootprintName> is not found in available libraries. Any referenced footprints can only be found if the relevant PcbLib(s) are either installed, or are added to the Library Importer directly.
각 항목의 의미:
-
FootprintName은(는) 누락된 풋프린트의 이름입니다.
권장 해결 방법
연결된 풋프린트가 포함된 라이브러리를 Library Importer에 추가하세요. 이 위반이 있는 컴포넌트를 Components Region에서 선택한 상태에서 Details Region의 Choose a Library 컨트롤을 클릭하면 됩니다.
또는 가져올 컴포넌트에 연결된 풋프린트가 포함된 라이브러리가 설치되어 있는지 확인하거나(설치된 라이브러리에 대한 자세한 내용은 데이터베이스 및 파일 기반 라이브러리에서 컴포넌트 검색 페이지 참조), 소스 라이브러리에서 풋프린트 링크를 편집하세요.
자세한 내용은 Schematic 라이브러리 Import 섹션을 참조하세요.
잘못된 파라미터 매핑
Report mode:
요약
이 위반은 파라미터 매핑 Configuration에 오류가 있는 경우 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
Parameter mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
여기서:
-
LibraryName는 파라미터 매핑이 잘못된 컴포넌트가 있는 소스 라이브러리의 이름입니다. -
LibraryType는 파라미터 매핑이 잘못된 컴포넌트가 있는 하위 라이브러리 그룹의 이름입니다. -
Descripion는 파라미터 매핑 위반에 대한 설명입니다.
권장 해결 방법
Properties 패널의 Parameter Mapping 영역에서
아이콘이 있는 파라미터를 찾아 매핑을 적절히 업데이트합니다. 또는 오류가 있는 매핑 항목을 제거합니다.
해당 HRID를 가진 항목이 이미 릴리스됨
Report mode:
요약
이 위반은 가져올 컴포넌트의 항목 ID가 대상 워크스페이스에 이미 있는 항목의 ID와 같을 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다:
Item with HRID <ItemID> already released.
여기서:
-
ItemID는 워크스페이스의 항목에 사용되는 ID입니다.
권장 해결 방법
Properties 패널의 Parameter Mapping 영역에서 ID 파라미터가 고유한 값을 가진 소스 라이브러리 파라미터에 매핑되어 있는지 확인합니다. 이 파라미터의 매핑을 <Auto>(으)로 설정할 수도 있습니다. 이 경우 컴포넌트 항목 ID는 패널의 Component 영역(Advanced 탭 아래)에 지정된 Naming Scheme을(를) 기반으로 자동 설정됩니다. 이때 Naming Scheme이(가) 고유한 항목 ID를 생성하도록 설정되어 있는지 확인합니다.
또는 항목 ID로 선택한 파라미터가 소스 라이브러리에서 고유한 값을 갖는지 확인합니다.
데이터시트를 가져오기 위한 수명 주기 정의를 찾을 수 없음
Report mode:
요약
이 위반은 소스 라이브러리에 데이터시트가 연결된 컴포넌트가 포함되어 있고 Datasheet 콘텐츠 유형이 수명 주기 정의에 할당되어 있지 않을 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다:
Lifecycle Definition to import <LibraryName>.<LibraryType> library datasheets is not found.
여기서:
-
LibraryName는 데이터시트가 포함된 컴포넌트가 있는 소스 라이브러리의 이름입니다. -
LibraryType는 데이터시트가 포함된 컴포넌트가 있는 하위 라이브러리 그룹의 이름입니다.
권장 해결 방법
Datasheet 콘텐츠 유형이 수명 주기 정의에 할당되어 있는지 확인합니다. 자세한 내용은 워크스페이스의 수명 주기 정의 설정 페이지를 참조하세요.
또는 Properties 패널의 Datasheet 영역(Advanced 탭 아래)에서 Migrate 옵션을 변경하여 데이터시트 파일 가져오기를 비활성화합니다.
모델 설명이 너무 김
Report mode:
요약
이 위반은 컴포넌트 모델의 설명이 256자를 초과할 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다:
Description of Model '<ModelName>' of component '<ComponentName>' more then 256 characters.
여기서:
-
ModelName는 문제가 있는 모델의 이름입니다. -
ComponentName는 문제가 있는 모델이 포함된 컴포넌트의 이름입니다.
권장 해결 방법
길이 제한을 초과하지 않도록 소스 라이브러리에서 모델 설명을 수정합니다.
필수 파라미터 값이 비어 있음
Report mode:
요약
이 위반은 연결된 컴포넌트 템플릿에 필수로 표시된 파라미터가 있고 소스 라이브러리에 이 파라미터의 값이 없을 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다:
<ParameterName> required parameter value in component <ComponentName> is empty.
여기서:
-
ParameterName는 문제가 있는 파라미터의 이름입니다. -
ComponentName는 문제가 있는 파라미터가 포함된 컴포넌트의 이름입니다.
권장 해결 방법
소스 라이브러리에서 문제가 있는 파라미터에 값을 추가하거나 Library Importer의 그리드 영역에서 직접 값을 추가합니다. 또는 Properties 패널의 Parameter Mapping 영역(General 탭 아래)에서 파라미터 매핑을 수정하여 필수 파라미터를 값이 있는 소스 라이브러리 파라미터에 매핑합니다.
데이터시트를 가져오기 위한 리비전 명명 체계를 찾을 수 없음
Report mode:
요약
이 위반은 소스 라이브러리에 데이터시트가 연결된 컴포넌트가 포함되어 있고 Datasheet 콘텐츠 유형이 리비전 명명 체계에 할당되어 있지 않을 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다:
Revision Naming Scheme to import <LibraryName>.<LibraryType> library datasheets is not found.
여기서:
-
LibraryName는 데이터시트가 포함된 컴포넌트가 있는 소스 라이브러리의 이름입니다. -
LibraryType는 데이터시트가 포함된 컴포넌트가 있는 하위 라이브러리 그룹의 이름입니다.
권장 해결 방법
Datasheet 콘텐츠 유형이 리비전 명명 체계에 할당되어 있는지 확인합니다. 자세한 내용은 워크스페이스의 리비전 명명 체계 정의 페이지를 참조하세요.
또는 Properties 패널의 Datasheet 영역(Advanced 탭 아래)에서 Migrate 옵션을 변경하여 데이터시트 파일 가져오기를 비활성화합니다.
시뮬레이션 모델 파일을 찾을 수 없음
Report mode:
요약
이 위반은 컴포넌트에 연결된 시뮬레이션 모델을 지정된 경로에서 찾을 수 없을 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다:
Simulation model file <Path> is not found.
여기서:
-
Path는 시뮬레이션 모델에 대해 지정된 경로입니다.
권장 해결 방법
시뮬레이션 모델이 지정된 경로에 있는지 확인합니다. 또는 소스 라이브러리에서 모델의 경로를 업데이트합니다.
심볼 이름은 비워 둘 수 없음
Report mode:
요약
이 위반은 컴포넌트에 연결된 심볼이 없을 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다:
Symbol name cannot be empty.
권장 해결 방법
소스 라이브러리에서 컴포넌트의 심볼 링크가 올바르게 정의되어 있는지 확인합니다.
폴더를 수정할 접근 권한이 없음
Report mode:
요약
이 위반은 연결된 워크스페이스의 타겟 폴더에 대한 쓰기 권한이 없을 때 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
You do not have access right to modify folder <FolderPath>.
각 항목의 의미:
-
FolderPath은(는) 편집 권한이 없는, 연결된 워크스페이스 내 타겟 폴더의 경로입니다.
권장 해결 방법
워크스페이스 관리자에게 해당 폴더에 대한 쓰기 권한을 요청하세요(자세한 내용은 워크스페이스 콘텐츠에 대한 액세스 제어 페이지 참조).
또는 Properties Panel에서 쓰기 권한이 있는 다른 폴더를 선택하세요. 워크스페이스에 저장할 콘텐츠의 Folder 필드 오른쪽에 있는
버튼을 클릭한 다음, 열리는 Choose Folder 대화 상자에서 기존 폴더를 찾아 선택하거나 새 폴더를 바로 생성하세요.
사용자 정의 검사는 Properties Panel의 Import Checks Region에서 구성합니다. Report Mode 드롭다운 메뉴를 사용하여 해당 위반 유형의 보고 수준을 변경할 수 있습니다. 이러한 검사는 아래에 나열되어 있습니다.
파라미터에 의한 컴포넌트 중복
Default report mode:
요약
이 위반은 가져올 원본 라이브러리의 컴포넌트에 고유 값으로 설정된 파라미터 값이 있고, 타겟 워크스페이스의 컴포넌트에 이 파라미터와 동일한 값이 있을 때 발생합니다. 자세한 내용은 중복 감지 섹션을 참조하세요.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
Component <ComponentName> is duplicated with components by parameter <ParameterName> (<ParameterValue>):
- Server components: <WorkspaceComponentList>
각 항목의 의미:
-
ComponentName은(는) 위반이 발생한 컴포넌트의 이름입니다. -
ParameterName은(는) 고유 값으로 설정된 파라미터의 이름입니다. -
ParameterValue은(는) 고유 값으로 설정된 파라미터의 값입니다. -
WorkspaceComponentList은(는) 고유 값으로 설정된 파라미터 값이 중복되는 타겟 워크스페이스 내 컴포넌트의 Item-리비전 ID 목록입니다.
권장 해결 방법
가져올 원본 라이브러리의 컴포넌트 파라미터를 확인하고, Properties Panel의 Advanced 탭에 있는 Unique Field 드롭다운에서 올바른 파라미터가 고유 값으로 선택되어 있는지 확인하세요.
가져올 컴포넌트가 타겟 워크스페이스에 이미 있는 컴포넌트와 동일하다면 마이그레이션에서 제외할 수 있습니다. 자세히 알아보기.
부품 선택에 의한 컴포넌트 중복
Default report mode:
요약
이 위반은 가져올 원본 라이브러리의 컴포넌트와 동일한 부품 선택을 가진 컴포넌트가 타겟 워크스페이스에 있을 때 발생합니다. 자세한 내용은 중복 감지 섹션을 참조하세요.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
Component <ComponentName> is duplicated with components by Part Choices:
- Server components: <WorkspaceComponentList> (<Manufacturer> <PartNumber>)
각 항목의 의미:
-
ComponentName은(는) 위반이 발생한 컴포넌트의 이름입니다. -
WorkspaceComponentList은(는) 가져올 원본 라이브러리의 컴포넌트와 동일한 부품 선택을 가진 타겟 워크스페이스 내 컴포넌트의 Item-리비전 ID 목록입니다. -
Manufacturer은(는) 중복된 부품 선택의 제조업체 파라미터입니다. -
PartNumber은(는) 중복된 부품 선택의 부품 번호 파라미터입니다.
권장 해결 방법
가져올 원본 라이브러리의 컴포넌트 파라미터를 확인하고, 부품 선택 파라미터 매핑(Properties Panel의 General 탭에 있는 Part Choices Mapping Region에 나열됨)이 올바른지 확인하세요.
가져올 컴포넌트가 타겟 워크스페이스에 이미 있는 컴포넌트와 동일하다면 마이그레이션에서 제외할 수 있습니다. 자세히 알아보기.
컴포넌트 템플릿 중복
이 검사는 현재 Library Importer의 유효성 검사 기능에서 수행되지 않습니다.
컴포넌트 유형이 정의되지 않음
Default report mode:
요약
이 위반은 분류되지 않은 컴포넌트, 즉 컴포넌트 유형이 할당되지 않은 컴포넌트가 있을 때 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
<ComponentName> component type is undefined.
각 항목의 의미:
-
ComponentName은(는) 위반이 발생한 컴포넌트의 이름입니다.
권장 해결 방법
분류되지 않은 컴포넌트에 컴포넌트 유형을 할당하세요. 자세한 내용은 분류되지 않은 컴포넌트 섹션을 참조하세요.
데이터시트를 찾을 수 없음
Default report mode:
요약
이 위반은 원본 라이브러리의 컴포넌트에 정의된 링크에서 데이터시트를 찾을 수 없을 때 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
Datasheet <Path> is not found.
각 항목의 의미:
-
Path은(는) 원본 라이브러리의 컴포넌트에 정의된 데이터시트 경로입니다.
권장 해결 방법
누락된 데이터시트 파일을 찾아 지정된 위치에 복원하세요. 또는 Properties Panel의 Datasheet Region(Advanced 탭 아래)에 있는 Migrate 옵션을 변경하여 데이터시트 파일을 가져오지 않도록 설정하세요.
핀 매핑 Import가 지원되지 않음
Default report mode:
요약
이 위반은 원본 라이브러리의 컴포넌트에 Custom 핀 매핑이 있을 때 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
Import for <ComponentName> component pin mapping is not supported.
각 항목의 의미:
-
ComponentName은(는) 위반이 발생한 컴포넌트의 이름입니다.
권장 해결 방법
가져온 후 컴포넌트 Editor의 싱글 컴포넌트 편집 모드에서 컴포넌트를 편집할 때 핀 매핑을 확인하고 필요에 따라 구성할 수 있습니다. 자세히 알아보기.
잘못된 파라미터 값
Default report mode:
요약
이 위반은 컴포넌트의 파라미터 값을 지정된 단위 유형의 유효한 값으로 해석할 수 없을 때 발생합니다.
알림
Messages Panel에 다음 형식으로 알림이 표시됩니다.
<ParameterName> parameter value <ParameterValue> in component <ComponentName> cannot be converted to unit of type <UnitType>.
각 항목의 의미:
-
ParameterName은(는) 위반이 발생한 컴포넌트 파라미터의 이름입니다. -
ParameterValue은(는) 위반이 발생한 컴포넌트 파라미터의 값입니다. -
ComponentName은(는) 위반이 발생한 파라미터가 있는 컴포넌트의 이름입니다. -
UnitType은(는) 위반이 발생한 파라미터에 현재 설정된 측정 단위입니다.
권장 해결 방법
Library Importer의 Grid 영역에서 문제가 있는 파라미터 값을 규격에 맞는 형식으로 수정합니다. 또는 소스 라이브러리를 선택한 상태에서 Properties 패널의 Parameter Mapping 영역(General 탭 아래)에서 적용된 컴포넌트 템플릿에 따라 결정된 매핑된 파라미터 단위 Type을 해석하지 않는 형식인 Text(으)로 변경합니다.
잘못된 부품 선택 매핑
Default report mode:
요약
이 위반은 부품 선택 매핑 설정에 오류가 있을 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다.
Part Choice mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
각 항목의 의미는 다음과 같습니다.
-
LibraryName은(는) 부품 선택 매핑이 잘못된 컴포넌트가 있는 소스 라이브러리의 이름입니다. -
LibraryType은(는) 부품 선택 매핑이 잘못된 컴포넌트가 있는 하위 라이브러리 그룹의 이름입니다. -
Descripion은(는) 부품 선택 매핑 위반에 대한 설명입니다.
권장 해결 방법
Properties 패널의 Part Choices Mapping 영역에서
아이콘이 있는 파라미터를 찾아 매핑을 적절히 업데이트합니다. 또는 오류가 있는 매핑 항목을 제거합니다.
파라미터 이름이 시스템 파라미터와 중복됨
Default report mode:
요약
이 위반은 소스 라이브러리의 컴포넌트에 시스템 파라미터와 이름이 같은 파라미터가 포함되어 있을 때 발생합니다. 해당 파라미터는 다음과 같습니다.
-
AncestorItemRevisionGUID -
Cat -
ComponentType -
ContentType -
ContentTypeGUID -
CreatedAt -
CreatedBy -
CreatedByGUID -
DynamicData -
Folder -
FolderGuid -
Hrid -
Id -
ItemDescription -
ItemGUID -
ItemHRID -
LatestRevision -
LifeCycle -
LifecycleStateGUID -
ModifiedBy -
ReleaseDate -
ReleaseDateNum -
ReleaseNote -
RevisionId -
RevisionNamingSchemeGUID -
SourceGUID -
SourceVaultGUID -
Text -
Updated -
UpdatedByGUID
알림
Messages 패널에 다음 형식의 알림이 표시됩니다.
'<ParameterName>' is system parameter
각 항목의 의미는 다음과 같습니다.
-
ParameterName은(는) 문제가 있는 컴포넌트 파라미터의 이름입니다.
권장 해결 방법
Properties 패널의 Parameter Mapping 영역(General 탭 아래)에서 문제가 있는 파라미터의 매핑 항목을 제거합니다. 또는 소스 라이브러리의 컴포넌트에서 문제가 있는 파라미터를 제거하거나 이름을 변경합니다.
시뮬레이션 파라미터를 건너뜀
Default report mode:
요약
이 위반은 소스 라이브러리의 컴포넌트에 연결된 시뮬레이션 모델이 있을 때 발생합니다.
알림
Messages 패널에 다음 형식의 알림이 표시됩니다.
<ComponentName> component simulation parameters are skipped (<SimulationParameterList>).
각 항목의 의미는 다음과 같습니다.
-
ComponentName은(는) 소스 라이브러리에서 문제가 있는 컴포넌트의 이름입니다. -
SimulationParameterList은(는) 가져오기 중 건너뛸 시뮬레이션 파라미터의 쉼표로 구분된 목록입니다.
권장 해결 방법
가져온 후 컴포넌트 Editor의 싱글 컴포넌트 편집 모드에서 컴포넌트를 편집할 때 필요에 따라 시뮬레이션 모델에 대한 연결을 설정할 수 있습니다. 자세히 알아보기.
오류 및 경고 해결
여기에 표시된 예시처럼 컴포넌트의 Forward Voltage 값을 유효한 전압으로 해석할 수 없는 파라미터 오류는 다음 방법으로 해결할 수 있습니다.
-
문제가 있는 파라미터 값 편집 – 해당 셀을 찾아 규격에 맞는 형식으로 수정합니다.
-
적용된 컴포넌트 템플릿에 따라 결정된 매핑된 파라미터 단위 Type을(를)
Voltage에서 해석하지 않는 형식인Text(으)로 변경 – 가져오기 도구 UI에서 소스 라이브러리를 선택한 다음 Properties 패널 Parameter Mapping 목록(General 탭 아래)에서Forward VoltageType을(를) 변경합니다. -
가져오기 프로세스에서 컴포넌트 제거 – 해당 항목을 마우스 오른쪽 버튼으로 클릭하고 Exclude from Importer 옵션을 선택합니다.
여기에 표시된 찾을 수 없는 데이터시트 파일과 같은 파일 누락 오류는 다음 방법으로 해결할 수 있습니다.
- 가장 기본적인 해결 방법은 누락된 파일을 찾아 원래 있어야 할 위치에 복원하는 것입니다.
- 데이터시트 파일 가져오기 비활성화 – Properties 패널 Datasheet 섹션(Advanced 탭 아래)에서 Migrate 옵션을 변경합니다.
- 라이브러리 가져오기 프로세스에서 컴포넌트 제외 – 위에서 설명한 방법을 따릅니다.
특정 컴포넌트 항목을 찾으려면 오른쪽 위의 Search 필드를 사용합니다. 검색은 현재 선택된 컴포넌트 유형에 대해 일치하는 파라미터 값으로 항목 목록을 필터링합니다. 사용 가능한 소스 라이브러리의 모든 컴포넌트에 검색을 적용하려면 Types(Folder Structure) 아래에서 All을(를) 선택합니다.
Schematic 라이브러리 Import
Schematic 라이브러리를 가져오려고 할 때 '모델을 찾을 수 없음' 오류(예: Footprint <footprint name> not found in available libraries)가 발생하면 Library Importer가 SCHLIB 내의 컴포넌트에 연결된 모델을 찾을 수 없다는 의미입니다.
간단 모드에서는 가져오기를 실행한 후 사용할 수 있는
버튼으로 여는 HTML 기반 Importing Report에 이러한 오류가 표시됩니다. 고급 모드에서는 기본 인터페이스의 상태 아이콘과 Messages 패널의 항목으로 오류가 표시됩니다. 이는 유효성 검사를 수행하거나 라이브러리를 가져오려고 할 때 발생합니다.
유효성 검사 프로세스는 누락된 풋프린트를 정확히 감지하며, 오류 보고서(Details 드롭다운 아래)에 Choose a Library 옵션도 제공합니다. 둘 이상의 컴포넌트 풋프린트가 누락된 것으로 감지되면 Apply PcbLib Selection 대화 상자에서 지정된 PcbLib를 해당 컴포넌트에만 사용할지, 풋프린트가 누락된 모든 컴포넌트에 사용할지 선택할 수 있습니다.
이 문제를 해결하거나 방지하는 또 다른 방법은 필요한 모델 라이브러리 파일을 Altium Designer 내에서 사용할 수 있도록 하는 것입니다. 라이브러리는 Preferences 대화 상자의 데이터 관리 – 파일 기반 라이브러리 페이지에서 설치합니다.
또는 여러 모델 라이브러리를 설치하지 않으려면 소프트웨어의 기본 라이브러리 경로에 해당 라이브러리를 배치하거나 경로를 수정하고, Schematic 라이브러리 컴포넌트에 모델 소스 라이브러리가 지정되어 있는지 확인해야 합니다.
- 소프트웨어의 기본 검색 경로 위치에 모델 라이브러리를 포함합니다. 해당 PCB 라이브러리와 같은 모델 라이브러리를 시스템의 기본 라이브러리 경로로 지정된 위치에 추가합니다. 이 위치를 확인하려면 Preferences 대화 상자의 시스템 – 기본 위치 페이지에서 Library Path 항목을 참조하십시오. 해당 경로 위치에 라이브러리 파일을 추가하거나 복사한 경우 변경 사항을 반영하려면 Altium Designer를 다시 시작해야 할 수 있습니다.
-
Schematic 라이브러리 컴포넌트의 타겟 모델 라이브러리 이름을 지정합니다. Library Importer가 Schematic 라이브러리 컴포넌트에 연결된 모델 라이브러리를 인식할 수 있도록 라이브러리의 PCB 모델 대화 상자에서 해당 이름을 지정합니다.
중복 감지
Library Importer에는 타겟 워크스페이스에 중복 컴포넌트가 생성되지 않도록 하는 기능도 포함되어 있습니다. 검증 과정에서 소스 라이브러리의 컴포넌트 식별자 파라미터 및 Part Choices를 타겟 워크스페이스와 가져올 소스 라이브러리에 있는 컴포넌트의 해당 항목과 비교하여 이를 수행합니다. 가져오기 도구의 기본 설정에서는 동일한 컴포넌트 Name 또는 Part Choices 항목(컴포넌트 중복 가능성을 나타냄)이 감지되면 검증 단계에서 Warning 메시지가 표시됩니다. 표시되는 경고/오류 메시지에는 중복 위반 유형(파라미터 또는 Part Choice), 위반한 라이브러리 컴포넌트 이름, 중복되는 컴포넌트의 ID가 포함됩니다.

검증 프로세스에서 감지된 두 가지 중복 가능성. 컴포넌트의 Name(위 이미지) 또는 Part Choice(아래 이미지)이 워크스페이스 컴포넌트에 이미 존재합니다.
중복 위반을 감지하는 데 사용되는 파라미터 이름-값 쌍은 Properties 패널의 Advanced 탭 아래에 있는 Duplicates Detection 영역에서 지정합니다. Unique Field 드롭다운 메뉴(기본값은 Name)를 사용하여 소스 라이브러리에서 사용 가능한 파라미터 중에서 선택합니다. 이 선택 기능은 광범위한 기업 시스템과 연계되는 자체 식별자 필드를 사용하는 회사 라이브러리 구성에 특히 유용합니다.

지정된 파라미터(ERP-REF)의 값이 로컬 라이브러리 컴포넌트와 워크스페이스 컴포넌트에서 동일하여 중복 위반이 감지된 경우입니다.
Properties 패널의 General 탭 아래에 있는 Import Checks 영역에서 다른 Report Mode을 선택하여 중복 위반에 대해 다른 유형의 상태 플래그를 설정할 수 있습니다.
컴포넌트 심볼 모델에 대해서도 중복 감지가 수행됩니다. 가져올 컴포넌트의 소스 라이브러리에 동일한 형상의 심볼 모델이 있으면 이 모델 중 하나만 가져옵니다.
싱글 모델 라이브러리
자동 중복 감지는 모든 컴포넌트에 공통 심볼 모델을 사용하는 소스 라이브러리를 처리하는 데도 사용됩니다. 이러한 라이브러리는 특정 패키지 형식의 저항과 같이 스타일과 값이 서로 다른 단일 컴포넌트 유형으로 구성되는 경우가 많으며, 각 컴포넌트의 심볼은 표준 모델 그래픽입니다.
Library Importer는 이러한 단일 공통 모델 조건을 감지하면, 각 컴포넌트에 개별 이름이 지정된 심볼을 각각 전송하는 대신 가져오는 모든 컴포넌트에 적용되는 하나의 심볼 모델을 전송하도록 가져오기를 구성합니다. 가져올 심볼에는 가져오기 대상 심볼 중 하나의 이름이 사용되며, 모든 컴포넌트 파라미터는 변경되지 않습니다.
가져온 라이브러리 심볼(일반 이름을 가지며 Description 필드는 비어 있음)은 필요에 맞게 편집할 수 있습니다. 컴포넌트 패널에서 마우스 오른쪽 버튼 클릭 메뉴의 Edit 옵션을 사용하여 작업을 실행합니다. 이 과정에서 Create Revisions for Item 대화 상자의 Update items related to <symbol ID> 옵션을 선택하여 가져온 컴포넌트가 새 심볼 리비전을 사용하도록 합니다.
모델만 가져오기
Library Importer는 소스 라이브러리에서 사용 가능한 컴포넌트 모델을 감지하고 처리하는 특수 Models Only 가져오기 모드로 전환할 수 있습니다.
모델만 가져오기 모드에서는 가져오기 도구의 분석 프로세스가 소스 라이브러리(IntLib, SchLib, PcbLib 등)에서 사용 가능한 모든 심볼, 풋프린트 및 시뮬레이션 모델을 감지한 다음, 시스템의 기본 위치, 이름 지정 체계 및 수명 주기 정의를 사용하여 해당 모델을 워크스페이스로 가져옵니다.
Library Importer를 고급 모드로 전환하거나 고급 모드(File » Library Importer)로 열면 예정된 모델 가져오기의 전체 세부 정보를 확인할 수 있습니다. Import Preview 영역에는 타겟 워크스페이스에서 사용할 Folder Structure이 표시되며, Properties 패널에서 각 모델 유형의 Folder 필드를 통해 기본 설정을 변경할 수 있습니다. 각 모델에 적용되는 이름 지정 체계와 수명 주기 정의는 사용 가능한 시스템 유형 중에서 선택할 수 있습니다(아래의 Properties 패널 참조).
필요에 따라 Properties 패널에서 각 모델 유형에 해당하는
버튼을 사용하여 특정 모델 유형을 비활성화(또는 활성화)함으로써 워크스페이스로 가져올 컴포넌트 모델을 유형별로 제한할 수 있습니다.
Library Importer 구성을 마쳤으면
버튼을 선택하여 나열된 컴포넌트 모델 가져오기를 완료합니다. 결과는 Library Importer 진행률 대화 상자에서 제공하는 가져오기 로그 파일에서 검토하거나, 컴포넌트 패널에서 가져온 모델을 확인하여 검토할 수 있습니다.
컴포넌트만 가져오기
위에서 설명한 Models Only 가져오기 모드와 마찬가지로, Library Importer를 특수 Components Only 가져오기 모드로 전환하면 소스 라이브러리에서 사용 가능한 컴포넌트를 연결된 모델 없이 가져올 수 있습니다.
컴포넌트만 가져오기 모드에서는 가져오기 도구의 분석 프로세스가 소스 라이브러리의 모든 컴포넌트, 파라미터 및 Part Choices를 감지한 다음, 시스템의 기본 위치, 이름 지정 체계 및 수명 주기 정의를 사용하여 이러한 컴포넌트를 워크스페이스로 가져옵니다.
Library Importer를 고급 모드로 전환하거나 고급 모드(File » Library Importer)로 열면 가져올 컴포넌트의 전체 세부 정보를 확인할 수 있습니다. 적용할 폴더, 명명 체계 및 수명 주기 정의는 사용 가능한 시스템 유형에서 선택할 수 있습니다(아래 Properties 패널 참조).
Library Importer 설정을 마친 후
버튼을 선택하면 목록에 있는 컴포넌트 가져오기가 완료됩니다. 워크스페이스에는 연결된 모델 없이 컴포넌트 항목만 생성됩니다. 결과는 Library Importer 진행 상황 대화 상자에서 제공하는 가져오기 로그 파일에서 검토하거나, 컴포넌트 패널에서 가져온 컴포넌트를 확인하여 검토할 수 있습니다.
Properties 패널
Library Importer와 연결된 Properties 패널 설정을 통해 선택한 라이브러리(또는 하위 라이브러리 그룹)의 가져오기 구성을 세부적으로 제어할 수 있습니다. 이 패널은 Library Importer의 고급 모드에서 설계 공간 오른쪽 하단의
버튼 메뉴에 있는 Properties 옵션을 선택하거나, Library Importer 뷰 오른쪽 상단의
버튼을 클릭하거나, Source Libraries 목록에서 <All Libraries> 또는 특정 범주 항목 옆에 있는
버튼을 클릭하여 열 수 있습니다.
패널의 옵션 설정은 시스템 기본 설정 또는 적용된 컴포넌트 템플릿에 지정된 설정으로 정의됩니다. 이 템플릿은 라이브러리에서 감지된 컴포넌트 유형에 따라 설정되며, 여기에 표시된 예에서는 LED입니다. 사용자가 설정을 편집하여 필요에 맞게 가져오기 프로세스를 조정할 수도 있으며, 오른쪽 상단의 Reset to Default 링크로 설정을 복원할 수 있습니다.
패널의 General 탭에는 다음 섹션이 있습니다.
-
General:
-
Component Type – 가져오기 도구가 선택한 라이브러리에서 감지한 컴포넌트 유형과, 이에 따라 적용되는 템플릿입니다(아래 Component Template 참조). 필드를 편집하여 새 컴포넌트 유형을 생성하거나, 드롭다운 메뉴 옵션(또는
버튼)을 사용하여 다른 유형을 선택하면 이 설정을 재정의할 수 있습니다. 이는 미분류 컴포넌트 문제를 해결하는 또 다른 방법입니다. 유형을 선택한 라이브러리 이름으로 설정하려면 [LibraryName]옵션을 선택합니다. -
Component Template – 가져온 컴포넌트에 적용할 워크스페이스 컴포넌트 템플릿과, 이에 연결된 컴포넌트 유형 설정입니다. 드롭다운 메뉴 옵션(또는
버튼)을 사용하여 다른 템플릿을 선택하면 이 설정을 재정의할 수 있습니다. 소스 라이브러리 파라미터와 Library Importer의 현재 설정을 기반으로 템플릿을 자동 생성하려면 이 옵션을 [Create new]로 설정하고, 템플릿이 적용되거나 생성되지 않게 하려면 [No Template]을 선택합니다.
-
Component Type – 가져오기 도구가 선택한 라이브러리에서 감지한 컴포넌트 유형과, 이에 따라 적용되는 템플릿입니다(아래 Component Template 참조). 필드를 편집하여 새 컴포넌트 유형을 생성하거나, 드롭다운 메뉴 옵션(또는
-
Parameter Mapping – 라이브러리 파라미터와 적용된 컴포넌트 템플릿의 파라미터(템플릿을 사용할 수 없는 경우 기본 설정) 간의 매칭과 각 파라미터의 값 유형(텍스트 또는 단위 인식 유형)입니다. Source Library Parameter 열의 드롭다운 메뉴 옵션을 사용하여 매핑을 변경하고, Type 열의 메뉴 옵션을 사용하여 템플릿이나 기본값에 따라 결정된 기존 설정을 재정의합니다. 파라미터를 포함하지 않으려면
<Skip>옵션을 선택합니다. 소스 라이브러리 파라미터와 자동으로 매칭되지 않은 파라미터(시스템에서<Skip>로 설정됨)는 적절한 템플릿 파라미터에 수동으로 매핑할 수 있습니다. 예를 들어 소스 파라미터ROHS를 선택하여 워크스페이스 템플릿에 정의된RoHS Compliant파라미터와 매칭할 수 있습니다. 파라미터 이름을 편집할 수 있으며, 파라미터 집합을 추가, 편집 및 제거할 수 있습니다. 기본 컴포넌트 파라미터(ID,Name,Description)는 다시 매핑할 수 있지만, 그 외에는 읽기 전용입니다. -
Part Choice Mapping – 가져오기 도구가 인식한 제조업체 부품 또는 공급업체 링크 파라미터 목록으로, 가져온 컴포넌트의 부품 선택 항목을 생성하는 데 사용됩니다. 드롭다운 메뉴 옵션을 사용하여 매핑을 재정의하거나 매핑 집합을 추가 및 삭제할 수 있습니다. 기본적으로 제조업체 부품 및 공급업체 링크 파라미터는 가져오기 프로세스에 포함되지 않고 건너뜁니다. 라이브러리 컴포넌트에 공급업체 링크가 여러 개 포함된 경우, 기본 공급업체 참조(
Supplier 1/Supplier Part Number 1)가 부품 선택 필드 항목에 사용됩니다. -
Import Checks – 가져오기 유효성 검사 규칙 위반에 대한 가져오기 도구의 오류/경고 응답을 확인하거나 설정합니다. Report Mode 드롭다운 메뉴를 사용하여 Violation Type 항목의 응답과 아이콘을 변경합니다.
Fatal Error보고 모드를 선택하면 해당 위반이 감지될 때 가져오기 프로세스가 차단됩니다.
패널의 Advanced 탭에서는 시스템 기본값 또는 적용된 컴포넌트 템플릿에 따라 설정된 모든 가져오기 도구 데이터 객체 항목의 설정을 제공합니다. 여기에는 컴포넌트 모델, 데이터시트 파일 및 생성된 모든 컴포넌트 템플릿이 포함됩니다. Datasheet 옵션(활성화/비활성화 토글)을 제외한 각 가져오기 객체의 설정은 다음과 같습니다.
- Folder – 가져온 객체를 저장할 타겟 워크스페이스 폴더입니다. 직접 편집하거나(예: 새 타겟 폴더 생성), 찾아보기 버튼으로 선택할 수 있습니다.
- Naming Scheme – 컴포넌트 템플릿에 정의된 객체의 워크스페이스 명명 규칙입니다. 활성 템플릿이 없는 경우에는 타겟 폴더에 설정된 체계 또는 수동으로 입력한 체계를 사용합니다. 드롭다운 메뉴에서 사용 가능한 명명 체계를 선택합니다. 타겟 폴더 경로(Folder)를 변경하면 폴더 자체 또는 적용되거나 연결된 컴포넌트 템플릿의 설정에 따라 적용되는 명명 체계도 변경될 수 있습니다.
- Revision Naming Scheme – 객체의 워크스페이스 리비전에 사용되는 명명 방식으로, 적용된 템플릿에 따라 설정되거나 해당 항목의 드롭다운 메뉴 옵션에서 선택됩니다. 시스템에서 활성화된 체계만 옵션으로 사용할 수 있습니다.
- Lifecycle Definition – 객체에 사용되는 수명 주기 시스템으로, 적용된 템플릿에 의해 설정되거나 Entry의 드롭다운 메뉴 옵션에서 선택됩니다. 시스템에서 활성화한 정의만 옵션으로 사용할 수 있습니다.
Export-Import Configuration
Library Importer는 현재 Configuration 설정을 기록한 상세한 텍스트 기반 파일을 내보내는 기능을 제공합니다. 이 파일에는 타겟 경로, 파라미터 매핑, 명명 체계, 수명 주기 정의, 타겟 컴포넌트 유형 등 구성 가능한 모든 Import 설정이 포함됩니다.
Importer Configuration 파일은 File » Export » Importer Config 명령을 통해 *.lmcfg 파일 형식으로 저장되며, 언제든지 File » Import » Importer Config 메뉴 옵션을 통해 복원할 수 있습니다.
Configuration 복원 기능은 원본 데이터베이스나 파일 기반 라이브러리가 업데이트되어 변경 사항을 워크스페이스로 가져와야 할 때 특히 유용합니다. 라이브러리를 처음 가져올 때 Configuration을 내보냈다면, 복원한(가져온) Configuration을 통해 당시 사용한 Configuration 설정을 정확히 재구성할 수 있으므로 해당 라이브러리(또는 여러 라이브러리)에 일관된 데이터 전송 체계를 적용할 수 있습니다.

























