디자인 오브젝트 파라미터로 작업하기
개요
- 객체, 문서, 프로젝트 수준을 비롯해 Altium Designer에서 파라미터가 존재하는 위치와 시스템 파라미터 및 사용자 파라미터의 차이를 알아보세요.
- Properties 패널, 설계 공간, 라이브러리 작업 흐름에서 파라미터 문자열을 추가, 편집, 이동, 잠금 설정하고 관리하는 방법을 살펴보세요.
- Designator, 자동 배치, 링크와 같은 특수 파라미터 유형을 포함하여 컴포넌트별 파라미터 동작을 이해해 보세요.
파라미터는 상위 객체에 속하는 하위 객체인 범용 텍스트 문자열입니다. 상위 객체를 식별하고 추가 정보를 제공하며, Schematic 시트에서 선택하면 Properties 패널에서 직접 액세스할 수 있습니다.
예를 들어, Schematic 컴포넌트는 파라미터를 광범위하게 사용합니다. 범용 컴포넌트 파라미터는 전력, 전압 등의 컴포넌트 세부 정보, 공급업체 이름과 부품 번호 등의 공급업체 세부 정보, 심볼의 리비전 번호와 같은 라이브러리 컴포넌트 설계 세부 정보, 컴포넌트 데이터시트로 연결되는 URL 같은 문서 세부 정보를 비롯한 다양한 용도로 사용할 수 있습니다.
파라미터는 Schematic 시트(문서) 및 프로젝트 수준에서도 정의할 수 있습니다. 문서 수준 파라미터는 문서 제목 및 번호와 같은 필드를 정의하는 데 사용되며, 프로젝트 수준 파라미터는 설계자 또는 프로젝트 이름과 같은 필드를 정의하는 데 적합합니다.
파라미터는 객체, 문서 및 프로젝트에 사용되어 설계에 상세 정보를 추가합니다. 위 이미지는 컴포넌트의 예를 보여 줍니다.
파라미터는 상위 객체의 속성으로 추가되거나 자동으로 포함되며, 텍스트 문자열처럼 독립적으로 배치되지 않습니다. 사용 가능한 파라미터 유형은 크게 시스템 파라미터와 사용자 파라미터로 나눌 수 있으며, 사용자 파라미터는 수동으로 추가합니다.
식별자 및 시스템 파라미터
Schematic에 배치된 객체에는 다양한 주요 시스템 파라미터가 자동으로 포함됩니다. 이러한 파라미터는 시스템이 상위 객체의 이름, 유형 및 데이터 소스를 구분하는 데 사용하는 기본 객체 정보를 제공합니다. 객체에 내장된 시스템 파라미터에는 Comment, Description 및 Design Item ID(라이브러리 참조) 속성 등이 포함됩니다. 상위 객체를 선택하면 Properties 패널의 General 섹션(General 탭 아래)에서 객체 시스템 파라미터에 액세스할 수 있습니다. 개별 파라미터가 설계 공간에 표시되어 있고 선택된 경우, 아래 설명과 같이 Properties 패널의 해당 모드를 통해 액세스할 수 있습니다.
사용자 파라미터
다음 설계 객체에 파라미터를 추가할 수 있습니다.
| Component | 컴포넌트(부품) 객체를 선택한 상태에서 Properties 패널의 Parameters 영역에 사용자 정의 파라미터를 추가하거나, Schematic 라이브러리 편집기에서 컴포넌트를 정의하는 동안 추가할 수 있습니다. 위에서 설명한 것처럼 컴포넌트 객체에는 Designator 및 Comment와 같은 시스템 파라미터가 항상 존재합니다. 객체를 두 번 클릭하거나 객체를 마우스 오른쪽 버튼으로 클릭한 후 컨텍스트 메뉴에서 Properties을 선택하면 Properties 패널에 액세스할 수 있습니다. Properties 패널이 이미 활성화되어 있다면 설계 공간에서 객체를 선택합니다. |
| Part | 부품 객체를 선택한 상태에서 Properties 패널의 Parameters 영역에서 추가합니다. |
| Pin | *.SchLib 파일 내에서 핀 객체를 선택한 상태에서 Properties 패널의 Parameters 탭에서 추가합니다. |
| Port | 포트 객체를 선택한 상태에서 Properties 패널의 Parameters 탭에서 추가합니다. |
| Sheet Symbol | 시트 심볼 객체를 선택한 상태에서 Properties 패널의 Parameters 탭에서 추가합니다. |
| Document | Document Options 모드에서 Properties 패널의 Parameters 탭에서 추가합니다(모든 Schematic 객체의 선택을 해제하거나 문서 시트의 빈 공간을 클릭). 적용된/기본 시트 템플릿에 따라 새 Schematic 시트에 여러 기본 파라미터가 자동으로 포함됩니다. |
| Project | 프로젝트 옵션 대화 상자 (Project » 프로젝트 옵션)에서 추가합니다. 프로젝트 수준 파라미터는 대화 상자의 Parameters 탭에 나열되며 여기서 추가할 수 있습니다. |
상위 객체를 선택하면 Properties 패널 또는 모달 대화 상자의 Parameters 영역에서 사용자 파라미터를 사용할 수 있습니다. 파라미터는 추가와 편집이 모두 가능합니다. 예외적으로 프로젝트 파라미터는 프로젝트 옵션 대화 상자를 통해, 컴포넌트 핀 파라미터는 핀 속성 또는 Pin 대화 상자의 모달 보기를 통해 액세스합니다. 개별 파라미터가 설계 공간에 표시되어 있고 선택된 경우, 아래 설명과 같이 Properties 패널의 해당 모드 또는 모달 대화 상자를 통해 액세스할 수 있습니다.
첫 번째: Properties 패널(Parameters 영역)의 컴포넌트 사용자 파라미터. 두 번째: Properties 패널의 개별 시스템 파라미터.
그래픽 편집
표시된 파라미터 문자열은 설계 공간에서 직접 그래픽 방식으로 편집할 수 있습니다.
파라미터를 클릭하고 드래그하여 위치를 변경합니다. 파라미터 문자열을 제자리에서 편집하려면 다음을 수행합니다.
-
마우스 버튼을 누른 상태에서 파라미터 객체를 둘러싸도록 마우스 커서를 드래그합니다.
-
선택하면 객체가 녹색 테두리로 강조 표시됩니다.
-
Enter을 선택하여 텍스트 편집을 시작합니다. -
편집을 마치면
Enter을 다시 누르거나 문자열 바깥쪽을 클릭하여 제자리 편집 모드를 종료합니다.
설계 공간에서 파라미터 문자열을 직접 선택하고 편집할 수 있습니다. 문자열 전체를 선택하면 새로 입력하여 덮어쓸 수 있습니다.
설계 공간에 표시되고 선택할 수 있는 파라미터는 새 위치로 드래그할 수 있으며, 드래그하는 동안 회전할 수도 있습니다. 파라미터 문자열을 클릭하고 드래그한 다음, Spacebar 및 Shift+Spacebar 키를 사용하여 90° 단위로 회전하고 클릭하여 새 위치/방향을 확정합니다.
컴포넌트 파라미터 Autopositioning 및 관련 Properties 패널 옵션에 대한 정보는 아래의 파라미터 문자열 배치를 참조하십시오.
잠긴 파라미터
컴포넌트 부품의 하위 객체인 파라미터는 잠글 수 있으며, 잠그면 해당 Name 및 Value 문자열을 편집할 수 없습니다. 다음 방법으로 잠글 수 있습니다.
-
상위 객체의 Properties 패널 또는 모달 대화 상자에서 Parameters 영역의 해당 항목에 연결된 잠금 아이콘을 전환하거나,
-
설계 공간에서 파라미터를 직접 선택한 상태에서 Properties 패널의 Lock Parameter 옵션을 선택합니다.
잠그면 파라미터 문자열은 Properties 패널, 모달 대화 상자(Parent 객체의 Parameters 아래), 또는 설계 공간의 직접 편집 기능으로 편집할 수 없습니다.
컴포넌트 파라미터
컴포넌트 파라미터는 가장 널리 알려져 있고 자주 사용되는 Schematic 파라미터로, 컴포넌트 객체를 정의하는 기능을 확장하는 전용 파라미터와 기능 세트를 추가로 포함합니다.
Schematic 라이브러리에서 파라미터 정의하기
Parent 컴포넌트 객체의 하위 파라미터는 Schematic에 배치하기 전에 컴포넌트 라이브러리 소스에서 정의할 수 있습니다.o Properties 패널을 사용하면 Schematic Editor에서 파라미터를 다룰 때와 동일한 방식으로 Schematic 라이브러리 Editor의 컴포넌트 Entry에 파라미터를 추가하고 편집할 수 있습니다.
Schematic 컴포넌트 라이브러리 문서가 열린 상태에서 SCH Library 패널의 컴포넌트 Entry를 선택하면 Properties 패널에서 해당 파라미터 속성에 접근할 수 있습니다.
SCH Library 패널에서 라이브러리 컴포넌트의 Entry를 선택하여 해당 속성에 접근합니다.
라이브러리 컴포넌트의 Designator와 Comment는 기본적으로 Schematic 라이브러리 Editor의 설계 공간에 표시되지 않지만, Properties 패널의 Library Options 모드(Tools » Document Options)에서 Show Comment/Designator 옵션을 선택하면 표시할 수 있습니다. 이 모드는 설계 공간에서 선택된 객체가 없을 때 사용할 수 있습니다.
라이브러리 컴포넌트에 속한 파라미터는 배치된 Schematic 컴포넌트에 적용하는 것과 동일한 절차로 정의하고 편집합니다. 설계 공간에 객체를 배치하는 동안 Tab 키를 사용하여 파라미터를 즉석에서 생성하거나 편집할 수 있습니다. 파라미터는 Properties 패널 또는 모달 대화 상자에서 접근할 수 있으며, 핵심 시스템 파라미터는 패널의 General 탭에서 사용할 수 있고 사용자 파라미터는 패널의 Parameters 드롭다운에서 추가하거나 편집할 수 있습니다.
Designator 파라미터
Schematic 라이브러리 Editor에서 컴포넌트의 Designator 파라미터에는 일반적으로 적절한 접두사 뒤에 물음표를 붙입니다. 라이브러리에서 컴포넌트를 가져와 Schematic에 배치하면 Schematic Editor의 Annotation 도구가 물음표를 감지하고, 프로젝트 Annotation 과정에서 이를 적절한 숫자 접미사로 바꿉니다.
Schematic Editor에는 동일한 부품의 여러 인스턴스를 배치할 때 사용할 수 있는 간단한 Designator 자동 증가 기능도 있습니다. 이 기능을 사용하려면 첫 번째 컴포넌트가 커서에 붙어 있는 동안 Tab 키를 눌러 배치를 일시 중지한 다음, Properties 패널에 적절한 Designator(예: R1)를 입력합니다. 이후 컴포넌트에는 R2, R3 등의 Designator가 지정됩니다.
멀티파트 컴포넌트를 배치할 때 이 방식으로 초기 Designator를 지정하면 U3A, U3B 등의 파트 접미사가 자동으로 추가됩니다. 초기 Designator를 지정하지 않으면 모든 파트에 동일한 접미사가 붙습니다. 이는 Schematic Editor의 Annotation 기능으로 해결할 수 있습니다. 파트 접미사는 Preferences 대화 상자의 Schematic - General 페이지에 있는 Alpha Numeric Suffix 옵션의 설정에 따라 영문자 또는 숫자가 될 수 있습니다.
파라미터 문자열 위치 지정
컴포넌트 파라미터 문자열은 기본적으로 배치 중이나 배치 후 컴포넌트를 회전할 때 자동으로 위치가 조정됩니다(즉, 방향을 유지합니다). 이 동작이 필요하지 않으면 Properties 패널의 Parameters Region 아래에서 해당 컴포넌트 파라미터 Entry의 Autoposition 옵션을 끕니다. 이 옵션에 접근하려면 목록에서 파라미터를 선택한 다음 Other를 클릭합니다. 컴포넌트 배치 중에는 Spacebar 및 Shift+Spacebar 키를 사용하여 회전할 수 있습니다. 배치된 컴포넌트 객체는 Properties 패널의 Location Region에 있는 Rotation 메뉴를 사용하거나, 컴포넌트를 선택한 다음 Spacebar 또는 Shift+Spacebar 키를 눌러 회전할 수 있습니다.
표시된 파라미터를 클릭하고 드래그하면 Schematic에서 위치를 수동으로 변경할 수 있으며, 표준 방향 변경 단축키도 적용됩니다. 해당 파라미터의 Autoposition 옵션이 비활성화되어 있고 and Preferences 대화 상자의 Schematic - Graphical Editing 페이지에서 Mark Manual Parameters 옵션이 활성화되어 있으면, 수동으로 이동한 파라미터는 선택 상자의 왼쪽 아래 모서리에 점으로 표시됩니다.
특수 목적 컴포넌트 파라미터
관련 URL 타겟이나 파일 기반 문서에 연결할 수 있는 특수 목적 컴포넌트 파라미터가 제공됩니다. 선택한 컴포넌트에 이러한 파라미터를 추가하려면 Properties 패널의 Parameters Region에서 Add 을 클릭한 다음 드롭다운에서 Link 을 선택합니다. 또는 F1 키로 활성화되는 전용 도움말 링크를 Parameters 탭에서 추가할 수 있습니다.
링크 파라미터
링크 기능을 사용하면 개수에 제한 없이 참조 URL이나 문서에 이름이 있는 링크를 정의하고 표시할 수 있습니다.
컴포넌트에 참조 링크를 추가하려면 설계 공간에서 컴포넌트를 선택한 다음, Properties 패널의 Parameters Region 아래에서 Links 를 클릭합니다. Parameters Region 하단의 Add 드롭다운 메뉴에서 Link 를 선택합니다. Grid에 링크 Name 과 Value (타겟 URL 또는 파일 경로)을 입력합니다. 이후 설계 공간에서 컴포넌트를 마우스 오른쪽 버튼으로 클릭하고 References 하위 메뉴에서 링크 <name>을 선택하여 해당 링크에 접근할 수 있습니다.
패널과 설계 공간에 표시되는 컴포넌트 링크는 내부적으로 ComponentLinknDescription/ComponentLinknURL 형식의 이름/값 쌍을 기반으로 합니다. 여기서 n은 생성 순서에 따른 목록 내 링크 번호입니다. 자세한 내용은 해당 컴포넌트의 파라미터 테이블 Editor Entry에서 확인할 수 있습니다.
HelpURL 파라미터
링크 파라미터와 마찬가지로 HelpURL 파라미터를 사용하면 컴포넌트에서 PDF와 같은 외부 문서나 웹 페이지 URL로 연결되는 링크를 정의할 수 있습니다. 이를 컴포넌트 파라미터로 추가하면 Schematic 시트의 컴포넌트 위에서 F1 키를 누르거나 Libraries 패널에서 컴포넌트가 선택된 상태로 해당 키를 누를 때 링크가 활성화됩니다. 이 동작은 Altium 온라인 문서의 관련 페이지로 연결하는 일반적인 F1 키 기능보다 우선합니다.
도움말 링크는 설계 공간에서 컴포넌트를 선택한 상태로 Properties 패널에서 사용자 파라미터로 추가합니다. Properties 패널의 Parameters Region 아래에서 Parameters 을 클릭한 다음, Parameters Region 하단의 Add 드롭다운 메뉴에서 Parameter 을 선택합니다. 파라미터 Name 에는 "HelpURL"을, 파라미터 Value에는 타겟 경로/URL을 입력합니다.
파라미터 값을 지정할 때는 URL, 문서의 절대 경로 또는 문서 이름만 입력할 수 있습니다. 배치된 컴포넌트 객체 위에 커서를 놓고 F1을 누르거나 마우스 오른쪽 버튼 클릭 메뉴에서 References » Help 옵션을 사용하면 다음과 같이 도움말 참조를 검색합니다.
- 경로가 지정된 경우 해당 위치를 먼저 검색합니다.
-
이 위치에서 문서를 찾을 수 없거나 경로가 지정되지 않은 경우, 소프트웨어 설치 경로의
\Help폴더를 검색합니다. - 타겟이 URL인 경우, Preferences 대화 상자의 System - View 페이지에 있는 Open internet links in external Web browser 옵션의 상태에 따라 소프트웨어의 내부 브라우저 또는 외부 브라우저에서 웹 페이지가 열립니다.
간접 참조 - 문자열 값으로 사용하는 파라미터
대부분의 컴포넌트 파라미터는 Properties 패널에서 표시 아이콘(제공되는 경우)을 활성화하여 Schematic 시트에 표시할 수 있습니다. 식별자 및 시스템 파라미터는 패널의 General 탭에서 사용할 수 있으며, 사용자 파라미터는 패널의 Parameters 영역에서 접근할 수 있습니다.
그러나 문서 및 프로젝트 파라미터와 같은 다른 파라미터는 Schematic 시트에 직접 표시할 수 없으며, String Indirection 기법을 사용하여 일반 텍스트 객체에 삽입할 수 있습니다. 간접 참조란 문자열 객체의 값 입력 항목에 사용 가능한 파라미터(예: 문서 또는 프로젝트 파라미터)의 이름 앞에 등호를 붙여 입력하는 것입니다. 예를 들면 =Title입니다.
소프트웨어는 이러한 문자열을 자동으로 감지하고 배치된 텍스트 객체의 값 입력 항목과 일치하는 사용 가능한 파라미터 이름이 있는지 확인합니다. 예시의 Title이 문서 파라미터로 검색되면 텍스트 문자열은 제목 파라미터 값을 해석하여 표시합니다. 예를 들면 MyDocument입니다. 파라미터 이름은 제자리 편집(즉, =Title 입력)을 통해 선택한 텍스트 문자열의 값으로 지정할 수 있습니다. 또는 사용 가능한 파라미터 문자열을 확인하면서 선택하려면 Properties 패널의 Text 드롭다운 메뉴를 사용할 수 있습니다.
특수 문자열
간접 참조 문자열(위 참조)로 사용할 수 있는 파라미터 문자열을 special strings이라고 합니다. 이러한 문자열에 표시되는 값은 템플릿이나 시스템 및 소스 데이터에서 동적으로 가져옵니다. 예를 들어 특수 문자열 =Time은 현재 시스템 시간을 감지하여 표시하고, =DocumentName은 현재 Schematic 문서 파일 이름(예: MySchematic.SchDoc)을 표시합니다.
미리 정의된 다양한 특수 문자열을 사용할 수 있습니다. 이러한 특수 문자열에 대한 자세한 내용은 Schematic에서 텍스트 객체 작업하기 페이지를 참조하십시오. 사용자 정의 문서 또는 프로젝트 파라미터도 특수 문자열로 사용하여 Schematic 시트의 텍스트 문자열에서 '간접 참조'할 수 있습니다.
파라미터에는 계층 구조가 있으므로 프로젝트의 서로 다른 수준에 같은 이름의 파라미터를 만들고 각각 다른 값을 지정할 수 있습니다. 컴포넌트 파라미터의 경우 Altium Designer는 다음과 같은 우선순위로 값을 결정합니다.
-
컴포넌트 파라미터(최우선)
-
Variant
-
Schematic 문서
-
시트 심볼(상위 시트 심볼의 파라미터 값을 보려면 설계 공간 하단의 Compiled 탭을 선택)
-
프로젝트
이 패널의 옵션/컨트롤은 대부분 직관적이므로 추가 설명이 필요하지 않습니다. 설명이 필요한 항목은 아래에 나와 있습니다.
-
Allow Synchronization with Database (Preferences 대화 상자에만 해당) - 데이터베이스와 동기화하려면 활성화합니다. 이 옵션은 Comment를 업데이트할 수 있는지 제어하는 데 사용됩니다. 기본적으로 이러한 옵션은 활성화되어 있어 소스 라이브러리/데이터베이스와의 동기화를 항상 허용합니다. 해당 Comment가 업데이트 과정에 포함되지 않도록 하려면 이 옵션을 비활성화할 수 있습니다.
파라미터 관리자 사용하기
사용자 정의 설계 속성은 파라미터를 통해 설계에 추가됩니다. 파라미터는 개별적으로 추가하고 편집할 수 있으며, Parameter Table Editor 대화 상자 (Tools » Parameter Manager)를 사용하여 전체 설계 또는 전체 라이브러리에서 파라미터를 추가하고 편집할 수도 있습니다. 이러한 파라미터는 활성 프로젝트의 소스 Schematic 문서에 있는 다양한 종류의 객체나 활성 라이브러리의 컴포넌트가 '소유'합니다. 이 기능을 사용하면 모든 파라미터를 한곳에 모아 빠르고 효율적으로 편집할 수 있으며, Engineering Change Order를 생성하여 파라미터 변경 사항을 해당 파라미터를 '소유'하는 각 설계 객체에 직접 적용할 수 있습니다.
대화 상자를 열면 전체 설계의 모든 파라미터 데이터를 수집하여 표 형태의 Grid에 표시합니다. Schematic에서 대화 상자를 실행하면 Parameter Editor Options 대화 상자가 열립니다. Parameter Table Editor 대화 상자에 불러올 파라미터 유형을 선택하십시오. 예를 들어 컴포넌트 파라미터를 작업하는 경우 Include Parameters Owned By 영역에서 Parts을 제외한 모든 옵션을 비활성화합니다. 대화 상자 중앙의 드롭다운 필드를 사용하면 포함할 객체의 범위를 더욱 세밀하게 지정할 수 있습니다. 모든 객체, 기존 파라미터가 있는 객체만, 또는 실제로 사용되는 기존 파라미터가 있는 객체만 포함하도록 선택할 수 있습니다.
또 다른 예로, 문서 파라미터를 작업하는 경우에는 Documents 옵션만 활성화합니다. Exclude System Parameters 옵션에는 컴포넌트 모델 설정, 템플릿에 정의된 문서 파라미터 등이 포함됩니다. 파라미터 관리에 익숙해진 후 이 옵션을 살펴보십시오.
설계의 특정 객체에 대한 파라미터만 편집하려면 필요한 객체를 선택하고 Selected Objects Only 옵션을 활성화합니다. 대화 상자의 Include Parameters Owned By 영역에서 해당 객체 종류가 활성화된 경우에 한해 선택한 객체만 포함됩니다.
필요한 옵션을 선택한 후 OK을 클릭하여 Parameter Table Editor 대화 상자를 엽니다.
대화 상자의 옵션/필드는 대부분 직관적입니다. 추가 설명이 필요한 항목은 아래에 나와 있습니다.
-
Remove Columns - 클릭하여 열을 제거합니다. 이 옵션은 정적 정보가 있는 열에서만 사용할 수 있습니다.
-
Add Column - 클릭하여 열을 추가합니다. 파라미터 이름을 정의할 수 있는 Add Parameter 대화 상자가 열립니다.
-
Reset Column Order - 클릭하여 열을 알파벳순으로 표시합니다.
-
Accept Changes (Create ECO) - 이러한 변경 사항을 컴포넌트에 적용하려면 ECO(Engineering Change Order)를 생성해야 합니다. 클릭하여 Engineering Change Order 대화 상자를 엽니다.
마우스 오른쪽 버튼 클릭 메뉴
-
Revert - 클릭하여 선택한 셀의 편집 내용을 실행 취소합니다.
-
Add - 클릭하여 선택한 셀에 정보를 추가합니다. 표시되는 드롭다운에서 원하는 정보를 선택합니다.
-
Rename Column - 클릭하여 기존 파라미터의 이름을 변경할 수 있는 기존 파라미터 이름 변경 대화 상자를 엽니다.
-
Remove Columns - 클릭하여 선택한 열을 삭제합니다.
-
Report - 클릭하여 보고서를 생성하는 Report Preview 대화 상자를 엽니다.
-
Cross Probe - 클릭하여 선택한 객체를 크로스 프로빙합니다. 선택한 객체가 Schematic 시트에서 강조 표시됩니다.
참고
-
Grid Region에서 열을 드래그 앤 드롭하여 열 표시 순서를 변경할 수 있습니다. 새 순서는 프로젝트 파일에 저장되므로 대화 상자를 다시 열 때도 유지됩니다.
-
다음과 같은 방법으로 파라미터가 업데이트되지 않도록 할 수 있습니다.
- 개별 컴포넌트 파라미터 수준에서는 Properties Panel의 Component 모드에서 Lock Parameter 옵션을 활성화합니다(컴포넌트를 두 번 클릭하여 접근). Allow Synchronization With Database 옵션은 Comment의 업데이트 가능 여부를 제어하는 데도 사용됩니다. 기본적으로 이 옵션은 활성화되어 소스 라이브러리/데이터베이스와의 동기화를 항상 허용합니다. 업데이트 프로세스에 Comment가 포함되지 않도록 하려면 이 옵션을 비활성화할 수 있습니다.
- 데이터베이스 연결 수준에서는 관련 데이터베이스 연결 문서(*.DbLink, *.DbLib 또는 *.SvnDbLib 파일)의 Field Mapping Region에 파라미터의 업데이트 가능 여부를 제어하는 여러 옵션이 포함되어 있습니다. 여기에는 Update Values, Add to Design 및 Remove from Design이 포함됩니다.
이 대화 상자를 사용하여 프로젝트 전체의 파라미터를 추가, 편집 및 제거할 수 있습니다. 프로젝트의 기존 파라미터를 직접 편집하거나 연결된 데이터베이스(DbLink, DbLib 또는 SvnDbLib 파일을 통해 연결)에서 파라미터를 업데이트하도록 구성할 수 있습니다. 이러한 데이터베이스 라이브러리 연결 유형 파일에는 파라미터의 업데이트 여부를 제어하는 옵션이 포함되어 있습니다. 변경 사항은 이 대화 상자에서 생성한 ECO(Engineering Change Order)를 통해 적용됩니다.
파라미터 추가
새 파라미터를 추가하려면 버튼을 클릭합니다(또는 기본 Grid의 아무 곳이나 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Add Column 명령을 선택합니다). Add Parameter 대화 상자가 열립니다. 객체에 값을 할당하지 않고 새 파라미터만 생성하려면 원하는 이름을 입력하고 OK을 클릭합니다. 모든 객체에 특정 값과 함께 파라미터를 추가하려면 Add to all objects 옵션을 활성화하고 원하는 값을 입력한 다음 OK을 클릭합니다. 새 파라미터의 열이 기존 열의 끝(목록의 맨 오른쪽)에 추가됩니다.
파라미터 이름 변경
파라미터 이름을 변경하려면 이름을 변경할 열의 셀을 마우스 오른쪽 버튼으로 클릭한 다음 드롭다운 메뉴에서 Rename Column 을 선택합니다. Rename Existing Parameter 대화 상자가 열립니다. Enter the new name for the parameter 필드에 새 이름을 입력한 다음 OK을 클릭합니다. 열 머리글이 변경되고 이름 옆에 작은 파란색 삼각형이 표시됩니다. 이 아이콘은 해당 셀의 값이 변경되었음을 나타냅니다.

Rename Existing Parameter 대화 상자
선택한 컴포넌트에 파라미터 추가
컴포넌트에 파라미터를 추가하려면 Parameter Table Editor 대화 상자 Editor에서 Shift+Click 또는 Ctrl+Click 키 조합을 사용하여 셀을 선택하고 마우스 오른쪽 버튼을 클릭한 다음 드롭다운 메뉴에서 Add 을 선택합니다. Add을 선택하면 각 셀에 작은 녹색 더하기 기호가 표시됩니다. 이는 새 파라미터가 추가되었음을 나타냅니다.
이제 파라미터가 추가되었으므로 각 컴포넌트의 컴포넌트 유형을 정의할 수 있습니다. Parameter Table Editor 대화 상자는 표준 표 편집 단축키를 지원합니다. F2을 눌러 셀을 편집한 다음 Enter 을 눌러 편집 내용을 적용할 수 있습니다. 여러 셀을 편집하려면 셀을 선택한 다음 마우스 오른쪽 버튼을 클릭하고 메뉴에서 Edit 을 선택합니다. 새 값을 입력한 다음 Enter 을 눌러 선택한 모든 셀에 편집 내용을 적용합니다.
파라미터 변경 사항 적용
방금 완료한 파라미터 편집 내용은 현재 Parameter Table Editor 대화 상자에만 보관되어 있으며 Schematic 시트의 컴포넌트에는 적용되지 않았습니다. 이러한 변경 사항을 컴포넌트에 적용하려면 ECO를 생성한 다음 설계에 적용해야 합니다. Parameter Table Editor 대화 상자에서 Accept Changes (Create ECO) 버튼을 클릭합니다. Parameter Editor Table 대화 상자가 닫히고 Engineering Change Order 대화 상자가 열립니다.
Validate Changes 버튼을 클릭하여 변경 사항을 적용할 수 있는지 확인합니다. 변경 사항이 유효하면 Check 열에 녹색 체크 표시가 나타납니다.
Execute Changes을 클릭하여 파라미터 변경 사항을 컴포넌트에 적용합니다. 변경 사항이 적용되면 Engineering Change Order 대화 상자를 닫습니다.
)
)







