Supply Chain Database to Workspace Data Synchronization
W skrócie
- Dowiedz się, jak utworzyć konfigurację synchronizacji i podłączyć obsługiwane źródła danych.
- Poznaj sposób mapowania parametrów dostawców i progów cenowych oraz wykorzystania numeru części producenta do powiązania wpisów dostawców z komponentami w przestrzeni roboczej.
- Sprawdź, jak uruchomić synchronizację lub zaplanować jej wykonywanie oraz gdzie znaleźć uzyskane dane niestandardowego dostawcy części w Altium Designer.
Dzięki koncepcji wyboru części części komponentów przechowywane w przestrzeni roboczej Altium 365 lub przestrzeni roboczej Enterprise Server można powiązać z rzeczywistymi częściami oferowanymi przez dostawców na podstawie wskazanej części producenta. Domyślnie te dane łańcucha dostaw są pobierane za pośrednictwem usługi chmurowej Altium Parts Provider i obejmują aktualizowane w czasie rzeczywistym informacje o częściach dostawców, takie jak stany magazynowe, ceny jednostkowe i progi cenowe.
W wielu organizacjach dane o dostawcach komponentów pochodzą jednak (i muszą pochodzić) z wewnętrznego systemu przedsiębiorstwa, który udostępnia własny zestaw danych o dostawcach części — oparty na przykład na ściśle zatwierdzonej grupie dostawców lub specjalnych strukturach cenowych. Taką sytuację obsługuje alternatywne rozwiązanie Altium Custom Parts Provider, które po skonfigurowaniu synchronizacji w Altium Designer umożliwia mapowanie danych dostawców z określonego źródła bazodanowego na dane łańcucha dostaw w przestrzeni roboczej.
Za pomocą funkcji Custom Parts Provider Synchronization w Altium Designer, opisanej poniżej, dane dostawców z wybranej tabeli w nadrzędnej bazie danych są mapowane tak, aby stały się alternatywnym źródłem danych dla części wybieranych dla komponentów w Altium Designer. W praktyce utworzona konfiguracja mapowania służy do synchronizacji źródłowej bazy danych z danymi dostawców w przestrzeni roboczej — według harmonogramu lub na żądanie. W rezultacie aktualizacje danych dostawców w nadrzędnej bazie danych są przenoszone do odpowiadających im danych dostawców komponentów w połączonej przestrzeni roboczej.
Funkcja ta pozwala firmom, które centralnie zarządzają danymi dostawców komponentów w bazie danych systemu przedsiębiorstwa, korzystać z zalet przestrzeni roboczej Altium przy jednoczesnym zachowaniu synchronizacji z systemem przedsiębiorstwa (PLM, PDM, ERP itp.) — lub po prostu ze współdzieloną bazą danych albo plikiem CSV. W trybie automatycznej synchronizacji zadanie w Harmonogramie zadań systemu Windows aktualizuje dane w przestrzeni roboczej na podstawie bazy danych niezależnie od aplikacji projektowej Altium Designer.
-
Informacje na temat importowania bibliotek bazodanowych do przestrzeni roboczej można znaleźć w artykule Importowanie istniejących bibliotek do połączonej przestrzeni roboczej.
-
Informacje o powiązanym procesie synchronizacji parametrów komponentów w przestrzeni roboczej ze źródłową bazą danych można znaleźć w artykule Synchronizacja danych między bazą danych komponentów a przestrzenią roboczą.
Tworzenie konfiguracji synchronizacji niestandardowego dostawcy części
Synchronizację danych dostawców części między bazą danych a przestrzenią roboczą konfiguruje się przez utworzenie i skonfigurowanie dokumentu Custom Parts Provider Synchronization Configuration (*.PrtSync) w Altium Designer. Interfejs dokumentu i jego funkcjonalność są podobne do interfejsu i funkcjonalności narzędzia Components Synchronizer. Po połączeniu z przestrzenią roboczą Altium utwórz nowy dokument za pomocą polecenia menu File » New » Custom Parts Provider Synchronization Configuration.
Dodaj wybrane nadrzędne źródło danych do konfiguracji synchronizacji za pomocą przycisku
lub przeciągając zgodne pliki danych do obszaru Data Sources interfejsu. Konfiguracja obsługuje następujące źródła danych parametrów komponentów:
-
Pliki baz danych Access (
*.mdb,*.accdb) -
Arkusze kalkulacyjne Excel (
*.xlsx) -
Pliki CSV (
*.csv) -
Inne źródła danych, takie jak interfejsy serwerowe zgodne z OLE DB (w tym bazy danych PostgreSQL), za pośrednictwem odpowiedniego ciągu połączenia. Procedurę nawiązywania połączenia ODBC z MySQL opisano poniżej w sekcji Konfiguracja MySQL.
W przedstawionym tutaj przykładzie do konfiguracji dodano bazę danych zawierającą dane dostawców części (diod Zenera). Źródłowa baza danych (SupplierData.mdb) zawiera dwie tabele — CustomSupplierParts1 i CustomSupplierParts2 — z których pierwsza jest włączona do mapowania i synchronizacji.
Procedura konfiguracji ODBC dla MySQL
Synchronizację niestandardowego dostawcy części z bazą danych MySQL konfiguruje się przy użyciu Microsoft OLE DB Provider for ODBC w aplikacji MySQL Connector/ODB. Procedura nawiązywania połączenia i konfiguracji wygląda następująco:
-
Pobierz i zainstaluj MySQL Connector, dostępny po wybraniu opcji instalacji niestandardowej w MySQL Installer 8. Następnie uruchom aplikację ODB Data Sources systemu Windows, aby dodać typ MySQL ODBC ANSI Driver, określ źródło MySQL i bazę danych w MYSQL Connector i potwierdź nowo dodane źródło danych ODB.
-
Utwórz nową konfigurację Parts Sync w Altium Designer (File » New » Custom Parts Provider Synchronization Configuration) i wybierz opcję Use Connection String z menu
.
-
W wyświetlonym oknie dialogowym Data Link Properties wybierz opcję
Microsoft OLER DB Provider for ODBC Driversna karcie Provider, kliknij Next, a następnie na karcie Connection wprowadź dane źródła danych określone powyżej w Step 1. -
Włącz wybraną tabelę bazy danych MySQL w panelu Properties w Altium Designer.
-
Wybierz tabelę bazy danych w hierarchii Data Source, a następnie w razie potrzeby zmapuj kolumny danych na parametry Altium w panelu Properties.
Mapowanie parametrów danych dostawców
Nowa konfiguracja niestandardowego dostawcy części uzyskuje dostęp do tabeli bazy danych jako do źródła danych parametrów. Po wybraniu tabeli w drzewie Data Sources konfiguracji można zmapować ją na standardowe parametry danych dostawców używane przez Altium Designer i przestrzeń roboczą Altium.
Parametry danych dostawców są mapowane ze źródłowej bazy danych do konfiguracji dostawcy części w obszarze Parameter Mapping panelu Properties. Użyj opcji menu rozwijanego wpisu Column, aby wybrać parametr źródłowej bazy danych odpowiadający parametrowi danych dostawców lub usunąć parametr z synchronizacji (<Skip>). Każdy zestaw danych parametrów jest dodawany do listy Components Preview w trakcie mapowania. Kolejność tych kolumn można zmieniać, przeciągając ich nagłówki, a włączać i wyłączać je można za pomocą menu Select Columns (dostępnego po kliknięciu nagłówka prawym przyciskiem myszy).
Obsługiwanych jest wiele systemowych parametrów danych dostawców, w tym Manufacturer Name, Manufacturer Part Number, Category, Datasheet itd. Możesz również dodawać i usuwać niestandardowe parametry danych dostawców za pomocą przycisków
i
w obszarze Parameter Mapping panelu Properties.
Progi cenowe komponentów określają liczbę komponentów, które należy zamówić u dostawcy, aby uzyskać niższą cenę jednostkową. Wymagane wielkości zamówień są zazwyczaj uporządkowane według kolejnych potęg dziesięciu — 10 sztuk, 100 sztuk itd. — i są obsługiwane we wpisach wyboru części w danych dostawców Altium.
Te dane liczbowe można mapować z wpisów źródłowej bazy danych na dane dostawców w przestrzeni roboczej, dodając wpisy Quantity progów cenowych w sekcji Price Breaks panelu Properties — odpowiadające kolejnym ilościom zwiększanym dziesięciokrotnie — a następnie mapując te wpisy na odpowiednie pola bazy danych. Należy pamiętać, że standardowy parametr kosztu unit (Price) znajduje się w ogólnej sekcji Parameter Mapping.
Synchronizacja bazy danych z przestrzenią roboczą
Po skonfigurowaniu mapowania danych dostawców zapisz dokument konfiguracji niestandardowego dostawcy części (File » Save) i uruchom synchronizację danych źródłowej bazy danych z serwerem za pomocą przycisku
lub skonfiguruj synchronizację według harmonogramu Pierwsza synchronizacja prześle zmapowane dane dostawców z firmowej bazy danych do przestrzeni roboczej Altium, a kolejne cykle synchronizacji będą aktualizować te dane.
W pokazanym przykładzie dane dostawców dotyczące diod Zenera, zsynchronizowane ze źródłowej bazy danych z przestrzenią roboczą, stają się dostępne jako dane Custom Parts Provider tych komponentów — obok standardowych danych dostawców części udostępnianych przez usługę chmurową Altium Parts Provider.
Można to od razu zaobserwować w panelu Manufacturer Part Search po wybraniu kategorii Custom Parts Provider. Panel wyświetli opcje zaopatrzenia w komponenty udostępniane przez usługę Custom Parts Provider, zsynchronizowane z bazą danych dostawców Twojej organizacji.
Scalanie danych dostawców
Jeśli nazwa producenta i numer części producenta w zsynchronizowanej bazie danych dostawców są takie same jak nazwa producenta i numer części producenta udostępniane przez Altium Parts Provider, dane dostawców ze skonfigurowanej usługi Custom Parts Provider są scalane z danymi Altium Parts Provider. Dzięki temu wszystkie informacje o dostawcach są prezentowane łącznie wszędzie tam, gdzie w interfejsie oprogramowania wyświetlane są dane dostawców (SPN), w tym w panelu Manufacturer Part Search, w ActiveBOM oraz podczas dodawania wyborów części.
Wybory części na podstawie danych niestandardowego dostawcy
Podczas dodawania informacji o wyborach części do wpisów komponentów w panelu Components (kliknięcie prawym przyciskiem myszy, Operations » Create/Edit PCL) dane dostawców udostępniane przez Custom Parts Provider pojawią się na początku listy w oknie dialogowym Add Part Choices — jak pokazano tutaj dla wpisu diody Zenera 1N4747A. Wybrany (podświetlony) wpis zostanie dodany jako wybór części dla wybranego komponentu w panelu Components.
Podobnie jak usługa Altium Parts Provider, usługa Custom Parts Provider również obsługuje dane dostawców dotyczące wielu producentów i pochodzące od wielu dostawców — dane te są pobierane z wielu osobnych wpisów w tabeli źródłowej bazy danych. Należy również pamiętać, że dane niestandardowego dostawcy będą zawierać informacje o progach cenowych i stanach magazynowych zsynchronizowane ze źródłowej bazy danych.
Oprócz pokazanego tutaj panelu Components, wybory części od dostawców komponentów można przypisywać do odwołania do komponentu w następujących interfejsach Altium Designer:
Synchronizacja według harmonogramu
Zapisane konfiguracje synchronizacji części można skonfigurować do automatycznego przetwarzania danych z bazy danych do przestrzeni roboczej w oknie dialogowym Auto Synchronization Schedule, otwieranym przyciskiem
w głównym interfejsie.
Synchronizację według harmonogramu, zgodną z bieżącym profilem konfiguracji, można ustawić na określoną godzinę każdego dnia, na określoną godzinę w wybrane dni tygodnia lub na moment logowania do systemu Windows. Możesz również wyłączyć synchronizację na czas, gdy nie jesteś zalogowany. Po zatwierdzeniu ustawień przyciskiem
konfiguracja zostanie dodana jako zadanie cykliczne w Windows Task Scheduler. Wybierz ustawienie No automatic synchronization, aby usunąć istniejący harmonogram synchronizacji.
Synchronizację danych z bazy danych z danymi części można również uruchomić ręcznie z wiersza poleceń za pomocą aplikacji ComponentSync.Executor.exe, znajdującej się w folderze \System instalacji oprogramowania. Składnia polecenia to ComponentSync.Executor.exe [configuration file name]. Na poniższym obrazie uruchomiono konfigurację MyPrtSyncConfig z tego przykładu, używając następującego ciągu polecenia:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync








).


