Импорт существующих библиотек в ваш подключенный Workspace
Краткий обзор
- Узнайте, как открыть инструмент импорта библиотек и выбрать простой или расширенный режим.
- Разберитесь, какие библиотеки и данные компонентов можно импортировать и какие основные ограничения при этом действуют.
- Ознакомьтесь с предварительным просмотром результатов импорта, классификацией компонентов, настройками параметров и отчетами, которые помогут проверить и скорректировать импорт.
Altium Designer совместно с подключенным рабочим пространством обеспечивает простой и высокоавтоматизированный процесс быстрого импорта существующих библиотек в это рабочее пространство. Интерфейс этого процесса — Library Importer — позволяет одним щелчком автоматически проанализировать выбранные библиотеки и импортировать их в рабочее пространство, к которому вы подключены в данный момент.
Инструмент импорта библиотек Library Importer поддерживает все типы библиотек, используемые в прежних подходах к управлению компонентами (SchLib, PcbLib, IntLib, DbLib, SVNDbLib), и предназначен для быстрого создания корпоративной библиотеки компонентов в рабочем пространстве. Это позволяет воспользоваться всеми ее преимуществами: высокой целостностью данных, централизованным хранением и управлением, удобством повторного использования проектных решений и актуальной информацией о цепочке поставок.
Library Importer предлагает минималистичный режим интерфейса Simple, в котором выбранные файловые библиотеки и библиотеки на основе баз данных импортируются в компоненты рабочего пространства за один шаг. При этом инструмент автоматически определяет типы компонентов, целевую папку исходных данных, состав параметров и типы их значений, а также переносит все необходимые данные. Также доступен режим интерфейса Advanced, который позволяет предварительно просмотреть все результаты планируемого импорта библиотек и получить доступ к связанным данным и настройкам. Хотя по умолчанию импорт выполняется одним щелчком, Library Importer также предоставляет расширенные настройки на панели Properties, позволяя точнее управлять процессом импорта.
Что импортируется?
В компоненты рабочего пространства импортируется вся информация из исходной библиотеки, включая все связанные модели (схемные символы, посадочные места на печатной плате, модели для моделирования), параметры, назначенные варианты комплектующих, файлы технической документации и т. д. При необходимости также создаются шаблоны компонентов, которые затем можно доработать и использовать при последующих импортах библиотек.
Если для исходных компонентов задано несколько посадочных мест на печатной плате, Library Importer перенесет эти модели и сохранит текущее посадочное место по умолчанию. Если вы работаете только с библиотеками посадочных мест, то есть занимаетесь исключительно проектированием печатных плат, Library Importer позволяет импортировать только эти библиотеки. Кроме того, можно включить режим импорта только моделей, в котором модели указанных типов импортируются из интегрированных библиотек или библиотек на основе баз данных. Библиотеки, содержащие несколько типов компонентов (монолитные библиотеки), также распознаются и обрабатываются автоматически.
Хотя при импорте приходится работать с файловыми библиотеками и библиотеками на основе баз данных, использующими различные стандарты форматирования, автоматический анализ позволяет определить типы компонентов в исходной библиотеке (резисторы, конденсаторы и т. д.), а также имена параметров и типы их значений (вольты, омы и т. д.). Система выполняет ряд проверок: например, проверяет отсутствие повторяющихся идентификаторов у создаваемых компонентов библиотеки рабочего пространства, предотвращает создание дубликатов моделей и шаблонов компонентов и при необходимости обеспечивает повторное использование этих объектов за счет связи с соответствующими компонентами. Если возникают проблемы, система отмечает их и предлагает способы устранения, чтобы импорт можно было продолжить как можно быстрее и без затруднений.
Поддерживается импорт следующих типов библиотек:
-
Библиотека схемных символов (
*.SchLib). -
Библиотека посадочных мест на печатной плате (
*.PcbLib). -
Интегрированная библиотека (
*.IntLib) -
Библиотека на основе базы данных (
*.DbLib). -
Библиотека на основе базы данных SVN (
*.SVNDbLib).
Доступ к Library Importer
Library Importer доступен при подключении к рабочему пространству. Чтобы открыть инструмент в режиме Simple:
-
На панели Components выберите пункт Import Library в меню
. Если в столбце Categories панели (или в верхнем раскрывающемся списке, когда панель находится в компактном режиме) выбрана файловая библиотека или библиотека на основе базы данных, Library Importer откроется для этой библиотеки. Если выбран тип компонентов библиотеки рабочего пространства, откроется стандартное диалоговое окно Windows Open, в котором можно найти и выбрать файл библиотеки для импорта.
-
Щелкните правой кнопкой мыши файл библиотеки на панели Projects и выберите Import Library в контекстном меню.
-
Выберите Tools » Import Library в редакторе схемных символов или посадочных мест на печатной плате, когда открыт файл локальной библиотеки.
-
Выберите File » Import Library или Tools » Import Library в редакторе библиотек на основе баз данных.
-
В диалоговом окне Libraries Preferences выберите запись библиотеки на вкладке Installed, затем нажмите Import.
-
Перетащите файл библиотеки из папки Windows на панель Explorer.
Простой режим позволяет сразу импортировать выбранную библиотеку или открыть Library Importer в режиме полного графического интерфейса

Library Importer в режиме Simple, позволяющем выполнить импорт одним щелчком.
Чтобы сразу открыть Library Importer в режиме интерфейса Advanced, выберите File » Library Importer в главном меню.

Library Importer в режиме полного интерфейса Advanced также поддерживает импорт одним щелчком.
Простой режим
В простом режиме Library Importer заранее задает все настройки импорта на основе анализа исходной библиотеки и подключенного рабочего пространства. Затем в диалоговом окне Library Importer отображается сводка структуры импорта, включая общее количество объектов каждого типа. Импорт библиотеки выполняется за один шаг с помощью команды
.
Этот простой режим интерфейса подходит для большинства распространенных форматов исходных библиотек, которые обычно содержат стандартные типы компонентов (резисторы, конденсаторы, интегральные схемы и т. д.) и стандартизированные значения параметров. В ходе первоначального анализа система определяет тип компонентов в библиотеке по позиционным обозначениям или ключевым словам параметров (LD?, LED и т. д.), а затем находит соответствующий шаблон компонента в целевом рабочем пространстве (например, LED). Этот шаблон применяется при импорте соответствующих компонентов и определяет такие настройки, как целевая папка (Components/LED), сопоставление параметров, единицы измерения значений параметров и т. д. Подходящие шаблоны доступны в рабочем пространстве, если при активации рабочего пространства Altium 365 или установке Altium On-Prem Enterprise Server был выбран вариант с добавлением демонстрационных данных.
Результаты импорта библиотеки в виде вновь созданных компонентов рабочего пространства можно увидеть на панелях Explorer и Components. Импортированные компоненты включают все модели, параметры, интерпретированные в соответствии с применёнными шаблонами компонентов, варианты выбора компонентов, полученные из исходных данных ссылок на поставщиков, а также все справочные ссылки и файлы.
Важные особенности процесса импорта библиотек:
-
Монолитные библиотеки (содержащие компоненты нескольких типов) автоматически разделяются на подгруппы, каждая из которых соответствует одному из типов компонентов, обнаруженных в библиотеке. Эти группы обрабатываются как отдельные библиотеки.
-
Исходная библиотека с нераспознанным (неопределённым) типом компонентов будет импортирована без интерпретации: компоненты без назначенного типа будут помещены в папку
Components/Uncategorizedрабочего пространства. До запуска импорта эту проблему можно устранить, применив сопоставление позиционных обозначений или группировку по параметрам в режиме Advanced (полный интерфейс). Другой вариант — выполнить импорт, а затем изменить настройки и папку компонента на панели Explorer. - Процесс импорта библиотеки включает этап автоматической проверки компонентов. Компоненты, вызвавшие ошибку проверки, будут пропущены.
- Если в импортируемой исходной библиотеке обнаружены дублирующиеся модели, будет импортирована только одна из них. Она будет связана с созданными компонентами в целевом рабочем пространстве. Соответствующее уведомление появится в верхней части диалогового окна Library Importer.
-
Все ошибки, возникшие в ходе процесса, можно просмотреть в Importing Report, доступном по кнопке
после завершения импорта.
Расширенный режим
Полный графический интерфейс Library Importer отображается в режиме Advanced, который предоставляет подробные средства управления библиотеками, типами компонентов и их параметрами. В сочетании с панелью Properties он позволяет настроить импорт библиотек компонентов в рабочее пространство под ваши конкретные задачи. Настройки средства импорта можно сохранять и восстанавливать путём экспорта и импорта файлов конфигурации.
Расширенный режим включается при открытии Library Importer командой File » Library Importer или при нажатии кнопки
в простом режиме. Библиотеки добавляются в раздел SOURCE LIBRARIES средства импорта (если он ещё не заполнен) перетаскиванием файла библиотеки в эту область, щелчком правой кнопкой мыши по <All Libraries> с последующим выбором пункта Add Library в контекстном меню или нажатием кнопки
.
В разделе Import Preview перечислены группы типов компонентов, определённые по исходным библиотекам, — как Types или предлагаемые Folder Structure , — а также представлена таблица параметров этих компонентов (Components). Значения параметров в таблице можно редактировать непосредственно, без открытия и изменения исходной библиотеки. Нижняя область Details содержит дополнительную информацию о выбранном компоненте: варианты выбора компонентов, модели и технические описания.
Несмотря на наличие подробных настроек и данных в интерфейсе, расширенный режим средства импорта можно использовать так же, как и простой: достаточно нажать кнопку
, чтобы запустить импорт без дополнительных действий. Как и в простом режиме, средство импорта анализирует библиотеку, определяет тип содержащихся в ней компонентов и применяет подходящий шаблон компонента. В свою очередь, шаблон определяет целевую папку рабочего пространства, применяемые схемы именования и определения жизненного цикла, а также сопоставление и интерпретацию параметров.
Монолитные библиотеки
Исходные библиотеки, содержащие компоненты нескольких типов, выявляются алгоритмами анализа средства импорта и разделяются на группы подбиблиотек, которые можно обрабатывать как отдельные библиотеки компонентов одного типа. Тип компонентов определяется по позиционным обозначениям исходных компонентов (R?, C? и т. д.), а также по ключевым словам (Resistor, Res и т. д.) в других основных параметрах компонентов (описании, идентификаторе и т. д.).
В приведённом ниже примере исходная библиотека (ProjectABC.IntLib) автоматически «разделена» по обнаруженным типам компонентов (конденсаторы, резисторы и т. д.). Их можно выбирать в столбце Folder Structure (или столбце Types), чтобы просматривать входящие в них компоненты в таблице Components.
Отображение списка Components можно изменить несколькими способами:
-
Щёлкните заголовок столбца, чтобы отсортировать список по этому параметру, а затем щёлкните ещё раз, чтобы изменить порядок сортировки на обратный.
-
В контекстном меню заголовка, открываемом правой кнопкой мыши:
-
Выберите Clear Sorting, чтобы восстановить порядок сортировки по умолчанию (по столбцу Name по возрастанию).
-
Выберите Best Fit, чтобы подогнать ширину определённого столбца под его содержимое.
-
Выберите Select Best Fit All Columns, чтобы подогнать ширину всех доступных столбцов под их содержимое.
-
Выберите Select Columns, чтобы открыть диалоговое окно Select Columns, в котором можно включать и отключать столбцы параметров, а также изменять их порядок в списке.
-
-
Щёлкните значок фильтра в заголовке, чтобы ограничить список доступным значением параметра столбца, пустыми или непустыми значениями либо условием фильтра Custom. Применённый фильтр отображается внизу списка, где его можно включить или отключить соответствующим флажком, изменить в Filter Editor или удалить. Выбор All через значок фильтра в заголовке также удаляет применённый фильтр.
Компоненты без категории
Если одна из подгрупп библиотеки называется Uncategorized (и отображается как Uncategorized в Types или Folder Structure и сопровождается значком
значок), это означает, что средство импорта не смогло определить и назначить тип этой группе компонентов — для параметра Component Type фактически установлено значение None. В данном случае компоненты, тип которых не удалось определить (логические ИС инверторов), используют нераспознанный префикс позиционного обозначения (U?), а их параметры не содержат распознаваемых ключевых слов, таких как IC, logic и т. д.
Эту проблему можно решить, вручную сопоставив позиционные обозначения этих компонентов с нужным типом компонента в диалоговом окне Library Splitting, которое открывается кнопкой
, доступной при выборе исходной библиотеки (ProjectABC.IntLib). Диалоговое окно Library Splitting с настройками по умолчанию позволяет задать пользовательские правила группировки компонентов без категории в библиотеке на основе сопоставления позиционных обозначений с типами компонентов и разделения по параметрам.
Выбрав в диалоговом окне параметр Map Designators , выберите подходящий тип для компонентов без категории в раскрывающемся списке Component Type (он содержит все доступные типы компонентов). Подтвердите настроенное сопоставление типа с позиционными обозначениями (тип компонента Logic и позиционные обозначения U?) кнопкой
.
Теперь, когда тип компонента определён с помощью заданного сопоставления, средство импорта будет использовать соответствующий шаблон компонента (Logic) для настройки импорта библиотеки в соответствии с параметрами шаблона (папка, правила именования и т. д.).
Обратите внимание: благодаря гибкости настроек Library Importer библиотеку компонентов нового типа (без категории) можно импортировать со всей инфраструктурой, необходимой для последующих импортов библиотек этого типа. После выбора подходящей конфигурации импорта — нового типа компонента, шаблона компонента, целевой папки, сопоставления параметров и типов единиц измерения значений параметров — для следующего импорта библиотеки этого типа потребуется лишь выбрать ранее определённый тип компонента. Выбранный тип компонента определит все остальные настройки импорта.
Исключение из импорта
Вы также можете исключить из импорта определённые типы компонентов. Для этого в списке Types щёлкните правой кнопкой мыши тип компонента, который нужно исключить, и выберите Exclude from Importer в контекстном меню. При необходимости измените отображение списка с Folder Structure на Types
Исключённый тип компонента будет отображаться серым цветом в списке Types. Чтобы просмотреть исключённые компоненты в таблице, нажмите Show Excluded Component (n), где n обозначает количество исключённых компонентов.
Включение в импорт
Если вы исключили тип компонента из импорта с помощью описанной выше команды Exclude from Importer и всё же хотите включить его, щёлкните правой кнопкой мыши тип компонента, отображаемый серым цветом в списке Types (или Folder Structure), и выберите Include to Importer в контекстном меню. Тип компонента снова появится в списке Types, что означает, что он больше не исключён из импорта.
Ошибки и предупреждения проверки
Компоненты, которые будут импортированы в рабочее пространство некорректно или не будут импортированы вовсе, отмечаются значками предупреждений или ошибок в расширенном интерфейсе при запуске Library Importer или выполнении проверки импорта Проверка также выявляет пустые пути к папкам рабочего пространства, конфликты системных параметров и дубликаты моделей. Критическая ошибка блокирует импорт.
При попытке выполнить импорт панель Messages заполняется обнаруженными нарушениями, а в диалоговом окне предлагается отменить импорт или продолжить его с текущей конфигурацией. В последнем случае некорректные компоненты не будут импортированы либо процесс импорта завершится с ошибкой.
При отмене импорта или запуске проверки вручную все компоненты, не прошедшие проверки импорта, помечаются значками ошибок/предупреждений, а в нижней области Details отображается дополнительная информация. Значки в столбце Status области предварительного просмотра указывают на конкретные записи компонентов, нарушающие правила проверки импорта.
Ниже перечислены встроенные проверки.
Слишком длинное описание компонента
Report mode:
Общие сведения
Это нарушение возникает, если описание импортируемого компонента содержит более 256 символов.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<ComponentName> description more then 256 characters.
где:
-
ComponentName— имя компонента, вызвавшего нарушение.
Рекомендации по устранению
Измените описание компонента в исходной библиотеке так, чтобы оно не превышало ограничение по длине.
Ошибки шаблона компонента
Report mode:
Общие сведения
Это нарушение возникает при наличии ошибки в шаблоне компонента, применённом к импортируемым компонентам.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Component template has errors: <Descripion>
где:
-
Descripion— описание ошибки шаблона компонента.
Рекомендации по устранению
На основании описания ошибки найдите и исправьте её в исходной библиотеке или в конфигурации импорта библиотеки.
Дублирующийся HRID компонента
Report mode:
Общие сведения
Это нарушение возникает, если идентификаторы элементов импортируемых компонентов совпадают.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<ComponentName1> component HRID is duplicated with <ComponentName2> component HRID.
где:
-
ComponentName1иComponentName2— имена компонентов, вызвавших нарушение.
Рекомендации по устранению
В области Parameter Mapping панели Properties убедитесь, что параметр ID сопоставлен с параметром исходной библиотеки, имеющим уникальные значения для компонентов, вызвавших нарушение. Также можно задать для этого параметра сопоставление с <Auto> — в таком случае идентификаторы элементов компонентов будут назначаться автоматически на основе Naming Scheme, указанного в области Component панели (на вкладке Advanced).
Кроме того, убедитесь, что параметр, выбранный в качестве идентификатора элемента, имеет уникальное значение для каждого компонента с нарушением в исходной библиотеке.
Одинаковая геометрия моделей
Report mode:
Описание
Это нарушение возникает, когда импортируемые компоненты имеют модели условных графических обозначений с одинаковой геометрией в исходных библиотеках.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<SymbolModelName1> model has the same geometry as <SymbolModelName2> in your source library. Imported components will be linked to <SymbolModelName2>
где:
-
SymbolModelName1иSymbolModelName2— имена моделей условных графических обозначений с нарушением.
Пустой HRID компонента
Report mode:
Описание
Это нарушение возникает, когда идентификатор элемента импортируемого компонента пуст.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<ComponentName> component HRID is empty.
где:
-
ComponentName— имя компонента с нарушением.
Рекомендации по устранению
В области Parameter Mapping панели Properties убедитесь, что параметр ID сопоставлен с параметром исходной библиотеки, имеющим значение для компонента с нарушением. Также можно задать для этого параметра сопоставление с <Auto> — в этом случае идентификатор элемента компонента будет задан автоматически на основе Naming Scheme, указанного в области Component панели (на вкладке Advanced).
Кроме того, убедитесь, что выбранный параметр имеет значение в исходной библиотеке.
В настройках сущности не задано определение жизненного цикла
Report mode:
Описание
Это нарушение возникает, когда исходная библиотека содержит данные, типу которых не назначено определение жизненного цикла.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Lifecycle Definition.
где:
-
ContentType— тип данных (например, компонент или условное графическое обозначение), которому не назначено определение жизненного цикла. -
LibraryName— имя исходной библиотеки, содержащей данные, типу которых не назначено определение жизненного цикла. -
LibraryType— имя группы подбиблиотек, содержащей данные, типу которых не назначено определение жизненного цикла.
Рекомендации по устранению
Убедитесь, что в раскрывающемся списке Lifecycle Definition для типа данных с нарушением на панели Properties (на вкладке Advanced) выбрано определение жизненного цикла. Если в раскрывающемся списке есть доступные варианты, убедитесь, что типу данных с нарушением назначено определение жизненного цикла. Подробнее см. на странице Создание определений жизненного цикла для рабочего пространства.
В настройках сущности не задана схема именования ревизий
Report mode:
Описание
Это нарушение возникает, когда исходная библиотека содержит данные, типу которых не назначена схема именования ревизий.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Revision Naming Scheme.
где:
-
ContentType— тип данных (например, компонент или условное графическое обозначение), которому не назначена схема именования ревизий. -
LibraryName— имя исходной библиотеки, содержащей данные, типу которых не назначена схема именования ревизий. -
LibraryType— имя группы подбиблиотек, содержащей данные, типу которых не назначена схема именования ревизий.
Рекомендации по устранению
Убедитесь, что в раскрывающемся списке Схема именования ревизий для типа данных с нарушением на панели Properties (на вкладке Advanced) выбрано определение жизненного цикла. Если в раскрывающемся списке есть доступные варианты, убедитесь, что типу данных с нарушением назначена схема именования ревизий. Подробнее см. на странице Создание схем именования ревизий для рабочего пространства.
Папка не существует
Report mode:
Описание
Это нарушение возникает, когда папка, в которую должны быть импортированы данные, отсутствует в подключенном рабочем пространстве.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Folder '<FolderPath>' does not exist
где:
-
FolderPath— путь к целевой папке, которая отсутствует в подключенном рабочем пространстве.
Рекомендации по устранению
На панели Properties укажите целевую папку, нажав кнопку
справа от поля Folder для данных, которые будут сохранены в рабочем пространстве. В открывшемся диалоговом окне Choose Folder найдите и выберите существующую папку или создайте новую.
Посадочное место не найдено в доступных библиотеках
Report mode:
Описание
Это нарушение возникает, когда у компонента есть связанное посадочное место, которое не удается найти в доступных библиотеках.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Footprint <FootprintName> is not found in available libraries. Any referenced footprints can only be found if the relevant PcbLib(s) are either installed, or are added to the Library Importer directly.
где:
-
FootprintName— имя отсутствующего посадочного места.
Рекомендации по устранению
Добавьте библиотеки, содержащие связанные посадочные места, в средство импорта библиотек. Для этого выберите компонент с этим нарушением в области Components и нажмите элемент управления Choose a Library в области Details.
Кроме того, убедитесь, что библиотеки, содержащие посадочные места, связанные с импортируемыми компонентами, установлены (подробнее об установленных библиотеках см. на странице Поиск компонентов в библиотеках на основе баз данных и файлов), или измените ссылку на посадочное место в исходной библиотеке.
Подробнее см. в разделе Импорт библиотек схемных компонентов.
Некорректное сопоставление параметров
Report mode:
Описание
Это нарушение возникает при ошибке в настройке сопоставления параметров.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Parameter mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
где:
-
LibraryName— имя исходной библиотеки, в которой найден компонент с некорректным сопоставлением параметров. -
LibraryType— имя группы подбиблиотек, в которой найден компонент с некорректным сопоставлением параметров. -
Descripion— описание нарушения сопоставления параметров.
Рекомендации по устранению
В области Parameter Mapping панели Properties найдите параметры со значком
и исправьте их сопоставление. Также можно удалить записи сопоставления с ошибками.
Элемент с таким HRID уже выпущен
Report mode:
Краткое описание
Это нарушение возникает, когда идентификатор элемента импортируемого компонента совпадает с идентификатором элемента, уже существующего в целевом рабочем пространстве.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Item with HRID <ItemID> already released.
где:
-
ItemID— идентификатор элемента в рабочем пространстве.
Рекомендации по устранению
В области Parameter Mapping панели Properties убедитесь, что параметр ID сопоставлен с параметром исходной библиотеки, имеющим уникальное значение. Также можно задать для этого параметра сопоставление с <Auto> — в этом случае идентификатор элемента компонента будет задан автоматически на основе Naming Scheme, указанной в области Component панели (на вкладке Advanced). При этом убедитесь, что Naming Scheme настроена на создание уникальных идентификаторов элементов.
Другой вариант — убедиться, что параметр, выбранный в качестве идентификатора элемента, имеет уникальное значение в исходной библиотеке.
Не найдено определение жизненного цикла для импорта технических описаний
Report mode:
Краткое описание
Это нарушение возникает, когда исходная библиотека содержит компоненты со связанными техническими описаниями, а тип содержимого Datasheet не назначен определению жизненного цикла.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Lifecycle Definition to import <LibraryName>.<LibraryType> library datasheets is not found.
где:
-
LibraryName— имя исходной библиотеки, компоненты которой содержат технические описания. -
LibraryType— имя группы подбиблиотек, компоненты которой содержат технические описания.
Рекомендации по устранению
Убедитесь, что тип содержимого Datasheet назначен определению жизненного цикла. Подробнее см. на странице Настройка определений жизненного цикла для рабочего пространства.
Также можно отключить импорт файлов технических описаний, изменив параметр Migrate в области Datasheet панели Properties (на вкладке Advanced).
Слишком длинное описание модели
Report mode:
Краткое описание
Это нарушение возникает, когда описание модели компонента содержит более 256 символов.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Description of Model '<ModelName>' of component '<ComponentName>' more then 256 characters.
где:
-
ModelName— имя модели, вызвавшей нарушение. -
ComponentName— имя компонента, содержащего модель, вызвавшую нарушение.
Рекомендации по устранению
Отредактируйте описание модели в исходной библиотеке так, чтобы его длина не превышала установленное ограничение.
Значение обязательного параметра не задано
Report mode:
Краткое описание
Это нарушение возникает, когда в связанном шаблоне компонента есть параметр, отмеченный как обязательный, но в исходной библиотеке его значение не задано.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<ParameterName> required parameter value in component <ComponentName> is empty.
где:
-
ParameterName— имя параметра, вызвавшего нарушение. -
ComponentName— имя компонента, содержащего параметр, вызвавший нарушение.
Рекомендации по устранению
Задайте значение параметра, вызвавшего нарушение, в исходной библиотеке или непосредственно в табличной области средства импорта библиотек. Также можно изменить сопоставление параметров в области Parameter Mapping панели Properties (на вкладке General), чтобы обязательный параметр был сопоставлен с параметром исходной библиотеки, имеющим значение.
Не найдена схема именования ревизий для импорта технических описаний
Report mode:
Краткое описание
Это нарушение возникает, когда исходная библиотека содержит компоненты со связанными техническими описаниями, а тип содержимого Datasheet не назначен схеме именования ревизий.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Revision Naming Scheme to import <LibraryName>.<LibraryType> library datasheets is not found.
где:
-
LibraryName— имя исходной библиотеки, компоненты которой содержат технические описания. -
LibraryType— имя группы подбиблиотек, компоненты которой содержат технические описания.
Рекомендации по устранению
Убедитесь, что тип содержимого Datasheet назначен схеме именования ревизий. Подробнее см. на странице Настройка схем именования ревизий для рабочего пространства.
Также можно отключить импорт файлов технических описаний, изменив параметр Migrate в области Datasheet панели Properties (на вкладке Advanced).
Файл модели для моделирования не найден
Report mode:
Краткое описание
Это нарушение возникает, когда у компонента есть связанная модель для моделирования, которую не удается найти по указанному пути.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Simulation model file <Path> is not found.
где:
-
Path— указанный путь к модели для моделирования.
Рекомендации по устранению
Убедитесь, что модель для моделирования находится по указанному пути. Также можно обновить путь к модели в исходной библиотеке.
Имя условного обозначения не может быть пустым
Report mode:
Краткое описание
Это нарушение возникает, когда у компонента нет связанного условного обозначения.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Symbol name cannot be empty.
Рекомендации по устранению
Убедитесь, что в исходной библиотеке для компонента корректно задана ссылка на условное обозначение.
У вас нет прав на изменение папки
Report mode:
Краткое описание
Это нарушение возникает, если у вас нет прав на запись в целевую папку в подключенном рабочем пространстве.
Уведомление
На панели Messages отображается уведомление в следующем формате:
You do not have access right to modify folder <FolderPath>.
где:
-
FolderPath— путь к целевой папке в подключенном рабочем пространстве, для которой у вас нет прав на редактирование.
Рекомендации по устранению
Попросите администратора вашего рабочего пространства предоставить вам права на запись в эту папку (подробнее см. на странице Управление доступом к содержимому рабочего пространства).
Также можно выбрать на панели Properties другую папку, для которой у вас есть права на запись. Нажмите кнопку
справа от поля Folder для содержимого, которое будет сохранено в рабочем пространстве, и в открывшемся диалоговом окне Choose Folder найдите и выберите существующую папку или создайте новую.
Пользовательские проверки настраиваются в области Import Checks панели Properties. Используйте раскрывающееся меню Report Mode, чтобы выбрать другой уровень сообщения для соответствующего типа нарушения. Эти проверки перечислены ниже.
Дублирование компонента по параметру
Default report mode:
Общие сведения
Это нарушение возникает, если у компонента из импортируемых исходных библиотек есть параметр, значение которого должно быть уникальным, а в целевом рабочем пространстве уже есть компонент с таким же значением этого параметра. Подробнее см. в разделе Обнаружение дубликатов.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Component <ComponentName> is duplicated with components by parameter <ParameterName> (<ParameterValue>):
- Server components: <WorkspaceComponentList>
где:
-
ComponentName— имя компонента, вызвавшего нарушение. -
ParameterName— имя параметра, значение которого должно быть уникальным. -
ParameterValue— значение параметра, для которого задано требование уникальности. -
WorkspaceComponentList— список идентификаторов Item-Revision компонентов в целевом рабочем пространстве с повторяющимися значениями параметра, для которого задано требование уникальности.
Рекомендации по устранению
Проверьте параметры компонентов в импортируемой исходной библиотеке и убедитесь, что в раскрывающемся списке Unique Field на вкладке Advanced панели Properties правильно выбран параметр, значение которого должно быть уникальным.
Если импортируемый компонент совпадает с компонентом, уже существующим в целевом рабочем пространстве, его можно исключить из переноса — подробнее.
Дублирование компонента по вариантам выбора
Default report mode:
Общие сведения
Это нарушение возникает, если в целевом рабочем пространстве есть компонент с тем же вариантом выбора изделия, что и у компонента в импортируемых исходных библиотеках. Подробнее см. в разделе Обнаружение дубликатов.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Component <ComponentName> is duplicated with components by Part Choices:
- Server components: <WorkspaceComponentList> (<Manufacturer> <PartNumber>)
где:
-
ComponentName— имя компонента, вызвавшего нарушение. -
WorkspaceComponentList— список идентификаторов Item-Revision компонентов в целевом рабочем пространстве, имеющих тот же вариант выбора изделия, что и компонент в импортируемой исходной библиотеке. -
Manufacturer— параметр производителя дублирующегося варианта выбора изделия. -
PartNumber— параметр номера детали дублирующегося варианта выбора изделия.
Рекомендации по устранению
Проверьте параметры компонентов в импортируемой исходной библиотеке и убедитесь, что сопоставления параметров вариантов выбора изделий (перечисленные в области Part Choices Mapping на вкладке General панели Properties) заданы правильно.
Если импортируемый компонент совпадает с компонентом, уже существующим в целевом рабочем пространстве, его можно исключить из переноса — подробнее.
Дублирование шаблона компонента
В настоящее время эта проверка не выполняется средствами проверки Library Importer.
Тип компонента не определен
Default report mode:
Общие сведения
Это нарушение возникает при наличии компонента без категории, то есть компонента, которому не назначен тип.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<ComponentName> component type is undefined.
где:
-
ComponentName— имя компонента, вызвавшего нарушение.
Рекомендации по устранению
Назначьте тип компоненту без категории. Подробнее см. в разделе Компоненты без категории.
Техническое описание не найдено
Default report mode:
Общие сведения
Это нарушение возникает, если техническое описание не удается найти по ссылке, заданной для компонента в исходной библиотеке.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Datasheet <Path> is not found.
где:
-
Path— путь к техническому описанию, заданный для компонента в исходной библиотеке.
Рекомендации по устранению
Найдите отсутствующий файл технического описания и восстановите его в ожидаемом расположении. Также можно отключить импорт файлов технических описаний, изменив параметр Migrate в области Datasheet панели Properties (на вкладке Advanced).
Импорт сопоставления выводов не поддерживается
Default report mode:
Общие сведения
Это нарушение возникает, если для компонента в исходной библиотеке задано пользовательское сопоставление выводов.
Уведомление
На панели Messages отображается уведомление в следующем формате:
Import for <ComponentName> component pin mapping is not supported.
где:
-
ComponentName— имя компонента, вызвавшего нарушение.
Рекомендации по устранению
После импорта можно проверить сопоставление выводов и настроить его нужным образом при редактировании компонента в редакторе компонентов в режиме редактирования одного компонента — подробнее.
Недопустимое значение параметра
Default report mode:
Общие сведения
Это нарушение возникает, если значение параметра компонента невозможно интерпретировать как допустимое значение для указанного типа единиц измерения.
Уведомление
На панели Messages отображается уведомление в следующем формате:
<ParameterName> parameter value <ParameterValue> in component <ComponentName> cannot be converted to unit of type <UnitType>.
где:
-
ParameterName— имя параметра компонента, вызвавшего нарушение. -
ParameterValue— значение параметра компонента, вызвавшего нарушение. -
ComponentName— имя компонента с параметром, вызвавшим нарушение. -
UnitType— единицы измерения, заданные в данный момент для параметра, вызвавшего нарушение.
Рекомендации по устранению
Исправьте некорректное значение параметра в табличной области Library Importer, приведя его к допустимому формату. Либо, выбрав исходную библиотеку, измените единицу измерения сопоставленного параметра Type, заданную примененным шаблоном компонента, на неинтерпретируемую Text в области Parameter Mapping панели Properties (на вкладке General).
Некорректное сопоставление вариантов компонентов
Default report mode:
Описание
Это нарушение возникает при ошибке в настройке сопоставления вариантов компонентов.
Уведомление
В панели Messages отображается уведомление в следующем формате:
Part Choice mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
где:
-
LibraryName— имя исходной библиотеки, в которой найден компонент с некорректным сопоставлением вариантов компонентов. -
LibraryType— имя группы подбиблиотек, в которой найден компонент с некорректным сопоставлением вариантов компонентов. -
Descripion— описание нарушения сопоставления вариантов компонентов.
Рекомендации по устранению
В области Part Choices Mapping панели Properties найдите параметры со значком
и исправьте сопоставление. Либо удалите записи сопоставления с ошибками.
Имя параметра совпадает с именем системного параметра
Default report mode:
Описание
Это нарушение возникает, когда компонент в исходной библиотеке содержит параметр с тем же именем, что и системный параметр. К таким параметрам относятся:
-
AncestorItemRevisionGUID -
Cat -
ComponentType -
ContentType -
ContentTypeGUID -
CreatedAt -
CreatedBy -
CreatedByGUID -
DynamicData -
Folder -
FolderGuid -
Hrid -
Id -
ItemDescription -
ItemGUID -
ItemHRID -
LatestRevision -
LifeCycle -
LifecycleStateGUID -
ModifiedBy -
ReleaseDate -
ReleaseDateNum -
ReleaseNote -
RevisionId -
RevisionNamingSchemeGUID -
SourceGUID -
SourceVaultGUID -
Text -
Updated -
UpdatedByGUID
Уведомление
В панели Messages отображается уведомление в следующем формате:
'<ParameterName>' is system parameter
где
-
ParameterName— имя параметра компонента, вызывающего нарушение.
Рекомендации по устранению
Удалите запись сопоставления некорректного параметра из области Parameter Mapping панели Properties (на вкладке General). Либо удалите этот параметр из компонента в исходной библиотеке или переименуйте его.
Параметры моделирования пропускаются
Default report mode:
Описание
Это нарушение возникает, когда с компонентом в исходной библиотеке связана модель для моделирования.
Уведомление
В панели Messages отображается уведомление в следующем формате:
<ComponentName> component simulation parameters are skipped (<SimulationParameterList>).
где:
-
ComponentName— имя компонента в исходной библиотеке, вызывающего нарушение. -
SimulationParameterList— разделенный запятыми список параметров моделирования, которые будут пропущены при импорте.
Рекомендации по устранению
После импорта можно настроить связь с моделью для моделирования при редактировании компонента в редакторе компонентов в режиме редактирования одного компонента — подробнее.
Устранение ошибок и предупреждений
Ошибки параметров, как в показанном здесь примере, где значение Forward Voltage компонента невозможно интерпретировать как допустимое напряжение, можно устранить следующими способами:
-
Изменить значение некорректного параметра — найдите соответствующую ячейку и приведите ее содержимое к допустимому формату.
-
Изменить единицу измерения сопоставленного параметра Type, заданную примененным шаблоном компонента, с
Voltageна неинтерпретируемуюText— выберите исходную библиотеку в интерфейсе импортера, затем изменитеForward VoltageType в списке панели Properties Parameter Mapping (на вкладке General). -
Исключить компонент из процесса импорта — щелкните правой кнопкой мыши его запись и выберите пункт Exclude from Importer.
Ошибку отсутствия файла, например показанного здесь файла технического описания, который не удается найти, можно устранить следующими способами:
- Самое очевидное решение — найти отсутствующий файл и восстановить его в ожидаемом расположении.
- Отключить импорт файлов технических описаний — измените настройку Migrate в разделе панели Properties Datasheet (на вкладке Advanced).
- Исключить компонент из процесса импорта библиотеки, как описано выше.
Используйте поле Search (вверху справа) для поиска определенных записей компонентов. Поиск фильтрует список элементов по совпадающим значениям параметров для выбранного типа компонентов. Чтобы поиск выполнялся по всем компонентам в доступных исходных библиотеках, выберите All в разделе Types (Folder Structure).
Импорт библиотеки схемных компонентов
Если при попытке импорта библиотеки схемных компонентов возникает ошибка «модель не найдена» (например, Footprint <footprint name> not found in available libraries), это означает, что Library Importer не может найти модели, связанные с компонентами в SCHLIB.
В простом режиме такие ошибки отображаются в HTML-отчете Importing Report, который открывается кнопкой
, доступной после выполнения импорта. В расширенном режиме ошибки обозначаются значками состояния в основном интерфейсе и записями в панели Messages — это происходит при выполнении проверки или при попытке импорта библиотеки
Отсутствующие посадочные места корректно обнаруживаются в процессе проверки, а в отчете об ошибках также доступен пункт Choose a Library (в раскрывающемся меню Details). Если обнаружено несколько компонентов с отсутствующими посадочными местами, диалоговое окно Apply PcbLib Selection позволяет использовать указанную PcbLib для текущего компонента или для всех компонентов с отсутствующими посадочными местами.
Другой способ устранить (или предотвратить) эту проблему — обеспечить доступность необходимых файлов библиотек моделей в Altium Designer. Библиотеки устанавливаются на странице Data Management – File-based Libraries диалогового окна Preferences.
Если вы не хотите устанавливать несколько библиотек моделей, разместите их по пути к библиотекам, заданному в программе по умолчанию (или измените этот путь), и убедитесь, что для компонентов библиотеки схемных компонентов указана исходная библиотека моделей:
- Разместите библиотеку моделей по пути поиска, заданному в программе по умолчанию. Добавьте библиотеку моделей, например соответствующую библиотеку посадочных мест, в расположение, указанное системным путем к библиотекам по умолчанию. Чтобы проверить это расположение, найдите запись Library Path на странице System – Default Locations диалогового окна Preferences. Если файл библиотеки был добавлен или скопирован в это расположение, для применения изменения может потребоваться перезапуск Altium Designer.
-
Укажите имя целевой библиотеки моделей для компонентов библиотеки схемных компонентов. Чтобы Library Importer мог определить библиотеку моделей, на которую ссылается компонент библиотеки схемных компонентов, укажите ее имя в диалоговом окне PCB Model библиотеки.
Обнаружение дубликатов
Инструмент Library Importer также включает механизмы, предотвращающие создание дубликатов компонентов в целевом рабочем пространстве. Для этого во время проверки параметры идентификации компонентов и варианты выбора компонентов (Part Choices) исходной библиотеки сравниваются с соответствующими данными компонентов в целевом рабочем пространстве и в исходных библиотеках, подлежащих импорту. При настройках импортера по умолчанию на этапе проверки выводится сообщение Warning, если обнаружена одинаковая запись Name или Part Choices компонента, указывающая на возможное дублирование. Отображаемое предупреждение или сообщение об ошибке содержит тип дублирования (параметр или Part Choice), имя библиотечного компонента, для которого обнаружено дублирование, и идентификатор компонента, с которым он совпадает.

Два потенциальных дубликата, обнаруженных в ходе проверки: Name компонента (верхнее изображение) или его Part Choice (нижнее изображение) уже существуют у компонентов рабочего пространства.
Пара «имя — значение» параметра, используемая для обнаружения дубликатов, задается в области Duplicates Detection панели Properties на вкладке Advanced. В раскрывающемся меню Unique Field (по умолчанию выбрано Name) выберите один из параметров, доступных в исходной библиотеке. Эта возможность особенно полезна для корпоративных библиотек, в которых используется собственное поле идентификатора, связанное с общей системой предприятия.

Обнаружено дублирование: значение указанного параметра (ERP-REF) совпадает у компонента локальной библиотеки и компонента рабочего пространства.
Для случаев дублирования можно задать другой тип индикатора состояния, выбрав альтернативное значение Report Mode в области Import Checks на вкладке General панели Properties.
Обнаружение дубликатов также выполняется для моделей условных графических обозначений (УГО) компонентов. Если импортируемые компоненты имеют в исходных библиотеках модели УГО с одинаковой геометрией, будет импортирована только одна из этих моделей.
Библиотеки с одной моделью
Автоматическое обнаружение дубликатов также используется для обработки исходных библиотек, в которых одна общая модель УГО применяется ко всем компонентам. Такие библиотеки обычно состоят из компонентов одного типа с различными исполнениями и номиналами, например резисторов определенного типоразмера корпуса, для каждого из которых используется стандартное графическое обозначение.
Library Importer обнаруживает наличие единой общей модели и настраивает импорт так, чтобы перенести одну модель УГО для всех импортируемых компонентов, а не отдельное обозначение с собственным именем для каждого компонента. Импортируемому УГО присваивается имя одного из исходных обозначений, а все параметры компонентов остаются без изменений.
Импортированное библиотечное УГО (с общим именем и пустым полем Description) можно отредактировать в соответствии с вашими потребностями. На панели Components выберите команду Edit в контекстном меню, чтобы запустить редактирование. В ходе этого процесса выберите опцию Update items related to <symbol ID> в диалоговом окне Create Revisions for Item, чтобы импортированные компоненты использовали новую ревизию УГО.
Импорт только моделей
Library Importer можно переключить в специальный режим импорта Models Only, который обнаруживает и обрабатывает модели компонентов, доступные в исходной библиотеке.
В режиме Models Only в ходе анализа импортер обнаруживает все модели УГО, посадочных мест и моделирования, доступные в исходной библиотеке (IntLib, SchLib, PcbLib и т. д.), а затем импортирует их в рабочее пространство, используя заданные в системе по умолчанию расположения, схемы именования и определения жизненного цикла.
Если переключить Library Importer в расширенный режим или открыть его в расширенном режиме (File » Library Importer), будут доступны полные сведения о планируемом импорте моделей. В области Import Preview показаны Folder Structure, которые будут использоваться в целевом рабочем пространстве. Их значения по умолчанию можно изменить в поле Folder для каждого типа моделей на панели Properties. Применяемые схемы именования и определение жизненного цикла для каждой модели можно выбрать из доступных в системе вариантов (см. панель Properties ниже).
При необходимости импорт моделей компонентов в рабочее пространство можно ограничить по типу, отключив (или включив) определенные типы моделей на панели Properties с помощью соответствующих кнопок
.
После настройки Library Importer нажмите кнопку
, чтобы завершить импорт перечисленных моделей компонентов. Результаты можно просмотреть в файле журнала импорта, который предлагается открыть в диалоговом окне хода выполнения Library Importer , либо непосредственно на панели Components, просмотрев импортированные модели.
Импорт только компонентов
Аналогично описанному выше режиму импорта Models Only, Library Importer можно переключить в специальный режим Components Only, позволяющий импортировать доступные в исходной библиотеке компоненты без связанных с ними моделей.
В режиме Components Only в ходе анализа импортер обнаруживает все компоненты, параметры и варианты выбора компонентов (Part Choices) в исходной библиотеке, а затем импортирует эти компоненты в рабочее пространство, используя заданные в системе по умолчанию расположение, схему именования и определение жизненного цикла.
При переключении Library Importer в расширенный режим или открытии в этом режиме (File » Library Importer) становятся доступны полные сведения о предстоящем импорте компонентов. Используемую папку, схемы именования и определение жизненного цикла можно выбрать из доступных системных типов (см. панель Properties ниже).
После настройки Library Importer нажмите кнопку
, чтобы завершить импорт перечисленных компонентов. В рабочем пространстве будут созданы только элементы компонентов, без связанных моделей. Результаты можно просмотреть в файле журнала импорта, доступном из диалогового окна хода выполнения Library Importer , или просмотрев импортированные компоненты на панели Components.
Панель Properties
Настройки связанной с Library Importer панели Properties предоставляют расширенные возможности управления конфигурацией импорта для выбранной библиотеки (или группы подбиблиотек). Панель можно открыть в расширенном режиме Library Importer, выбрав пункт Properties в меню кнопки
(в правом нижнем углу области проектирования), нажав кнопку
в правом верхнем углу представления Library Importer или кнопку
рядом с <All Libraries> либо записью определенной категории в списке Source Libraries.
Значения параметров панели определяются системными настройками по умолчанию или настройками примененного шаблона компонента, который, в свою очередь, определяется обнаруженным типом компонентов библиотеки — LED в приведенном здесь примере. Настройки также можно редактировать вручную, адаптируя процесс импорта под свои требования, и восстанавливать с помощью ссылки Reset to Default (справа вверху).
Вкладка General панели содержит следующие разделы:
-
General:
-
Component Type — тип компонента, определенный средством импорта для выбранной библиотеки, и связанный с ним применяемый шаблон (см. Component Template ниже). Это значение можно переопределить, отредактировав поле, что приведет к созданию нового типа компонента, или выбрав другой тип из раскрывающегося меню (либо с помощью кнопки Это еще один способ устранить проблему компонентов без категории. Выберите вариант
[LibraryName], чтобы использовать имя выбранной библиотеки в качестве типа. -
Component Template — шаблон компонента рабочего пространства, который будет применен к импортируемым компонентам, и связанная с ним настройка типа компонента. Это значение можно переопределить, выбрав другой шаблон из раскрывающегося меню (либо с помощью кнопки Установите значение
[Create new]для автоматического создания шаблона на основе параметров исходной библиотеки и текущих настроек Library Importer или выберите [No Template], чтобы шаблон не применялся и не создавался.
-
Component Type — тип компонента, определенный средством импорта для выбранной библиотеки, и связанный с ним применяемый шаблон (см. Component Template ниже). Это значение можно переопределить, отредактировав поле, что приведет к созданию нового типа компонента, или выбрав другой тип из раскрывающегося меню (либо с помощью кнопки Это еще один способ устранить проблему компонентов без категории. Выберите вариант
-
Parameter Mapping — сопоставление параметров библиотеки с параметрами примененного шаблона компонента (или с настройками по умолчанию, если шаблон недоступен), а также тип значения каждого параметра (текстовый или тип с учетом единиц измерения). Используйте раскрывающееся меню столбца Source Library Parameter для изменения сопоставления и меню столбца Type для переопределения существующей настройки, заданной шаблоном или значениями по умолчанию. Выберите вариант
<Skip>, чтобы исключить параметр. Любой параметр, который не был автоматически сопоставлен с параметром исходной библиотеки (система установила для него значение<Skip>), можно вручную сопоставить с подходящим параметром шаблона. Например, исходный параметрROHSможно сопоставить с параметромRoHS Compliant, определенным в шаблоне рабочего пространства. Имена параметров можно редактировать, а наборы параметров — добавлять, редактировать и удалять. Для базовых параметров компонента (ID,Name,Description) можно изменить сопоставление, но в остальном они доступны только для чтения. -
Part Choice Mapping — список распознанных средством импорта параметров изделий производителей или ссылок на поставщиков, которые будут использоваться для формирования записей Part Choices для импортируемых компонентов. Используйте раскрывающееся меню для изменения сопоставления, а также добавляйте и удаляйте наборы сопоставлений. Обратите внимание, что по умолчанию параметры изделий производителей и ссылок на поставщиков не включаются в импорт (пропускаются). Если компонент библиотеки содержит несколько ссылок на поставщиков, для заполнения полей Part Choices используется основная ссылка на поставщика (
Supplier 1/Supplier Part Number 1). -
Import Checks — просмотр или настройка реакции средства импорта в виде ошибки или предупреждения при нарушении правил проверки импорта. Используйте раскрывающееся меню Report Mode, чтобы изменить реакцию и значок для записи Violation Type. Обратите внимание: если выбран режим уведомления
Fatal Error, при обнаружении этого нарушения процесс импорта будет заблокирован.
Вкладка Advanced панели содержит настройки для всех объектов данных средства импорта, заданные системными значениями по умолчанию или примененным шаблоном компонента. К ним относятся модели компонентов, файлы технической документации и создаваемые шаблоны компонентов. За исключением параметра Datasheet (переключателя включения/выключения), настройки для каждого импортируемого объекта включают:
- Folder — целевая папка рабочего пространства для импортируемого объекта. Ее можно отредактировать вручную (например, чтобы создать новую целевую папку) или выбрать с помощью кнопки обзора
- Naming Scheme — правило именования объекта в рабочем пространстве, заданное шаблоном компонента, а при отсутствии активного шаблона — схема, установленная для целевой папки (или введенная вручную). Используйте раскрывающееся меню для выбора из доступных схем именования. Обратите внимание, что изменение пути к целевой папке (Folder) может сопровождаться изменением применяемой схемы именования в соответствии с настройками самой папки или примененного/связанного шаблона компонента.
- Revision Naming Scheme — схема именования ревизий объекта в рабочем пространстве, заданная примененным шаблоном или выбранная из раскрывающегося меню записи. Для выбора доступны только схемы, включенные в системе.
- Lifecycle Definition – система жизненного цикла, используемая для объекта и заданная применённым шаблоном или выбранная из раскрывающегося меню соответствующего поля. Для выбора доступны только определения, включённые в системе.
Экспорт и импорт конфигурации
Инструмент Library Importer позволяет экспортировать подробный текстовый файл с текущей конфигурацией, включающей все настраиваемые параметры импорта: целевые пути, сопоставление параметров, схему именования, определения жизненных циклов, целевые типы компонентов и т. д.
Файл конфигурации импорта сохраняется с помощью команды File » Export » Importer Config в формате *.lmcfg и может быть восстановлен в любое время с помощью пункта меню File » Import » Importer Config .
Возможность восстановления конфигурации особенно полезна, когда исходная база данных или файловая библиотека была обновлена и эти изменения необходимо импортировать в рабочее пространство. Если конфигурация была экспортирована при первом импорте библиотеки, её восстановление (импорт) позволит в точности воспроизвести использованные настройки, что гарантирует единообразную схему переноса данных для этой библиотеки (или библиотек).

























