Подробнее о конструировании плат

Вы просматриваете версию 23. Для самой новой информации, перейдите на страницу Подробнее о конструировании плат для версии 24
Translation is available for Altium Designer 22: Go to the page
 

Inside every electronics product is a printed circuit board, or PCB. Altium Designer's PCB editor allows you to create, edit and verify the PCB design.

Setting Up the PCB Editor

The PCB Editor category of the Preferences dialog (accessed by clicking the  icon at the top-right of the design space) provides access to pages of preferences affecting the behavior of the PCB editor. Access these preferences at any moment to configure settings as required.

Use the PCB Editor category of Altium Designer's Preferences to set up the PCB editor.
Use the PCB Editor category of Altium Designer's Preferences to set up the PCB editor.

Learn more about PCB preferences: PCB Editor Preferences.

Setting Up a PCB Document

To start laying out your PCB, add a new PCB document to the PCB project. To do this, right-click the project's entry in the Projects panel and select Add New to Project » PCB command from the context menu. The default PCB document will appear in the design space.

A newly created PCB document will be the active document in the design space.
A newly created PCB document will be the active document in the design space.

Options for a PCB document are configured in the Properties panel when no object is selected in the design space. The main options are configured on the General tab of the panel:

  • Grid setting (the Grid Manager region) – configure options of the default global grid or add additional grids (cartesian and polar) as required. Grids ensure accurate movement and placement of objects.

    When in the design space, press G to open a menu from where you can quickly set the global grid to one of the standard values.
  • Units (the Other region) – select the preferred measurement units (mm or mils) for the document.

Configure options of the PCB document in the Properties panel.
Configure options of the PCB document in the Properties panel.

Learn more about configuring a PCB document: PCB Environment Setup.

Defining the Board Shape and the Origin

The board shape, also referred to as the board outline, defines the overall extents of the board. By default, the board is a rectangle of 6000 x 4000 mil (152.4 x 101.6 mm). The PCB editor provides a number of tools to define the board shape as required.

You can interactively define a new board shape in the following process:

  1. Enter the editor's Board Planning Mode by selecting the View » Board Planning Mode command from the main menus.
  2. Select the Design » Redefine Board Shape command from the main menus.
  3. Position the cursor and click to anchor the starting vertex for the board shape.
  4. Move the cursor ready to place the second vertex and click to place it.

    • Press Shift+Spacebar to cycle through the five available corner modes: 45 degree, 45 degree with arc, 90 degree, 90 degree with arc, and Any Angle.
    • Press Spacebar to toggle between the two corner direction sub-modes.
    • When in either of the arc corner modes, hold the "," or "." keys to shrink or grow the arc. Hold the Shift key as you press to accelerate arc resizing.
  5. Continue to move the mouse and click to place further vertices.
  6. After placing the final vertex, right-click to close and complete the definition of the board shape. There is no need to manually close the board shape as the PCB editor will automatically complete the shape by connecting the start point to the final point placed.

You can also edit the existing shape instead of redefining it using the following process:

  1. Enter the editor's Board Planning Mode by selecting the View » Board Planning Mode command from the main menus.
  2. Select the Design » Edit Board Shape command from the main menus.
  3. Click, hold and drag a board shape side or vertex to move it.

    • When moving a vertex, use Shift+Spacebar to change modes.
    • Ctrl+Click anywhere along an edge away from editing handles to insert a new end vertex.
  4. Exit editing mode by clicking anywhere in the design space (on or away from the board shape).

Use the View » 2D Layout Mode command from the main menus to return to the editor's 2D Layout Mode.

Positions of objects placed in the PCB document are displayed/defined relative to the current origin shown in the design space as a white cross in a circle. Use the Edit » Origin » Set command from the main menus to define a location in the design space as the new current origin and set its coordinates to (0,0).
Learn more about available board shape definition techniques: Defining the Board Shape.

Defining the Layer Stack

The PCB is designed and formed as a stack of layers defined in the Layer Stack Manager (Design » Layer Stack Manager). The Layer Stack Manager opens in a document editor in the same way as a schematic sheet, the PCB, and other document types do. The functionality is divided over the tabs displayed across the bottom of the Layer Stack Manager. The main configuration operations are performed on the Stackup and Via Types tabs.

The Stackup tab details the fabrication layers. Layers are added, removed and configured in this tab.

Javascript

To add a layer, select a layer above/below which a new layer should be added in the grid area and click the Add button at the top of the Layer Stack Manager and use the pop-up that appears.

To delete a layer, select it in the grid area and click the Delete button.

To select a layer material from the material library, select the required layer in the grid area and click the Modify button. The properties defined for the chosen material will be applied to the layer.

The properties of the currently selected layer can also be edited directly in the grid area or the Properties panel.

  • To access the material library, select the Design » Layer Stack Manager command from the main menus.
  • A number of pre-defined layer stacks are available in the Tools » Presets menu.

The Via Types tab is used to define the allowed Z-plane layer-spanning requirements of the vias used in the design.

Javascript

The default thru-hole via type is always present in a PCB design.

To add an additional via type (blind, buried, or micro via), click the Add button at the top of the Layer Stack Manager and then select the layers that this via type spans in the First layer and Last layer drop-downs in the Properties panel when the via type is selected in the grid area.

To delete an added via type, select it in the grid area and click the Delete button.

Note that the diameter and hole size (X&Y properties) of the vias placed in the design is controlled by the applicable Routing Via Style design rule if the via is placed during interactive routing.

Use the File » Save to PCB command in the Layer Stack Manager to reflect the changes in the PCB.

When placing objects using the PCB editor, you should consider which layer they will be placed on. Objects are placed on the current layer, shown as the active layer tab at the bottom of the design space.

Use the layer tabs to select the currently active layer. In the image above, the Top Layer is the active layer.
Use the layer tabs to select the currently active layer. In the image above, the Top Layer is the active layer.

Learn more about the Layer Stack ManagerDefining the Layer StackBlind, Buried & Micro Via Definition.

Configuring Design Rules

Design rules monitor and test your design for different design requirements, such as clearances between copper objects, widths of routes, lengths of nets, etc. Collectively, the design rules form an instruction set for the PCB editor to follow.

Design rules are defined and managed from within the PCB Rules and Constraints Editor dialog is accessed by choosing the Design » Rules command from the main menus.

Note that if the Constraint Manager functionality was available at the moment of creating the PCB project, the Constraint Manager is used to define design constraints for that project. In this case, the PCB Rule and Constraints Editor dialog will not be available in the PCB editor. Otherwise, the previous approaches to define design constraints (design directives and the PCB Rule and Constraints Editor dialog) can only be used.

The PCB Rules and Constraints Editor dialog has two sections:

  • The left-hand side of the dialog presents a tree that lists available rule categories, rule types in each category, and individual rules of each type that are currently defined.
  • The right-hand side of the dialog presents information in relation to what is currently selected in the tree. For example, select an individual rule to show the settings for that rule.
Javascript

Click the Design Rules entry to access a summary listing of all specific rules that have been defined for the design.

Click a category entry to access a summary listing of all specific rules that have been defined for all associated design rule types of that category.

Click on the entry for a specific rule to access controls for managing its definition.

Design rules have three groups of settings described below and shown on the images afterward:

  1. Main attributes of the rule – here, you can give the rule a meaningful name and add an optional comment.
  2. Rule scope – defines specific objects within a design that the rule targets. Depending on the rule type, one (for a unary rule that defines the required behavior of an object) or two (for a binary rule that defines the interaction between two objects) scopes should be defined.
  3. Rule constraints – specific constraints for the rule.
Javascript

Rules of the Width type are unary rules. A single scope (Where the Object Matches) should be defined for a unary rule. 

Rules of the Clearance type are binary rules. Two scopes (Where the First Object Matches and Where the Second Object Matches) should be defined for a binary rule.

To create a new rule, right-click the required rule type in the dialog's tree and select the New Rule command from the context menu. The new rule will be added to the tree under the selected category. Select the rule's entry in the tree to edit it.

When there are multiple rules of the same type targeting the same object(s), the PCB editor uses the rule priority to ensure the highest priority applicable rule is applied. Click the Priorities button at the bottom of the PCB Rules and Constraints Editor dialog to open the Edit Rule Priorities dialog and change the priorities as required. 1 is the highest priority. When a new rule is added (using the New Rule command), it is given the highest priority.

Learn more about working with PCB design rules and specific rule types: Defining, Scoping & Managing PCB Design RulesPCB Design Rule Types.

Placing Components

When the design data is transferred from the PCB project's schematics to the PCB document (using the Design » Update PCB Document command from the main menus of the schematic editor and the following ECO execution process), the default footprints of components used in the schematics will be placed in arbitrary positions in the PCB document. Component pads will be connected by connection lines, according to the nets (connected component pins) defined in schematics.

A PCB after updating from schematics.
A PCB after updating from schematics.

The basic techniques to define location of a component on a PCB are:

  • To move a component to the required location, Click, Hold&Drag then release the mouse button to place it.
  • To rotate a component, press Spacebar while dragging it.
  • To flip a component to the other side of the board, press L while dragging it. 

The connection lines are automatically re-optimized as you move a component. Use them to help orient and position the components to reduce the number of connection line cross-overs.

Learn more about connectivity on a PCB and placing components: Understanding Connectivity on Your PCBComponent Placement.

Routing the Board

Routing is the process of laying tracks, arcs, and vias on the board to connect the component pads. The PCB editor suggests a number of tools to route connections on your board, including interactive routing tools.

Because the routing tools are rule-driven, it is essential to configure the design rule before you start routing. The main design rules used during the interactive routing process are:

  • The Clearance rule (the Electrical category) – defines how close the routes for the net being routed are allowed to get to other objects on the board.
  • The Width rule (the Routing category) – defines the width of routes for the net being routed.
  • The Routing Via Style (the Routing category) – defines the diameter and hole size of vias placed when switching layers during routing.

To route a single connection, the Interactive Routing tool is used. The process is as follows:

  1. Select the Route » Interactive Routing command from the main menus.
  2. Click a component pad from which you want to start routing.
  3. Position the cursor, then click in the design space to place the routes up to the cursor. Continue to define the route path.

    During interactive routing, you can use the following shortcuts:

    • Tab to pause routing and open the Properties panel to configure interactive routing options. When done, click the button in the design space to return to interactive routing mode.
    • Shift+Spacebar to cycle through the corner styles: Track 45, Line 45/90 With Arc, Any Angle, etc.
    • Spacebar to toggle the corner direction.
    • Shift+R to cycle through the available routing conflict resolution modes: Walkaround Obstacles, Push Obstacles, Ignore Obstacles, etc.
    • Ctrl+Shift+Wheel Scroll to switch to the next available signal layer and insert a via.
    • Shift+F1 to display the list of interactive routing shortcuts.
  4. Click the target pad to finish routing the connection. The connection will be automatically released, and you will remain in interactive routing mode, ready to route the next connection.
  5. Right-click to exit interactive routing mode.

Learn more about preparing a PCB for routing and routing the PCB: Preparing a PCB for RoutingRouting the PCB.

Placing Polygons

To cover a signal layer of the PCB with a large area of copper, a polygon pour can be used. A polygon pour automatically pours around existing objects, connecting only to objects on the same net as the polygon pour. Clearances and connection properties are controlled by the applicable Clearance and Polygon Connection Style design rules.

To place a polygon pour:

  1. Select the Place » Polygon Pour command from the main menus.
  2. During placement, you can press the Tab key to open the Properties panel and configure the properties of the polygon being placed: net, layer, fill mode, etc. When done, click the button in the design space to return to placement mode.
  3. Position the cursor and click to anchor the starting vertex for the polygon pour.
  4. Move the cursor ready to place the second vertex and click to place it.

    • Press Shift+Spacebar to cycle through the five available corner modes: 45 degree, 45 degree with arc, 90 degree, 90 degree with arc, and Any Angle.
    • Press Spacebar to toggle between the two corner direction sub-modes.
    • When in either of the arc corner modes, hold the "," or "." keys to shrink or grow the arc. Hold the Shift key as you press to accelerate arc resizing.
  5. Continue to move the mouse and click to place further vertices.
  6. After placing the final vertex, right-click to close and complete the polygon pour placement. There is no need to manually close the polygon shape as the PCB editor will automatically complete the shape by connecting the start point to the final point placed.
  7. Continue placing further polygon pours or right-click to exit placement mode.

When a polygon pour is modified (for example, its shape or properties have been changed), it must be repoured to reflect the modifications. To repour a polygon, click the Repour button at the top of the Properties panel when the polygon is selected.

Learn more about polygon pours: Polygons on Signal Layers.

Performing a Design Rule Check

The PCB editor provides Design Rules Checking (DRC) functions to check that your design conforms to the enabled design rules.

Configuration for design rule checking is performed in the Design Rule Checker dialog accessed through the Tools » Design Rule Check command from the main menus.

  • Click the Report Options entry in the tree on the left-hand side of the dialog to configure additional options that are available when running a Batch DRC.
  • Click the Rules to Check entry or an entry for a specific rule category to load the dialog with a list of rule types and enable each rule type for Online and/or Batch DRC as required:
    • Online DRC – the check will be performed in real-time as you design.
    • Batch DRC – the check will be performed as a batch process by clicking the Run Design Rule Check button in the dialog, with results listed in the Messages panel and an optional generated report.
Javascript

When running an Online or Batch DRC, detected rule violations will be indicated in the design space (using the custom violation graphics and/or violation overlay). Some examples of violations in the design space are shown below:

Tracks offending a Width rule. The violation is indicated by both custom violation graphics and violation overlay.
Tracks offending a Width rule. The violation is indicated by both custom violation graphics and violation overlay.

A track offending a Net Antennae rule. The violation is indicated by custom violation graphics.
A track offending a Net Antennae rule. The violation is indicated by custom violation graphics.

Detected rule violations for the selected rule class or specific rule are also listed in the Violations region of the PCB Rules And Violations panel. Click a violation entry to highlight the violation in the design space, according to the setting at the top of the panel: Mask/Dim/Normal, Select, Zoom.

DRC can also be run for all rules, rules of a specific type, or a specific rule by right-clicking the associated entry in the PCB Rules And Violations panel and selecting the Run DRC command.

Run DRC right from the PCB Rules And Violations panel. Running DRC for all defined Clearance rules is shown here.
Run DRC right from the PCB Rules And Violations panel. Running DRC for all defined Clearance rules is shown here.

Learn more about DRC: Design Rule Check (DRC).
If you find an issue, select the text/image and pressCtrl + Enterto send us your feedback.
Примечание

Набор доступных функций зависит от вашего уровня доступа к продуктам Altium. Ознакомьтесь с функциями, включенными в различные уровни Подписки на ПО Altium, и функциональными возможностями приложений, предоставляемых платформой Altium 365.

Если вы не видите в своем ПО функцию, описанную здесь, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Content