Работа с директивами на схеме
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Краткий обзор
- Узнайте, что такое директивы проектирования и как они используются при создании и проверке схем.
- Разберитесь, когда следует использовать No ERC, а когда — Compile Mask, чтобы подавить нежелательные сообщения проверки.
- Узнайте, как размещать, включать, отключать и редактировать маски Compile Mask в редакторе схем.
Директивы проектирования — это объекты, которые размещаются на схеме при ее разработке и позволяют задавать инструкции для передачи в другие части программного обеспечения. Доступны различные директивы проектирования, которые используются двумя следующими способами:
- Директивы, связанные с автоматической компиляцией исходных документов схем.
- Директивы для передачи информации, заданной на листе схемы, на печатную плату.
В следующих разделах подробнее рассматриваются эти области применения и соответствующие директивы.
Директивы, связанные с компиляцией
Проекты развиваются со временем, а их схемы создаются поэтапно. По мере завершения каждого этапа часто возникает необходимость проверить его отдельно от остального проекта. Компиляция отдельного документа схемы или всего проекта на промежуточных этапах разработки нередко приводит к появлению сообщений об ошибках, вызванных еще не созданными участками схемы или незавершенными соединениями между ее фрагментами. Такие сообщения не несут реальной пользы, поскольку лишь мешают видеть действительно важную информацию. Самый быстрый и простой способ подавить эти ошибки компиляции — разместить директивы No ERC или Compile Mask.
Директива No ERC
Директива No ERC размещается в узле схемы для подавления всех предупреждений и/или сообщений об ошибках проверки электрических правил, обнаруживаемых при валидации проекта схемы. Подробнее см. на странице Валидация проекта.
Директива Compile Mask
Директивы No ERC хорошо подходят для подавления нарушений у небольшого числа выводов, портов, входов листов или цепей проекта. Однако в некоторых случаях требуется исключить из проверки целый участок проекта, включая компоненты. Используйте директиву Compile Mask (команда Place » Directives » Compile Mask) или нажмите кнопку Compile Mask в раскрывающемся списке директив на Active Bar, чтобы скрыть от компилятора область проекта, заключенную в маску. Это позволяет вручную отключить проверку ошибок для участков схемы, которые могут быть еще не завершены и заведомо вызывают ошибки компиляции. Такая возможность особенно полезна, если необходимо скомпилировать активный документ или проект, чтобы проверить корректность других участков, не отвлекаясь на сообщения компилятора о незавершенных частях схемы.
Как следует из названия, эта директива указывает компилятору игнорировать все объекты, которые находятся completely в пределах заданной маски. Размещайте маску так же, как примечание или прямоугольник.
Рассмотрим пример схемы на следующем изображении, где соединения с устройством LCD1 еще не завершены. Компиляция только этой схемы (Project » Validate PCB Project) приведет к появлению множества сообщений о нарушениях (показаны ниже), каждое из которых вызвано незавершенными соединениями. Наведите указатель на изображение, чтобы увидеть результат размещения директивы Compile Mask вокруг незавершенного участка схемы. Компилятор проигнорирует эти нарушения, а остальная часть схемы, в которой все соединения выполнены, будет проверена. Обратите внимание: объекты, на которые действительно действует маска, то есть полностью находящиеся внутри ее ограничивающего прямоугольника, отображаются серым цветом.

Наведите указатель на изображение, чтобы увидеть, как директива Compile Mask скрывает сообщения компилятора о нарушениях, вызванных незавершенными участками схемы.
Маска компиляции
Размещенная маска Compile Mask в левой части приведенной выше схемы.
Общие сведения
Compile Mask — это директива проектирования, позволяющая скрыть от компилятора заключенную в нее область проекта при выполнении валидации с помощью команды Project » Validate Project . Она позволяет вручную отключить проверку ошибок для участков схемы, которые могут быть еще не завершены и будут вызывать ошибки валидации. Маска Compile Mask полезна, когда необходимо выполнить валидацию текущего проекта, чтобы проверить корректность определенных участков, не перегружая результаты сообщениями компилятора о незавершенных частях схемы.
Доступность
Маски Compile Mask можно размещать только в редакторе схем. Чтобы разместить маску Compile Mask:
- Выберите команду Place » Directives » Compile Mask в главном меню.
- Нажмите кнопку Compile Mask в раскрывающемся списке директив на Active Bar в верхней части рабочей области. Нажмите и удерживайте кнопку Active Bar, чтобы получить доступ к другим связанным командам. После использования команда становится верхним элементом в соответствующем разделе Active Bar.
- Щелкните правой кнопкой мыши в редакторе схем, затем выберите Place » Directives » Compile Mask.
Размещение
После запуска команды указатель примет вид перекрестия, обозначающего режим размещения маски Compile Mask. Для размещения выполните следующие действия:
- Установите указатель в нужное место, затем щелкните мышью или нажмите Enter, чтобы зафиксировать первый угол маски.
- Перемещайте указатель, задавая размер маски так, чтобы она полностью охватывала область проекта, которую требуется скрыть от компилятора. Затем щелкните мышью или нажмите Enter , чтобы зафиксировать противоположный по диагонали угол и завершить размещение маски. Объекты проекта, полностью находящиеся в пределах маски, станут серыми.
- Продолжайте размещать маски компиляции либо щелкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима размещения.
Графическое редактирование
Этот способ редактирования позволяет выбрать размещенную маску компиляции непосредственно в рабочей области и графически изменить ее размер, форму или положение.
Маска компиляции может отображаться в активном (полная рамка) или свернутом (треугольник в рамке) виде, что соответствует включенному и отключенному состоянию маски. Чтобы переключить режим отображения, щелкните значок ▲ или ▼ в левом верхнем углу размещенной маски компиляции.
Щелкните треугольник в левом верхнем углу, чтобы свернуть и отключить маску компиляции.
При выборе активной (развернутой) маски компиляции доступны следующие маркеры редактирования:
Выбранная маска Compile Mask в активном состоянии.
- Нажмите и перетащите A, чтобы изменить размер маски компиляции одновременно по вертикали и горизонтали.
- Нажмите и перетащите B, чтобы изменить размер маски компиляции отдельно по вертикали и горизонтали.
- Нажмите в любом месте маски компиляции, кроме маркеров редактирования, и перетащите ее в новое положение. При перетаскивании маску компиляции можно поворачивать (Spacebar/Shift+Spacebar) или зеркально отражать (клавиши X и Y для отражения относительно оси X и оси Y соответственно).
Неграфическое редактирование
Доступны следующие способы неграфического редактирования.
Редактирование через диалоговое окно Compile Mask или панель Properties
Panel page: Свойства маски компиляции
Этот способ редактирования позволяет изменять свойства объекта «Маска компиляции» с помощью соответствующего диалогового окна Compile Mask и режима панели Properties.
После размещения диалоговое окно Compile Mask можно открыть следующими способами:
- Дважды нажмите на размещенный объект маски компиляции.
- Выберите объект маски компиляции, нажмите правую кнопку мыши и выберите Properties в контекстном меню.
Во время размещения режим Compile Mask панели Properties можно открыть нажатием клавиши Tab. После размещения маски компиляции становятся доступны все параметры.
После размещения режим Compile Mask панели Properties можно открыть одним из следующих способов:
- Если панель Properties уже активна, выберите объект маски компиляции.
- Выбрав объект маски компиляции, откройте панель Properties с помощью кнопки Panels в правой нижней части рабочей области или выберите View » Panels » Properties в главном меню.
Редактирование нескольких объектов
Панель Properties поддерживает редактирование нескольких объектов, позволяя изменять значения свойств, одинаковые для всех выбранных объектов. Если несколько объектов одного типа выбраны вручную, через диалоговое окно поиска похожих объектов либо с помощью панели Filter или List, значение поля панели Properties, которое не отображается в виде звездочки (*), можно изменить для всех выбранных объектов.
Редактирование через панель List
Panel pages: Панели List, SCH Filter
Панель List отображает объекты проекта из одного или нескольких документов в табличном виде, позволяя быстро просматривать и изменять их атрибуты. В сочетании с соответствующей фильтрацией — путем выбора типов объектов (с помощью параметров Include панели), использования соответствующей панели Filter или диалогового окна поиска похожих объектов — она позволяет отображать только те объекты, которые соответствуют активному фильтру. Свойства объектов в списке затем можно редактировать непосредственно на панели List.
Свойства маски компиляции
Свойства объектов редактора схем — это настраиваемые параметры, определяющие внешний вид, содержимое и поведение размещенного объекта. Настройки свойств для каждого типа объектов задаются следующим образом:
- Post-placement settings — все свойства объекта «Маска компиляции» доступны для редактирования в диалоговом окне Compile Mask и на панели Properties, когда размещенная маска компиляции выбрана в рабочей области.
Расположение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки объекта относительно текущего начала координат рабочей области. Измените значение, чтобы изменить положение объекта по оси X. Значение можно вводить в метрических или дюймовых единицах; если используемые единицы отличаются от текущих единиц по умолчанию, укажите их при вводе.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки объекта относительно текущего начала координат. Измените значение, чтобы изменить положение объекта по оси Y. Значение можно вводить в метрических или дюймовых единицах; если используемые единицы отличаются от текущих единиц по умолчанию, укажите их при вводе.
Свойства
- Width — введите ширину объекта.
- Height — введите высоту объекта.
- Border — выберите нужную границу в раскрывающемся списке.
- Fill Color — нажмите на цветовой образец, чтобы выбрать нужный цвет объекта.
- Collapsed and Disabled — установите флажок, чтобы свернуть и отключить объект.
Директивы, связанные с печатной платой
Будучи единой средой проектирования, Altium Designer позволяет определять требования к печатной плате еще до начала ее топологического проектирования. Для этого к объектам, размещенным на листах схемы, добавляют параметры и задают их значения.
Для некоторых объектов схемы, таких как компоненты, символы листов, порты и т. д., соответствующие параметры добавляются в свойства объекта. Для объектов цепей, таких как проводники и шины, параметры нельзя добавить непосредственно в свойства проводника или шины. Вместо этого параметры, необходимые для хранения этой информации, задаются с помощью специальных директив проектирования.
С помощью директив можно задать следующую информацию, которая при синхронизации проекта будет перенесена в соответствующие определения на печатной плате:
- Ограничения на топологию печатной платы
- Дифференциальные пары
- Классы цепей
Добавляя директивы проектирования на схему, инженеры могут явно задавать ограничения проектирования, при этом схема остается основным источником данных о проекте. Все изменения в проект вносятся только на стороне схемы, а затем передаются на печатную плату. Это особенно важно, когда над проектом работают несколько человек, в особенности если они находятся в разных местах. Вместо обмена длинными цепочками электронных писем или телефонных звонков разработчик схемы может гарантировать, что заданные ограничения действительно будут применяться при разработке топологии.
В основе этой функциональности лежит директива Parameter Set.
По сути, это пользовательские объекты наборов параметров, которые можно связывать с объектами цепей на схеме. Разместите директиву PCB Layout на проводнике, шине или сигнальном жгуте, чтобы задать одно или несколько ограничений проектирования для соответствующих цепей. При создании печатной платы на основе схемы информация из директивы PCB Layout используется для создания соответствующих правил проектирования печатной платы. Информация, заданная директивой PCB Layout, применяется только к той цепи или группе цепей, к которой подключена директива.
Она служит контейнером для любого количества параметров, относящихся к цепи, к которой подключена директива Parameter Set. Можно разместить стандартную директиву Parameter Set без параметров (Place » Directives » Parameter Set) и добавить необходимые параметры позже. В следующих разделах подробнее рассматривается использование этих директив на основе параметров. Доступны как пользовательские (Parameter Set), так и предопределенные (Differential Pair) директивы наборов параметров. Единственное отличие пустого набора параметров от предопределенного заключается в том, что предопределенный набор уже содержит параметр, как описано ниже.
Набор параметров
Общие сведения
Набор параметров — это директива проектирования, позволяющая связывать требования к проекту с объектом цепи на схеме. Например, с помощью набора параметров можно объявить две цепи участниками дифференциальной пары. Именно по наличию параметров с определенными именами в наборе программа определяет, какую директиву проектирования вы размещаете.
Доступность
Наборы параметров доступны для размещения только в редакторе схем. Доступны как стандартные (пустые), так и предопределенные (Differential Pair) директивы наборов параметров. Единственное отличие пустого набора параметров от предопределенного заключается в том, что предопределенный набор уже содержит параметр, как описано ниже.
Соответствующие команды доступны в главном меню Place:
| • | Place » Directives » Parameter Set | |
| • | Place » Directives » Differential Pair | |
Размещение
Набор параметров позволяет привязать параметры к следующим объектам:
- Проводник
- Шина
- Сигнальный жгут
- Символ листа
После запуска команды курсор примет вид перекрестия и включится режим размещения директив проектирования. Для размещения выполните следующие действия:
- Наведите курсор на проводник или другой объект цепи и щелкните мышью либо нажмите Enter, чтобы разместить директиву.
- Продолжайте размещать директивы либо щелкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима размещения.
Во время размещения, пока набор параметров привязан к курсору, доступны следующие дополнительные действия:
-
Нажмите клавишу Tab, чтобы приостановить размещение и перейти в режим Parameter Set панели Properties, где можно изменить свойства объекта на лету. Чтобы продолжить размещение, нажмите кнопку паузы, отображаемую поверх рабочей области
-
Нажмите клавишу Alt, чтобы ограничить перемещение горизонтальной или вертикальной осью в зависимости от начального направления движения.
-
Нажмите Spacebar, чтобы повернуть дугу против часовой стрелки, или Shift+Spacebar, чтобы повернуть ее по часовой стрелке. Это действие также можно выполнять при перетаскивании объекта. Поворот выполняется с шагом 90°.
-
В режиме размещения нажмите клавишу X или Y, чтобы зеркально отразить набор параметров по оси X или Y.
Графическое редактирование
Этот способ редактирования позволяет выбрать размещенную директиву набора параметров непосредственно в рабочей области и изменить ее положение или ориентацию графически.
При выборе директивы набора параметров в рабочей области вокруг нее появляется пунктирная рамка. Рамка охватывает только область, занимаемую самой директивой. Для каждого параметра набора, отображение которого включено, будет видна пунктирная линия, соединяющая текстовое поле параметра с телом директивы и подтверждающая их связь:
Щелкните в любом месте внутри пунктирной рамки и перетащите набор параметров в нужное положение. Во время перетаскивания набор параметров можно поворачивать (Spacebar/Shift+Spacebar) или зеркально отражать (клавиши X или Y для отражения относительно оси X или Y).
Размер текстовых полей набора параметров (которые можно редактировать графически независимо от родительской директивы) можно изменить только с помощью параметра Style на странице Схема – Настройки по умолчанию диалогового окна Preferences. Поэтому при выборе любого из этих объектов маркеры редактирования не отображаются.
Щелкните в любом месте внутри пунктирной рамки и перетащите текстовый объект в нужное положение. Во время перетаскивания текстовый объект можно поворачивать (Spacebar/Shift+Spacebar) или зеркально отражать (клавиши X или Y для отражения относительно оси X или Y).
Если на странице Схема – Общие диалогового окна Preferences включен параметр Enable In-Place Editing, значение параметра можно редактировать непосредственно в рабочей области (за исключением параметров, добавленных в качестве правил). Выберите текстовый объект, затем щелкните по нему один раз, чтобы перейти к редактированию. Введите новое значение, затем щелкните за пределами текстового объекта или нажмите Enter, чтобы применить изменение.
Неграфическое редактирование
Доступны следующие способы неграфического редактирования.
Редактирование через диалоговое окно «Набор параметров» или панель «Свойства»
Panel page: Свойства набора параметров
Этот способ редактирования позволяет изменять свойства объекта набора параметров с помощью соответствующего диалогового окна Parameter Set и режима Properties панели.

Диалоговое окно Parameter Set на первом изображении и режим Parameter Set панели «Свойства» на втором изображении
После размещения открыть диалоговое окно Parameter Set можно следующими способами:
- Дважды щелкните по размещенному объекту набора параметров.
- Наведите курсор на объект набора параметров, щелкните правой кнопкой мыши и выберите Properties в контекстном меню.
Во время размещения открыть режим Parameter Set панели Properties можно нажатием клавиши Tab. После размещения набора параметров становятся доступны все параметры.
После размещения открыть режим Parameter Set панели Properties можно одним из следующих способов:
- Если панель Properties уже активна, выберите объект набора параметров.
- Выберите объект набора параметров, затем выберите панель Properties в меню кнопки Panels в правом нижнем углу рабочей области или выберите View » Panels » Properties в главном меню.
Редактирование нескольких объектов
Панель Properties поддерживает редактирование нескольких объектов: можно изменять значения свойств, одинаковые для всех выбранных объектов. Если несколько объектов одного типа выбраны вручную, через диалоговое окно Поиск похожих объектов или с помощью панели Filter либо List, значение поля панели Properties, которое не отображается в виде звездочки (*), можно изменить сразу для всех выбранных объектов.
Редактирование через панель List
Panel pages: Панели списков, SCH Filter
Панель List позволяет отображать объекты проекта из одного или нескольких документов в табличном виде для быстрого просмотра и изменения их атрибутов. В сочетании с соответствующей фильтрацией — с помощью нужной панели Filter или диалогового окна Поиск похожих объектов — она позволяет отображать только объекты, соответствующие активному фильтру, что обеспечивает более точный и эффективный выбор и редактирование нескольких объектов проекта.
Примечания
- При размещении директивы набора параметров по умолчанию она не содержит параметров. После размещения добавьте нужные параметры в разделе Parameters панели Properties .
- Директива набора параметров позволяет назначать цепи на схеме информацию для проектирования печатной платы. При создании печатной платы на основе схемы информация из набора параметров используется для создания соответствующих правил проектирования печатной платы. Информация, указанная в директиве набора параметров, применяется только к тем цепям, к которым она подключена.
- При добавлении директивы набора параметров к цепи на панели Properties этой цепи становятся доступны поля Power Net и High Speed. При обновлении документа печатной платы на основе схем предлагается добавить правило проектирования «Цепи питания» для каждой цепи с включенным параметром Power Net.
- Директивы класса цепей позволяют создавать пользовательские классы цепей на схеме. При создании печатной платы на основе схемы информация из директивы класса цепей используется для создания соответствующего класса цепей на плате. Чтобы включить цепь в класс цепей, прикрепите директиву набора параметров к соответствующему проводу или шине и добавьте класс, указав для него имя нужного класса. Для использования этой функции на вкладке Class Generation диалогового окна Параметры проекта должен быть включен параметр Generate Net Classes (для пользовательских классов).
- Если для цепи задана директива Net Class, то все правила проектирования печатной платы, также созданные этим объектом набора параметров, при передаче проекта в редактор печатных плат будут иметь область действия «Класс цепей».
- Директиву Net Class можно создать на основе размещенной директивы Parameter Set, добавив класс и задав в качестве его значения нужный класс цепей печатной платы.
-
Объект Blanket совместно с директивой Parameter Set также можно использовать для назначения классов компонентов и параметров компонентам, которые полностью находятся внутри области, заданной объектом Blanket. Для этого используйте пункты Component Class и Parameter в раскрывающемся меню кнопки Add в свойствах директивы Parameter Set, прикрепленной к объекту Blanket. Информация о классе компонентов и параметре будет передана в документ печатной платы проекта в ходе выполнения ECO при обновлении печатной платы.
Свойства набора параметров
Свойства объектов редактора схем — это настраиваемые параметры, определяющие внешний вид, содержимое и поведение размещенного объекта.
Свойства каждого типа объектов задаются двумя способами:
-
Pre-placement settings – большинство свойств объекта Parameter Set или те из них, которые логически можно задать заранее, доступны для редактирования в качестве настроек по умолчанию на странице Schematic – Defaults диалогового окна Preferences (открывается кнопкой
в правом верхнем углу рабочей области). Выберите объект в Primitive List, чтобы справа отобразились его параметры.
-
Post-placement settings – все свойства объекта Parameter Set доступны для редактирования в диалоговых окнах Parameter Set и на панели Properties, когда набор параметров выбран в рабочей области.
Расположение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки объекта относительно текущего начала координат рабочей области. Измените значение, чтобы изменить положение объекта по оси X. Значение можно ввести в метрических или дюймовых единицах; если используемые единицы отличаются от текущих единиц по умолчанию, укажите их при вводе.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки объекта относительно текущего начала координат. Измените значение, чтобы изменить положение объекта по оси Y. Значение можно ввести в метрических или дюймовых единицах; если используемые единицы отличаются от текущих единиц по умолчанию, укажите их при вводе.
- Rotation — выберите угол поворота в раскрывающемся списке.
Свойства
- Label — подпись набора параметров. При необходимости измените ее.
- Style — выберите стиль в раскрывающемся списке. Нажмите на образец цвета, чтобы открыть раскрывающуюся палитру, в которой можно выбрать цвет по умолчанию.
Параметры
- Grid — отображает Name и Value параметров, связанных с выбранным параметром. После добавления поля Name и Value можно редактировать. Чтобы задать имя Value, нажмите на поле и введите нужный текст. Поле Name можно изменить только в режиме Properties панели для объекта Parameter Set с помощью Ctrl+Click. При этом панель Properties открывается в режиме Parameter, где можно ввести нужное имя в поле Name. Используйте значок замка , чтобы заблокировать или разблокировать параметр в списке. Используйте значок глаза, чтобы показать или скрыть параметр. С помощью кнопки All и кнопок отдельных параметров в этой области можно отобразить все параметры, отдельные параметры или скрыть их все. Параметры отключены, когда соответствующие кнопки серые, и включены, когда кнопки синие.
-
Add — используйте раскрывающийся список, чтобы добавить класс нужного типа:
-
Net Class — выберите, чтобы добавить новый класс цепей.
- Component Class — выберите, чтобы добавить новый класс компонентов. Этот пункт доступен только в диалоговом окне Parameter Set или на панели Properties для объекта Parameter Set.
-
Diff. Pair Net Class — выберите, чтобы добавить новый класс цепей дифференциальных пар. Этот пункт доступен только в диалоговом окне Parameter Set или на панели Properties для объекта Differential Pair.
-
Parameter — выберите, чтобы добавить новый параметр.
-
Rule — нажмите, чтобы открыть диалоговое окно Select Design Rule Type, в котором можно выбрать тип нового правила После выбора типа правила и нажатия
откроется диалоговое окно Edit PCB Rule (From Schematic), где при необходимости можно отредактировать новое правило.
-
Нажмите значок карандаша , чтобы открыть диалоговое окно Edit PCB Rule (From Schematic) для редактирования выбранного элемента. Нажмите
, чтобы удалить выбранный элемент.
- Font Settings — нажмите на отображаемый шрифт, чтобы изменить его стиль. Этот параметр доступен только после добавления класса цепей, класса цепей дифференциальных пар, параметра или правила.
-
Other — если добавлен класс цепей, класс цепей дифференциальных пар, параметр или правило, нажмите, чтобы открыть раскрывающееся меню и изменить дополнительные параметры:
- Show Parameter Name – включите, чтобы отображать имя параметра.
- Allow Synchronization with Database – включите для синхронизации с базой данных.
- X/Y – введите координаты X и Y.
- Rotation – выберите угол поворота в раскрывающемся списке.
- Autoposition – установите флажок, чтобы включить автоматическое позиционирование.
Размещение директив набора параметров
Чтобы разместить директиву этого типа, выберите команду Place » Directives » Parameter Set в главном меню или в контекстном меню, вызываемом щелчком правой кнопкой мыши в рабочей области. При размещении директивы набора параметров по умолчанию в ней нет параметров. Набор параметров — это директива проектирования, позволяющая связать требования к проекту с объектом типа «цепь» на схеме. Например, с помощью набора параметров можно указать, что две цепи входят в дифференциальную пару. Программа определяет тип размещаемой директивы по наличию в наборе параметров с определенными именами.
Помимо пользовательских директив параметров, можно создать директиву параметра на основе правила в диалоговом окне Choose Design Rule Type, доступном в соответствующем параметру режиме панели Properties. Для этого выполните следующие действия:
-
Нажмите
Tabперед размещением набора параметров или дважды щелкните уже размещенную директиву набора параметров, чтобы отобразить ее свойства на панели Properties. -
Затем нажмите кнопку
в области Parameters панели Properties и выберите Rule в раскрывающемся списке, чтобы выбрать правило в диалоговом окне Select Design Rule Type.

Редактирование значения правила.
В диалоговом окне Select Design Rule Type выберите тип правила, которое нужно добавить в директиву в качестве параметра правила. Дважды щелкните тип правила, чтобы открыть соответствующее диалоговое окно Edit PCB Rule (From Schematic), в котором можно задать ограничения для правила.

Задание ограничений для выбранного правила.
В области Parameters будет указан выбранный тип правила вместе с заданными ограничениями. На следующем изображении показаны параметры правила ограничения ширины, заданные для директивы Parameter Set. Чтобы отобразить правило в рабочей области, щелкните значок видимости в области Rules.

Несколько ограничений правил, заданных для определенной цепи с помощью директивы набора параметров.
При передаче проекта на печатную плату в процессе синхронизации будут созданы соответствующие правила проектирования на основе информации, содержащейся в директиве. В имени каждого созданного правила используется слово Schematic, позволяющее определить источник этого правила.

Правила проектирования, созданные в документе печатной платы.
Размещение директив класса цепей
Директива класса цепей позволяет создавать пользовательские классы цепей на схеме. Чтобы разместить директиву класса цепей, выберите команду Place » Directives » Parameter Set в главном меню, а затем настройте набор параметров как директиву класса цепей, как описано в совете № 2 на странице команды. При создании печатной платы на основе схемы информация из директивы класса цепей используется для создания соответствующего класса цепей на плате. Чтобы включить цепь в класс, прикрепите директиву класса цепей к соответствующему проводу, шине или сигнальному жгуту, а затем задайте для параметра ClassName этой директивы имя нужного класса. Для использования этой функции необходимо включить параметр Generate Net Classes (для пользовательских классов) на вкладке Class Generation диалогового окна Project Options.
Если для цепи задана директива класса цепей, то при передаче проекта в редактор печатных плат областью действия всех правил проектирования платы, созданных этим же объектом набора параметров, будет класс цепей. Директиву класса цепей можно создать на основе размещенной директивы набора параметров, добавив класс и задав для него значение, соответствующее требуемому классу цепей печатной платы.
Важные требования к настройкам проекта
Чтобы наборы параметров, заданные на схеме, передавались на печатную плату, в диалоговом окне Options for PCB Project необходимо настроить следующие параметры:
- Включите параметр Generate Net Classes в области User-Defined Classes на вкладке Class Generation этого диалогового окна.
-
На вкладке Comparator этого диалогового окна установите режим проверки Differences Associated with Nets » Extra Net Classes в значение
Find Differences.

Для передачи директив набора параметров на печатную плату необходимо настроить два параметра проекта. Сначала включите параметр Generate Net Classes на вкладке Class Generation. Наведите указатель на изображение, чтобы отобразить вкладку Comparator, на которой нужно установить параметр Extra Net Classes в значение Find Differences.
При передаче проекта на печатную плату в процессе синхронизации будут созданы соответствующие классы цепей на основе информации, содержащейся в директиве.
Размещение директив Blanket
Директивы Parameter Set могут применяться только к конкретной цепи, к которой они подключены, однако в сочетании с директивой Blanket их область действия можно расширить на все цепи внутри области Blanket.
Разместите директиву этого типа, выбрав команду Place » Directives » Blanket в главном меню. При размещении области Blanket можно задать простую прямоугольную или многоугольную форму. Последняя позволяет точнее охватить нужные объекты цепей на листе.
Область Blanket определяет нужные цепи — разместите директиву Parameter Set в любом месте на границе области, чтобы применить требования к проекту к этим цепям. Чтобы директива на границе применялась к цепи под областью Blanket, связанный с этой цепью объект — вывод, порт, метка цепи, порт питания, сегмент провода/шины/жгута (включая оба конца) — должен находиться в пределах области Blanket. Обратите внимание: для идентификаторов цепей, таких как метки цепей, внутри области Blanket должна находиться точка привязки. Если входящие в группу цепи не переносятся в Parameter Set на плате ожидаемым образом, попробуйте скорректировать границы области Blanket.

Пример использования директивы Blanket для применения директивы Parameter Set к цепям внутри области Blanket.
Примеры использования директивы Blanket:
- Подключение директивы Parameter Set к объекту Blanket для применения ее параметров правил к каждой отдельной цепи, охватываемой этой областью Blanket.
- Подключение директивы Parameter Set к объекту Blanket для создания набора параметров Parameter Set, в который входят отдельные цепи, охватываемые этой областью Blanket.
- Подключение директивы Differential Pair к объекту Blanket для создания объектов дифференциальных пар на основе дифференциальных цепей в пределах этой области Blanket.
Область Blanket в сочетании с директивой Parameter Set также можно использовать для назначения классов компонентов и параметров компонентам, которые полностью находятся внутри области Blanket. Для этого воспользуйтесь опциями Component Class и Parameter в раскрывающемся меню кнопки Add в свойствах директивы Parameter Set, подключенной к области Blanket. Информация о классе компонентов и параметре будет перенесена в документ платы проекта в ходе выполнения ECO при обновлении платы.
Область Blanket
Прямоугольная и многоугольная области Blanket — к каждой подключена директива
Общие сведения
Blanket — это групповой объект-директива прямоугольной или многоугольной формы, размещаемый поверх группы цепей и/или компонентов. Директива (объект Parameter Set), примененная к области Blanket, будет действовать на все цепи и компоненты, охватываемые этой областью. При размещении области Blanket можно задать простую прямоугольную или многоугольную форму. Последняя позволяет точнее охватить нужные объекты цепей на листе.
Область Blanket действует на все цепи, которые:
- полностью находятся внутри области, заданной объектом Blanket, или
- имеют хотя бы одну подключенную конечную вершину провода / шины / жгута внутри области Blanket, или
- имеют метку цепи, подключенную к проводу / шине / жгуту, причем эта метка находится внутри области Blanket.
Для компонентов область Blanket действует на все компоненты, находящиеся внутри заданной ею области.
Директива, примененная к границе области Blanket (Place » Directive), например No ERC, Differential Pair или определенный набор параметров правил/классов Parameter Set, будет действовать на все цепи и компоненты, охватываемые объектом Blanket. Области Blanket можно отключать и скрывать.
Доступность
Области Blanket доступны для размещения только в редакторе схем. Чтобы разместить область Blanket:
- Выберите Place » Directives » Blanket в главном меню.
- Нажмите кнопку Blanket в раскрывающемся меню директив на Active Bar в верхней части рабочей области. Нажмите и удерживайте кнопку Active Bar, чтобы получить доступ к другим связанным командам. После использования команды она станет верхним элементом в этом разделе Active Bar.
- Щелкните правой кнопкой мыши в редакторе схем, затем выберите Place » Directives » Blanket.
Размещение
Чтобы разместить прямоугольную область Blanket:
- Запустите команду, как описано выше.
- Установите курсор в нужное положение, затем щелкните мышью или нажмите Enter , чтобы задать верхний левый угол.
- Установите курсор в нужное положение, затем щелкните мышью или нажмите Enter , чтобы задать нижний правый угол.
- Щелкните правой кнопкой мыши или нажмите Enter , чтобы завершить размещение.
- Продолжайте размещать области Blanket или щелкните правой кнопкой мыши либо нажмите Esc , чтобы выйти из режима размещения.
Чтобы разместить многоугольную область Blanket:
- Запустите команду размещения.
- Установите курсор в нужное положение, затем щелкните мышью или нажмите Enter , чтобы зафиксировать начальную точку области Blanket.
- Перемещайте курсор и щелкайте мышью или нажимайте Enter , чтобы последовательно зафиксировать сегменты, определяющие форму области Blanket.
- После размещения последнего сегмента щелкните правой кнопкой мыши или нажмите Esc , чтобы завершить размещение. Замыкать многоугольник не требуется: программа автоматически завершит фигуру, добавив необходимые сегменты для соединения начальной точки с последним размещенным сегментом.
- Продолжайте размещать области Blanket или щелкните правой кнопкой мыши либо нажмите Esc , чтобы выйти из режима размещения.
При размещении сегментов области Blanket доступны следующие дополнительные действия:
- Нажмите клавишу Tab, чтобы приостановить размещение и перейти в режим Blanket панели Свойства, где можно изменить свойства линии прямо в процессе размещения. Нажмите кнопку паузы, отображаемую поверх рабочей области , чтобы возобновить размещение.
- Нажмите Spacebar, чтобы изменить направление угла еще не зафиксированного сегмента.
- Нажмите Backspace для удаления ранее зафиксированного сегмента при задании многоугольной формы области Blanket. Последовательное нажатие Backspace удаляет предыдущие сегменты по порядку.
Графическое редактирование
Этот способ редактирования позволяет выбрать размещенный объект Blanket непосредственно в рабочей области и графически изменить его размер, форму или положение. При выборе объекта Blanket доступны следующие маркеры редактирования:
Выбранные прямоугольная и многоугольная области Blanket с маркерами графического редактирования.
Чтобы переместить границу области Blanket, нажмите и перетащите маркер редактирования в центре соответствующего сегмента.
Для прямоугольной области Blanket нажмите и перетащите угловой маркер редактирования, чтобы одновременно изменить ее размер по вертикали и горизонтали.
Чтобы переместить область Blanket, нажмите в любом месте ее контура вне маркеров редактирования и перетащите ее. Во время перетаскивания область Blanket можно поворачивать или зеркально отражать:
- Нажмите Spacebar, чтобы повернуть область Blanket против часовой стрелки относительно положения курсора. Shift+Spacebar поворачивает область Blanket по часовой стрелке относительно курсора. Поворот выполняется с шагом 90°.
- Нажмите клавишу X или Y, чтобы зеркально отразить область Blanket по оси X или Y относительно положения курсора.
Неграфическое редактирование
Доступны следующие способы неграфического редактирования.
Редактирование через диалоговое окно Blanket или панель Properties
Panel page: Свойства области Blanket
Этот способ редактирования использует соответствующий режим диалогового окна Blanket и режим панели Properties для изменения свойств объекта Blanket.
Диалоговое окно Blanket слева и режим Blanket панели Properties справа
После размещения открыть диалоговое окно Blanket можно следующими способами:
- Дважды щелкните размещенный объект Blanket.
- Наведите курсор на объект Blanket, нажмите правую кнопку мыши и выберите Properties в контекстном меню.
Во время размещения перейти в режим Blanket панели Properties можно нажатием клавиши Tab. После размещения области Blanket отображаются все параметры.
После размещения перейти в режим Blanket панели Properties можно одним из следующих способов:
- Если панель Properties уже активна, выберите объект Blanket.
- Выбрав объект Blanket, откройте панель Properties с помощью кнопки Panels в правом нижнем углу рабочей области или выберите View » Panels » Properties в главном меню.
Редактирование нескольких объектов
Панель Properties поддерживает редактирование нескольких объектов: можно изменять значения свойств, одинаковые у всех выбранных объектов. Если несколько объектов одного типа выбраны вручную, через диалоговое окно Find Similar Objects (Поиск похожих объектов) или с помощью панели Filter либо List, значение поля панели Properties, в котором не отображается звездочка (*), можно изменить для всех выбранных объектов.
Редактирование через панель List
Panel pages: Панели List, SCH Filter
Панель List отображает объекты проекта из одного или нескольких документов в табличном виде, что позволяет быстро просматривать и изменять их атрибуты. В сочетании с соответствующей фильтрацией — путем выбора типов объектов (с помощью параметров Include панели), использования соответствующей панели Filter или диалогового окна Find Similar Objects (Поиск похожих объектов) — она позволяет отображать только объекты, соответствующие активному фильтру. Затем свойства перечисленных объектов можно редактировать непосредственно на панели List.
Поддержка фильтрации
Для поиска объектов Blanket с помощью логических выражений запросов доступны два особенно полезных ключевых слова. Они дополняют набор других ключевых слов, используемых для поиска областей Blanket по их свойствам.
-
Collapsed— объект свернут (также полезно при поиске масок компиляции). Это ключевое слово находится в категории SCH Functions - Fields при использовании Query Helper (Помощник запросов). -
IsBlanket— проверяет, является ли объект областью Blanket. Это ключевое слово находится в категории SCH Functions - Object Type Checks при использовании Query Helper (Помощник запросов).
Создавайте логические выражения запросов для поиска и получения нужных областей Blanket в проекте. Примеры логических выражений запросов для поиска областей Blanket:
IsBlanket And Collapsed — находит все объекты Blanket, которые в данный момент свернуты.
IsBlanket And Not Collapsed — находит все объекты Blanket, которые в данный момент не свернуты.
Отключение области Blanket
После размещения области Blanket можно временно отключать, нажав на небольшой треугольник в левом верхнем углу Нажмите один раз, чтобы отключить и скрыть область Blanket; нажмите еще раз, чтобы включить ее снова. Это удобный способ управлять действием области Blanket, не удаляя ее из проекта полностью.
Свойства области Blanket
Свойства объектов редактора схем — это настраиваемые параметры, определяющие внешний вид, содержимое и поведение размещенного объекта. Свойства каждого типа объектов задаются двумя способами:
-
Pre-placement settings — большинство свойств объекта Blanket, а также свойства, которые логично задать заранее, доступны для редактирования в качестве настроек по умолчанию на странице Schematic - Defaults диалогового окна Preferences (открывается кнопкой
в правом верхнем углу рабочей области). Выберите объект в Primitive List, чтобы отобразить его параметры справа.
- Post-placement settings — все свойства объекта Blanket доступны для редактирования в диалоговом окне Blanket и на панели Properties, когда размещенная область Blanket выбрана в рабочей области.
Свойства
- Border Width — выберите нужную толщину границы в раскрывающемся списке.
- Стиль линии — выберите нужный стиль линии в раскрывающемся списке.
- Border Color — щелкните цветовой образец, чтобы выбрать нужный цвет границы.
- Fill Color — щелкните цветовой образец, чтобы выбрать нужный цвет заливки.
- Collapsed and Disabled — установите флажок, чтобы свернуть и отключить области Blanket.
Косвенные директивы (на основе параметров)
Директивы Parameter Set необходимы для объектов схемы, которые не могут содержать параметры. Для объектов, поддерживающих параметры, директивы проектирования можно применять косвенно, добавляя и настраивая их как параметры соответствующего объекта схемы. По сути, они представляют собой parameter-based directives.
Примеры использования директив на основе параметров — ограничение высоты определенного компонента или добавление ограничения зазора для всех объектов проекта. Необходимый параметр, задающий ограничение, добавляется к объекту как правило.
При синхронизации с печатной платой директивы на основе параметров, добавленные к объектам схемы, преобразуются в правила проектирования печатной платы. Область действия соответствующего правила определяется типом объекта, которому изначально был назначен параметр. В следующей таблице приведены поддерживаемые варианты соответствия параметров схемы областям действия правил печатной платы.
| Добавить параметр (как правило) к объекту... | Где... | Область действия правила печатной платы... |
|---|---|---|
| Вывод | на вкладке Parameters панели Properties в режиме Pin. | Контактная площадка |
| Порт | на вкладке Parameters панели Properties в режиме Port. | Цепь |
| Компонент | в области Parameters панели Properties в режиме Components. | Компонент |
| Символ листа | на вкладке Parameters панели Properties в режиме Sheet Symbol, если в области Source выбрано значение Local. | Класс компонентов |
| Символ листа устройства | на вкладке Parameters панели Properties в режиме Sheet Symbol, если в области Source выбрано значение Device. | Класс компонентов |
| Символ управляемого листа | в области Parameters панели Properties в режиме Sheet Symbol, если в области Source выбрано значение Managed. | Класс компонентов |
| Лист | на вкладке Parameters панели Properties в режиме Document Options. | Все объекты |
Во всех случаях процедура добавления параметра в виде правила одинакова. На соответствующей вкладке или в диалоговом окне выполните следующие действия:
- Добавьте параметр как правило.
- Выберите тип правила.
- Настройте ограничения для выбранного типа правила.
Задание классов компонентов
Аналогичным образом на схеме можно задать классы компонентов: добавьте параметр ClassName к нужным компонентам и укажите в качестве его значения имя требуемого класса. При переносе проекта на печатную плату будут созданы заданные классы компонентов.
Чтобы классы компонентов, заданные на схеме, переносились на печатную плату, в диалоговом окне Project Options необходимо настроить следующие параметры:
- Включите параметр Generate Component Classes в области User-Defined Classes на вкладке Class Generation диалогового окна.
-
На вкладке Comparator диалогового окна установите для параметра Differences Associated with Components » Extra Component Classes Mode значение
Find Differences.
Указанный выше параметр вкладки Class Generation показан на изображении ниже. Наведите указатель мыши на изображение, чтобы увидеть настройку параметра на вкладке Comparator .

Чтобы классы компонентов переносились на печатную плату, включите параметр Generate Component Classes на вкладке Class Generation. Наведите указатель мыши на изображение, чтобы увидеть вкладку Comparator, на которой необходимо установить для параметра Extra Component Classes Mode значение Find Differences.
После задания классов их можно заблокировать в области Properties панели Properties свойств соответствующего компонента.
Управление печатью директив
По умолчанию при печати листов схемы выводятся все директивы проектирования. Однако это можно изменить:
- В диалоговом окне Schematic Print Properties при печати непосредственно из редактора схем или в рамках настроенного задания вывода в файле Output Job Configuration.
- В области Schematics include на странице Additional PDF Settings мастера Smart PDF Wizard.

Настройте печать директив в соответствии с вашими требованиями. Для директив No ERC можно выбрать, какие стили символов печатать, а какие исключить из печати.




).
).