Проектирование жестко-гибкой печатной платы — стандартный режим

Краткий обзор

В этой статье описаны основные этапы создания жестко-гибкой печатной платы в режиме Standard Rigid-Flex в Altium Designer: от настройки подстеков в диспетчере стека слоев (Layer Stack Manager) до определения контура платы, ее разделения на жесткие и гибкие области, а также размещения и редактирования линий сгиба в гибких областях. Основное внимание уделено практическому процессу работы в редакторе печатных плат: показано, где находятся нужные функции и на какие ключевые настройки и ограничения следует обращать внимание на каждом этапе. Если вам нужен четкий и структурированный обзор создания стандартного жестко-гибкого проекта и работы с ним в Altium Designer, это руководство поможет уверенно пройти весь процесс. Читайте далее.

- Как включить режим Standard Rigid-Flex и определить подстеки, необходимые для структуры вашей платы.
- Как создать и отредактировать контур платы, назначить стеки слоев областям и разделить плату на жесткие и гибкие области.
- Как размещать, настраивать и управлять линиями сгиба в гибких областях с учетом важных ограничений режима Standard.
Узнайте больше с ИИ:

Определение подстеков

Структура платы задается в менеджере стека слоев (Design » Layer Stack Manager). Здесь можно включить нужный режим проектирования гибко-жестких плат и определить подстеки, необходимые для вашей гибко-жесткой конструкции.

Определение подстеков:

  • Чтобы включить функции, необходимые для проектирования гибко-жесткой платы в стандартном режиме, выберите команду Tools » Features » Rigid-Flex в главном меню Layer Stack Manager.
  • Добавьте новый подстек, нажав кнопку  в верхней части Layer Stack Manager.
  • Установите или снимите флажок для каждого слоя, чтобы были включены только слои, необходимые в этом подстеке.
  • Задайте свойства подстека (например, Name и должен ли он быть гибким) на панели Properties.

► Подробнее: Определение подстеков — стандартный режим

Определение формы и областей платы

Форма платы определяет ее границы в редакторе печатных плат. Форма платы — это объект печатной платы (также называемый контуром платы), который по сути представляет собой замкнутый многоугольник. При создании нового документа печатной платы это черная область, отображаемая в рабочем пространстве редактора печатных плат.

Форму платы можно задать несколькими способами. В видео ниже показано использование контура, созданного из линий и дуг на механическом слое. После задания общего контура его разделяют на жесткие и гибкие области.

Определение формы и областей платы:

  • Форму платы можно задать интерактивно в режиме планирования платы (View » Board Planning Mode) или на основе существующего контура в режиме 2D-компоновки (View » 2D Layout Mode), как показано в видео выше.
  • Чтобы задать форму платы на основе существующего контура, выберите этот контур в режиме 2D-компоновки и выполните команду Design » Board Shape » Define Board Shape from Selected Objects. Программа пройдет по осевым линиям выбранных дорожек и дуг, чтобы определить внешнюю границу формы платы. Обратите внимание: концы дорожек и дуг контура должны совпадать, чтобы алгоритм обхода мог следовать по осевой линии. Если это не удастся, алгоритм предложит попробовать пройти по внешнему краю выбранных объектов.
  • Чтобы задать форму платы интерактивно, переключитесь в режим планирования платы (сочетание клавиш 1) и выберите команду Design » Redefine Board Shape. При определении формы платы действуют стандартные правила размещения объекта-области; используйте сетку привязки и направляющие рабочего пространства, чтобы упростить этот процесс. Включите параметр Board Shape в палитре параметров привязки, чтобы обеспечить максимальный контроль при редактировании формы платы. Подробнее: Принципы работы привязки.
  • Чтобы задать Name и назначить Layer stack для каждой области, дважды щелкните по области. Также можно переключить панель PCB в режим Layer Stack Regions, в котором можно просматривать и редактировать области и линии сгиба.
  • Чтобы разделить область платы на две меньшие области, используйте команду Design » Define Split Line. Эта команда размещает прямую линию между двумя точками, заданными щелчками мыши. При щелчке внутри формы платы первая точка будет расположена на ближайшем к месту щелчка краю платы. Переместите курсор, чтобы задать вторую точку, затем щелкните еще раз. Чтобы переместить вершину разделительной линии, нажмите на нее и, удерживая кнопку мыши, перетащите в новое положение.
  • Расположение и форму существующей области платы можно изменить. Выполните команду Design Design » Edit Board Shape, затем скорректируйте форму, используя стандартные приемы редактирования полигональных объектов.

► Подробнее: Планирование жестких и гибких областей — стандартный режим

Определение сгибов в гибкой области

После создания гибкой области в ней можно задать линии сгиба. Линия сгиба — это линейный объект, размещаемый поперек области.

Определение линии сгиба:

  • Линии сгиба размещаются в режиме планирования платы (сочетание клавиш 1).
  • Чтобы разместить линию сгиба, выполните команду Design » Define Bending Line.
  • Разместите линию сгиба поперек гибкой области платы. Необязательно точно совмещать начало и конец линии сгиба с краями области: программа автоматически удлинит линию, если она слишком короткая, или укоротит, если она слишком длинная. Хотя бы один конец линии сгиба должен касаться края области или выходить за него.
  • Чтобы изменить свойства линии сгиба, щелкните в любом месте внутри области, чтобы отобразить вершины всех линий сгиба в этой области, затем:
    • Дважды щелкните по вершине линии сгиба, чтобы открыть диалоговое окно линии сгиба, или
    • Откройте панель PCB и переключите ее в режим Layer Stack Regions, в котором можно просматривать и редактировать области и линии сгиба.
    • Задайте Bending Angle и параметр сгиба Radius в соответствии с требованиями.
    • Сгибы выполняются в порядке, определяемом их Fold Index; используйте эту возможность, когда важно проверить последовательность сгибания.
  • Чтобы переместить линию сгиба, перетащите каждую из ее вершин.
  • Чтобы удалить линию сгиба, нажмите на одну из ее вершин и, удерживая кнопку мыши, нажмите Delete на клавиатуре.
  • Линии сгиба нельзя размещать на краю выреза в плате. Если это требуется для вашей платы, переключитесь в расширенный режим проектирования гибко-жестких плат.

► Подробнее: Определение линий сгиба — стандартный режим

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents